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These release notes contain system requirements for the LabVIEW PDA 

Module software, installation and licensing instructions, a tutorial that 

guides you through building, running, and debugging PDA VIs, and known 

issues with the PDA Module.
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Required System Configuration

The PDA Module has the following requirements:

• LabVIEW 7.0

• One of the following PDA devices:

– A Palm OS device with Palm OS 3.1 or later. National Instruments 

recommends Palm OS 3.5 or later.

– A Pocket PC 2002 device.

• To debug a PDA VI on a PDA device, you must have a serial cable or 

serial cradle for your PDA device.

Installing the PDA Module

Complete the following steps to install the PDA Module.

1. If you are installing the PDA Module on Windows 2000/NT/XP, log in 

as an administrator or as a user with administrator privileges.

2. If it isn’t already installed, install LabVIEW 7.0 and the PDA software 

provided with your PDA device on the host computer. For Palm OS 

devices, the PDA software is Palm Desktop and HotSync. For Pocket 

PC 2002 devices, the PDA software is ActiveSync.

3. (Pocket PC 2002) Insert the Microsoft eMbedded Visual Tools CD 

into the CD-ROM drive. The Microsoft eMbedded Visual Tools 

installation program runs automatically.

If the Microsoft eMbedded Visual Tools installation program does 

not run automatically, you can run the installer by running 
X:\\setup.exe, where X is the CD-ROM drive on the computer.

4. (Pocket PC 2002) Select to install eMbedded Visual Tools 3.0 and 

Microsoft Windows SDK for Pocket PC 2002 and follow the 

instructions that appear on the screen.

5. Insert the PDA Module CD into the CD-ROM drive. The PDA Module 

installation program runs automatically.

If the PDA Module installation program does not run automatically, 

you can run the installer by running X:\\setup.exe, where X is the 

CD-ROM drive on the computer.

6. Follow the instructions that appear on the screen. When the installer 

completes, restart the computer.

7. (Palm OS) Use the Palm Desktop and HotSync software to install 

DatalogMgr.prc and Mathlib.prc, located in the  
\LabVIEW 7.0\PDA\Utilities directory, on the PDA device.
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Additional Sony Clié Installation Instructions
For Sony Clié devices, you must perform the following additional 

installation steps to obtain the Sony SDK 5.0.

1. On the host computer, create the Sony folder in the \Program 

Files\Metrowerks\CodeWarrior\Other SDKs\ directory.

2. Open a Web browser to www.cliedeveloper.com, click the Obtain 

Development Tools link, and click the Sony SDK 5.0 link.

3. After reading the agreement and if you agree, click the Agree link to 

download the cliesdk50e.zip.

4. When the download is complete, extract the contents of the 

cliesdk50e.zip file into the Sony directory you created in step 1.

Installing the PDA Emulator

Emulators are useful tools you can use during development to quickly 

run and test PDA VIs without having to download the PDA VI to the PDA 

device. The PDA emulator you use depends on the PDA platform you 

have installed.

Installing the Palm OS Emulator
Complete the following steps to install the Palm OS emulator.

Note If you are using a Sony Clié device, skip to the Installing the Sony Clié 

Palm OS Emulator and ROM Image section to install the emulator and ROM image.

1. On the host computer, create the \Program Files\Palm OS 

Emulator directory.

2. Navigate to the \LabVIEW 7.0\PDA\Utilites directory and extract 

the contents of the emulator35-win.zip file to the directory you 

created in step 1.

3. (Optional) Complete the following steps to enable the Palm OS 

emulator to access the USB port.

a. Navigate to the \Palm directory and copy USBPort.dll.

b. Navigate to the \Palm OS Emulator directory you created in 

step 1 and paste the copy of USBPort.dll.
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Transferring a ROM Image from a 
Palm OS Device to the Host Computer
You must have a ROM image to run the Palm OS emulator. A ROM 

image contains information about the capabilities of a Palm OS device. 

Palm OS emulators use ROM images to enable the emulator to behave 

like a Palm OS device. You can download ROM images from the Palm 

Web site, or transfer the ROM from a Palm OS device.

Complete the following steps to transfer a ROM image from a Palm OS 

device to the host computer for use with the Palm emulator.

1. Place the Palm OS device in the cradle and use the Palm Desktop 

and HotSync software to install the ROM Transfer.prc file you 

just extracted from the ZIP file onto the Palm OS device.

2. When the HotSync operation is complete, disable the HotSync 

Manager and any other applications that are using the serial port.

3. If the cradle is connected to the USB port, you must copy 

USBPort.dll, located in the Palm directory, to the Palm OS 

Emulator directory you created in step 1of the Installing the Palm OS 

Emulator section.

4. Run the ROM Transfer application on the PDA device and tap the 

Begin Transfer button.

5. On the host computer, double-click the emulator.exe and click the 

Download button. In the Transfer ROM dialog box that appears, 

select USB from the Port pull-down menu and click the Begin button. 

The transfer will take several minutes.

6. Save the ROM image on the host computer. You now can use this ROM 

image to run the emulator. Click the Exit button to leave the Palm OS 

Emulator.

7. Restart HotSync to be able to sync the Palm OS device with the host 

computer.

Installing the Sony Clié Palm OS Emulator and ROM Image
Complete the following steps to obtain the Sony Clié Palm OS emulator 

and ROM image.

Note You must register with Sony to obtain these files.

1. Open a Web browser to www.cliedeveloper.com, click the Obtain 

Development Tools link, and click the Palm OS Emulator link.

2. Click the Register link and follow the links to sign up for the Standard 

Program.
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3. When you receive your developer program ID by email, return to the 

link in step 1 and select the Palm OS Emulator link.

4. Enter the developer ID and password you received when you 

registered.

5. Follow the instructions on the Sony Web site to download the emulator 

and the ROM image.

Installing the Pocket PC 2002 Emulator
The Pocket PC 2002 emulator was automatically installed when you 

installed the Microsoft eMbedded Tools. The Pocket PC 2002 emulator 

launches automatically when you download a PDA VI to the Pocket PC 

2002 emulator from LabVIEW.

You also can launch the Pocket PC 2002 emulator when LabVIEW is not 

running. Complete the following steps to launch the Pocket PC 2002 

emulator outside of LabVIEW.

1. Navigate to \Win CE Tools\BIN and run CEFILEVW.EXE.

2. In the Windows CE Remote File Viewer that appears, select 

Connection»Add Connection.

3. In the dialog box that appears, select Pocket PC 2002 Emulation and 

click the OK button. The emulator launches in a new window.

Licensing the PDA Module

You must activate the license to build VIs that run on PDA devices. 

Complete the following steps to active the license for the PDA Module.

1. In Windows, select Start»Programs»National Instruments» 
NI License Manager.

2. In the left pane of NI License Manager, expand Software 

Licenses»LabVIEW»Version 7.0»Modules and right-click PDA 

Module and select Activate License.

3. In the NI License Wizard that appears, select No and click the 

Next button.

4. Enter your serial number, name, and organization in the fields 

provided and click the Next button.

5. Select the Auto option and click the Next button. The NI License 

Wizard automatically sends your registration information over a secure 

internet connection and activates the PDA Module license.

If you select Email, Phone, Fax, or Web as options, follow the 

instructions that follow to complete licensing the PDA Module.

6. Click the Finish button to exit the NI License Wizard.
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Note You also can activate the PDA Module license by selecting Tools»Build for PDA 

from an unlicensed installation of the PDA Module. When you attempt to build a PDA VI 

from an unlicensed installation of the PDA Module, a dialog box appears that allows you 

to open the NI License Manager.

PDA Module Tutorial

This tutorial shows you how to build, run, and debug a PDA VI.

Part 1—Building the VI on the Host Computer
The PDA Tutorial VI generates simulated data and saves the data to file. 

When you sync the PDA device with the host computer, the data files are 

copied to a directory you create, C:\PDAdata.

Complete the following steps to build the PDA Tutorial VI on the host 

computer.

1. On the host computer, create a new directory, C:\PDAdata. This new 

directory is where the PDA Tutorial VI will copy the data it collects 

when you sync the PDA device with the host computer.

2. Open LabVIEW. From the Execution Target pull-down menu, select 

PalmOS Device or a Pocket PC 2002 device.

3. Open a new VI using the PalmScreen or PocketPCScreen VI 

template by clicking the arrow on the New button and selecting 

PalmScreen.vit or PocketPCScreen.vit from the pull-down 

menu.

Tip You also can open the PalmScreen or PocketPCScreen VI templates by selecting 

File»New and selecting PalmScreen.vit or PocketPCScreen.vit and clicking the 

OK button.

Front Panel

1. Build the following front panel. Notice the controls and indicators are 

larger sizes than controls and indicators on VIs built for the LabVIEW 

for Windows execution target.

(Palm OS) Notice the standard Palm OS title bar. The VI Name 

automatically changes to the name of the PDA VI when you build the 

PDA VI.
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Block Diagram

1. Build the following block diagram. The TRUE and FALSE cases are 

shown in the following figures.

(Optional) Instead of building the block diagram, you can open the 

PDA Tutorial VI, located in the \examples\PDA directory, and skip 

to Part 2—Build the PDA VI.
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2. Save the VI to any location on the host computer as 

PDA Tutorial.vi.

Part 2—Build the PDA VI
Complete the following steps to build the PDA VI.

1. Select Tools»Build for PDA. The Build PDA Application dialog box 

appears. Set the Destination Directory to the same directory as the 

top-level VI.

If you want to build the PDA VI in another location, enter the path 

to the directory or click the Browse button and navigate to the 

directory where you want LabVIEW to save the PDA VI.

2. Click the OK button. LabVIEW builds the PDA VI, which is a 

.prc file for Palm OS targets or a.exe file for Pocket PC 2002 

targets.

Notice that the space in the filename PDA Tutorial.vi is replaced 

by an underscore ( _ ) character for the PDA VI file.

Part 3—Download the PDA VI
Complete the following steps to download the PDA VI to the PDA device.

1. On the host computer, select Operate»Download Application.

2. If you saved the PDA VI in the default directory (the same directory as 

the top-level VI on the host computer), (Palm OS) LabVIEW prompts 

you to press the HotSync button on the PDA cradle, or (Pocket PC 2002) 

LabVIEW automatically downloads the PDA VI to the Pocket PC 

2002 device.
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If you saved the PDA VI to another location, a file dialog box 

appears. Navigate to the (Palm OS) PDA_Tutorial.prc or  
(Pocket PC 2002) PDA_Tutorial.exe file and click the Open button.

Part 4—Run the PDA VI on the PDA Device
Complete the following steps to run the PDA Tutorial on the PDA device.

1. Remove the PDA device from its cradle.

2. Navigate to the PDA_Tutorial. Tap the icon to open the PDA VI.

3. Tap the Collect button. Notice the PDA_Tutorial begins displaying 

simulated data on the graph.

4. Tap the Save button. Notice the PDA_Tutorial stops collecting the 

simulated data.

5. Tap the Collect button again. Notice the PDA_Tutorial clears the graph 

and begins displaying another collection of simulated data.

6. Tap the Exit button. The PDA_Tutorial quits and returns you to the 

PDA operating system.

Part 5—Sync with the Host Computer
The way you synchronize data between the PDA and the host computer is 

different for Palm OS and Pocket PC 2002.

Synching with Palm OS Devices
Complete the following steps to sync data stored on the PDA device with 

the host computer.

1. Place the PDA in the cradle.

2. Press the HotSync button on the cradle. Palm OS connects the PDA 

device to the host computer and syncs the files.

3. After the HotSync is complete, navigate to the C:\PDAdata directory. 

Notice DatalogMgr copied the data files you created on the PDA to this 

directory.

Synching with Pocket PC 2002 Devices
Complete the following steps to sync data stored on the PDA device with 

the host computer.

1. Place the PDA in the cradle.

2. ActiveSync automatically syncs the data files on the PDA to the 
C:\PDAdata directory host computer.
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Part 6—Debug the PDA VI
To debug a PDA VI on the PDA device, you must connect the PDA device 

to the host computer using a serial cradle or serial cable.

Complete the following steps to debug the PDA VI.

1. On the host computer, enable debugging on the host VI by selecting 

File»VI Properties and placing a checkmark in the Allow debugging 

checkbox on the Execution page. Click the OK button.

2. Open the Build PDA Application dialog box by selecting 

Tools»Build for PDA.

3. Click the Settings button. In the dialog box that appears, place a 

checkmark in the Generate debug info checkbox. Click the OK 

button.

4. In the Build PDA Application dialog box, click the OK button to 

build the PDA VI. If a warning dialog box appears, click the OK 

button to confirm that you want to replace the existing file.

5. When the PDA Module finishes building the PDA VI, download the 

PDA_tutorial.prc or .exe file to the PDA device as you did in  
Part 3—Download the PDA VI.

6. With the PDA in the cradle, launch the PDA_Tutorial on the PDA 

device. A dialog box appears on the PDA that indicates the PDA device 

is waiting to connect to LabVIEW on the host computer.

To abort the connection, tap the Cancel button on the PDA device. 

The PDA VI runs as if it is not being debugged.

7. If it is not open already, open the PDA Tutorial VI on the host computer 

and set the execution target to the PDA device or emulator that you 

want to debug. Select any debugging tools you need—for this tutorial, 

add probes.

Note Execution Highlighting is not supported when debugging PDA VIs.

8. Run the PDA Tutorial VI on the host computer. LabVIEW on the 

host computer connects to the PDA device using the serial port and 

baud rate specified in the Target Settings dialog box.

Tip To modify these settings, select Operate»Switch Execution Target»Select Target 

with Options. Changing the baud rate to a higher setting increases the execution speed 

of the PDA device, but some settings can be incompatible with some PDA devices.

9. When LabVIEW on the host computer connects to the PDA VI, 

PDA_Tutorial runs on the PDA device. The front panel is fully 

functional on the PDA device, but any changes you make to the 
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front panel on the host computer have no effect on the execution of 

the PDA VI or the block diagram displayed on the host computer.

10. Notice the VI is running on the host computer and that the probes 

on the block diagram of the PDA Tutorial VI return values from 

PDA_Tutorial on the PDA device.

You can use additional debugging tools on the block diagram of 

the host computer while PDA_Tutorial runs on the PDA device.

11. To end the debug session and stop execution, tap the Exit button on 

PDA_Tutorial or click the Abort button on PDA Tutorial VI on the 

host computer. Notice the PDA Tutorial VI on the host computer stops 

when the PDA VI stops on the PDA device.

DAQ for Pocket PC 2002

You can perform data acquisition on Pocket PC 2002 devices using the 

DAQ for Pocket PC 2002 VIs.

To perform data acquisition on a Pocket PC 2002 device, you need a 

PC Card Expansion Pack for the Pocket PC 2002 device and one of the 

following National Instruments PCMCIA DAQ cards:

• DAQCard-6062E

• DAQCard-6024E

• DAQCard-AI-16XE-50

• DAQCard-AI-16E-4

The DAQCard-6062E is the only card that supports waveform analog 

output.

Caution Using a different PCMCIA DAQ card might damage the Pocket PC 2002 device.

Contact the manufacturer of your Pocket PC 2002 device for information 

about purchasing a PC Card Expansion Pack.

Installing DAQ for Pocket PC 2002
You must install DAQ for Pocket PC 2002 for each Pocket PC 2002 device 

on which you want to run PDA VIs that use the Pocket PC 2002 DAQ VIs. 

Complete the following steps to install DAQ for Pocket PC 2002.

1. Make sure the Pocket PC 2002 device is connected to the host 

computer.

2. On the host computer, open \LabVIEW 7.0\PDA\Utilities\ 

DAQ-PPC Installer and run setup.exe.
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3. In the dialog box that appears, click the OK button to install the files 

on the PDA device.

Note You also can set up the host computer to install the DAQ for Pocket PC 2002 files 

when the PDA is not connected to the host computer. When the PDA is not connected to 

the host system, the installer copies the files to the Mobile Device directory on the host 

computer. When you later connect the Pocket PC 2002 device, open the ActiveSync utility 

and tap Sync on the Pocket PC 2002 device. ActiveSync copies DAQ for Pocket PC 2002 

to the PDA and completes the installation.

You can uninstall DAQ for Pocket PC 2002 by running setup.exe and 

clicking the Uninstall button.

Known Issues with the PDA Module

The following are known issues with the PDA Module:

• You must use strict C code in Formula Nodes you use in PDA VIs. 

However, LabVIEW does not check the C code in the Formula Node 

syntax while in edit mode. If you build a PDA VI that contains a 

Formula Node with non-strict C code, the PDA Module returns a 

general error.

• Serial communication is not supported on Palm OS 3.1.

• The PDA Module does not work in non-English versions of 

Windows NT 4.0. The PDA Module works on non-English versions 

of Windows 2000/XP, but the software and documentation are not 

localized.

• (Palm OS Emulator) If you enter data into a string or numeric control 

using the keyboard in a PDA VI running on a Palm OS emulator, 

the emulator does not update the control until the control loses focus.

• (Palm OS Emulator) Running IrDA application on Palm OS emulator 

with the Palm OS 4.0 debug ROM crashes the emulator. Use the 

release version of the ROM to avoid the crash.

• (Palm OS 5 Simulator) You must complete the following additional steps 

to debug PDA VIs on the Palm OS 5 Simulator.

1. On the host computer, connect two serial ports to each other using 

a loopback cable.

2. In LabVIEW, select Operate»Switch Execution Target and 

select Select Target with Options.

3. In the Select Execution Target dialog box, select Palm OS 

Device as the execution target and select a COM port.

4. In the Palm OS Simulator, configure the other COM port to the 

Palm OS Simulator by right-clicking the Simulator window, 
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selecting Settings»Communication»Communication Ports, 

and selecting the COM port.

Differences and Known Issues with DAQ for Pocket PC 2002
The following are notable differences between the behavior of the 

DAQ for Pocket PC 2002 VIs and the DAQ 6.x Easy I/O VIs that they 

resemble. Also listed are know issues with DAQ for Pocket PC 2002:

• Automatic power off is unsupported. DAQ operations crash when the 

PDA powers off.

• DAQ for Pocket PC 2002 does not support interleaved analog output.

• DAQ for Pocket PC 2002 supports only counter 0 for counter/timer 

operations.

• Data acquisition in PDA VIs built for the Pocket PC 2002 emulator do 

not output actual data, regardless of whether the PDA VI is running on 

the emulator or on a Pocket PC 2002 device.

• DAQ for Pocket PC 2002 attempts to identify invalid configuration 

settings, but it cannot detect all errors. Verify the channel, counter, 

and min/max settings with the DAQ hardware manual.

• If an error occurs during processing, DAQ for Pocket PC 2002 

passes the error to error out and stops processing. This differs from 

traditional Easy I/O VI behavior, which displays a dialog box as soon 

as an error occurs. You must explicitly handle output errors for the 

DAQ for Pocket PC 2002 VIs to operate correctly. Use the PDA Error 

Handler VI to handle errors on PDA devices.

• DAQ for Pocket PC 2002 uses min/max settings to calculate optimal 

gain settings for the DAQ hardware. If the min/max settings do not 

exactly match the dynamic range of a particular gain setting, the 

effective range of the acquisition is larger than specified. While no 

data is lost, consider this behavior when you design PDA VIs that 

use DAQ for Pocket PC 2002.

• The AO Update Channel Chip VI is locked to bipolar operation.

• The AO Update Waveform Chip VI returns an obtained frequency.

• Because DAQ for Pocket PC 2002 does not use interrrupts, the output 

FIFO size of the DAQCard you are using constrains the maximum 

safe acquisition size that is guaranteed to succeed. Under certain 

conditions, the acquisition FIFO might underflow at rates of  

20,000 samples per second or greater.
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Where to Go from Here

The following documents contain information that you might find helpful:

• LabVIEW PDA Module User Manual, available in PDF format by 

selecting Start»Programs»National Instruments»LabVIEW» 
Module Documents»LabVIEW PDA Module User Manual.

• LabVIEW User Manual, available in PDF format by selecting 

Start»Programs»National Instruments»LabVIEW»Search the 

LabVIEW Bookshelf and clicking the LabVIEW User Manual link.

• LabVIEW Help, available by selecting Help»VI, Function, & 

How-To Help. Help specific to the PDA Module is available from 

the PDA Module book in the Contents tab of the LabVIEW Help.

• Documentation for the PDA device you use.

You must have Adobe Acrobat Reader with Search and Accessibility 5.0.5 

or later installed to view the PDFs. Refer to the Adobe Systems 

Incorporated Web site at www.adobe.com to download Acrobat Reader.
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