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LabVIEW  Datalogging and Supervisory 
Control Module Release Notes
Version 7.1

This document describes installation, known issues, new features, upgrade 

steps, and more for the DSC Module version 7.1. For recent information 

not included in these release notes, refer to the dsc_readme.html file in 

the LabVIEW directory.
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System Requirements

The DSC Module runs on any system with the following minimum 

specifications:

• Windows 2000/NT 4.0 or later/XP. The DSC Module requires that 

Windows NT include service pack 6a and the 6a Security Rollup 

Package, which are part of the July 26, 2001 security update available 

at www.windowsupdate.com. LabVIEW 7.1 does not support 

Windows Me/9x.

• 800 MB of disk space to install LabVIEW and the DSC Module 

and have swap space available. Increasing computer resources has 

a significant effect on performance of DSC Module applications. 

• Version 7.1 of the LabVIEW Full or Professional Development 

System. Refer to the LabVIEW Release Notes for LabVIEW system 

requirements.

Protecting Against Power Failure 
Power failure is a potential threat to system stability. If a computer loses 

power suddenly, data kept in memory is lost and files might be corrupted. 

The only effective protection against power failure is an Uninterruptible 

Power Supply (UPS). A UPS is a device that keeps the computer running 

for at least a short time when the primary power source is lost. It provides 

complete isolation between the AC power source and the computer and has 

backup battery power in case of power outages. If you do not need battery 

backup, you can use a quality surge protector to protect a computer from 

most electrical surges and spikes.

Compatibility Issues

The following sections describe compatibility issues for version 7.1 of the 

DSC Module.

VI Compatibility
If you are upgrading from a previous version of LabVIEW, existing VIs are 

automatically converted and compiled when you open them, and you are 

prompted to save. A VI saved in the DSC Module version 7.1 no longer 

loads in an earlier version.

Citadel Database Compatibility
The DSC Module version 7.0 introduced Citadel 5, a new version of the 

historical database. The current DSC Module logs to and retrieves from 

Citadel 5 databases only. You must convert Citadel 3.8 or Citadel 4.x 
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databases to Citadel 5 if you want to use them with version 7.1 of the 

DSC Module. Refer to the Converting Citadel 4.x Databases section of this 

document for information about converting databases.

NI-DAQ Software Compatibility
If you want to use NI-DAQ with version 7.1 of the DSC Module, you can 

use either Traditional NI-DAQ or NI-DAQmx, but not both at the same 

time. If you use Traditional NI-DAQ, you can use DAQ OPC. You cannot 

use NI-DAQmx with OPC. To use NI-DAQmx, you must use the DAQ VIs 

with memory tags. 

If you have trouble with a Traditional NI-DAQ application after upgrading 

to version 7.1 of the DSC Module, make sure the DAQ OPC server is 

installed. Perform a custom installation from the NI-DAQ installation CD 

to install DAQ OPC. The DSC Module installation CD does not include the 

DAQ OPC server.

Installation

Before You Install
Review the following list of issues before you install the DSC Module:

• You must install version 7.1 of the LabVIEW Full or Professional 

Development System before you install the DSC Module. If you 

reinstall LabVIEW 7.1 after installing the DSC Module, you must 

reinstall the DSC Module.

• Make sure that you meet the system requirements listed in the System 

Requirements section of this document and in the LabVIEW Release 

Notes.

• If you have a previous version of the DSC Module installed, either 

uninstall that older version or install version 7.1 in a different directory. 

Due to a change in Citadel, you must install a patch for version 7.0 of 

the DSC Module if you want to run both version 7.0 and 7.1 on the 

same computer. The patch for version 7.0 is located on the installation 

CD in the Simultaneous Operation Patch folder.

• If you want to preserve custom settings from a previous installation 

of the DSC Module, save all .ini and .cfg files in the LabVIEW 

directory to a backup location and then return them to the appropriate 

location after installing version 7.1. 
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• If you want to preserve custom images you have stored in Image 

Navigator, back up custom.cat files before upgrading to version 7.1 

of the DSC Module and then return them to the appropriate location 

after installing version 7.1. 

• If you have Microsoft SQL Server version 6.5 or earlier installed on the 

computer, you must upgrade to Microsoft SQL Server version 7.0 

or later before installing the DSC Module.

Installing the DSC Module
Complete the following steps to install the DSC Module.

1. Install LabVIEW 7.1 if you have not already done so. Refer to the 

LabVIEW Release Notes for information about installing LabVIEW.

2. After installing LabVIEW and before installing the DSC Module, 

restart the computer and log on as an administrator or as a user with 

administrator privileges.

3. Insert the DSC Module CD in the CD-ROM drive and follow the 

instructions that appear on the screen.

4. Restart the computer and log on as an administrator or as a user with 

administrator privileges. When you restart, you might have to wait for 

the MSDE setup to complete.

5. (Optional) Launch LabVIEW and change the default palette view 

to access the DSC Module palettes: select Tools»Options, select 

Control/Function Palettes in the pull-down menu, and choose the 

Advanced palette view. The DSC Module palette icon is shown at left.

Uninstalling the DSC Module
To uninstall version 7.1 of the DSC Module, select Start»Settings»

Control Panel»Add/Remove Programs. Select National Instruments 

Software and remove NI LabVIEW DSC Module 7.1.

New Features for Version 7.1

The following sections describe changes to existing features and new 

features added in version 7.1 of the DSC Module.

New Delete Database VI
Version 7.1 of the DSC Module includes a new Delete Database VI on 

the Historical Data palette. The Delete Database VI programmatically 

removes the logical connection between the DSC Module and a Citadel 

database, removes all Citadel-related files from their specified storage 
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location, and removes the database directory unless non-Citadel files exist 

there.

DataSocket Connection Enhancement
Version 7.1 of the DSC Module includes an enhancement to DataSocket. 

If a DataSocket client loses a connection to the DataSocket Server or 

cannot establish a connection to the DataSocket Server, the DataSocket 

Proxy attempts to reconnect every 60 seconds by default. The DataSocket 

Proxy can reconnect to the DataSocket Server automatically, and the Tag 

Engine does not need to be restarted. To use a reconnection interval other 

than 60 seconds, create a file named DataSocket.ini in the vi.lib\

lvdsc\servers\DataSocket Proxy directory. Create the following 

keys in the DataSocket.ini file:

ReadReconnection=x

WriteReconnection=x

where x is the reconnection interval in seconds.

Changes to the HMI Wizard for Historical Trends
The HMI Wizard behavior for the Historical Trend has changed slightly 

with version 7.1 of the DSC Module. Previously, when you used the HMI 

Wizard with a Historical Trend and selected Database Name as the Data 

Source of the tags, the HMI Wizard replaced \\computername\ in the 

trace path with \\localhost\ if computername matched the current 

computer. In version 7.1, the HMI Wizard does not automatically make this 

change. Traces appear exactly as they exist in the database. 

When Data Source is set to SCF File in the HMI Wizard for Historical 

Trends, a new Use ‘localhost’ in URL? checkbox is available. Place 

a checkmark in this checkbox to replace \\computername\ with 

\\localhost\ when Data Source is set to SCF File. If a checkmark 

exists in the Use ‘localhost’ in URL? checkbox and you switch between 

SCF File and Database Name, you might see tags in the Tag List marked 

as invalid. If you see a circle with a slash, shown at left, next to a tag in the 

Tag List, delete the tag and add it again to fix the problem. 
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New Features for Version 7.0

The following sections describe changes to existing features and new 

features added to version 7.0 of the DSC Module.

Citadel 5 Database
The DSC Module versions 7.0 and 7.1 include Citadel 5, a new version 

of the Citadel historical database. Citadel 5 introduces data access from 

ActiveX Data Objects (ADO) clients and improved Open Database 

Connectivity (ODBC) support.

Database Names
Citadel 4.x identified databases exclusively by their path. Citadel 5 uses 

database names. Because of the new Citadel 5 format, the Historical Data 

VIs have been modified, the Tag Configuration Editor uses a new .scf file 

format, the ODBC data source setup has changed, and the Historical Data 

Viewer has been updated.

Conversion to Citadel 5 Format
The DSC Module versions 7.0 and 7.1 log to and retrieve from Citadel 5 

databases only. You must convert Citadel 3.8 or 4.x databases to Citadel 5 

if you want to use them with the current DSC Module. Refer to the 

Converting Citadel 4.x Databases section of this document for information 

about converting databases.

Citadel 5 ODBC Data Source
As with Citadel 4.x, you must have an ODBC data source for Citadel 5 as 

described in the LabVIEW Help. However, the following changes have been 

made to the National Instruments Citadel ODBC Setup dialog box:

• ODBC setup asks for a Database URL instead of a database path. 

Database URL is the computer and database name where data for the 

source are stored—for example, \\computer_name\my_database. 

Use a Database URL that matches the existing local or remote 

database you intend to access.

• Use the ... button to browse local and remote databases.

• Use the Test Connection button to test the connection you are 

setting up.
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Expanded Access to Citadel 5 Data
The Citadel 5 ODBC driver is compliant with SQL 92 and ODBC 2.5 

standards. All clients that follow these standards can retrieve data from a 

Citadel 5 database. ADO clients can access the Citadel 5 database using the 

ODBC driver through the Microsoft OLE DB Provider for ODBC Drivers. 

You can use a Microsoft Query Wizard to build queries.

Creating a Data Link for the ODBC Data Source
If you want to access Citadel data from an ADO client, you need a data link 

to ODBC. You might be able to create the data link from within an ADO 

client, but you might be required to create it multiple times. Alternatively, 

complete the following steps to create a data link once that you can store on 

a system or network.

1. Create a Citadel 5 ODBC data source if you have not already done so.

2. Create a new text (.txt) document.

3. Right-click the new text document and rename it to have a .udl 

extension, for example data_link.udl. A warning might appear, 

explaining that changing file extensions might cause files to become 

unusable. Disregard this warning.

4. Right-click the .udl file and select Properties. In the dialog box 

that appears, click the Provider tab and select Microsoft OLE DB 

Provider for ODBC Drivers.

5. Click the Connection tab and select the Citadel 5 ODBC data source 

name.

6. Click the OK button.

Citadel 5 Tables
Citadel 5 tables are different than Citadel 4.x tables. For more information 

about Citadel 5 tables, refer to the Updating Citadel 4.x SQL Queries 

section of this document.

Storage and Security for Alarms and Events
Citadel 5 uses Microsoft SQL Server or MSDE 2000 (Microsoft SQL 

Server Desktop Engine 2000) to store alarms and events. MSDE 2000 

is a light version of Microsoft SQL Server. The major restriction of 

MSDE 2000 is that the size of one database is limited to 2 GB, so you must 

upgrade to the full version of SQL Server 2000 if an application exceeds 

this 2 GB limit. 

To connect to and access a remote SQL Server database, local and network 

clients can use one of two security modes: Windows Authentication Mode 

or Mixed Mode. Windows Authentication Mode security uses the built-in 
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Windows security system and takes advantage of Windows NT domains. 

All clients that need to access SQL Server remotely must be properly 

configured on the same domain to access data stored on remote SQL Server 

computers. Clients must connect through the Windows security system on 

the server. 

Mixed Mode security allows clients to connect to a server using either 

Windows Authentication or SQL Server Authentication. With SQL Server 

Authentication, all user accounts are stored within the SQL Server, and 

clients do not need to go through the built-in Windows NT security system. 

Mixed Mode security is simple to set up because clients need not be on the 

same domain. They only need to have the correct user name and password 

to access the SQL Server. However, SQL Server Authentication is more 

vulnerable than Windows Authentication Mode. 

Citadel 5 uses SQL Server Authentication by default, so network clients do 

not need to be explicitly configured. The DSC Module installer enables 

Mixed Mode security on existing SQL Servers or installs MSDE 2000 with 

Mixed Mode security if the target computer does not have SQL Server 

installed. 

The default password for the SQL Server administrator sa is left blank. 

NI recommends that you assign a strong password to the sa user. Use the 

following command line utility to set the SQL Server administrator 

password: 

osql -U"sa" -P"" -Q"sp_password NULL, 'new_password', 'sa'"

Use the following command to change an existing password:

osql -U"sa" -P"old_password" -Q"sp_password 'old_password', 

'new_password', 'sa'"

If Mixed Mode security is not acceptable, change both the SQL Server 

and Citadel login modes by setting the registry DWORD values 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQL

Server\LoginMode and HKEY_LOCAL_MACHINE\SOFTWARE\

National Instruments\Citadel\5.0\IntegratedSecurity to 1. 

This forces the use of Windows Authentication mode.

NI recommends changing the login mode immediately after installing 

the DSC Module. If you change the login mode after you have logged data, 

you must reattach all existing Citadel databases. Restart the SQL Server 

and Citadel services to implement the changes. If you use Windows 

Authentication Mode, remember that you might need to explicitly 

configure the server computer and all clients.
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Revised Historical Data VIs
Version 7.0 of the DSC Module introduced several changes to the VIs on 

the Historical Data palette:

• Doubles that were formatted as show date & time are replaced by the 

LabVIEW time stamp data type.

• Read Trace and Read Traces VIs are polymorphic for output trace type 

and include a new timeout parameter.

• Read Trace and Read Traces VIs allow interpolation. Previously, the 

interpolate through gaps parameter for the Read Trend and Read 

Trends VIs, if set to TRUE, removed gaps/breaks. The interpolate 

data subparameter in the options parameter now calculates 

interpolations, which can slow down data retrieval. To only remove 

gaps/breaks, use the remove data breaks subparameter of the option 

parameter instead of interpolate data.

• A maintain trending info option is included for the Read Trace and 

Read Traces VIs. If this option is set to TRUE, the returned trace 

includes the first data point before start timestamp and the last data 

point after stop timestamp. If the option is set to FALSE, the returned 

trace includes only points between the start and stop time stamp.

• The Detach Database VI allows you to programmatically remove the 

logical connection between the DSC Module and a Citadel database. 

You might want to detach a database to move or rename database files 

without causing errors. Also, you should detach all local databases 

before renaming the host computer. A detached database does not 

show up in the Citadel 5 Universe tree view in Historical Data Viewer.

• The Make Network Path VI and Split Network Database Path VI 

are no longer on a palette because the DSC Module no longer uses 

database paths.

• The VIs have new icons.

If you have a DSC Module 6.x application that uses the Historical Data VIs, 

you do not need to replace them unless you want to take advantage of the 

new functionality. However, previous Historical Data VIs are renamed 

automatically to Legacy_old_VI_name.vi when detected in version 7.0 

or 7.1.

Table 1.  Comparison of Historical Data VIs

Version 6.x VI Version 7.x VI

— Create Database

— Detach Database

— Delete Database (7.1 only)
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Archive Database Archive Traces

Call HTV Call HDV

Compact Database Compact Database

Decimate Historical Trend Decimate Trace

Decimate Historical Trends Decimate Traces

Delete Traces Delete Traces

Get Historical Tag List Get Trace List

Get Historical Trend Info Get Trace Info

Get Trace Names Get Trace List

Historical Trend Statistics Get Trace Statistics

Historical Trend to Spreadsheet Write Traces to Spreadsheet

Historical Trend to Spreadsheet File Write Traces to Spreadsheet File

Launch MAX HDV Call HDV

Make Database Network Path —

Read Historical String Trend Read Trace (String)

Read Historical String Trends Read Traces (String)

Read Historical Trend Read Trace

Read Historical Trend Read Trace (Bit Array)

Read Historical Trend Read Trace (Logical)

Read Historical Trend Read Trace (Numeric)

Read Historical Trends Read Traces

Read Historical Trends Read Traces (Bit Array)

Read Historical Trends Read Traces (Logical)

Read Historical Trends Read Traces (Numeric)

Rename Traces Rename Historical Data

Split Network Database Path —

Table 1.  Comparison of Historical Data VIs (Continued)

Version 6.x VI Version 7.x VI
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Revised Historical Alarm and Event VIs
Version 7.0 of the DSC Module introduced changes to several VIs on the 

Alarm & Events palette:

• The format of returned alarms provides additional data.

• The A&E Query to Spreadsheet VI allows either text or HTML output 

format, and you can define a header, footer, and delimiter.

• The alarm and event queries support more advanced filtering.

• The Make Network Path VI and Split Network Database Path VI 

are no longer on a palette because the DSC Module no longer uses 

database paths.

• The VIs have new icons.

If you have a DSC Module 6.x application that uses the Alarms & Events 

VIs, you do not need to replace them unless you want to take advantage of 

the new functionality. HIST Alarm & Event Query and HIST Alarm & 

Event Query to Spreadsheet File will be renamed automatically to 

Legacy_old_VI_name.vi when detected in version 7.0 or 7.1.

The legacy HIST Alarm & Event Query to Spreadsheet File VI no longer 

supports the timeout, table or multicolumn listbox, and colors 

parameters. If you wire values to any of these parameters, you get a warning 

that the features are no longer supported, along with any errors from the 

query. The new Alarm & Event Query to Spreadsheet File VI also does not 

support the timeout, table or multicolumn listbox, and colors parameters.

Table 2.  Comparison of Historical Alarm and Event VIs

Version 6.x VI Version 7.x VI

Acknowledge Alarm Acknowledge Alarm

Archive Alarms and Events Alarm & Event Archive

Get Alarm Summary Status Get Alarm Summary Status

HIST Alarm & Event Query Alarm & Event Query

HIST Alarm & Event Query to 

Spreadsheet File

Alarm & Event Query to 

Spreadsheet File

Make Network Database Path —

Read Alarm Summary Read Alarm Summary

Read Event History Read Event History

Read Tag Alarm Read Tag Alarm

Split Network Database Path —
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Revised Data Set Logger VIs
Version 7.0 of the DSC Module introduced several changes to the Data Set 

Logger VIs:

• database path in is now database URL.

• Doubles are replaced by the LabVIEW time stamp data type.

• A new timeout parameter is provided.

If you are updating a DSC Module 6.x application that uses Data Set VIs, 

you must right-click the VIs on the block diagram and choose to replace 

them with the legacy version available in legacy.llb in the vi.lib\

lvdsc\servers\Data Set Logger directory. The format of the legacy 

VIs is legacy_old_name.vi. These legacy VIs have the new 

functionality but use previous inputs and outputs.

If you are developing a new application, use the new Data Set VIs available 

on the palette.

Other VI and Palette Changes
Version 7.0 of the DSC Module introduced the following changes:

• DSC Module controls and VIs are accessible through the DSC Module 

icon, shown at left.

• The Tag control is located on the DSC Module controls palette rather 

than the I/O controls palette. 

• The Tags palette includes a Tag Name to DataSocket URL function.

• The Get Logging Status VI on the System palette has a logging 

databases parameter.

New Version of Historical Data Viewer
With the Historical Data Viewer that comes with versions 7.0 and 7.1 of the 

DSC Module, you can view both Citadel 4.x and Citadel 5 databases in 

Measurement & Automation Explorer (MAX). You also can convert 

Citadel 4.x databases to Citadel 5 format. In addition, navigation tools have 

been added for simpler viewing of data sets. 

Revised Historical/Event Logging Configuration
Citadel 5 databases are identified by names instead of paths. For Citadel 

databases that have not been converted to Citadel 5 format, the DSC 

Module creates a name for the database using its path and underscore 

characters.
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You must give each Citadel 5 database a unique name/path pair. For 

example, you can have a database named Db1 on multiple computers, but 

you cannot have two databases named Db1 on the same computer. Database 

name/path pairs are checked for conflicts when you configure historical or 

event logging and when the Tag Engine launches.

When you open a .scf file that was created in version 6.x of the DSC 

Module, you are prompted to convert the file and its associated databases 

to the current format. For more information about converting databases, 

refer to the Converting Citadel 4.x Databases section of this document.

Enhanced HMI Wizard for Historical Trends
When you right-click a Historical Trend and launch the HMI Wizard in 

version 7.0 or 7.1 of the DSC Module, you can select tags from either a 

database or a .scf file.

New Version of Image Navigator
The Image Navigator that comes with versions 7.0 and 7.1 of the DSC 

Module contains over 4,000 symbols. It includes many new symbols, new 

categories, improvements to existing graphics, broader support for various 

file types, and feature enhancements such as drag-and-drop.

Tag Monitor Enhancements
The Tag Monitor that comes with versions 7.0 and 7.1 of the DSC Module 

has the following additional features:

• New display columns for Tag Name and Read/Write Attributes

• New Type Mismatch Checking, XX for Bad Quality, Hex for Raw 

Data, Set Decimal Places, and Select Columns selections available in 

the Options menu

New Examples
Version 7.0 of the DSC Module introduced additional examples to help you 

develop applications and understand common DSC Module tasks. Select 

Help»Find Examples to access all examples in the NI Example Finder.

Online Documentation Enhancements
Version 7.0 of the DSC Module introduced a Bookshelf in PDF format so 

that you can search National Instruments product documents installed on 

a computer. To access the Bookshelf PDF, select Help»Search the DSC 

Module Bookshelf in LabVIEW. You must have Adobe Reader 

version 5.0.5 or later with Search and Accessibility to use the search 
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functionality. Refer to the Adobe Systems Incorporated Web site at 

www.adobe.com to download Adobe Reader.

The following LabVIEW Help updates were introduced in version 7.0 of the 

DSC Module:

• Use the LabVIEW Help to learn about the DSC Module features. You 

can access the LabVIEW Help by selecting Help»VI, Function, & 

How-To Help in LabVIEW.

• When you click an input or output parameter in the help, the help topic 

jumps to the description of the parameter in the scrolling region.

• Click either the Place on the block diagram button or Find on the 

Functions Palette button in a VI reference topic and switch back to 

LabVIEW to place the VI on the block diagram or view the VI on the 

palette.

Change in Bad Quality Status
The error status for application-defined quality is now a warning instead of 

an error. For example, a thermocouple out-of-range state from FieldPoint 

is now a warning and not a bad-quality error.

Changes to NI Services
Version 7.0 of the DSC Module introduced a new version of the Citadel 

service, which appears as National Instruments Citadel in Windows 

Services and nicitdl5.exe in the Task Manager. To start and stop this 

or other NI services, use Windows Services available in the Control 

Panel.

Change to Default Source of Time Stamps
By default in versions 7.0 and 7.1 of the DSC Module, time stamps logged 

to Citadel come from the system clock of the computer running the Tag 

Engine instead of from the server. To have time stamps come from the 

server, change the DSCEngine.ini setting Use Server Timestamps to 

TRUE. Because changing this setting can result in larger Citadel databases, 

NI recommends keeping the default value.
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Upgrading DSC Module 6.x Applications to 7.1

After installing version 7.1 of LabVIEW and the DSC Module, follow the 

instructions in this section to convert existing DSC Module applications.

Upgrading from Version 7.0
If you are upgrading an application built or run in version 7.0 of the DSC 

Module, you do not have to do any manual conversion work. When you 

open the application in version 7.1, LabVIEW automatically recompiles it. 

Converting Version 6.x .scf Files
When you use the Tag Configuration Editor to open a .scf file created in 

version 6.x of the DSC Module, a conversion wizard launches and leads 

you through the process of converting the .scf file. The wizard also gives 

you the option of converting existing Citadel 3.8 or 4.x databases that are 

associated with that .scf file. If the Tag Engine attempts to access a .scf 

file that you have not yet converted, an error message appears.

The conversion wizard saves a renamed backup of the original .scf file to 

the same location as the new, converted .scf file.

Converting Citadel 4.x Databases
The DSC Module versions 7.0 and 7.1 log to and retrieve from Citadel 5 

databases only. You must convert older databases to Citadel 5 if you want 

to use them with the current DSC Module.

Databases Associated with a .scf File
When you open a .scf file created in version 6.x of the DSC Module, 

a conversion wizard launches. After converting the .scf file, the wizard 

gives you the option of converting databases that are associated with that 

.scf file. 

Caution NI recommends using the default conversion options. If you must save the 

converted database to a location other than the default path due to a shortage of hard drive 

space, for example, you might need to make minor changes to the application.

To log new data to an existing database, do not log data until you convert 

the database to Citadel 5. If you log data from a converted application 

before converting the database, the DSC Module creates a new, empty 

Citadel 5 database in the same location as the older Citadel database and 
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logs data to that new database. To get all the logged data back into one 

database after that happens, you must use the Historical Data Viewer to 

convert the older Citadel database and then merge it with the new Citadel 5 

database.

Databases Not Associated with a .scf File
If you choose not to convert a Citadel database when the wizard asks you, 

or if you have an existing database that is not associated with a converted 

.scf file, you can convert the database using the Historical Data Viewer 

in MAX. In LabVIEW, select Tools»DSC Module»View Historical Data. 

In the window that opens, right-click the Historical Data category, select 

Create New from the shortcut menu, and choose the appropriate 

conversion in the dialog box that appears. If you cannot locate the database 

you want to convert, you might need to create a Citadel 4.x version of it in 

Historical Data Viewer before choosing to convert it to Citadel 5.

Remote Databases
You cannot convert a database remotely. You must convert it on the 

computer where it exists.

Converted Alarms
Alarm priorities logged by version 6.x of the DSC Module ranged from 

0–10, and those values are retained when converted to Citadel 5 format. 

Alarm priorities logged to Citadel 5 range from 0–15.

Redirecting NI HyperTrend and HTV to Citadel 5 Data
If you convert a Citadel database and an application that uses the 

NI HyperTrend control, right-click the control on the front panel and 

select the tags to display so that data is retrieved from the converted 

Citadel 5 database instead of the old Citadel database.

If you convert a Citadel database and an application that uses Historical 

Trend Viewer (HTV), launch HTV and select the tags to display so that data 

is retrieved from the converted Citadel 5 database instead of the old Citadel 

database.

Checking for Nondefault Citadel 4.x Conversion Issues
If you do not use the default values while converting a Citadel database, or 

if you rename a database after conversion, verify that any VI parameters 

such as Citadel path in, source Citadel path, database path, data 

directory, network path, and so on, point to the new database location or 

name.
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If you rename or move a .scf file after conversion and the application 

includes the Call HTV VI, verify that the scf path parameter of that VI 

points to the correct file location.

Creating a New ODBC Data Source
For information about creating an ODBC data source for Citadel 5, refer to 

the Citadel 5 ODBC Data Source section of this document. 

Updating Citadel 4.x SQL Queries
If you have existing SQL queries for retrieving Citadel 4.x data, you must 

convert them for use with Citadel 5. Refer to Tables 3 and 4, which detail 

the differences in Citadel 4.x and Citadel 5 queries.

For more information about each Citadel 5 database table, refer to 

Appendix A, Using SQL to Access Historical Data in a Citadel Database, 

of the LabVIEW Datalogging and Supervisory Control Module Developer 

Manual.

Table 3.  Changes in Citadel Tables

Citadel 5 ODBC Driver

Citadel 4.x 

ODBC 

Driver  Description 

Aliases N/A Aliases table is used to map alias names to actual 

tag names.

RawData Points RawData table is used to retrieve the actual values 

logged for a tag and times they were logged. 

You can query only one tag at a time.

IntData Traces IntData table is used to retrieve interpolated values. 

You can query more than one tag at a time. 

DS_RawData_dataset_name N/A DS_RawData_dataset_name table is used to 

retrieve the actual values logged for a tag, times, 

and particular data set where logged. You can query 

only one tag at a time. 

DS_IntData_dataset_name N/A DS_IntData_dataset_name table is used to retrieve 

the interpolated values for a particular data set. 

You can query more than one tag at a time.
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Citadel 5 Transform Functions
Transform functions have changed with Citadel 5, as shown in Table 4.

Table 4.  Changes in Transform Functions

Citadel 5 ODBC Driver 

Citadel 4.x ODBC 

Driver Description 

MATH_MIN(tag | 

TO_DISCRETE(tag) | 

TO_CONTINUOUS(tag)) 

MIN(tag) Returns the minimum for tag across the 

interval. 

MATH_MAX(tag | 

TO_DISCRETE(tag) | 

TO_CONTINUOUS(tag)) 

MAX(tag) Returns the maximum for tag across the 

interval. 

MATH_AVG(tag | 

TO_DISCRETE(tag) | 

TO_CONTINUOUS(tag)) 

AVG(tag) Returns the average for tag across the 

interval. 

MATH_STDEV(tag | 

TO_DISCRETE(tag) | 

TO_CONTINUOUS(tag)) 

STDEV(tag) Returns the standard deviation for tag 

across the interval. 

MATH_STARTS(tag | 

TO_DISCRETE(tag) | 

TO_CONTINUOUS(tag)) 

STARTS(tag) Returns the number of starts (that is, the 

number of transitions from OFF to ON) 

for tag across the interval. For numeric 

points, 0.0 is interpreted as OFF, and all 

other numbers are treated as ON. 

MATH_STOPS(tag | 

TO_DISCRETE(tag) | 

TO_CONTINUOUS(tag)) 

STOPS(tag) Returns the number of stops (that is, the 

number of transitions from ON to OFF) 

for tag across the interval. 

MATH_ETM(tag | 

TO_DISCRETE(tag) | 

TO_CONTINUOUS(tag)) 

ETM(tag) Returns the amount of time tag was in 

the ON state across the interval.

MATH_QUAL(tag | 

TO_DISCRETE(tag) | 

TO_CONTINUOUS(tag)) 

QUAL(tag) There might be gaps in the historical 

data traces in Citadel because of a 

computer shutdown, Tag Engine 

shutdown, or similar occurrence. 

MATH_QUAL returns the ratio of time 

for which valid data exist for tag across 

the interval to the length of the interval 

itself. If valid data exist for only 

one-half of the interval, MATH_QUAL 

returns 0.5. 
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Standard set functions (MIN, MAX, AVG, COUNT) are supported and you 

can use them on any Citadel 5 table. It is important to distinguish between 

set functions MIN, MAX, and AVG, and Citadel 5 transform functions 

MATH_MIN, MATH_MAX, and MATH_AVG. Set functions perform 

calculations on query results. Transform functions perform calculations on 

interpolation intervals.

Tag names are forced into an accepted format by replacing characters 

within the names with the characters in Table 5.

Long Tag Names and Aliases
Database tables and column names can be only up to 126 characters long 

and cannot contain some special characters. Some ODBC clients support 

names only up to 62 characters long. The database URL is not included in 

a tag or data set name. The Citadel 5 driver automatically generates alias 

names for tags or data sets whose names are longer than the Maximum 

Column Name Length value specified in the ODBC configuration dialog 

box. Alias names consist of a prefix and original tag or data set name 

substring, so the total length of the alias string is equal to the Maximum 

Column Name Length value. An alias prefix has the format 

~XXXXXXXXXXXXXXXX_ where XXXXXXXXXXXXXXXX is a 

64-bit tag or data set ID. 

TO_DISCRETE(tag) N/A Casts current tag type to discrete (that is, 

the tag is treated as discrete). 

TO_CONTINUOUS(tag) N/A Casts current tag type to continuous 

(that is, the tag is treated as continuous).

Table 5.  Special Access SQL Characters

Special Character Converted Character

period (.) at sign (@)

forward slash (/) backslash (\)

Table 4.  Changes in Transform Functions (Continued)

Citadel 5 ODBC Driver 

Citadel 4.x ODBC 

Driver Description 
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Reimporting FieldPoint Configuration

If you communicate with FieldPoint modules in a DSC Module application 

using the FieldPoint IAK server, sometimes referred to as the FieldPoint 

LabVIEW DSC Server or the FieldPoint VI-Based Server, complete the 

following steps after upgrading from version 6.x of the DSC Module.

1. Uninstall FieldPoint Explorer if you are using a version earlier 

than 3.0.1.

2. Download and install a more recent version of FieldPoint Explorer.

• If you install FieldPoint version 3.0.1 or 3.0.2, mass compile the 

FieldPoint IAK server (the contents of the <LABVIEW>\

_servers\FieldPoint folder), and export the configuration to 

the DSC Module by selecting BridgeVIEW»Export to 

BridgeVIEW from FieldPoint Explorer. 

• If you install FieldPoint version 4.0, save a backup of the .scf 

file and then revise it to use the FieldPoint OPC Server in one of 

two ways:

– Use the Tag Configuration Wizard to generate a new set of 

tags using the National Instruments.OPCFieldPoint server.

– Edit the configuration of each FieldPoint tag. On the 

Connection tab, change the Server Name to National 

Instruments.OPCFieldPoint. Add the tag to an I/O Group, 

and select the appropriate Item.

Special Upgrade Notes for BridgeVIEW Users

The following special topics apply when upgrading directly from 

BridgeVIEW to version 7.1 of the DSC Module.

Major Interface Changes
Whereas BridgeVIEW was a stand-alone software package, the DSC 

Module is an add-on to LabVIEW. The items on the BridgeVIEW Project 

menu now appear in the LabVIEW Tools»DSC Module menu. DSC 

Module tools are concentrated in this menu. The controls, indicators, VIs, 

and functions that come with the DSC Module are added to the LabVIEW 

Controls and Functions palettes. The Tag Engine, the next generation of 

the BridgeVIEW engine, is how the DSC Module manages data.

IAK/IAS Servers
NI recommends that instead of the old IAK (IAS) servers, you use the 

National Instruments Lookout Protocol Drivers OPC Server or the OPC 

servers for NI-DAQ, National Instruments FieldPoint, and National 
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Instruments Foundation Fieldbus. For more information about converting 

an application so that it does not use IAK (IAS) servers, refer to the 

NI Developer Zone at ni.com/zone.

Importing Tags
Open the Tag Configuration Editor and select File»Import Network Tags. 

In the dialog box that appears, you can browse to a .scf file on any 

computer on a network and import tags from that file into a local .scf file.

You also can use this dialog box to import tags from a remote computer 

using BridgeVIEW 2.x networking. This option is provided for 

compatibility with BridgeVIEW 2.x networking, but NI recommends 

converting to the latest National Instruments Logos networking when 

possible. To use Logos networking, either create new tags or update the 

connection information for each existing tag.

You also can access this option in the Tag Configuration Editor with 

BridgeVIEW compatibility preselected by selecting Configure»

Network»BridgeVIEW 2.x Networking»Import Network 

Configuration.

If you have enabled BridgeVIEW 2.x networking in the Tag Configuration 

Editor, the Advanced button on the Configure Network Access dialog 

box is enabled. Click this button in the dialog box to launch a Network 

Settings dialog box. These settings apply only to BridgeVIEW 2.x 

networking.

Converting Network Protocol
In the Tag Configuration Editor, select Configure»Network»Convert 

Network Protocol to convert the currently loaded .scf file from 

BridgeVIEW 2.x network tags to DSC Module Logos tags.

The DSC Module makes use of the Logos communications protocol, 

an internal National Instruments technology for rapid and reliable 

transmission of data across a network and between applications running 

on one computer. You might occasionally see the term Logos in data 

addressing and browsing activities, and you might find the term used in 

URLs for data connections.

Adjusting Security Levels
BridgeVIEW offered up to 255 security levels. The DSC Module offers 

11 levels, ranging from 0 to 10. The DSC Module does not depend 

on security levels, however, and discourages their use. Instead, NI 

recommends that you use access rights to configure access to controls 

and indicators.



© National Instruments Corporation 23 DSC Module 7.1 Release Notes

Importing Security User Accounts
You can import BridgeVIEW user accounts into the User Account 

Manager. If it is not already running, open the National Instruments User 

Account Manager by selecting Tools»DSC Module»Security»Edit User 

Accounts. Select User»Import BridgeVIEW User Accounts. A dialog 

box appears, asking you whether the user accounts you want to import are 

from BridgeVIEW 1.0, 1.1 or later, a BridgeVIEW 2.0 binary export, or a 

BridgeVIEW text export file. Select the correct option to complete 

importing the user information.

When the DSC Module User Account Manager imports user accounts from 

BridgeVIEW, it maps the security levels as shown in Table 6 and Table 7.

Table 6.  BridgeVIEW Default Security Level Conversions

BridgeVIEW Default 

Security Level

User Account Manager 

Security Level

0 0

25 1

50 2

100 4

150 6

200 8

255 10

Table 7.  BridgeVIEW Security Range Conversions

BridgeVIEW Security 

Level Range

User Account Manager 

Security Level

0 0

1–38 1

39–63 2

64–89 3

90–114 4

115–140 5

141–165 6

166–191 7
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Known Issues

For recent known issues not included in these release notes, refer to the 

dsc_readme.html file in the LabVIEW directory. Version 7.1 of the 

DSC Module has the following known issues. 

Installation

• If you install the DSC Module on a non-English version of Windows, 

the following error message appears:

(Error 1931. The windows installer service cannot 

update the system file <system path>\

mscpxl32.dll...)

This error appears because the DSC Module installs Microsoft Data 

Access Components (MDAC) version 2.7, but installing on a 

non-English version of Windows requires MDAC 2.7 service pack 1, 

available at the following location:

http://www.microsoft.com/downloads/details.aspx?Fam

ilyID=9ad000f2-cae7-493d-b0f3-ae36c570ade8&DisplayL

ang=en

• Due to a change in Citadel, you must install a patch for version 7.0 of 

the DSC Module if you want to run both version 7.0 and 7.1 on the 

same computer. The patch for version 7.0 is located on the installation 

CD in the Simultaneous Operation Patch folder.

• cwui.ocx cannot be registered on a Windows XP computer that has 

Crystal Reports 8 installed. Complete the following steps to work 

around the problem by granting the user full access to the cwui.ocx 

type library registry key and its subkeys.

1. Open the registry editor and select the cwui.ocx key, 

HKEY_LOCAL_MACHINE\SOFTWARE\Classes\TypeLib\

{D940E4E4-6079-11CE-88CB-0020AF6845F6}.

2. Select Edit»Permissions and select the appropriate user.

3. Click the Advanced button, click the Edit button, grant full 

control, and click the OK button.

192–216 8

217–242 9

243–255 10

Table 7.  BridgeVIEW Security Range Conversions (Continued)

BridgeVIEW Security 

Level Range

User Account Manager 

Security Level
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4. Enable the Replace permission entries on all child object 

switch entries shown here that apply to child objects option 

and click the OK button.

5. From a command prompt, run regsvr32 cwui.ocx to manually 

register cwui.ocx.

Data Logging and Retrieval

• When querying a large local database with many (hundreds of 

thousands) of data set runs in it, the Data Set Logger VIs might appear 

to hang before timing out. This delay is not an issue with remote 

queries. If necessary, use a timeout of –1 to prevent the apparent hang. 

Though this work-around solution allows other activity to continue, 

you still have to wait for the data query.

• NI cannot guarantee that all data is preserved after a computer crashes 

or the power fails. NI recommends that you use NTFS (NT File 

System) and uninterruptible power supplies for computers that are 

acquiring or logging data. 

• If you quit the Tag Engine using the Task Manager, the Citadel 

database can be corrupted.

• Database names cannot contain certain characters. They must contain 

only characters A–Z, a–z, 0–9, and the underscore character ( _ ).

• Periodically, you might see CPU usage at 100% due to Citadel and 

SQL services, even when no clients are present.

• Converting a large (2 GB or more) Citadel 4.x database to Citadel 5 

is slow.

• In Historical Data Viewer, A&E Views might not work after a 

destructive database archive.

• When changing an NI HyperTrend y-axis Minimum and Maximum, 

the Apply button does not work. Click the OK button to apply the 

change. When changing an NI HyperTrend x-axis Width, you must 

right-click the NI HyperTrend and select Restore X Axis Width from 

the shortcut menu to apply the change.

• If a remote database connection is lost while a client computer is in 

hibernation mode, an NI HyperTrend display on the client computer 

might hang.

• If you try to configure data sets when the Tag Engine is running, you 

can select tags only from the .scf file being used by the Tag Engine.

• If the network connection is lost during an archive operation to a 

remote computer, the operation times out and aborts instead of waiting 

for reestablished communication.
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OPC

• The DSC Module OPC server does not support non-Western 

character sets.

• You might experience a hang or error when attempting to launch 

NI-DAQ or the DAQ OPC server from a DSC Module application. 

A work-around solution is described in the NI KnowledgeBase on 

ni.com, Unusual Error Messages Loading, Executing, or Debugging 

an Application When Using NI-DAQ for Windows.

• In Server Explorer or Server Browser, browsing to remote OPC servers 

might not work for certain operating systems.

• Even when an OPC server has items off scan, the Tag Engine can 

connect to the items and the .scf file sets initial values for the items.

• The OPC Demo server might not correctly unload when the Tag 

Engine stops. Exit LabVIEW to unload the server.

• In Server Explorer, you might receive error 0x80080005 when trying 

to launch the OPC LabVIEW server.

• The Tag Engine might not shut down as expected after OPC clients are 

disconnected. If you lose a connection to the OPC Server and you try 

to shut down the Tag Engine on the client computer, the Tag Engine 

might appear to hang. However, the Tag Engine is not hanging in this 

case. It is waiting for the timeout period, which is about three minutes.

DSC Module VIs, Communication, and Dialog Boxes

• You cannot use the HMI Wizard with the digital waveform graph in 

LabVIEW.

• If data is being written to the Tag Engine while an application is 

reading a trend with a large number of samples (100,000 or more) 

in a tight loop, the read might fail.

• When you attempt to start or stop the Tag Engine from the Engine 

Manager window, certain error messages might be placed under the 

Engine Manager window where you cannot see them.

• With extrapolate to now set to TRUE and interpolate through gaps 

set to FALSE, the legacy Read Historical Trend(s) VIs extrapolate the 

last good value to now, even if the tag status has gone bad.

• A Can’t connect to Lookout error occurs if you use the HMI Wizard 

to create a front panel DataSocket item and the VI is set to run when 

opened. To avoid this error, first open LabVIEW and then open and run 

the VI.

• The DSC Module might not correctly report bad status for 

disconnected or unavailable FP-1600 modules.

http://digital.ni.com/public.nsf/MainPage?OpenForm&node=133020_US
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• Tag control values might reset to 0 instead of the LabVIEW default 

value, last value held, or last value logged.

• The Tag Status Handler VI does not support positive user-defined error 

codes. If a user-defined error code has a positive value, the default 

LabVIEW error message is used.

• The polymorphic Read Trace VI might not automatically change type 

when you wire in a certain data type. To select the correct type, 

right-click the VI on the block diagram and choose Select Type from 

the shortcut menu.

Tag Monitor
In Tag Monitor, denying read privileges causes a quality of access denied 

for write-only tags. The read/write column values also might not be 

accurate.

Examples

The Trend-Flow VI of the Heat Exchanger example includes a hard-coded 

database URL on the block diagram. If you install the DSC Module to any 

location other than the default location, clicking the Flow (Water & Air) 

button on the front panel fails to populate the report screen with data. To 

fix this problem, correct the database URL in Trend-Flow.vi, located 

in Heat Exchanger.llb.

More Information and Updates

For information on DSC Module updates and changes in the future, 

visit ni.com/labviewdsc.

To download the newest NI patches and other updates, visit 

ni.com/downloads.
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