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Lookout  Release Notes
Version 5.1

Welcome to Lookout 5.1, the National Instruments human machine 

interface (HMI) and supervisory control and data acquisition (SCADA) 

software system. This document describes installation, new features, and 

known issues. 

For detailed information on the new features in Lookout 5.1, consult your 

online and printed documentation. For the latest information not included 

in this document, refer to the readme.txt file on your Lookout CD.
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System Requirements

Lookout requires the following:

• Pentium class or equivalent PC running at 90 MHz or faster

• At least 32 MB RAM

• 65 MB free disk space, plus possibly 100 MB or more, depending 

on how much historical data you intend to log to the Citadel storage 

system; you should also have about 50 MB of disk space for file 

swapping on Windows 2000/NT/XP computers

• Windows 2000, Windows NT version 4.0 (with Service Pack 6), 

Windows XP, or Windows Me/98; National Instruments strongly 

recommends using Windows 2000/NT/XP for optimum stability

• Monitor display setting of at least 800 × 600 pixels

• Network card and TCP/IP networking installed on the computers 

you want to connect, if you intend to take advantage of Lookout 

networking

Note Performance of Lookout depends on the number, size, and complexity of processes 

you are running. While the minimum requirements are fine for some processes, you should 

plan on using more powerful computer configurations for complex and data intensive 

applications.

• You must be properly set up on a network with TCP/IP protocols 

installed if you want to use the networking capabilities of Lookout. 

You must be able to ping any computer on your network that you 

intend to have as a part of your Lookout network. To test this, access 

a command prompt and enter the following command:

Ping compname

where compname is the name of the computer you want to ping.

If TCP/IP is functioning properly on your computer, you should 

receive a response that looks something like the following example:

Pinging compname [123.45.67.89] with 32 bytes of 

data:

Reply from 123.45.67.89: bytes=32 time<10ms TTL=128

Reply from 123.45.67.89: bytes=32 time<10ms TTL=128

Reply from 123.45.67.89: bytes=32 time<10ms TTL=128

Reply from 123.45.67.89: bytes=32 time<10ms TTL=128

If TCP/IP is not working properly on your computer, consult your system 

administrator. Refer to the Lookout Developer’s Manual for more 

information on networking and network configuration with Lookout.
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Tip If your computer does not have a command prompt available in the Windows Start 

menu or in Start»Programs, select Start»Run and enter command.com in the Run dialog 

box. This opens a command prompt you can use for the ping command.

Installation

Installing Lookout is more than just copying files to your computer. 

You must register Lookout for long-term use of your I/O points, and for 

instances of Lookout that are intended to run server processes, you also 

must register to activate your client connections. There are also a number 

of Lookout system configuration options you should set when you install. 

If you plan on networking with Lookout, you also should test to make sure 

TCP/IP is present and running on all the computers you intend to use.

For detailed information about requirements, installation steps and options, 

registration, keycodes, and licenses, refer to Chapter 1, Introduction to 

Lookout, of the Lookout Developer’s Manual.

Installing onto Computers with Existing Versions of Lookout
• (Lookout 3.8 or earlier) Avoid installing Lookout 5.1 over Lookout 3.8 

or earlier. Either uninstall Lookout 3.8, or put Lookout 5.1 in a new 

directory. You can then move or copy Lookout 3.8 process files 

to the Lookout 5.1 directory. 

• (Lookout 4.0 or later) You can run these versions and Lookout 5.1 on the 

same computer. 

Installing
Complete the following steps to install Lookout:

1. Run the Lookout setup.exe. If you are installing from a Lookout 

CD, insert the CD in your CD-ROM drive. If your computer has the 

AutoPlay feature enabled, the installation begins automatically. If your 

system does not use AutoPlay, run x:\Lookout\setup.exe where 

x is the letter of your CD-ROM drive.

2. Follow the onscreen instructions. 

3. Reboot your computer. 

Registering Lookout
If you purchased a previous version of Lookout from National Instruments, 

your earlier registration keycode will work to maintain your I/O licensing. 

However, you must register your client connections separately. Get your 

client connection keycode (and an upgraded I/O point keycode as well, if 

necessary) by registering Lookout with National Instruments. Refer to 
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Chapter 1, Introduction to Lookout, of the Lookout Developer’s Manual for 

more information about registering Lookout and getting your keycode. 

Otherwise, you can use Lookout unregistered, which limits you to 

50 I/O points for 30 days.

Uninstalling Lookout
To uninstall Lookout, select Start»Settings»Control Panel»

Add/Remove Programs. Select National Instruments Software and 

choose to remove NI Lookout 5.1.

What’s New in Lookout 5.1

The following additions and changes are included in Lookout 5.1.

Support for International Character Sets
Lookout 5.1 supports international character sets such as Chinese, Korean, 

and Japanese, as follows:

• Text constants such as popup messages, descriptions, and labels 

support international characters.

• Tag values or data member values support international characters. 

Multi-byte character strings can be transferred from one object to 

another.

• Text values for data logging support international characters. 

Descriptions for alarms and events, including prefix and suffix, support 

international characters. However, alarm Area names do not. Logged 

international characters are stored in the Citadel historical database, 

and you can query this historical data in Lookout or using third-party 

ODBC clients. 

• Parameters in Lookout text functions, such as Find(), support 

international characters.

• Lookout file and path names support international characters. 

However, Windows does not allow international characters as part of a 

computer name. Also, Citadel database logging paths cannot contain 

international characters.

• International characters cannot be used in any string that might be part 

of a tag name, including the name of a tag, process, object, folder, data 

member, or alias. For more information about valid tag names, refer to 

the naming guidelines in the Steps to Create an Object section of 

Chapter 5, Creating Lookout Processes, of the Lookout Developer’s 

Manual.
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• The Alarm Filters dialog box supports international characters in each 

field. However, if you input international characters in any field other 

than Description, no alarms will match your selection.

• Both the DataTable and SQLExec objects support international 

characters in SQL commands.

• The Spreadsheet object supports international characters for both file 

names and data fields.

• User Account Manager does not support international character sets, 

so user names, group names, and passwords must not include 

international characters.

• Text expressions support international characters.

• DDE text, with either a DDE server or client, supports international 

characters.

Function Browser Tool
The new function browser feature allows you to browse for Lookout 

operators and functions instead of manually typing them into a field. 

The function browser is available in two locations:

• When you choose Insert»Expressions, the Edit Expression dialog 

box appears with a new Functions button. 

• When you choose Object»Edit Connections, the Edit Connections 

dialog box appears with a Functions button. 

Place your cursor in the expression field where you want to paste a function 

or operator. Click the Functions button in this dialog box to open the 

function browser dialog box. When you choose a function or operator and 

click OK, your selection is pasted in at the current cursor position. 

The function browser dialog box is shown in the following illustration.
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Tracer Object
Use the new Tracer object as a debugging tool to monitor and log Lookout 

messages passed from one object to another. The Tracer object reports 

every message connected to the From and To data members. You can 

monitor entire processes, all the objects in a folder, or a single data 

member. You can log these messages to a text file. For more information 

about the Tracer object, refer to the Lookout Help.

Hitachi_EH150 Object
Use the Hitachi_EH150 object to communicate with Hitachi EH-150 series 

devices using the serial or Ethernet protocol. For more information about 

the Hitachi_EH150 object, refer to the Lookout Help.

OPCClient Object Compatibility with OPC 2.0
The OPCClient object is now compliant with OPC version 2.0 and can be 

used with either version 1.0 or 2.0 of the OPC specification. The OPC 

Version parameter allows you to choose between OPC server versions 

1.0 or 2.0. 

Using the new Reconnect Automatically parameter, you can configure the 

OPCClient object to reconnect after the ServerDown data member goes 

HIGH. For more information about the OPCClient object, refer to the 

Lookout Help.
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Toshiba Object OffHook Data Member
The ToshibaMseries and ToshibaTseries objects include a new OffHook 

data member. You can use the OffHook data member to have the PLC 

retain exclusive use of its assigned communication port. For more 

information about the Toshiba objects, refer to the Lookout Help.

$Alarm Object ClearEvent Data Member
The $Alarm object has a new data member, ClearEvent, that clears events 

in the Alarms Window programmatically when it transitions from False to 

True. For more information about the $Alarm object, refer to the Lookout 

Help.

ModbusOmni Object ASCII Data Members
The ModbusOmni object includes new 4001–4999 ASCII data members. 

For more information about the ModbusOmni object, refer to the Lookout 

Help.

Mitsubishi FX Object Expanded Data Member Range
The Mitsubishi FX object’s D0–D2999 data member has been expanded to 

D0–D7999. For more information about the Mitsubishi object, refer to the 

Lookout Help.

FieldPoint Object New Data Members
The FieldPoint driver object includes new data members to support the 

latest FieldPoint hardware modules. For more information about the 

FieldPoint object, refer to the Lookout Help.

Known Issues

The following known issues exist for Lookout 5.1. Internal tracking codes 

are shown in parentheses for applicable issues.

User Cannot Change Passwords
Lookout 3.8 allowed users to change their own passwords. With 

Lookout 4.x and later, users cannot change their own passwords. However, 

if an Administrator sets up the password to expire, the user is prompted to 

change the password when it expires. (2UQDTDE9)
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Pushbutton Behavior with Lookout WebBrowser
If a Pushbutton is connected to the saveAs data member of the Lookout 

WebBrowser ActiveX, it stays pressed in when you click it. To release it, 

click it again. (2V5DL402)

Deleting Objects in Connection Browser Causes Crash on 
Windows 98/Me

Deleting an orphan object at the bottom of the Connection Browser can 

crash Lookout. To avoid a crash, you can delete the object from Object 

Explorer. (2UN2RK00)

Cannot Change Position of Minimized Panel
If a panel is minimized, you cannot programmatically change its position. 

Changes to its X and Y data members are ignored. If you want to use 

pushbuttons to open a panel in more than one location, create two panels 

that look the same but open in different locations. (2UIEAACP)

ActiveX Pipe Control Appearance Changes
ActiveX pipe controls in Lookout show white lines around the object 

border. When you save and reopen the process, the RelX and RelY settings 

in the Property Pages are changed. (2UGH8TR3)

Old Alarms Filter Does Not Work in Clients
The Old Alarms settings in the Alarm Filters dialog box does not work in 

a Lookout client. The Lookout client does not save old alarms. 

(2QLDR6A3)

Tiway.cbx Does Not Limit Request Length to 70 Bytes for FACTS 405 
Network

When using a TI 435 PLC with a 405 FACTS network, there is a 70 byte 

response limit. One Tiway object with multiple connections and I/O points 

might cause the PLC to go offline. The Lookout Tiway driver object does 

not enforce this limitation. To avoid exceeding the 70 byte response limit, 

create multiple Tiway objects, each of which requests only a few data 

members or values. (2NT882PE)
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Listbox ActiveX Object Does Not Work in String Compares with =
When a Lookout Listbox ActiveX object is used in an expression with =, 

the expression does not evaluate correctly. For example, 

ListBox1.properties.selectedItem="Text1" is not TRUE when 

it should be. Use an EXACT(Text1, Text2) function instead, which 

returns TRUE when Text1=Text2. (2MGDMCI1)

Loading New Recipe Prevents State File Save
If you have edit access to a process in a development version of Lookout, 

loading a new recipe, which is a process change, prevents Lookout from 

saving the state file. Select File»Save to save the process after loading the 

recipe file, and Lookout will save the state file properly. Run-time versions 

of Lookout do not have this problem. (2ICAIECC) 

Second DataTable Connected via DDE Does Not Shrink
A second DataTable connected to a source DataTable through DDE will 

not shrink when the source table shrinks. If the number of rows in the 

source DataTable is reduced, the second DataTable receives the new data 

but does not clear the extra rows of old data. To avoid this problem, use the 

enable data member to disable and re-enable the second DataTable 

whenever the source DataTable changes size. (25TEA49L)

Lookout Panel Function Keys Behave Like Pushbuttons
Lookout Panel function keys act like switches instead of pushbuttons. 

A data member stays active after being activated. (2EACD8PE)

Pager Message Does Not Work if # Required by Numeric Pager Service
The Pager object might not send a message to a numeric pager service that 

asks for # key at end of message. To send a message to a numeric pager that 

uses the # key to indicate the end of the message, put the phone number and 

message in the phone number field separated by commas, and leave the 

message field empty. (2ET9BFCC)

Moving Window Over Custom .wmf Graphic Distorts Image
If you drag another window over some custom .wmf graphics on a control 

panel, the graphic might appear partially erased. Minimize and restore the 

control panel to redraw the graphic. (2G39SQ26)

CitadelControl Object Does Not Log Over Network
You cannot use the CitadelControl object to log data remotely over the 

network. (29MCRKMV)
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Displays that are Outside the Screen Area
If you move a display off the screen, you cannot delete it from Object 

Explorer due to remaining dependencies. Either edit the display 

coordinates in the .lks file or increase the screen size to make the display 

visible again. (1XF9K97F)

Lookout Control Sources and Refresh Value Operations
A Lookout control with a Local source and a direct connection does not 

change if something acts to alter the value or status of the PLC or object it 

is connected to. Instead, Lookout restores the control value to the PLC or 

object in the following circumstances:

• When the driver object is modified or I/O is reconfigured

• When the process is reloaded

• When communication is restored after a communications failure

• After 100 polls in some cases (this varies from driver to driver and 

might depend on .ini file settings)

If you operate a Lookout control with a Remote source connection, and the 

PLC register it is connected to cannot or does not change when Lookout 

writes the new value out to the PLC, the control snaps back to display the 

actual PLC register value or status. Whether or not this problem occurs 

depends on data transmission time between your Lookout computer and the 

field hardware. To prevent this problem, Lookout has built-in delays for 

most driver objects. The following driver objects do not have a built-in 

delay.

• AdvantechPCL

• DeltaTau

• Dynamic

• ProfibusDP

• ProfibusL2

• Reliance

• Sixnet

• Wizdom

The following two driver objects do not support remote source connections 

at all because the underlying protocols do not allow this sort of connection:

• Aquatrol

• DeviceNet
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Another way to correct snap-back problems caused by slow 

communication is to adjust the SnapDelay setting that is available with 

some control objects. For Switch and Pushbutton objects, use the 

SnapDelay data member; for the Pot object, use the SnapDelay 

lookout.ini setting.

Connection Browser Open with No Processes Visible
Occasionally the Connection Browser might open with no processes visible 

in the window. Close the Connection Browser and then reopen it. This 

usually clears the problem. If for some reason it does not, close the 

Connection Browser again and make sure you select a process in your 

Object Explorer before reopening the Connection Browser.

CWUI ActiveX 3-D Control License Problems
If you load a Lookout 5 process with Lookout CWUI ActiveX 3-D controls 

and attempt to edit those controls, you can develop a problem with the 

license for those controls. To avoid this difficulty, load the Lookout 5 

process and immediately save it in order to force the control license to 

update. You can then edit the controls with no problem.

Missing Aggregate Definitions
If you load a process that includes an Aggregate object, but the 

corresponding aggregate definition is unavailable, the Aggregate does not 

function properly. It appears in the Object Explorer as expandable, but it 

does not expand. (270DIAYZ)

Administrator Access Needed to Download Lookout Player
If you want to use the Lookout Web Client feature on a computer running 

Windows 2000/NT/XP, you must have administrator privileges to install 

the Lookout Player component of the Web Client. After the Lookout Player 

is installed, administrator privileges are not necessarily required to use the 

Lookout Web Client successfully.

Pot Connected to an FP-2010 Can Fluctuate
When you change the value of a Pot object that is remotely connected to a 

published data member of the FieldPoint FP-2010, the Pot can fluctuate in 

value before it reaches its final state. To address this problem, try changing 

the snapDelay setting in the lookout.ini file. Refer to the Lookout 

Help for more information on this setting. (28I89I7M)
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ToshibaTSeries Sets PLC Values to 0
If the ToshibaTSeries object does a write before a read, it sets all the PLC 

values to 0. (1V5HS5M0)

Web Clients and the Sequencer Object
If you use the Web Client to browse a Lookout process that uses a 

Sequencer, and you browse to another URL while the Sequencer is active, 

Lookout might stop the process and reset the Sequencer, inserting a huge 

wait value in the active sequence step. Avoid using the Web Client with 

Lookout processes that use a Sequencer object. (28FGCNBD)

Pulse Object Erratic Behavior
The Lookout Pulse object might operate erratically, including missing 

some pulses, if you use period or duration numbers that are not simple. 

Using an expression to calculate a pulse period or duration is one way to 

encounter this problem; using too precise a number such as 1.26 seconds is 

another way. (28B89NBD)

Including Custom Graphics when You Deploy
Remember that graphics are not included in Lookout source files (.lks). 

When you move processes from one computer to another, you must copy 

all graphics, including custom graphics. (2D6F3BDF)

Expression Displays that Automatically Resize
Lookout resizes expression displays when reopening a project. If an 

expression value has more characters than can be displayed in the given 

size of the expression display, it shows ####. If you close the project and 

reopen it, Lookout automatically resizes the expression display so that the 

string stored in the state file fits. This can be a significant problem if, for 

example, an expression is displaying input that is several hundred 

characters long. (2AJCJQTM)

Web Client Alert Has Incorrect Slashes in URL
No matter what URL you enter in the Web Client export options, the 

slashes are always shown as forward slashes in a Web Client Alert. If you 

use back slashes with an http URL, the URL does not work, but the 

Lookout alert message displays the correct URL with forward slashes. 

If you are confused because the URL looks correct in an alert message, 

check the direction of the slashes in your export options. (28B9OI9L)
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Aggregate Problems with Incorrect Computer Name
If you have the incorrect computer name entered in the System Options 

dialog box and you drag and drop an Aggregate object data member on a 

panel, you get bad quality (a red X) for the data member. Additionally, you 

might find that some data members you did not intend to expose in the 

Aggregate object are visible in the Object Explorer. Select Options»

System and make sure the computer name matches the name in your 

Windows networking configuration. (246FA49L)

Using the ! and NOT Expression Functions
In Lookout expressions, the ! function has a transient TRUE value, but the 

NOT function does not. To negate an expression without a glitch, use NOT 

rather than !. (239957E9)

Saving a Process with a Read-Only LKS File
If you attempt to save a process with a read-only .lks file, you (correctly) 

get a message that Lookout cannot save. If you were closing the process, 

the process close is aborted. The asterisk next to the process name at the top 

left of the Lookout workspace disappears, and if you attempt to close the 

process again, Lookout closes without prompting you to save your recent 

changes. (270DANYZ)

Bug Fixes

The following bugs have been fixed for Lookout 5.1:

• The [Alarms] header=0 setting in the Lookout.ini file hides 

column headers in the Alarms Window. (257HGA26, 1T4CQBQH)

• Bad quality no longer received from network module FP-2010, when 

using the FieldPoint cbx in Lookout. (28I7TN7M)

• The FieldPoint object in Lookout has been updated to include the 

FP-20xx data members. (286G4B7M) 

• Using an invalid entry in an (expression) object no longer causes 

Lookout to crash. (2ASFRFNE)

• A switch connected to the Lookout Webbrowser ActiveX control 

Visible property can now make the Web browser invisible and restore 

it to visible. (2CRI6MBD)

• You no longer get an error when using the ModbusDaniel object 

without a Modbus Daniel device attached to the serial port. 

Additionally, the update light comes on when the data is updated. 

(2DOH63B4)

• Scaling now works for driver object data members. (2EL94MB4)
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• Right-clicking a process or object in the Edit Object Connections 

dialog box and choosing Configure Network Security works 

properly. (2C88R2SP)

• Connecting a numeric value to the Sample Pulse parameter of the PID 

object works correctly. (27K8EEYZ)

• The Pot object accepts dates entered as mm/dd/yyyy. (2CG6TKTS) 

(2EE851E9)

• IPASCII updates correctly, even when there is a heavy traffic. 

(2H7BIS9L)

• The ScanData object now saves the phone number. (2HSA4D7E)

• You can use the new clearEvent data member of the Alarm object to 

programmatically clear all the events in the Alarms Window. 

(20OES8CM)

• The Aquatrol object is now relayable if you are using it with repeater 

in a noisy environment. (2HTFLIE9)

• Saved .l4p files no longer crash when updated from Lookout 4.0.1. 

(2HO8P4UQ)

• The Pager object no longer hangs when talking with TAP compliant 

pager system. (2DOGD6B4)

• Lookout does not crash on startup in the OPClient.cbx. (2ILD07E9)

• Data transfers do not hang when using the Mitsubishi object with a 

high number of I/O points. (2K18SFUQ)

• If you do not want operators to access a Web browser from Lookout, 

use the User cannot switch to another program setting in the System 

Options dialog box. (2JJ9LU7E)

• Printing alarms and events from the File menu no longer crashes 

Lookout.exe with an access violation. (27JE21E9)

• The problems addressing registers in an Allen Bradley PLC 2 have 

been resolved. (1ZP8F0G6)

• Images appear correctly when nested in an Aggregate. (2KFAUHUQ)

• Lookout interprets DataSocket string arrays correctly. (2KFFKR9L)

• Within Industrial Automation OPC Servers, the Applicom driver can 

read and write. (2K1AOH7E)

• Lookout does not crash if a client attempts to subscribe with a bad 

URL. (28NFMRFN)

• A Pot value, its expression, and the logged value stay in sync when you 

have set a deviation. Use the Lookout.ini file setting. In the 

[Database] section, the LogResolution sets the resolution of 

datalogging (default is Deviation/2). A value of 0= always log data as 

precisely as possible. (2IL7QLE9)
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• Function keys need not be pressed twice to activate the Pot enterValue 

dialog box. (2KLA051Z)

• Report objects do not keep old connections. (2H77FD26)

• Lookout no longer crashes when using the NIDeviceNetExplicit 

driver. (2MBEE5OM)

• Lookout sends correct lifespan information to Citadel. (2LSEE3ZU)

• Lookout does not hang when saving a state file to an unavailable 

remote machine. (1O2F8U9I)

• Password expiration behaves as expected. (2OJ7PPE9)

• The ModbusDaniel object writes to the registers properly. (2JS9NPB4, 

2LTD4JE9)

• Mitsubishi consistently reports Incorrect frame check sum 

(FCS) with D data members. (2QODCEE9) 

• SLC500 (5/04) updates ST registers correctly. (2Q1BOF9L)

• The Commfail data member on the Pager object behaves correctly. 

(2IH9RPPE)

• Allen Bradley Micrologix options listed are only those supported. 

(2NOE9FPE)

• Alarm Journal printouts have correct format for system time events, 

without extra carriage returns. (2S4H788W)

• You can now justify the text on a digital Pot object. (1SEFRDRM)

• Importing graphics from Image Navigator when you have two 

instances of Lookout no longer causes dialog box problems. 

(2GCEHHMO)

• The Modbus stack overflow crash has been resolved. (2M9G54B4)

• If a non-numeric data member is configured to be logged as numeric, 

Lookout checks the deviation value. (2O7DQE9L)

• Pager object no longer crashes when the message sent is ether "" or 04 

(without quotation marks). (2UAAQ4K4)

• The MitsubishiFX object FX Mode setting, either Direct or 

Multi-drop, is loaded correctly from a .lks file. (2UN9EVW3)
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Compatibility and Conversion Issues

Opening Older Process Files in Lookout 5.1
(Lookout 4.5 and 5.0) If you are upgrading from Lookout 4.5 or 5.0, you 

should be able to open the .l4p process file without recompiling.

(Lookout 4.0) To open Lookout 4.0 processes in Lookout 5.1, open the .lks 

file instead of the .l4p file when you load a process. As soon as the 

process opens, save it to update the .l4p file.

(Lookout 3.8) If you are upgrading from Lookout 3.8, open the .lks file in 

Lookout 5.1, then save the process to create a new .l4p file. Some minor 

adjustments might have to be made in some processes, and you will have 

to change redundancy using backup computers. Refer to the following 

sections for more information about compatibility and conversion issues 

when upgrading from Lookout 3.8.

Lookout 3.8 and Lookout 5.1 Compatibility
The following list contains known compatibility issues and fixes for 

Lookout 5.1 that might affect Lookout 3.8 users who are upgrading. 

• Lookout 5.1 does not run on Windows NT version 3.51 or earlier—you 

must be using Windows NT 4.0 or later.

• Earlier versions of Lookout process files used the file extension .lkp, 

and state files used the extension .lst. Lookout now uses the .l4p 

extension for process files and .l4t for state files.

If you want to continue to run your old 3.8 processes in a 3.8 version, 

save backups of the files. Otherwise, recompiling a 3.8 process in 

Lookout 4 or later will create (if you save) new .lks, .l4p, and .l4t 

files. Lookout also creates new security files using the .lka extension.

• Avoid installing Lookout 5.1 over Lookout 3.x.xx. Either uninstall your 

previous version of Lookout, or put Lookout 5.1 in a new directory, 

transferring or copying files for conversion.

• Lookout 3.x.xx can run on the same computer with Lookout 5.1, and a 

process in one can be networked to a process in the other using DDE. 

If you intend to run both versions at one time, start the earlier version 

of Lookout first.

• Lookout 3.8 Citadel files cannot be used by Lookout 5.1. You should 

maintain old Citadel files separately from Lookout 5.1 database files.
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• Events are now stored with alarms and process data in the Citadel 

database. 

• The default location for data logged with the Spreadsheet object is the 

Lookout directory. The Lookout directory is also the default for any 

spreadsheet files you might export from the DataTable object or .csv 

(comma separated value) files you might create with the Print Alarms 

dialog box. If you do not want these files to be created in the Lookout 

directory, enter a complete path (including file name) for the location 

where you want the file created.

Converting Lookout 3.8 Processes to Lookout 5.1
To load a Lookout 3.8 process file in Lookout 5.1, select File»Open and 

set the Files of type to Lookout Source Files (*.lks), as shown in the 

following illustration.

 

Select the file you want to convert and click the Open button 

(or double-click the file name). Lookout uses the built-in CBL compiler 

to recompile the 3.8 source file into a Lookout 5.1 process file.

Converting 3.8 files might require the following adjustments:

• Lookout 3.8 versions of the Pot, Switch, Pushbutton, and TextEntry 

objects that are remoted convert as L3Pot, L3Switch, and so on, and 

continue to function as they formerly did. You cannot create new 

3.8 objects like these through Lookout 5.1.

Because remote position source connections have changed in response 

to the demands of networking, you might find you want to replace 

L3 versions of these controls with the new Lookout 5.1 versions, 

especially if you want these controls to operate over a network. Delete 

the old controls and replace them with new controls using the same 

names. The Connection Browser and Object Explorer can help you 
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track all the connections that might need to be re-established if you 

decide to make these replacements.

• ODBC/SQL limitations: With the introduction of networking and 

hierarchical arrangement of objects within processes, it is easy to 

exceed the 62 character limit that exists in Microsoft Access and 

Microsoft Query. Even fully-compliant ODBC programs are limited 

to 126 characters, so some consideration of these limitations when 

assigning computer, process, and object names is necessary if you 

intend to use SQL queries.

• The old LKSwap CBX no longer works. If you used this special object 

from the old Lookout Evaluation Guide, you will have to replace it 

with the Lookout Loader object, which is more flexible and powerful 

than the old LKSwap object. Lookout 5.1 can run multiple processes, 

so it is not necessary to shut one process down before running another.

• Fonts are preserved when converting Lookout 3.8 process files to 

Lookout 5.1 using the .lks file, but font code page information is lost. 

This appears to mostly affect international users whose languages use 

a different code page than the US code page. 

• The $Alarm object syntax in a .lks file has changed. The full URL 

for a $Alarm object will be as follows:

\\machine\process\$Alarm

• Your custom built Lookout 3.8 .cbx files should run in Lookout 5.1 

as long as they were developed using the Lookout Object Developer 

Toolkit. If you have problems with a custom .cbx, contact National 

Instruments technical support for help in resolving the problem.

• The Lookout HyperTrend object now accesses data through a URL 

connection. The data source for that connection must be logged to the 

Citadel database for the HyperTrend to display the data.

• When you convert a process with a Lookout 3.xx HyperTrend in it, 

Lookout automatically creates a named expression to make the URL 

connection to. Lookout automatically logs this named expression to 

the Citadel database. To maintain your converted HyperTrend objects, 

you must use or replace these named expressions.

• If you have Lookout 3.8 processes that use the NI DAQ or NI SCXI 

objects, and you have a version 6.5.1 or earlier of NI-DAQ installed on 

your computer, you must upgrade to NI-DAQ 6.5.2 or later to use 

Lookout 5.1. You can download the current version of NI-DAQ 

software from the National Instruments Web site.

If your Lookout process will be running on the same computer as 

your National Instruments Data Acquisition or SCXI hardware, we 

recommend that you edit your process to use the OPCClient object 

to connect to NI-DAQ for performance reasons.
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Importing Old Security Files into Lookout 5.1
If you are upgrading from Lookout 4.0 or later, Lookout converts your 

security file automatically when you open it with the National Instruments 

User Account Manager. If you are upgrading from Lookout 3.8, you can 

import the user account information into Lookout 5.1 using the User 

Account Manager, as follows:

1. In edit mode, select Options»User Manager from the Lookout menu. 

The User Account Manager dialog box appears.

2. Select User»Import Security File. The following dialog box appears.

 

3. Navigate to your old Lookout 3.8 security file lookout.sec, and 

select it. Lookout 3.8 kept the lookout.sec security file in the 

Lookout directory.

4. Click the Open button.

5. If you have already created any user accounts in an earlier version of 

Lookout that are the same as accounts you used in Lookout 3.8, you 

will receive a message informing you that a user account with that 

name already exists. You may replace your recently created account, 

or choose not to use the old account information.

6. Exit the User Account Manager.

Note Unlike Lookout 3.8, Lookout 5.1 maintains the lookout.sec security file in the 

Windows System directory. To implement the accounts that you have defined when you 

deploy your process, you must use the same lookout.sec file for each copy of Lookout 

running on your network. Copy your lookout.sec file to the Windows System directory 

in every computer you intend to run Lookout on.



322470E-01 Apr03
*322470E-01*

More Information and Updates

For the most recent Lookout news and updates, visit ni.com/lookout.

To download the newest patches and other updates, visit 

ni.com/downloads.
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