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to be a substitute for any form of established process, procedure, or equipment used to monitor or safeguard human health
and safety in medical or clinical treatment.
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About This Manual

The LabVIEW User Manual provides information about creating virtual
instruments (VIs). This manual also includes information about the
interfaces to which you can input and output data, using LabVIEW VIs to
perform analysis operations, and how LabVIEW handles network and
interapplication communication. Please read the LabVIEW Release Notes
before you use the LabVIEW User Manual.

Organization of This Manual

The LabVIEW User Manual is organized as follows.

Chapter 1, Introduction, introduces the unique LabVIEW approach to
programming. It also explains how to start using LabVIEW to develop
programs.

Part I, Introduction to G Programming

This section contains basic information about creating virtual instruments
(VIs), using VIs in other VIs, programming structures such as loops, and
data structures such as arrays and strings.

Part I, Introduction to G Programming, contains the following chapters.

© National Instruments Corporation

Chapter 2, Creating VIs, explains how to create a VI including the
front panel, which is the user interface, and the block diagram, which
is the source code. Once you create a VI, you can use it in other VIs.

Chapter 3, Loops and Charts, shows you how to repeat portions of the
block diagram using a While Loop and a For Loop. This chapter also
explains how to display graphically multiple points, one at a time, on
a chart.

Chapter 4, Case and Sequence Structures and the Formula Node,
explains how to use the Case structure, which is a conditional structure,
the Sequence structure, which aids in establishing execution order, and
the Formula Node, which aids in executing mathematical formulas.

Chapter 5, Arrays, Clusters, and Graphs, shows how to display a
group or array of data points on a graph. You can pass scale parameters
as well as an array of data points to a graph by creating a cluster, which
is a group of data different data types.

Chapter 6, Strings and File I/0, introduces string controls and
indicators and file input and output operations.
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Part Il, 1/0 Interfaces

Part Ill, Analysis

LabVIEW User Manual

This section contains basic information on the interfaces to which you can
input and output data, which are data acquisition, GPIB, serial, and VXI.
Refer to the Data Acquisition Basics Manual for basic information on
real-time data acquisition. VISA (Virtual Instrument Software
Architecture) is a single software library that interfaces with GPIB, serial,
and VXI instruments. LabVIEW applications developed especially for a
specific instrument are called instrument drivers. National Instruments
provides several instrument drivers using the VISA library, but you can also
build your own instrument drivers.

Part I1, I/O Interfaces, contains the following chapters.

e Chapter 7, Getting Started with a LabVIEW Instrument Driver,
explains how to create and use National Instruments instrument
drivers.

e Chapter 8, LabVIEW VISA Tutorial, shows you how to implement
common VISA applications using message-based and register-based
communication as well as events and locking.

e Chapter 9, Introduction to LabVIEW GPIB Functions, explains how
the GPIB operates and the difference between the IEEE 488 and
IEEE 488.2 interface.

e Chapter 10, Serial Port Vls, explains the important factors that affect
serial communication.

This section contains basic information on analysis of data, signal
processing, signal generation, linear algebra, curve fitting, probability, and
statistics.

Part 11, Analysis, contains the following chapters.

e Chapter 11, Introduction to Analysis in LabVIEW, introduces concepts
that apply to all analysis applications, including supported
functionality, notation and naming conventions, and sampling signal
methods.

*  Chapter 12, Signal Generation, explains how to produce signals using
the normalized frequency and how to build a simulated function
generator.

»  Chapter 13, Digital Signal Processing, shows the difference
between the Fast Fourier Transform (FFT) and the Discrete Fourier
Transform (DFT).
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Chapter 14, Smoothing Windows, explains how using windows
prevents spectral leakage and improves the analysis of acquired
signals.

Chapter 15, Spectrum Analysis and Measurement, shows how to
determine the amplitude and phase spectrum, develop a spectrum
analyzer, and determine the total harmonic distortion (THD).

Chapter 16, Filtering, explains how to filter unnecessary frequencies
from signals using infinite impulse response filters (IIR), finite
impulse response filters (FIR), and nonlinear filters.

Chapter 17, Curve Fitting, shows how to extract information from a
data set to create a data trend description.

Chapter 18, Linear Algebra, explains how to perform matrix
computation and analysis.

Chapter 19, Probability and Statistics, explains some fundamental
concepts of probability and statistics, and shows how to use these
concepts in solving real-world problems.

Part IV, Network and Interapplication Communication

This section contains basic information about network and interapplication
communication.

Part IV, Network and Interapplication Communication, contains the
following chapters.
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Chapter 20, Introduction to Communication, introduces the way
LabVIEW handles networking and interapplication communication.

Chapter 21, TCP and UDP, explains basic concepts of Transmission
Control Protocol (TCP), Internet Protocol (IP), and internet addresses.

Chapter 22, ActiveX Support, shows how LabVIEW can be an ActiveX
server and client. ActiveX is the same as OLE Automation
communication.

Chapter 23, Using DDE, explains how to use Dynamic Data Exchange
(DDE) to communicate between Windows applications. DDE can be
used in a client, a server, and across a network.

Chapter 24, AppleEvents, shows how AppleEvents are used to
communicate between LabVIEW and other Macintosh applications.
LabVIEW can be an AppleEvents server and client.

Chapter 25, Program-to-Program Communication, explains how
LabVIEW can communicate to other Macintosh applications using
Program-to-Program Communication (PPC).
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Part V, Advanced G Programming

This section contains information on VI customization; programmatic
control of front panel objects, VIs, and LabVIEW; and tips on how to
design complex applications.

Part V, Advanced G Programming, contains the following chapters.

Chapter 26, Customizing VIs, shows how to use VI Setup... and
VI Node Setup... to customize the appearance and execution behavior
of a VI when it is running.

Chapter 27, Front Panel Object Attributes, describes objects called
attribute nodes, which are special block diagram nodes that control the
appearance and functional characteristics of controls and indicators.

Chapter 28, Program Design, explains techniques to use when
creating programs and offers programming-style guidelines.

Chapter 29, Where to Go from Here, provides information about
resources you can use to create your applications successfully.

Appendices, Glossary, and Index

LabVIEW User Manual

Appendix A, Analysis References, lists the reference material used to
produce the Analysis VIs in LabVIEW. These references contain more
information on the theories and algorithms implemented in the
analysis library.

Appendix B, Common Questions, answers common questions about
LabVIEW networking communications and Instrument 1/O,
specifically GPIB and serial I/O.

Appendix C, Customer Communication, contains forms to help you
gather the information necessary to help us solve your technical
problems and a form you can use to comment on the product
documentation.

The Glossary contains an alphabetical list of terms used in this manual,
including abbreviations, acronyms, metric prefixes, mnemonics, and
symbols.

The Index contains an alphabetical list of key terms and topics in this
manual, including the page where you can find each one.
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Conventions Used in This Manual

bold italic

bold monospace

italic

The following conventions are used in this manual:

Angle brackets enclose the name of a key on the keyboard—for example,
<shift>. Angle brackets containing numbers separated by an ellipsis
represent a range of values associated with a bit or signal name—

for example, DBIO<3..0>.

A hyphen between two or more key names enclosed in angle brackets
denotes that you should simultaneously press the named keys—
for example, <Control-Alt-Delete>.

The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options» Substitute
Fonts directs you to pull down the File menu, select the Page Setup item,
select Options, and finally select the Substitute Fonts options from the
last dialog box.

This icon to the left of bold text denotes the beginning of an activity, which
contains step-by-step instructions you can follow to learn more about
LabVIEW.

This icon to the left of bold text denotes the end of an activity, which
contains step-by-step instructions you can follow to learn more about
LabVIEW.

This icon to the left of bold italicized text denotes a note, which alerts you
to important information.

This icon to the left of bold italicized text denotes a caution, which advises
you of precautions to take to avoid injury, data loss, or a system crash.

Bold text denotes the names of menus, menu items, parameters, dialog
boxes, dialog box buttons or options, icons, windows, Windows 95 tabs,
or LEDs.

Bold italic text denotes an activity objective, note, caution, or warning.

Bold monospace text denotes messages and responses that the computer
automatically prints to the screen.

Italic text denotes variables, emphasis, a cross reference, or an introduction
to a key concept. This font also denotes text from which you supply the
appropriate word or value, as in Windows 3.x.
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monospace

paths

Platform

Text in this font denotes text or characters that you should literally enter
from the keyboard, sections of code, programming examples, and syntax
examples. This font is also used for the proper names of disk drives, paths,
directories, programs, subprograms, subroutines, device names, functions,
operations, variables, filenames and extensions, and for statements and
comments taken from programs.

Paths in this manual are denoted using backslashes (\) to separate drive
names, directories, folders, and files.

Text in this font denotes information related to a specific platform.

Related Documentation

* G Programming Reference Manual

*  LabVIEW Data Acquisition Basics Manual

*  LabVIEW Function and VI Reference Manual
e LabVIEW QuickStart Guide

* LabVIEW Online Reference, available by selecting
Help»Online Reference

e LabVIEW Online Tutorial (Windows only), which you launch from the
LabVIEW dialog box

e G Programming Quick Reference Card
*  LabVIEW Getting Started Card

*  LabVIEW Release Notes

e LabVIEW Upgrade Notes

Customer Communication

LabVIEW User Manual

National Instruments wants to receive your comments on our products
and manuals. We are interested in the applications you develop with our
products, and we want to help if you have problems with them. To make it
easy for you to contact us, this manual contains comment and configuration
forms for you to complete. These forms are in Appendix C, Customer
Communication, at the end of this manual.
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Introduction

This chapter introduces the unique LabVIEW approach to programming.
It also explains how to start using LabVIEW to develop programs. The
chapter refers you to other chapters or manuals for more information.

What Is LabVIEW?

LabVIEW is a program development environment, much like modern C
or BASIC development environments, and National Instruments
LabWindows/CVI. However, LabVIEW is different from those
applications in one important respect. Other programming systems use
text-based languages to create lines of code, while LabVIEW uses a
graphical programming language, G, to create programs in block diagram
form.

LabVIEW, like C or BASIC, is a general-purpose programming system
with extensive libraries of functions for any programming task. LabVIEW
includes libraries for data acquisition, GPIB and serial instrument control,
data analysis, data presentation, and data storage. LabVIEW also includes
conventional program development tools, so you can set breakpoints,
animate the execution to see how data passes through the program, and
single-step through the program to make debugging and program
development easier.

How Does LabVIEW Work?

LabVIEW is a general-purpose programming system, but it also includes
libraries of functions and development tools designed specifically for data
acquisition and instrument control. LabVIEW programs are called virtual
instruments (VIs) because their appearance and operation can imitate actual
instruments. However, VIs are similar to the functions of conventional
language programs.

A VI consists of an interactive user interface, a dataflow diagram that
serves as the source code, and icon connections that allow the VI to be
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called from higher level VIs. More specifically, VIs are structured as
follows:

e The interactive user interface of a VI is called the front panel,
because it simulates the panel of a physical instrument. The front
panel can contain knobs, push buttons, graphs, and other controls
and indicators. You enter data using a mouse and keyboard, and
then view the results on the computer screen.

e The VI receives instructions from a block diagram, which you
construct in G. The block diagram is a pictorial solution to a
programming problem. The block diagram is also the source code
for the VI.

e VIs are hierarchical and modular. You can use them as top-level
programs, or as subprograms within other programs. A VI within
another VI is called a subVI. The icon and connector of a VI work
like a graphical parameter list so that other VIs can pass data to a
subVI.

With these features, LabVIEW promotes and adheres to the concept of
modular programming. You divide an application into a series of tasks,
which you can divide again until a complicated application becomes a
series of simple subtasks. You build a VI to accomplish each subtask and
then combine those VIs on another block diagram to accomplish the larger
task. Finally, your top-level VI contains a collection of subVIs that
represent application functions.

Because you can execute each subVI by itself, apart from the rest of the
application, debugging is much easier. Furthermore, many low-level
subVIs often perform tasks common to several applications, so that you can
develop a specialized set of subVIs well-suited to applications you are
likely to construct.

G is the easy to use graphical data flow programming language on which
LabVIEW is based. G simplifies scientific computation, process
monitoring and control, and test and measurement applications, and you
also can use it for a wide variety of other applications.

Part I, Introduction to G Programming, covers the functionality of G that
you need to get started with most LabVIEW applications. For a more
extensive explanation of LabVIEW functionality, see the G Programming
Reference Manual.
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The basic concepts of G that are covered in this manual are described in the
following list.

e VIs—Virtual instruments (VIs) have three main parts: the front panel,
the block diagram, and the icon/connector. The front panel specifies
the user interface of the VI. The block diagram consists of the
executable code that you create using nodes, terminals, and wires.
With the icon/connector, you can use a VI as a subVI in the block
diagram of another VI. For more information about VIs, refer to
Chapter 2, Creating VIs and Chapter 26, Customizing VIs.

*  Loops and Charts—G has two structures to repeat execution of a
sub-diagram—the While Loop and the For Loop. Both structures are
resizable boxes. You place the subdiagram to be repeated inside the
border of the loop structure. The While Loop executes as long as the
value at the conditional terminal is TRUE. The For Loop executes a set
number of times. Charts are used to display real-time trend information
to the operator. For more information about loops and charts, refer to
Chapter 3, Loops and Charts.

*  Case and Sequence Structures—The Case structure is a conditional
branching control structure, which executes a subdiagram based on
certain input. A Sequence structure is a program control structure that
executes its subdiagrams in numeric order. For more information about
Case or Sequence structures, refer to Chapter 4, Case and Sequence
Structures and the Formula Node.

*  Attribute Nodes—Attribute nodes are special block diagram nodes
that you can use to control the appearance and functional
characteristics of controls and indicators. For more information about
attribute nodes, refer to Chapter 27, Front Panel Object Attributes.

e Arrays, Clusters and Graphs—An array is a resizable collection of
data elements of the same type. A cluster is a statically sized collection
of data elements of the same or different types. Graphs commonly are
used to display data. For more information about arrays, clusters, and
graphs, refer to Chapter 5, Arrays, Clusters, and Graphs.
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Organization of the LabVIEW System (Windows)
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After you have completed the installation, as described in the LabVIEW
Release Notes that come with your software, your LabVIEW directory
should contain the following files.

LABVIEW.EXE—This is the LabVIEW program. Launch this program
to start LabVIEW.

vi.lib directory—Contains libraries of VIs that are included with
LabVIEW, including GPIB, analysis, and data acquisition (DAQ) VIs.
Most of these are available from the Functions palette.

examples directory—Contains numerous subdirectories of examples.
This directory also contains a VI called readme . vi that serves as a
guide to the examples.

serpdrv and dagdrv—These files serve as part of LabVIEW’s
interface to the serial port, and DAQ communication, respectively.
These files must be in the same directory as vi.lib.

resource directory

— labview.rsc, lvstring.rsc, and 1vicon.rsc—Data files

used by the LabVIEW application

— (Windows 3.1) 1vdevice.d11—This file provides timing services
to LabVIEW and must be in the same directory as vi.1lib for
LabVIEW to run.

—  (Windows 3.1) 1vimage.d11—This file allows LabVIEW to load
images created using a variety of graphics programs.

— labview50.tlb—Thisfileis atype library to enable LabVIEW
to act as an ActiveX server.

— ole_container.dl11—This file enables LabVIEW to display
and update ActiveX containers.

— 1lvwutil32.d11—This file is used by the Solution Wizard,
which builds DAQ and Instrument I/O examples based on your
criteria.

— 1lvjpeg.dll and lvpng.dl1—These files provide support to
display JPEG and PNG graphics in HTML files when you print VI
documentation to an HTML file.

Cintools directory—Contains files necessary to build Code Interface
Nodes (CINs), which are a means to link C code to LabVIEW VIs.

visarc file—Serves as part of LabVIEW’s interface to VISA (Virtual
Instrument Software Architecture). VISA provides a single interface
library for controlling VXI, GPIB, and Serial instruments.
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* labview.ini—Contains the configuration options for LabVIEW.

* Project directory—Contains files which become items in the
LabVIEW Project menu.

* menus directory— Contains files used to configure the structure of the
Controls and Functions palettes.

* Instr.lib directory—Contains instrument drivers used to control
VXI, GPIB, and Serial instruments. When you install National
Instruments instrument drivers, place them in this directory because
they will be added to the Functions palette.

* Help directory—Contains complete online documentation as well as
the Search Examples help file, which aids in locating examples
common to your application.

* Tutorial directory—Contains files that are necessary to run the
online tutorial, an interactive tutorial covering the basic concepts of the
LabVIEW environment.

* Activity directory—Is a location where you can save the VIs you
create while completing the activities in this manual.

* User.lib directory—Is a location where you can save commonly
used VIs that you have created. The VIs in this directory will be
displayed in the Functions palette.

* Wizarddirectory—This directory creates the Solution Wizard option
in the File menu. You can use this directory to add items to the
File menu.

LabVIEW installs driver software for GPIB, data acquisition, and VXI
driver hardware. For configuration information, see Chapter 2, Installing
and Configuring Your Data Acquisition Hardware, in the LabVIEW Data
Acquisition Basics Manual, the VXI VI Reference Manual, and Chapter 8,
LabVIEW VISA Tutorial, of this manual.

Startup Screen on Windows

When you launch LabVIEW, you are greeted with a navigation dialog box
where introductory material, common commands, and Quick Tips are
easily accessible. If you prefer to bypass the navigation dialog, you can
disable it using a checkbox at the bottom of the dialog box. To reenable it,
use the Preferences dialog box.

When all VIs are closed, a similar dialog box appears. The Small Dialog
button switches to a simpler version of the dialog box—with only New,
Open, and Exit buttons.
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Organization of the LabVIEW System (Macintosh)
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After you have completed the installation, as described in the LabVIEW
Release Notes that come with your software, your LabVIEW directory
should contain the following files.

LabVIEW—This is the LabVIEW program. Launch this program to
start LabVIEW.

vi.lib folder—Contains libraries of VIs that are included with
LabVIEW, including GPIB, analysis, and data acquisition (DAQ) VIs.
Most of these are available from the Functions palette.

examples folder—Contains numerous subfolders of examples. This
folder also contains a VI called readme . vi that serves as a guide to
the examples.

resource folder

— lvstring.rsrcand lvicon.rsrc—Data files used by the
LabVIEW application.

— lvjpeg.lib and lvpng.lib—These files provide support to
display JPEG and PNG graphics in HTML files when you print VI
documentation to an HTML file.

cintools folder—Contains files necessary to build Code Interface
Nodes (CINs), which are a means to link C code to LabVIEW VIs.

visarc file—Serves as part of LabVIEW s interface to VISA, Virtual
Instrument Software Architecture. VISA provides a single interface
library for controlling VXI, GPIB, and Serial instruments.

Project folder—Contains files which become items in the LabVIEW
Project menu.

menus folder—Contains files used to configure the structure of the
Controls and Functions palettes.

instr.1lib folder—Contains instrument driers used to control VXI,
GPIB, and Serial instruments. When you install National Instruments
instrument drivers, place them in this directory because they will be
added to the Functions palette.

help folder—Contains complete online documentation as well as the
Search Examples help file, which aids in locating examples common
to your application.

activity folder—Is alocation where you can save the VIs you create
while completing the activities in this manual.
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user.1lib folder—Is a location where you can save commonly used
VIs that you have created. The Vs in this directory will be displayed
in the Functions palette.

Wizard folder—This directory creates the Solution Wizard option in
the File menu (PCI Macintosh only). You can use this directory to add
items to the File menu.

In addition, the LabVIEW installation utility installs several driver files so
that you can use GPIB and/or DAQ plug-in boards.

System Folder:Control Panels:NI-488 INIT—This control
panel contains the drivers for your GPIB boards. You can use it to
configure your boards, but you rarely need to change any settings.

System Folder:Control Panels:NI-DAQ—This control panel
loads DAQ drivers into memory. You can use it to configure the
location and behavior of your DAQ boards and SCXI modules.

System Folder:Extensions:NI-DMA/DSP—DBoth the GPIB and
DAQ drivers use this extension. It provides support for direct memory
access (DMA) transfer of data, which provides higher data transfer
rates. This extension also provides support for NI-DSP boards.

LabVIEW installs driver software for GPIB and data acquisition hardware.
For configuration information, see Chapter 2, Installing and Configuring
Your Data Acquisition Hardware, in the LabVIEW Data Acquisition Basics
Manual.

Organization of the LabVIEW System (UNIX)

After you have completed the installation, as described in the LabVIEW
Release Notes that come with your software, your LabVIEW directory
should contain the following files.

© National Instruments Corporation

labview—This is the LabVIEW program. Launch this program to
start LabVIEW.

vi.lib directory—Contains libraries of VIs that are included with
LabVIEW, including GPIB, analysis, and data acquisition (DAQ) VIs.
Most of these are available from the Functions palette.

examples directory—Contains numerous subdirectories of examples.
This directory also contains a VI called readme . vi that serves as a
guide to the examples.

serpdrv—This file serves as part of LabVIEW's interface to
serial port communication. This file must be in the same directory
asvi.lib.
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resource directory

— labview.rsc, lvstring.rsc, and 1vicon.rsc—Data files

used by the LabVIEW application

— 1lvjpeg.lib and lvpng.lib—These files provide support to
display JPEG and PNG graphics in HTML files when you print VI
documentation to an HTML file.

cintools directory—Contains files necessary to build Code
Interface Nodes (CINs), which are a means to link C code to
LabVIEW VIs.

visarc file—Serves as part of LabVIEW’s interface to VISA,
Virtual Instrument Software Architecture. VISA provides a single
interface library for controlling VXI, GPIB, and Serial instruments.

Project directory—Contains the files which become items in the
LabVIEW Project menu.

menus directory—Contains files used to configure the structure of the
Controls and Functions palettes.

instr.lib directory—Contains instrument drivers used to control
VXI, GPIB, and Serial instruments. When you install National
Instruments instrument drivers, place them in this directory because
they will be added to the Functions palette.

help directory—Contains complete online documentation as well as
the Search Examples help file, which aids in locating examples
common to your application.

activity directory—Is a location where you can save the VIs you
create while completing the activities in this manual.

user.lib directory—Is a location where you can save commonly
used VIs that you have created. The VIs in this directory will be
displayed in the Functions palette.

Wizard directory—This directory creates the Solution Wizard
option in the File menu. You can use this directory to add items to
the File menu.

acrobat directory—Contains online documentation in Acrobat
(.pdf) format.

acroread directory—Contains Adobe Acrobat reader files.
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Toolkit Support

Files that are installed in vi . 1ib\addons automatically show up at the top
level of the Controls and Functions palettes. This feature can be used by
new toolkits to make them more accessible after installation. If you already
have toolkits that installed files elsewhere, you can move them to the
addons directory for easier access. If you want to add your own VIs to the
palettes, we recommend placing them in user.lib or adding them to a
custom palette set.

Where Should | Start?

This manual provides basic information on how to build an application
in LabVIEW. To become familiar with the LabVIEW environment,

go through the LabVIEW Online Tutorial (Windows only), the

LabVIEW QuickStart Guide, and Part 1, Introduction to G Programming
in this manual.

Most LabVIEW applications are divided into the following tasks:

I/0 interface to sensors or instruments, data display on the front panel, data
analysis, data storage, and data transfer across a network. To learn more
about each of these tasks, refer to Part I, I/O Interfaces, Part 111, Analysis,
and Part IV, Network and Interapplication Communication. For advanced
G programming techniques, refer to Part V, Advanced G Programming,
in this manual.

To generate or find examples similar to your application, refer to the
Solution Wizard (Windows and PCI Macintosh only) or Search Examples
online help file (Windows only), which you can access from the LabVIEW
startup dialog.

For information on individual functions and VIs, refer to the LabVIEW
Function and VI Reference Manual and online help.
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Introduction to G Programming

Note

This section contains basic information about creating virtual instruments
(VIs), using VIs in other VIs, programming structures such as loops, and
data structures such as arrays and strings.

Part I, Introduction to G Programming, contains the following chapters.

Chapter 2, Creating VIs, explains how to create a VI including the
front panel, which is the user interface, and the block diagram, which
is the source code. Once you create a VI, you can use it in other VIs.

Chapter 3, Loops and Charts, shows you how to repeat portions of the
block diagram using a While Loop and a For Loop. This chapter also
explains how to display multiple points graphically, one at a time, on
a chart.

Chapter 4, Case and Sequence Structures and the Formula Node,
explains how to use the Case structure, which is a conditional structure,
the Sequence structure, which aids in establishing execution order, and
the Formula Node, which aids in executing mathematical formulas.

Chapter 5, Arrays, Clusters, and Graphs, shows how to display a
group or array of data points on a graph. You can pass scale parameters
as well as an array of data points to a graph by creating a cluster, which
is a group of different data types.

Chapter 6, Strings and File I/0, explains how to manipulate strings
and write those strings to an ASCII file.

(Windows 3.1) You must save the VIs you create in Part I in VI libraries.

VI libraries allow you to use file names that are longer than 8 characters.
Also, the VIs needed for the activities in Part I are located in the VI library
LabVIEW\Activity\Activity.1l1lb. Refer to the Saving Vls section in
Chapter 2, Editing VIs, of the G Programming Reference Manual for more
information on VI Libraries.



Creating Vls

This chapter introduces the basic concepts of virtual instruments and
provides activities that explain the following:

e How to create the icon and connector

e Howtousea VIasasubVI

What is a Virtual Instrument?

A virtual instrument (VI) is a program in the graphical programming
language G. Virtual instrument front panels often have a user interface
similar to physical instruments. G also has built-in functions that are similar
to VIs, but do not have front panels or block diagrams as VIs do. Function
icons always have a yellow background.

How Do You Build a VI?

VI Hierarchy

One of the keys to creating LabVIEW applications is understanding and
using the hierarchical nature of the VI. After you create a VI, you can use
it as a subVI in the block diagram of a higher-level VI.

When you create an application, you start at the top-level VI and define the
inputs and outputs for the application. Then, you construct subVIs to
perform the necessary operations on the data as it flows through the block
diagram. If a block diagram has a large number of icons, group them into a
lower-level VI to maintain the simplicity of the block diagram. This
modular approach makes applications easy to debug, understand, and
maintain.

As with other applications, you can save your VI to a file in a regular
directory. With G, you also can save multiple VIs in a single file called a
VI library.
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If you are using Windows 3.1, you should save your VIs into VI libraries
because you can use long file names (up to 255 characters) with mixed
cases.

You should not use VI libraries unless you need to transfer your VIs to
Windows 3.1. Saving VIs as individual files is more effective than using
VI libraries because you can copy, rename, and delete files more easily than
if you are using a VI library. For a list of the advantages and disadvantages
of using VI libraries and individual files, see the section Saving VIs in
Chapter 2, Editing Vls, of the G Programming Reference Manual.

VI libraries have the same load, save, and open capabilities as other
directories. VI libraries, however, are not hierarchical. That is, you cannot
create a VI library inside of another VI library. You cannot create a new
directory inside a VI library, either. There is no way to list the VIs in a
VI library outside the LabVIEW environment.

After you create a VI library, it appears in the LabVIEW file dialog box as
a folder with VI on the folder icon. Regular directories appear as a folder
without the VI label.

Even though you might not save your own VIs in VI libraries, you should
be familiar with how they work. In the various activities in this manual, you
will save your VIs in the LabVIEW\Activity directory. Solutions to these
activities are provided in the LabVIEW\Activity\Solution directory.

Controls, Constants, and Indicators

LabVIEW User Manual

A control is an object you place on your front panel for entering data into a
Vlinteractively or into a subVI programmatically. An indicator is an object
you place on your front panel for displaying output. Controls and indicators
in G are similar to input and output parameters, respectively, in traditional
programming languages. An alternative to placing controls and indicators
on the front panel and then wiring them to functions or VIs on the block
diagram, is to create controls or indicators directly from the block diagram.
To do this, pop up on the input terminal of a function or VI on the block
diagram and select Create Control. This creates a control of the correct
data type and wires it to the terminal.
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[Device]

[

Show [
Data Operations ]
Replace ]

Temé
Representation » F

Format & Precision...
Create Constant

1]

Create Control
Create Indicator

You can create an indicator and wire it to an output terminal by popping up
on the terminal and selecting Create Indicator. As an alternative to placing
constants on the block diagram and wiring them to functions and VIs, you
can pop up on a function or VI terminal and select Create Constant. You
cannot delete a control or indicator from the block diagram. As with all
front panel objects, you must go to the front panel, select the Positioning
tool, and then delete the object.

Each time you create a new control or indicator on the front panel,
LabVIEW creates the corresponding terminal in the block diagram.

The terminal symbols suggest the data type of the control or indicator.
For example, a DBL terminal represents a double-precision, floating-point
number; a TF terminal is a Boolean; an 116 terminal represents a regular,
16-bit integer; and an ABC terminal represents a string. For more
information about data types in G, and their graphical representations,
see the G Programming Quick Reference Card.

Terminals are regions on a VI or function through which data passes.
Terminals are analogous to parameters in text-based programming
languages. It is important that you wire the correct terminals of a function
or VI. You can view the icon connector to make correct wiring easier.

To do this, pop up on the function or VI and choose Show»Terminals.
To return to the icon, pop up on the function or VI and select
Show»Terminals again.
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Wires

Hot Spot -‘f%
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A wire is a data path between nodes. Wires are colored according to the
kind of data each wire carries. Blue wires carry integers, orange wires carry
floating-point numbers, green wires carry Booleans, and pink wires carry
strings. For more information about wire styles and colors, see the

G Programming Quick Reference Card.

To wire from one terminal to another, click the Wiring tool on the first
terminal, move the tool to the second terminal, and click on the second
terminal. It does not matter at which terminal you start. The hot spot of the
Wiring tool is the tip of the unwound wiring segment.

In the wiring illustrations in this section, the arrow at the end of this mouse
symbol shows where to click and the number printed on the arrow indicates
how many times to click the mouse button.

When the Wiring tool is over a terminal, the terminal area blinks, to indicate
that clicking connects the wire to that terminal. Do not hold down the
mouse button while moving the Wiring tool from one terminal to another.
You can bend a wire once by moving the mouse perpendicular to the current
direction. To create more bends in the wire, click the mouse button.

To change the direction of the wire, press the spacebar. Click with the
mouse button, to tack the wire down and move the mouse perpendicularly.

Temp

Temp

[

Tip Strips

When you move the Wiring tool over the terminal of a node, a tip strip for
that terminal pops up. Tip strips consist of small, yellow text banners that
display the name of each terminal. These tip strips should help you to wire
the terminals. The following illustration displays the tip strip that appears
when you place the Wiring tool over an output of the Simple Error
Handler VI.
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i~ <¢—— Wiring Tool

<——Tip Strip

Note When you place the Wiring tool over a node, G displays wire stubs that indicate
each input and output. The wire stub has a dot at its end if it is an input to the node.

Wire Stretching

m You can move wired objects individually or in groups by dragging the
selected objects to a new location with the Positioning tool.

Temperature @
Temperature @

Temperature @

L]

=

)

Selecting and Deleting Wires

You might wire nodes incorrectly. If you do, select the wire you want to
delete and then press <Delete>. A wire segment is a single horizontal or
vertical piece of wire. The point where three or four wire segments join is
called a junction. A wire branch contains all the wire segments from one
junction to another, from a terminal to the next junction, or from one
terminal to another if there are no junctions in between. You select a wire
segment by clicking on it with the Positioning tool. Double-clicking selects
a branch, and triple-clicking selects the entire wire.
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Segment

/\ e e e
(EER mop S S

7Segmem EE E;___ E?éﬂﬂ
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Bend . )
en Selects a Segment Selects a Branch Selects an Entire Wire

Bad Wires

[---] A dashed wire represents a bad wire. You can get a bad wire for a number
of reasons, such as connecting two controls, or connecting a source
terminal to a destination terminal when the data types do not match (for
instance, connecting a numeric to a Boolean). You can remove a bad wire

by clicking on it with the Positioning tool and pressing <Delete>. Choosing
Edit»>Remove Bad Wires or <Ctrl-B> deletes all bad wires in the block
diagram. This is a useful quick fix to try if your VI refuses to run or returns
the Signal has Loose Ends error message.

Note Do not confuse a black, dashed wire with a dotted wire. A dotted wire represents a
Boolean data type, as the following illustration shows.

Dashed Wire (bad)

Murnber 1 tatch

Dotted Wire (good)
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) Activity 2-1. Create a VI

Your objective is to build a VI.

|\g@

Imagine that you have sensors that read temperature and volume readings
as voltage. You will use a VI in the LabVIEW\Activity directory to
simulate the temperature and volume measurements in volts. You will write
a VI to scale these measurements to degrees fahrenheit and liters,
respectively.

1. Open a new front panel by selecting File»New. If you have closed all
Vs, select New VI from the LabVIEW dialog box.

Note If the Controls palette is not visible, select Windows»Show Controls Palette 7o
display the palette. You also can access the Controls palette by popping up in an
open area of the front panel. To pop up, right-click on your mouse (<Option>-click
Jor Macintosh).

2. Select Tank from Controls»Numeric, and place it on the front panel.

3. Type volume in the label text box and click anywhere on the front
panel.

Note If you click outside the text box without entering text, the label disappears.
To show the label again, pop up on the control and select Show»Label.

4. Rescale the tank indicator to display the tank volume between 0.0

and 1000.0.
a. Using the Labeling tool, double-click on 10. 0 on the tank scale to
highlight it.

b. Type 1000 in the scale and click the mouse button anywhere on
the front panel. The intermediary increments are scaled
automatically.

5. Place a thermometer from Controls»Numeric on the front panel.
Label it Temp and rescale it to be between 0 and 100.
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6. Your front panel should look like the following illustration.

1000.0- ;;E';% 100.0- ,TB:%
750.0- 75.0-
500.0- 50.0-
250.0- 5.0-
0.0- EI.EI—.

7. Open the block diagram by choosing Windows»Show Diagram.
Select the objects listed below from the Functions palette and place
them on the block diagram.

Note If the Functions palette is not visible, select Windows»Show Functions Palette to
display the palette. You also can access the Functions palette by popping up in an

open area of the block diagram.

8. Place each of the following objects on the block diagram.

Process Monitor (Functions»Select a VI from the LabVIEW\Activity
directory)—Simulates reading a temperature voltage and volume value
from a sensor or transducer.

=[]

Eﬁﬂ Random Number Generator (Functions»Numeric)—Generates a number
between 0 and 1.

I}>, Multiply function (Functions»Numeric)—Multiplies two numbers and
returns their product. In this activity, you need two of these. Drop one from
the palette and copy and paste to create the other.

L=l
L]

Numeric Constant (Functions»Numeric)—You need two of these.
Drop one from the palette. Using the labeling tool, change its value to
10.00. Copy and paste it.

Note Another way to create a constant is to pop up on the terminal of a function or VI
using the Wiring tool. Select Create Constant from the floating menu. A constant
of the appropriate data type appears.
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9. To view the inputs and outputs of a function or a VI, select Show Help
from the Help menu and then drag the cursor over each function and
VI. The Help window for the Process Monitor VI is shown below.

Proc Preszsure

P
Index " % — Temperature
— Yalume

Process Monitor_vi

10. Using the Wiring tool, wire the objects as shown.
e Process Monitor vi
Proc | P Tem
i
HMaon [\

olurne|

[

10.00
Note To move objects around on the block diagram, click on the Positioning tool in the

Tools palette.

11. Select File»Save and save the VI as Temp & Vol.vi inthe
LabVIEW\Activity directory.

12. From the front panel, run the VI by clicking on the Run button. Notice
values for Volume and Temperature are displayed on the front panel.

13. Close the VI by selecting File»Close.

@ End of Activity 2-1.
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VI Documentation

You can document a VI by choosing Windows»Show VI Info.... Type the
description of the VI in the VI Information dialog box. Then, you can recall
the description by selecting Windows»Show VI Info... again.

You can edit the descriptions of objects on the front panel (or their
respective terminals on the block diagram) by popping up on the object and
choosing Data Operations»Description....

Note You cannot change the description of a VI or its front panel objects while the VI
is running.

The following illustration is an example pop-up menu that appears while
you are running a VI. You cannot add to or change the description while
running the VI, but you can view any previously entered information.

1000,0- Yolume
7h0.0-
Reinitialize to Drefault
Bon.0- [Euf [ata
260.0- Copy Data
Baste Data
n.o-

[Hrline Helm

You also can view the description of a front panel object by showing the
Help window (Help»Show Help) and moving the cursor over the object.

N

[ Activity 2-2. Document a Vi

—/

%

Your objective is to document a VI that you have created.

1. Openthe Temp & Vol.vi created in Activity 2-1 from the
LabVIEW\Activity directory.

2. Select Windows»Show VI Info.... Type the description for the VI, as
shown in the following illustration, and click on OK.

LabVIEW User Manual 2-10 © National Instruments Corporation



Chapter 2 Creating Vs

¥ Information E

Memie: T &Yes Locking and Password Status:

Path: CALabVIEWNActivinhTemp & Val vi & Unlocked [no passward)

£ Locked [ho password)
Explain... |

Current Revizion: 13

£ Password-protected

Drescription:

This %I simulates reading a temperature sensor and level ransducer | -

~Memory Usage:

Resources: 184K Frant Panel: 3.0k
Block Diagram: 5.0k
Code: 41K
Data: 1.8K
Total: ~13.9K

ak. | Cancel |

3. Pop up on the tank and choose Data Operations»Description....
Type the description for the indicator, as shown in the following
illustration, and click OK.

Description
Walume Description
Dizplays simulated volume in livers) ;I
[
OF. Cancel
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4. Pop up on the thermometer and choose Data Operations»
Description.... Type in the description: Displays simulated
temperature (deg F) measurement. Click on OK.

5. Select Show Help from the Help menu. Place the cursor on Volume
and then on Temp. You can see the descriptions you typed in appear
in the help window.

Save and close the VI.

@ End of Actlwty 2-2.

What is a SubVI?

Hierarchy Window

LabVIEW User Manual

A subVI is much like a subroutine in text-based programming languages.
It is a VI that is used in the block diagram of another VI.

You can use any VI that has an icon and a connector as a subVI in
another VI. In the block diagram, you select VIs to use as subVIs from
Functions»Select a VI.... Choosing this option produces a file dialog box,
from which you can select any VI in the system. If you open a VI that does
not have an icon and a connector, a blank, square box appears in the calling
VI's block diagram. You cannot wire to this node. For more information
about icons and connectors, see the LabVIEW Online Tutorial, which you
can access from the startup dialog box.

A subVlI is analogous to a subroutine. A subVI node is analogous to a

subroutine call. The subVI node is not the subVTI itself, just as a subroutine
call statement in a program is not the subroutine itself. A block diagram that
contains several identical subVI nodes calls the same subVI several times.

The Hierarchy window displays a graphical representation of the calling
hierarchy for all VIs in memory, including type definitions and global
variables. You use the Hierarchy window (Project»Show VI Hierarchy)
to display the dependencies of VIs by providing information on VI callers
and subVIs. This window contains a toolbar that you can use to configure
several types of settings for displayed items. The following illustration
shows an example of the VI hierarchy toolbar.
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[ E & =eE

You can use buttons on the Hierarchy window toolbar or the View menu,
or pop up on an empty space in the window to access the following
options. For more information about the Hierarchy window see the
Using the Hierarchy Window section in Chapter 3, Using SubVls, of the
G Programming Reference Manual.

Redraw—Rearranges nodes after successive operations on hierarchy nodes
if you need to minimize line crossings and maximize symmetric aesthetics.
If a focus node exists, you then scroll through the window so that the first
root that shows subVls is visible.

i

Switch to vertical layout—Arranges the nodes from top-to-bottom, placing
roots at the top.

[&]

Switch to horizontal layout—Arranges the nodes from left-to-right, placing
roots on the left side.

2]

Include/Exclude VIs—Toggles the hierarchy graph to include VI libraries,
or exclude VIs in VI libraries.

ﬂl

Include/Exclude global—Toggles the hierarchy graph to include or exclude
global variables. Global variables store data used by several VIs.

2]

Include/Exclude typedefs—Toggles the hierarchy graph to include or
exclude typedefs. A typedefis a master copy of a custom control, which can
be used by several VIs.

Ex

In addition, the View menu and pop-up menus include Show all VIs and
Full VI Path in Label options that you cannot access on the toolbar.

As you move the Operating tool over objects in the Hierarchy window,
LabVIEW displays the name of the VI below the VI icon.

Ed

Use the <Tab> key to toggle between the Positioning and Scroll window
tools. This feature is useful for moving nodes from the Hierarchy window
to the block diagram.

You can drag a VI or subVI node to the block diagram or copy it to the

clipboard by clicking on the node. <Shift>-click on a VI or subVIs node to
select multiple objects for copying to other block diagrams or front panels.
Double-clicking on a VI or subVI node opens the front panel of that node.
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Any VIs that contain subVIs have an arrow button next to the VI that you
can use to show or hide subVlIs. Clicking on the red arrow button or
double-clicking on the VI itself displays the subVIs in that VI. A black
arrow button on a VI node means that all subVIs are displayed. You also
can pop up on a VI or subVI node to access a menu with options, such as
showing or hiding subVIs, opening the VI or subVI front panel, editing the
Vlicon, and so on.

Search Hierarchy

You also can search currently visible nodes in the Hierarchy window by
name. You initiate the search by typing in the name of the node, anywhere
on the window. As you type in the text, a search string appears, which
displays the text as you type it in and concurrently searches through the
hierarchy. The following illustration shows the search hierarchy.

Search: [Demo

E=H s, JEPLEY
% lTernp RERD
WOLTE

B Fead Yolkage.vi

After finding the correct node, you can press <Enter> to search for the next
node that matches the search string, or you can press <Shift-Enter> to find
the previous node that matches the search string.

Icon and Connector

LabVIEW User Manual

Every VI has a default icon displayed in the upper-right corner of the Front
Panel and Diagram windows. For Vs, the default is the LabVIEW VI icon
and a number indicating how many new VIs you have opened since
launching LabVIEW. You use the Icon Editor to customize the icon by
turning individual pixels on and off. To activate the Icon Editor, pop up on
the default icon in the top right corner of the Panel window and select
Edit Icon.

The following illustration shows the Icon Editor Window. You use the tools

at left to create the icon design in the pixel editing area. An image of the
actual icon size appears in one of the boxes to the right of the editing area.
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Icon Editor E
Fil= Edit Help
B & Ciopy fran
<

T
[~ Show Teminals

16 Colors

25E Colors 0K |

Cancel |

The tools to the left of the editing area perform the following functions:
Pencil tool—Draws and erases pixel by pixel.

Line tool—Draws straight lines. Press <Shift> and then drag this tool to
draw horizontal, vertical, and diagonal lines.

(/][]

Color Copy tool—Copies the foreground color from an element in the icon.
Fill bucket tool—Fills an outlined area with the foreground color.

Rectangle tool—Draws a rectangular border in the foreground color.
Double-click on this tool to frame the icon in the foreground color.

=

Filled rectangle tool—Draws a rectangle bordered with the foreground
color and filled with the background color. Double-click to frame the icon
in the foreground color and fill it with the background color.

= Select tool—Selects an area of the icon for moving, cloning, or other
changes.

Text tool—Enters text into the icon design.

Foreground/Background—Displays the current foreground and
background colors. Click on each to get a color palette from which you can
choose new colors.

© National Instruments Corporation 2-15 LabVIEW User Manual



Chapter 2 Creating VIs

The buttons at the right of the editing screen perform the following
functions:

*  Undo—Cancels the last operation you performed.
e OK—Saves your drawing as the VI icon and returns to the front panel.

e Cancel—Returns to the front panel without saving any changes.

Depending on the type of monitor you are using, you can design a separate
icon for monochrome, 16-color, and 256-color mode. You design and save
each icon version separately. The editor defaults to Black & White, but you
can click on one of the other color options to switch modes.

Note If you design a color icon only, the icon does not show up in a subpalette of the
Functions palette if you place the VI in the * . 1ib directory, nor will the icon be
printed or displayed on a black and white monitor.

LabVIEW User Manual

The connector is the programmatic interface to a VI. If you use the panel
controls or indicators to pass data to and from subVIs, these controls or
indicators need terminals on the connector pane. You define connections by
choosing the number of terminals you want for the VI and assigning a front
panel control or indicator to each of those terminals.

To define a connector, select Show Connector from the icon pane pop-up
menu on the Panel window.

The connector icon replaces the icon in the upper-right corner of the Panel
window. LabVIEW selects a terminal pattern appropriate for your VI with
terminals for controls on the left side of the connector pane, and terminals
for indicators on the right. The number of terminals selected depends on the
number of controls and indicators on your front panel.

Each rectangle on the connector represents a terminal area, and you can use
the rectangles either for input or output from the VI. If necessary, you can
select a different terminal pattern for your VI. To do this, pop up on the
icon, select Show Connector, pop up again, and select Patterns.
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7 Activity 2-3. Create an Icon and Gonnector

Your objective is to make an icon and connector for a VI.

@@

To use a VI as a subVI, you must create an icon to represent it on the block
diagram of another VI, and a connector pane to which you can connect
inputs and outputs. LabVIEW provides several tools with which you can
create or edit an icon for your VlIs.

The icon of a VI represents it as a subVI in the block diagram of other VIs.
It can be a pictorial representation of the purpose of the VI, or a textual
description of the VI.

1. Open Temp & Vol.vi inthe LabVIEW\Activity directory.

2.  From the front panel, pop up on the icon in the top right corner and
select Edit Icon.... You also can double click on the icon to invoke the
icon editor.

Note You only can access the icon/connector for a VI from the front panel.

3. Erase the default icon. With the Select tool, which appears as a dotted
rectangle, click and drag over the section you want to delete, and press
the <Delete> key. You also can double click on the shaded rectangle in
the tool box to erase the icon.

4. Draw a thermometer with the Pencil tool.

5. Create the text with the Text tool. To change the font, double-click on
the Text tool. Your icon should look similar to the following
illustration.

Icon Editor E

B & Coapy fran

TEMF | L&

16 Colors : :

III E L [~ Show Teminals
Unda |

i 286 Colors 0K |

Cancel |

LB
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6. Close the Icon Editor by clicking on OK. The new icon appears in the
icon pane.

7. Define the connector terminal pattern by popping up in the icon pane
on the front panel and choosing Show Connector. By default,
LabVIEW selects a terminal pattern based on the number of controls
and indicators on the front panel. Because there are two objects on
the front panel, the connector has two terminals, as shown at left.

8. Pop up on the connector pane and select Rotate 90 Degrees.
Notice how the connector pane changes, as shown at left.

9. Assign the terminals to Temp and Volume.

a. Click on the top terminal in the connector. The cursor
automatically changes to the Wiring tool, and the terminal
turns black.

b. Click on the Temp indicator. A moving dashed line frames the
indicator, as shown in the following illustration. The selected
terminal changes to a color consistent with the datatype of the
control/indicator selected.

ragsoTr Jemel
imnn B
| 750~

i B0.0-

| 25.0-

1

T

If you click in an open area on the front panel, the dashed line disappears
and the selected terminal appears dimmed, indicating that you have
assigned the indicator to that terminal. If the terminal is white, you have not
made the connection correctly.

c. Repeat steps a and b to associate the bottom terminal with the
Volume indicator.

d. Pop up on the connector and select Show Icon....
10. Save the VI by choosing File»Save.
Now, this VIis complete and ready for use as a subVIin other VIs. The icon

represents the VI in the block diagram of the calling VI. The connector
(with two terminals) outputs the temperature and volume.
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Note The connector specifies the inputs and outputs of a VI when you use it as a subV1.
Remember that front panel controls can be used as inputs only; front panel
indicators can be used as outputs only.

11. Close the VI by choosing File»Close.

@ End of Activity 2-3.

Opening, Operating, and Changing SubVls

You can open a VI used as a subVI from the block diagram of the calling
VI by double-clicking on the subVIicon or by selecting Project»This VI’s
SubVlIs. You will see a palette containing all the subVIs of the calling VI.
Select the subVI you want to open.

Any changes you make to a subVTI alter only the version in memory until
you save the subVI. The changes affect all instances of the subVI and not
just the node you used to edit the VI.

N
0

Activity 2-4. Call a SubVI

Your objective is to build a VI that uses the Temp & Vol.vi as a subVI

E

The Temp & Vol VI you built in Activity 2-1 returns a temperature and
volume. You will take a volume reading and convert the value to gallons
when a switch is pressed.

Front Panel

Open a new front panel by selecting File»New.

2. Select a Horizontal Switch from the Controls»Boolean palette and
label it volume. Place free labels on the front panel to indicate Liters
and Gallons by using the Labeling tool.

3. Select ameter from Controls»Numeric and place it on the front panel.
Label it Tank Volume.
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Block Diagram

b
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Tank Volurme
Volume 400.0 500.0
. 200.0 : = 8000
Liters |:|:. Gallons
1000.0
0o
hY
968,29

4. Change the range of the meter to accommodate values ranging
between 0.0 and 1000.0. With the Operating tool, double-click on the
high limit and change it from 10.0 to 1000.0. Switch to the positioning
tool and resize the meter by dragging out one of the corners and
expanding the control.

Go to the block diagram by selecting Windows»Show Diagram.

6. Popup in a free area of the block diagram and choose
Functions»Select a VI.... A dialog box appears. Select
Temp & Vol.vi inthe LabVIEW\Activity directory. Click on
Open in the dialog box. LabVIEW places the Temp & Vol VI on the
block diagram.

7. Add the other objects to the block diagram as shown in the following

illustration.
Ternp & Wolvi
ﬂ'-fél; Dividd

Select T ahk Wolume

3785

Numeric Constant (Functions»Numeric)—Add a numeric constant to the
block diagram. Assign the value 3.785 to the constant by using the
Labeling tool. This is the conversion factor for switching from liters to
gallons.

Select Function (Function»Comparison)—Returns the value wired to the
TRUE or FALSE input, depending on the Boolean input.
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|> Divide function (Functions»Numeric)—Divides the value in liters by
3.785 to convert it to gallons.

8. Wire the diagram objects as shown.

| |:[} 9. Return to the front panel and click on the Run button in the toolbar.
| The meter shows the value in liters.

10. Click on the switch to select Gallons and click on the Run button.
The meter shows the value in gallons.

11. Save the VI as Using Temp & Vol.vi inthe LabVIEW\Activity
directory.

@ End of Activity 2-4.

How Do You Debug a VI?

A VI cannot compile or run if it is broken. Normally, the VI is broken while
you are creating or editing it, until you wire all the icons in the diagram. If it
still is broken when you finish, try selecting Remove Bad Wires from the
Edit menu. Often, this fixes a broken VI.

When your VI is not executable, a broken arrow appears instead of the Run
button. To list the errors, click on the broken Run button. Click on one of
the errors listed and then click on Find to highlight the object or terminal
that reported the error.

You can animate the VI block diagram execution by clicking on the
Highlight Execution button. Execution highlighting is commonly used
with single-step mode to trace the data flow in a block diagram.

For debugging purposes, you might want to execute a block diagram node
by node. This is known as single-stepping. To enable the single-step mode,
click on the Step Into button or Step Over button. This action then causes
the first node to blink, denoting that it is ready to execute. Then you can
click on either the Step Into or Step Over button again to execute the node
and proceed to the next node. If the node is a structure or VI, you can select
the Step Over button to execute the node but not single-step through the
node. For example, if the node is a subVI and you click on the Step Over
button, you execute the subVI and proceed to the next node but cannot see
how the subVI nodes execute. To single step through a structure or subVl,
select the Step Into button.
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Click on the Step Out button to finish execution of the block diagram nodes
and/or complete single stepping. For more information about debugging,
see Chapter 4, Executing and Debugging VIs and SubVls, in the

G Programming Reference Manual.

N

[ Activity 2-5. Debug a Vi in LabVIEW

_/

%

Your objective is to use the probe tool and the probe window and to
examine data flow in the block diagram using the execution highlighting
feature.

1. OpenUsing Temp & Vol.vi from the LabVIEW\Activity
directory.

2. Select Windows»Show Diagram.
If the Tools palette is not open, select Windows»Show Tools Palette.

4. Select the Probe tool from the Tools palette. Click with the Probe tool
on the wire coming out of the Divide function. A Probe window pops
up with the title Probe 1 and a yellow glyph with the number of the
probe, as shown in the following illustration. The Probe window
remains open, even if you switch to the front panel.

TEMF
yoL

Probe [1]

5. Return to the front panel. Move the Probe window so you can
view both the probe and volume values as shown in the following
illustration. Run the VI. The volume in gallons appears in the
Probe window while Tank Volume displays the value in liters.

Tank Wolurme

Yalurne

400.0 000
Liters |:|:. Gallons 2l BDD.D1 o
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Probe [1] E3 T
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Chapter 2 Creating Vs

Note The volume values that appear on your screen may be different than what is
shown in this illustration. Refer to the Numeric Conversion section in Chapter 3,
Loops and Charts, for more information.

6.

Close the Probe window by clicking in the close box at the top of the
Probe window title bar.

Another useful debugging technique is to examine the flow of data in the
block diagram using the execution highlighting feature.

7.

[ & 8.

Return to the block diagram of the VI.

Begin execution highlighting by clicking on the Highlight Execution
button, in the toolbar. The Highlight Execution button changes to an
illuminated light bulb.

Click on the Run button to run the VI, and notice that execution
highlighting animates the VI block diagram execution. Moving
bubbles represent the flow of data through the VI. Also notice that data
values appear on the wires and display the values contained in the
wires at that time, as shown in the following block diagram, just as if
you had probed the wire.

T ahk Wolurne

You also can use the single stepping buttons if you want to walk through
the graphical code, one step at a time.

El 10.
IEI 11.
=

EI 12.

Begin single-stepping by clicking on the Step Over button, in the
toolbar.

Step into the Temp & Vol subVI by clicking on the Step Into button,
in the toolbar. Clicking on this button opens the front panel and block
diagram of your Temp & Vol subVI. Click on the Step Over button
until the VI finishes executing.

Finish executing the block diagram by clicking on the Step Out button,
in the toolbar. Clicking on this button completes all remaining
sequences in the block diagram.

@ End of Activity 2-5.
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Loops and Charts

This chapter introduces structures and explains the basic concepts of charts,
the While Loop, and the For Loop. This chapter also provides activities that
illustrate how to accomplish the following:

e Learn about different chart modes

*  Use a While Loop and a chart

*  Change the mechanical action of a Boolean switch
*  Control loop timing

*  Use a shift register

¢ Create a multiplot chart

*  Use a For Loop

What is a Structure?

A structure is a program control element. Structures control the flow of
data in a VI. G has five structures: the While Loop, the For Loop, the Case
structure, the Sequence structure, and the Formula Node. This chapter
introduces the While Loop and For Loop structures along with the chart and
the shift register. The Case structure, Sequence structure, and Formula
Node are explained in Chapter 4, Case and Sequence Structures and the
Formula Node.

While and For Loops are basic structures for programming with G, so you
can find them in most of the G examples as well as the activities in this
manual. You also can find more information on loops in Chapter 19,
Structures, in the G Programming Reference Manual.

For examples of structures, see Examples\General\structs.1lb.
For examples of charts, see Examples\General\Graphs\charts.1llb.
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Charts

Chart Modes

LabVIEW User Manual

A chart is a numeric plotting indicator which is updated with new data
periodically. You can find two types of charts in the Controls»Graph
palette: waveform chart and intensity chart. You can customize charts to
match your data display requirements or to display more information.
Features available for charts include: a scrollbar, a legend, a palette, a
digital display, and representation of scales with respect to time. For more
information about charts, see Chapter 15, Graph and Chart Controls and
Indicators, in your G Programming Reference Manual.

The following illustration shows the three chart display options available
from the Data Operations»Update Mode submenu—Strip chart,
Scope chart, and Sweep chart. The default mode is strip chart.

Strip Chart
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0.0-
49 149

[Scope Char]
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40_\/_\_/
2.0-

0.0-
100 200

Sweep Chart
100
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2.0+
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100 200
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Faster Chart Updates

You can pass an array of multiple values to the chart. The chart treats these
inputs as new data for a single plot. Refer to the charts.vi example
located in Examples\General\Graphs\charts.1llb.

Overlaid Versus Stacked Plots

You can display multiple plots on a chart using a single vertical scale,
called overlaid plots, or using multiple vertical scales, called stacked plots.
Refer to the charts.vi example located in Examples\General)\
Graphs\charts.1llb.

d

:E, Activity 3-1. Experiment with Chart Modes

Your objective is to view a chart as your VI runs in strip chart mode, scope
chart mode, and sweep chart mode.

1. Open Charts.vi, located in the following directory:
LabVIEW\Examples\General\Graphs\charts.1l1lb.

2.  Run the VI.

The strip chart mode has a scaling display similar to a paper tape strip chart
recorder. As each new value is received, it is plotted at the right margin and
old values shift to the left.

The scope chart mode has a retracing display similar to an oscilloscope.
As the VI receives each new value, it plots the value to the right of the last
value. When the plot reaches the right border of the plotting area, the VI
erases the plot and begins plotting again from the left border. The scope
chart is significantly faster than the strip chart because it is free of the
processing overhead involved in scrolling.

The sweep chart mode acts much like the scope chart, but it does not go
blank when the data hits the right border. Instead, a moving vertical line
marks the beginning of new data and moves across the display as the VI
adds new data.

3. With the VI still running, pop up on any chart, and select Update
Mode, and change the current mode to that of another chart. Notice the
difference between the various charts and modes.

Stop and close the VI.
A% End of Actnnty 3-1.
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While Loops

A While Loop is a structure that repeats a section of code until a condition
is met. It is comparable to a Do Loop or a Repeat-Until Loop in traditional
programming language.

The While Loop, shown in the following illustration, is a resizable box you
use to execute the diagram inside it until the Boolean value passed to the
conditional terminal (an input terminal) is FALSE. The VI checks the
conditional terminal at the end of each iteration; therefore, the While Loop
always executes at least once. The iteration terminal is an output numeric
terminal that outputs the number of times the loop has executed. However,
the iteration count always starts at zero, so if the loop runs once, the
iteration terminal outputs 0.

Iteration Conditional
Terminal Terminal

[ —[G

The While Loop is equivalent to the following pseudocode:
Do

Execute Diagram Inside the Loop (which sets the
condition)

While Condition is TRUE
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) Activity 3-2.  Use a While Loop and a Chart

Your objective is to use a While Loop and a chart for acquiring and

displaying data in real time.

You will build a VI that generates random data and displays it on a chart.
A knob control on the front panel adjusts the loop rate between 0 and 2
seconds and a switch stops the VI. You will change the mechanical action
of the switch so you do not have to turn on the switch each time you run
the VI. Use the front panel in the following illustration to get started.

Front Panel

G

Laop Delay (sec)
OM  #free label# I
OFF Transparent Color *knob#®
Crigital display
#yertical switch* hidden
Randorn Signal 052
1.0-
0.8-
06—
0.4-
0.2-
*wavefarm chart* oo-
Crigital displ h ’
igital display shown a s

Open a new front panel by selecting File»New.

Place a Vertical Switch (Controls»Boolean) on the front panel.
Label the switch Enable.

Use the Labeling tool to create free labels for oN and OFF. Select the
Labeling tool, and type in the label text. With the Color tool, shown at
left, make the border of the free label transparent by selecting the T
in the bottom left corner of the Color palette.

Place a waveform chart (Controls»Graph) on the front panel.
Label the chart Random Signal. The chart displays random data
in real time.

Note Make sure that you select a waveform chart and not a waveform graph. In the
Graph palette, the waveform chart appears closest to the left side.

© National Instruments Corporation
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5. Pop up on the chart and choose Show»Palette, and Show»Legend to
hide the palette and legend. The digital display shows the latest value.
Then pop up on the chart and choose Show»Digital Display and
Show»Scroll Bar.

Rescale the chart from 0.0 to 1. 0. Use the Labeling tool to replace the
high limit of 10.0 with 1.0.

-]

4 & 7. Place a knob (Controls»Numeric) on the front panel. Label the knob
Loop Delay (sec). This knob controls the timing of the While
Loop. Pop up on the knob and deselect Show»Digital Display to hide
the digital display.

8. Rescale the knob. Using the Labeling tool, double-click on 10. 0 in the
scale around the knob, and replace it with 2. 0.

Block Diagram

9. Open the block diagram and create the diagram in the following
illustration.

Fi andom Mumber [0-1 P —

i/ I

oo T it Ukl Mext mes Multiple]
‘

Enable

a. Place the While Loop in the block diagram by selecting it from
Functions»Structures. The While Loop is a resizable box that is
not dropped on the diagram immediately. Instead, you have the
chance to position and resize it. To do so, click in an area above
and to the left of all the terminals. Continue holding down the
mouse button and drag out a rectangle that encompasses the
terminals.
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Chapter 3 Loops and Charts

b. Select the Random Number (0-1) function from Functions»
Numeric.

c. Wire the diagram as shown in the Block Diagram, connecting the
Random Number (0—1) function to the Random Signal chart
terminal, and the Enable switch to the conditional terminal of the
While Loop. Leave the Loop Delay terminal unwired for now.

Return to the front panel and turn on the vertical switch by clicking on
it with the Operating tool.

Save the VI as Random Signal.vi in the LabVIEW\Activity
directory.

Run the VI.

The While Loop is an indefinite looping structure. The diagram within it
executes as long as the specified condition is TRUE. In this example, as
long as the switch is on (TRUE), the diagram continues to generate random
numbers and display them on the chart.

13.

14.

15.

Stop the VI by clicking on the vertical switch. Turning the switch
off sends the value FALSE to the loop conditional terminal and stops
the loop.

Scroll through the chart. Click and hold down the mouse button on
either arrow in the scrollbar.

Clear the display buffer and reset the chart by popping up on the chart
and choosing Data Operations»Clear Chart.

Note The display buffer default size is 1,024 points. You can increase or decrease this
buffer size by popping up on the chart and choosing Chart History Length....
You only can use this feature when the VI is not running.

@ End of Activity 3-2.

© National Instruments Corporation
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Mechanical Action of Boolean Switches
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You might notice that each time you run the VI, you must turn on the
vertical switch and then click the Run button in the toolbar. With G, you
can modify the mechanical action of Boolean controls.

There are six possible choices for the mechanical action of a Boolean
control:

e Switch When Pressed
e Switch When Released
e Switch Until Released
e Latch When Pressed

e Latch When Released
e Latch Until Released

Below are figures depicting each of these boolean switches, as well as a
description of each of these mechanical actions.

Switch When Pressed action—Changes the control value each time you
click on the control with the Operating tool. The action is similar to that of
a ceiling light switch, and is not affected by how often the VI reads the
control.

Switch When Released action—Changes the control value only after you
release the mouse button, during a mouse click, within the graphical
boundary of the control. The action is not affected by how often the VI
reads the control. This action is similar to what happens when you click on
a check mark in a dialog box; it becomes highlighted but does not change
until you release the mouse button.

Switch Until Released action —Changes the control value when you click
on the control. It retains the new value until you release the mouse button,
at which time the control reverts to its original value. The action is similar
to that of a doorbell, and is not affected by how often the VI reads the
control.

Latch When Pressed action—Changes the control value when you click on
the control. It retains the new value until the VI reads it once, at which point
the control reverts to its default value. (This action happens regardless of
whether you continue to press the mouse button.) This action is similar to
that of a circuit breaker and is useful for stopping While Loops or having
the VI do something only once each time you set the control.
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P Latch When Released action—Changes the control value only after you
. D—_u”— release the mouse button. When your VI reads the value once, the control

reverts to the old value. This action guarantees at least one new value. As
with Switch When Released, this action is similar to the behavior of buttons
in a dialog box; clicking on this action highlights the button, and releasing
the mouse button latches a reading.

e Latch Until Released action —Changes the control value when you click
. DJ_,_L_t on the control. It retains the value until your VI reads the value once or until

you release the mouse button, depending on which one occurs last.

d

Activity 3-3.  Change the Mechanical Action
of a Boolean Switch

Your objective is to experiment with the different mechanical actions of
Boolean switches.

N\

1. Open the Random Signal.vi, as saved in Activity 3-2, from the
LabVIEW\Activity directory. The default value of the Enable
switch is FALSE.

2. Modify the vertical switch so it is used only to stop the VI. Change the
switch so that you do not need to turn on the switch each time you run
the VI.

Turn on the vertical switch with the Operating tool.

b. Pop up on the switch and choose Data Operations»Make
Current Value Default. This makes the ON position the default
value.

c. Pop up on the switch and choose Mechanical Action»Latch
When Pressed.

3. Run the VI. Click on the Enable switch to stop the acquisition.
The switch moves to the OFF position momentarily and is reset back
to the ON position.

4. Save the VL.
Note For your reference, LabVIEW contains an example that demonstrates these

behaviors, called Mechanical Action of Booleans.vi. Itis located in
Examples\General\Controls\booleans.1llb.

@ End of Activity 3-3.
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Timing

Loops and Charts

When you ran the VI in the previous activity, the While Loop executed as
quickly as possible. However, you can slow it down to iterate at certain
intervals with the functions in the Functions»Time & Dialog palette.

The timing functions express time in milliseconds (ms), however, your

operating system might not maintain this level of timing accuracy.

N

—/

(Windows 95/NT) The timer has a resolution of 1 ms. However, this is
hardware-dependent, so on slower systems, such as an 80386, you
might have lower resolution timing.

(Windows 3.1) The timer has a default resolution of 55 ms. You can
configure LabVIEW to have 1 ms resolution by selecting Edit»
Preferences..., selecting Performance and Disk from the Paths ring,
and unchecking the Use Default Timer checkbox. LabVIEW does not
use the 1 ms resolution by default because it places a greater load on
your operating system.

(Macintosh) For 68K systems without the QuickTime extension, the
timer has a resolution of 16 2/3 ms (1/60th of a second). If you have a
Power Macintosh or have QuickTime installed, timer resolution is

1 ms.

(UNIX) The timer has a resolution of 1 ms.

Activity 3-4. Control Loop Timing

Your objective is to control loop timing and ensure that no iteration is
shorter than the specified number of milliseconds.

1.

LabVIEW User Manual

Open Random Signal.vi, as modified and saved in Activity 3-3,
from the LabVIEW\Activity directory.

Modify the VI to generate a new random number at a time interval
specified by the knob, as shown in the following illustration.
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Randarn Signal

E. Wait Until Next ms Multiple function (Functions»Time & Dialog) —
e Multiply the knob terminal by 1,000 to convert the knob value in seconds
to milliseconds. Use this value as the input to the Wait Until Next ms
Multiple function.

|> Multiply function (Functions»Numeric)—The multiply function
multiplies the knob value by 1000 to convert seconds to milliseconds.

Numeric constant (Functions»Numeric)—The numeric constant holds the
constant by which you must multiply the knob value to get a quantity in
milliseconds. Thus, if the knob has a value of 1.0, the loop executes once
every 1000 milliseconds (once per second).

3. Run the VI. Rotate the knob to get different values for the loop delay.
Notice the effects of the loop delay on the update of the Random
Signal display.

4. Save the VI as Random Signal with Delay.vi in the
LabVIEW\Activity directory. Close the VI

@ End of Activity 3-4.
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Preventing Code Execution in the First lteration

The While Loop always executes at least once, because G performs the
loop test for continuation after the diagram executes. You can construct
a While Loop that pretests its conditional terminal by including a Case
structure inside the loop. Wire a Boolean input to the Case structure
selector terminal so the subdiagram for the FALSE condition executes if
the code in the While Loop should not execute. See Chapter 4, Case and
Sequence Structures and the Formula Node for more information about
using Case structures.

The subdiagram for the TRUE condition contains the work of the While
Loop. The test for continuation occurs outside the Case structure, and the
results are wired to the conditional terminal of the While Loop and the
selector terminal of the Case structure. In the following illustration, labels
represent the pretest condition.

A A[Truz

Fretest
Condition

Fretest |
Condition

This example has the same result as the following pseudocode:
While (pretest condition)
Do actual work of While Loop

Loop
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Shift Registers

Shift registers (available for While Loops and For Loops) transfer
values from one loop iteration to the next. You can create a shift register
by popping up on the left or right border of a loop and selecting

Add Shift Register.

Online Help
Deszcription...

Shiow 3
Replace »

Remave while Loop

The shift register contains a pair of terminals directly opposite each other
on the vertical sides of the loop border. The right terminal stores the data
upon the completion of an iteration. That data shifts at the end of the
iteration and appears in the left terminal at the beginning of the next
iteration, as shown in the following illustration. A shift register can hold
any data type—numeric, Boolean, string, array, and so on. The shift
register automatically adapts to the data type of the first object you wire
to the shift register.
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Before Loop Begins First lteration

Inital Inital
Value Value
—p

Subsequent lterations Last lteration

Previous
Value

Previous
Value

You can configure the shift register to remember values from several
previous iterations. This feature is useful for averaging data points.

You create additional terminals to access values from previous iterations
by popping up on the left or right terminal and choosing Add Element.
For example, if a shift register contains three elements in the left terminal,
you can access values from the last three iterations, as shown in the
following illustration.

Contains i-1 —p] Previous values Latest value —»|
Contains i-2 —p] are available at passes to the
Contains i-3—p»| the left terminal. right terminal.

Pop up on left
terminal to add
new elements or
use Positioning
tool to resize the
left terminal to
expose more
elements.

Pop up on border
for new shift register.
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) Activity 3-5.  Use a Shift Register

Your objective is to build a VI that displays a running average on a chart.

|\g@

Front Panel

1. Open a new front panel and create the objects as shown in the
following illustration.

R andom Flot
Enable 20-

Ok
OFF /5=

“Wertical Switch 1.0-
Default -> OM :
techanical Action

Latch 'when Preszed

PlotD |

05-
*wf aveformn Chart®

0.0-! Scrollbar showing
1]

* Free Label®
TN —

Tranzparent Labels
W %] $-241 )

2. Change the scale of the Waveform chart to range from 0.0 to 2. 0.

After adding the vertical switch, pop up on it and select Mechanical
Action»Latch When Pressed and set the ON state to be the default by
choosing Operate»Make Current Values Default.

Block Diagram

4. Build the block diagram shown in the following illustration.

R andorn Plot

Cormpound Arithmeticy

00
(N,
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Qi
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5. Add the While Loop (Functions»Structures) in the block diagram
and create the shift register.

a. Pop up on the left or right border of the While Loop and choose
Add Shift Register.

b. Add an extra element by popping up on the left terminal of the
shift register and choosing Add Element. Add a third element in
the same manner as the second.

Random Number (0-1) function (Functions»Numeric)—This function
generates random data ranging between 0 and 1.

Compound Arithmetic function (Functions»Numeric)—In this activity,
the compound arithmetic function returns the sum of random numbers from
two iterations. To add more inputs, pop up on an input and choose Add
Input from the pop-up menu.

Divide function (Functions»Numeric)—In this activity, the divide
function returns the average of the last four random numbers.

Numeric Constant (Functions»Numeric)—During each iteration of the
While Loop, the Random Number (0—1) function generates one random
value. The VI adds this value to the last three values stored in the left
terminals of the shift register. The Random Number (0—1) function divides
the result by four to find the average of the values (the current value plus
the previous three). Then the average is displayed on the waveform chart.

Wait Until Next ms Multiple function (Functions»Time & Dialog)—This
function ensures that each iteration of the loop occurs no faster than the
millisecond input. The input is 500 milliseconds for this activity. If you pop
up on the icon and choose Show»Label, the label Wait Until Next ms
Multiple appears.

6. Pop up on the input of the Wait Until Next ms Multiple function and
select Create Constant. A numeric constant appears and is
automatically wired to the function.

7. Type 500 in the label. The numeric constant wired to the Wait Until
Next ms Multiple function specifies a wait of 500 milliseconds
(one half-second). Thus, the loop executes once every half-second.
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Notice that the VI initializes the shift registers with a random number.

If you do not initialize the shift register terminal, it contains the default
value or the last value from the previous run and the first few averages are
meaningless.

8. Run the VI and observe the operation.

9. Save this VI as Random Average.vi in the LabVIEW\Activity
directory.

= Note

into your current data measurements

@ End of Activity 3-5.

Using Uninitialized Shift Registers

Remember to initialize shift registers to avoid incorporating old or default data

© National Instruments Corporation 3-17

You initialize a shift register by wiring a value from outside a While Loop
or For Loop to the left terminal of the shift register. Sometimes, however,
you want to execute a VI repeatedly with a loop and a shift register, so that
each time the VI executes, the initial output of the shift register is the last
value from the previous execution. To do that, you must leave the left shift
register terminal unwired from outside the loop. Leaving the input to the
left shift register terminal unwired preserves state information between
subsequent executions of a VI.

The following illustration shows an example of a subVI that calculates the
running average of four data points. The VI uses an uninitialized shift
register (with three additional elements) to store previous data points.

Running Average.vi _ (O]
File Edt Operate Project Windows Help Bso
| 13pt Application Font rerage
new input unning average
3000 0.00
7163 4| |l
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Running Average.vi Diagram [_ (O] x|

File Edit Operate Project Windows Help Hom
EE |13ptﬁ3«pplica average

runniné averaée

7063 4 |L|j

Each time the VI is called, running average is computed from the new
input and the previous three values. Then the new value is saved into the
shift register, and the previous two values are moved up in the shift register.
There is no input value wired to the input side of the left shift registers, so
all three values are preserved for the next execution of the VI.

Because this subVI has nothing wired to the condition terminal, it executes
exactly once when called. The While Loop in this subVI is not used to loop
several times, but to store values in the loop shift registers between calls.

When the Running Average VI is loaded into memory, the uninitialized
shift registers are set to zero automatically. If the shift registers are wired to
Boolean values, the initial value is FALSE.
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7 Activity 3-6.  Create a Multiplot Chart

Your objective is to create a chart that can accommodate more than
one plot.

Open the Random Average.vi you created in Activity 3-5.

2.  Modify the Front Panel as shown in the following illustration.
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Using the Positioning tool, stretch the legend to include two plots.

Show the digital display by popping up on the chart, and choosing
Show»Digital Display. Move the legend if necessary.

Rename Plot O to Current Value by double-clicking on the
label with the Labeling tool and typing in the new text. You can
resize the label area by dragging either of the left corners with
the Positioning tool. Rename Plot 1 to Running Avg in the
same way.

For the Current value plot, change the interpolation to
unconnected, the point style to square, and the color to green. You
can change the plot style and color by popping up on the legend.
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Block Diagram

3. Modify the block diagram, as shown in the following illustration,
to display both the average and the current random number on the
same chart.

R andom Floh =

E nablef

E@ Bundle function (Functions»Cluster)—In this activity, the Bundle
function bundles the average and current value for plotting on the chart.
L The bundle node appears as shown at left when you place it in the block

diagram. You can add additional elements by using the Resizing cursor
(accessed by placing the Positioning tool at the corner of the function)
to enlarge the node.

Note The order of the inputs to the Bundle function determines the order of the plots on
the chart. For example, if you wire the raw data to the top input of the Bundle
function and the average to the bottom, the first plot corresponds to the raw data
and the second plot corresponds to the average.

4. From the front panel, run the VI. The VI displays two plots on the
chart. The plots are overlaid. That is, they share the same vertical scale.

5. From the block diagram, run the VI with execution highlighting turned
on to see the data in the shift registers.

6. Turn execution highlighting off. From the front panel, run the VI.
While the VI is running, use the buttons from the palette to modify the
chart. You can reset the chart, scale the X or Y axis, and change the
display format at any time. You also can scroll to view other areas or
zoom into areas of a graph or chart.

o You can use the X and Y buttons to rescale the X and Y axes, respectively.
If you want the graph to autoscale either of the scales continuously, click on
|:[| the lock switch to the left of each button to lock on autoscaling.
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You can use the other buttons to modify the axis text precision or to control
the operation mode for the chart. Experiment with these buttons to explore
their operation, scroll the area displayed, or zoom in on areas of the chart.

7. Format the scales of the waveform chart to represent either absolute or
relative time. To select the x scale time format, pop up on the x-scale
and select Formatting....

a.

Choose absolute time by selecting the Time & Date option from
the Format and Precision menu ring. This changes the dialog
box to the one shown below. For the waveform chart to start at a
certain time and increment at certain intervals, you can edit the
Xo and dX values respectively.

¥ Scale Formatting E

Scale Style tapping Mode ——

Farmat and Frecision: Example:

I Tirne & Date vl 07:28:39 PM
0241741995

o s Linear ¥ Time
22 7% AMPM 7 HH: MM
Eie Clsthors 24 hour % HH:MM 55

L~ [T wess
L~ [T s

Seconds Precigion: I 1]

-5Scaling Factors ——M [¥ Date

p] d[H:MM:55] ¥ MDA ¥ Don't Show Year
|12:DD:DEI.DE| PM | [10:00.00 DA ¥ 2 Digit Year
10/24/1336 YD @ 4 Digit Yaar

ak. I Canicel |

b. Format the chart to display the data starting from noon,

Oct. 24, 1996 and increment every 10 minutes, as shown above.

Note Modifying the axis text format often requires more physical space than was
originally set aside for the axis. If you change the axis, the text may become larger
than the maximum size that the waveform can correctly present. To correct this,
use the Resizing cursor to make the display area of the chart smaller.

© National Instruments Corporation
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8. To select the relative time format, select Numeric from the Format
and Precision menu ring. Then you can select the Relative Time
(seconds) option in the dialog box and represent the time in seconds.
Modify the dialog box, as shown in the following illustration, and

select OK.
X Scale Formatting [ x|
Format and Precision: Example:
. I Humeric vI 15
Scale Style tapping Mode —
e #  Linear
o - I Decimal ;I

Grid Optiong

] [T s [0 Digis of Fresision
@ m P i~ Floating Paint Maotation

¥ Scientific Notation
rScaling Factors————————————————— ¥~ Engineering Motation
#0 s i+ Relative Time [seconds)
J0.00E+0 |1.00E+0

ak. I Cancel

9. Run the VL.

10. Save the VI as Multiple Random Plot.vi in the
LabVIEW\Activity directory.

@ End of Activity 3-6.

For Loops

LabVIEW User Manual

A For Loop executes a section of code a defined number of times. It is
resizable, and, like the While Loop, is not dropped on the block diagram
immediately. Instead, a small icon representing the For Loop appears in the
block diagram, and you have the opportunity to size and position it. To do
so, first click in an area above and to the left of all the terminals. While
holding down the mouse button, drag out a rectangle that encompasses the
terminals you want to place inside the For Loop. When you release the
mouse button, G creates a For Loop of the size and position you selected.
You place the For Loop on the block diagram by selecting it from
Functions»Structures.
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Loop Count —p>|M
Numerical Input

Numerical
Output

[}—

The For Loop executes the diagram inside its border a predetermined
number of times. The For Loop has two terminals, explained below.

E Count terminal (an input terminal)—The count terminal specifies the
number of times to execute the loop.

m Iteration terminal (an output terminal)—The iteration terminal contains the
number of times the loop has executed.
The For Loop is equivalent to the following pseudocode:
For i = 0 to N-1

Execute Diagram Inside The Loop

The following illustration shows a For Loop that generates 100 random
numbers and displays the points on a chart.
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Numeric Conversion

Note

Until now, all the numeric controls and indicators you have used have been
double-precision, floating-point numbers represented with 32 bits. G,
however, can represent numerics as integers (byte, word, or long) or
floating-point numbers (single-, double-, or extended-precision). The
default representation for a numeric is a double-precision, floating-point.

If you wire two terminals together that are of different data types,

G converts one of the terminals to the same representation as the other
terminal. As a reminder, G places a gray dot, called a coercion dot, on the
terminal where the conversion takes place.

For example, consider the For Loop count terminal. The terminal
representation is a long integer. If you wire a double-precision,
floating-point number to the count terminal, G converts the number to a
long integer. Notice the gray dot in the count terminal of the first For Loop.

Couble Precision Laong Integer

N
Gray Dot/
o . 0

When the VI converts floating-point numbers to integers, it rounds to the nearest
integer. If a number is exactly halfway between two integers, it is rounded to the
nearest even integer. For example, the VI rounds 6.5 to 6, but rounds 7.5 to 8. This
is an IEEE standard method for rounding numbers. See the IEEE Standard 754

Jor details.

LabVIEW User Manual
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) Activity 3-7.  Use a For Loop

Your objective is to use a For Loop and shift registers to calculate the
maximum value in a series of random numbers.

|\g@

Front Panel

1. Open a new front panel and add the objects shown in the following

illustration.
[Mascimum Yalue] [Random Data
1.0+ 000
0.8
0.6
0.4
0.2
0.0-¢ |
o o0
L1 [
a. Place a digital indicator on the front panel and label it Maximum
Value.
e b. Place a waveform chart on the front panel and label it Random
: J"} Data. Change the scale of the chart to range from 0.0 to 1.0.

c. Pop up on the chart and choose Show»Scrollbar and
Show»Digital Display. Pop up and hide the palette and legend.

d. Resize the scrollbar with the positioning tool.
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Block Diagram

2. Open the block diagram and modify it as shown in the following
J illustration.

Randorn Data
UL Fazirmurn alue

&

3. Place a For Loop (Functions»Structures) on the block diagram.

= 4. Add the shift register by popping up or right-clicking on the right or
left border of the For Loop and choosing Add Shift Register.

5. Add the following objects to the block diagram.

Random Number (0—1) function (Functions»Numeric)—This function
generates the random data.

i

Numeric Constant (Functions»Numeric)—The For Loop needs to know
how many iterations to make. In this case, you execute the For Loop
100 times.

Numeric Constant (Functions»Numeric)—You set the initial value of the
shift register to zero for this exercise because you know that the output of
the random number generator is from 0.0 to 1.0.

You must know something about the data you are collecting to initialize a
shift register. For example, if you initialize the shift register to 1.0, then that
value is already greater than all the expected data values, and is always the
maximum value. If you did not initialize the shift register, then it would
contain the maximum value of a previous run of the VI. Therefore, you
could get a maximum output value that is not related to the current set of
collected data.
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inputs and outputs the maximum value of the two in the top right corner and
the minimum of the two in the bottom right corner. Because you only are
interested in the maximum value for this exercise, wire only the maximum
output and ignore the minimum output.

B Max & Min function (Functions»Comparison)—Takes two numeric
L3

6. Wire the terminals as shown. If the Maximum Value terminal were
inside the For Loop, you would see it continuously updated, but
because it is outside the loop, it contains only the last calculated
maximum.

Note Updating indicators each time a loop iterates is time-consuming and you should
try to avoid it when possible to increase execution speed.

7. Run the VI.
8. Savethe VI as Calculate Max.vi in the LabVIEW\Activity
directory.

@ End of Activity 3-7.
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Case and Sequence Structures
and the Formula Node

This chapter introduces the basic concepts of Case and Sequence structures
and the Formula Node, and provides activities that explain the following:

*  How to use the Case structure
*  How to use the Sequence structure
*  What sequence locals are and how to use them

¢ What a Formula Node is and how to use it

Both Case and Sequence structures can have multiple subdiagrams,
configured like a deck of cards, of which only one is visible at a time. At the
top of each structure border is the subdiagram display window, which
contains a diagram identifier in the center and decrement and increment
buttons at each side. The diagram identifier indicates which subdiagram
currently is displayed. For Case structures, a diagram identifier is a list

of values which select the subdiagram. For Sequence structures, a diagram
identifier is the number of the frame in the sequence (0 to n — 1). The
following illustration shows a Case structure and a Sequence structure.

Increment/Decrement
Buttons ¢

/
flal 1[0.1]}

Diagram
Identifier

Case Structure Sequence Structure

Clicking on the decrement (left) or increment (right) button displays the
previous or next subdiagram, respectively. Incrementing from the last
subdiagram displays the first subdiagram, and decrementing from the first
subdiagram displays the last. For more information about Case and
Sequence structures, refer to Chapter 19, Structures, in the G Programming
Reference Manual.
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Case Structure

Note

The Case structure has two or more subdiagrams, or cases, exactly one of
which executes when the structure executes. This depends on the value
of an integer, Boolean, string, or enum value you wire to the external side
of the selection terminal or selector. A Case structure is shown in the
following illustration.

Case statements in other programming languages generally do not execute any

case if a case is out of range. In G, you must either include a default case that
handles out-of-range values or explicitly list every possible input value.

L Activity 4-1. Use the Case Structure

==

—/

Front Panel

LabVIEW User Manual

Your objective is to build a VI that checks a number to see if it is positive.
If the number is positive, the VI calculates the square root of the number;
otherwise, the VI returns an error.

1. Open a new front panel and create the objects as shown in the
following illustration.

#digital control# *digital indicator *

|—99999.DD indicates an error|

*free label*

The Number control supplies the number. The Square Root Value
indicator displays the square root of the number. The free label acts as a
note to the user.
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Block Diagram

2. Build the diagram as shown in the following illustration.

Square Root Y alue

Murnber
St | n : Pt
-33959.00
Error...
Megatiee Number
Selection
Terminal

3. Place a Case structure in the block diagram by selecting it from
Functions»Structures. The Case structure is a resizable box that is
not dropped on the diagram immediately. Instead, you have the chance
to position it and resize it. To do so, click in an area above and to the
left of all the terminals you want to be inside the Case structure.
Continue holding down the mouse button and drag out a rectangle that
encompasses the terminals.

Greater Or Equal To 0? function (Functions»Comparison)—Returns a
[@:’ TRUE if the number input is greater than or equal to 0.

I> Square Root function (Functions»Numeric)—Returns the square root of
the input number.
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Numeric Constant (Functions»Numeric)—In this activity, the constant
indicates the numeric value of the error.

% One Button Dialog function (Functions» Time & Dialog) —In this activity,
the function displays a dialog box that contains the message
Error...Negative Number.

Error String Constant (Functions»String)—Enter text inside the box with the
Megative Nurmber Labeling tool.

The VI executes either the TRUE case or the FALSE case. If the number is
greater than or equal to zero, the VI executes the TRUE case and returns the
square root of the number. The FALSE case outputs —99999.00 and
displays a dialog box with the message Error...Negative Number.

Note You must define the output tunnel for each case. When you create an output
tunnel in one case, tunnels appear at the same position in all the other cases.
Unwired tunnels appear as white squares.

4. Return to the front panel and run the VI. Try a number greater than zero
and a number less than zero by changing the value in the digital control
you labeled Number. Notice that when you change the digital control
to a negative number, LabVIEW displays the error message you set up
in the FALSE case of the Case structure.

5. Save the VI as Square Root.vi inthe LabVIEW\Activity
directory.

VI Logic

The block diagram in this activity has the same effect as the following
pseudocode in a text-based language.

if (Number >= 0) then

Square Root Value = SQRT (Number)

else

Square Root Value = -99999.00

Display Message "Error...Negative Number"

end if

@ End of Activity 4-1.
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Sequence Structures

The Sequence structure, which looks like frames of film, executes block
diagrams sequentially. In conventional programming languages, the
program statements execute in the order in which they appear. In data flow
programming, a node executes when data is available at all of the node
inputs, although sometimes it is necessary to execute one node before
another. G uses the Sequence structure as a method to control the order in
which nodes execute. G executes the diagram inside the border of Frame 0
first, it executes the diagram inside the border of Frame 1 second, and so
on. As with the Case structure, only one frame is visible at a time.

A Sequence structure is shown in the following illustration.

1[0.1]

ooooano

d

:ﬁ Activity 4-2. Use a Sequence Structure

Your objective is to build a VI that computes the time it takes to generate
a random number that matches a given number.

Front Panel

1. Open a new front panel and build the front panel shown in the
following illustration. Be sure to modify the controls and indicators
as described in the text following the illustration.

MHumber to Match Current Mumber
=[50 50
*digital control® “digital indicator®
[lata Range Frecigion =10
Min =10
IME'” = wlt:l ] # of iterations
nerement =
Default = 50 135
DL:lt.Df range -» Suspend *digital indicatar*
Precision =0 Representation -» 132
Time to katch
023 zEC
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132
EE
—

LabVIEW User Manual

The Number to Match control contains the number you want to match.
The Current Number indicator displays the current random number.
The # of iterations indicator displays the number of iterations before
amatch. Time to Match indicates how many seconds it took to find the
matching number.

Modifying the Numeric Format

By default, LabVIEW displays values in numeric controls in decimal
notation with two decimal places (for example, 3.14). You can use the
Format & Precision... option of a control or indicator pop-up menu to
change the precision or to display the numeric controls and indicators in
scientific or engineering notation. You can also use the

Format & Precision... option to denote time and date formats for
numerics.

2. Pop up on the Time to Match digital indicator and choose
Format & Precision.... The front panel must be the active window to
access the menu.

3. Enter 3 for Digits of Precision and click OK.

Format & Precision 1]

Farmat: Evample:

I Murmeric: vl 314

I 3 Digits of Precision

& Floating Point Maotation
 Scientific Notation

£ Engineering MNaotation
& Relative Time [zeconds)

ak. I Cancel

4.  Pop up on the Number to Match digital control and choose

Representation»132.

5. Repeat Step 4 for the Current Number and the # of iterations digital

indicators.
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Setting the Data Range

@ With the Data Range... option, you can prevent a user from setting a
control or indicator value outside a preset range or increment. Y our options
are to ignore the value, coerce it to within range, or suspend execution. The
range error symbol appears in place of the run button in the toolbar when a
range error suspends execution. Also, a solid, dark border frames the
control that is out of range.

6. Pop up on the Number to Match indicator and choose Data Range....

7. Fill in the dialog box as shown in the following illustration and
click OK.

Reprezentation

132 kimirnum |E|
=1 L]
/= .

G ERIE ] |1IJD
Long

Inerament |1

I alue iz Out of A ange:
Suspend = Default [0

Idse Default Walues |

ak. I Cancel |

Block Diagram
Open the block diagram.

Place the Sequence structure (Functions»Structures) in the block
diagram.

10. Enlarge the structure by dragging one corner with the Resizing cursor.
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11. Create a new frame by popping up on the frame border and choose
Add Frame After. Repeat this step to create frame 2.

12. Build the block diagram shown in the following illustrations.

-DDDDDDDDDDDDDDDD[‘DD2E|E|E|E|E|E|E|E|E|E|E|E|E|E|E|E|E|D

Get initial tire

Tick Count [mz

+
OO0000000000000000000000000000000000020 10

-DDDDDDDDDDDDDDDD[“ID2E|E|E|E|E|E|E|E|E|E|E|E|E|E|E|E|EID

Perfarm Auto bMatch. vi

Mumber to Match f of iterations|

|ncrement

" zhartg at 0
20 increment by 1%

+
OO0000000000000000000000000000000000020 10
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1000000000000 0000 2020000000 o0oo0oooo

Get final time. Compute time delay in seconds.

Timne bo katch

+
O0O0000000000000000000000000000000000 O

Frame 0 in the previous illustration contains a small box with an arrow in
it. That box is a sequence local variable which passes data between frames
of a Sequence structure. You can create sequence locals on the border of a
frame. Then, the data wired to a frame sequence local is available in
subsequent frames. However, you cannot access the data in frames
preceding the frame in which you created the sequence local.

13. Create the sequence local by popping up on the bottom border of
Frame 0 and choosing Add Sequence Local.

The sequence local appears as an empty square. The arrow inside the square
appears automatically when you wire a function to the sequence local.

14. Finish the block diagram as shown in the opening illustration of the
Block Diagram section in this activity.

Tick Count (ms) function (Functions»Time & Dialog)—Returns the
number of milliseconds that have elapsed since power on. For this activity,
you need two Tick Count functions.

Random Number (0—1) function (Functions»Numeric)—Returns a
random number between 0 and 1.

Multiply function (Functions»Numeric)—In this activity, the function
multiplies the random number by 100.

Numeric Constant function (Functions»Numeric)—In this activity, the
numeric constant represents the maximum number that can be multiplied.
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>
[

LAV

Round to Nearest function (Functions»Numeric)—In this activity, the
function rounds the random number between 0 and 100 to the nearest whole
number.

Not Equal? function (Functions»Comparison)—In this activity, the
function compares the random number to the number specified in the front
panel and returns a TRUE if the numbers are not equal. Otherwise, this
function returns FALSE.

Increment function (Functions»Numeric)—In this activity, the function
increments the While Loop count by 1.

Subtract function (Functions»Numeric)—In this activity, the function
returns the time (in milliseconds) elapsed between frame 2 and frame 0.

Divide function (Functions»Numeric)—In this activity, the function
divides the number of milliseconds elapsed by 1,000 to convert the number
to seconds.

Numeric constant (Functions»Numeric)—In this activity, the function
converts the number from milliseconds to seconds.

In Frame 0, the Tick Count (ms) function returns the current time in
milliseconds. This value is wired to the sequence local, where the value is
available in subsequent frames. In Frame 1, the VI executes the While Loop
as long as the number specified does not match the number that the Random
Number (0-1) function returns. In Frame 2, the Tick Count (ms) function
returns a new time in milliseconds. The VI subtracts the old time (passed
from Frame O through the sequence local) from the new time to compute
the time elapsed.

15. Return to the front panel and enter a number inside the Number to
Match control and run the VL.

16. Save the VI as Time to Match.vi in the LabVIEW\Activity
directory.

@ End of Activity 4-2.

LabVIEW User Manual
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Formula Node

The Formula Node is a resizable box that you can use to enter formulas
directly into a block diagram. You place the Formula Node on the block
diagram by selecting it from Functions»Structures. This feature is
useful when an equation has many variables or is otherwise complicated.
For example, consider the equation below:

y=x2+x+l

If you implement this equation using regular G arithmetic functions, the
block diagram looks like the one in the following illustration.

[

You can implement the same equation using a Formula Node, as shown in
the following illustration

Formula Node

With the Formula Node, you can directly enter a complicated formula, or
formulas, in lieu of creating block diagram subsections. You enter formulas
with the Labeling tool. You create the input and output terminals of the
Formula Node by popping up on the border of the node and choosing Add
Input (Add Output). Type the variable name in the box. Variables are case
sensitive. You enter the formula or formulas inside the box. Each formula
statement must end with a semicolon ( ;).
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LabVIEW User Manual

The operators and functions available inside the Formula Node are listed in
the Help window for the Formula Node, as shown in the following
illustration. A semicolon terminates each formula statement.

Help =] E3
[
Formula Mode operators, lowest precedence first;
azzignment =
conditional 7
logical ORI logical AND &
relational == l= » ¢ = <=
anthmetic  + - * 4 °
unary + -
Formula Mode functions:
abz acos acosh aszin asinh atan atanh ceil
coz cosh cot csc exp expml floor getexp getman
int intrz In Ihpl log log2 max min mod rand
rem sec sign sin ginc sinh sqrt tan tanh
-
SRR 4V

The following example shows how you can perform a conditional
assignment inside a Formula Node.

Consider the following code fragment that computes the square root of x if
x 1s positive, and assigns the result to y. If x is negative, the code assigns
99 toy.

if (x >= 0) then

y = sqrt (x)

else
y = —-99
end if

You can implement the code fragment using a Formula Node, as shown in
the following illustration.
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Conditional False
Operator  Condition

'

y=[wx=0]7sqrx] : -99;

Square

Murnber Roat

Condition  True
Condition

N

[ Activity 4-3. Use the Formula Node

Your objective is to build a VI that uses the Formula Node to calculate the
following equations.

:

yl = x> - x* + 5
y2 =m * x + Db

where x ranges from O to 10.

You will use only one Formula Node for both equations, and you will
graph the results on the same graph. For more information on graphs,
see Chapter 5, Arrays, Clusters, and Graphs.
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Front Panel

rd

Block Diagram

LabVIEW User Manual

1. Open a new front panel and build the front panel shown in following
illustration. The waveform graph indicator displays the plots of the
equation. The VI uses the two digital controls to input the values for

m and b.
ﬂ W avetorm Graph
e[ 10000~ vl
800.0- y2
b
B00.0-
sooo

400.0-
200.0-

0.0-) 1 [l 1 1 I
a 2 4 E g 10

2. Create the graph legend shown in the following illustration by
selecting Show»Legend. Use the Resizing cursor to drag the legend
downward so it displays two plots. Use the Labeling tool to rename the
plots. You can define the line style for each plot using the legend
pop-up menu. You also can color each plot by using the Color tool on
the plots legend.

3. Build the block diagram shown in the following illustration.

N

Pl=8"3-2"2+5;
p2=m u+b;

v aveform Graph

SE

Formula Node (Functions»Structures). With this node, you can enter
formulas directly. Create the three input terminals by popping up on the
border and choosing Add Input. You create the output terminal by
choosing Add Output from the pop-up menu.
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When you create an input or output terminal, you must give it a variable
name. The variable name must match the one you use in the formula
exactly. The names are case sensitive. That is, if you use a lowercase a in
naming the terminal, you must use a lowercase a in the formula. You can
enter the variable names and formula with the Labeling tool.

Note Although variable names are not limited in length, be aware that long names take
up considerable diagram space. A semicolon ( ; ) terminates the formula
statement.

Numeric Constant (Functions»Numeric). You also can pop up on the

count terminal and select Create Constant to create and wire the numeric
constant automatically. The numeric constant specifies the number of For
Loop iterations. If x range is 0 to 10 including 10, you must wire 11 to the
count terminal.

m Because the iteration terminal counts from O to 10, you use it to control the
x value in the Formula Node.

E' Build Array (Functions»Array) puts two array inputs into the form of a
multiplot graph. Create the two input terminals by using the Resizing
cursor to drag one of the corners. For more information on arrays, see
Chapter 5, Arrays, Clusters, and Graphs.

4. Return to the front panel and run the VI with different values for m
and b.

5. Savethe VI as Equations.vi in the LabVIEW/Activity directory.

@ End of Activity 4-3.

Artificial Data Dependency

Nodes not connected by a wire can execute in any order. Nodes do not
necessarily execute in left-to-right, top-to-bottom order. A Sequence
structure is one way to control execution order when natural data
dependency does not exist.

Another way to control execution order is to create and artificial data
dependency, a condition in which the arrival of data rather than its value
triggers execution of an object. The receiver may not actually use the data
internally. The advantage of artificial dependency is that all of the nodes are
visible at one level, although, in some cases, the confusion created by the
artificial links between the nodes can be a disadvantage.
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You can open the Timing Template (data dep) .vi from
Examples\General\structs.1llb to see how the Timing Template
has been altered to use artificial data dependency rather than a sequence
structure.
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This chapter introduces the basic concepts of polymorphism, arrays,
clusters, and graphs and provides activities that explain auto-indexing and
the Graph and Analysis VIs.

Arrays

An array is a collection of data elements that are all the same type. An array
has one or more dimensions and up to 231 _ 1 elements per dimension,
memory permitting. You access each array element through its index. The
index is in the range O to n — 1, where # is the number of elements in the
array. The following 1D array of numeric values illustrates this structure.
Notice that the first element has index 0, the second element has index 1,
and so on.

index 0 1 2 3 4 5 6 7 8 9
10-elementarray |12 |32 |82 |80 |48 |51|6.0|10]|25]|17

How Do You Create and Initialize Arrays?

If you need an array as a source of data in your block diagram, you can
choose Functions»Array and then select and place the array shell on your
block diagram. Using the Operating tool, you can choose a numeric
constant, Boolean constant, or string constant to place inside the empty
array. The following illustration shows an example array shell with a
numeric constant inserted into the array shell.

To create an array on the front panel, select Array & Cluster from the
Controls palette and place the array shell on your front panel. Then select
an object (numeric, for example) and place that inside the array shell. This
creates an array of numerics.
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Note You also can create an array and its corresponding control on the front panel and
then copy or drag the array control to the block diagram to create a corresponding
constant.

Auto-Indexing

For more information on how to create array controls and indicators on the
front panel, see Chapter 14, Array and Cluster Controls and Indicators, in
the G Programming Reference Manual.

There are several ways to create and initialize arrays on the block diagram.
Some block diagram functions also produce arrays, as the following
illustration shows.

Sine Pattern
String to Byte Array

xX[i]=ASCll code  [1.00

of i" character

{01 234567 83ABCDEF

Array Controls, Constants, and Indicators

You create array controls, constants, and indicators on the front panel or
block diagram by combining an array shell with a numeric, Boolean, string,
or cluster. An array element cannot be another array, chart, or graph.

For examples of arrays, see Examples\Generallarrays.llb.

For Loop and While Loop structures can index and accumulate arrays at
their boundaries automatically. These capabilities collectively are called
auto-indexing. When you enable auto-indexing and wire an array of any
dimension from an external node to an input tunnel on the loop border,
components of that array enter the loop, one at a time, starting with the first
component. The loop indexes scalar elements from 1D arrays, 1D arrays
from 2D arrays, and so on. The opposite action occurs at output tunnels—
elements accumulate sequentially into 1D arrays, 1D arrays accumulate
into 2D arrays, and so on.

Note Auto-indexing is the default for every array wired to a For Loop. You can disable
auto-indexing by popping up on the tunnel (entry point of the input array) and
selecting Disable Indexing.

LabVIEW User Manual
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tunnel

Dizable Indexin

|

m Array Toolz
Create Constant
Create Control

Create |ndicatar

By default, auto-indexing is disabled for every array wired to a While Loop.
Pop up on the array tunnel of a While Loop to enable auto-indexing.

X

] .
~— Activity 5-1. Create an Array
with Auto-Indexing

Your objective is to create an array using the auto-indexing feature of a
For Loop and plot the array in a waveform graph.

DN

You will build a VI that generates an array using the Generate Waveform
VI and plots the array in a waveform graph. You also will modify the VI to
graph multiple plots.

Front Panel

1. Open a new front panel.

aveform Graph
=

.

1.0+
05-

n.o-

-0.5- T T T T
1] 20 40 g0 30 100

o el 2. Place an array shell from Controls»Array & Cluster in the front
k panel. Label the array shell waveform Array.
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Block Diagram

WAVE

&

LabVIEW User Manual

3. Place a digital indicator from Controls»Numeric inside the
element display of the array shell, as the following illustration shows.
This indicator displays the array contents.

‘wavetorm Arra

4. Place a waveform graph from Controls»Graph in the front panel.
Label the graph Waveform Graph.

Enlarge the graph by dragging a corner with the Resizing cursor.
6. Hide the legend and palette.

Disable autoscaling by popping up on the graph and deselecting
Y Scale»Autoscale Y.

8. Use the Text tool to rescale the Y axis to range from -0.5to 1.5.

9. Build the block diagram shown in the following illustration.

Delkax  =a

EE undie vy avefom Graph
I3
I!!H ' [E==

\ i aveform Array

1D Array

Generate YW aveform. i

Generate Waveform VI (Functions»Select a VI... from the
LabVIEW\Activity directory)—Returns one point of a waveform.
The VI requires a scalar index input, so wire the loop iteration terminal
to this input.

Notice that the wire from the Generate Waveform VI becomes thicker as it
changes to an array at the loop border.

The For Loop automatically accumulates the arrays at its boundary. This is
called auto-indexing. In this case, the numeric constant wired to the loop
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count numeric input has the For Loop create a 100-element array (indexed

0t0 99).
EEE N Bundle function (Functions»Cluster)—Assembles the plot components
L2} . . .
[eal ['] into a cluster. You need to resize the Bundle function icon before you can

wire it properly. Place the Positioning tool on the lower-left corner of the

[ icon. The tool transforms into the Resizing cursor shown at left. When the
tool changes, click and drag down until a third input terminal appears.
Now, you can continue wiring your block diagram as shown in the previous
illustration.

the number of For Loop iterations, the initial X value, and the delta X value.
Notice that you can pop up on the For Loop count terminal, shown at left,
and select Create Constant to add and wire a numeric constant for that
terminal automatically.

Numeric Constant (Functions»Numeric)—Three numeric constants set

10. From the front panel, run the VI. The VI plots the auto-indexed
waveform array on the waveform graph. The initial X value is 0 and the
delta X value is 1.

11. Change the delta X value to 0.5 and the initial X value to 20. Run the
VI again.

Notice that the graph now displays the same 100 points of data with a
starting value of 20 and a delta X of 0.5 for each point (see the X axis). In a
timed test, this graph might correspond to 50 seconds worth of data starting
at 20 seconds.

12. You can view any element in the waveform array by entering the index
of that element in the index display. If you enter a number greater than
the array size, the display dims, indicating that you do not have a
defined element for that index.

- If you want to view more than one element at a time, you can resize the
array indicator. Place the Positioning tool on the lower right corner of
the array. The tool transforms into the array Resizing cursor shown at left.
When the tool changes, drag to the right or straight down. The array now
displays several elements in ascending index order, beginning with the
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element corresponding to the specified index, as the following
illustration shows.

W avefarm Array W avefiorm Srray
# oz oz Joes | 6 ooz e
index 6 7 8 index W 7
DEE | 8

In the previous block diagram, you specified an initial X and a delta X value
for the waveform. The default initial X value is zero and the delta X value
is 1. So, you can wire the waveform array directly to the waveform graph
terminal without the initial X and delta X specified, as the following
illustration shows.

Generate "W avefarm. vi

&)

W aveform Graph

\ Wavetform Aray

1D Array

13. Return to the block diagram. Delete the Bundle function and the
numeric constants wired to it. To delete the function and constants,
select the function and constants with the Positioning tool then press
<Delete>. Select Edit>Remove Bad Wires. Finish wiring the block
diagram as shown in the previous illustration.

14. Run the VI. Notice that the VI plots the waveform with an initial
X value of 0 and a delta X value of 1.
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You can create multiplot waveform graphs by building an array of the data
type normally passed to a single-plot graph.

100HM]  Generate Wavebom.vi

Tl Waveform Array

"wiavefarm Graph
=)
..... ~ Build Array T

2D Array

0.50

-i5IH

15. Continue building your block diagram as shown in the preceding
diagram.

Sine function (Functions»Numeric»Trigonometric)—In this activity,
you use the function in a For Loop to build an array of points that represents
one cycle of a sine wave.

Build Array function (Functions»Array)—In this exercise, you use this
function to create the proper data structure to plot two arrays on a waveform
graph, which in this case is a 2D array. Enlarge the Build Array function to
create two inputs by dragging a corner with the Positioning tool.

Pi constant (Functions»Numeric»Additional Numeric Constants)—
Remember that you can find the Multiply and Divide functions in
Functions»Numeric.

16. Switch to the front panel. Run the VI.
Notice that the two waveforms plot on the same waveform graph.

The initial X value defaults to 0 and the delta X value defaults to 1 for
both data sets.
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Note You can change the appearance of a plot on the graph by popping up in the legend
Jor a particular plot. For example, you can change from a line graph to a bar
graph by choosing Common Plots»Bar Graph.

17. Save the VI as Graph Waveform Arrays.vi inthe
LabVIEW\Activity directory.

@ End of Activity 5-1.

In the previous example, the For Loop executed 100 times because a
constant of 100 was wired to the count terminal. The following activity
illustrates another means of determining how many times a loop will
execute.

N

Activity 5-2. Use Auto-Indexing
— on Input Arrays

Your objective is to open and operate a VI that uses auto-indexing in a
For Loop to process an array.

AN

1. Open the Separate Array Values VI by selecting File»Open.... The VI
is located in Examples\General\arrays.1llb.

2. Open the block diagram. The following illustration shows the block
diagram with both TRUE and FALSE cases visible.
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-

[

Initialize
A ay

-
+ g

Input Array
[DEL]

Initialize
ArEay

-
+ @

Input &rray

S Trae B

FPositive &ray

[mEL]

“M[F alse ™

Fositive drray

MNegative Array

[DBL]

Notice that the wire from Input Array changes from a thick wire outside
the For Loop, indicating it is an array, to a thin wire inside the loop,

-th

indicating it is a single element. The i"* element of the array is indexed
automatically from the array during each iteration.

© National Instruments Corporation
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Using Auto-Indexing to Set the For Loop Count

N

Notice that the count terminal is left unwired. When you use auto-indexing
on an array entering a For Loop, the loop executes according to the size of
the array, eliminating the need to wire a value to the count terminal. If you
use auto-indexing for more than one array, or if you set the count in
addition to auto-indexing an array, the actual number of iterations is the
smallest number possible.

3. Run the VI Of the eight input values, you will see four in the Positive
Array and four in the Negative Array.

4. From the block diagram, wire a constant of 5 to the count terminal of
the For Loop. Run the VI. You will see three values in the Positive
Array and two in the Negative Array, even though the input array still
has eight elements. This demonstrates that if N is set and you are
auto-indexing, the smaller number is used for the actual number of
iterations of the loop.

Close the VI and do not save changes.

@ End of Actlwty 9-2.

Using Array Functions

LabVIEW User Manual

G has many functions to manipulate arrays located in Functions»Array.
These functions include Replace Array Element, Search 1D Array,

Sort 1D Array, Reverse 1D Array, and Multiply Array Elements.

For more information about arrays and the array functions available,
refer to Chapter 14, Array and Cluster Controls and Indicators, in the

G Programming Reference Manual or Online Reference»Function and
VI Reference.

Build Array

91;":;?"% [;]I "_T”— array with appended elernent(z)
g

alarnen

clarnenT T

Build Array
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Build Array function (Functions»Array)—You can use it to create an
array from scalar values or from other arrays. Initially, the Build Array
function appears with one scalar input.

You can add as many inputs as you need to the Build Array function, and
each input can be either a scalar or an array. To add more inputs, pop up on
the left side of the function and select Add Element Input or Add Array

L Input. You also can enlarge the Build Array node with the Resizing cursor
(place the Positioning tool at the corner of an object to transform it into the
Resizing cursor). You can remove inputs by shrinking the node with the
Resizing cursor, or by selecting Remove Input.

The following illustration shows two ways to create and initialize arrays
with values from block diagram constants. On the left, five string constants
are built into a 1D array of strings. On the right, three groups of numeric
constants are built into three, 1D numeric arrays. Then, the three arrays are
combined into a 2D numeric array. The result is a 3 x 3 array with the rows
3,4,7,-1,6,2; and 5, -2, 8.

LR Avayol 2D Array
53 | strings of Numbers
=

You also can create an array by combining other arrays along with scalar
elements. For example, suppose you have two arrays and three scalar
elements that you want to combine into a new array with the order array 1,
scalar 1, scalar 2, array 2, and scalar 3.

Initialize Array

Use this function to create an array whose elements all have the same value.
In the following illustration, this function creates a 1D array.

Initialize &rray

"I} '— [132]
H 10 Arra
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The element input determines the data type and the value of each element.
The dimension size input determines the length of the array. For example,
if element is a long integer with the value of five and dimension size
has a value of 100, the result is a 1D array of 100 long integers all set to
five. You can wire the inputs from front panel control terminals, as shown
in the preceding illustration, from block diagram constants, or from
calculations on other parts of your diagram.

To create and initialize an array that has more than one dimension, pop up
on the lower-left side of the function and select Add Dimension. You also

(g can use the Resizing cursor to enlarge the Initialize Array node and add
more dimension size inputs, one for each additional dimension. You can
remove dimensions by shrinking the node by selecting Remove Dimension
from the function pop-up menu or with the Resizing cursor.

The following block diagram shows how to initialize a 3D array.

Initialize &rray

letemnent||[BZ}——
[dimension size 1{|[T5Z]] - [r32]

] A0 Arra
[dirnension size 2|
[dirnension size 3|

If all the dimension size inputs are zero, the function creates an empty array
of the specified type and dimension.

Array Size

Array Size returns the number of elements in the input array.

array E, zizelz)

[7laf2]5] N —1[« |

Array Size = 4 Elements
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31 2|5

. _ 2Rows
2D Array Size = 3 Columns

Array Subset

You can use this function to extract a portion of an array or matrix.

array =
index(07 ..
length —
g i
langitiy 7

sub-array

Array Subset

Array Subset returns a portion of an array starting at index and
containing length elements. The following illustrations show examples
of Array Subsets. Notice that the array index begins with 0.

1DArray|1|2|7|3|2|5|8|—
Index [ 2 ] -t —[ 7 [3]2][5]

Length HH New 1D Array

2D Array
718 2 | 5
2 | 5 7 1

1 4 2 7 ——
;-...:
;-q*

3 2 5
5 7 1
New 2D Array

Row Index |I|
Row Length
Column Index
Column Length
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Index Array

The Index Array function accesses an element of an array.

n-dirmension array =|F_ element ar

1nn:|e::{ 0 — sub-array

-;!-:.ja._-\:: " -‘E e AI

Index Array

The following illustration shows an example of an Index Array function
accessing the third element of an array. Notice that the index of the third
element is 2 because the first element has index 0.

DAray[ 3 [ 2 [ 5[ 7 [1]4]2] |:|—
Index - Element

You also can use this function to slice off one or more dimensions of a
multi-dimensional array to create a subarray of the original. To do this,
stretch the Index Array function to include two index inputs, and select
the Disable Indexing command on the pop-up menu of the second index
terminal as shown in the following illustration. Now you have disabled the
access to a specific array column. By giving it a row index, the result is an
array whose elements are the elements of the specified row of the 2D array.
You also can disable indexing on the row terminal.
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|:| <+— Array —»

.t
o4

Online Help
Drezcriptiar. .

Show 3
Replace 3

Disabled Input
(Empty Box)

le Indexing
Add Dimengion
R emove Dimenzion
Create Congtant
Create Contral
Create Indicator

Notice that the index terminal symbol changes from a solid to an empty
box when you disable indexing. To restore a disabled index, use the
Enable Indexing command from the same menu.

You can extract subarrays along any combination of dimensions.
The following illustration shows how to extract a 1D row or column arrays
from a 2D array.

Extract Column

F ; ZDArray Colurn 3§
:
=3
Fow 2 H
EpE—{E=r]

Extract Row

© National Instruments Corporation 5-15 LabVIEW User Manual



Chapter 5 Arrays, Clusters, and Graphs

From a 3D array, you can extract a 2D array by disabling two index
terminals, or a 1D array by disabling a single index terminal. The following
figure shows several ways to slice a 3D array.

A

The following rules govern the use of the Index Array function to slice
arrays:

e The dimension of the output object must equal the number of disabled
index terminals. For example:

—  Zero disabled = scalar element
—  One disabled = 1D component
— Two disabled = 2D component

e The values wired to enabled terminals must identify the output
elements.

Thus, you can interpret the lower left preceding example as a command to
generate a 1D array of all elements at column 0 and row 3. You can interpret
the upper right example as a command to generate a 2D array of page 1.
The new, 0™ element is the one closest to the original, as shown in the
preceding illustration.
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el Activity 5-3. Use the Build Array Function

g Your objective is to use the Build Array function to combine elements and
arrays into one bigger array.

Front Panel

1.

© National Instruments Corporation

Create a new front panel, as shown in the following illustration.

Place a digital control from the Controls»Numeric palette and label it
scalar 1.Change its representation to I32.

Copy and paste it to create two other digital controls and label them
scalar 2 and scalar 3.

Create an array of digital controls and label it array 1. Copy and
paste it and label it array 2.

Expand the arrays and enter the values 1 through 9 in array 1,
scalar 1, scalar 2,array 2,and scalar 3, asshown in the
illustration above.

Copy the array and paste it and change it to an indicator. Label it
1D array. Expand it to show nine values.
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Block Diagram

7. Place a Build Array function (Functions»Array) on the block
diagram. Expand it with the Positioning tool to have five inputs.

8. Pop up on the first input in the Build Array node and select Change to
Array. Do the same for the fourth input.

9. Wire the arrays and scalars to the node. The output array is a 1D array
composed of the elements of array 1 followed by scalar 1,
scalar 2, and the elements of array 2 and scalar 3, as the
following illustration shows.

Build &rray

|ar’r‘al,| 1||ﬁ|—ﬁ-:|+ =
|5ca]ar‘ 1|II—| [:]I [x32]
|5ca]ar‘ 2| 10 array

10. Run the VI. You can see the values in scalar 1, scalar 2,
scalar 3,array 1,and array 2 appear in a single 1D array.

]
+
L

11. Save the VI as Build Array.vi in the LabVIEW\Activity
directory.

@ End of Activity 5-3.

Efficient Memory Usage: Minimizing Data Copies

To save memory, you can use single-precision arrays instead of
double-precision arrays. For information about how memory is allocated,
see the section Monitoring Memory Usage in Chapter 28, Performance
Issues, in the G Programming Reference Manual.
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What is Polymorphism?

Polymorphism is the ability of a function to adjust to input data of different
types, dimensions, or representations. Most G functions are polymorphic.
For example, the following illustrations show some of the polymorphic
combinations of the Add function.

Combination Result

Scalar + Scalar > Scalar
2

2
Scalar + Array EEER Array
THIER >

Array + Array EEERN } EEREE B
iZiEE

In the first combination, the two scalars are added together, and the result
is a scalar. In the second combination, the scalar is added to each element
of the array, and the result is an array. An array is a collection of data. In the
third combination, each element of one array is added to the corresponding
element of the other array. You also can use other combinations, such as
clusters of numerics or arrays of clusters.

You can apply these principles to other G functions and data types.

G functions are polymorphic to different degrees. Some functions might
accept numeric and Boolean inputs, others might accept a combination of
any other data types. For more information about polymorphism, see
Online Reference»Function and VI Reference.
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Clusters

Graphs

A cluster is a data type that can contain data elements of different types.
The cluster in the block diagram that you will build in Activity 5-4 groups
related data elements from multiple places on the block diagram, reducing
wire clutter. When you use clusters, your subVlIs require fewer connection
terminals. A cluster is analogous to a record in Pascal or a struct in C. You
can think of a cluster as a bundle of wires, much like a telephone cable.
Each wire in the cable would represent a different element of the cluster.
The components include the initial X value (0), the delta X value (1), and
the Y array (waveform data, provided by the numeric constants on the
block diagram). In G, use the Bundle function to assemble a cluster. For
more information about Clusters refer to Chapter 14, Array and Cluster
Controls and Indicators, in the G Programming Reference Manual.

A graph is a two-dimensional display of one or more data arrays called
plots. There are three types of graphs in the Controls»Graph palette:

XY graph
*  Waveform graph
e Intensity graph

The difference between a graph and a chart is that a graph plots data as a
block, whereas a chart plots data point by point, or array by array.

For examples of graph VIs, see Examples\General\Graphs.

Customizing Graphs

LabVIEW User Manual

Both waveform and XY graphs have a number of optional parts that you
can show or hide using the Show submenu of the pop-up menu for the
graph. The options include a legend, through which you can define the
color and style for a given plot, a palette from which you can change scaling
and format options while the VI is running, and a cursor display. The
following illustration of a graph shows all of the optional components
except for the cursor display.
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Major Grids Minor Grids

label
10.0- 0. [[——]

2.0

Y Scale —» &.0

Legend

4.0
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u] 2 4 & g 10 | €— X Scale

[[l <4— Palette
[ |

Graph Cursors

You can place cursors and a cursor display on all the graphs in G, and you
can label the cursor on the plot. You can set a cursor to lock onto a plot, and
you can move multiple cursors at the same time. There is no limit to the
number of cursors a graph can have. The following illustration shows a
waveform graph with the cursor display.

0| Eud Jmm JEe =R

@lcm | Eo0 | 1EEE
p P AL

Y Position |  Style

Cursor

Movement X Position Control
Control  Cursor Lock
Name to Plot
Active Control
Cursor Button
for Cursor
Movement

For more detailed information on customizing graphs, see Chapter 15,
Graph and Chart Controls and Indicators, in the G Programming
Reference Manual.
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Refer to the ZoomGraph VI in Examples\General\Graphs\zoom.1l1lb
for an example that reads cursor values and programmatically zooms in and
out of a graph using the cursors.

Graph Axes

You can format the scales of a graph to represent either absolute or relative
time. Use absolute time format to display the time, date, or both for your
scale. If you do not want G to assume a date, use relative time format.

To select absolute or relative time format, pop up on the chart and select
the scale you want to modify. Select Formatting.... This enables the
Formatting dialog box, which you can use to specify different attributes
of the chart.

Data Acquisition Arrays

Data returned from a plug