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GETTING STARTED

NI ISM-7400/7401/7402 
Integrated Steppers and NI 9512 
C Series Modules
This document explains how to install and configure the NI ISM-7400/7401/7402 integrated 
steppers for use with the NI 9512 C Series drive interface module. 
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What You Need to Get Started

You need the following items to get started.

Hardware
 NI 9512 C Series stepper drive interface module.

 NI Real-Time controller.
– CompactRIO controller and chassis that support the RIO Scan Interface.
or
– NI 9146, 9147, 9148, or 9149 Ethernet RIO Expansion Chassis.
or
– NI 9144 distributed chassis and compatible RT controller.

 +24 V power supply (such as the NI PS-15) for the CompactRIO controller
(NI part number 781093-01)

 Separate +24 V power supply for the NI 9512 (such as the NI PS-15)

 NI PS-12 (+24 V) or NI PS-13 (+48 V) power supply for the NI integrated stepper

Note The power supply required for your application will depend on the torque and 
speed requirements, as well as the motor used. Refer to the product data sheet to help 
choose a suitable power supply.

 Ethernet connection and cable for the CompactRIO controller or Ethernet RIO Expansion 
Chassis.

 NI 951x Cable and Terminal Block bundle (NI part number 780553-01).

 NI ISM-7400/7401/7402 integrated stepper.

Software
 LabVIEW 2010 (minimum).

 LabVIEW 2010 Real-Time Module (minimum).

 LabVIEW 2010 NI SoftMotion Module (minimum).

 NI-RIO 3.5.0 (minimum).
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Figure 1 shows the required hardware and software.

Figure 1.  NI 9512 to NI ISM Connections

Hardware Installation and Configuration

This section covers the hardware setup for the Real Time system, NI 9512 C Series module, and 
NI ISM-7400/7401/7402 integrated stepper.

Step 1: Set Up the Real Time System
Complete the following steps to set up the Real Time system depending on your hardware
1. Refer to the Getting Started guide included with the Real-Time controller to assemble it, 

connect it to power, discover it on the network, and install the software in NI MAX.
2. Install the NI 9512 module in an available slot that supports High Speed Interface (HSI) in 

your chassis.

Note Older model chassis, such as cRIO-902x, cRIO-907x, cRIO-908x, NI 9144, 
and NI 9148, have HSI support on slots 1 through 4. Refer to your chassis 
documentation for more information about HSI slot support.
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Step 2: Connect the NI 9512 to the 37-Pin Terminal 
Block
1. Connect the MDR and DSUB connectors on the NI 951x Y-cable to the MDR and DSUB 

connectors on the NI 9512 module. 
2. Connect the 37-pin DSUB to the DSUB connector on the NI 951x terminal block.

Figure 2 shows the 37-pin terminal block pin assignments.

Figure 2.  NI 9512 37-Pin Terminal Block Pin Assignments

Step 3: Connect the 37-Pin Terminal Block to the +24 V 
Power Supply
1. Connect the V+ terminal from the 24 V power supply to one of the two Vsup inputs on the 

37-pin terminal block. The 37-pin terminal block provides a Vsup input for the NI 9512 on 
pin 14 and pin 22. 

2. Connect the V- terminal from the 24 V power supply to one of the COM terminals on the 
37-pin terminal block. The 37-pin terminal block provides COM on pins 3, 5, 8, 17, 24, 
and 32.
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Step 4: Connect the Drive Command Signals
The NI ISM-7400/7401/7402 integrated steppers support both single-ended and differential 
stepper commands. This document provides instruction for single-ended connection only.
1. Connect the integrated stepper Step- wire (brown) to the 37-pin terminal block Step (CW)+ 

terminal (pin 18).
2. Connect the integrated stepper Dir- wire (green) to the 37-pin terminal block Direction 

(CCW)+ terminal (pin 16).
3. Connect the integrated stepper Step+ wire (orange) and Dir+ wire (yellow) to the 37-pin 

terminal block +5V OUT terminal (pin 9). 

Step 5: Connect the Drive Enable Signal
Complete the following steps to connect the Drive Enable signal, which controls the enable 
function of the drive:
1. Connect the En- wire (purple) to the 37-pin terminal block COM terminal (pin 5).
2. Connect the En+ wire (blue) to the 37-pin terminal block Drive Enable terminal (pin 33).

Step 6: (Optional) Connect the Drive Fault Signal
Complete the following steps to map an NI 9512 digital input to the Out signal to monitor the 
NI integrated stepper for faults:
1. Connect the Out+ wire (grey) to the 37-pin terminal block Vsup terminal (pin 22).
2. Connect the Out- wire (white) to the 37-pin terminal block DI 0 terminal (pin 4).

Note If you do not connect the Out+ and Out- signals to the 37-pin terminal block, 
insulate the wires.

Step 7: Connect the Encoder Signals
If your NI ISM includes an encoder, connect the encoder cable to the integrated stepper using 
the included connector, and connect the encoder wires to the 37-pin terminal block as indicated 
in Table 1.

Table 1.  NI ISM to 37-Pin Terminal Block Connections

NI ISM 

Signal Name Wire Color

37-Pin 

Terminal Block 

Pin Number

37-Pin 

Terminal Block 

Signal Name

A blue 25 Encoder 0 Phase A+

A blue/white 26 Encoder 0 Phase A-

B brown 27 Encoder 0 Phase B+

B brown/white 29 Encoder 0 Phase B-
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Step 8: Connect the NI PS-12/13 Power Supply

Note Do not plug in or turn on the power supply until you complete Step 11: Power 
on the Drive and Verify Connections.

Complete the following steps to connect the power supply to AC input power and to the 
NI integrated stepper. Figure 3 shows the power supply terminals.

Figure 3.  NI PS-12/13 Power Supply Terminals

1. Connect an AC input cable to the line, neutral, and ground (protective earth) connectors.
2. Connect the integrated stepper V+ (red) wire to the power supply +V connector.
3. Connect the integrated stepper V- (black) wire to the power supply -V connector.
4. Connect the NI 9512 COM to the NI PS-12/13 -V terminal to ensure a common reference.

I orange 6 Encoder 0 Index+

I orange/white 7 Encoder 0 Index-

GND green/white 8 COM

+5V green 9 +5V OUT

1 +24 V (NI PS-12) or +48 V (NI PS-13) Output
2 +24 V (NI PS-12) or +48 V (NI PS-13) Ground
3 AC Input Ground (Protective Earth)

4 AC Input Neutral
5 AC Input Line

Table 1.  NI ISM to 37-Pin Terminal Block Connections (Continued)

NI ISM 

Signal Name Wire Color

37-Pin 

Terminal Block 

Pin Number

37-Pin 

Terminal Block 

Signal Name

LN-V+V

Made in China

+V  ADJ

+

OUTPUT: 48V      6.7A INPUT: 100-240VAC 5A 50/60Hz

LN-V+V

Made in China

+V  ADJ

+

Serial No.

1 2 3 4 5
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Step 9: Configure the NI ISM-7400/7401/7402 DIP 
Switches
The NI ISM-7400/7401/7402 integrated steppers provide drive configuration DIP switches. 
Figure 4 shows the DIP switch location and functions.

Note If you change the DIP switch settings you must power cycle the NI ISM for 
the new settings to take effect.

Figure 4.  NI ISM-7400/7401/7402 DIP Switches

Refer to Table 2 for the DIP switch settings that this document uses.

Table 2.  DIP Switch Settings

Setting Name Switch Position Corresponding Value

Running Current 100%

Idle Current 50%

Self Test Off

Running Current

On

Idle Current

Self Test
Step Noise Filter
Step Smoothing Filter
Load Inertia

Step Pulse Type

Steps/Rev

1 2

3

4
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Step 10: Cut Off and Insulate the NC Wire
The NC wire on the NI ISM-7400/7401/7402 is unused. NI recommends removing and 
insulating this wire for optimal operation.
1. Cut off the NC wire.
2. Insulate the end of the wire if there is any exposed metal remaining.

Step Noise Filter 2 MHz

Step Smoothing Filter Off

Load Inertia 0 - 4X

Step Pulse Type Step/Dir

Step Size 25000

Table 2.  DIP Switch Settings (Continued)

Setting Name Switch Position Corresponding Value

5

6

7

8

1 2 3 4
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Step 11: Power on the Drive and Verify Connections
After all hardware connections have been made complete the following steps to confirm the 
hardware setup.
1. Turn on all power supplies.
2. Verify that the Drive Status LED on the NI ISM flashes or is solid green. Figure 5 shows 

the location of the Drive Status LED.

Figure 5.  Drive Status LED Location

If the Drive Status LED does not flash or turn solid green, turn off all power, verify the 
connections, and try again. 

Software Installation and Configuration

This section covers installing and configuring software for the NI 9512 C Series module.

Note These instructions assume you have installed all required software from the 
What You Need to Get Started section on your development machine.

Step 1: Install Software on and Configure the NI RT 
Controller
Complete the following steps to configure the controller and install software on it.
1. Launch Measurement & Automation Explorer (MAX) on the development computer by 

clicking the MAX icon on the desktop, or by selecting Start»All Programs»
National Instruments»NI MAX.

2. Select the controller under Remote Systems in the Configuration pane. If you do not see 
the controller, you may need to disable the firewall on the development computer.

3. Verify that the Serial Number in the Identification section matches the serial number on 
the device.

4. Expand the controller item in the tree, right-click Software, and select Add/Remove 
Software.

Drive Status 

LED
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5. Select a recommended software set that includes NI-RIO 2014 (minimum) with NI Scan 
Engine Support. 

6. Click Next and enable the following add-ons:
• LabVIEW SoftMotion Module
• NI Industrial Communications for EtherCAT if using the NI 9144.

7. Click Next to install the selected software on the controller. Click Help if you need 
information about installing recommended software sets.

8. Close MAX.

Step 2: Create a Project and add NI RT Controller
Complete the following steps to create a LabVIEW project.
1. Launch LabVIEW by selecting Start»All Programs»National Instruments»LabVIEW.
2. Click the Empty Project link in the Getting Started window to display the Project 

Explorer window. You can also select File»New Project to display the Project Explorer 
window.

3. Select Help and make sure that Show Context Help is checked. You can refer to the 
context help throughout the tutorial for information about items on the block diagram.

Depending on the hardware configuration being used, continue to the following respective 
sections.

A. CompactRIO Controller
If you are using a CompactRIO controller, complete the following steps to add the device to the 
project and detect the C Series modules.
1. Right-click the top-level project item in the Project Explorer window and select New»

Targets and Devices from the shortcut menu to display the Add Targets and Devices 
dialog box.

2. Make sure that the Existing target or device radio button is selected.
3. Expand Real-Time CompactRIO.
4. Select the CompactRIO controller to add to the project and click OK.
5. If you have LabVIEW FPGA installed, the Select Programming Mode dialog box 

appears. Select Scan Interface to put the system into Scan Interface mode.

Tip Use the CompactRIO Chassis Properties dialog box to change the 
programming mode in an existing project. Right-click the CompactRIO chassis in the 
Project Explorer window and select Properties from the shortcut menu to display 
this dialog box.

6. Click Discover in the Discover C Series Modules? dialog box if it appears.
7. Click Continue.



Getting Started with NI Integrated Steppers and NI 9512 Modules | © National Instruments | 11

8. Right-click the controller item in the Project Explorer window and select Properties from 
the shortcut menu to display the RT Target Properties dialog box. Select Scan Engine 
from the Category list to display the Scan Engine page. 

9. Set the Scan Period to 5 ms or lower.
10. Click OK to close the RT Target Properties dialog box.

B. EtherCAT Master and NI 9144 EtherCAT Expansion Chassis
If you are using the NI 9144 chassis, complete the following steps to add the EtherCAT master 
device and detect the C Series module.
1. Add the Master Real Time Controller to the project. Right click the top level project item 

in the Project Explorer window and select New»Targets and Devices from the shortcut 
menu to display the Add Targets and Devices dialog box.

2. Make sure that Existing target or device radio button is selected.
3. Expand the folder that corresponds to the device you are adding, such as Real Time 

Industrial Controller, Real Time PXI, and so on.
4. Select Real Time to add to the project and click OK.
5. In the LabVIEW Project Explorer window, right-click the master controller and select 

New»Targets and Devices.
6. In the Add Targets and Devices dialog window shown in Figure 6, select Existing target 

or device and expand the category EtherCAT Master Device to auto-discover the EtherCAT 
port on the master controller. An EtherCAT master device and modules can be added 
manually at any time.

Figure 6.  Adding the EtherCAT Master

When all the slave devices are discovered, the LabVIEW Project Explorer window lists each 
slave device and any installed C Series modules.
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C. NI 9146/7/8/9 Ethernet RIO Expansion Chassis
Complete the following steps to add the device to the project and detect the C Series modules if 
the NI 9146/7/8/9 Ethernet RIO Expansion chassis is being used.
1. Right-click the top-level project item in the Project Explorer window and select New»

Targets and Devices from the shortcut menu to display the Add Targets and Devices 
dialog box.

2. Make sure that the Existing target or device radio button is selected.
3. Expand Ethernet RIO.
4. Select the Ethernet RIO expansion chassis to add to the project and click OK.
5. If you have LabVIEW FPGA installed, the Select Programming Mode dialog box 

appears. Select Scan Interface to put the system into Scan Interface mode.

Tip Use the Chassis Properties dialog box to change the programming mode in an 
existing project. Right-click the chassis in the Project Explorer window and select 
Properties from the shortcut menu to display this dialog box.

6. Click Discover in the Discover C Series Modules? dialog box if it appears.
7. Click Continue.
8. Right-click the controller item in the Project Explorer window and select Properties from 

the shortcut menu to display the Ethernet RIO Properties dialog box. Select Scan Engine 
from the Category list to display the Scan Engine page. 

9. Set the Scan Period to 5 ms or lower. 
10. Click OK to close the Ethernet RIO Properties dialog box.

Step 3: Add a SoftMotion Axis to the Project
Complete the following steps to create a LabVIEW project and add a SoftMotion Axis to it. 
1. Right-click the controller item in the Project Explorer window and select New»

NI SoftMotion Axis from the shortcut menu to open the Axis Manager dialog box, shown 
in Figure 7.

2. Click Add New Axis to create an NI SoftMotion axis associated with the NI 9512 module. 
Axes are automatically bound to an available module. You can double-click the axis name 
to rename the axis and give it a descriptive name.
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Figure 7.  Axis Manager Dialog Box

3. Click OK to close the Axis Manager dialog box. The new axis is added to the Project 
Explorer window. 

Note You cannot associate more than one axis with the same C Series module.

When you have finished these steps your LabVIEW project should look similar to the 
image in Figure 8.

Figure 8.  Project Explorer Windows with Modules in Scan Interface Mode
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Step 4: Configure the NI 9512 Axis
Complete the following steps to configure the axis I/O settings for use with the NI ISM 
integrated stepper.
1. Right-click the axis in the Project Explorer window and select Properties from the 

shortcut menu to open the Axis Configuration dialog box.

Note The Axis Configuration dialog box user interface may not match this image 
exactly depending on which version of the LabVIEW NI SoftMotion Module you are 
using.

Figure 9.  Axis Configuration Dialog Box

2. Configure the following settings on the General Settings page ( ).
a. Confirm that Loop Mode is set to Open-Loop. Axes configured in open-loop mode 

produce step outputs but do not require feedback from the motor to verify position.
b. Set Feedback Source to Encoder 0, if you have connected an encoder, or None if you 

do not have an encoder connected.
c. Confirm that the Axis Enabled and Enable Drive on Transition to Active Mode 

checkboxes contain checkmarks. These selections configure the axes to automatically 
activate when the NI Scan Engine switches to Active mode.
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Note Disable these options to prevent axes from automatically activating when the 
NI Scan Engine switches to Active mode.

3. If you have connected an encoder, click the Encoder button ( ) and configure the 
Units and Counts Per Unit.
a. In the Active State section set the Line State for A, B, and Index to High.
b. In the Index Reference Criteria section set the Line State for A and B to Inactive.
c. Select rev from the Units text box, or type revolutions if you prefer.
d. Set the Counts per rev to 8,000. This setting is the encoder resolution in quadrature 

counts per revolution and corresponds to the encoder lines per revolution multiplied 
by four. 

Note The counts per revolution should be set accordingly if a dual shaft model of 
Integrated Stepper Motor with a third party Encoder is being used.

When you are finished the Encoder Settings page will look similar to Figure 10.

Figure 10.  Axis Configuration Encoder Page

4. Click the Stepper button ( ) to open the Stepper page.
a. Ensure that the Stepper Output settings match the following:

• Output Mode—Step and Direction
• Output Type—Single-Ended
• Active State— Low

b. Configure the Units and Steps Per Unit.
• Select rev from the Units text box, or type revolutions if you prefer.
• Set Steps Per revolution to 25,000.

Note The Steps Per revolution setting must match the Steps/Rev DIP switch 
setting. If you change the Steps/Rev setting using the DIP switches, update this 
setting to match.
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c. (Optional) Click the Monitor button ( ) and make the following changes to 
enable NI SoftMotion to disable the drive and turn off the Drive Enable signal when 
the specified position error limit is exceeded.

Note The Monitor button is greyed out if Feedback Source on the Axis Settings 
page is set to None.

• Enable the Enforce Position Error Limit checkbox.
• Set Position Error Limit to a reasonable tolerance for your system, such as 1.

5. Click the Drive Enable button ( ) and ensure that the Drive Enable settings match the 
following:
• Output Type—Sourcing
• Active State—Off
• Safe State—On

6. If you connected the Out+/Out- signal, click the Digital I/O button ( ) and complete 
the following steps to configure the DI 0 signal:
a. Double-click the text in the Mapping column and select Drive Fault/Alarm from the 

dropdown list. 
b. Ensure that the DI 0 settings match the following:

• Input Type—Sinking
• Active State—On
• Digital Filter—50 µs

7. Complete the following additional steps if you do not have limits and home connected at 
this time:
a. Click the Limits & Home button ( ).
b. In the Forward Limit and Reverse Limit sections ensure that the settings match the 

following:

Note These configuration settings disable limits for initial setup and testing 
purposes. National Instruments recommends connecting and enabling limits in your 
final application.

• Clear the Enable checkbox from both Forward Limit and Reverse Limit. 
• Set the Active State for both Forward Limit and Reverse Limit to Off. This 

prevents a limit warning even though limits are turned off.
c. Open the Home section and clear the Enable checkbox.

8. Configure any additional I/O settings according to your system requirements, such as 
position compare or position capture signals.

9. Click OK to close the Axis Configuration dialog box.
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10. Right-click the controller item in the Project Explorer window and select Deploy All to 
deploy the axis information. If a conflict resolution dialog box appears, click Apply to 
proceed with deployment.

11. Select File»Save Project to save the project.

Step 5: Enable and Test the Drive Using LabVIEW
Use the Interactive Test Panel to test and debug your motion system and configuration settings 
on the selected axis. With the Interactive Test Panel you can perform a simple straight-line 
move, monitor feedback position and position error information, I/O and move status 
information, change move constraints, get information about software errors and faults, 
and view position or velocity plots of the move. 

Complete the following steps to test your setup after configuring the axis using the Axis 
Configuration dialog box.
1. Right-click the axis in the Project Explorer window and select Interactive Test Panel 

from the shortcut menu. Opening this dialog box sends the axis settings to the hardware and 
activates the I/O on the module.

2. On the Move tab set Move Mode to Relative Position and Target Position to 10 rev.
3. On the Move Constraints tab set Velocity to 2 rev/sec, Acceleration and Deceleration to 

20 rev/sec2, and Acceleration Jerk and Deceleration Jerk to 200 rev/sec3. Using the 
encoder counts per revolution and stepper steps per revolution values specified in this 
tutorial the motor will move 10 revolutions at 120 rpm. 

Tip Click the Help button ( ) on the bottom of the dialog box for detailed 
information about the items available in this dialog box.

4. Click the Enable button ( ) on the bottom of the dialog box to enable the drive.
5. Click the Start button ( ) on the bottom of the dialog box to start the move with the 

configured options.
6. Use the Status and Plots tabs to monitor the move while it is in progress.

Finalize your motion system setup by connecting and configuring additional I/O such as 
limits as required by your system using the 37-pin terminal block. 



18 | ni.com | Getting Started with NI Integrated Steppers and NI 9512 Modules

Where To Go From Here

The following documents contain additional information that you may find helpful. All 
referenced documents ship with the product and are available at ni.com/manuals.
• Operating instructions for the controller and C Series module.
• NI ISM-7400 User Manual or NI ISM-7401/7402 User Manual
• LabVIEW NI SoftMotion Module Help—Use this help file to learn about using the 

NI SoftMotion Module in LabVIEW including information about function blocks and 
using the NI SoftMotion Module with the LabVIEW Project. To access this help file from 
LabVIEW, select Help»LabVIEW Help, then expand the LabVIEW NI SoftMotion 
Module book on the Contents tab.

• LabVIEW Help—Use the LabVIEW Help to access information about LabVIEW 
programming concepts, step-by-step instructions for using LabVIEW, and reference 
information about LabVIEW VIs, functions, palettes, menus, tools, properties, methods, 
events, dialog boxes, and so on. The LabVIEW Help also lists the LabVIEW documentation 
resources available from National Instruments. Access the LabVIEW Help by selecting 
Help»LabVIEW Help.

• SoftMotion Examples—After the configuration and testing of the motion system is 
complete, use SoftMotion API to program the motion control application in LabVIEW. 
Access the SoftMotion Examples by selecting Help»Find Examples»Hardware Input 
and Output»Motion Control»SoftMotion. 
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Worldwide Support and Services

The National Instruments Web site is your complete resource for technical support. At 
ni.com/support you have access to everything from troubleshooting and application 
development self-help resources to email and phone assistance from NI Application Engineers.

Visit ni.com/services for NI Factory Installation Services, repairs, extended warranty, 
calibration, and other services. 

Visit ni.com/register to register your National Instruments product. Product registration 
facilitates technical support and ensures that you receive important information updates from NI.

A Declaration of Conformity (DoC) is our claim of compliance with the Council of the European 
Communities using the manufacturer’s declaration of conformity. This system affords the user 
protection for electromagnetic compatibility (EMC) and product safety. You can obtain the DoC 
for your product by visiting ni.com/certification. If your product supports calibration, 
you can obtain the calibration certificate for your product at ni.com/calibration.

National Instruments corporate headquarters is located at 11500 North Mopac Expressway, 
Austin, Texas, 78759-3504. National Instruments also has offices located around the world to 
help address your support needs. For telephone support in the United States, create your service 
request at ni.com/support and follow the calling instructions or dial 512 795 8248. For 
telephone support outside the United States, visit the Worldwide Offices section of ni.com/
niglobal to access the branch office Web sites, which provide up-to-date contact information, 
support phone numbers, email addresses, and current events.

http://www.ni.com/services
http://www.ni.com/support
http://www.ni.com/register
http://www.ni.com/certification
http://www.ni.com/calibration
http://www.ni.com/support
http://www.ni.com/niglobal
http://www.ni.com/niglobal
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