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GETTING STARTED

NI SMD-7620/7621 Stepper 
Drives and NI 9512 C Series 
Modules

Note If you are a new user of LabVIEW or are unfamiliar with LabVIEW, refer to 

the Getting Started with LabVIEW manual for information about LabVIEW and 

LabVIEW terminology.

This document explains how to install and configure the NI SMD-7620/7621 stepper drives for 

use with the NI 9512 C Series drive interface module. 
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What You Need to Get Started

You need the following items to get started.

Hardware
 NI 9512 C Series stepper drive interface module

 NI real-time controller

– CompactRIO controller and chassis that support the RIO Scan Interface

Tip To determine if your controller and chassis support the RIO Scan Interface go 

to ni.com/info and enter the Info Code rdsoftwareversion.

or

– NI 9144 distributed chassis and compatible RT controller

 +24 V power supply (such as the NI PS-15) for the CompactRIO controller

(NI part number 781093-01)

 Separate +24 V power supply for the NI 9512 (such as the NI PS-15)

 NI SMD-7620/7621 stepper drive

 NI or third-party stepper motor

Note NI offers stepper motors matched to the NI SMD-7620/7621. Refer to 

ni.com/motion for motor options. National Instruments highly recommends using 

these motors for the best user experience.

 (Optional) ENC-7741 encoder for ST23 motors (NI part number 748992-01) or ENC-7742 

encoder for ST34 motors (NI part number 748993-01)

 NI-7748 encoder cable to connect the encoder to the NI 951x terminal block

(NI part number 748994-01)

 Ethernet connection and cable for the CompactRIO controller

 Ethernet connection and cable for the NI SMD-7620/7621

 AC input cable for the NI SMD-7620/7621

 NI 951x Cable and Terminal Block bundle (NI part number 780553-01)
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Software
 LabVIEW 2010 or later

 LabVIEW 2010 Real-Time Module or later

 LabVIEW 2010 NI SoftMotion Module or later

 NI-RIO 3.5.1 or later

 NI Stepper Configuration Utility

Figure 1 shows a simplified connection diagram.

Figure 1.  NI 9512 to NI SMD-7620/7621 Connections

Related Documentation
The following documents contain additional information that you may find helpful. All 

referenced documents ship with the product and are available at ni.com/manuals.

� Operating instructions for the controller and C Series module.

� NI SMD-7620/7621 User Manual

� LabVIEW NI SoftMotion Module Help—Use this help file to learn about using the 

NI SoftMotion Module in LabVIEW including information about function blocks and 

using the NI SoftMotion Module with the LabVIEW Project. To access this help file from 

LabVIEW, select Help»LabVIEW Help, then expand the LabVIEW NI SoftMotion 

Module book on the Contents tab.

� LabVIEW Help—Use the LabVIEW Help to access information about LabVIEW 

programming concepts, step-by-step instructions for using LabVIEW, and reference 

information about LabVIEW VIs, functions, palettes, menus, tools, properties, methods, 
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events, dialog boxes, and so on. The LabVIEW Help also lists the LabVIEW documentation 

resources available from National Instruments. Access the LabVIEW Help by selecting 

Help»LabVIEW Help.

� Getting Started with LabVIEW—Use this document as a tutorial to familiarize yourself 

with the LabVIEW graphical programming environment and the basic LabVIEW features 

you use to build data acquisition and instrument control applications. Access the Getting 

Started with LabVIEW PDF by selecting Start»All Programs»National Instruments»

LabVIEW»LabVIEW Manuals»LV_Getting_Started.pdf.

Hardware Installation and Configuration

This section covers the hardware setup for the CompactRIO system, NI 9512 C Series module, 

and NI SMD-7620/7621 stepper drive.

Step 1: Set Up the CompactRIO System
Complete the following steps to set up the CompactRIO hardware.

1. Install the real-time CompactRIO controller on the chassis if you are not using an integrated 

controller and chassis. 

Note Write down the controller serial number before installing the controller onto 

the chassis. You will be unable to read the serial number after you install the 

controller.

a. Make sure that no power is connected to the controller or the chassis.
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b. Align the controller with the chassis as shown in Figure 2. 

Figure 2.  Installing the Controller on the Chassis (Eight-Slot Chassis Shown)

c. Slide the controller onto the controller slot on the chassis. Press firmly to ensure the 

chassis connector and the controller connector are mated. 

d. Using a number 2 Phillips screwdriver, tighten the two captive screws on the front of 

the controller.

2. Connect the controller to a power supply and an Ethernet network on the same subnet as 

the development computer. Refer to the controller operating instructions for information 

about wiring the controller to the power supply and Ethernet network.

Note Do not plug in or turn on any power to the system until after you complete 

Step 11: Power on the Drive and Verify Connections.

3. Install the NI 9512 module in slot 1, 2, 3, or 4 of the chassis.

1 Controller
2 Captive Screws
3 Controller Slot

4 Reconfigurable Embedded Chassis
5 Grounding Screw
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Step 2: Connect the NI 9512 to the 37-Pin Terminal 
Block
1. Connect the MDR and DSUB connectors on the NI 951x Y-cable to the MDR and DSUB 

connectors on the NI 9512 module. 

2. Connect the 37-pin DSUB to the DSUB connector on the NI 951x terminal block.

Figure 3 shows the 37-pin terminal block pin assignments.

Figure 3.  NI 9512 37-Pin Terminal Block Pin Assignments

Step 3: Connect the 37-Pin Terminal Block to the 
+24 V Power Supply

Note Do not plug in or turn on the power supply until after you complete Step 11: 

Power on the Drive and Verify Connections.

1. Connect the V+ terminal from the 24 V power supply to one of the two Vsup inputs on the 

37-pin terminal block. The 37-pin terminal block provides a Vsup input for the NI 9512 on 

pin 14 and pin 22. 

2. Connect the V- terminal from the 24 V power supply to one of the COM terminals on the 

37-pin terminal block. The 37-pin terminal block provides COM on pins 3, 5, 8, 17, 24, 

and 32.
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Step 4: Connect the Drive Command Signals
Complete the following steps to connect the Drive Command signals to the NI 9512 terminal 

block.

1. Connect the SMD-7620/7621 X1/STEP- terminal (pin 2) to the 37-pin terminal block 

Step (CW)+ terminal (pin 18).

2. Connect the SMD-7620/7621 X2/DIR- terminal (pin 4) to the 37-pin terminal block 

Direction (CCW)+ terminal (pin 16).

3. Connect the SMD-7620/7621 X1/STEP+ terminal (pin 1) and X2/DIR+ terminal (pin 3) to 

the 37-pin terminal block +5V OUT terminal (pin 9).

Figure 4 shows the SMD-7620/7621 Drive Command and I/O Connector location and pinout.

Figure 4.  SMD-7620/7621 Drive Command and I/O Connector

Step 5: Connect the Drive Enable Signal
Complete the following steps to connect the Drive Enable signal, which controls the enable 

function of the drive:

1. Connect the X3/EN- terminal (pin 6) to the 37-pin terminal block COM terminal (pin 5).

2. Connect the X3/EN+ terminal (pin 5) to the 37-pin terminal block Drive Enable terminal 

(pin 33).

Step 6: (Optional) Connect the Drive Fault Signal
Complete the following steps to map an NI 9512 digital input to the SMD-7620/7621 Y1 

programmable output signal to monitor the NI SMD-7620/7621 stepper drive for faults:

1. Connect the Y1+ terminal (pin 11) to the 37-pin terminal block Vsup terminal (pin 22).

2. Connect the Y1- terminal (pin 12) to the 37-pin terminal block DI 0 terminal (pin 4).
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Step 7: (Optional) Connect the Encoder Signals
If your motor includes an encoder, complete the following steps to connect the encoder to the 

NI 951x terminal block:

1. Connect one end of the encoder cable to the encoder.

2. Cut the 15-pin DSUB connector off of the other end of the cable and expose the encoder 

wires.

3. Connect the encoder wires to the 37-pin terminal block as indicated in Table 1.

4. Insulate any unused wires.

Step 8: Connect the NI SMD-7620/7621 to AC Power

Note Do not apply power until after you complete Step 11: Power on the Drive and 

Verify Connections.

Complete the following steps to connect the NI SMD-7620/7621 to AC power.

1. Connect an AC input cable to the line, neutral, and protective earth connectors as shown in 

Figure 5.

2. (Optional) Install a fuse on the AC input line as shown. The SMD-7620 contains an internal 

8 A fast acting fuse. The SMD-7621 contains an internal 3.5 A fast acting fuse. If an 

external fuse is desired, National Instruments recommends a 6 A fast acting fuse for the 

SMD-7620 and a 3 A fast acting fuse for the SMD-7621 version. 

3. (Optional) If your application requires EMC compliance, install a Corcom 6ET1 line filter 

in series with the AC input as shown. 

Table 1.  NI SMD-7620/7621 to 37-Pin Terminal Block Connections

Encoder

Signal Name

Encoder Cable 

Wire Color

37-Pin 

Terminal Block 

Pin Number

37-Pin 

Terminal Block 

Signal Name

CH A blue 25 Encoder 0 Phase A+

CH A- blue/white 26 Encoder 0 Phase A-

CH B yellow 27 Encoder 0 Phase B+

CH B- yellow/white 29 Encoder 0 Phase B-

INDEX orange 6 Encoder 0 Index+

INDEX- orange/white 7 Encoder 0 Index-

GND black 8 COM

+Vcc red 9 +5V OUT
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Note Refer to the NI SMD-7620/7621 User Manual for more information about 

connecting to AC power.

Figure 5 shows the SMD-7620/7621 Power and Motor Connector location and pinout, with 

optional fusing and line filters.

Figure 5.  SMD-7620/7621 Power and Motor Connector

Step 9: Connect the SMD-7620/7621 to the Motor

Caution Do not connect or disconnect the motor when the power is on. 

NI offers NEMA 23 and NEMA 34 stepper motors matched to the SMD-7620/7621. When 

connecting these motors to the SMD-7620, connect them in parallel as shown in Figure 6.

Figure 6.  Eight Lead Motor Parallel Connection
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When connecting these motors to the SMD-7621, connect them in series as shown in Figure 7.

Figure 7.  Eight Lead Motor Series Connection

Note For information about connecting third-party motors, refer to the 

NI SMD-7620/7621 User Manual.

Figure 8 shows the NI SMD-7620/7621 motor connections.

Figure 8.  NI SMD-7620/7621 Motor Connector Terminal 
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Step 10: Connect the NI SMD-7620/7621 to the Network
1. Connect the NI SMD-7620/7621 to an Ethernet network on the same subnet as the 

development computer. 

2. Set the rotary switch to one of the preset IP addresses or to the F position to configure the 

drive to use DHCP. 

Note This document assumes you have configured the drive for DHCP. For 

information about other settings refer to the NI SMD-7620/7621 User Manual.

Figure 9 shows the NI SMD-7620/7621 NI SMD-7620/7621 IP address selection switch and 

Ethernet connector.

Figure 9.  NI SMD-7620/7621 IP Selection and Ethernet Connector

1 IP Address Selection Switch 2 Ethernet connector

A+ A- B-B+L N

1 2
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Step 11: Power on the Drive and Verify Connections
After all hardware connections have been made complete the following steps to confirm the 

hardware setup.

1. Turn on all power supplies and apply AC power.

2. Verify that the Drive Status LED on the NI SMD-7620/7621 flashes or is solid green. 

Figure 10 shows the location of the Drive Status LED.

Figure 10.  Drive Status LED Location

If the Drive Status LED does not flash or turn solid green, turn off all power, verify the 

connections, and try again. Refer to the Worldwide Support and Services section for additional 

tips.

Software Installation and Configuration

This section covers installing and configuring software for the NI 9512 C Series module.

Note These instructions assume you have installed all required software from the 

What You Need to Get Started section on your development machine.

Step 1: Install Software on and Configure the NI RT 
Controller
Complete the following steps to configure the controller and install software on it.

Note The Measurement & Automation Explorer (MAX) user interface may not 

match these steps exactly depending on which version of MAX you are using. 

Verify the NI RT Controller

1. Launch Measurement & Automation Explorer (MAX) on the development computer by 

clicking the MAX icon on the desktop ( ), or by szelecting Start»All Programs»

National Instruments»Measurement & Automation.

Status LEDs
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2. Expand the Remote Systems tree.

3. Highlight the system.

Note If you do not see the controller, you may need to disable the firewall on the 

development computer. Go to ni.com/info and enter RIOMAXTroubleshoot 

for more information.

4. Verify that the Serial Number in the General Settings section matches the serial number 

on the device.

If you do not want to format the disk on the controller, eliminating all installed software and files, 

skip to Install Software on the NI RT Controller.

Reformat the NI RT Controller (Optional)

1. Set the Safe Mode switch on the controller to the On position.

2. Power on the controller. If it is already powered on, press the Reset button on the controller 

to reboot it.

3. Right-click the controller under Remote Systems in the Configuration pane in MAX and 

select Format Disk. 

4. (Optional) Enable the Keep Network Settings checkbox if you want to retain the same 

target name and IP address. 

5. Click Format to start formatting the disk.

6. When MAX finishes formatting the disk, set the Safe Mode switch to the Off position and 

click OK.

7. Select the System Settings tab on the bottom and type a descriptive name for the system in 

the Hostname field.

8. (Optional) Complete this step only if the target has an empty IP address (0.0.0.0). Select the 

Network Settings tab and select DHCP or Link Local from the Configure IPv4 Address 

list to assign an IP address or select the Static to specify a static IP address in the IPv4 

Address section.

9. Click Save on the toolbar and let MAX reboot the system. You may not need to complete 

this step if you did not change the IP address or name.

Install Software on the NI RT Controller

1. When the new system name appears under Remote Systems, expand the controller item in 

the tree, right-click Software, and select Add/Remove Software.

2. Select a recommended software set that includes NI-RIO 3.5.1 or later. 

3. Click Next.

4. Select LabVIEW NI SoftMotion Module from the add-ons list.

Note If you are using NI SoftMotion Module 2010 SP1 or earlier, also select 

LabVIEW NI SoftMotion Module Scan Engine Support from the list.
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5. Click Next to install the selected software on the controller. Click Help if you need 

information about installing recommended software sets.

6. When the software installation completes, click Finish to reboot the controller.

7. Close MAX.

Step 2: Create a Project in Scan Interface Mode
Scan Interface mode enables you to use C Series modules directly from LabVIEW Real-Time. 

Modules that you use in Scan Interface mode appear directly under the chassis item in the 

Project Explorer window. Unlike most C Series modules, NI 951x modules are not directly 

configurable from the Project Explorer window and no I/O variables are directly available 

under the module. 

Tip Refer to the Select Programming Mode Dialog Box topic of the CompactRIO 

Reference and Procedures (Scan Interface) help file for more information about Scan 

Interface mode. 

Use a LabVIEW project to manage VIs, targets, and I/O modules on the development computer. 

Complete the following steps to create a LabVIEW project. 

1. Launch LabVIEW.

2. Select File»Create Project or Project»Create Project to display the Create Project 

dialog box. You can also click the Create Project button on the Getting Started window. 

The Create Project dialog box includes a list of templates and sample projects you can use 

to ensure that the project you create uses reliable designs and programming practices.

3. Select Blank Project from the list of templates.

4. Click Finish.

5. Select Help and make sure that Show Context Help is checked. You can refer to the 

context help throughout the tutorial for information about items on the block diagram.

Step 3: Add Resources to the Project
1. Right-click the top-level project item in the Project Explorer window and select New»

Targets and Devices from the shortcut menu to display the Add Targets and Devices 

dialog box.

2. Make sure that the Existing target or device radio button is selected.

3. Expand Real-Time CompactRIO.

4. Select the CompactRIO controller to add to the project and click OK.

5. If you have LabVIEW FPGA installed, the Select Programming Mode dialog box 

appears. Select Scan Interface to put the system into Scan Interface mode.

Tip Use the CompactRIO Chassis Properties dialog box to change the 

programming mode in an existing project. Right-click the CompactRIO chassis in the 

Project Explorer window and select Properties from the shortcut menu to display 

this dialog box.
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6. Click Discover in the Discover C Series Modules? dialog box if it appears.

7. Click Continue. 

8. Right-click the controller item in the Project Explorer window and select Properties from 

the shortcut menu to display the RT Target Properties dialog box. Select Scan Engine 

from the Category list to display the Scan Engine page. 

9. Set the Scan Period to 5 ms, then click OK to close the RT Target Properties dialog box.

10. Right-click the controller item in the Project Explorer window and select New»

NI SoftMotion Axis from the shortcut menu to open the Axis Manager dialog box, shown 

in Figure 11.

11. Click Add New Axis to create an NI SoftMotion axis associated with the NI 9512 module. 

Axes are automatically bound to an available module. You can double-click the axis name 

to rename the axis and give it a descriptive name.

Figure 11.  Axis Manager Dialog Box

12. Click OK to close the Axis Manager dialog box. The new axis is added to the Project 

Explorer window. 

Note You cannot associate more than one axis with the same C Series module.

When you have finished these steps your LabVIEW project should look similar to the 

image in Figure 12.
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Figure 12.  Project Explorer Window with Modules in Scan Interface Mode

Step 4: Configure the NI 9512 Axis
The Axis Configuration dialog box includes configuration options for stepper drive command 

signals, feedback devices, motion and digital I/O, trajectory, and axis setup. Figure 13 shows the 

parts of the Axis Configuration dialog box for the NI 9512 C Series module. Refer to the 

NI SoftMotion Module book of the LabVIEW Help for detailed information about each 

configuration option.

Figure 13.  Axis Configuration Dialog Box
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Note The Axis Configuration dialog box user interface may not match this image 

exactly depending on which version of the LabVIEW NI SoftMotion Module you are 

using. 

Complete the following steps to configure the axis I/O settings for use with the 

NI SMD-7620/7621 stepper drive.

1. Right-click the axis in the Project Explorer window and select Properties from the 

shortcut menu to open the Axis Configuration dialog box.

2. Configure the following settings on the General Settings page ( ).

a. Confirm that Loop Mode is set to Open-Loop. Axes configured in open-loop mode 

produce step outputs but do not require feedback from the motor to verify position.

b. Set Feedback Source to Encoder 0, if you have connected an encoder, or None if you 

do not have an encoder connected.

c. Confirm that the Axis Enabled and Enable Drive on Transition to Active Mode 

checkboxes contain checkmarks. These selections configure the axes to automatically 

activate when the NI Scan Engine switches to Active mode.

Note Disable these options to prevent axes from automatically activating when the 

NI Scan Engine switches to Active mode.

3. If you have connected an encoder, click the Encoder button ( ) and configure the 

Units and Counts Per Unit.

a. In the Active State section set the Line State for A, B, and Index to High.

b. In the Index Reference Criteria section set the Line State for A and B to Inactive.

c. Select rev from the Units text box, or type revolutions if you prefer.

d. Set the Counts per rev to 8,000. This setting is the encoder resolution in quadrature 

counts per revolution and corresponds to the encoder lines per revolution multiplied 

by four. 

When you are finished the Encoder Settings page will look similar to Figure 14.

Figure 14.  Axis Configuration Encoder Page
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4. Click the Stepper button ( ) to open the Stepper page.

a. Ensure that the Stepper Output settings match the following:

� Output Mode—Step and Direction

� Output Type—Single-Ended

� Active State—Low

b. Configure the Units and Steps Per Unit.

� Select rev from the Units text box, or type revolutions if you prefer.

� Set Steps Per revolution to 20,000.

Note The Stepper steps per revolution setting must match the Steps/Rev setting 

in the NI Stepper Configuration Utility. The NI Stepper Configuration Utility settings 

are covered in Step 5: Configure the Drive Using the NI Stepper Configuration 

Utility.

c. (Optional) Click the Monitor button ( ) and make the following changes to 

enable NI SoftMotion to disable the drive and turn off the Drive Enable signal when 

the specified position error limit is exceeded.

Note The Monitor button is greyed out if Feedback Source on the Axis Settings 

page is set to None.

� Enable the Enforce Position Error Limit checkbox.

� Set Position Error Limit to a reasonable tolerance for your system, such as 1.

5. Click the Drive Enable button ( ) and ensure that the Drive Enable settings match the 

following:

� Output Type—Sourcing

� Active State—Off

� Safe State—On

6. If you connected the Y1+/Y1- signal, click the Digital I/O button ( ) and complete 

the following steps to configure the DI 0 signal:

a. Double-click the text in the Mapping column and select Drive Fault/Alarm from the 

dropdown list. 

b. Ensure that the DI 0 settings match the following:

� Input Type—Sinking

� Active State—On

� Digital Filter—50 µs
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7. Complete the following additional steps if you do not have limits and home connected at 

this time:

a. Click the Limits & Home button ( ).

b. In the Forward Limit and Reverse Limit sections ensure that the settings match the 

following:

Note These configuration settings disable limits for initial setup and testing 

purposes. National Instruments recommends connecting and enabling limits in your 

final application.

� Clear the Enable checkbox from both Forward Limit and Reverse Limit. 

� Set the Active State for both Forward Limit and Reverse Limit to Off. This 

prevents a limit warning even though limits are turned off.

c. Open the Home section and clear the Enable checkbox.

8. Configure any additional I/O settings according to your system requirements, such as 

position compare or position capture signals.

9. Click OK to close the Axis Configuration dialog box.

10. Right-click the controller item in the Project Explorer window and select Deploy All to 

deploy the axis information.

11. Select File»Save Project to save the project.

Step 5: Configure the Drive Using the NI Stepper 
Configuration Utility
1. Launch the NI Stepper Configuration utility.

2. Select Drive»Drive Discovery, verify that your host IP address is highlighted, then click 

OK.

3. When Drive Discovery detects a drive, click Yes in the confirmation dialog box.

4. Select the drive you are configuring from the Drive dropdown list.

5. Click the I/O button to launch the I/O Configuration dialog box.

a. Enable the close fault output (Y1) option button to configure the fault signal.

b. Enable the When Enable input is (X3) is open option button to configure the drive 

enable signal.

c. (Optional) Configure additional I/O signals on the drive as necessary.

6. Click the Motor button to launch the Motor dialog box.

a. Select your motor from the Standard motor dropdown list. If you are using a motor 

other than one of the standard motors, refer to the NI Stepper Configuration Utility 

Help for information about how to configure it for use with the NI SMD-7620/7621.
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7. Click the Motion button to launch the Pulse & Direction Control dialog box.

a. Set Steps/Rev to 20,000. 

b. (Optional) Set the Step Smoothing Filter and Input Noise Filter as appropriate for 

your application. Refer to the NI Stepper Configuration Utility Help for information 

about these settings.

8. Click Download to Drive to apply the updated settings to the drive.

Step 6: Enable and Test the Drive Using LabVIEW
Use the Interactive Test Panel to test and debug your motion system and configuration settings 

on the selected axis. With the Interactive Test Panel you can perform a simple straight-line move 

and monitor feedback position and position error information, move and I/O status information, 

change move constraints, get information about software errors and faults, and view position or 

velocity plots of the move. 

Complete the following steps to test your setup after configuring the axis using the Axis 

Configuration dialog box.

1. Right-click the axis in the Project Explorer window and select Interactive Test Panel 

from the shortcut menu. Opening this dialog box sends the axis settings to the hardware and 

activates the I/O on the module.

2. On the Move tab set Move Mode to Relative Position and Target Position to 20 rev.

3. On the Move Constraints tab set Velocity to 2 rev/sec, Acceleration and Deceleration to 

20 rev/sec2, and Acceleration Jerk and Deceleration Jerk to 200 rev/sec3. Using the 

encoder counts per revolution and stepper steps per revolution values specified in this 

tutorial the motor will move 20 revolutions at 120 rpm. 

Tip Click the Help button ( ) on the bottom of the dialog box for detailed 

information about the items available in this dialog box.

4. Click the Enable button ( ) on the bottom of the dialog box to enable the drive.

5. Click the Start button ( ) on the bottom of the dialog box to start the move with the 

configured options.

6. Use the Status and Plots tabs to monitor the move while it is in progress.

Finalize your motion system setup by connecting and configuring additional I/O such as 

limits as required by your system using the 37-pin terminal block. 
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