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GETTING STARTED

NI 9512 C Series Modules and 
AKD Servo Drives

Note If you are a new user of LabVIEW or are unfamiliar with LabVIEW, refer to 

the Getting Started with LabVIEW manual for information about LabVIEW and 

LabVIEW terminology.

This document explains how to install and configure the AKD servo drives for use with the 

NI 9512 C Series drive interface module. 

Tip If you encounter any problems during setup, refer to the Tips and 

Troubleshooting section for assistance.
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What You Need to Get Started

Caution Before installing the drive, review Chapter 2, Safety, in the AKD 

Installation Manual that came with your hardware or available from ni.com/

manuals. Failure to follow safety instructions may result in injury or damage to 

equipment. 

You need the following items to get started.

Hardware
 NI 9512 C Series stepper drive interface module

 NI real-time controller

– CompactRIO controller and chassis that support the RIO Scan Interface

Tip To determine if your controller and chassis support the RIO Scan Interface go 

to ni.com/info and enter the Info Code rdsoftwareversion.

or

– NI 9144 distributed chassis and compatible RT controller

 Power supply for the CompactRIO controller

 +24 VDC power supply for the drive interface module and AKD servo drive

 Ethernet connection and cable for the CompactRIO controller

 Ethernet connection and cable for the AKD servo drive

 NI 9512 to AKD Drive Cable
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 AKD servo drive

 NI or third-party servo motor and encoder

Note AKM series servo motors available from NI contain built-in encoders and 

come pre-wired for use with the AKD servo drive. National Instruments recommends 

using one of these motors for the best user experience and system performance.

Software
 LabVIEW 2009 SP1 or later

 LabVIEW 2009 SP1 Real-Time Module or later

 LabVIEW 2009 SP1 NI SoftMotion Module or later

 NI-RIO 3.4.0 or later

 NI-Industrial Communications for EtherCAT® 1.2 or later, if you are using the NI 9144 

distributed chassis

 AKD WorkBench software. Refer to Step 1: Install Software on and Configure the NI RT 

Controller in the Software Installation and Configuration section of this document for 

installation information.

Figure 1 shows the required hardware and software.

Figure 1.  Required Hardware and Software
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Related Documentation
The following documents contain additional information that you may find helpful. All 

referenced documents ship with the product and are available at ni.com/manuals.

� Operating instructions for the controller and C Series module.

� AKD Installation Manual—Use this document to learn additional information about the 

electrical and mechanical aspects of the AKD servo drive, including important safety 

information.

� Getting Started with NI 951x C Series Modules and LabVIEW—Use this document to learn 

about using the NI 951x modules with LabVIEW, including information about the 

LabVIEW NI SoftMotion Module. To access this document, select Start»All Programs»

National Instruments»LabVIEW»LabVIEW Manuals»

Getting_Started_NI_951x_Modules_LabVIEW.pdf.

� LabVIEW NI SoftMotion Module Help—Use this help file to learn about using the 

NI SoftMotion Module in LabVIEW including information about function blocks and 

using the NI SoftMotion Module with the LabVIEW Project. To access this help file from 

LabVIEW, select Help»LabVIEW Help, then expand the LabVIEW NI SoftMotion 

Module book on the Contents tab.

� NI 9144 User Guide and Specifications—Use this document to learn additional information 

about how to connect the NI 9144 chassis to a network, how to use the NI 9144 chassis 

features, and contains the NI 9144 chassis specifications.

� NI Industrial Communications for EtherCAT software documentation

� LabVIEW Help—Use the LabVIEW Help to access information about LabVIEW 

programming concepts, step-by-step instructions for using LabVIEW, and reference 

information about LabVIEW VIs, functions, palettes, menus, tools, properties, methods, 

events, dialog boxes, and so on. The LabVIEW Help also lists the LabVIEW documentation 

resources available from National Instruments. Access the LabVIEW Help by selecting 

Help»LabVIEW Help.

� Getting Started with LabVIEW—Use this document as a tutorial to familiarize yourself 

with the LabVIEW graphical programming environment and the basic LabVIEW features 

you use to build data acquisition and instrument control applications. Access the Getting 

Started with LabVIEW PDF by selecting Start»All Programs»National Instruments»

LabVIEW»LabVIEW Manuals»LV_Getting_Started.pdf.
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Hardware Installation and Configuration

This section covers the hardware setup for the CompactRIO system, NI 9512 C Series module, 

and AKD servo drive.

Figure 2 shows an overview of the connectors on the AKD servo drive.

Figure 2.  AKD Servo Drive Connectors
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2 Motor, Brake (X2)
3 AC Input Power (X3)
4 Encoder Emulation (X9)

5 Drive Grounding Lug
6 Feedback (X10)
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8 I/O Connector (X7)

9 Static IP Addressing Switch (S2)
10 Static IP Addressing Switch (S1)
11 Drive Communication (X11)
12 LED Indicators
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Step 1: Set Up the CompactRIO System
Complete the following steps to set up the CompactRIO hardware.

Note If you are using an NI 9144 chassis, refer to Setting Up a System with an 

NI 9144 Chassis in the Setting Up a Distributed System section for alternate 

configuration instructions, then continue with Step 2: Connect NI 9512 to AKD Drive 

Cable to the C Series Module.

1. Install the real-time CompactRIO controller on the chassis if you are not using an integrated 

controller and chassis. 

Note Write down the controller serial number before installing the controller onto 

the chassis. You will be unable to read the serial number after you install the 

controller.

a. Make sure that no power is connected to the controller or the chassis.

b. Align the controller with the chassis as shown in Figure 3. 

Figure 3.  Installing the Controller on the Chassis (Eight-Slot Chassis Shown)
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c. Slide the controller onto the controller slot on the chassis. Press firmly to ensure the 

chassis connector and the controller connector are mated. 

d. Using a number 2 Phillips screwdriver, tighten the two captive screws on the front of 

the controller.

2. Connect the controller to a power supply and an Ethernet network on the same subnet as 

the development computer. Refer to the controller operating instructions for information 

about wiring the controller to the power supply and Ethernet network.

Note Do not plug in or turn on any power to the system until after you complete 

Step 8: Connect the Drive Communication.

3. Install the NI 9512 module in slot 1, 2, 3, or 4 of the chassis.

Step 2: Connect NI 9512 to AKD Drive Cable to the 
C Series Module
Connect the MDR and DSUB connectors on the NI 9512 to AKD Drive Cable to the MDR and 

DSUB connectors on the C Series module. Figure 4 shows the NI 9512 to AKD Drive Cable 

connectors.

Figure 4.  NI 9512 to AKD Drive Cable Connectors
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The NI 9512 to AKD Drive Cable contains the following connections:

� DSUB Connector—15-pin DSUB connector containing drive command and drive enable 

signals.

� MDR Connector—20-pin MDR connector containing encoder, limit, home sensor, 

position compare, and position capture signals.

� X1 3-pin Connector—+24 V power supply connection for the AKD servo drive provided 

through the 20-pin screw terminal connector.

� X7 10-Pin Connector—10-pin connector containing the step/direction signals and AKD 

digital outputs.

� X8 10-Pin Connector—10-pin connector containing the enable and fault signals.

� X9 DSUB Connector—9-pin DSUB connector containing emulated encoder output 

signals from the AKD servo drive.

� Screw Terminal Connector—20-pin screw terminal connector for external I/O 

connections. 

Table 1 shows the screw terminal connector pinout.

Table 1.  NI 9512 to AKD Drive Cable Screw-Terminal Pinout

Pin Signal Name

1 Forward Limit

2 Home

3 Reverse Limit

4 NI 9512 Digital Input 0

5 Vsup

6 Vsup Return

7 NI 9512 Digital Output 0

8 NI 9512 Digital Output 1

9 NC†

10 NC†

11 NI 9512 +5V OUT

12 Position Compare

13 Position Capture

14 COM

15 Reserved

16 Reserved



Getting Started with NI 9512 Modules and AKD Servo Drives | © National Instruments | 9

Step 3: Mount the Drive and Connect the Protective 
Earth
1. Mount the drive to a conductive metal plate. Refer to the AKD Installation Manual for 

dimensions and additional information specific to the drive model. 

2. Connect the protective earth (PE) to either ground screw on the drive grounding lug. 

Figure 2 shows the location of the grounding lug on the drive.

Step 4: Connect the Logic Power Supply to the NI 9512 
to AKD Drive Cable
The NI 9512 to AKD Drive Cable requires connection to an external +24 V power supply. The 

+24 V power supply provides both the logic power to the AKD servo drive and powers the 

NI 9512 module. 

Note Do not plug in or turn on the +24 V power supply until after you complete 

Step 8: Connect the Drive Communication.

Complete the following steps to connect the +24 V power supply to the cable.

1. Connect the +24 V power supply (+) terminal to the Vsup terminal on the NI 9512 to AKD 

Drive Cable screw terminal connector. Refer to Table 1 for the screw terminal connector 

pinout.

2. Connect the +24 V power supply return (–) terminal to the Vsup Return terminal on the 

NI 9512 to AKD Drive Cable screw terminal connector.

17 Reserved

18 Reserved

19 Reserved

20 Reserved

† NC = Not Connected

Table 1.  NI 9512 to AKD Drive Cable Screw-Terminal Pinout (Continued)

Pin Signal Name
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Step 5: Connect the NI 9512 to AKD Drive Cable to the 
AKD Servo Drive
Connect the NI 9512 to AKD Drive Cable to the AKD servo drive. Refer to Figure 6 for the 

location of the connectors.

1. Connect the cable X1 3-pin connector to the AKD servo drive X1 3-pin connector. This 

connector provides +24 V power to both the drive logic and to the safe torque out (STO) 

input. The STO input must be powered by +24V for proper drive operation. If you need to 

use the STO functionality complete the following additional steps:

a. Disconnect the STO wire from the NI 9512 to AKD cable X1 connector and insulate it.

Note The STO and +24V wires are internally connected in the NI 9512 to AKD 

cable. You must insulate the STO wire if you disconnect it from the X1 connector.

b. Connect the STO terminal and GND terminal to the output of a safety relay or security 

control. The safety relay must comply with the requirements of the SIL 2 according to 

IEC 61800-5-2, PL d according to ISO 13849-1, or Category 3 according to EN-954. 

Refer to the AKD Installation Manual for more information.

Figure 5 shows the X1 connector pin assignment and wire colors.

Figure 5.  AKD X1 Connector
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2. Connect the cable X9 DSUB connector to the AKD servo drive X9 DSUB connector.

3. Connect the cable X7 10-pin connector to the AKD servo drive X7 10-pin connector.

4. Connect the cable X8 10-pin connector to the AKD servo drive X8 10-pin connector. 

Figure 6.  NI 9512 to AKD Drive Cable Connections

1 +24 V Supply, STO (X1)
2 Encoder Emulation (X9)

3 I/O (X8)
4 I/O (X7)

1
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Step 6: Connect the Motor and Encoder to the Drive
All servo motors available from NI come pre-wired for direct connection to the AKD servo drive 

X2 motor connector and X10 feedback connector. Refer to Figure 7 for the location of the 

connectors.

1. Connect the motor 6-pin connector to the AKD servo drive X2 motor connector.

Note The X2 connector also provides connection for the drive to control the +24 V 

holding brake for motors that have a brake. Refer to the AKD Installation Manual for 

information about using the holding brake.

2. Connect the motor DSUB feedback connector to the AKD servo drive X10 feedback 

connector. 

Figure 7.  Motor and Encoder Connections

1 Motor Connector (X2) 2 Feedback Connector (X10)

2

1
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Step 7: Connect the AC Input Power
Connect the X3 mains supply connector to AC input power. Pins 4 through 7 contain the 

AC power signals. The X3 connector also provides signals for an external brake (regen) resistor 

(±RB) and DC bus link (–DC). Refer to the AKD Installation Manual for information about 

using these terminals. 

Note Do not turn on the AC power until after you complete Step 8: Connect the 

Drive Communication.

Figure 8 shows the location and pin assignment for the X3 connector. 

Figure 8.  AKD Servo Drive X3 Connector

AC input power can be connected for either a three-phase or single-phase operation. 

Note External filtering and fusing are optionally provided by the user. Refer to the 

AKD Installation Manual for information about filter and fuse requirements.

Figure 9 shows three-phase connection. 

Figure 9.  AC Input Power Three-Phase Connection
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Figure 10 shows single-phase connection.

Figure 10.  AC Input Power Single-Phase Connection

Step 8: Connect the Drive Communication
Complete the following steps to set up the drive for software configuration using Ethernet. These 

steps assume you are connecting the AKD servo drive using a hub, switch, or router using 

DHCP. If you cannot use DHCP, refer to Connecting to the PC Using a Static IP in the Tips and 

Troubleshooting section for instructions about direct connection using a static IP address.

1. Set S1 and S2 on the drive to 0 to configure the drive for DHCP mode. The drive obtains 

an IP address from an external DHCP server if one exists on the network. If no DHCP 

server is present, the drive assumes an automatic private IP address in the form of 

169.254.x.x. This process may take up to a minute to complete. Figure 2 shows the 

locations of S1 and S2.

2. Connect the AKD servo drive X11 service port to a hub, switch, or router using an Ethernet 

cable. Figure 11 shows the location of the X11 service port on the drive.

Figure 11.  AKD Servo Drive X11 Connector
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Step 9: Confirm Drive Connections
After all hardware connections have been made complete the following steps to confirm the 

AKD hardware setup.

1. Apply AC power.

2. Turn on the +24 V power supply. After logic power is supplied to the drive, the drive 

displays the following sequence of flashes in the LED indicators. Figure 2 shows the 

location of the LED indicators on the AKD servo drive.

a. – –

b. []

c. Drive IP address, flashed sequentially

d. Drive status, either current operation mode or the fault code if there is a fault 

condition. The operation modes are as follows:

� o0—torque mode (current mode)

� o1—velocity mode

� o2—position mode

Note If the drive shows a fault code, click the Clear Faults button on the AKD 

WorkBench software toolbar after you install the AKD WorkBench software in Step 5: 

Install AKD WorkBench and Configure the Drive of the Software Installation and 

Configuration section and connect to the drive to clear the fault state. If the fault 

reappears, refer to the AKD Fault and Warning Messages Card that came with the 

drive for more information about the fault, including possible solutions. After resolving 

the cause of the fault, click the Clear Faults button on the toolbar again. Figure 17 

shows the location of the Clear Faults toolbar button in the AKD WorkBench 

software.

Software Installation and Configuration

This section covers installing and configuring the software for the AKD servo drive and NI 9512 

C Series module.

Note If you are using an NI 9144 chassis, refer to Software Installation and 

Configuration with the NI 9144 in the Setting Up a Distributed System section for 

alternate configuration instructions, then continue with Step 2: Create a Project in 

Scan Interface Mode.

Step 1: Install Software on and Configure the NI RT 
Controller
Complete the following steps to configure the controller and install software on it.

Note The Measurement & Automation Explorer (MAX) user interface may not 

match these steps exactly depending on which version of MAX you are using. 
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1. Launch Measurement & Automation Explorer (MAX) on the development computer by 

clicking the MAX icon on the desktop ( ), or by selecting Start»All Programs»

National Instruments»Measurement & Automation.

2. Expand the Remote Systems tree.

3. Highlight the system.

Note If you do not see the controller, you may need to disable the firewall on the 

development computer. Go to ni.com/info and enter RIOMAXTroubleshoot 

for more information.

4. Verify that the Serial Number in the General Settings section matches the serial number 

on the device.

5. If you do not want to format the disk on the controller, eliminating all installed software and 

files, skip to step 15.

6. Set the Safe Mode switch on the controller to the On position.

7. Power on the controller. If it is already powered on, press the Reset button on the controller 

to reboot it.

8. Right-click the controller under Remote Systems in the Configuration pane in MAX and 

select Format Disk. 

9. (Optional) Enable the Keep Network Settings checkbox if you want to retain the same 

target name and IP address. 

10. Click Format to start formatting the disk.

11. When MAX finishes formatting the disk, set the Safe Mode switch to the Off position and 

click OK.

12. Select the System Settings tab on the bottom and type a descriptive name for the system in 

the Hostname field.

13. (Optional) Complete this step only if the target has an empty IP address (0.0.0.0). Select the 

Network Settings tab and select DHCP or Link Local from the Configure IPv4 Address 

list to assign an IP address or select the Static to specify a static IP address in the IPv4 

Address section.

14. Click Save on the toolbar and let MAX reboot the system. You may not need to complete 

this step if you did not change the IP address or name.

15. When the new system name appears under Remote Systems, expand the controller item in 

the tree, right-click Software, and select Add/Remove Software.

16. Select a recommended software set that includes NI-RIO 3.4.0 or later. 

17. Click Next.

18. Select LabVIEW NI SoftMotion Module from the add-ons list.

Note If you are using the NI SoftMotion Module 2010 SP1 or earlier, also select 

LabVIEW NI SoftMotion Module Scan Engine Support from the list.
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19. Click Next to install the selected software on the controller. Click Help if you need 

information about installing recommended software sets.

20. When the software installation completes, click Finish to reboot the controller.

21. Close MAX.

Step 2: Create a Project in Scan Interface Mode
Scan Interface mode enables you to use C Series modules directly from LabVIEW Real-Time. 

Modules that you use in Scan Interface mode appear directly under the chassis item in the 

Project Explorer window. Unlike most C Series modules, NI 951x modules are not directly 

configurable from the Project Explorer window and no I/O variables are directly available 

under the module. 

Tip Refer to the Select Programming Mode Dialog Box topic of the CompactRIO 

Reference and Procedures (Scan Interface) help file for more information about Scan 

Interface mode. 

Use a LabVIEW project to manage VIs, targets, and I/O modules on the development computer. 

Complete the following steps to create a LabVIEW project. Depending on which version of 

LabVIEW you are using the steps are slightly different.

Creating a Project in LabVIEW 2012

1. Launch LabVIEW.

2. Select File»Create Project or Project»Create Project to display the Create Project 

dialog box. You can also click the Create Project button on the Getting Started window. 

The Create Project dialog box includes a list of templates and sample projects you can use 

to ensure that the project you create uses reliable designs and programming practices.

3. Select Blank Project from the list of templates.

4. Click Finish.

5. Select Help and make sure that Show Context Help is checked. You can refer to the 

context help throughout the tutorial for information about items on the block diagram.

Creating a Project in LabVIEW 2011 SP1 or Earlier

1. Launch LabVIEW.

2. Select File»New Project or Project»New Project to display the Create Project dialog 

box. You can also click the Empty Project link on the Getting Started window. 

3. Select Help and make sure that Show Context Help is checked. You can refer to the 

context help throughout the tutorial for information about items on the block diagram.
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Step 3: Add Resources to the Project
1. Right-click the top-level project item in the Project Explorer window and select New»

Targets and Devices from the shortcut menu to display the Add Targets and Devices 

dialog box.

2. Make sure that the Existing target or device radio button is selected.

3. Expand Real-Time CompactRIO.

4. Select the CompactRIO controller to add to the project and click OK.

5. If you have LabVIEW FPGA installed, the Select Programming Mode dialog box 

appears. Select Scan Interface to put the system into Scan Interface mode.

Tip Use the CompactRIO Chassis Properties dialog box to change the 

programming mode in an existing project. Right-click the CompactRIO chassis in the 

Project Explorer window and select Properties from the shortcut menu to display 

this dialog box.

6. Click Discover in the Discover C Series Modules? dialog box if it appears.

7. Click Continue. 

Note If you are using the NI 9144 chassis refer to Adding the EtherCAT Master 

Device to the LabVIEW Project in the Setting Up a Distributed System section for 

information about adding the EtherCAT master device before continuing.

8. Right-click the controller item in the Project Explorer window and select Properties from 

the shortcut menu to display the RT Target Properties dialog box. Select Scan Engine 

from the Category list to display the Scan Engine page. 

9. Set the Scan Period to 5 ms or lower, then click OK to close the RT Target Properties 

dialog box.

10. Right-click the controller item in the Project Explorer window and select New»

NI SoftMotion Axis from the shortcut menu to open the Axis Manager dialog box, shown 

in Figure 12.

11. Click Add New Axis to create an NI SoftMotion axis associated with the NI 9512 module. 

Axes are automatically bound to an available module. You can double-click the axis name 

to rename the axis and give it a descriptive name.
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Figure 12.  Axis Manager Dialog Box

12. Click OK to close the Axis Manager dialog box. The new axis is added to the Project 

Explorer window. 

Note You cannot associate more than one axis with the same C Series module.

When you have finished these steps your LabVIEW project should look similar to the 

image in Figure 13.

Figure 13.  Project Explorer Window with Modules in Scan Interface Mode
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Step 4: Configure the NI 9512 Axis
The Axis Configuration dialog box includes configuration options for stepper drive command 

signals, feedback devices, motion and digital I/O, trajectory, and axis setup. Figure 14 shows the 

parts of the Axis Configuration dialog box for NI 9512 C Series module. Refer to the 

NI SoftMotion Module book of the LabVIEW Help for detailed information about each 

configuration option.

Figure 14.  Axis Configuration Dialog Box

Note The Axis Configuration dialog box user interface may not match this image 

exactly depending on which version of the LabVIEW NI SoftMotion Module you are 

using. 

Complete the following steps to configure the axis I/O settings for use with the AKD servo drive.

1. Right-click the axis in the Project Explorer window and select Properties from the 

shortcut menu to open the Axis Configuration dialog box.

2. Configure the following settings on the General Settings page ( ).

a. Confirm that Loop Mode is set to Open-Loop. Axes configured in open-loop mode 

produce step outputs but do not require feedback from the motor to verify position.

b. Set Feedback Source to Encoder 0. 

c. Confirm that the Axis Enabled and Enable Drive on Transition to Active Mode 

checkboxes contain checkmarks. These selections configure the axes to automatically 

activate when the NI Scan Engine switches to Active mode.

Note Disable these options to prevent axes from automatically activating when the 

NI Scan Engine switches to Active mode.



Getting Started with NI 9512 Modules and AKD Servo Drives | © National Instruments | 21

3. Click the Encoder button ( ) and configure the Units and Counts Per Unit.

a. In the Active State section set the Line State for A, B, and Index to High.

b. In the Index Reference Criteria section set the Line State for A and B to Active.

c. Select rev from the Units text box, or type revolutions if you prefer.

d. Set the Counts per Unit to 8,000. This setting is the encoder resolution in quadrature 

counts per revolution and must correspond to the AKD WorkBench emulated encoder 

output Resolution setting in lines per revolution multiplied by four. You may want to 

choose a different resolution depending on your application needs. A setting of 8,000 

assumes an AKD WorkBench Emulated Encoder output Resolution setting of 2,000 

lines per revolution.

Note You configure the emulated encoder output Resolution setting in Step 5: 

Install AKD WorkBench and Configure the Drive in the Software Installation and 

Configuration section.

When you are finished the Encoder Settings page will look similar to Figure 15.

Figure 15.  Axis Configuration Encoder Page

4. Click the Stepper button ( ) to open the Stepper page.

a. Ensure that the Stepper Output settings match the following:

� Output Mode—Step/Direction

� Output Type—Single-Ended

� Active State—Active Low

b. Configure the Units and Steps Per Unit.

� Select rev from the Units text box, or type revolutions if you prefer.

� Set Steps Per revolution to 8,000.
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Note The Steps Per revolution setting must match the AKD WorkBench 

Feedback 2 Resolution parameter specified in Step 5: Install AKD WorkBench and 

Configure the Drive.

c. (Optional) Click the Monitor button ( ) and enable the Enforce Position Error 

Limit checkbox. This causes NI SoftMotion to disable the drive and turn off the Drive 

Enable signal when the specified position error limit is exceeded.

5. (Optional) Click the Digital I/O button ( ) to open the Digital I/O page and map the 

following optional status inputs.

a. Complete the following steps to map DI 1 (DSUB Pin 8) to Drive Fault/Alarm. When 

the Drive Fault/Alarm signal is active, the module does not generate command 

signals. 

1) Double-click the text in the Mapping column and select Drive Fault/Alarm 

from the dropdown list. 

2) Ensure that the DI 1 settings match the following:

� Input Type—Sinking

� Active State—Off

� Digital Filter—50 µs

b. Complete the following steps to map DI 2 (DSUB Pin 4) to Servo/Drive Ready. This 

signal is active when the drive is enabled.

1) Double-click the text in the Mapping column and select Servo/Drive Ready 

from the dropdown list. 

2) Ensure that the DI 2 settings match the following:

� Input Type—Sourcing

� Active State—On

� Digital Filter—50 µs

c. Complete the following steps to map DI 3 (DSUB Pin 3) to In-Position. The 

In-Position signal from the AKD servo drive is active when the current position is 

within a user-specified distance from the target position. This distance is set in Step 5: 

Install AKD WorkBench and Configure the Drive when the Position Error Monitor 

output is configured.

1) Double-click the text in the Mapping column and select In-Position from the 

dropdown list. 

2) Ensure that the DI 3 settings match the following:

� Input Type—Sourcing

� Active State—On

� Digital Filter—50 µs



Getting Started with NI 9512 Modules and AKD Servo Drives | © National Instruments | 23

6. (Optional) Click the Trajectory button ( ) and enable the In-Position to be used as a 

criteria for move complete. When this signal is included in the move complete criteria, the 

move is only complete if the In-Position signal is active. 

7. Click the Drive Enable button ( ) and ensure that the Drive Enable settings match the 

following:

� Output Type—Sourcing

� Active State—On

� Safe State—Off

8. Complete the following additional steps if you do not have limits and home connected at 

this time:

a. Click the Limits & Home button ( ).

b. In the Forward Limit and Reverse Limit sections ensure that the settings match the 

following:

Note These configuration settings disable limits for initial setup and testing 

purposes. National Instruments recommends connecting and enabling limits in your 

final application.

� Clear the Enable checkbox from both Forward Limit and Reverse Limit. 

� Set the Active State for both Forward Limit and Reverse Limit to Off. This 

prevents a limit warning even though limits are turned off.

c. Open the Home section and clear the Enable checkbox.

9. Configure any additional I/O settings according to your system requirements, such as 

position compare or position capture signals.

10. Click OK to close the Axis Configuration dialog box.

11. Right-click the controller item in the Project Explorer window and select Deploy All to 

deploy the axis information.

12. Select File»Save Project to save the project.
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Step 5: Install AKD WorkBench and Configure the Drive
AKD WorkBench is available on the CD that came with the AKD servo drive and is also 

available from ni.com/updates. Complete the following steps to install AKD WorkBench.

1. Insert the AKD WorkBench CD in the CD-ROM drive.

2. Double-click Full Setup.exe to launch the installer.

3. Follow the onscreen instructions to complete the installation.

Complete the following steps to configure the drive settings with AKD WorkBench.

1. Launch the AKD WorkBench software by clicking the AKD WorkBench icon on the 

desktop ( ), or by selecting Start»All Programs»Kollmorgen»AKD WorkBench.

2. Select the drive to configure from the list and click Connect.

Note If the drive is not in the list, refer to the Tips and Troubleshooting section of 

this document for possible solutions.

Figure 16 shows the AKD WorkBench Start page.

Figure 16.  AKD WorkBench Start Page

1 Available Drives 2 Specify Address 3 Connect to Drive

1 32
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3. Open the Parameter Load/Save page from the configuration tree and click Factory 

Defaults to return the drive settings to the factory default values. Any drive settings not 

updated in this document are assumed to be the default values.

4. (Optional) Change the name of the drive from the default name of no_name on the AKD 

Overview page to a more descriptive name.

Figure 17 shows the AKD Overview page.

Figure 17.  AKD WorkBench Overview Page

1 Software Enable/Disable
2 Command Source
3 Operation Mode
4 Clear Faults
5 Save Configuration Settings to Drive

6 Software Enable/Disable
7 Drive Active Indicator
8 Software Enable Status Indicator
9 Hardware Enable Status Indicator
10 Fault Indicator

1 2 4 53

7 8 109

6
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5. Configure the command source and operation mode.

a. Open the Settings page and set the Operation Mode to 2 - Position Mode.

b. Set the Command Source to 2 - Electronic Gearing.

Note You must set the Operation Mode before setting the Command Source or 

AKD WorkBench returns an error.

When you have updated these settings, the Settings page should look similar to Figure 18.

Figure 18.  AKD WorkBench Settings Page
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6. If you mapped any digital input in Step 4: Configure the NI 9512 Axis, configure the AKD 

servo drive digital outputs for the same signals:

a. Open the Digital I/O page under the Settings tree item.

b. If you mapped the NI 9512 DI 2 signal to Servo/Drive Ready, select 8 - Enable from 

the DOUT 1 Mode list.

c. If you mapped the NI 9512 DI 3 signal to In-Position, select 4 - Position Error 

Monitor from the DOUT 2 Mode list.

d. Set Param for the Position Error Monitor output to a reasonable tolerance for the 

system resolution. This setting will depend on the specified encoder counts and steps 

per revolution setting.

When you are finished configuring the digital outputs, the Digital Inputs and Outputs 

page will look similar to Figure 19.

Figure 19.  AKD WorkBench Digital Inputs and Outputs Page

1 DOUT 2 Configuration 2 DOUT 1 Configuration 3 DOUT 2 Param Setting

31 2
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7. Configure the emulated encoder output.

a. Expand the Settings tree item and open the Encoder Emulation page. 

b. Select 1 - Output - With once per rev index pulse from the Function dropdown list.

c. Set the Resolution to 2,000 lines/rev. 

Note The encoder resolution output value determines the equivalent resolution of 

an incremental encoder in pulses per revolution (PPR). NI SoftMotion returns 

encoder positions in encoder counts per revolution. A resolution of 2,000 lines/rev is 

the same as 8,000 quadrature counts per revolution. You may want to choose a 

different value depending on your application needs. In general, higher resolution 

values result in more difficult servo loop tuning; lower resolution values provide less 

accuracy. 

Figure 20 shows the AKD WorkBench Encoder Emulation page.

Figure 20.  AKD WorkBench Encoder Emulation Page
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8. Configure the secondary feedback resolution. This is the NI 9512 steps per revolution, and 

must match the Steps Per revolution setting specified in Step 4: Configure the NI 9512 

Axis.

a. Open the Feedback 2 page under the Settings tree item.

b. Set the Feedback Source to 2 - Feedback Source X7.

c. Confirm that the Feedback Mode is 1 - Input - Step and direction signals. 

d. Set the Resolution to 8,000. A setting of 8,000 counts/rev corresponds to 1 step per 

count, when the AKD emulated encoder Resolution is set to 2,000 and the 

NI SoftMotion encoder Counts Per revolution is set to 8,000.

Note Depending on your application needs, you can chose a value other than 8,000. 

However, the Feedback 2 Resolution setting must match the NI SoftMotion Module 

Steps Per revolution setting specified in Step 4: Configure the NI 9512 Axis.

Figure 21 shows the AKD WorkBench Feedback 2 page.

Figure 21.  AKD WorkBench Feedback 2 Page
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9. Configure the software enable signal:

a. Click the Parameters tree icon to list all configurable drive parameters.

b. Expand the Drive section.

c. Set the Software enable default parameter to 1. This enables the drive on bootup so 

you do not have to enable the drive from WorkBench.

Figure 22 shows the AKD WorkBench Parameters page.

Figure 22.  AKD WorkBench Parameters Page

10. Activate the software enable on the drive by clicking the Enable button on the AKD 

Overview page or on the toolbar. Figure 17 shows the location of the Enable button.

11. Save all configuration changes to the drive by clicking the Save to Drive toolbar button 

shown in Figure 17.

Step 6: Tune the Motor Using the WorkBench 
Performance Servo Tuner
Use the AKD WorkBench Performance Servo Tuner to quickly tune the servo motor with a 

single click. Tune the system with a load connected for best results.

1. Select Performance Servo Tuner under the drive tree item.

2. Confirm that the drive is hardware enabled and enable it if it is not.

3. Click Start. The Performance Servo Tuner performs a series of tests and displays the 

results on the page. The progress bar shows the relative progress of the tuning process.

4. When tuning is complete, the Complete LED illuminates and the Performance Servo Tuner 

page displays a Bode plot showing the frequency response of the system.
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Note Refer to the Using the Performance Servo Tuner topic in the WorkBench Help 

for more information about using the autotuner including advanced autotuning 

options.

Step 7: Enable and Test the Drive Using LabVIEW
Use the Interactive Test Panel to test and debug your motion system and configuration settings 

on the selected axis. With the Interactive Test Panel you can perform a simple straight-line move 

and monitor feedback position and position error information, move and I/O status information, 

change move constraints, get information about software errors and faults, and view position or 

velocity plots of the move. 

Complete the following steps to test your setup after configuring the axis using the Axis 

Configuration dialog box and configuring the drive with the AKD WorkBench software.

1. Right-click the axis in the Project Explorer window and select Interactive Test Panel 

from the shortcut menu. Opening this dialog box sends the axis settings to the hardware and 

activates the I/O on the module.

2. On the Move tab set Target Position to 25 revolutions.

3. On the Move Constraints tab set Velocity to 1 revolution/sec. Using the encoder counts 

per revolution and stepper steps per revolution values specified in this tutorial the motor 

will move 25 revolutions at 60 RPM. 

Tip Click the Help button ( ) on the bottom of the dialog box for detailed 

information about the items available in this dialog box.

4. Click the Enable button ( ) on the bottom of the dialog box to enable the drive.

5. Click the Start button ( ) on the bottom of the dialog box to start the move with the 

configured options.

6. Use the Status and Plots tabs to monitor the move while it is in progress.

Finalize your motion system setup by connecting and configuring additional I/O such as 

limits as required by your system using the 20-pin screw terminal connector. Table 1 shows 

the screw-terminal connector pinout.

Setting Up a Distributed System

Setting Up a System with an NI 9144 Chassis
Complete the following steps to set up the EtherCAT master and configure the distributed 

network for use with the NI 9144.

1. Install the real-time controller into the CompactRIO or PXI system.

2. Connect the controller to a power supply and an Ethernet network on the same subnet as 

the development computer. Refer to the controller operating instructions for information 

about wiring the controller to the power supply and Ethernet network.
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Note Do not plug in or turn on any power to the system until after you complete 

Step 8: Connect the Drive Communication.

3. Connect the secondary port of your EtherCAT Master directly to the IN port (top port) on 

the NI 9144 chassis using a standard Category 5 Ethernet cable. If you are using the 

NI cRIO-9074 as your EtherCAT Master, the secondary port is top port (LAN PORT #2). 

If you are using a PXI system, you must add a PXI-8231/8232 network card for the 

secondary port. You may expand the deterministic Ethernet network by connecting an 

additional NI 9144 chassis or other slave devices to the OUT port (bottom port) on the first 

NI 9144 chassis.

Figure 23.  Connecting the NI 9144 Chassis to Network

4. Install the NI 9512 module in slot 1, 2, 3, or 4 of the NI 9144 chassis.

5. If using the NI 9144 chassis with a PXI master controller, disable Legacy USB Support in 

the host PC BIOS, if it is enabled.

6. Continue with Step 2: Connect NI 9512 to AKD Drive Cable to the C Series Module.

Software Installation and Configuration with the NI 9144
Complete the following steps to configure the controller and install software on it.

1. Launch Measurement & Automation Explorer (MAX) on the development computer by 

clicking the MAX icon on the desktop ( ), or by selecting Start»All 

Programs»National Instruments»Measurement & Automation.

2. Expand the Remote Systems tree.

3. Select the controller under Remote Systems in the Configuration pane. 

Note If you do not see the controller, you may need to disable the firewall on the 

development computer. Go to ni.com/info and enter RIOMAXTroubleshoot 

for more information.

4. Verify that the Serial Number in the Identification section matches the serial number on 

the device.

5. If you do not want to format the disk on the controller, eliminating all installed software and 

files, power on the controller and skip to step 15.

Additional 

NI 9144 Chassis/Slave Devices

NI 9144 Expansion Chassis

NI Master Controller

Host

Computer
Ethernet

Secondary

Primary

IN

OUT

EtherCAT
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6. Set the Safe Mode switch on the controller to the On position.

7. Power on the controller. If it is already powered on, press the Reset button on the controller 

to reboot it.

8. Right-click the controller under Remote Systems in the Configuration pane and select 

Format Disk. Click Yes on the dialog box that appears.

9. When MAX finishes formatting the disk, set the Safe Mode switch to the Off position and 

press the Reset button on the controller to reboot it.

10. Select the System Settings tab and type a descriptive name for the system in the Name 

field.

11. (Optional) Complete this step only if the target has an empty IP address (0.0.0.0). Select the 

Network Settings tab and select DHCP or Link Local from the Configure IPv4 Address 

list to assign an IP address or select the Static to specify a static IP address in the IPv4 

Address section.

12. Click Save on the toolbar and let MAX reboot the system.

13. When the new system name appears under Remote Systems, expand the controller item in 

the tree, right-click Software, and select Add/Remove Software.

14. Select a recommended software set that includes NI-RIO 3.4.0 or later.

15. Click Next.

16. Select the following items from the add-ons list.

� LabVIEW NI SoftMotion Module

� IndCom for EtherCAT Scan Engine Support

Note If you are using the NI SoftMotion Module 2010 SP1 or earlier, also select 

LabVIEW NI SoftMotion Module Scan Engine Support from the list.

17. Click Next to install the selected software on the controller. Click Help if you need 

information about installing recommended software sets.

18. When MAX finishes installing the software on the controller, select the controller under 

Remote Systems in the Configuration pane. 

19. Click the Network Settings tab and expand More Settings in the eth1 section

20. Select EtherCAT from the Adapter Mode list.

Note These settings are not available if NI-Industrial Communications for 

EtherCAT is not installed.
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21. In the eth0 (Primary) section click More Settings and change Packet Detection to 

Polling. Leave the Polling Interval at 1 ms.

When you have completed these steps the Network Settings tab will look similar to 

Figure 24.

Figure 24.  Network Settings Tab

22. Click Save.

23. Close MAX.

24. Continue with Step 2: Create a Project in Scan Interface Mode.

Adding the EtherCAT Master Device to the LabVIEW 
Project
If you are using the NI 9144 chassis, complete the following steps to add the EtherCAT master 

device and detect the C Series modules.

1. In the LabVIEW Project Explorer window, right-click the master controller and select 

New»Targets and Devices.

2. In the Add Targets and Devices dialog window shown in Figure 25, select Existing target 

or device and expand the category EtherCAT Master Device to auto-discover the EtherCAT 

port on the master controller. An EtherCAT master device and modules can be added 

manually at any time.
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Figure 25.  Adding the EtherCAT Master

When all the slave devices are discovered, the LabVIEW Project Explorer window lists 

each slave device and any installed C Series modules.

3. For more information about configuring the deterministic Ethernet network, the NI 9144 

chassis, and the C Series modules, refer to the Related Documentation section of this 

document.

Tips and Troubleshooting

The Drive Does Not Enable
If, after going through all steps in this document, the AKD servo drive does not enable, verify 

the following settings:

� The Drive Enable line from the NI 9512 C Series module must be active. Figure 17 shows 

the location of the hardware enable indicator in the AKD WorkBench software.

� The software enable must be enabled. This setting is available on the upper toolbar in the 

AKD WorkBench software. Figure 17 shows the location of the software enable indicator 

and toolbar button.

� The drive must not be in a fault state. Click the Clear Faults button on the WorkBench 

toolbar to clear the fault state after determining and fixing the source of the fault. Figure 17 

shows the location of the Fault indicator and Clear Faults toolbar button.

Tip Refer to the AKD Fault and Warning Messages card that came with the drive 

for fault information and solutions.

Cannot Communicate with the Drive Using Ethernet
Confirm that the link LEDs on the drive and PC are both illuminated. Figure 11 shows the 

location of the link LED on the drive.
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Increasing the Maximum Velocity and Acceleration
The default AKD settings limit the velocity to 3000 RPM and the acceleration and deceleration 

to 10,000 RPM/sec. These limits are acceptable for most applications. Complete the following 

steps to modify the limits if your application requires different limits.

1. Launch the AKD WorkBench software. 

2. Select the drive to configure from the list and click Connect.

3. Open the Electronic Gearing page under the Settings tree item.

4. Set Maximum Velocity to 8000 RPM and set both Maximum Acceleration and 

Maximum Deceleration to 200,000 RPM/sec.

5. Save the configuration changes to the drive by clicking the Save to Drive toolbar button 

shown in Figure 17.

Connecting to the PC Using a Static IP
1. Use the S1 and S2 rotary switches on the drive to set a static IP address. The IP address is 

192.168.0.S1S2. For example, if S1 is set to 2 and S2 is set to 3 the IP address is 

192.168.0.23. 

Note If you change S1 or S2 when the +24 V power supply is powered on, you must 

unplug the network cable from the drive for at least three seconds to reset the 

IP address.

2. Connect the AKD servo drive to the computer directly using an Ethernet cable. Figure 11 

shows the location of the X11 service port on the drive.

3. Complete the following steps to configure the static IP based on your operating system 

version.

Windows XP

a. Select Start»Control Panel»Network Connections to open the Network 

Connections dialog box.

b. Select the network connection type corresponding to the port you used to connect the 

AKD servo drive. This will most likely be Local Area Connection x, where x 

corresponds to the number of the connection.

c. Click Properties to open the Local Area Connection Properties dialog box.

d. Select Internet Protocol (TCP/IP) from the list and click Properties.

e. In the Internet Protocol (TCP/IP) dialog box, select Use the following IP address.

f. Change IP address to 198.168.0.100.

g. Change Subnet mask to 255.255.255.0. 

Windows Vista or Later

a. Select Start»Control Panel»Network and Sharing Center.

b. Select the network connection type corresponding to the port you used to connect the 

AKD servo drive. This will most likely be Local Area Connection x, where x 

corresponds to the number of the connection.
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c. Click Properties to open the Local Area Connection Properties dialog box.

d. Select Internet Protocol Version 4 (TCP/IPv4) from the list and click Properties.

e. In the Internet Protocol Version 4 (TCP/IPv4) dialog box, select Use the following 

IP address.

f. Change IP address to 198.168.0.100.

g. Change Subnet mask to 255.255.255.0. 

Verify that S1 and S2 are set to non-zero values.

The Motor Responds Poorly
Use the AKD WorkBench Autotuner to change the control loop settings for the motor. Refer to 

the Using the Autotuner topic in the WorkBench Help for more information about using the 

autotuner including advanced autotuning options.

Cannot See the AKD Servo Drive in the AKD 
WorkBench Software
Manually enter the drive IP address by enabling the Specify Address checkbox on the AKD 

WorkBench software Start Page shown in Figure 16. To obtain the drive IP address either press 

the B1 button on the top of the drive or disconnect and reconnect the Ethernet cable. In either 

case, the LED displays the digits and dots of the IP address in sequence. Figure 26 shows the 

location of the B1 button.

Figure 26.  AKD Servo Drive B1 Button

X11

B1
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Wiring Diagram

Figure 27.  AKD Wiring Diagram
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Worldwide Support and Services

The National Instruments Web site is your complete resource for technical support. At 

ni.com/support you have access to everything from troubleshooting and application 

development self-help resources to email and phone assistance from NI Application Engineers.

Visit ni.com/services for NI Factory Installation Services, repairs, extended warranty, 

calibration, and other services. 

Visit ni.com/register to register your National Instruments product. Product registration 

facilitates technical support and ensures that you receive important information updates from NI.

A Declaration of Conformity (DoC) is our claim of compliance with the Council of the European 

Communities using the manufacturer’s declaration of conformity. This system affords the user 

protection for electromagnetic compatibility (EMC) and product safety. You can obtain the DoC 

for your product by visiting ni.com/certification. If your product supports calibration, 

you can obtain the calibration certificate for your product at ni.com/calibration.

National Instruments corporate headquarters is located at 11500 North Mopac Expressway, 

Austin, Texas, 78759-3504. National Instruments also has offices located around the world to 

help address your support needs. For telephone support in the United States, create your service 

request at ni.com/support and follow the calling instructions or dial 512 795 8248. For 

telephone support outside the United States, visit the Worldwide Offices section of ni.com/

niglobal to access the branch office Web sites, which provide up-to-date contact information, 

support phone numbers, email addresses, and current events.

http://www.ni.com/support
http://www.ni.com/certification
http://www.ni.com/calibration
http://www.ni.com/support
http://www.ni.com/niglobal
http://www.ni.com/niglobal
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