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Conventions

The following conventions are used in this manual:

» The » symbol leads you through nested menu items and dialog box options 

to a final action. The sequence File»Page Setup»Options directs you to 

pull down the File menu, select the Page Setup item, and select Options 

from the last dialog box.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

bold Bold text denotes items that you must select or click on in the software, 

such as menu items and dialog box options. Bold text also denotes 

parameter names.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction 

to a key concept. This font also denotes text that is a placeholder for a word 

or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 

keyboard, sections of code, programming examples, and syntax examples. 

This font is also used for the proper names of disk drives, paths, directories, 

programs, subprograms, subroutines, device names, functions, operations, 

variables, filenames and extensions, and code excerpts.
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1
System Requirements 
and Installation

This chapter lists system requirements and installation instructions and 

introduces the IMAQ Vision Builder environment.

System Requirements

To run IMAQ Vision Builder, you must have the following minimum 

system requirements:

• Personal computer using at least a 133 MHz Pentium or higher 

microprocessor (233 MHz Pentium MMX or higher microprocessor 

recommended)

• Microsoft Windows 2000/NT/9x

• 800 × 600 resolution (or higher) video adapter, 65,536 colors (16-bit) 

or higher

• National Instruments image acquisition (IMAQ) hardware and 

NI-IMAQ 2.2 or higher for Windows 2000/NT/9x (if you are acquiring 

images)

• Minimum of 32 MB RAM (64 MB recommended)

• Minimum of 30 MB of free hard disk space

Note You need Excel 97 or higher installed on your computer to complete a few steps in 

the second tutorial.
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Installing IMAQ Vision Builder

Note To install IMAQ Vision Builder on a Windows NT or Windows 2000 system, you 

must be logged in with Administrator privileges.

1. Insert the IMAQ Vision Builder CD into your CD-ROM drive.

If the CD startup screen does not appear, use the Windows Explorer to 

run the SETUP.EXE program in the \Setup directory on the CD.

2. Follow the setup instructions you see on your screen.

By default, the IMAQ Vision Builder installation program creates a new 

folder, \Program Files\National Instruments\IMAQ Vision 

Builder\, that contains the following items:

• Program folder—IMAQ Vision Builder.exe, the online help file, 

function libraries, and other related program files

• Readme.txt—Late-breaking information about IMAQ Vision 

Builder

• Examples folder—Images and scripts that you need to complete the 

example tutorials in this manual

• Manuals folder—Portable Document Format (PDF) versions of the 

IMAQ Vision User Manual and this manual

Note You must have Adobe Acrobat Reader installed to access these documents.

• Solutions folder—Example images and scripts

Launching and Exiting IMAQ Vision Builder

To launch IMAQ Vision Builder in Windows, point to 

Start»Programs»National Instruments IMAQ Vision Builder»

IMAQ Vision Builder.

To quit IMAQ Vision Builder, follow these steps:

1. Close open parameter windows.

2. Save your script and images if you want to keep them.

3. Select File»Exit.



Chapter 1 System Requirements and Installation

© National Instruments Corporation 1-3 IMAQ Vision Builder Tutorial

IMAQ Vision Builder Environment

IMAQ Vision Builder is a tool that you can use to prototype and test image 

processing applications. To prototype your image processing application, 

you build custom algorithms with the IMAQ Vision Builder scripting 

feature. The scripting feature records every step of your processing 

algorithm. After completing the algorithm, you can test it on other images 

to make sure it works.

The algorithm is recorded in a Builder file. Builder files are ASCII text files 

that list the processing functions and relevant parameters for an algorithm 

that you create in IMAQ Vision Builder. You can implement the algorithm 

defined by the Builder file in any development environment, such as 

LabVIEW, LabWindows/CVI, or Visual Basic using the IMAQ Vision 

machine vision and image processing library. Refer to Implementing the 

Algorithm in LabVIEW in Chapter 3, Using Blob Analysis to Analyze the 

Structure of a Metal, for an example of a Builder file and its LabVIEW 

implementation.

Features
IMAQ Vision Builder offers the following features:

• Script window—Records a series of image processing steps and the 

settings you use for each of those steps. You can run scripts on single 

images or image collections (batch processing). You can modify and 

save scripts. See Figure 2-6 to view a script in the Script window.

• Image Browser—Contains all of the images currently loaded in IMAQ 

Vision Builder. Through the Image Browser, you can select an image 

that you want to process by double clicking on it. See Figure 2-3 to 

view images loaded into the Image Browser.

• Acquisition window—Displays the Interfaces window (IMAQ 

hardware and channels available) and the property pages for the 

IMAQ hardware device. See Figure 2-7 to view all the elements of the 

Acquisition window.

• Processing window—Updates the image as you change parameters. 

Because this view immediately reflects the changes you have made in 

the parameters window, you can continue modifying parameters until 

you get the desired result. See Figure 2-4 to view an image loaded into 

the Processing window.

• Parameter window—Displays parameters that you can set for an image 

processing function. Each IMAQ Vision function available through the 

menus has a parameter window where you set the parameters for that 
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function. See Figure 2-5 to view an example of the threshold 

Parameter window.

• Reference window—Displays the original version of the image 

(image source) as you manipulate it in the processing window. See 

Figure 2-4 to view an image in the Reference window.

• Tools palette—Displays a collection of tools for selecting regions of 

interest (ROI), zooming in and out, and changing the Image palette. 

See Figure 2-6 to view the Tools palette.

• Solution Wizard—Displays a list of industries and corresponding 

quality-assurance tasks that those industries perform. Based on the 

task the user selects, the wizard loads an IMAQ Vision-based solution 

to the task.

• Performance Meter—Estimates how long your script will take to run 

in IMAQ Vision on a given image. The Performance Meter gives you 

estimates on both how long the entire script will take to run on the 

current image and how long each function of the script will take to 

execute.

Image Analysis Functions
IMAQ Vision Builder also offers several image analysis functions, 

including the following:

• Histogram—Counts the total number of pixels in each grayscale value 

and graphs it.

• Line Profile—Returns the grayscale values of the pixels along a line 

that you draw with the Line Tool from the Tools palette and graphs it.

• Particle Analysis—Computes more than 40 measurements on objects 

in an image, including the area and perimeter of the objects.

• 3D View—Displays an image using an isometric view. Each pixel 

from the image source is represented as a column of pixels in the 

3D view. The pixel value corresponds to the altitude.

• Centroid—Computes the energy center of a grayscale image or area of 

interest.

Image Processing Functions
IMAQ Vision Builder includes a comprehensive set of functions for image 

processing, including the following:

• Filtering—Functions for smoothing, edge detection, and convolution.

• Morphology—Functions (including erosion, dilation, opening, and 

closing) that modify the shape of objects in grayscale or binary images.
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• Thresholding—Functions that enable you to select ranges of pixel 

values in grayscale and color images, separating the objects under 

consideration from the background.

• Particle Filtering—Functions to filter objects based on shape 

measurements.

Machine Vision Functions
IMAQ Vision Builder also offers several machine vision functions, 

including the following:

• Edge Detection—Finds edges along a line that you draw with the 

Line Tool from the Tools palette.

• Pattern Matching—Locates regions of a grayscale image that match a 

predetermined template. Pattern Matching can find template matches 

regardless of poor lighting, blur, noise, shifting of the template, and 

rotation of the template.

• Shape Matching—Searches for the presence of a shape in a binary 

image and specifies the location of each matching shape. The shape 

can be detected even if rotated or scaled.

• Circle Detection—Finds the center and radius of circular objects in an 

image.

• Caliper—Computes measurements such as distances, areas, and 

angles based on results returned from other machine vision and image 

processing functions.

• Color Matching—Quantifies which colors and how much of each color 

exist in a region of an image and uses this information to check if 

another image contains the same colors in the same ratio.

Getting Help

As you work with IMAQ Vision Builder, you might need to consult other 

sources if you have questions. The following sources can provide you with 

more specific information about IMAQ Vision, IMAQ hardware, and 

imaging.

IMAQ Vision Builder Online Help
IMAQ Vision Builder offers tooltips and online help that you can access in 

the following ways:

• Access the IMAQ Vision Builder online help by selecting Online Help 

from the Help menu. There you can find information not available in 
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this manual, such as function descriptions and directions for 

performing image processing functions.

• Tooltips appear when you move the mouse cursor over a button in the 

Processing toolbar, Tools palette, Script window, Reference window, 

Acquisition window, or Image Browser.

• Press the Help button in any function parameter window to get 

information about that function and its parameters.

IMAQ Vision Manuals
If you have purchased IMAQ Vision software from National Instruments, 

you also have one of the following manuals, depending on the development 

environment you use. The following manuals provide information about 

image processing and the IMAQ Vision functions:

• IMAQ Vision for G Reference Manual

• IMAQ Vision for LabWindows/CVI

• Getting Results with ComponentWorks IMAQ Vision

For detailed information about the concepts and algorithms used by 

IMAQ Vision Builder, launch the IMAQ Vision User Manual from the 

Start menu (Start»Programs»National Instruments IMAQ Vision 

Builder»IMAQ Vision User Manual).

National Instruments Web Site
The National Instruments Web site provides information about IMAQ 

hardware and software. Visit the site at www.ni.com/imaq.

From the IMAQ site, you can locate information about new IMAQ Vision 

features, machine vision problems and solutions, using MMX technology 

on machine vision applications, and selecting the appropriate IMAQ 

hardware, cameras, lenses, and lighting equipment for your application.

IMAQ Vision Builder Scripts
You installed several example scripts when you installed IMAQ Vision 

Builder. You can run these scripts to learn more about IMAQ Vision 

Builder scripting capabilities. You also can customize these scripts for 

your own applications. By default, the scripts are installed at \Program 

Files\National Instruments\IMAQ Vision Builder\Examples.
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2
Introduction to Image 
Processing with 
IMAQ Vision Builder

This chapter describes how you can use IMAQ Vision Builder to create and 

test your own image processing algorithms. It explains the types of images 

IMAQ Vision Builder can load and process and how to get started in IMAQ 

Vision Builder.

Images

For the purposes of image processing, the term image refers to a digital

image. An image is a function of the light intensity

f(x, y)

where f is the brightness of the point (x, y), and x and y represent the spatial 

coordinates of a picture element (abbreviated pixel).

By convention, the spatial reference of the pixel with the coordinates (0, 0) 

is located at the upper-left corner of the image. Notice in the following

representation that the value of x increases moving from left to right, and

y increases in the downward direction.

Figure 2-1.  Spatial Reference of the (0, 0) Pixel

Properties
A digitized image has three basic properties: resolution, definition, and 

number of planes. 

Y

X

f(x,y)

(0,0)
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• Image Resolution—The spatial resolution of an image is its number of 

rows and columns of pixels. An image composed of m rows and n 

columns has a resolution of m × n. This image has n pixels along its 

horizontal axis and m pixels along its vertical axis.

• Image Definition—The definition of an image indicates the number of 

shades that you can see in the image. The bit depth of an image is the 

number of bits used to encode the value of a pixel. For a given bit depth 

of n, the image has an image definition of 2n, meaning a pixel can have 

2n different values. For example, if n equals 8 bits, a pixel can take 256 

different values ranging from 0 to 255. If n equals 16 bits, a pixel can 

take 65,536 different values ranging from 0 to 65,535 or from –32,768 

to 32,767.

• Number of Planes—The number of arrays of pixels that compose the 

image. A gray-level or pseudo-color image is composed of one plane, 

while a true-color image is composed of three planes—one for the red 

component, one for the blue, and one for the green—as shown in 

Figure 2-2. For a color version of this figure, see the PDF version of 

this document, which you can find in Start»Programs»National 

Instruments IMAQ Vision Builder»IMAQ Vision Builder 

Tutorial.

Figure 2-2.  Number of Planes in an Image

In gray-level images, there is a single intensity value per pixel. In 

three-plane or true-color images, the RGB intensities of a pixel are 

coded into three different values, corresponding to the red, green, and 

blue components.
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Image Types and File Formats
The IMAQ Vision libraries can manipulate three types of images: 

gray-level, color, and complex images.

• Gray-Level Images—Gray-level images are composed of a single 

plane of pixels. Standard gray-level image file formats are 8-bit BMP, 

TIFF, PNG, JPEG, and AIPD. Standard 16-bit gray-level formats are 

PNG and AIPD. AIPD is an internal file format that offers the 

advantage of storing the spatial calibration of an image.

• Color Images—Color images are composed of pixels that are a 

composite of four values. In the RGB color model, each color is 

encoded with an 8-bit red, green, and blue value. In the HSL color 

model, each color is encoded with an 8-bit hue, saturation, and 

luminance value. In both color models, an additional 8-bit value 

goes unused. This representation is called both 4 × 8 bit and 32 bit. 

Standard color file formats for RGB images are BMP, TIFF, PNG, 

JPEG, and AIPD.

• Complex Images—Complex images are composed of complex data in 

which pixel values have a real part and an imaginary part. Such images 

are derived from the Fast Fourier transform of gray-level images. Four 

representations of a complex image can be given: the real part, 

imaginary part, magnitude, and phase. 

Getting Started in IMAQ Vision Builder

This section describes the software-specific terminology that you need to 

complete the tutorials in this manual and understand the online help. The 

best way to understand how IMAQ Vision Builder works and what you can 

accomplish with IMAQ Vision Builder is by using it.

In this short example, you load images into IMAQ Vision Builder and 

perform one image processing function—a threshold. Thresholding 

isolates objects so that you can keep those that interest you and remove 

those that do not. Thresholding also converts the image from a grayscale 

image, with pixel values ranging from 0 to 255, to a binary image, with 

pixel values of 0 or 1.

Follow these steps to get started in IMAQ Vision Builder:

1. Launch IMAQ Vision Builder from the Start menu 

(Start»Programs»National Instruments IMAQ Vision 

Builder»IMAQ Vision Builder). 
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2. To load images, select the Open Image button from the Welcome 

Screen.

3. Navigate to Program Files\National Instruments\IMAQ 

Vision Builder\Examples\Metal and check the Select All Files 

option. IMAQ Vision Builder previews the images in the Preview 

Image window and displays information about the file type and image 

depth.

4. Click OK.

IMAQ Vision Builder loads those image files into the Image Browser, 

as shown in Figure 2-3. The Image Browser provides information 

about the selected image, such as image size, location, depth, and type.

Figure 2-3.  Image Browser

Image Location

Image Browser

Browse Buttons

Image
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Close
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You can view new images in either thumbnail view, as shown in 

Figure 2-3, or in full-size view, which shows a single full-size view of 

the selected image.

5. Click the Thumbnail/Full-Size View toggle to view the first image in 

full size.

6. To enter processing mode, double click the image Metal1.jpg. 

IMAQ Vision Builder loads the image into the processing window, 

as shown in Figure 2-4.

Figure 2-4.  Processing an Image

Processing WindowReference Window

Zoom RatioImage SizeScript Window
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Tip The Reference window displays the original version of the image as you manipulate 

it in the Processing window.

7. Select Grayscale»Threshold. The Threshold parameter window 

appears in the lower right corner of the IMAQ Vision Builder window, 

as shown in Figure 2-5.

Figure 2-5.  Thresholding an Image

The Threshold parameter window displays a histogram. A histogram 

counts the total number of pixels at each grayscale value and graphs it. 

From the graph, you can tell whether the image contains distinct 

regions of a certain gray-level value, and you can select pixel regions 

of the image. For example, if the background of an image is black and 

you want to remove it, you can select a range with values close to 255 

(white). 

Threshold Parameter Window
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The Processing window displays a preview of the threshold operation 

using the current set of parameters. The pixels depicted in red have 

intensities that fall inside the threshold range. The threshold operator 

will set their values to 1. The pixels depicted in gray have values 

outside the threshold range. The threshold operator will set their values 

to 0.

8. From the Threshold parameter window, specify settings that work best 

for your application. To threshold this image, set the Min value to 130 

and Max value to 255 to select all of the objects.

Tip Often you will need to manipulate the parameters several times to find the values that 

work best. Rather than entering numbers in the Min and Max fields, you can select the 

range using the pointers on the histogram. Adjust the pointers until all of the objects you 

want to select are red. The black pointer marks the minimum value, and the white pointer 

marks the maximum value.

9. Click OK to apply the manual threshold to the image. The image is 

converted to a binary image where all of the selected pixels in the 

threshold range are set to 255 (white) and all other pixels are set 

to 0 (black).

Refer to Figure 2-6 to see what the image looks like after the threshold 

has been applied. 
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Figure 2-6.  Thresholded Image

The thresholding step is recorded in the Script window. The script 

records the processing operation and all of its parameters. If you need 

to run the same operation on other images, you can save the script and 

use it again.

10. Select Script»Save Script and name the script threshold.scr. 

If you find another image that you need to threshold similarly, run this 

script on a different image using the following steps:

a. Load the image.

b. Select Script»Open Script to open threshold.scr.

c. Click the Run Script button in the script window.

Try experimenting with different options and images. For example, 

you can perform a particle analysis to find the area that each object in 

Script
Window

Script
Tools

Tools
Palette
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this image occupies. If you need help with any specific image 

processing operation, click the Help button in the parameter window.

11. Select File»Exit to close IMAQ Vision Builder.

Acquiring Images in IMAQ Vision Builder

If you have National Instruments IMAQ hardware and NI-IMAQ installed, 

you can acquire live images in IMAQ Vision Builder.

Tip If you do not have IMAQ hardware and NI-IMAQ 2.2 or later, IMAQ Vision Builder 

automatically simulates the acquisition process by displaying a sequence of images. You 

can stop the sequence at any frame, capture the image, and send the image to the Image 

Browser for processing.

IMAQ Vision Builder offers three types of acquisitions: snap, grab, and 

sequence. A snap acquires and displays a single image. A grab acquires 

and displays a continuous sequence, which is useful, for example, when 

you need to focus your camera. A sequence acquires images according to 

settings that you specify and sends the images to the Image Browser.

Opening the Acquisition Window
If IMAQ Vision Builder is not loaded, launch the application from the 

Start menu (Start»Programs»National Instruments IMAQ Vision 

Builder»IMAQ Vision Builder). Press the Acquire Image button from 

the Welcome Screen to view the Acquisition window, as shown in 

Figure 2-7.

If you already have IMAQ Vision Builder running, press the 

Acquire Image button in the toolbar. IMAQ Vision Builder displays the 

Acquisition window, as shown in Figure 2-7.

The Interfaces window displays all IMAQ hardware and channels available 

for your computer. Figure 2-7 shows that two IMAQ hardware devices are 

available—the IMAQ PCI-1408 and the IMAQ PCI-1424.

Note The hardware devices listed in your Interfaces window will vary according to the 

devices plugged into your computer.
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Figure 2-7.  Acquiring Images in IMAQ Vision Builder

The property pages above the Interfaces window list properties available 

for the selected device. In Figure 2-7, the IMAQ PCI-1408 is selected. 

Because the PCI-1408 can acquire a sequence of images, you can set the 

following properties for Sequence acquisition. For information about the 

properties of other IMAQ devices, see your hardware manual and the 

Measurement & Automation Explorer online help.

• Number of Frames—Number of frames you want to acquire.

• Skip Count—Number of frames you want to skip between 

acquisitions.

• Line—Physical trigger line.

• Action—Triggering action. 

– Disabled—Disables triggering

Acquisition Property Pages

Store Acquired Image in Browser

IMAQ Hardware and Channels

Acquisition Window
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– Trigger start of acquisition

– Trigger each image

• Timeout—Time, in milliseconds, within which the trigger must 

occur.

Note A trigger is any event that causes or starts some form of data capture.

Note Your computer must have a National Instruments IMAQ board and NI-IMAQ 2.2 or 

higher installed before you can acquire live images in IMAQ Vision Builder.

Snapping an Image (Single Acquisition)

1. Make sure the Acquisition window is open.

2. Click the Acquire Single Image button to acquire a single image with 

the IMAQ device and display it. This operation is also known as a 

snap.

3. Press the Store Acquired Image in Browser button to send the image 

to the Image Browser.

4. Press Return to return to the Image Browser.

5. Process the image as you would any other image in IMAQ Vision 

Builder. See Chapter 3, Using Blob Analysis to Analyze the Structure 

of a Metal, and Chapter 4, Using Gauging for Part Inspection for 

examples of processing images in IMAQ Vision Builder.

Grabbing an Image (Continuous Acquisition)

1. Make sure the Acquisition window is open.

2. Click the Acquire Continuous Images button to acquire and display 

images in continuous mode at the maximum rate. This operation is also 

known as a grab.

Note If your computer does not have an IMAQ board, IMAQ Vision Builder simulates the 

live acquisition process. You can interact with the simulation module as you would with a 

live acquisition.

3. Click the Acquire Continuous Images button again to stop the 

acquisition and display the last acquired image.

Tip You can acquire a region of interest within the full-sized image. Draw a region of 

interest in your image while grabbing it, and the image reduces to that area. You can refine 
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the acquired area again by selecting another region of interest or return to the full-sized 

image by clicking on the image.

4. Press the Store Acquired Image in Browser button to send the image 

to the Image Browser.

5. Press Return to return to the Image Browser.

6. Process the image as you would any other image in IMAQ Vision 

Builder. See Chapter 3, Using Blob Analysis to Analyze the Structure 

of a Metal, and Chapter 4, Using Gauging for Part Inspection, for 

examples of processing images in IMAQ Vision Builder.

Acquiring a Sequence of Images

1. Make sure the Acquisition window is open.

2. Set the properties for the Sequence property page.

3. Click the Sequence Acquisition button to acquire a sequence of live 

images. A panel describing the status of sequence acquisition appears.

If you set the triggering action property to Disabled, press the Start 

Acquisition button to begin acquiring a sequence of images.

Images acquired are automatically sent to the Image Browser.

4. Press Return to return to the Image Browser.

5. Process the image as you would any other image in IMAQ Vision 

Builder. See Chapter 3, Using Blob Analysis to Analyze the Structure 

of a Metal, and Chapter 4, Using Gauging for Part Inspection, for 

examples of processing images in IMAQ Vision Builder.
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3
Using Blob Analysis to Analyze 
the Structure of a Metal

This chapter describes blob analysis and provides step-by-step directions 

for completing a blob analysis tutorial in IMAQ Vision Builder.

What Is Blob Analysis?

Blob analysis consists of a series of processing operations and analysis 

functions to produce some information about the blobs in an image. A blob 

(binary large object) is defined as a connected region or grouping of pixels 

in an image in which all pixels have the same intensity level. In a binary 

image, the background is zero, and every non-zero pixel is part of a binary 

object.

You perform a blob analysis to find statistical information—such as the size 

of the blobs or the number, location, and presence of blob regions. With this 

information, you can detect flaws on silicon wafers, detect soldering 

defects on electronic boards, or locate objects in motion control 

applications when there is significant variance in part shape or orientation.

Tutorial

In this tutorial, you find the area of circular particles in a metal. As you 

perform this analysis, IMAQ Vision Builder records all of the processing 

operations and parameters in a script. You will run that script on other 

images to test your blob analysis script.

To find the total area of circular particles, you will perform the following 

image processing steps:

• Filter the image to sharpen edges and ease the separation of the 

particles from the background.

• Threshold the image to isolate pixels that interest you (the particles) 

and remove all other pixels (the background).

• Fill holes that appear in the particles after thresholding.
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• Remove all objects touching the border so that you remove partial 

particles.

• Use a particle filter to find all circular blobs and remove non-circular 

blobs.

• Perform a particle analysis to find the total area occupied by circular 

blobs.

Loading Images into IMAQ Vision Builder

1. If IMAQ Vision Builder is not loaded, launch the application from the 

Start menu (Start»Programs»National Instruments IMAQ Vision 

Builder»IMAQ Vision Builder). Press the Open Image button from 

the Welcome Screen.

If you already have IMAQ Vision Builder running, press the 

Open Image button in the toolbar.

2. Navigate to Program Files\National Instruments\IMAQ 

Vision Builder\Examples\Metal and check the Select All Files 

option. IMAQ Vision Builder previews the images in the Preview 

Image window and displays information about the file format and size 

and pixel depth.

Tip The Preview Image window displays all selected images in a sequence. To view the 

images at a different rate, adjust the slide to the right of the Preview Image window.

3. Click OK.

IMAQ Vision Builder loads the image files, which represent 

microscopic views of pieces of metal, into the Image Browser. From 

this collection of images in the Image Browser, you can select the 

image that you want to process. 

4. Double click the first image, Metal1.jpg. The image is loaded into 

the processing window.

Preparing an Image for Blob Analysis
Before you can separate circular particles from non-circular particles, 

you need to prepare the image. To isolate particles of interest, verify that 

individual particles are distinct from other particles (that is, there is a gap 

between particles) and that the borders of those particles are sharp.
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Examining the Image
Examine the image in the processing window. The image is slightly 

blurred. Also, the edges of particles are not sharp. Although you can see 

these problems from just looking at this image, you might need to use a line 

profile in other cases. A line profile returns the grayscale values along a line 

that you draw with the Line Tool from the Tools palette. Follow these steps 

to examine edges using a line profile:

1. Select Image»Line Profile. The parameter window appears and the 

Line Tool from the Tools palette is automatically selected and active.

2. Draw a short segment across a particle, as shown in Figure 3-1.

Figure 3-1.  Using a Line Profile to Examine Edges

In Figure 3-1, the areas labeled 1 and 2 represent the edges of the 

particles. Notice that the edges of both particles have a slope. The more 

shallow the slope, the greater variation you will have in detecting the 

exact location of the edge. As you change the threshold level in images 

with shallow-sloped particle edges, you could inadvertently change the 

1 2

3
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shape or size of the particle. In the Filtering the Image section, you will 

use the Convolution-Highlight Details filter under Grayscale»Filters 

to define the edges of the particles and increase the slope.

The area labeled 3 is a fluctuation in pixel values, which might be 

caused by brighter and darker pixels in the center of the particles or it 

could be edges of a hole in the particle. Later, you will threshold the 

image to make all pixels in the objects the same pixel value and 

perform a morphological operation on the image to fill any holes left 

in the object.

3. Click Close.

Filtering the Image
Filters can smooth, sharpen, transform, and remove noise from an image so 

that you can extract the information you need. To sharpen edges, including 

the edges of any holes inside a particle, and create contrast between the 

particles and the background, follow these steps:

1. Select Grayscale»Filters.

2. Select Convolution-Highlight Details from the Filters list. This 

function looks for sharp transitions and highlights edge pixels 

according to a kernel to make gaps more prominent. A kernel is a 

structure that represents a pixel and its relationship to its neighbors. 

3. Click Apply to add this step to the script.

4. Click Close.

Examining the Results of the Filtering
To confirm that the filtering helped sharpen edges and separate particles, 

perform another line profile using the following steps:

1. Select Image»Line Profile.

2. Click and drag to draw a short segment across a particle to examine the 

line profile of a particle and its border, as shown in Figure 3-2. The line 

profile indicates more defined edges.

3. Click Close.
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Figure 3-2.  Using a Line Profile to Examine Particle Edges

Separating Particles from the Background with Thresholding
Thresholding isolates pixels so that you can keep those that interest you and 

remove the remaining pixels. Thresholding also converts the image from 

grayscale to binary.

The Threshold parameter window displays a histogram. A histogram 

counts the total number of pixels in each grayscale value and graphs it. 

From the graph, you can tell whether the image contains distinct regions of 

a certain gray-level value, and you can select pixel regions of the image.

Follow these steps to select a range of brighter pixels to analyze:

1. Select Grayscale»Threshold.

2. Select Manual Threshold from the Threshold list.
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3. Select a range of 130 to 255.

Notice that the particles of interest (circular and non-circular) are 

highlighted in red. When you apply this threshold, everything 

highlighted in red is set to white (255) and all other pixels are set 

to 0 (black).

Tip You can adjust the pointers until all of the particles of interest are red. The black 

pointer marks the minimum value, and the white pointer marks the maximum value.

4. Click OK to add this step to the script. Figure 3-3 shows the 

thresholded image. The pixels that you want to process are white. 

Unselected pixels are set to black.

The image is now a binary image, which is an image composed of 

black and white pixels with values of 0 and 255. The white particles 

are now referred to as blobs.

Figure 3-3.  Separating Particles from the Background with Thresholding
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Modifying Blobs with Morphological Functions
Morphological functions affect the shape of blobs. Each blob or region in 

the binary image is affected on an individual basis. Morphological 

operations prepare blobs in the image for quantitative analysis such as 

finding the area, perimeter, or orientation. Use the following steps to apply 

two morphological functions to the image. The first function fills holes in 

the particles and the second removes objects that touch the border of the 

image.

1. Select Binary»Adv. Morphology.

2. Select Fill holes from the Morphology-Advanced function list.

3. Click Apply to add this step to the script.

4. Select Remove border objects to remove any objects that touch the 

border of the image, as shown in Figure 3-4.

5. Click Apply and Close to add this step to the script and close the 

Advanced Morphology window.

Figure 3-4.  Modifying Blobs with Morphological Functions
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Isolating Circular Blobs
Use the following steps to define a particle filter that isolates and keeps the 

circular blobs and removes the non-circular blobs from the image.

1. Select Binary»Particle Filter.

2. Select Heywood circularity factor from the list of particle filters. 

This function calculates the ratio of the perimeter of the blob to the 

area of the particle. The more circular the blob, the closer the ratio to 1.

3. To find more circular and less oblong blobs, enter a minimum value 

of 0 and a maximum value of 1.06 for the parameter range.

4. Select the Keep Objects option to keep the circular blobs (and remove 

the blobs that do not fit in this range).

5. Click OK to add this step to the script. The image now contains only 

the circular blobs, as shown in Figure 3-5.

Figure 3-5.  Isolating Circular Blobs
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Analyzing Circular Blobs
Now that you have isolated the circular blobs, follow these steps to find the 

area occupied by them:

1. Select Binary»Particle Analysis. A results table is displayed with all 

of the measurement results.

IMAQ Vision Builder assign numerical labels to each blob. The 

first row of the results table lists the numerical label associated with 

each blob.

2. Click the Show/Hide Labels button to view the labels.

Tip When you click on a blob, the measurement results for that blob are highlighted in 

blue. When you click on the results for a blob, the blob is highlighted in yellow in the 

processing view.

3. To show only the area measurement, click the Choose Measurements 

button.

4. Click None to deselect all of the measurements.

5. Double click Area (unit).

6. Click OK.

7. Click Apply to record the particle analysis in the script.

8. Click Close.

You now have all of the information you need to analyze the structure of 

the metal. Remember to include the analysis as part of your LabVIEW, 

LabWindows/CVI, or Visual Basic solution. You also can use Microsoft 

Excel to analyze the data generated by IMAQ Vision Builder.

Tip To send the data to Microsoft Excel, click the Send Data to Excel button in the 

Particle Analysis results window.

Testing the Blob Analysis Script
The script that you created as you processed this image is a custom 

algorithm. To test this algorithm, run it on another image in the collection 

using the following steps:

1. Click the Image Browser button in the Standard toolbar.

2. Double click the third image, Metal3.jpg.
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Tip Rather than returning to the Image Browser, you can navigate through the images in 

the Image Browser from the Reference window. Click the next and back buttons until you 

see the image you want to process and then click the Make Image Active button to move 

that image into the Processing window.

3. Click the Run Script button. 

Figure 3-6 shows the original image, Metal3.jpg, on the left and the 

image after the blob analysis processing on the right. Notice that two 

circular blobs are removed from the image during processing because 

they are touching each other. To separate particles from each other, you 

can adjust the thresholding step.

Figure 3-6.  Comparing the Original Image to the Processed Image

4. Click Done to close the Particle Analysis window.

5. Double click the Threshold step in the script window to open the 

threshold parameters. Figure 3-7 shows Metal3.jpg at the 

thresholding step of the script.

Original Image (Metal3.jpg)

Overlapping
Circular Blobs

Image after Processing
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Figure 3-7.  Testing the Blob Analysis Script

6. Adjust the minimum threshold value until the blobs are clearly 

separated. A minimum value of 150 works well.

7. Click Replace.

8. Click the Run Script button to rerun the script. Notice that only the 

circular blobs now appear in the final processed image.

9. Click Done to close the Particle Analysis window.
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Saving the Blob Analysis Script
Now that you have written a blob analysis algorithm and tested it on 

another image, you can save the script to use on similar images. You also 

can perform batch processing with this script. See the Analyzing a 

Collection of Images with Batch Processing section in Chapter 4, Using 

Gauging for Part Inspection, for an example of batch processing in IMAQ 

Vision Builder.

1. Select Script»Save Script.

2. Save the script as blob analysis.scr.

Estimating Processing Time
IMAQ Vision Builder can estimate the time, in milliseconds, that IMAQ 

Vision will take to process the active image with the open script. The 

Performance Meter gives both an estimate of the total time IMAQ Vision 

will take to process the image and an estimate of the time each function 

within the script will require. Follow these steps to estimate how many 

milliseconds IMAQ Vision will use to process Metal3.jpg with 

blob analysis.scr:

1. Select Script»Performance Meter. The Performance Meter gives an 

estimate of the total time IMAQ Vision will take to run the script.

2. Click Expand to view an itemized list of the time IMAQ Vision will 

take to perform each function in the script.

3. Click OK to close the Performance Meter.

Implementing the Algorithm in LabVIEW
You have prototyped, tested, and refined an IMAQ Vision processing 

algorithm. Now you can use that script to implement the algorithm in 

development environments such as LabVIEW, LabWindows/CVI, and 

Visual Basic using the IMAQ Vision library. Follow these steps to 

implement the blob analysis algorithm in LabVIEW:

1. Select Script»Builder File. The Builder Information window lists 

all of the processing steps and the parameters for each.

2. Select File»Save.

3. Save the file as blob analysis.txt.

4. Close the Builder Information window.

5. Use File»Exit to close IMAQ Vision Builder.

6. Open the file in a text editor or word processor and print the file.
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7. Launch LabVIEW and use the step descriptions to build the blob 

analysis block diagram with IMAQ Vision VIs. The block diagram 

should look similar to Figure 3-8.

Figure 3-8.  Blob Analysis Block Diagram
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4
Using Gauging 
for Part Inspection

This chapter describes gauging and provides step-by-step directions for 

completing a part inspection tutorial in IMAQ Vision Builder.

What Is Gauging?

Components such as connectors, switches, and relays are small and 

manufactured in high quantity. Human inspection of these components is 

tedious and time consuming. Vision systems can quickly and consistently 

measure certain features on a component and generate a report with the 

results. From the results, you can determine whether a part meets its 

specifications.

Gauging consists of making critical distance measurements—such as 

lengths, diameters, angles, and counts—to determine if the product is 

manufactured correctly. If the gauged distance or count does not fall within 

tolerance limits, the component or part does not meet specifications and 

should be rejected. Gauging inspection is used often in mechanical 

assembly verification, electronic packaging inspection, container 

inspection, glass vile inspection, and electronic connector inspection.

Tutorial

In this tutorial, you analyze images of pipe brackets to see if the brackets 

meet their physical specifications. A pipe bracket is a metal piece of 

hardware used to bolt down long, slender parts, such as a tube of bundled 

wires.

Your goal is to measure angles and distances between features on the 

brackets and determine if those measurements fall within a tolerance range. 

Figure 4-1 illustrates the measurements and the acceptable values for those 

measurements.
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Figure 4-1.  Bracket Specifications

Width Center is the center of the bracket’s width. Width Center will become 

the vertex of Bracket Angle. Bracket Distance measures the length in pixels 

between two manufactured holes in the bracket. Bracket Distance 

determines whether the bracket’s arch is the appropriate height and 

curvature. Bracket Angle measures the angle of the arms of the bracket and 

determines if the bracket’s arms are aligned properly.

As you perform this analysis, IMAQ Vision Builder records all of the 

processing operations and parameters in a script. You will run that script on 

other bracket images to determine which are good and which are defective.

1 2
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Edge 1

Edge 2

Bracket Distance
362 to 368 pixels

Top View

Side View

Bracket Angle
178 to 181 degrees Width Center
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Loading Images into IMAQ Vision Builder
Perform the following steps to load an image:

1. Launch IMAQ Vision Builder from the Start menu 

(Start»Programs»National Instruments IMAQ Vision 

Builder»IMAQ Vision Builder).

2. Select File»Open Image to load images.

3. Navigate to Program Files\National Instruments\IMAQ 

Vision Builder\Examples\Bracket and check the Select All 

Files option. IMAQ Vision Builder previews the images in the Preview 

Image window and displays information about the file format and size 

and pixel depth.

Tip The Preview Image window displays all selected images in a sequence. To view 

the images at a different rate, adjust the slide to the right of the Preview Image window.

4. Click OK to load the image files into IMAQ Vision Builder. From this 

collection of images in the Image Browser, you can select the image 

that you want to process. 

5. Double click the first image, Bracket1.jpg, to load it into the 

processing window.

Finding Measurement Points Using Pattern Matching
Before you can compute the measurements, you need to locate features on 

which you can base the measurements. In this example, you will use pattern 

matching to find manufactured holes in a bracket. These holes will serve as 

points of measurement from which you will determine whether the 

bracket’s arch is the appropriate height and curvature.

1. Select Grayscale»Pattern Matching. Make sure the Learn Template 

tab is selected.

2. With the Rectangle Tool, click and drag a box around the left hole in 

the image, as shown in Figure 4-2. The selected area, or region of 

interest (ROI), will become the template pattern.
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Figure 4-2.  Selecting a Template Pattern

3. Click Create from ROI to learn the selected area as the template 

pattern. This will take a few seconds. After IMAQ Vision Builder 

learns the template, a save dialog box appears.

4. Navigate to Program Files\National Instruments\IMAQ 

Vision Builder\Examples\Bracket.

5. Save the template as template.png. The Pattern Matching parameter 

window displays the template image and its path.

6. Select the Search Template tab.

7. Set Search Mode to Shift Invariant. Use shift-invariant matching when 

you do not expect the matches you locate to be rotated in their images. 

If you expect your matches to be rotated, use rotation-invariant 

matching. 

8. Uncheck the Sub-Pixel Accuracy checkbox.

9. Set the Minimum Score to 600. A minimum score of 600 ensures that 

IMAQ Vision Builder will find matches similar, but not identical, to 

the template.

10. Set Number of Matches to 1.

11. With the Rectangle Tool, draw an ROI around the left side of the 

bracket, as shown in Figure 4-3. Be sure that the region you draw is 

larger than the template image and big enough to encompass all 

possible locations of the template in the other images you will analyze.

Drawing a region of interest in which you expect to locate a template 

match is a significant step in pattern matching. It reduces the risk of 

finding a mismatch. It also allows you to specify the order in which you 

want to locate multiple instances of a template in an image.
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Figure 4-3.  Selecting the First Search Area

Once you draw the region of interest, IMAQ Vision Builder 

automatically locates the template in the region and displays the score 

and location of the match. Notice that the score for the match is 1000. 

The score for this match is perfect because you made the template from 

the same region of the image.

12. Click Apply to add this step to the script.

13. With the Rectangle Tool, draw a region of interest around the right 

side of the bracket, as shown in Figure 4-4. IMAQ Vision Builder 

automatically locates the template in the region bound by the rectangle 

and displays the score and location of the match.

Figure 4-4.  Selecting the Second Search Area

The score of the second match is not a perfect 1000, but it is high 

enough for you to consider it a match to the template.

14. Click Apply to add this step to the script.

15. Click Close.
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Finding Edges in the Image
Before you can compute measurements to determine whether a bracket 

meets specifications, you need to detect edges on which you can base the 

measurements. The Edge Detector finds edges along a line that you draw 

with the Line Tool from the Tools palette.

1. Select Grayscale»Edge Detector.

2. Select the Simple Edge Tool. The Simple Edge Tool is effective on 

images with sharp contrast between the background and objects.

3. Select First & Last Edge so that IMAQ Vision Builder finds and 

labels only the first and last edges along the line you draw.

4. Select Absolute Value. Absolute Value indicates that you want to use 

pixel values to specify the threshold level. Relative Value indicates 

that you are specifying the threshold level as a percentage.

5. Set Threshold Level to 128. The threshold level specifies the 

difference in pixel values that you expect to constitute an edge in the 

image. Absolute detection considers a threshold level of 128 or greater 

as an edge.

6. Click and drag to draw a vertical line across the middle of the bracket 

to find the edges that you will use to calculate Width Center, as shown 

in Figure 4-5. IMAQ Vision Builder labels the edges 1and 2.

Tip To draw a straight line, press and hold the <Shift> key as you draw the line.

Figure 4-5.  Finding the Edges for Bracket Distance

Look at the line profile. The sharp transitions in the line profile indicate 

edges. Notice that the number of edges found is displayed under the 

line profile.

7. Click Apply to add this edge detection step to the script.

8. Click Close to close the Edge Detector window.
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Making the Measurements
Now that you have found the bracket’s holes and the necessary edges, you 

can calculate the center of the bracket’s width, distance between the 

bracket’s holes, and angle of the bracket’s arms with the Caliper function. 

The Caliper function is a tool that uses points on the image to calculate 

measurements, such as distances, angles, the center of a segment, or the 

area, depending on the number of points you have selected on the image. 

These points are results of earlier processing steps, such as edge detections 

and pattern matching.

Follow these steps to make the measurements:

1. Select Grayscale»Caliper.

2. In the image, click on points 3 and 4 to obtain the first 

measurement—Width Center, which specifies the center of the 

bracket’s width.

Tip If you have trouble finding the points, click the Zoom In tool in the Tools palette to 

magnify the image. Magnification factors are displayed in the lower, left corner of the 

processing window. 1/1 specifies 100% magnification (default). 2/1 specifies a slightly 

magnified view, and 1/2 specifies a slightly demagnified view.

Tip Instead of clicking on the points in the image, you can double click on the points in 

the Points list box to select them. When you select a point, IMAQ Vision Builder places a 

check mark next to it.

3. Select Center from the Type of Measure list.

4. Click the Measure button to compute the center of the bracket’s width 

and add the Width Center measurement to the results table, as shown 

in Figure 4-6.
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Figure 4-6.  Using the Caliper Function to Find Width Center

5. Click Apply to add this step to the script.

6. Select Grayscale»Caliper again. The center of the bracket’s width 

appears as point 5.

7. Click on points 1 and 2 in the image to find the second 

measurement—Bracket Distance, which measures the length between 

the manufactured holes in the bracket and determines whether the 

bracket’s arch is the appropriate height.

8. Select Distance from the Type of Measure list.

9. Click the Measure button to compute the distance between the 

bracket’s holes and add the measurement to the results table.

10. Click on points 1, 5, and 2 (in that order) to find the third 

measurement—Bracket Angle, which measures the angle of the 

bracket’s arms with respect to a vertex at point 5, as shown in 

Figure 4-7.

11. Select Angle from the Type of Measure list.
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12. Click the Measure button to compute the angle of the bracket’s arms 

and add the measurement to the results table.

Figure 4-7 shows the image with Bracket Distance and Bracket Angle 

selected on the image and displayed in the results table.

Figure 4-7.  Using the Caliper Tool to Collect Measurements

13. Click Apply to add these caliper measurements to the script and close 

the Caliper window.

14. Select Script»Save Script and save the script as bracket.scr.
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Analyzing a Collection of Images with Batch Processing
Perform the following steps to run the script as a batch process on 

the bracket images and generate a text file containing all of the 

measurement data:

1. Select Script»Batch Processing.

2. Select Browser from Image Source to process the images stored in the 

Image Browser.

The listbox contains all of the steps in the script. You can select any step in 

the script and choose options, such as saving that step’s results to file, 

displaying results, or opening the parameter window to adjust the settings 

on each iteration. For this example, open the Caliper parameter window and 

save the caliper results to a file.

3. Select the last Caliper entry in the list box.

4. Check Open Results Panel and Save Results under Analysis Mode.

5. Click the Setup button and set the following options:

a. Select One file for all results.

b. Press the Browse button, navigate to the directory where you want 

the file saved, and click Select Cur Dir.

c. In the File Name Prefix box, type bracket.txt to give the 

results files a consistent name.

6. Click OK to close the Setup options.

7. Click Run! to start the batch process.

As batch processing runs, a progress window appears on the left side 

of the IMAQ Vision Builder window. The progress window displays 

the current process (acquiring an image or processing an image), the 

number of times the process has been completed, the starting time, and 

an estimation of the time remaining. If you ever need to stop a batch 

process, click the Cancel button.

Note Because you checked Open Results Panel when setting up the batch processing 

parameters, you must click the Done button after the script runs on each image.

8. When the batch processing completes, click OK.

9. Click Return to exit the Batch Processing window.

The bracket images have been processed and the caliper results stored in a 

text file.
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Analyzing the Results
As you implement this algorithm in your development environment using 

the Builder file, remember to include your analysis. For this example, you 

can use Excel to quickly analyze the results.

Note To complete this part of the tutorial, you must have Microsoft Excel 97 or higher 

installed on your computer.

1. Launch Microsoft Excel.

2. Open bracket.txt from within Excel to view the results.

The results are labeled and listed in the order in which they appear in the 

Image Browser. In this case, images are listed from Bracket1.jpg to 

Bracket6.jpg.

Table 4-1 lists the acceptable ranges for the bracket measurements and the 

actual values you might see for the bracket images. Notice that Bracket1, 

Bracket2, and Bracket3 are the only ones that meet the specifications. 

The bold values for the other brackets indicate which measurements caused 

them to fail.

Note The values you see may not match the values in Table 4-1 exactly. However, the 

values you obtain should be close enough to the values in Table 4-1 so that Bracket1, 

Bracket2, and Bracket3 pass inspection, and Bracket4, Bracket5, and Bracket6 

do not pass.

Table 4-1.  Bracket Measurement Results

Bracket 

Number

Bracket Distance

(acceptable range: 362–368 pixels)

Bracket Angle

(acceptable range: 178°°°°–181°°°°)

Bracket 1 363.00 179.8

Bracket 2 364.00 180.3

Bracket 3 363.00 179.7

Bracket 4 349.00 178.5

Bracket 5 339.01 178.4

Bracket 6 359.03 174.8
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A
Technical Support Resources

This appendix describes the comprehensive resources available to you in 

the Technical Support section of the National Instruments Web site and 

provides technical support telephone numbers for you to use if you have 

trouble connecting to our Web site or if you do not have internet access.

NI Web Support

To provide you with immediate answers and solutions 24 hours a day, 

365 days a year, National Instruments maintains extensive online technical 

support resources. They are available to you at no cost, are updated daily, 

and can be found in the Technical Support section of our Web site at 

www.ni.com/support.

Online Problem-Solving and Diagnostic Resources
• KnowledgeBase—A searchable database containing thousands of 

frequently asked questions (FAQs) and their corresponding answers or 

solutions, including special sections devoted to our newest products. 

The database is updated daily in response to new customer experiences 

and feedback.

• Troubleshooting Wizards—Step-by-step guides lead you through 

common problems and answer questions about our entire product line. 

Wizards include screen shots that illustrate the steps being described 

and provide detailed information ranging from simple getting started 

instructions to advanced topics.

• Product Manuals—A comprehensive, searchable library of the latest 

editions of National Instruments hardware and software product 

manuals.

• Hardware Reference Database—A searchable database containing 

brief hardware descriptions, mechanical drawings, and helpful images 

of jumper settings and connector pinouts.

• Application Notes—A library with more than 100 short papers 

addressing specific topics such as creating and calling DLLs, 

developing your own instrument driver software, and porting 

applications between platforms and operating systems.



Appendix A Technical Support Resources

IMAQ Vision Builder Tutorial A-2 www.ni.com

Software-Related Resources
• Instrument Driver Network—A library with hundreds of instrument 

drivers for control of standalone instruments via GPIB, VXI, or serial 

interfaces. You also can submit a request for a particular instrument 

driver if it does not already appear in the library.

• Example Programs Database—A database with numerous, 

non-shipping example programs for National Instruments 

programming environments. You can use them to complement the 

example programs that are already included with National Instruments 

products.

• Software Library—A library with updates and patches to application 

software, links to the latest versions of driver software for National 

Instruments hardware products, and utility routines.

Worldwide Support

National Instruments has offices located around the globe. Many branch 

offices maintain a Web site to provide information on local services. You 

can access these Web sites from www.ni.com/worldwide.

If you have trouble connecting to our Web site, please contact your local 

National Instruments office or the source from which you purchased your 

National Instruments product(s) to obtain support.

For telephone support in the United States, dial 512 795 8248. For 

telephone support outside the United States, contact your local branch 

office:

Australia 03 9879 5166, Austria 0662 45 79 90 0, Belgium 02 757 00 20, 

Brazil 011 284 5011, Canada (Ontario) 905 785 0085, 

Canada (Québec) 514 694 8521, China 0755 3904939, 

Denmark 45 76 26 00, Finland 09 725 725 11, France 01 48 14 24 24, 

Germany 089 741 31 30, Hong Kong 2645 3186, India 91805275406, 

Israel 03 6120092, Italy 02 413091, Japan 03 5472 2970, 

Korea 02 596 7456, Mexico (D.F.) 5 280 7625, 

Mexico (Monterrey) 8 357 7695, Netherlands 0348 433466, 

Norway 32 27 73 00, Singapore 2265886, Spain (Madrid) 91 640 0085, 

Spain (Barcelona) 93 582 0251, Sweden 08 587 895 00, 

Switzerland 056 200 51 51, Taiwan 02 2377 1200, 

United Kingdom 01635 523545
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Glossary

Prefix Meaning Value

p- pico- 10–12

n- nano- 10–9

µ- micro- 10– 6

m- milli- 10–3

k- kilo- 103

M- mega- 106

G- giga- 109

t- tera- 1012

Numbers

1D One-dimensional.

2D Two-dimensional.

3D Three-dimensional.

3D view Displays the light intensity of an image in a three-dimensional coordinate 

system, where the spatial coordinates of the image form two dimensions 

and the light intensity forms the third dimension.

A

AIPD National Instruments internal image format used for saving all image 

types and for saving calibration information associated with the image 

(extension .APD).

alpha channel Channel used to code extra information, such as gamma correction, about a 

color image. The alpha channel is stored as the first byte in the four-byte 

representation of an RGB pixel.
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area threshold Detects objects based on their size, which can fall within a user-specified 

range.

arithmetic operators The image operations multiply, divide, add, subtract, and remainder.

auto-median function A function that uses dual combinations of opening and closing operations 

to smooth the boundaries of objects.

B

binary image An image containing objects usually represented with a pixel intensity 

of 1 (or 255) and the background of 0.

binary morphology Functions that perform morphological operations on a binary image.

bit depth The number of bits (n) used to encode the value of a pixel. For a given n, a 

pixel can take 2n different values. For example, if n equals 8-bits, a pixel 

can take 256 different values ranging from 0 to 255. If n equals 16 bits, a 

pixel can take 65,536 different values ranging from 0 to 65,535 or –32,768 

to 32,767. 

blob Binary large object. A connected region or grouping of pixels in an image 

in which all pixels have the same intensity level.

blob analysis A series of processing operations and analysis functions that produce some 

information about the blobs in an image.

BMP Bitmap. Image file format commonly used for 8-bit and color images 

(extension .BMP).

border function Removes objects (or particles) in a binary image that touch the image 

border.

Builder file IMAQ Vision Builder script file. Builder files are ASCII text files that list 

the processing functions and relevant parameters for an image processing 

algorithm that you created in IMAQ Vision Builder. 
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C

caliper (1) A function in IMAQ Vision Builder that calculates distances, angles, 

circular fits, and the center of mass based on positions given by edge 

detection, particle analysis, centroid, and search functions;

(2) A measurement function that finds edge pairs along a specified path in 

the image. This function performs an edge extraction and then finds edge 

pairs based on specified criteria such as the distance between the leading 

and trailing edges, edge contrasts, and so forth.

circle function Detects circular objects in a binary image.

closing A dilation followed by an erosion. A closing fills small holes in objects 

and smooths the boundaries of objects.

color images Images containing color information, usually encoded in the RGB form.

CLUT Color look-up table. Table for converting the value of a pixel in an image 

into a red, green, and blue (RGB) intensity.

complex images Save information obtained from the FFT of an image. The complex 

numbers which compose the FFT plane are encoded in 64-bit floating-point 

values: 32 bits for the real part and 32 bits for the imaginary part. 

connectivity Defines which of the surrounding pixels of a given pixel constitute its 

neighborhood.

connectivity-4 Only pixels adjacent in the horizontal and vertical directions are considered 

neighbors.

connectivity-8 All adjacent pixels are considered as neighbors.

convex function Computes the convex regions of objects in a binary image.

convolution See linear filter.

convolution kernel Simple 3 × 3, 5 × 5, or 7 × 7 matrices (or templates) used to represent the 

filter in the filtering process. The contents of these kernels are a discrete 

two-dimensional representation of the impulse response of the filter that 

they represent.
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D

Danielsson function Similar to the distance functions, but with more accurate results.

definition The number of values a pixel can take on, which is the number of colors or 

shades that you can see in the image.

density function For each gray level in a linear histogram, it gives the number of pixels in 

the image that have the same gray level. 

device Plug-in data acquisition board that can contain multiple channels and 

conversion devices.

differentiation filter Extracts the contours (edge detection) in gray level.

dilation Increases the size of an object along its boundary and removes tiny holes in 

the object.

distance calibration Determination of the physical dimensions of a pixel by defining the 

physical dimensions of a line in the image.

distance function Assigns to each pixel in an object a gray-level value equal to its shortest 

Euclidean distance from the border of the object.

driver Software that controls a specific hardware device, such as a data acquisition 

board.

E

edge Defined by a sharp change (transition) in the pixel intensities in an image 

or along an array of pixels.

edge contrast The difference between the average pixel intensity before and the average 

pixel intensity after the edge.

edge hysteresis The difference in threshold level between a rising and a falling edge.

edge steepness The number of pixels that corresponds to the slope or transition area of 

an edge.

Euclidean distance The shortest distance between two points in a cartesian system.

equalize function See histogram equalization.
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erosion Reduces the size of an object along its boundary and eliminates isolated 

points in the image. 

exponential and 

gamma corrections

Expand the high gray-level information in an image while suppressing low 

gray-level information.

exponential function Decreases the brightness and increases the contrast in bright regions of an 

image, and decreases contrast in dark regions.

F

FFT Fast Fourier Transform. A method used to compute the Fourier transform 

of an image.

fiducial A reference pattern on a part that helps a machine vision application find 

the part’s location and orientation in an image.

Fourier spectrum The magnitude information of the Fourier transform of an image.

Fourier transform Transforms an image from the spatial domain to the frequency domain.

frequency filters Counterparts of spatial filters in the frequency domain. For images, 

frequency information is in the form of spatial frequency. 

G

Gaussian filter A filter similar to the smoothing filter, but using a Gaussian kernel in the 

filter operation. The blurring in a Gaussian filter is more gentle than a 

smoothing filter.

grab Acquisition technique that acquires and displays a continuous sequence of 

images using an IMAQ device. Use this acquisition technique when you 

need to focus your camera.

gradient convolution 

filter

See gradient filter.

gradient filter Extracts the contours (edge detection) in gray-level values. Gradient filters 

include the Prewitt and Sobel filters.

gray level The brightness of a point (pixel) in an image.
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gray-level dilation Increases the brightness of pixels in an image that are surrounded by other 

pixels with a higher intensity.

gray-level erosion Reduces the brightness of pixels in an image that are surrounded by other 

pixels with a lower intensity.

gray-level images Images with monochrome information.

gray-level morphology Functions that perform morphological operations on a gray-level image.

grayscale The range of shades of black in an image.

H

highpass attenuation Inverse of lowpass attenuation.

highpass FFT filter Removes or attenuates low frequencies present in the FFT domain of an 

image.

highpass filter Emphasizes the intensity variations in an image, detects edges (or object 

boundaries), and enhances fine details in an image.

highpass frequency 

filter

Attenuates or removes (truncates) low frequencies present in the frequency 

domain of the image. A highpass frequency filter suppresses information 

related to slow variations of light intensities in the spatial image.

highpass truncation Inverse of lowpass truncations.

histogram Indicates the quantitative distribution of the pixels of an image per 

gray-level value.

histogram equalization Transforms the gray-level values of the pixels of an image to occupy the 

entire range (0 to 255 in an 8-bit image) of the histogram, increasing the 

contrast of the image.

hole filling function Fills all holes in objects that are present in a binary image.

HSI Color encoding scheme in Hue, Saturation, and Intensity.

HSL A color space where a color image is represented as hue, saturation, and 

luminance.

HSV A color space where a color image is represented as hue, saturation, and 

value.
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I

image A two-dimensional light intensity function f (x, y) where x and y denote 

spatial coordinates and the value f at any point (x, y) is proportional to the 

brightness at that point.

Image Browser IMAQ Vision Builder feature that displays all of the images currently 

loaded. Through the Image Browser, you can select an image that you want 

to process by double clicking it.

image buffer Memory location used to store images.

image file A file containing image information and data.

image palette The gradation of colors used to display an image on screen, usually defined 

by a color look-up table.

image processing Encompasses various processes and analysis functions which you can 

apply to an image.

image source Original input image.

image visualization The presentation (display) of an image (image data) to the user.

inner gradient Finds the inner boundary of objects.

inspection function Detects specific features in an image. The features detected include edges, 

peaks, and rotational shifts.

intensity range Defines the range of gray-level values in an object of an image.

intensity threshold Characterizes an object based on the range of gray-level values in the 

object. If the intensity range of the object falls within the user specified 

range, it is considered an object; otherwise it is considered part of the 

background.

interpolation Is the technique used to find values in between known values when 

resampling an image or array of pixels.

J

JPEG Joint Photographic Experts Group. Image file format for storing 8-bit and 

color images with lossy compression (extension .JPG).
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K

kernel Structure that represents a pixel and its relationship to its neighbors. The 

relationship is specified by weighted coefficients of each neighbor.

L

labeling The process by which each object in a binary image is assigned a unique 

value. This process is useful for identifying the number of objects in the 

image and giving each object a unique identity. 

LabVIEW Laboratory Virtual Instrument Engineering Workbench. Program 

development environment application based on the programming language 

G used commonly for test and measurement applications.

Laplacian filter Extracts the contours of objects in the image by highlighting the variation 

of light intensity surrounding a pixel.

line profile Represents the gray-level distribution along a line of pixels in an image.

linear filter A special algorithm that calculates the value of a pixel based on its own 

pixel value as well as the pixel values of its neighbors. The sum of this 

calculation is divided by the sum of the elements in the matrix to obtain a 

new pixel value.

logarithmic and inverse 

gamma corrections

Expand low gray-level information in an image while compressing 

information from the high gray-level ranges.

logarithmic function Increases the brightness and contrast in dark regions of an image, and 

decreases the contrast in bright regions of the image.

logic operators The image operations AND, NAND, OR, XOR, NOR, difference, mask, 

mean, max, and min.

lowpass attenuation Applies a linear attenuation to the frequencies in an image, with no 

attenuation at the lowest frequency and full attenuation at the highest 

frequency.

lowpass FFT filter Removes or attenuates high frequencies present in the FFT domain of an 

image.

lowpass filter Attenuates intensity variations in an image. You can use these filters to 

smooth an image by eliminating fine details and blurring edges.
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lowpass frequency 

filter

Attenuates high frequencies present in the frequency domain of the image. 

A lowpass frequency filter suppresses information related to fast variations 

of light intensities in the spatial image.

lowpass truncation Removes all frequency information above a certain frequency.

L-skeleton function Uses an L-shaped structuring element in the skeleton function.

LUT Look-up table. Table containing values used to transform the gray-level 

values of an image. For each gray-level value in the image, the 

corresponding new value is obtained from the look-up table.

M

mask Isolates parts of an image for further processing.

mask image An image containing a value of 1 and values of 0. Pixels in the source image 

with a corresponding mask image value of 1 are processed, while the others 

are left unchanged.

median filter A lowpass filter that assigns to each pixel the median value of its neighbors. 

This filter effectively removes isolated pixels without blurring the contours 

of objects.

morphological

transformations

Extract and alter the structure of objects in an image. You can use these 

transformations for expanding (dilating) or reducing (eroding) objects, 

filling holes, closing inclusions, or smoothing borders. They mainly are 

used to delineate objects and prepare them for quantitative inspection 

analysis.

M-skeleton function Uses an M-shaped structuring element in the skeleton function.

N

neighborhood 

operations

Operations on a point in an image that take into consideration the values of 

the pixels neighboring that point.

nonlinear filter Replaces each pixel value with a nonlinear function of its surrounding 

pixels.

nonlinear gradient filter A highpass edge-extraction filter that favors vertical edges.
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nonlinear Prewitt filter A highpass edge-extraction filter that favors horizontal and vertical edges 

in an image.

nonlinear Sobel filter A highpass edge-extraction filter that favors horizontal and vertical edges 

in an image.

Nth order filter Filters an image using a nonlinear filter. This filter orders (or classifies) 

the pixel values surrounding the pixel being processed. The pixel being 

processed is set to the Nth pixel value, where N is the order of the filter.

number of planes 

(in an image)

The number of arrays of pixels that compose the image. A gray-level or 

pseudo-color image is composed of one plane, while an RGB image is 

composed of three planes (one for the red component, one for the blue, 

and one for the green).

O

opening An erosion followed by a dilation. An opening removes small objects and 

smoothes boundaries of objects in the image.

operators Allow masking, combination, and comparison of images. You can use 

arithmetic and logic operators in IMAQ Vision.

outer gradient Finds the outer boundary of objects.

P

palette The gradation of colors used to display an image on screen, usually defined 

by a color look-up table.

Parameter window Displays parameters that you can set for an image processing function. 

Each IMAQ Vision function available through the menus has a parameter 

window where you set the parameters for that function. 

pattern matching The technique used to locate quickly a grayscale template within a 

grayscale image

picture element An element of a digital image. Also called pixel.

pixel Picture element. The smallest division that makes up the video scan line; 

for display on a computer monitor, a pixel’s optimum dimension is square 

(aspect ratio of 1:1, or the width equal to the height).
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pixel calibration Directly calibrating the physical dimensions of a pixel in an image.

PNG Portable Network Graphic. An image file format for storing 8-bit, 16-bit, 

and color images with lossless compression (extension .PNG).

Power 1/Y function Similar to a logarithmic function but with a weaker effect.

Power Y function See exponential function.

Prewitt filter Extracts the contours (edge detection) in gray-level values using a 3 × 3 

filter kernel.

probability function Defines the probability that a pixel in an image has a certain gray-level 

value.

Processing window IMAQ Vision Builder feature that updates the image as you change 

parameters. The Processing window is located on the right side of the 

IMAQ Vision Builder window.

proper-closing A finite combination of successive closing and opening operations that you 

can use to fill small holes and smooth the boundaries of objects.

proper-opening A finite combination of successive opening and closing operations that you 

can use to remove small particles and smooth the boundaries of objects.

Q

quantitative analysis Obtaining various measurements of objects in an image.

R

Reference window IMAQ Vision Builder feature that displays the original version of the image 

(image source) as you manipulate it in the processing window. The 

Reference window appears in the upper left corner of the IMAQ Vision 

Builder window.

resolution The number of rows and columns of pixels. An image composed of m rows 

and n columns has a resolution of . This image has n pixels along its 

horizontal axis and m pixels along its vertical axis.

reverse function Inverts the pixel values in an image, producing a photometric negative of 

the image.

m n×
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RGB Color encoding scheme using red, green, and blue (RGB) color information 

where each pixel in the color image is encoded using 32 bits: 8 bits for red, 

8 bits for green, 8 bits for blue, and 8 bits for the alpha value (unused).

Roberts filter Extracts the contours (edge detection) in gray level, favoring diagonal 

edges.

ROI Region of interest. An area of the image that is graphically selected from a 

window displaying the image. This area can be used to focus further 

processing.

ROI tools Collection of tools from the Tools palette that enable you to select a region 

of interest from an image. These tools let you select a point or line; 

polygon, rectangle, and oval regions; and freehand lines and areas.

rotation-invariant 

pattern matching

A pattern matching technique in which the reference pattern can be located 

anywhere in the test image as well as rotated at any degree.

S

script List of image processing and analysis functions and the parameters for each 

of those functions. IMAQ Vision Builder records each function and relevant 

parameters as you prototype your image processing application.

Script window The window in which IMAQ Vision Builder displays a script. From the 

scripting window, you can edit, remove, or add steps and run scripts. The 

Script window appears in the lower left corner of the IMAQ Vision Builder 

window.

segmentation function Fully partitions a labeled binary image into non-overlapping segments, 

with each segment containing a unique object.

separation function Separates objects that touch each other by narrow isthmuses.

sequence Acquisition technique that acquires images according to settings that you 

specify in the acquisition property pages.

shape matching Finds objects in an image whose shape matches the shape of the object 

specified by a shape template. The matching process is invariant to rotation 

and can be set to be invariant to the scale of the objects.

shift-invariant matching A pattern matching technique in which the reference pattern can be located 

anywhere in the test image but cannot be rotated or scaled.
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Sigma filter A highpass filter that outlines edges.

skeleton function Applies a succession of thinning operations to an object until its width 

becomes one pixel.

skiz function Obtains lines in an image that separate each object from the others and are 

equidistant from the objects that they separate.

smoothing filter Blurs an image by attenuating variations of light intensity in the 

neighborhood of a pixel.

snap Acquisition technique that acquires and displays a single image.

Sobel filter Extracts the contours (edge detection) in gray-level values using a 

3 × 3 filter kernel.

spatial calibration Assigning physical dimensions to the area of a pixel in an image.

spatial filters Alter the intensity of a pixel with respect to variations in intensities of its 

neighboring pixels. You can use these filters for edge detection, image 

enhancement, noise reduction, smoothing, and so forth.

spatial resolution The number of pixels in an image, in terms of the number of rows and 

columns in the image.

square function See exponential function.

square root function See logarithmic function.

structuring element A binary mask used in most morphological operations. A structuring 

element is used to determine which neighboring pixels contribute in the 

operation.

sub-pixel analysis Used to find the location of the edge coordinates in terms of fractions of a 

pixel.
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T

template Color, shape, or pattern that you are trying to match in an image using the 

color matching. shape matching, or pattern matching functions. A template 

can be a region selected from an image or it can be an entire image.

thickening Alters the shape of objects by adding parts to the object that match the 

pattern specified in the structuring element.

thinning Alters the shape of objects by eliminating parts of the object that match 

the pattern specified in the structuring element.

threshold Separates objects from the background by assigning all pixels with 

intensities within a specified range to the object and the rest of the pixels 

to the background. In the resulting binary image, objects are represented 

with a pixel intensity of 255 and the background is set to 0.

threshold interval Two parameters, the lower threshold gray-level value and the upper 

threshold gray-level value.

TIFF Tagged Image File Format. Tagged Image File Format. Image 

format commonly used for encoding 8-bit, 16-bit, and color images 

(extension .TIF).

Tools palette Collection of tools that enable you to select regions of interest, zoom in 

and out, and change the image palette.

trigger Any event that causes or starts some form of data capture.
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Index

Numerics
3D View function, 1-4

A
absolute value (threshold), 4-6

acquiring images

grab (continuous image), 2-11

opening the Interface window, 2-9, 3-2

property pages, 2-10

region of interest, 2-11

sequence, 2-12

snap (single image), 2-11

in StillColor, 2-10

Acquisition window, 1-3

opening, 2-9 to 2-11

analyzing blobs, 3-9

B
batch processing, 1-3, 4-10

batch processing for analyzing image 

collection, 4-10

blob, 3-1

blob analysis

analyzing circular blobs, 3-9

definition, 3-1

estimating processing time, 3-12

examining image, 3-3 to 3-4

filtering, 3-4

implementing in LabVIEW, 3-12 to 3-13

implementing algorithm in LabVIEW, 

3-12 to 3-13

introduction, 3-1

isolating circular blobs, 3-8

modifying blobs with morphological 

functions, 3-7

morphology, 3-7

opening images, 3-2

overview, 3-1

particle analysis, 3-9

particle filter, 3-8

preparing images for processing, 3-2 to 3-4

saving the script, 3-12

separating particles from background, 

3-5 to 3-6

testing the script, 3-9 to 3-11

thresholding, 3-5 to 3-6

Browser

See Image Browser.

Builder file, 1-3, 3-12, 4-11

C
Caliper function, 1-5, 4-7 to 4-9

Choose Measurements button, 3-9

Circle Detection function, 1-5

circular blobs

analyzing, 3-9

isolating, 3-8

closing IMAQ Vision Builder, 1-2

color images, 2-3

complex images, 2-3

continuous acquisition (grabbing images), 

2-11 to 2-12

conventions used in manual, iv

D
diagnostic resources, online, A-1

documentation

conventions used in manual, iv

IMAQ Vision manuals, 1-6
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E
Edge Detector, 1-5, 4-6

edges, finding in image, 4-6

Excel, using with IMAQ Vision Builder, 3-9, 

4-11

exiting IMAQ Vision Builder, 1-2

F
features of IMAQ Vision Builder, 1-3

Fill holes function, 3-7

filtering images, 1-4, 3-4

finding edges, 4-6

full-size view (Image Browser), 2-5

functions

image analysis functions, 1-4

image processing functions, 1-4 to 1-5

machine vision functions, 1-5

morphological functions, 3-7

G
gauging

analyzing results, 4-11

batch processing, 4-10

bracket specifications (figure), 4-2

definition, 4-1

finding edges in image, 4-6

finding measurement points using pattern 

matching, 4-3 to 4-5

introduction, 4-1 to 4-2

loading images, 4-3

making measurements, 4-7 to 4-9

overview, 4-1

storing the original image, 4-7

getting help, 1-5

getting started in IMAQ Vision Builder, 

2-3 to 2-9

grab, 2-9

grabbing an image, 2-11

grabbing images (continuous acquisition), 

2-11 to 2-12

gray-level images, 2-3

H
help

IMAQ Vision Builder scripts, 1-6

IMAQ Vision documentation, 1-6

National Instruments Web site, 1-6

online help, 1-5

Heywood Circularity Factor particle filter, 3-8

histogram, 1-4, 2-6 to 2-7, 3-5

histogram, in Threshold parameter 

window, 2-6

I
image acquisition, 2-9 to 2-12

grabbing images (continuous acquisition), 

2-11 to 2-12

opening Acquisition window, 2-9 to 2-11

sequence of images, 2-12

snapping one image (single 

acquisition), 2-11

image analysis functions, 1-4

Image Browser

accessing from the toolbar, 3-10

definition, 1-3

full-size view, 2-5

important elements (figure), 2-4

thumbnail view, 2-5

image processing

entering processing mode, 2-5

getting started in IMAQ Vision Builder, 

2-3 to 2-9

thresholding images, 2-7 to 2-8

image processing functions, 1-4
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images

color, 2-3

complex, 2-3

definition, 2-1

gray-level, 2-3

loading

for blob analysis, 2-5

for gauging, 4-3

for image processing, 2-4

number of planes, 2-2

opening in IMAQ Vision Builder, 2-4

pixel depth, 2-2

properties, 2-1

resolution, 2-2

spatial reference of (0, 0) pixel 

(figure), 2-1

spatial resolution, 2-2

types, 2-3

IMAQ hardware, 1-1, 2-9

IMAQ Vision Builder

acquiring images, 2-9 to 2-12

environment, 1-3

using with Excel, 3-9

exiting, 1-2

features, 1-3

getting help, 1-5 to 1-6

getting started, 2-3 to 2-9

image analysis functions, 1-4

image processing functions, 1-4

installing, 1-2

using with LabVIEW, 3-9

using with LabWindows/CVI, 3-9

launching, 1-2

machine vision functions, 1-5

online help, 1-5

sending data to Excel, 4-11

system requirements, 1-1

using with LabVIEW, 3-12

using with LabWindows/CVI, 3-12

using with Visual Basic, 3-12, 3-9

IMAQ Vision documentation, 1-6

implementing scripts, 3-12

installing IMAQ Vision Builder, 1-2

Interface window (acquisition), 1-3, 2-10

isolating blobs, 3-8

isolating circular blobs, 3-8

L
LabVIEW, 3-9, 3-12

LabVIEW, implementing blob analysis 

algorithm in, 3-12 to 3-13

LabWindows/CVI, 3-9, 3-12

launching IMAQ Vision Builder, 1-2

line profile, 1-4, 3-3, 4-6

Line Tool, 3-3

loading images

blob analysis, 3-2

gauging, 4-3

image processing, 2-4

M
machine vision functions, 1-5

magnifying an image, 4-7

manuals for IMAQ Vision, 1-6

measurements for gauging.

See gauging

morphology, 1-4, 3-7

N
National Instruments Web site, 1-6

National Instruments Web support, A-1

NI-IMAQ, 1-1, 2-9

number of planes, 2-2



Index

IMAQ Vision Builder Tutorial I-4 www.ni.com

O
online help, 1-5

online problem-solving and diagnostic 

resources, A-1

opening images, 2-4, 3-2, 4-3

P
Parameter window, 1-3

part inspection, 4-1

particle analysis, 1-4, 3-9

particle filter, 1-5, 3-8

particles, separating from background with 

thresholding, 3-5 to 3-6

pattern matching for finding measurement 

points, 4-3 to 4-5

pixel depth, 2-2

planes, number of, 2-2

Preview Image window, 3-2, 4-3

problem-solving and diagnostic resources, 

online, A-1

processing mode, 2-5

Processing window, 1-3, 2-5

R
Reference window

definition, 1-4

purpose, 2-6

using to browse images, 3-10

relative value (threshold), 4-6

Remove border objects function, 3-7

resolution, 2-2

Run Script button, 2-8, 3-10, 3-11

S
scripting

batch processing, 4-10

description, 1-3

using example scripts, 1-6

implementing Builder files, 3-12

modifying scripts, 3-11

opening scripts, 2-8

Run Script button, 2-8, 3-10, 3-11

saving scripts, 2-8, 3-12

Script window, 1-3, 2-8

testing scripts, 3-9

scripts

blob analysis script

implementing in LabVIEW, 

3-12 to 3-13

recording, 3-1

saving, 3-12

testing, 3-9 to 3-11

gauging script

analyzing collection of images, 4-10

saving, 4-9

sample scripts, 1-6

thresholding script, 2-8 to 2-9

search-correlate, 1-5

Select All Files option, 3-2, 4-3

Send Data to Excel button, 3-9

separating particles from background with 

thresholding, 3-5 to 3-6

sequence, 2-9

sequence acquisition, 2-12

sequence of images, acquiring, 2-12

shape matching, 1-5

Show Labels option, 3-9

Simple Edge tool, 4-6

simulation module, 2-11

single acquisition (snapping one image), 2-11

snap, 2-9

snapping one image (single acquisition), 2-11

software-related resources, A-2
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starting IMAQ Vision Builder, 1-2

StillColor acquisition, 2-10

storing an image, 4-7

system requirements, 1-1

T
technical support resources, A-1

telephone support, A-2

testing scripts, 3-9

Three-Dimensional View function, 1-4

Threshold parameter window, 2-6

thresholding

definition, 1-5

manual threshold, 2-6 to 2-7, 3-5 to 3-6

modifying threshold parameters, 

3-10 to 3-11

procedure, 2-7 to 2-8

separating particles from background, 

3-5 to 3-6

threshold levels, 4-6

thumbnail view (Image Browser), 2-5

Tools Palette, 1-4

tutorials

blob analysis, 3-1

gauging, 4-1

V
Visual Basic, 3-9, 3-12

W
Web support from National Instruments

getting help for IMAQ Vision, 1-6

online problem-solving and diagnostic 

resources, A-1

software-related resources, A-2

windows

Acquisition, 1-3

Parameter, 1-3

Processing, 1-3, 2-5

Reference, 1-4, 2-6, 3-10

Script, 1-3, 2-8

worldwide technical support, A-2

Z
Zoom In tool, 4-7
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