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NI Signal Generators Getting Started Guide
このドキュメントには、日本語ページも含まれています。

This document explains how to install, configure, and test National Instruments signal generators for
generating arbitrary and standard function waveforms using National Instruments software.

This document applies to the following devices:
• NI 5402
• NI 5404
• NI 5406
• NI 5412
• NI 5421
• NI 5422
• NI 5441
• NI 5442
• NI 5450
• NI 5451

TheNI Signal Generators Help includes more information about these devices, including signal generator
features and programming.

For free downloads of the most current versions of documentation, visit ni.com/manuals. For the latest
version of NI-FGEN, visit ni.com/idnet.
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Conventions

Angle brackets that contain numbers separated by an ellipsis represent a range
of values associated with a bit or signal name—for example, AO <0..3>.

< >

Square brackets enclose optional items—for example, [response].[ ]

The » symbol leads you through nested menu items and dialog box options to
a final action. The sequence File»Page Setup»Options directs you to pull
down the Filemenu, select the Page Setup item, and selectOptions from the
last dialog box.

»

The indicates that the following text applies only to a specific product, a
specific operating system, or a specific software version.

This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to avoid
injury, data loss, or a system crash.

When symbol is marked on a product, it denotes a warning advising you to
take precautions to avoid electrical shock.

When symbol is marked on a product, it denotes a component that may be hot.
Touching this component may result in bodily injury.

Bold text denotes items that you must select or click in the software, such as
menu items and dialog box options. Bold text also denotes parameter names.

Bold

Italic text denotes variables, emphasis, cross-references, or an introduction to
a key concept. Italic text also denotes text that is a placeholder for a word or
value that you must supply.

italic

Text in this font denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples. This
font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames, and extensions.

monospace

Bold text in this font denotes the messages and responses that the computer
automatically prints to the screen. This font also emphasizes lines of code that
are different from the other examples.

monospace bold

Italic text in this font denotes text that is a placeholder for a word or value that
you must supply.

monospace italic
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Related Documentation
The following table lists resources referenced in this document and describes where to find them. After
you install NI-FGEN, you can access NI-FGEN documentation at Start»All Programs»National
Instruments»NI-FGEN»Documentation. Refer to ni.com/manuals to download the latest versions of
documentation.

Table 1. Related Documentation Descriptions and Locations

Contains information about device-specific content for all NI signal generators,
concepts, detailed VI and function references for the NI-FGEN instrument
driver, fundamentals of waveforms and video signals, and getting started steps
for creating an application with NI-FGEN and your ADE. Located at Start»
All Programs»National Instruments»NI-FGEN»Documentation.

NI Signal Generators Help

Contains detailed information about device performance and specifications.
Located at Start»All Programs»National Instruments»NI-FGEN»
Documentation.

Device Specifications

Contains important information regarding NI-FGEN, such as new features,
supported hardware, system requirements, file locations, and known issues.
Located at Start»All Programs»National Instruments»NI-FGEN»
Documentation.

NI-FGEN Instrument Driver
Readme

Contains information about using the FGEN SFP to interactively generate
waveforms. Located atHelp»FGEN SFPHelp orHelp»Show Context Help
fromwithin the SFP. For device-specific help, selectHelp»Hardware-Specific
Help in the SFP.

FGEN Soft Front Panel Help

Contains information on configuring and testing data acquisition (DAQ) devices
using Measurement & Automation Explorer (MAX) for NI-DAQmx, and
special considerations for operating systems.Located at Help»Help Topics»
NI-DAQmx»MAX Help for NI-DAQmx in MAX.

Measurement & Automation
Explorer Help for NI-DAQmx

Contains information about how to configure your remote systems or devices
with Measurement & Automation Explorer (MAX). Located at Help»Help
Topics»Remote Systems in MAX.

Measurement & Automation
Explorer Remote Systems Help

Contains important cooling information for many PXI, PXIe, PCI, and PCIe
hardware modules. Ships in the device kit.

Maintain Forced-Air Cooling
Note to Users

Contains information for adding an EMI gasket to a PXI module to reduce
high-frequency emissions. Ships in the device kit.

Retrofitting Your PXI Module
Note to Users

Contains safety instructions and electromagnetic compatibility (EMC)
information for the hardware it accompanies. Ships in the device kit.

Read Me First: Safety and
Electromagnetic Compatibility

Verifying the System Requirements
To use an NI signal generator with NI-FGEN, your system must meet certain requirements.

TheNI-FGEN Instrument Driver Readme includesmore information about minimum and recommended
system requirements and supported application development environments (ADEs).
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Unpacking
The device ships in an antistatic envelope to prevent electrostatic discharge (ESD). ESD can damage
several components on the device.

Caution Never touch the exposed pins of connectors.

To avoid damage when handling the device, take the following precautions:
• Ground yourself using a grounding strap or by touching a grounded object.
• Touch the antistatic package to a metal part of your computer chassis before removing the device

from the package.

Remove the device from the envelope and inspect it for loose components or any sign of damage. Notify
NI if the device appears damaged in any way. Do not install a damaged device into your computer.

Store the device in the antistatic envelope when not in use.

Verifying the Kit Contents
The following items are included in the NI signal generator kit:
• NI signal generator
• SMB-BNC cable (included with the NI 5404/5412/5421/5422/5441/5442 only)
• NI-FGEN instrument driver DVD sleeve, which contains the following items:

– NI-FGEN DVD, which includes the NI Signal Generators Help

• NI AnalogWaveform Editor CD. Eligible hardware kits (NI 5412/5421/5422/5441/5442/5450/5451
only) receive an activation license.

• NI Modulation Toolkit CD. Eligible hardware kits (NI 5441/5442/5450/5451 only) receive an
activation license.

• The following documents:
– NI Signal Generators Getting Started Guide
– The specifications document for the NI signal generator
– Read Me First: Safety and Electromagnetic Compatibility
– Maintain Forced-Air Cooling Note to Users (except the NI 5404 devices)
– Retrofitting Your PXI Module Note to Users (NI 5402/5406/5412/5421/5422/5441 only)

Electromagnetic Interference (EMI) Gasket
The kit may also include an EMI gasket.

The Retrofitting Your PXI Module Note to Users describes under what conditions you should install the
gasket. If needed, the gasket should be installed during the installation of your PXI module.
Related Information
Installing PXI and PXI Express Modules on page 6

Other Required Items
In addition to the items contained in the kit, you need the following items to install your device:
• 1/8 in. Phillips head screwdriver
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• Cables appropriate for use with your device

For PXI devices
• A PXI chassis, a PXI/SCXI combination chassis, or a PXI/CompactPCI chassis and chassis

documentation
• A PXI controller or MXI bridge

For PXI Express devices
• A PXI Express chassis and chassis documentation
• A PXI Express controller or a MXI-Express bridge

For PCI devices
• A desktop computer with its documentation

Note If your application uses NI-TClk synchronization, youmust use a RTSI cable to connect
the devices (PCI NI-DAQmx devices only).

Installing the Software
The NI-FGENDVD, included with your device, installs the instrument driver for all NI signal generators.
The NI-FGENDVD also includes the FGEN Soft Front Panel (SFP), which is an easy-to-use, interactive
tool that helps you quickly begin working with the NI signal generator.

To install NI-FGEN, complete the following steps:
1. [Optional] If you are developing an application for the NI signal generator, install an ADE, such

as LabVIEW or LabWindows™/CVI™.
2. Insert the NI-FGEN DVD. The NI-FGEN installer should open automatically.

Note If the installation window does not appear, navigate to the DVD drive, double-click
the drive, and double-click setup.exe.

3. Follow the instructions in the installation prompts. For installation troubleshooting information
contact NI technical support or visit ni.com/support.

Note If you are usingWindows Vista, you may see access and security messages during
installation. Accept the prompts to complete the installation.

4. When the installer completes, a dialog box appears that asks if you want to restart, shut down, or
restart later. Select Restart.

5. If you are using a system running the LabVIEW Real-Time Module, download NI-FGEN to the
target using Measurement & Automation Explorer (MAX). Refer to the MAX Explorer Remote
Systems Help.

Installing the Hardware
The following sections contain information about installing hardware for PXI, PXI Express, and PCI
platforms.

Caution Youmust power off and unplug the computer or chassis before installing the device.
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To prevent damage to the device caused by ESD or contamination, handle the device using the edges
or the metal bracket. Refer to the Read Me First: Safety and Electromagnetic Compatibility document
for more information about handling your device.

Note You must install the software before installing the hardware.

Cooling Considerations for PXI and PCI Devices
You must maintain an acceptable operating temperature for your device.

Caution When installing an NI-DAQmx device (except the NI 5404), follow the guidelines
in the Maintain Forced-Air Cooling Note to Users document included in the kit to ensure
that the device is cooled effectively.

Thermal Shutdown
If the device temperature rises above the maximum operating temperature, the device shuts down and
MAX or NI-FGEN notifies you with an error message.

For information about the operating temperatures for your device, refer to the device specifications. To
re-enable the device after thermal shutdown, you must perform a hard reset, using one of the following
methods:
• Power off the computer or chassis that contains the device. After the device has cooled, power on

the computer or chassis and reboot the controller, if necessary.
• Call the niFgen Reset Device VI or the niFgen_ResetDevice function.
• Perform a device reset in MAX. The Measurement & Automation Explorer Help for NI-DAQmx

contains information about resetting a device in MAX.

Review the guidelines in the Maintain Forced-Air Cooling Note to Users and make any necessary
adjustments. The thermal shutdown error is reported until the device has cooled to an acceptable operating
temperature and has been reset successfully.

Installing PXI and PXI Express Modules
Refer to the chassis documentation to determine which slots are designated for PXI Express modules.

To install PXI devices in either a PXI chassis, a PXI/SCXI combination chassis, or a PXI/CompactPCI
chassis or to install PXI Express devices in a PXI Express chassis, complete the following steps:
1. Power off and unplug the chassis.
2. [Optional] If you need to use the provided EMI gasket to reduce high-frequency emissions, install

it now. The Retrofitting Your PXI Module Note to Users contains information about installing the
gasket.

3. Position the chassis so that inlet and outlet vents are not obstructed. For more information about
optimal chassis setup, refer to the chassis documentation.

4. Make sure that the ejector handle is in the unlatched (downward) position.
5. Hold the module by the ejector handle and slide it into an empty slot. Make sure that the base

engages with the guides in the chassis, as shown in the following figure.
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1. PXI Chassis
2. Ejector Handle
3. Captive Screw
4. NI PXI Device

Figure 1. PXI Installation

Caution Performance may suffer if both screws are not tightened properly.

6. Slide the module completely into the chassis and latch it by pulling up on the ejector handle. Tighten
the captive screws at the top and bottom of the module front panel.

7. Verify that the chassis exhaust fans are operable and free of dust and other contaminants restricting
airflow. You must provide adequate cooling to prevent your device from overheating.

8. Plug in the chassis.

Related Information
Cooling Considerations for PXI and PCI Devices on page 6

Uninstalling PXI and PXI Express Modules
When removing modules, you must power down the chassis.

Hot Surface During operation, the metal surfaces of devices may become hot. Be careful
when removing the device from the chassis or when moving it to a different peripheral slot.
When removing the device, hold it by only the ejector handle and front panel.

Ensure that you are grounded with a grounding strap or are touching a grounded metal surface. To avoid
ESD, do not touch the exposed connector pins or any exposed circuitry on the device. When not in use,
devices should be stored in the original antistatic envelope to avoid damage.

Installing PCI Devices
To install the PCI device, complete the following steps:
1. Power off and unplug the PC.
2. Remove the PC cover.
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3. Insert the device into an open PCI slot, as shown in the following figure.

Tip To maximize airflow and extend the life of the device, leave any adjacent PCI slots
empty.

1

2

3

1. NI PCI Device
2. PCI Slot
3. Computer Chassis

Figure 2. PCI Installation

4. Secure the device with a screw.

Caution It is important to completely screw the device into the PCI slot both for
mechanical stability and for a solid ground connection, which reduces electrical noise.
Improperly secured devices may affect the accuracy of device specifications.

Some computer manufacturers use a securing lever made of plastic to secure PCI devices;
such a lever is unacceptable and must be removed. Use the screw provided in the kit to
secure the device. Otherwise, you must use a different computer chassis.

5. Verify that the computer exhaust fans are operable and free of dust and other contaminants restricting
airflow. You must provide adequate cooling to prevent your device from overheating.

6. Replace the PC cover.
7. Plug in the PC.

Related Information
Cooling Considerations for PXI and PCI Devices on page 6
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Power On Your Computer or PXI Chassis
Windows recognizes any newly installed device the first time you restart the computer after hardware
is installed. On some Windows systems, the Found New Hardware wizard opens with a dialog box for
every NI device installed. Install the software automatically (Recommended) is selected by default.
Click Next or Yes to install the software for each device.
• PXI or PXI Express devices controlled using MXI—Power the PXI chassis before you power on

the PC.
• PCI devices—Verify that spread-spectrum clocking is enabled in the PC BIOS. Refer to the PC

user documentation for information about how to verify this setting if it is available.

Caution Spread-spectrum clocking varies the clock signal to spread the timing clock signal
over a small frequency range. Disabling spread-spectrum clocking may affect the accuracy
of the signal generator specifications.

Configuring and Testing in MAX
Complete the following steps to configure and test your device:
1. Launch MAX.
2. In the configuration pane, double-clickDevices and Interfaces and expand theNI-DAQmxDevices

folder.

Note If you are using a remote RT target, expand Remote Systems, find and expand
your target, and then expand Devices and Interfaces.

Figure 3. MAX Configuration Pane

3. Check that your device appears under Devices and Interfaces. If your device does not appear,
press <F5> to refresh the view inMAX. If the device is still not recognized, refer to ni.com/support.

Note If you are using a MXI interface to control a PXI or PXI Express chassis and
encounter performance or initialization issues, refer to yourMXI documentation to verify
the system requirements and to ensure that the MXI interface is properly configured.
Software optimization might be necessary. For MXI-3 optimization, select Start»All
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Programs»National Instruments MXI-3»MXI-3 Optimization. MXI-4 and
MXI-Express optimization are performed automatically by the hardware.

4. Perform a device self-test to verify installation by right-clicking the device and selecting Self-Test.
A dialog box appears and indicates whether the device passed the test. When the self-test finishes,
a message indicates either successful verification or that an error occurred.

Note If the device does not pass the self-test, reboot your system and repeat
steps 1 through 4. If the device still does not pass the self-test, refer to ni.com/support.

5. Configure the device settings by completing the following steps:
a. Record the device number or device name assigned to the device. You need this number when

programming the device.
• The assigned device name is appended to the device in its configuration tree label. For

example, after installing the NI 5421, the device configuration tree label may appear as
NI PXI-5421: <Dev1>, where Dev1 is the device name. When developing your
application, the resource name for your device is the device name MAX assigned to the
device. You can rename NI-DAQmx devices by right-clicking the device and selecting
Rename.

b. PCI only—Right-click the NI signal generator in the list and select Properties.
c. PCI only—Select the appropriate tab to set the configuration options. The configuration options

you see depend on the device.
d. Click OK to close the window.

Setting up Synchronization in MAX
If you plan to share triggers or clocks to synchronize the devices, you must identify or configure certain
components in MAX.

Note The following sections contain information required for any type of synchronization,
including NI-TClk synchronization. For information about NI-TClk synchronization, refer to
Programming»NI-TClk Synchronization Help in the NI Signal Generators Help.

PXI Devices
Identify the PXI system controller by completing the following steps:
1. In theMAXConfiguration tree underDevices and Interfaces, right-clickPXI System»Identify As

and select your controller from the list. For example, select External PC if you are using a MXI
controller in an external PC.

2. Expand the PXI System tree and select the chassis name to identify the chassis you are using.

PXI Express devices controlled using MXI-Express
Identify the PXI Express system controller in theMAXConfiguration tree underDevices and Interfaces
by right-clicking PXI System»Identify As, and selecting External PC. Your chassis is automatically
identified.

PXI Express devices controlled using a PXI Express controller
PXI Express controllers installed in a PXI Express chassis are automatically identified in MAX.
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PCI Devices
Configure the RTSI cable by completing the following steps:
1. Connect a RTSI cable between the PCI devices to physically share triggers or clocks.
2. In the MAX Configuration tree under Devices and Interfaces, right-click NI-DAQmx Devices.
3. Select Create New NI-DAQmx Device»RTSI Cable.
4. To add a device to a RTSI cable, right-click on the RTSI cable name in the Configuration tree and

select Add Device to RTSI Cable.

Generating Waveforms Interactively
You can interactively generate arbitrary and standard function waveforms using the FGEN Soft Front
Panel (SFP).

Figure 4. FGEN Soft Front Panel

Generating a Standard Waveform
To generate a standard waveform using the FGEN Soft Front Panel, complete the following steps:

Note The NI 5450 does not support standard waveform generation. You can use arbitrary
waveform generation when using the NI 5450 and the FGEN SFP.

1. Launch the FGEN SFP from Start»All Programs»National Instruments»NI-FGEN»FGENSoft
Front Panel.

2. Verify that the device you installed appears on the FGEN SFP display. You can choose a different
signal generator by navigating to Edit»Device Configuration to launch the device configuration
dialog box and selecting a device from the Device list.

3. Click the Standard Function Mode button ( ) to configure your device for standard function
generation.

4. Set the frequency, amplitude, offset, and type of waveform that you want to generate by using the
drop-down listbox to choose the setting to configure and then using the knob to control the value.
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5. Click the Run button ( ) to initiate waveform generation.

The FGEN SFP default settings instruct the signal generator to generate a continuous sine wave at a
frequency of 1 MHz, with a peak-to-peak amplitude of 1 V into a 50 Ω load, and no offset. The FGEN
SFP Help includes more information about the FGEN SFP.

Generating an Arbitrary Waveform
To generate an arbitrary waveform using the FGEN Soft Front Panel, complete the following steps:

Note NI 5402/5404/5406 devices do not support arbitrary waveform generation.

1. Launch the FGEN SFP from Start»All Programs»National Instruments»NI-FGEN»FGENSoft
Front Panel.

2. Verify that the device you installed appears on the FGEN SFP display. You can choose a different
signal generator by navigating to Edit»Device Configuration to launch the device configuration
dialog box and selecting a device from the Device list.

3. (NI 5450/5451 only) Select a channel from the Channel list where you want the waveform
configured. When using the NI 5450/5451 to generate waveforms on multiple channels, perform
steps 4 through 8 to load a waveform on to each channel on which you want to generate.

4. Click the Single Arbitrary WaveformMode button ( ) to configure your device for arbitrary
waveform generation.

5. Click the Download Waveform button ( ) to download a waveform to the device onboard
memory.

6. Select Load Waveform from disk. The Select File dialog box opens and displays waveform
example files. You also can download a waveform by selecting File»Load New Waveform. For
the installation location of the example waveforms, refer to theNI-FGEN Instrument Driver Readme.

7. Select a waveform such as arbMode-sine.lvm and click OK. The File Load dialog box
andWaveform Previewwindow launch. You can close or minimize theWaveform Previewwindow.

8. In the File Load dialog box, select one of the following settings from theWaveform drop-down
listbox:
• NI 5412—sine, 16MHz@40MS/s
• All other signal generators—sine, 40MHz@100MS/s

9. Click OK.
10. Click the Run button to initiate waveform generation. To optimize the sine wave shape, select

Edit»Device Configuration, and change the filter settings.

The FGEN SFP default settings instruct the arbitrary waveform generator to generate a continuous sine
wave, with a peak-to-peak amplitude of 1 V into a 50 Ω load, and no offset. The FGEN SFP Help
includes more information about the FGEN SFP.

Tip You can use the NI Analog Waveform Editor to create arbitrary waveform files.

Generating Waveforms Programmatically
You can control your signal generator programmatically with an ADE using the supplied NI-FGEN
Interchangeable Virtual Instrument (IVI) driver. You also can run the NI-FGEN examples to demonstrate
the functionality of your device.
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NI-FGEN Examples
Examples demonstrate the functionality of the device, serving as programming models and building
blocks for your own applications.

The NI Example Finder is a utility available for some software applications that organizes examples
into categories and allows you to easily browse and search installed examples. You can see descriptions
and compatible hardware models for each example or see all the examples compatible with one particular
hardware model.

Example locations are shown in the following table.

Table 2. NI-FGEN Example Locations

Locating ExamplesSoftware Application

Locate examples with the NI Example Finder. Within
LabVIEW or LabWindows/CVI, select Help»Find
Examples and navigate to Hardware Input and
Output»Modular Instruments.

LabVIEW or LabWindows™/CVI™

Locate examples in the
<NIDocDir>\NI-FGEN\examples directory, where
<NIDocDir> is one of the following directories:
• (Windows 2000/XP) Documents and

Settings\All Users\Shared
Documents\National Instruments

• (Windows Vista)
Users\Public\Documents\National
Instruments

ANSI C or Visual Basic

NI-FGEN Instrument Driver
The NI-FGEN API features a set of operations and attributes that exercise all the functionality of the
device, including configuration, control, and other device-specific functions.

The NI Signal Generators Help includes information about programming with NI-FGEN.

Creating and Editing Waveforms
TheNI AnalogWaveformEditor is an interactive software tool for creating and editing analogwaveforms.

To view or edit existing waveforms, you can open and resample data files saved in binary or ASCII file
formats. Once a waveform is imported, you can view and edit your waveforms. You can also create new
waveforms by selecting from a library of more than 20 waveform primitives or by enteringmathematical
expressions.

© National Instruments Corporation 13 NI Signal Generators Getting Started Guide



Figure 5. The NI Analog Waveform Editor

Tip The NI Analog Waveform Editor can be activated with the serial number provided in the
kits with an eligible hardware purchase. You can also purchase the NI AnalogWaveform Editor
at ni.com.

Appendix A: Front Panels
This section contains front panel connector figures and connector description tables that describe the
signal connection options for NI signal generators.

The NI Signal Generators Help includes signal descriptions, connector pin assignments, and routing
information.

NI PXI/PCI-5402/5406
The NI 5402 is a 20 MHz bandwidth,14-bit arbitrary function generator. The NI 5406 is a 40 MHz
bandwidth, 16-bit arbitrary function generator. These devices have four BNC connectors, as shown in
the following figure. Signal descriptions are listed in the following table.
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ACCESS ACTIVE

SYNC OUT /
PFI 0

PFI 1

NI PXI-540 2

REF IN

CH 0

NI PCI-5402

REF
IN

SYNC
OUT/
PFI 0

PFl 1

CH 0

Figure 6. NI PXI/PCI-5402 Front Panel (NI PXI/PCI-5406 devices include the same connectors)

Table 3. NI PXI/PCI-5402/5406 Front Panel Connectors

FunctionAccessConnector

Provides the waveform output.OutputCH 0

Accepts a PLLReference clock from
an external source and can frequency
lock the Sample clock timebase to
the external Reference clock.

InputREF IN

Provides a TTL-level output of the
waveform being generated on CH 0.
SYNC OUT/ PFI 0 can also be
configured to accept a trigger from
an external source that can start or
step through waveform generation
or can route signals from several
clock, event, and trigger sources.

Input/OutputSYNC OUT/PFI 0
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FunctionAccessConnector

Accepts a trigger from an external
source that can start or step through
waveform generation or can route
signals from several clock, event,
and trigger sources.

Input/OutputPFI 1

NI PXI-5404
The NI PXI-5404 is a 100 MHz frequency generator. The NI PXI-5404 has five SMB connectors, as
shown in the following figure. Signal descriptions are listed in the following table.

SINE

REF
OUT

REF
IN

PFI 0

CH 0

CLOCK

ACCESS ACTIVE

NI PXI-540 4
100 MHz Freq Source

Figure 7. NI PXI-5404 Front Panel

Table 4. NI PXI-5404 Front Panel Connectors

FunctionAccessConnector

Provides a sine waveform of the
desired frequency output.

OutputSINE

Provides a TTL version of the sine
waveform being generated at the
SINE connector.

OutputCLOCK
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FunctionAccessConnector

Accepts either a TTL signal to start
waveform generation, or provides an
output to synchronize—or
trigger—other devices at a certain
time within waveform generation.

Input/OutputPFI 0

Routes signals from the PXI
backplane clock, PXI trigger lines,
or a divided-down version of
the internal NI 5404 clock.

OutputREF OUT

Accepts a PLLReference clock from
an external source and can frequency
lock the NI PXI-5404 Sample clock
timebase to the external Reference
clock.

InputREF IN

NI PXI/PCI-5412/5421/5422/5441
The NI 5412 is a 100 MS/s, 20 MHz, 14-bit arbitrary waveform generator. The NI 5421 is a 100 MS/s,
43 MHz, 16-bit arbitrary waveform generator. The NI 5422 is a 200 MS/s, 80 MHz, 16-bit arbitrary
waveform generator. The NI 5441 is a 100 MS/s, 43 MHz, 16-bit arbitrary waveform generator with
onboard signal processing (OSP). These devices have up to five connectors—four SMB connectors and
one 68-pin male VHDCI connector, as shown in the following figure. Signal descriptions are listed in
the following table.
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Figure 8. NI PXI/PCI-5421 Front Panel (NI PXI/PCI-5412/5422/5441 devices are similar)

Note The DIGITAL DATA & CONTROL (DDC) connector is not available on the NI 5412
or the NI 5421/5422 with the 8 MB memory option.

Table 5. NI PXI/PCI-5412/5421/5422/5441 Front Panel Connectors

FunctionAccessConnector

Provides the waveform output.OutputCH 0

Accepts a PLLReference clock from
an external source and can frequency
lock the Sample clock timebase to
the external Reference clock. The
signal on this connector can also be
used as a Sample clock source.

InputCLK IN

NI Signal Generators Getting Started Guide 18 ni.com



FunctionAccessConnector

Accepts a trigger from an external
source that can start or step through
waveform generation, or can route
signals out from several clock, event,
and trigger sources.

Input/OutputPFI 0

Accepts a trigger from an external
source that can start or step through
waveform generation or can route
signals from several clock, event,
and trigger sources.

Input/OutputPFI 1

Routes the 16-bit digital pattern
outputs, digital pattern clock output,
trigger outputs, trigger inputs, and a
clock input.

Input/OutputDIGITAL DATA & CONTROL
(DDC)

NI PXIe-5442
The NI 5442 is a PXI Express, 100 MS/s, 43 MHz, 16-bit arbitrary waveform generator with OSP. The
NI 5442 has four SMB connectors, as shown in the following figure. Signal descriptions are listed in
the following table.
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PFI 0

PFI 1

NI PXIe-5442

ACCESS ACTIVE

CLK

IN

CH 0

100 MS/s AWG OSP

Figure 9. NI PXIe-5442 Front Panel

Table 6. NI PXIe-5442 Front Panel Connectors

FunctionAccessConnector

Provides the waveform output.OutputCH 0

Accepts a PLLReference clock from
an external source and can frequency
lock the Sample clock timebase to
the external Reference clock. The
signal on this connector can also be
used as a Sample clock source.

InputCLK IN

Accepts a trigger from an external
source that can start or step through
waveform generation or can route
signals from several clock, event,
and trigger sources.

Input/OutputPFI 0
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FunctionAccessConnector

Accepts a trigger from an external
source that can start or step through
waveform generation or can route
signals from several clock, event,
and trigger sources.

Input/OutputPFI 1

NI PXIe-5450/5451
The NI 5450 is a two-slot PXI Express, 400 MS/s, 120 MHz, dual-channel,16-bit arbitrary waveform
generator with onboard signal processing (OSP). The NI 5451 is a two-slot PXI Express, 400 MS/s, 135
MHz, dual-channel,16-bit arbitrary waveform generator with onboard signal processing (OSP) and 160
MHz of digital upconverter bandwidth. These devices have six SMA connectors and two SMB connectors,
as shown in the following figure. Signal descriptions are listed in the following table.

Figure 10. NI PXIe-5450/5451 Front Panels

© National Instruments Corporation 21 NI Signal Generators Getting Started Guide



Table 7. NI PXIe-5450/5451 Front Panel Connectors

FunctionAccessConnector

Provides differential waveform
output for channel 0. The NI 5451
provides single-ended waveform
output on channel 0+.

OutputCH 0+/I+

Provides complementary differential
waveform output for channel 0.

OutputCH 0–/I–

Provides differential waveform
output for channel 1. The NI 5451
provides single-ended waveform
output on channel 1+.

OutputCH 1+/Q+

Provides complementary differential
waveform output for channel 1.

OutputCH 1–/Q–

Accepts an external clock that can
be used as a Reference clock, a
Sample clock, or a Sample clock
timebase.

InputCLK IN

Provides a clock signal that can be
shared by other devices.

OutputCLK OUT

Accepts a trigger from an external
source that can start or step through
waveform generation or can route
signals from several clock, event,
and trigger sources.

Input/OutputPFI 0

Accepts a trigger from an external
source that can start or step through
waveform generation or can route
signals from several clock, event,
and trigger sources.

Input/OutputPFI 1

Where to Go for Support
The National Instruments Web site is your complete resource for technical support. At ni.com/support
you have access to everything from troubleshooting and application development self-help resources to
email and phone assistance from NI Application Engineers.

A Declaration of Conformity (DoC) is our claim of compliance with the Council of the European
Communities using the manufacturer's declaration of conformity. This system affords the user protection
for electronic compatibility (EMC) and product safety. You can obtain the DoC for your product by
visiting ni.com/certification. If your product supports calibration, you can obtain the calibration certificate
for your product at ni.com/calibration.

National Instruments corporate headquarters is located at 11500 North Mopac Expressway, Austin,
Texas, 78759-3504. National Instruments also has offices located around the world to help address your
support needs. For telephone support in the United States, create your service request at ni.com/support
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and follow the calling instructions or dial 512 795 8248. For telephone support outside the United States,
contact your local branch office.

Australia 1800 300 800, Austria 43 0 662 45 79 90 0, Belgium 32 0 2 757 00 20, Brazil 55 11 3262 3599,
Canada 800 433 3488, China 86 21 6555 7838, Czech Republic 420 224 235 774,
Denmark 45 45 76 26 00, Finland 385 0 9 725 725 11, France 33 0 1 48 14 24 24,
Germany 49 0 89 741 31 30, India 91 80 41190000, Israel 972 0 3 6393737, Italy 39 02 413091,
Japan 81 3 5472 2970, Korea 82 02 3451 3400, Lebanon 961 0 1 33 28 28, Malaysia 1800 887710,
Mexico 01 800 010 0793, Netherlands 31 0 348 433 466, New Zealand 0800 553 322,
Norway 47 0 66 90 76 60, Poland 48 22 328 90 10, Portugal 351 210 311 210, Russia 7 495 783 68 51,
Singapore 1800 226 5886, Slovenia 386 3 425 42 00, South Africa 27 0 11 805 8197,
Spain 34 91 640 0085, Sweden 46 0 8 587 895 00, Switzerland 41 56 200 51 51,
Taiwan 886 02 2377 2222, Thailand 662 278 6777, Turkey 90 212 279 3031,
United Kingdom 44 0 1635 523545
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National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments
Corporation. Refer to the Terms of Use section on ni.com/legal for more information about
National Instruments trademarks. Other product and company names mentioned herein are
trademarks or trade names of their respective companies. For patents covering National
Instruments products/technology, refer to the appropriate location: Help»Patents in your software,
the patents.txt file on your CD, or the National Instruments Patent Notice at ni.com/patents.
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