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About This Manual

The LabVIEW Data Acquisition Basics Manual includes the information
you need to get started with data acquisition and LabVIEW. You should
have a basic knowledge of LabVIEW before you try to read this manual. If
you have never worked with LabVIEW, please read through the LabVIEW
QuickStart Guide or the LabVIEW Online Tutorial before you begin. This
manual shows you how to configure your software, teaches you basic
concepts needed to accomplish your task, and refers you to common
example VIs in LabVIEW. If you have used LabVIEW for data acquisition
before, you can use this book as a troubleshooting guide.

This manual supplements the LabVIEW User Manual, and assumes that
you are familiar with that material. You also should be familiar with the
operation of LabVIEW, your computer, your computer's operating system,
and your data acquisition (DAQ) device.

Conventions Used in This Manual

<>

»

5
@

italic

The following conventions are used in this manual:

Angle brackets that contain numbers separated by an ellipsis represent a
range of values associated with a bit or signal name—for example,
DBIO<3..0>.

Square brackets enclose optional items—for example, [response].

The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

This icon denotes a note, which alerts you to important information.
This icon denotes a tip, which alerts you to advisory information.

Bold text denotes items that you must select or click on in the software,
such as menu items and dialog box options. Bold text also denotes
parameter names.

Italic text denotes variables, emphasis, a cross reference, or an introduction
to a key concept. This font also denotes text that is a placeholder for a word
or value that you must supply.
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About This Manual

monospace

monospace bold

monospace italic

NI-DAQ 4.8.x

NI-DAQ 5.x

NI-DAQ 6.0

Platform

Text in this font denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames and extensions, and code excerpts.

Bold text in this font denotes the messages and responses that the computer
automatically prints to the screen. This font also emphasizes lines of code
that are different from the other examples.

Ttalic text in this font denotes text that is a placeholder for a word or value
that you must supply.

NI-DAQ 4.8.x refers to functions supported only on the Macintosh for
NuBus DAQ products.

NI-DAQ 5.x refers to functions supported only on Windows DAQ products.

NI-DAQ 6.0 refers to functions supported only on Windows and PCI-based
Macintosh DAQ products.

Text in this font denotes a specific platform and indicates that the text
following it applies only to that platform.
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About This Manual

LabVIEW Data Types

Each VI description gives a data type picture for each input and output
parameter, as illustrated in the following table:

Control Indicator Data Type

Signed 8-bit integer

Signed 16-bit integer

Signed 32-bit integer

Unsigned 8-bit integer

Unsigned 16-bit integer

Unsigned 32-bit integer

Single-precision floating-point number

Double-precision floating-point number

Extended-precision floating-point
number

String

T TF Boolean

bl

132 Array of signed 32-bit integers

2D Array of signed 32-bit integers

Cluster

HBEEEE EEEEEEBEE
o8 & EE R E

File Refnum
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About This Manual

Related Documentation

The following documents contain information you might find helpful as
you read this manual:

LabVIEW QuickStart Guide

LabVIEW User Manual

G Programming Reference Manual
LabVIEW Function and VI Reference Manual

LabVIEW Online Reference, available online by selecting
Help»Online Reference

LabVIEW Online Tutorial, which you launch from the LabVIEW
dialog box (Windows)

Application Note 025, Field Wiring and Noise Considerations for
Analog Signals

Application Note 046, Measuring Temperature with RTDs—A Tutorial

The user manuals for the data acquisition boards you use
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Part |

Before You Get Started

This section contains all the information you should know before you
start learning about data acquisition with LabVIEW.

Part I, Before You Get Started, contains the following chapters:

e Chapter 1, How To Use This Book, explains how this manual is
organized.

e Chapter 2, Installing and Configuring Your Data Acquisition
Hardware, explains how to set up your system to use data acquisition
with LabVIEW and your data acquisition hardware.

e Chapter 3, Basic LabVIEW Data Acquisition Concepts, explains key
concepts in understanding how data acquisition works with LabVIEW.

*  Chapter 4, Where You Should Go Next, directs you to the chapter or
chapters in the manual best suited to answer questions about your data
acquisition application.
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How To Use This Book

This chapter explains how this manual is organized. The following outline
shows you what information you can find in this manual.
PartI Before You Get Started
How to Use This Book
Installing and Configuring Your Data Acquisition Hardware
Basic LabVIEW Data Acquisition Concepts
Where You Should Go Next

Part I Catching the Wave with Analog Input
Things You Should Know about Analog Input
One-Stop Single-Point Acquisition
Buffering Your Way through Waveform Acquisition
Controlling Your Acquisition with Triggers

Letting an Outside Source Control Your Acquisition Rate

Part III Making Waves with Analog Output
Things You Should Know about Analog Output
One-Stop Single-Point Generation
Buffering Your Way through Waveform Generation
Letting an Outside Source Control Your Update Rate

Simultaneous Buffered Waveform Acquisition and Generation

Part IV Getting Square with Digital I/O
Things You Should Know about Digital I/O
When You Need It Now—Immediate Digital I/O
Shaking Hands with a Digital Partner
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Chapter 1 How To Use This Book

Part V. SCXI—Getting Your Signals in Great Condition
Things You Should Know about SCXI
Hardware and Software Setup for Your SCXI System
Special Programming Considerations for SCXI
Common SCXT Applications

SCXI Calibration—Increasing Signal Measurement Precision

Part VI Counting Your Way to High-Precision Timing
Things You Should Know about Counters
Generating a Square Pulse or Pulse Trains
Measuring Pulse Width
Measuring Frequency and Period
Counting Signal Highs and Lows

Dividing Frequencies

Part VII Debugging Your Data Acquisition Application
Debugging Techniques
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Chapter 1 How To Use This Book

If you already have started a LabVIEW DAQ application, please refer to
Chapter 2, Installing and Configuring Your Data Acquisition Hardware,
to check your configuration. Refer to Part VII, Debugging Your Data
Acquisition Application, for information on common errors. The following
flowchart shows the steps to follow before running your application.

( Install and Configure Your Hardware )

( Learn Basic Data Acquisition Concepts

'

C Go to Your Specific Application Section

)

)
:

)

)

C Review LabVIEW Example Applications

'

C Learn How to Debug Your Application

© National Instruments Corporation

Install and Configure Your Hardware—When you install
LabVIEW, the program prompts you to have the data acquisition
(DAQ) drivers installed. This manual guides you through setting up
NI-DAQ software with your DAQ device and SCXI hardware. You
should read any unique installation instructions for your platform in
Chapter 2, Installing and Configuring Your Data Acquisition
Hardware.

Learn Basic Data Acquisition Concepts—Chapter 3, Basic
LabVIEW Data Acquisition Concepts, shows you the location of
DAQ example VIs; DAQ VI organization; VI parameter conventions;
default and current value conventions; common VI parameter
definitions; error handling; channel, port and counter addressing;
limit settings; and data organization for analog applications.
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Go to Your Specific Application Section—Chapter 4, Where You
Should Go Next, shows you where to find information in this manual
for your application.

Review LabVIEW Example Applications—The remaining chapters
teach you basic concepts in analog input and output, digital I/O,
counters, and SCXI. Each application section first lists example Vs,
then describes the basic concepts needed to understand these example
VIs. Whenever possible, you should have the VI open as you refer to
these examples.

Learn How to Debug Your Application—Chapter 29, Debugging
Techniques, describes the different ways you can debug your
application. This chapter helps you troubleshoot for common
programming errors.
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Installing and Configuring Your
Data Acquisition Hardware

This chapter explains how to set up your system to use data acquisition
with LabVIEW and your data acquisition hardware. The chapter contains
hardware installation and configuration and software configuration
instructions and some general information and techniques.

@ Note The LabVIEW installer prompts you to have the NI-DAQ driver software installed.
All National Instruments data acquisition (DAQ) devices are packaged with NI-DAQ driver
software. The version of NI-DAQ packaged with your DAQ device might be newer than
the version installed by LabVIEW. You can determine the NI-DAQ version in LabVIEW

inFo] by running the Get DAQ Device Information VI, located in Functions»Data
Acquisition»Calibration and Configuration.

After installing LabVIEW and the NI-DAQ driver, follow the steps
in Figure 2-1 to install your hardware and complete the software
configuration. LabVIEW uses the software configuration information
to recognize your hardware and to set default DAQ parameters.
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Install Plug-in Devices )

\ 4

[Use Measurement & Automation Explorej

or Your Configuration Utility
to Configure Devices

:

\ 4

[ Install and Configure SCXI )

\4

Use the Measurement & Automation Explorer
(NI-DAQ 6.5 or higher for Windows 9x/NT)
to configure Al, AO, or DIO channels.
or
Use the DAQ Channel Wizard
(NI-DAQ 6.1 or lower, Windows 9x/NT or Macintosh)
to configure Al, AO, or DIO channels.

\ 4

Read Chapter 3, Basic Data Acquisition Concepts,
and Chapter 4, Where You Should Go Now

Figure 2-1. Installing and Configuring DAQ Devices

NI-DAQ driver software provides LabVIEW with a high-level interface to
DAQ devices and signal conditioning hardware.
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Figure 2-2 shows the relationship between LabVIEW, NI-DAQ, and
DAQ hardware.

LabVIEW Vls

NI-DAQ Drivers

Data Acquisition Devices

Figure 2-2. How NI-DAQ Relates to Your System and DAQ Devices

(NI-DAQ 4.8.x for Macintosh) NI-DAQ 4.8.x for the Macintosh device drivers
are bundled in a single file that determines which drivers to load. When you
restart your computer, this control panel driver, called NI-DAQ, determines
which devices are installed in the system and loads their corresponding
drivers. NI-DAQ uses its control panel settings to determine what Signal
Conditioning eXtensions for Instrumentation (SCXI) hardware is
configured and what the default device settings are for devices in the
computer. If you use DMA, NI-DAQ also communicates with the
NI-DMA/DSP for DMA services. When you install LabVIEW, the installer
places both of these files on your hard drive.

(NI-DAQ 6. x for Macintosh) The NI-DAQ driver, called NI-DAQ is installed
in the National Instruments folder in your Macintosh Extensions folder.

(NI-DAQ 5.x, 6.x for Windows) The NI-DAQ driver, NIDAQ32 .DLL, i$
installed in your Windows SYSTEM or SYSTEM32 directory.
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LabVIEW Data Acquisition Hardware Support

National Instruments periodically upgrades LabVIEW to add support for
new DAQ hardware. To make sure this version of LabVIEW supports the
hardware you use, refer to the following table.

Table 2-1. LabVIEW DAQ Hardware Support with NI-DAQ

NI-DAQ Version Support

Device Type Device Windows 9x Windows NT 4.0 | Windows 2000 Macintosh
PCI Bus NI 4060 for PCI 6.1 and higher 6.1 and higher 6.6 and higher N/A
Devices
NI 4351 for PCI 6.5 and higher 6.5 and higher 6.6 and higher N/A
NI 4551 for PCI 6.1 and higher 6.1 and higher 6.6 and higher N/A
NI 4552 for PCI 6.1 and higher 6.1 and higher 6.6 and higher N/A
NI 5102 for PCI 5.0 and higher 5.0 and higher 6.6 and higher N/A
NI 5401 for PCI 6.5.2 and higher 6.5.2 and higher 6.6 and higher N/A
NI 5411 for PCI 5.0 and higher 5.0 and higher 6.6 and higher N/A
NI 5431 for PCI 6.5 and higher 6.5 and higher 6.6 and higher N/A
PCI-1200 4.9 and higher 5.0 and higher 6.6 and higher 4.9 and higher
PCI-4451 6.1 and higher 6.1 and higher 6.6 and higher N/A
PCI-4452 6.1 and higher 6.1 and higher 6.6 and higher N/A
PCI-4453 6.6 and higher 6.6 and higher 6.6 and higher N/A
PCI-4454 6.6 and higher 6.6 and higher 6.6 and higher N/A
PCI-6023E 6.5 and higher 6.5 and higher 6.6 and higher N/A
PCI-6024E 6.5 and higher 6.5 and higher 6.6 and higher N/A
PCI-6025E 6.5 and higher 6.5 and higher 6.6 and higher N/A
PCI-6031E 5.1 and higher 5.1 and higher 6.6 and higher 6.0 and higher
PCI-6032E 5.1 and higher 5.1 and higher 6.6 and higher 6.0 and higher
PCI-6033E 5.1 and higher 5.1 and higher 6.6 and higher 6.0 and higher
PCI-6034E 6.6 and higher 6.6 and higher 6.6 and higher N/A
PCI-6035E 6.6 and higher 6.6 and higher 6.6 and higher N/A
PCI-6052E 6.5 and higher 6.5 and higher 6.6 and higher N/A
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Table 2-1. LabVIEW DAQ Hardware Support with NI-DAQ (Continued)

NI-DAQ Version Support

Device Type Device Windows 9x Windows NT 4.0 | Windows 2000 Macintosh

PCI Bus PCI-6071E 5.1 and higher 5.1 and higher 6.6 and higher 6.0 and higher

?Ce(\)/rll(t:iensued) PCI-6110E 6.1 and higher 6.1 and higher 6.6 and higher 6.1 and higher
PCI-6111E 6.1 and higher 6.1 and higher 6.6 and higher 6.1 and higher
PCI-6503 6.1 and higher 6.1 and higher 6.6 and higher N/A
PCI-6527 6.6 and higher 6.6 and higher 6.6 and higher N/A
PCI-6601 6.6 and higher 6.6 and higher 6.6 and higher N/A
PCI-6602 6.5 and higher 6.5 and higher 6.6 and higher N/A
PCI-6608 6.6 and higher 6.6 and higher 6.6 and higher N/A
PCI-6703 6.6 and higher 6.6 and higher 6.6 and higher N/A
PCI-6704 6.5 and higher 6.5 and higher 6.6 and higher N/A
PCI-6711 6.5 and higher 6.5 and higher 6.6 and higher N/A
PCI-6713 6.5 and higher 6.5 and higher 6.6 and higher N/A
PCI-7030?2 6.5 and higher 6.5 and higher 6.6 and higher N/A
PCI-70402 6.5 and higher 6.5 and higher 6.6 and higher N/A
PCI-DIO-32HS 5.0 and higher 5.0 and higher 6.6 and higher 6.0 and higher
PCI-DIO-96 4.9 and higher 5.0 and higher 6.6 and higher 4.9 and higher
PCI-MIO-16E-1 5.0 and higher 5.0 and higher 6.6 and higher 6.0 and higher
PCI-MIO-16E-4 5.0 and higher 5.0 and higher 6.6 and higher 6.0 and higher
PCI-MIO-16XE-10 5.0 and higher 5.0 and higher 6.6 and higher 6.0 and higher
PCI-MIO-16XE-50 4.9 and higher 5.0 and higher 6.6 and higher 4.9 and higher

PXI Combo PXI-1010 6.0 and higher 6.0 and higher 6.6 and higher N/A

Chassis PXI-1011 6.6 and higher 6.6 and higher 6.6 and higher N/A

© National Instruments Corporation 2-5 LabVIEW Data Acquisition Basics Manual




Chapter 2

Installing and Configuring Your Data Acquisition Hardware

Table 2-1. LabVIEW DAQ Hardware Support with NI-DAQ (Continued)

NI-DAQ Version Support

Device Type Device Windows 9x Windows NT 4.0 | Windows 2000 Macintosh

PXI Bus NI 4060 for PXI 6.1 and higher 6.1 and higher 6.6 and higher N/A

Devices NI 4351 for PXI 6.5 and higher 6.5 and higher 6.6 and higher N/A
NI 5102 for PXI 6.0 and higher 6.0 and higher 6.6 and higher N/A
NI 5401 for PXI 6.5.2 and higher 6.5.2 and higher 6.6 and higher N/A
NI 5411 for PXI 6.5 and higher 6.5 and higher 6.6 and higher N/A
NI 5431 for PXI 6.5 and higher 6.5 and higher 6.6 and higher N/A
PXI-6011E 5.1 and higher 5.1 and higher 6.6 and higher N/A
PXI-6025E 6.5 and higher 6.5 and higher 6.6 and higher N/A
PXI-6030E 5.1 and higher 5.1 and higher 6.6 and higher N/A
PXI-6031E 6.1 and higher 6.1 and higher 6.6 and higher N/A
PXI-6035E 6.6 and higher 6.6 and higher 6.6 and higher N/A
PXI-6040E 5.1 and higher 5.1 and higher 6.6 and higher N/A
PXI-6052E 6.6 and higher 6.6 and higher 6.6 and higher N/A
PXI-6070E 5.1 and higher 5.1 and higher 6.6 and higher N/A
PXI-6071E 6.1 and higher 6.1 and higher 6.1 and higher N/A
PXI-6508 6.0 and higher 6.0 and higher 6.6 and higher N/A
PX1-6527 6.6 and higher 6.6 and higher 6.6 and higher N/A
PXI-6533 5.1 and higher 5.1 and higher 6.6 and higher N/A
PXI-6602 6.5 and higher 6.5 and higher 6.6 and higher N/A
PXI-6608 6.6 and higher 6.6 and higher 6.6 and higher N/A
PXI-6703 6.6 and higher 6.6 and higher 6.6 and higher N/A
PXI-6704 6.5 and higher 6.5 and higher 6.6 and higher N/A
PXI-6711 6.5 and higher 6.5 and higher 6.6 and higher N/A
PX1-6713 6.5 and higher 6.5 and higher 6.6 and higher N/A
PXI-7030? 6.5 and higher 6.5 and higher 6.6 and higher N/A
PXI-7040? 6.5 and higher 6.5 and higher 6.6 and higher N/A
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Table 2-1. LabVIEW DAQ Hardware Support with NI-DAQ (Continued)

NI-DAQ Version Support

Device Type Device Windows 9x Windows NT 4.0 | Windows 2000 Macintosh
PC Card DAQCard-500 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
Devices DAQCard-700 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
DAQCard-1200 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
DAQCard-516 4.9 and higher 5.0 and higher 6.6 and higher 6.0 and higher
DAQCard-6023E 6.6 and higher 6.6 and higher 6.6 and higher N/A
DAQCard-6024E 6.6 and higher 6.6 and higher 6.6 and higher N/A
DAQCard-6062E 6.6 and higher 6.6 and higher 6.6 and higher N/A
DAQCard-6533 5.1 and higher 5.1 and higher 6.6 and higher 6.0 and higher
DAQCard-6723 6.6 and higher 6.6 and higher 6.6 and higher N/A
DAQCard-AI-16E-4 4.9 and higher 5.0 and higher 6.6 and higher 6.0 and higher
DAQCard-AI-16XE-50 4.9 and higher 5.0 and higher 6.6 and higher 6.0 and higher
DAQCard-AO-2DC 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
DAQCard-DIO-24 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
NI 4050 for PCMCIA 5.0 and higher 5.0 and higher 6.6 and higher N/A
NI 4350 for PCMCIA 5.1 and higher 5.1 and higher 6.6 and higher N/A
NI 5102 for PCMCIA 5.0 and higher 5.0 and higher 6.6 and higher N/A
External DAQPad-1200' 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
Devices DAQPad-6020E (USB) 6.5 and higher? N/A 6.6 and higher N/A
DAQPad-6052E (1394) 6.6 and higher? N/A 6.6 and higher N/A
DAQPad-6070E (1394) 6.5 and higher? N/A 6.6 and higher N/A
DAQPad-6507/6508 6.0 and higher? N/A 6.6 and higher N/A
(USB)
DAQPad-6533 (1394) 6.5 and higher? N/A 6.6 and higher N/A
DAQPad-6713 (1394) 6.5 and higher? N/A 6.6 and higher N/A
DAQPad-MIO-16XE-50! | 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
NI 4350 for USB 6.0 and higher? N/A 6.6 and higher N/A
NI 5102 for USB 6.0 and higher? N/A 6.6 and higher N/A
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Table 2-1. LabVIEW DAQ Hardware Support with NI-DAQ (Continued)

NI-DAQ Version Support

Device Type Device Windows 9x Windows NT 4.0 | Windows 2000 Macintosh

AT Bus AT-A2150 4851049 Contact NI N/A N/A

Devices
AT-AI-16XE-10 4.9 and higher 5.0 and higher 6.6 and higher N/A
AT-AO-6/10 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
AT-DIO-32F 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
AT-DIO-32HS 5.0 and higher 5.0 and higher 6.6 and higher N/A
AT-DSP2200 4851049 Contact NI N/A N/A
AT-MIO-16/16D 4.8.51t06.1 5.0t06.1 N/A N/A
AT-MIO-16DE-10 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
AT-MIO-16E-1 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
AT-MIO-16E-2 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
AT-MIO-16E-10 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
AT-MIO-16F-5 4.851t06.1 5.0t06.1 N/A N/A
AT-MIO-16X 4.8.5t06.1 5.0t06.1 N/A N/A
AT-MIO-16XE-10 4.9 and higher 5.0 and higher 6.6 and higher N/A
AT-MIO-16XE-50 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
AT-MIO-64E-3 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
AT-MIO-64F-5 4.851t06.1 5.0t06.1 N/A N/A
NI 5102 for ISA 5.0 and higher 5.0 and higher 6.6 and higher N/A
NI 5411 for ISA 5.0 and higher 5.0 and higher 6.6 and higher N/A
NI 5431 for ISA 6.5 and higher 6.5 and higher 6.6 and higher N/A
EISA-A2000 485t04.9 Contact NI N/A N/A
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Table 2-1. LabVIEW DAQ Hardware Support with NI-DAQ (Continued)

NI-DAQ Version Support

Device Type Device Windows 9x Windows NT 4.0 | Windows 2000 Macintosh
PC/XT Bus NI 4350 for ISA 5.1 and higher 5.1 and higher 6.6 and higher N/A
Devices
PC-516 4.9 and higher 5.0 and higher 6.6 and higher N/A
PC-AO-2DC 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
PC-DIO-24 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
PC-DIO-24PnP 6.0 and higher 5.0 and higher 6.6 and higher N/A
PC-DIO-96 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
PC-DIO-96PnP 6.0 and higher 5.0 and higher 6.6 and higher N/A
PC-LPM-16 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
PC-LPM-16PnP 4.9 and higher 5.0 and higher 6.6 and higher N/A
PC-OPDIO-16 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
PC-TIO-10 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
Lab Series Lab-PC+ 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
Devices Lab-PC-1200 4.9 and higher 5.0 and higher 6.6 and higher N/A
Lab-PC-1200AI 4.9 and higher 5.0 and higher 6.6 and higher N/A
Lab-LC N/A N/A N/A 48t04.9
Lab-NB N/A N/A N/A 4.8t04.9
NEC Devices | NEC-AI-16E-4 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
NEC-AI-16XE-50 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
NEC-MIO-16E-4 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
NEC-MIO-16XE-50 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
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Table 2-1. LabVIEW DAQ Hardware Support with NI-DAQ (Continued)

NI-DAQ Version Support

Device Type Device Windows 9x Windows NT 4.0 | Windows 2000 Macintosh
NuBus NB-A2000 N/A N/A N/A 48t04.9
Devices
NB-A2150 N/A N/A N/A 4.8t04.9
NB-A2100 N/A N/A N/A 4.8t04.9
NB-AO-6 N/A N/A N/A 4.8t04.9
NB-DIO-24 N/A N/A N/A 4.8t04.9
NB-DIO-32F N/A N/A N/A 4.8t04.9
NB-DIO-96 N/A N/A N/A 4.8t04.9
NB-DMA-8-G N/A N/A N/A 4.8t04.9
NB-DMA2800 N/A N/A N/A 4.8t04.9
NB-MIO-16 N/A N/A N/A 4.8t04.9
NB-MIO-16X N/A N/A N/A 4.8t04.9
NB-TIO-10 N/A N/A N/A 4.8t04.9
VXI Carriers | VXI-AO-48XDC 4.9 and higher 5.0 and higher 6.6 and higher N/A
and Modules
VXI-DIO-128 4.9 and higher 5.0 and higher 6.6 and higher N/A
VXI-MIO-64E-1 4.9 and higher 5.0 and higher 6.6 and higher N/A
VXI-MIO-64XE-10 4.9 and higher 5.0 and higher 6.6 and higher N/A
VXI-SC-1000 5.0 and higher 5.0 and higher 6.6 and higher N/A
VXI-SC-1102 5.0 and higher 5.0 and higher 6.6 and higher N/A
VXI-SC-1102B 5.1 and higher 5.1 and higher 6.6 and higher N/A
VXI-SC-1102C 5.1 and higher 5.1 and higher 6.6 and higher N/A
VXI-SC-1104 6.5 and higher 6.5 and higher 6.6 and higher N/A
VXI-SC-1150 5.0 and higher 5.0 and higher 6.6 and higher N/A
SCXI SCXI-1000 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
Chassis SCXI-1000DC 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SCXI-1001 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SCXI-2000 4.9 and higher 5.0 and higher 6.6 and higher N/A
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Table 2-1. LabVIEW DAQ Hardware Support with NI-DAQ (Continued)

NI-DAQ Version Support

Device Type Device Windows 9x Windows NT 4.0 | Windows 2000 Macintosh

SCXI SCXI-1100 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher

Modules
SCXI-1101 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCXI-1102 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SCXI-1102B 5.1 and higher 5.1 and higher 6.6 and higher 6.0 and higher
SCXI-1102C 5.1 and higher 5.1 and higher 6.6 and higher 6.0 and higher
SCXI-1104 6.5 and higher 6.5 and higher 6.6 and higher N/A
SCXI-1112 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCXI-1120 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SCXI-1120D 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SCXI-1121 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SCXI-1122 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SCXI-1124 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SCXI-1125 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCXI-1126 6.0 and higher 6.0 and higher 6.6 and higher 6.0 and higher
SCXI-1127 6.5.2 and higher 6.5.2 and higher 6.6 and higher N/A
SCXI-1140 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SCXI-1141 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SCXI-1142 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCXI-1143 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCXI-1160 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SCXI-1161 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SCXI-1162 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SCXI-1162HV 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SCXI-1163 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SCXI-1163R 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SCXI-1200! 4.8.5 and higher 5.0 and higher 6.6 and higher N/A
SCXI-2400 4.9 and higher 5.0 and higher 6.6 and higher N/A
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Table 2-1. LabVIEW DAQ Hardware Support with NI-DAQ (Continued)

NI-DAQ Version Support

Device Type Device Windows 9x Windows NT 4.0 | Windows 2000 Macintosh

Accessories AMUX-64T 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SC-2040 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SC-2042-RTD 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher
SC-2043-SG 4.8.5 and higher 5.0 and higher 6.6 and higher 4.8 and higher

Signal SC-2345 6.0 and higher 6.0 and higher 6.6 and higher 6.0 and higher

Conditioning

Components SCC-A10 6.0 and higher 6.0 and higher 6.6 and higher 6.0 and higher

(Csise)r:“d SCC-AIOI 6.6and higher | 6.6 and higher | 6.6and higher N/A
SCC-AI02 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCC-AIO3 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCC-AIO4 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCC-AIO5 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCC-AI06 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCC-AI07 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCC-AI13 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCC-All14 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCC-CI20 6.0 and higher 6.0 and higher 6.6 and higher 6.0 and higher
SCC-DI01 6.5 and higher 6.5 and higher 6.6 and higher N/A
SCC-DOO01 6.5 and higher 6.5 and higher 6.6 and higher N/A
SCC-FTO01 6.0 and higher 6.0 and higher 6.6 and higher 6.0 and higher
SCC-LPO1 6.1 and higher 6.1 and higher 6.6 and higher 6.1 and higher
SCC-LP02 6.1 and higher 6.1 and higher 6.6 and higher 6.1 and higher
SCC-LPO3 6.1 and higher 6.1 and higher 6.6 and higher 6.1 and higher
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Table 2-1. LabVIEW DAQ Hardware Support with NI-DAQ (Continued)

NI-DAQ Version Support

Device Type Device Windows 9x Windows NT 4.0 | Windows 2000 Macintosh

Signal SCC-PWRO1 6.0 and higher 6.0 and higher 6.6 and higher 6.0 and higher

Conditioning

Components SCC-PWRO02 6.0 and higher 6.0 and higher 6.6 and higher 6.0 and higher

gfggr:“d SCC-PWR03 6.0 and higher | 6.0 and higher | 6.6and higher | 6.0 and higher

(Continued) SCC-SGO1 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCC-SG02 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCC-SG03 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCC-SG04 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCC-SG11 6.6 and higher 6.6 and higher 6.6 and higher N/A
SCC-TCO1 6.0 and higher 6.0 and higher 6.6 and higher 6.0 and higher
SCC-TC02 6.0 and higher 6.0 and higher 6.6 and higher 6.0 and higher

' The DAQPad-MIO-16XE-50 and DAQPad-1200 do not work with NEC PC-9800 Series computers. The SCXI-1200

works with NEC PC-9800 Series computers ONLY when used with Remote SCXI.

2 Requires LabVIEW/RT.

3 USB and IEEE-1394 devices are supported only on Windows 98 and Windows 2000. There is no support under

Windows 95 and Windows NT 4.0.

© National Instruments Corporation

For more information regarding hardware support for LabVIEW, refer to
Appendix B, Hardware Capabilities, in the LabVIEW Function and VI
Reference Manual, or the LabVIEW Online Reference, by selecting
Help»Online Reference.
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Chapter 2 Installing and Configuring Your Data Acquisition Hardware

Installing and Configuring Your
National Instruments Device

Some DAQ devices have jumpers to set analog input polarity, input mode,
analog output reference, and so on. Before you install your device, check
your hardware user manuals to see if your device has jumpers and how to
change its settings. You then can determine whether you need to change
any jumper settings. Record any jumper settings that you change so that
you can enter the information correctly in the configuration utility.

The next step depends on what version of NI-DAQ you have. Go to the
appropriate section below to continue the configuration of your devices.

Installing and Configuring Your DAQ Device Using NI-DAQ 5.x, 6.x

You can refer to the online help for specific instructions on how to install
and configure your DAQ device. If you are using Windows 9x/NT with
NI-DAQ 6.5 or higher, refer to the help file for Measurement &
Automation Explorer by selecting Help»Help Topics»DAQ Help. If you
are using an earlier version of NI-DAQ for Windows, you can find the help
file in Start»>Programs»LabVIEW»NI-DAQ Configuration Utility
Help. If you are using a Macintosh, you can find the help file in the Help
menu of the NI-DAQ Configuration Utility.

Configuring Your DAQ Device Using NI-DAQ 4.8.x on the Macintosh

ke

NI-DAQ

After you check and record your jumper settings, turn off your computer
and insert your National Instruments devices.

Turn your computer back on. You can find NI-DAQ in your control
panels folder. The NI-DAQ icon looks like the one shown to the left.
Double-click on this icon to launch NI-DAQ.

When you launch the program, NI-DAQ displays a list of all of the devices
in your computer. Each device has a list of attributes, as shown in

Figure 2-3. The number specified in the device line is the logical device
number that NI-DAQ assigned to the device. You use this number in
LabVIEW as the device number to select that device for any operation.
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Fi=——— NI-DAl ——
1‘.;?’ 4.8.5
#° [Help] [Devices |
Active Devices - i
device: z
niame : PCI-1200
type: 353
bus: FCl
socket:
address: C:20204000
device: 3
niame : PCI-010-96
type: 352
bus: FCl
socket: [
address: Oxc20201000
[

Figure 2-3. NI-DAQ Device Window Listing

Now show the Device Configuration window by selecting the
Device Configuration option from the menu as shown in Figure 2-4.

E=—— NI-Dil =——

- 4.8.5 |
»

 Devices
Device Configuration

Help

Active DeVITery | Configuration &
device: Errors |
name: FLT=T.200
type: 353
bus: FCI
socket:
address: O:20204000
device: 2
name : FCI-D10-25
type: 352
bus: FCI
socket: ci
address: C:20201000
i

Figure 2-4. Accessing the Device Configuration Window in NI-DAQ

Figure 2-5 shows the NI-DAQ Device Configuration window. When you
are in the Device Configuration window of the utility, you can edit the
default settings for parameters, such as analog input polarity and range
on a per-device basis. If you are using AMUX-64T or signal conditioning
devices with your DAQ device, select the appropriate device using the
Accessories menu. LabVIEW uses these settings when initializing the
device instead of the default settings listed in the descriptions of the
hardware configuration VIs. (You can use these VIs to change any

setting recorded by NI-DAQ.) When you click on the name of the device,
NI-DAQ displays the I/O connector for the device, as shown in Figure 2-5.
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Installing and Configuring Your SCXI Chassis

Installing and Configuring Your Data Acquisition Hardware

EO=—— NI-Dil =——

1!‘?[ 4.8.5

Help ] [Device Configuration |

] 2 Te]rc 1 200

1/0 Subsystem|ADC 0 |
Polarity[Bipolar | Mode[Refer... |
Range[101  |speed

Accessories[None |

channelf<] 0 [z]
Coupling[DC | Gain[1 |
LE - 2E4E Gab

ACHO
ACHZ
ACH4
ACHE
AIGHD
ACGHD
OGHO
FA1
FAZ
FAS
FA7
FE1
FEZ
FES
FE?
FC1
PC3
PCS
PC?
EXTUFDOATE*
auTED
OuTE 1
CLEET
GATEEZ
+5 U

2 [ACH1

4 |ACHZ2

6 [ACHS

2  [ACH?

9 [ 10 [DRCO OUT
11] 12 |DACT OUT
12 | 14 |PRO

15 | 16 |PRZ

17 | 12 |PR4

19 | 20 |PRG
21|22 |PEO

23 | 24 |FBZ2

25 | 26 |FB4

27 | 28 |PBE

29 | 20 |PCO

21| 22 |PC2

22 134 |PC4

25 | 26 |PCE

27 |28 EXTTRIG
29 | 40 |EXTCOHU*
41 | 42 |GATEED
43 | 44 |GARTEE1
45 | 46 |0UTEZ

47 | 48 |CLKEZ

49 | 50 |DGHD

PC1-1200

Figure 2-5. Device Configuration and I/0 Connector Windows in NI-DAQ

You also can find additional information by clicking the Help button. If at
any time during configuration you need to view a list of the LabVIEW DAQ
error codes and their meanings, you can do so by clicking on the NI-DAQ
menu bar, located to the right of the Help button, and choosing Errors.

Note Some DAQ devices, such as the Lab-NB and NB-MIO-16 devices, require hardware
jumper changes in addition to software configuration. Consult your DAQ device hardware
reference manual for more information.

The following section describes the procedures for installing and

configuring your SCXI chassis.

Hardware Configuration

Your SCXI hardware kit includes the Getting Started with SCXI manual,
which contains detailed instructions for assembling your SCXI system,
module jumper settings, cable assemblies, and terminal blocks.

LabVIEW Data Acquisition Basics Manual 2-16
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The following are the basic steps you must complete to assemble your
SCXI system:

1.

7.

Check the jumpers on your modules. Generally, you will leave the
jumpers in their default positions. However, the Getting Started with
SCXI manual contains a section for each module type that lists cases
where you might want to change the jumper settings.

Turn off the chassis power. Plug in your modules through the front of
the chassis. You can put the modules in any slot. For simplicity, start
with slot 1 on the left side of the chassis and move right with each
additional module. Be sure to tightly screw the modules into the
chassis frame.

If you are using an SCXI-1180 feedthrough panel, you must install the
SCXI-1180 in the slot immediately to the right of the module that you
will cable to the DAQ device. Otherwise, the cable connectors might
not fit together conveniently.

If you have more than one chassis, select a unique jumpered address
for each additional chassis by using the jumpers directly behind the
front panel of the chassis.

Plug the appropriate terminal blocks into the front of each module and
screw them tightly into the chassis frame.

If you are using a DAQ device in your computer to control your
SCXI chassis, connect the mounting bracket of the SCXI-134x
(where x is a number) cable assembly to the back of one of the modules
and screw it into the chassis frame. Connect the other end of the cable
to the DAQ device in your computer. In multiplexed mode, you need
to connect only one module to the DAQ device. In most cases, it does
not matter which module you cable. The following are two special
cases where you must cable a specific module to the device:

a. If you use SCXI-1140 modules with other types of modules, you
need to cable one of the SCXI-1140 modules to the DAQ device.

b. If you use analog input modules and other types of modules, you
need to cable one of the analog input modules to the DAQ device.

Turn on your chassis power.

Refer to the Getting Started with SCXI manual for more information about
related topics, such as multichassis cabling.

© National Instruments Corporation
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NI-DAQ 5.x, 6.x Software Configuration

You can refer to the online help for specific instructions on how to install
and configure your DAQ device. If you are using Windows 9x/NT with
NI-DAQ 6.5 or higher, refer to the help file for Measurement &
Automation Explorer by selecting Help»Help Topics»DAQ Help. If you
are using an earlier version of NI-DAQ for Windows, you can find the help
file in Start»Programs»LabVIEW»NI-DAQ Configuration Utility
Help. If you are using a Macintosh, you can find the help file in the Help
menu of the NI-DAQ Configuration Utility.

NI-DAQ 4.8.x for Macintosh Software Configuration

To use SCXI with LabVIEW and NI-DAQ 4.8.x, you must enter
the configuration for each SCXI chassis using NI-DAQ. Select
SCXI Configuration in the NI-DAQ menu bar to bring up the
SCXI Configuration window as shown in Figure 2-6.

SI=———— NI-DAl ——

v Devices

- «Device Configuration

_P SCHI Configuration

1/0 Subsyst®
Polarity[Bipolar | Mode|Refer... |

Range[10 1 Spaad

Hccessuries|Nnne |

Channel[=]] 0 [=]
Coupling[DC | Ea|n|l |
$E-2048 s,

Figure 2-6. Accessing the NI-DAQ SCXI Configuration Window
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Figure 2-7 shows NI-DAQ with the SCXI Configuration window selected.

Ef=—=— NI-lll "ok
7 4.8.5
#* [Help][SCHI Configuration |

Chassis[<]] 1 [&]=[scHI-1001 |

Method|Serial | Path{None

Module|=] 1 [z]:[scH1-1120

Cabled Device|NMone
Operating Mode|Multiplexed

channelg] 0 []
Filter[4z | Gain[1000 ]

fapal Mo

Figure 2-7. SCXI Configuration Window in NI-DAQ
Follow these steps to configure your SCXI chassis and modules:

1. Leave the Chassis control set to 1 if you have only one chassis. You
will use this number to access the SCXI chassis from your application.
If you have multiple chassis, advance the Chassis control to configure
each subsequent chassis.

2. Select the appropriate chassis type. This activates the remaining fields
on the panel.

3. If you have only one chassis, leave the Address field and the address
jumpers on your SCXI chassis set to 0. If you have additional chassis,
you must select a unique hardware-jumpered address for each chassis
and enter it in the Address field.

4. Leave the Method set to Serial, which means that LabVIEW
communicates with the chassis serially using a DIO port of the plug-in
DAQ device. The Path automatically sets itself to the device number
of the appropriate DAQ device when you enter the Cabled Device
information in step 5b.
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5. Enter the configuration for each slot in the chassis. The fields in the
bottom two sections of the window reflect the settings for the selected
Module number. Refer to your SCXI chassis hardware manual to
determine how the slots in a chassis are numbered. You must set the
following fields for each SCXI module you install:

a.

LabVIEW Data Acquisition Basics Manual

Module type—Select the correct module type for the module
installed in the current slot. If the current slot does not have a
module, leave this field set to None and advance the Module
number to the next slot.

Cabled Device—If the module in the current slot is directly
cabled to a DAQ device in your computer, set this field to the
device number of that DAQ device. Leave the Cabled Device field
set to None if the module in the current slot is not directly cabled
to a DAQ device. If you are operating your modules in multiplexed
mode, you only need to cable one module in each chassis to your
DAQ device. If you are not using multiplexed mode, refer to the
SCXI Operating Modes section of Chapter 19, Hardware and
Software Setup for Your SCXI System, for instructions about
module cabling.

Operating Mode—The system defaults to the multiplexed
operating mode, which is recommended for almost all

SCXT applications. The operating modes available for each
SCXI module type are described in the SCXI Operating Modes
section of Chapter 19, Hardware and Software Setup for Your
SCXI System.

If the module is an analog input module, enter the gain and filter
settings for each channel in the bottom section of the window. The
system disables the Channel control for any modules that use
only one gain and filter setting for the entire module.
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Configuring Your Channels in NI-DAQ 5.x, 6.x

Once you install and configure your hardware, you can configure your
channels. LabVIEW DAQ software includes a channel configuration
application, the DAQ Channel Wizard, you can use to configure the analog
and digital channels on your DAQ device—DAQ plug-in boards,
standalone DAQ products, or SCXI modules. In NI-DAQ 6.5 or higher, the
DAQ Channel Wizard is integrated into Measurement & Automation
Explorer. In NI-DAQ 5.x only analog input channels can be configured.
The DAQ Channel Wizard helps you define the physical quantities you are
measuring or generating on each DAQ hardware channel by querying for
information about the physical quantity being measured, the sensor or
actuator being used, and the associated DAQ hardware.

As you configure channels in the DAQ Channel Wizard, you give each
channel configuration a unique name that is used when addressing your
channels in LabVIEW. The channel configurations you define are saved in
a file that instructs the NI-DAQ driver how to scale and process each DAQ
channel by its name. You can simplify the programming required to
measure your signal by using the DAQ Channel Wizard to configure your
channels.

You can refer to the online help for specific instructions on how to install
and configure your DAQ device. If you are using Windows 9x/NT with
NI-DAQ 6.5 or higher, refer to the help file for Measurement & Automation
Explorer by selecting Help»Help Topics»DAQ Help. If you are using an
earlier version of NI-DAQ for Windows, you can find the help file in
Start»Programs»LabVIEW»NI-DAQ Configuration Utility Help. If
you are using a Macintosh, you can find the help file in the Help menu of
the NI-DAQ Configuration Utility.

Refer to the Channel Name Addressing section of Chapter 3, Basic
LabVIEW Data Acquisition Concepts, for information about how to use
your named channels in LabVIEW.

Now that you have successfully installed and configured your

DAQ hardware for LabVIEW, read Chapter 3, Basic LabVIEW Data
Acquisition Concepts, for more information about data acquisition with
LabVIEW.
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Basic LabVIEW Data
Acquisition Concepts

This chapter explains how data acquisition works with LabVIEW. Before
you start building your data acquisition (DAQ) application, you should
know some of the following basic LabVIEW DAQ concepts:

*  Location of common DAQ examples
e Locating the DAQ VIs in LabVIEW

*  DAQ VI organization

e VI parameter conventions

e Common DAQ VI parameters

*  Default and current value conventions
e Error handling

e Channel, port, and counter addressing
e Limit settings

* Data organization for analog applications

If you do not already understand basic programming concepts in
LabVIEW, refer to the LabVIEW User Manual or the G Programming
Reference Manual for help with programming in LabVIEW.

Location of Common DAQ Examples

The DAQ examples address many common applications involving
data acquisition in LabVIEW. You can find these examples in
labview\examples\dag.

(NI-DAQ 5.x, 6.x) There are two ways to locate DAQ examples. One way is
to run the DAQ Solution Wizard. The other way is to run the Search
Examples Online Help, available in LabVIEW version 5.0 and higher. You
can launch either tool from the LabVIEW launch screen.
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The following list briefly describes the VI libraries (designated by the . 11b
file extension) and directories located in the dag directory.

accessories

anlogin

anlogout

anlog_io

counter

digital

scxi

solution

run_me.llb

Folder containing VIs that work with specific
accessories.

Folder containing VIs that perform analog input and
VIs that write or stream acquired data to disk.

Folder containing VIs that generate single values or
multiple values (waveforms) to output through
analog channels.

Folder containing VIs for analog I/O control loops
and simultaneous analog input and output.

Folder containing VIs that perform various
counter/timer operations.

Folder containing VIs that perform immediate digital
I/O and digital handshaking.

Folder containing VIs for use with specific SCXI
modules.

Folder containing a variety of ready-to-run
application VIs.

Library containing VIs that perform basic operations
concerning analog I/O, digital I/O, and counters.

Each chapter in this manual teaches the basic concepts behind several of the
DAQ examples. For a brief description of any example, open the example
VI and choose Windows»Show VI Info for a text description of the

example. You also can choose Help»Show Help to open the Help window.

LabVIEW Data Acquisition Basics Manual
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Locating the Data Acquisition Vis in LabVIEW

You can find the Data Acquisition VIs in the Functions palette from your
block diagram in LabVIEW. When you put your cursor over each of the
icons in the Functions palette, LabVIEW displays the palette name you are
about to access at the top of the Functions palette. You can find the Data
Acquisition icon near the bottom of the Functions palette, as shown in
Figure 3-1.

Data Acg 0 Display of Palette Name
¥ G
¥

aun

“:]}r / : Data Acquisition Icon
¥ - /
B ErE »

— "' —1HID ata Acquisition

i | % 8, &, a., =, "
Pt L EIm
o] = E e

(81

Figure 3-1. Accessing the Data Acquisition Palette

The Data Acquisition palette contains six subpalette icons that take you to
the different classes of DAQ VIs. Figure 3-2 shows what each of the icons
in the Data Acquisition palette means.

Analog Output VIs  Digital /0 Vis

Ii>! Data Acquisition E
Analog Input Vs B tEy, M. ME. Counter Vs
9P E
Calibration and E- ¢ B,,,-’
Configuration Vls Fireg) |2

Signal Conditioning VIs

Figure 3-2. Data Acquisition VIs Palette
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DAQ VI Organization

In most of the DAQ VI subpalettes, the VIs are arranged in different levels
according to their functionality. You can find some of the following four
levels of DAQ VIs within the DAQ VI subpalettes:

e Easy VIs

e Intermediate VIs
e Utility VIs

e Advanced VIs

A good example of a palette that contains all of the available levels of
DAQ VlIs is the Analog Input palette. Figure 3-3 shows this palette.

=l Analog Input

[ [1] Al ]
HULT PT || HULTFT | | OME FT || OMEFT | g

P e A= ) Easy Analog Input Vls

coirie|| st || rfho |[s-2tan || ciar Intermediate

o] | et P )| Py Analog Input Vs

et il Advanced
v\ Analog Input Vis

Analog Input Utility Vs

Figure 3-3. Analog Input VI Palette Organization

Easy Vls

The Easy VIs perform simple DAQ operations and are typically the first
row of VIs in the DAQ palettes. You can run these VIs from the front panel
or use them as subVlIs in basic applications.

You only need one Easy VI to perform each basic DAQ operation. Unlike
intermediate- and advanced-level VIs, Easy VIs automatically alert you to
errors with a dialog box that allows you to stop the execution of the VI or
to ignore the error.

The Easy VIs usually are composed of Intermediate VIs, which are in turn
composed of Advanced VIs. The Easy VIs provide a basic interface with
only the most commonly used inputs and outputs. For more complex
applications, you should use the intermediate- or advanced-level Vs for
more functionality and better performance.
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Refer to your particular type of VI in the LabVIEW Function and VI
Reference Manual for specific VI information, or refer to the LabVIEW
Online Reference, by selecting Help»Online Reference.

The Intermediate VIs have more hardware functionality and efficiency in
developing your application than the Easy VIs. The Intermediate VIs
contain groups of Advanced VIs, but they use fewer parameters and do not
have some of the more advanced capabilities.

Intermediate VIs give you more control over error-handling than the
Easy VIs. With each VI, you can check for errors or pass the error cluster
on to other VIs.

@ Note Most LabVIEW data acquisition examples shown in this manual are based on the
Intermediate VIs. You can find these example VIs in the examples folder.

Utility VIs

Advanced VIs

The Utility VIs, found in many of the LabVIEW DAQ palettes, are also
intermediate-level VIs and thus have more hardware functionality and
efficiency in developing your application than the Easy Vls.

The Advanced VIs are the lowest-level interface to the DAQ driver. Very
few applications require the use of the Advanced VIs. Use the

Advanced VIs when the Easy or Intermediate VIs do not have the inputs
necessary to control an unusual DAQ function. Advanced VIs return the
greatest amount of status information from the DAQ driver. This manual
primarily focuses on applications using the Easy or Intermediate VIs.

VI Parameter Conventions

In each LabVIEW DAQ VI front panel or Help window, the appearance
of the control and indicator labels denote the importance of that parameter.
Control and indicator names shown in bold are required and must be wired
to a node on the block diagram for your application to run. Parameter
names that appear in plain text are optional and are not necessary for your
program to run. You rarely need to use the parameters with labels in square
brackets ([ ]). Keep in mind that these conventions apply only to the
information in the Help window and on the front panel. Both this manual
and the LabVIEW Function and VI Reference Manual list parameter names
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in bold to distinguish them from other elements of the text. Default input
values appear in parentheses to the right of the parameter names.

Figure 3-4 illustrates these Help window parameter conventions for the
Al Read One Scan VI. As the window text for this VI indicates, you must
wire the device (if you are not using channel names), channels, error in,
and iteration input parameters and the scaled data and error out output
parameters. To pass error information from one VI to another, connect the
error out cluster of the current VI to the error in cluster of the next VI. The
coupling & input config, input limits, output units, and number of
AMUX boards input parameters and the binary data output parameter are
optional.

coupling & input config [no...
input limits [no change]

device [1] FEW sraled data
channels [0] = o & binary data
output units [1] f L= error out

&rrar in (o erar)
iteration [init 0] ———
[Rurnber of AWMU boards] [ho...

Figure 3-4. LabVIEW Help Window Conventions

Default and Current Value Conventions

To use the DAQ VIs, you should know the difference between a default
input, a default setting, and a current setting. A default input is the default
value of a front panel control. When you do not wire an input to a terminal
of a VI, the default input for the control associated with that terminal passes
to the driver. In the Help window, default inputs appear in parentheses to
the right of the parameter names. A default setting is a default parameter
value recorded in the driver. The current setting is the value of a control at
any given moment. The default setting of a control becomes the current
setting and remains so until you change the value of the control.

In many cases, a control input defaults to a certain value (most often 0),
which means you can use the current setting. For example, the default input
for a parameter may be do not change the current setting, and
the current setting may be no AMUX-64T boards. If you change the value
of such a parameter, the new value becomes the current setting.
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Common DAQ VI Parameters

The device input on analog I/0O, digital I/O, and counter VIs specifies the
number assigned to your DAQ device in the DAQ configuration software.
Your software assigns a unique number to each DAQ device. The device
parameter usually appears as an input to the configuration VIs. Another
common configuration VI output, task ID, assigns your specific

I/0 operation and device a unique number that identifies it throughout
your program flow. The task ID can also contain group information about
the channels and gain used in your operation.

Some DAQ VIs perform either the device configuration or the

I/0 operation, while other DAQ VIs perform both configuration and the
operation. The VIs that handle both functions have an iteration input.
When your VI has the iteration set to 0, LabVIEW configures the

DAQ device and then performs the specific I/O operation. For iteration
values greater than 0, LabVIEW uses the existing configuration to perform
the I/O operation. You can improve the performance of your application
by not configuring the DAQ device every time an I/O operation occurs.
Typically, you should wire the iteration input to an iteration terminal in a
loop as shown in the following illustration.

N

[ " aveform 5 can. v
TS
wAYE

Wiring the iteration input this way means the device is only configured
on the first I/O operation. Subsequent I/O operations use the existing
configuration.
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Error Handling

Each Easy VI contains an error handling VI. A dialog box appears
immediately if an error occurs in an Easy VI.

Every Intermediate and Advanced VI contains an error in input cluster and
an error out output cluster, as shown in Figure 3-5. The clusters contain a
Boolean that indicates whether an error occurred, the code for the error, and
source or the name of the VI that returned the error. If error in indicates an
error, the VI passes the error information to error out and does not execute

any DAQ functions.
eror in [ho ernor) error out
code code
na errar I 3*1 0 | o error I 0 |
FOLINCE FOUICE
| | J |

Figure 3-5. LabVIEW Error In Input and Error Out Output Error Clusters

For more information on error handling, refer to Part VII, Debugging Your
Data Acquisition Application, in this manual.

Channel, Port, and Counter Addressing

The Analog Input and Analog Output VIs have a channel list parameter
where you can specify the channels from which the VIs read or to which
they write. The Digital Input and Output VIs have a similar parameter,
called digital channel list and the equivalent value is called counter list
for the Counter Vls.

@ Note To simplify the explanation of channel addressing concepts, the channel list, digital
channel list, and counter list parameters are all referred to as channel list in this section.
Any special exceptions for these parameters are noted.

Each channel you specify in the channel list becomes a member of a group.
For each group, you can acquire or generate data on the channels listed in
the group. VIs scan (during acquisition) or update (during generation) the
channels in the same order they are listed. To erase a group, pass an empty
channel list and the group number to the VI or assign a new channel list
to the group. Changing groups can only be done at the Advanced VI level.
Refer to the LabVIEW Function and VI Reference Manual or the LabVIEW
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Online Reference, by selecting Help»Online Reference, for more
information.

Channel Name Addressing

If you use the DAQ Channel Wizard to configure your analog and digital
channels, you can address your channels by name in the channel list
parameter in LabVIEW. channel list can be an array of strings or, as with
the Easy Vls, a scalar string control, as shown in Figure 3-6. If you have a
channel list array, you can use one channel entry per array element, specify
the entire list in a single element, or use any combination of these two.

If you enter multiple channel names in channel list, all of the channels in
the list must be configured for the same DAQ device. If you configure
channels with names of temperature and pressure, both of which are
measured by the same DAQ device, you can specify a list of channels

in a single element by separating them by commas—for example
temperature, pressure. In specifying channel names, spelling and
spaces are important, but case is not.

Channel String Armray Control

ﬂﬂ | |temperature | |pressure | ‘

Channel String Aray Control

=0 | lremperature, pressure | |

Channel String Control

remperature. pressure |

Figure 3-6. Channel String Controls

Using channel names, you do not need to wire the device, input limits,
or input config input parameters. The device input is always ignored
by LabVIEW when using channel names. LabVIEW configures your
hardware in terms of your channel configuration.

@ Tip Unless you need to overwrite your channel name configuration, do not wire input
limits or input config. Allow LabVIEW to set them up for you. In addition, LabVIEW
orders and pads the channels specified in channel list for you as needed according to any
special device requirements.
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Channel Number Addressing

If you are not using channel names to address your channels, you can
address your channels by channel numbers in the channel list parameter.
The channel list can be an array of strings or, as with the Easy VIs, a
scalar string control. If you have a channel list array, you can use one
channel entry per array element, specify the entire list in a single element,
or use any combination of these two methods. For instance, if 0, 1, and 2
are your channels, you can specify a list of channels in a single element by
separating the individual channels by commas—for example, 0, 1, 2.
Or, because 0 refers to the first channel in a consecutive channel range and
2 refers to the last channel, you can specify the range by separating the first
and last channels with a colon—for example, 0: 2.

Some Easy and Advanced Digital VIs and Intermediate Counter VIs only
need one port or counter to be specified. For more information, refer to the
LabVIEW Function and VI Reference Manual or the LabVIEW Online
Reference. You also can choose Help»Show Help and put your cursor on
the VI to view the VI Help window for the VI you intend to use.

LabVIEW recognizes three types of analog channels on a DAQ device:
onboard, AMUX-64T, and SCXI channels. It recognizes two types of
digital ports and counters: onboard and SCXI. This section describes
addressing onboard channels, ports, and counters. AMUX-64T
addressing is described later in Chapter 5, Things You Should Know
about Analog Input. SCXI channel, port, and counter addressing is
described in Chapter 18, Things You Should Know about SCXI.

Onboard channels refer to analog or digital I/O channels provided by the
plug-in DAQ device. If x is an onboard channel, you can specify this by
entering x or OBx as the channel list element. Refer to the description of
your device in your hardware user manual for restrictions on channel order.
Figure 3-7 shows several ways you can address onboard channels 0, 1,
and 2. The top three examples apply to VIs whose channel parameters are
string arrays. The bottom two examples apply to VIs whose channel
parameters are scalar strings.
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Channel String Array Contral

- O |

Channel String Array Control

O N | ]

Channel Sting Armray Control

o — ]

Channel String Contral

0.2

Channel String Contral

n1.2

Figure 3-7. Channel String Array Controls

Refer to Appendix B, Hardware Capabilities, in the LabVIEW Function and VI

Reference Manual for the number of channels your device can acquire data from at one
time, or refer to the LabVIEW Online Reference, by selecting Help»Online Reference.

Limit Settings

© National Instruments Corporation

Limit settings are the maximum and minimum values of the analog
signal(s) you are measuring or generating. The pair of limit setting values
can be unique for each analog input or output channel. For analog input
applications, the limit setting values must be within the range for the
device. For more information on the range for your device, refer to
Chapter 5, Things You Should Know about Analog Input.

Each pair of limit setting values forms a cluster. Analog output limits have
a third member, the reference source. For simplicity, LabVIEW refers to
limit settings as a pair of values. LabVIEW uses an array of these clusters
to assign limits to the channels in your channel string array.

If you use the DAQ Channel Wizard to configure your analog input
channels, the unit applied to the limit settings is the physical unit you
specified for a particular channel name in the DAQ Channel Wizard.

For example, if you configured a channel in the DAQ Channel Wizard

to have physical units of Deg C, the limit settings are treated as limits in
degrees Celsius. LabVIEW configures your hardware to make the
measurement in terms of your channel name configuration. Unless you
need to overwrite your channel name configuration, do not wire this input.
Allow LabVIEW to set it up for you.
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@ Note For NI-DAQ 6.5 and higher, the DAQ Channel Wizard is part of Measurement &
Automation Explorer.

If you are not using the DAQ Channel Wizard, the default unit applied to
the limit settings is usually volts, although the unit applied to the limit
settings may be volts, current, resistance, or frequency, depending on the
capability and configuration of your device.

The default range of the device, set in the configuration utility or by
LabVIEW according to the channel name configuration in the

DAQ Channel Wizard, is used whenever you leave the limit settings
terminal unwired or you enter 0 for your upper and lower limits.

As the previous Channel, Port, and Counter Addressing section explains,
LabVIEW uses an array of strings to specify which channels belong to a
group. Also, remember LabVIEW lists one channel to as many as all of the
device’s channels in a single array element in the channel string array.
LabVIEW also assigns all the channels listed in a channel string array
element the same settings in the corresponding limit settings cluster array
element. Figure 3-8 illustrates one case of this.

Channel 0 [z | &1 | #= &7 I

Array

Limit =] high limit I high limit CF high limit

Settings 000 | 2500 | 2100

g:"':;e' low i low fimit lows i
Hl10.00 =/5.00 =\

Figure 3-8. Limit Settings, Case 1

In this example, channels 0:3 (or 0, 1, 2, and 3) are assigned limits of
10.00 to —10.00. Channel 4 has limits of 5.00 to —=5.00. Channels 5, 6,
and 7 have limit settings of 1.00 to 0.00.

If the limit settings cluster array has fewer elements than the channel
string array, LabVIEW assigns any remaining channels the limit settings
contained in the last entry of the limit settings cluster array. Figure 3-9
illustrates this case.
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Channel 0 X 1 2 -
Chamnel G0 57— 8T i # 57—
Array
Limit E high lirnit
Settings HH0.00
Cluster lows lirit
i H10.00

Figure 3-9. Limit Settings, Case 2

In this example, channels 0, 1, 2, and 3 have limits of 10.00 to —10.00.
There are more channels left, but the limit settings cluster array is
exhausted. Therefore, the remaining channels (4, 5, 6, and 7) are also
assigned limits of 10.00 to —10.00.

The Easy Analog Input VIs have only one pair of input limits. This pair
forms a single cluster element. If you specify the default limit settings, all
channels scanned with these VIs will have identical limit settings. The Easy
Analog Output VIs do not have limit settings. All the Intermediate VIs,
both analog input and output, have the channel string array and the limit
settings (or input limits) cluster array on the same VI. Assignment of
limits to channels works exactly as described above. Refer to the LabVIEW
Function and VI Reference Manual for more information on how to assign
limit settings to a particular analog channel using the Advanced Vs, the
Group Config VI and the Hardware Config VI, or refer to the LabVIEW
Online Reference, by selecting Help»Online Reference.

In analog applications, you not only specify the range of the signal, you
must also specify the range and the polarity of the device. A unipolar range
is a range containing either positive or negative values, but never both.

A bipolar range is a range that has both positive and negative values.
When a device uses jumpers or DIP switches to select its range and
polarity, you must enter the correct jumper setting in the configuration
utility.

In DAQ hardware manuals and in the configuration utility, you may find
reference to the concept of gain. Gain is the amplification or attenuation
of a signal. Most National Instruments DAQ devices have programmable
gains (no jumpers), but some SCXI modules require the use of jumpers
or DIP switches. For all DAQ devices used with LabVIEW, the gain is
determined by limit settings. However, for some SCXI modules, you must
enter the gain in the configuration utility.
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Data Organization for Analog Applications

If you acquire data from more than one channel multiple times, the data is
returned as a two-dimensional (2D) array. If you were to create a 2D array
and label the index selectors on a LabVIEW front panel, the array might
look like Figure 3-10.

column

fow %g

Figure 3-10. Example of a Basic 2D Array

The two vertically arranged boxes on the left are the row and column index
selectors for the array. The top index selects a row, and the bottom index
selects a column.

You can organize data for a 2D array in one of two ways. First, you can
organize the data by rows. If the array contained data from analog input
channels, this would mean that each row holds data from one channel.
Selecting a row selects a channel. Selecting a column selects a scan of data.
This ordering method is often referred to as row major order. When you
create data in a nested For Loop, the inner loop creates a row for each
iteration of the outer loop. If you were to label your index selectors for a
row major 2D array, the array might look like Figure 3-11.

channel g lch, se0 | |ch0, sc1 |ch, sc2 | chO, sc3

scan gl lchl, zc0 | ok, 221 | chi, 2c2 |chi, &3
lch2, se0 | |ch2, sc1 ||ch2, sc2 ||ch2, sc3
lchd, 20 | ch3, sl | ch3, 2c2 | ch3, =03

Figure 3-11. 2D Array in Row Major Order

You also can organize 2D array data by columns. The Analog Input VIs in
LabVIEW organize their data in this way. Each column holds data from one
channel, so selecting a column selects a channel. Selecting a row selects
a scan of data. This ordering method is often called column major order.
If you were to label your index selectors for a column major 2D array, the
array might look like Figure 3-12.
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sCan g lec0, okl | |zcO, chl | ecO, ch2 | ecO, ch3
channel U lzc1, chld |zc1.chl |sel, ch2 | lscl. ch3
lzc2, ok | |zc2, chl | lac2, ch2 | ecZ. ch3
|z, chl | =z chl |[se3 ch2 | s, ch3

Figure 3-12. 2D Array in Column Major Order

To graph a column major order 2D array, you must configure the waveform
chart or graph to treat the data as transposed by turning on this option in the
graph pop-up menu.

@ Note This option appears in gray until you wire the 2D array to a graph. To convert
the data to row major order, select Functions»Array & Cluster»Transpose 2D Array.

To extract a single channel from a column major 2D array, use the Index
Array function from Functions»Array & Cluster. Add a dimension so
that you have two black rectangles in the lower left corner. The top
rectangle selects the row, and the bottom rectangle selects the column. Pop
up on the row rectangle and select Disable Indexing. Now, when you select
a column (or channel) by wiring your selection to the bottom rectangle, the
Index Array function produces the entire column of data as a 1D array, as
shown in Figure 3-13.

Calurin major
20 Aray Index Aray

Single Channel

Chatirel

Figure 3-13. Extracting a Single Channel from a Column Major 2D Array

Analog output buffers that contain data for more than one channel are also
column major 2D arrays. To create such an array, first make the data from
each output channel a 1D array. Then select the Build Array function from
Functions»Array & Cluster. Add as many input terminals (rows) to the

Build Array terminal as you have channels of data. Wire each 1D array to
the Build Array terminal to combine these arrays into a single row major

2D array. Then use the Transpose 2D Array function to convert the array to
a column major array.
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The finished array is ready for the AO Write VI, as shown in Figure 3-14.
Channel 0 Transpoze,
E‘_ Build Arra
=
Channel 1
[pBL]

Figure 3-14. Analog Output Buffer 2D Array

Calumni major
20 any

[oBL]
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Where You Should Go Next

This chapter directs you to the chapter in the manual best suited to
answer questions about your data acquisition application. You answer

a series of questions that help determine the purpose of your application.
At first, the questions are general and then become more focused until
you are referred to a specific section in the manual dealing with your
type of application.

@ Note This manual is divided into parts. You always should read the Things You Should
Know About chapter at the beginning of each part specific to your application. The Things
You Should Know About chapters teach you about basic concepts dealing with your
application.

Use the following flowchart as a guide as you answer the questions that
follow it. The questions should pinpoint the sections in the manual you
should read for your particular application.
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Questions You Should Answer

1. Measuring Device—DAQ Device or SCXI Module?

Are you working in a noisy environment? If you are, then you may
have SCXI modules connected to your DAQ device or the parallel port
of your computer. SCXI modules can filter and isolate noise from
signals. They can also amplify low signals. SCXI modules expand the
number of channels to acquire or generate data.

DAQ devices are primarily used alone when extra signal conditioning
is not necessary.

If you are using a DAQ device, then read question 2. If you are using
SCXI, go to Part V, SCXI—Getting Your Signals in Great Condition.

2. Analog or Digital Signal Analysis?

Does your signal have two discrete values that are TTL signals? If so,
then you have a digital signal. Otherwise, you have an analog signal.
The type of information you would need to know from an analog signal
is the level (discrete value), shape, and frequency content.

3. Analog or Digital Signal Acquisition or Generation?

If you want to measure and analyze signals from a source outside the
computer, you want to acquire signals. If you want to send signals to
an outside instrument to control its operation, then you want to
generate signals.

If you want to acquire analog signals, go to question 5. If you want to
generate analog signals, refer to question 6. If you want to acquire and
generate analog signals, refer to the Using Analog Input/Output
Control Loops section of Chapter 6, One-Stop Single-Point
Acquisition.

If you want to acquire or generate digital signals, read the next
question.
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Digital or Counter Interfacing?

Digital I/O interfaces primarily with binary operations, such as turning
external equipment on or off or sense logic states, such as the on/off
position of the switch. Counters generate individual digital pulses or
waves or count digital events, like how many times a digital signal rises
or falls in value.

If you are performing digital I/O, refer to question 9. If you need to use
counters, read question 10.

Single-Point or Multiple-Point Acquisition?

Do you want to acquire a signal value(s) at one time or over a period
of time at a certain rate? If you measure a signal at a given instant of
time, you are performing single-point acquisition. If you measure
signals over a period of time at a certain rate, then you are performing
multiple-point or waveform acquisition.

If you want single-point acquisition, refer to Chapter 6, One-Stop
Single-Point Acquisition. If you want multiple-point acquisition, read
question 7.

Single-Point or Multiple-Point Generation?

Are you outputting a steady (DC) signal or are you generating a
changing signal at a certain rate? A constant or slowly changing signal
output is called single-point generation. The output of a changing
signal at a certain rate is called multiple-point or waveform generation.

If you want to perform single-point generation, refer to Chapter 11,
One-Stop Single-Point Generation. If you want multiple-point
generation, refer to Chapter 12, Buffering Your Way through
Waveform Generation.

Triggering a Signal or Using a Clock?

You can start an analog acquisition when a certain analog or digital
value occurs by triggering the acquisition.

If you want to trigger an analog acquisition, refer to Chapter 8,
Controlling Your Acquisition with Triggers.
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Multiple-Point Acquisition with an Internal or External Clock?

Multiple point or waveform acquisition can be done at a rate set by an
internal DAQ device clock or an external clock. The external clock will
be a TTL signal produced at a certain rate.

If you want to acquire a waveform at the rate of an external signal, refer
to Chapter 9, Letting an Outside Source Control Your Acquisition
Rate. If not, read Chapter 7, Buffering Your Way through Waveform
Acquisition.

Non-Latched or Latched Digital I/0?

If you want your program to read the latest digital input or immediately
write a new digital output value, you should use non-latched
(immediate) digital I/O. When a DAQ device accepts or transfers data
after a digital pulse has been received, it is called latched (handshaked)
digital I/O. With latched digital I/O, you can store the values you want
to transfer in a buffer. Only one value will be transferred after each
handshaked pulse.

If you want to use non-latched (immediate) digital I/O, refer to
Chapter 16, When You Need It Now— Immediate Digital I/0. If you
need to perform latched (handshaked) digital I/O, refer to Chapter 17,
Shaking Hands with a Digital Partner.

Counters—Counting or Generating Digital Pulses?

If you want to generate digital pulses from a counter at a certain rate,
read Chapter 24, Generating a Square Pulse or Pulse Trains. If you
want to measure the width of a digital pulse, refer to Chapter 25,
Measuring Pulse Width. If you want to measure the frequency or
period of a digital signal, refer to Chapter 26, Measuring Frequency
and Period. If you just want to count how many times a digital signal
rises or falls, refer to Chapter 27, Counting Signal Highs and Lows. To
learn how to slow the frequency of a digital signal, refer to Chapter 28,
Dividing Frequencies.
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Part I

Catching the Wave with Analog Input

This section contains basic information about acquiring data with
LabVIEW, including acquiring a single point or multiple points,

triggering your acquisition, and using outside sources to control

acquisition rates.

Part I1, Catching the Wave with Analog Input, contains the following
chapters:

© National Instruments Corporation

Chapter 5, Things You Should Know about Analog Input, explains
basic concepts on using analog input with LabVIEW.

Chapter 6, One-Stop Single-Point Acquisition, shows you how to
acquire one data point from a single channel and then one data point
from each of several channels using LabVIEW, and explains how
software-timing and/or hardware-timing affects the performance of
analog /0.

Chapter 7, Buffering Your Way through Waveform Acquisition,
reviews the different methods of reading multiple channels and
explains how LabVIEW stores the acquired data with each method.

Chapter 8, Controlling Your Acquisition with Triggers, explains how
to set your analog acquisition to occur at a certain time using either
software or hardware triggering methods.

Chapter 9, Letting an Outside Source Control Your Acquisition Rate,
shows you how to control your data acquisition rate by some other
external source in your system.
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Things You Should Know
about Analog Input

Hunting has been a part of survival from the beginning of time. People
used to hunt for the things they needed to survive, like food and water.
Today, engineers and scientists use data acquisition to “hunt down” the
information they need to survive in the information age. This chapter
focuses on defining the tools you need to be a successful hunter in the
world of data acquisition.

Defining Your Signal

You and your friends plan a hunting trip for this weekend. What do you
plan to bring with you? This question is really not valid, because you must
know first what you will be hunting before you pack your fishing pole or
elephant rifle. The same idea applies to scientists and engineers engaged
in the quest for information. You must know the defining characteristics
of what you want to “hunt,” be it a wild animal or an analog signal.

You cannot just say, “I will hunt voltages,” or even “I will hunt analog
voltages.” Voltages come in various forms. This chapter gives you the
terms, tools, and techniques designed to help show you the best way to
catch your wave.

Analog signals can be divided into three categories: DC, time domain, and
frequency domain. You must ask yourself, “Is the information I seek
primarily contained in the level, the shape, or the frequency content of my
signal?” Figure 5-1 illustrates which signals correspond to certain types of
signal information.

DC —  ADC/DAC 0.985 Level
(slow) —
Analog Signal Time Domain ADC/DAC | | Shape
(fast)
Frequency Domain  —ADC (fast) |M_‘_LA__>| Freq. Content

AnaIyS|s

Figure 5-1. Types of Analog Signals
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You might be saying to yourself, “I know that I have a thermocouple and
that the primary information (temperature) is contained in the level of the
analog voltage. Now I am ready to go hunting!” Well, you are almost ready
to hunt, but you first must figure out a few more signal characteristics
before you can begin. For example, to what is your signal referenced? How
fast does the signal vary with time? The rate you sample determines how
often the A/D conversions take place. A fast sampling rate acquires more
points in a given time, and therefore can often form a better representation
of the original signal than a slow sampling rate. According to the Nyquist
Theorem, you must sample at a rate greater than twice the maximum
frequency component in that signal to get accurate frequency information
about that signal. The frequency at one half the sampling frequency is
referred to as the Nyquist frequency. For more information on the Nyquist
frequency, refer to the section Sampling Considerations in Chapter 11,
Introduction to Analysis in LabVIEW, of the LabVIEW User Manual.

What Is Your Signal Referenced To?

Signals come in two forms: referenced and non-referenced signal sources.
More often, referenced sources are said to be grounded signals, and
non-referenced sources are called floating signals.

Grounded Signal Sources

Grounded signal sources have voltage signals that are referenced to a
system ground, such as earth or a building ground. Devices that plug into a
building ground through wall outlets, such as signal generators and power
supplies, are the most common examples of grounded signal sources, as
shown in Figure 5-2.

Ground /77

Figure 5-2. Grounded Signal Sources
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Floating Signal Sources

Floating signal sources contain a signal, such as a voltage, that is not
connected to an absolute reference, such as earth or a building ground.
Some common examples of floating signals are batteries, battery-powered
sources, thermocouples, transformers, isolation amplifiers, and any
instrument that explicitly floats its output signal. Notice that in Figure 5-3
neither terminal of the floating source is connected to the electrical outlet
ground.

Vs

Ground / 7 7

Figure 5-3. Floating Signal Sources

Now that you know how your signal is referenced, read on to learn about
the different systems available to acquire these signals.
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Choosing Your Measurement System

Resolution

Now that you have defined your signal, you must choose a measurement
system. You have an analog signal, so you must convert the signal with an
ADC measurement system, which converts your signal into information
the computer can understand. Some of the issues you must resolve before
choosing a measurement system are your ADC bit resolution, device range,
and signal range.

The number of bits used to represent an analog signal determines the
resolution of the ADC. You can compare the resolution on a DAQ device
to the marks on a ruler. The more marks you have, the more precise your
measurements. Similarly, the higher the resolution, the higher the number
of divisions into which your system can break down the ADC range, and
therefore, the smaller the detectable change. A 3-bit ADC divides the
range into 23 or 8 divisions. A binary or digital code between 000 and 111
represents each division. The ADC translates each measurement of the
analog signal to one of the digital divisions. Figure 5-4 shows a sine wave
digital image as obtained by a 3-bit ADC. Clearly, the digital signal does
not represent the original signal adequately, because the converter has too
few digital divisions to represent the varying voltages of the analog signal.
By increasing the resolution to 16 bits, however, the ADC’s number of
divisions increases from 8 to 65,536 (2!6). The ADC can now obtain an
extremely accurate representation of the analog signal.

Amplitude (volts)

16-Bit Versus 3-Bit Resolution
(5 kHz Sine Wave)

10.00
8.75
7.50¢
6.25f
5.00
3.75
2.50
1.25

0 50 100 150 200
Time (us)

Figure 5-4. The Effects of Resolution on ADC Precision

LabVIEW Data Acquisition Basics Manual 5-4 www.natinst.com



Chapter 5 Things You Should Know about Analog Input

Device Range

Range refers to the minimum and maximum analog signal levels that the
ADC can digitize. Many DAQ devices feature selectable ranges, so you can
match the ADC range to that of the signal to take best advantage of the
available resolution. For example, in Figure 5-5, the 3-bit ADC, as shown
in the left chart, has eight digital divisions in the range from 0 to 10 V. If
you select a range of —10.00 to 10.00 V, as shown in the right chart, the
same ADC now separates a 20 V range into eight divisions. The smallest
detectable voltage increases from 1.25 to 2.50 V, and you now have a
much less accurate representation of the signal.

Range=0to 10V Range =-10to 10V

10.00 10.00
8.75 1 7.50 1
7.50
6.25}
5.00
3.75
2.50
1.25

Amplitude (volts)
Amplitude (volts)

0 50 100 150 200 0 50 100 150 200
Time (us) Time (us)

Figure 5-5. The Effects of Range on ADC Precision
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Signal Limit Settings

Limit settings are the maximum and minimum values of the signal you are
measuring. A more precise limit setting allows the ADC to use more
digital divisions to represent the signal. Figure 5-6 shows an example of
this theory. Using a 3-bit ADC and a device range setting of 0.00 to
10.00 V, Figure 5-6 shows the effects of a limit setting between 0 and 5 V
and 0 and 10 V. With a limit setting of 0 to 10 V, the ADC uses only four
of the eight divisions in the conversion. But using a limit setting of 0to 5 V,
the ADC now has access to all eight digital divisions. This makes the digital
representation of the signal more accurate.

10.00 i
8.75
. 110
101
6.25
100
V.  5.00
3.75 01
\ 010 [
250 \ Limit Settings 0 to 10 V.
mi ettngs (o]
1 o5 001 g
0.00 000
10.00
8.75
7.5
6.25
vV 5.00 1
3.75 g)?
250 \ %J(% Limit Settings 0to 5 V
\ 010
1.25 001
0.00 000
Limit Settings 0to 5 V

Figure 5-6. The Effects of Limit Settings on ADC Precision

LabVIEW Data Acquisition Basics Manual 5-6 www.natinst.com



Chapter 5 Things You Should Know about Analog Input

Considerations for Selecting Analog Input Settings

The resolution and device range of a DAQ device determine the smallest
detectable change in the input signal. You can calculate the smallest
detectable change, called the code width, using the following formula.

device range

Zresolution

code width =

For example, a 12-bit DAQ device with a O to 10 V input range detects a
2.4 mV change, while the same device with a—10 to 10 V input range
detects only a change of 4.8 mV.

device range 10 _
resolution ST 24 mv
2 2
device range 20
zresolulion = 5_12 = 48mV

A high-resolution A/D converter provides a smaller code width given the
device voltage ranges shown above.

devi 10
devicerange _ 10 _ 15y
device range _ 2_1(2 - 3mV

Zresolution

The smaller your code width, the more accurate your measurements
will be.

There are times you must know whether your signals are unipolar or
bipolar. Unipolar signals are signals that range from 0 value to a positive
value (for example, 0 to 5 V). Bipolar signals are signals that range from a
negative to a positive value (for example, -5 to 5 V). To achieve a smaller
code width if your signal is unipolar, specify that the device range is
unipolar, as shown previously. If your signal range is smaller than the
device range, you should set your limit settings to values that more
accurately reflect your signal range. Table 5-1 shows how the code width
of the 12-bit DAQ devices vary with device ranges and limit settings,
because your limit settings automatically adjust the gain on your device.
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Table 5-1. Measurement Precision for Various Device Ranges and Limit Settings
(12-bit A/D Converter)

Device Voltage Range Limit Settings Precision!
OtolI0V Oto 10V 2.44 mV
Oto5V 1.22 mV
0to25V 610 uv
0to 125V 305 uV
OtolV 244 uvV
0t00.1V 244 uvV
0to20 mV 4.88 uv
-Sto5V -S5to5V 2.44 mV
251025V 1.22 mV
-1.25t01.25V 610 uv
—0.625t0 0.625 V 305 uv
-0.5t00.5V 244 uv
-50 to 50 mV 24.4 uV
—10 to 10 mV 4.88 uv
-10to 10V -10t0 10V 4.88 mV
-Sto5V 2.44 mV
-25t025V 1.22 mV
-1.25t01.25V 610 uv
1tolV 488 uV
0.1t00.1V 48.8 uV
20 to 20 mV 9.76 uV
!'The value of 1 Least Significant Bit (LSB) of the 12-bit ADC. In other words, the voltage
increment corresponding to a change of 1 count in the ADC 12-bit count.

For more information on the device range and limit settings for your device,
refer to the tables in Appendix B, Hardware Capabilities, in the LabVIEW
Function and VI Reference Manual, or to the LabVIEW Online Reference,
available by selecting Help»Online Reference. In these tables, there is
information on gain settings for each device. For more information on gain,
refer to the Limit Settings section of Chapter 3, Basic LabVIEW Data
Acquisition Concepts.

Now that you know which kind of ADC to use and what settings to use
for your signal, you can connect your signals to be measured. On most
DAQ devices, there are three different ways to configure your device to
read the signals: differential, referenced single-ended (RSE), and
nonreferenced single-ended (NRSE).
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Differential Measurement System

Chapter 5

Things You Should Know about Analog Input

In a differential measurement system, you do not need to connect either
input to a fixed reference, such as earth or a building ground. DAQ devices
with instrumentation amplifiers can be configured as differential
measurement systems. Figure 5-7 depicts the 8-channel differential
measurement system used in the MIO series devices. Analog multiplexers
increase the number of measurement channels while still using a single
instrumentation amplifier. For this device, the pin labeled AIGND

(the analog input ground) is the measurement system ground.

MUX

CHO+ O——————0 0

—

CH2+ o————1—0 0O

CH1+ o——1—0 0

CH7+ o0————+—0 0

MUX

CHO- O0————1—0 0O
CH2- o0———1—0 0

CHl-o————1—0 o

CH7-o————F+——o0 0o

Instrumentation Amplifier

+

o
AIGND
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Figure 5-7. 8-Channel Differential Measurement System
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In general, a differential measurement system is preferable because it
rejects not only ground loop-induced errors, but also the noise picked up in
the environment to a certain degree. Use differential measurement systems
when all input signals meet the following criteria:

e Low-level signals (for example, less than 1 V)

*  Long or non-shielded cabling/wiring traveling through a noisy
environment

*  Any of the input signals require a separate ground-reference point or
return signal

An ideal differential measurement system reads only the potential
difference between its two terminals—the positive (+) and negative (-)
inputs. Any voltage present at the instrumentation amplifier inputs with
respect to the amplifier ground is called a common-mode voltage. An ideal
differential measurement system completely rejects (does not measure)
common-mode voltage, as shown in Figure 5-8.

