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Important Information

Warranty

The NI 7811R/7813R/7830R/7831R/7833R/7841R/7842R/7851R/7852R/7853R/7854R is warranted against defects in materials and
workmanship for a period of one year from the date of shipment, as evidenced by receipts or other documentation. National Instruments will,
at its option, repair or replace equipment that proves to be defective during the warranty period. This warranty includes parts and labor.

The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, due to defects in
materials and workmanship, for a period of 90 days from date of shipment, as evidenced by receipts or other documentation. National Instruments
will, at its option, repair or replace software media that do not execute programming instructions if National Instruments receives notice of such defects
during the warranty period. National Instruments does not warrant that the operation of the software shall be uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of the package before any
equipment will be accepted for warranty work. National Instruments will pay the shipping costs of returning to the owner parts which are covered by
warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed for technical accuracy. In
the event that technical or typographical errors exist, National Instruments reserves the right to make changes to subsequent editions of this document
without prior notice to holders of this edition. The reader should consult National Instruments if errors are suspected. In no event shall National
Instruments be liable for any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS ANY WARRANTY OF
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL
INSTRUMENTS SHALL BE LIMITED TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER. NATIONAL INSTRUMENTS WILL NOT BE LIABLE FOR DAMAGES RESULTING
FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF. This limitation of
the liability of National Instruments will apply regardless of the form of action, whether in contract or tort, including negligence. Any action against
National Instruments must be brought within one year after the cause of action accrues. National Instruments shall not be liable for any delay in
performance due to causes beyond its reasonable control. The warranty provided herein does not cover damages, defects, malfunctions, or service
failures caused by owner’s failure to follow the National Instruments installation, operation, or maintenance instructions; owner’s modification of the
product; owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, flood, accident, actions of third parties, or other events outside
reasonable control.

Copyright

Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying,
recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National
Instruments Corporation.

National Instruments respects the intellectual property of others, and we ask our users to do the same. NI software is protected by copyright and other
intellectual property laws. Where NI software may be used to reproduce software or other materials belonging to others, you may use NI software only
to reproduce materials that you may reproduce in accordance with the terms of any applicable license or other legal restriction.

Trademarks

National Instruments, NI, ni.com, and LabVIEW are trademarks of National Instruments Corporation. Refer to the Terms of Use section
on ni.com/legal for more information about National Instruments trademarks.

Other product and company names mentioned herein are trademarks or trade names of their respective companies.

Members of the National Instruments Alliance Partner Program are business entities independent from National Instruments and have no agency,
partnership, or joint-venture relationship with National Instruments.

Patents

For patents covering National Instruments products, refer to the appropriate location: Help»Patents in your software, the patents. txt file
on your media, or ni.com/patents.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS

(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL OF
RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL COMPONENTS IN
ANY LIFE SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO CAUSE SIGNIFICANT
INJURY TO A HUMAN.

(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS CAN BE
IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL POWER SUPPLY,
COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE FITNESS, FITNESS OF COMPILERS
AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION, INSTALLATION ERRORS, SOFTWARE AND HARDWARE
COMPATIBILITY PROBLEMS, MALFUNCTIONS OR FAILURES OF ELECTRONIC MONITORING OR CONTROL DEVICES,
TRANSIENT FAILURES OF ELECTRONIC SYSTEMS (HARDWARE AND/OR SOFTWARE), UNANTICIPATED USES OR MISUSES, OR
ERRORS ON THE PART OF THE USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS THESE ARE HEREAFTER
COLLECTIVELY TERMED “SYSTEM FAILURES”). ANY APPLICATION WHERE A SYSTEM FAILURE WOULD CREATE A RISK OF
HARM TO PROPERTY OR PERSONS (INCLUDING THE RISK OF BODILY INJURY AND DEATH) SHOULD NOT BE RELIANT SOLELY
UPON ONE FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM FAILURE. TO AVOID DAMAGE, INJURY, OR DEATH,
THE USER OR APPLICATION DESIGNER MUST TAKE REASONABLY PRUDENT STEPS TO PROTECT AGAINST SYSTEM FAILURES,
INCLUDING BUT NOT LIMITED TO BACK-UP OR SHUT DOWN MECHANISMS. BECAUSE EACH END-USER SYSTEM IS
CUSTOMIZED AND DIFFERS FROM NATIONAL INSTRUMENTS' TESTING PLATFORMS AND BECAUSE A USER OR APPLICATION
DESIGNER MAY USE NATIONAL INSTRUMENTS PRODUCTS IN COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT
EVALUATED OR CONTEMPLATED BY NATIONAL INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS ULTIMATELY
RESPONSIBLE FOR VERIFYING AND VALIDATING THE SUITABILITY OF NATIONAL INSTRUMENTS PRODUCTS WHENEVER
NATIONAL INSTRUMENTS PRODUCTS ARE INCORPORATED IN A SYSTEM OR APPLICATION, INCLUDING, WITHOUT
LIMITATION, THE APPROPRIATE DESIGN, PROCESS AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.



Compliance

Compliance with FCC/Canada Radio Frequency Interference
Regulations

Determining FCC Class

The Federal Communications Commission (FCC) has rules to protect wireless communications from interference. The FCC
places digital electronics into two classes. These classes are known as Class A (for use in industrial-commercial locations only)
or Class B (for use in residential or commercial locations). All National Instruments (NI) products are FCC Class A products.

Depending on where it is operated, this Class A product could be subject to restrictions in the FCC rules. (In Canada, the
Department of Communications (DOC), of Industry Canada, regulates wireless interference in much the same way.) Digital
electronics emit weak signals during normal operation that can affect radio, television, or other wireless products.

All Class A products display a simple warning statement of one paragraph in length regarding interference and undesired
operation. The FCC rules have restrictions regarding the locations where FCC Class A products can be operated.

Consult the FCC Web site at www . fcc . gov for more information.

FCC/DOC Warnings

This equipment generates and uses radio frequency energy and, if not installed and used in strict accordance with the instructions
in this manual and the CE marking Declaration of Conformity*, may cause interference to radio and television reception.
Classification requirements are the same for the Federal Communications Commission (FCC) and the Canadian Department
of Communications (DOC).

Changes or modifications not expressly approved by NI could void the user’s authority to operate the equipment under the
FCC Rules.

Class A

Federal Communications Commission

This equipment has been tested and found to comply with the limits for a Class A digital device, pursuant to part 15 of the FCC
Rules. These limits are designed to provide reasonable protection against harmful interference when the equipment is operated
in a commercial environment. This equipment generates, uses, and can radiate radio frequency energy and, if not installed and
used in accordance with the instruction manual, may cause harmful interference to radio communications. Operation of this
equipment in a residential area is likely to cause harmful interference in which case the user is required to correct the interference
at their own expense.

Canadian Department of Communications
This Class A digital apparatus meets all requirements of the Canadian Interference-Causing Equipment Regulations.
Cet appareil numérique de la classe A respecte toutes les exigences du Reglement sur le matériel brouilleur du Canada.

Compliance with EU Directives

Users in the European Union (EU) should refer to the Declaration of Conformity (DoC) for information* pertaining to the
CE marking. Refer to the Declaration of Conformity (DoC) for this product for any additional regulatory compliance
information. To obtain the DoC for this product, visit ni .com/certification, search by model number or product line,
and click the appropriate link in the Certification column.

* The CE marking Declaration of Conformity contains important supplementary information and instructions for the user or
installer.
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About This Manual

Conventions

This manual describes the electrical and mechanical aspects of the
National Instruments 781xR/783xR/784xR/785xR devices and contains
information about programming and using the devices.

»

> &

> B

bold

italic

The following conventions appear in this manual:

Angle brackets that contain numbers separated by an ellipsis represent
a range of values associated with a bit or signal name—for example,
AO <3..0>.

The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options directs you to
pull down the File menu, select the Page Setup item, and select Options
from the last dialog box.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to
avoid injury, data loss, or a system crash. When this symbol is marked on a
product, refer to the Safety Information section of Chapter 1, Introduction,
for information about precautions to take.

When symbol is marked on a product, it denotes a warning advising you to
take precautions to avoid electrical shock.

When symbol is marked on a product, it denotes a component that may be
hot. Touching this component may result in bodily injury.

Bold text denotes items that you must select or click in the software, such
as menu items and dialog box options. Bold text also denotes parameter
names.

Italic text denotes variables, emphasis, a cross-reference, or an introduction
to a key concept. Italic text also denotes text that is a placeholder for a word
or value that you must supply.

© National Instruments Corporation vii R Series Intelligent DAQ User Manual
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monospace

Multifunction R Series

NI 78xxR

Platform

Text in this font denotes text or characters that you should enter from the
keyboard, sections of code, programming examples, and syntax examples.
This font is also used for the proper names of disk drives, paths, directories,
programs, subprograms, subroutines, device names, functions, operations,
variables, filenames, and extensions.

Multifunction R Series refers to the NI 783xR, NI 784xR, and NI 785xR,
which provide both analog and digital 1/O.

NI 781xR, 783xR, NI 784xR, and NI 785xR refer to all PXI and PCI
R Series devices.

Text in this font denotes a specific platform and indicates that the text
following it applies only to that platform.

Related Documentation

Reconfigurable 1/0 Documentation

This manual is one piece of the documentation set for your reconfigurable
I/0 system and application. Depending on the hardware and software
you use for your application, you could have any of several types of
documentation. The documentation includes the following documents:

e Getting Started with R Series Intelligent DAQ—This document
explains how to install and configure NI 781xR/783xR/784xR/785xR,
and contains a tutorial that demonstrates how to begin taking a
measurement using LabVIEW FPGA. This document is available at
Start»All Programs»National Instruments»NI-RIO. This
document is also available at ni.com/manuals.

e NIR Series Intelligent DAQ Specifications— Lists the specifications of
the NI 781xR/783xR/784xR/785xR R Series devices. This document is
available at Start»All Programs»National Instruments»NI-RIO.
This document is also available at ni . com/manuals.

e LabVIEW FPGA documentation

—  Getting Started with LabVIEW FPGA 8.x—This KnowledgeBase,
available at ni . com/kb, provides links to the top resources that
can be used to assist in getting started with programming in
LabVIEW FPGA.

—  FPGA Module book in the LabVIEW Help—Select Help»Search
the LabVIEW Help in LabVIEW to view the LabVIEW Help.
Browse the FPGA Module book in the Contents tab for
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information about using the FPGA Module to create VIs that run
on the NI 78xxR device.

—  LabVIEW FPGA Module Release and Upgrade Notes—Contains
information about installing the LabVIEW FPGA Module,
describes new features, and provides upgrade information.

To access this document, refer to ni . com/manuals. In
LabVIEW 8.0 or later, you can also view the LabVIEW Manuals
directory that contains this document by selecting Start»All
Programs»National Instruments»LabVIEW»LabVIEW
Manuals.

e LabVIEW Real-Time documentation

—  Getting Started with the LabVIEW Real-Time Module—Provides
exercises to teach you how to develop a real-time project and Vs,
from setting up RT targets to building, debugging, and deploying
real-time applications. This document provides references to the
LabVIEW Help and other Real-Time Module documents for more
information as you create the real-time application. To access this
document, refer to ni . com/manuals. In LabVIEW 8.0 or later,
you can also view the LabVIEW Manuals directory that contains
this document by selecting Start»All Programs»National
Instruments»LabVIEW»LabVIEW Manuals.

—  Real-Time Module book in the LabVIEW Help—Select Help»
Search the LabVIEW Help in LabVIEW to view the LabVIEW
Help. Browse the Real-Time Module book in the Contents tab
for information about how to build deterministic applications
using the LabVIEW Real-Time Module.

—  LabVIEW Real-Time Module Release and Upgrade
Notes—Includes information about system requirements,
installation, configuration, new features and changes, and
compatibility issues for the LabVIEW Real-Time Module.

To access this document, refer to ni . com/manuals. In
LabVIEW 8.0 or later, you can also view the LabVIEW Manuals
directory that contains this document by selecting Start»All
Programs»National Instruments»LabVIEW»LabVIEW
Manuals.
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Additional Resources

The following documents contain information you might find helpful:

R Series Intelligent DAQ User Manual

NI Developer Zone tutorial, Field Wiring and Noise Considerations

for Analog Signals, at ni . com/zone

PICMG CompactPCI 2.0 R3.0
PXI Hardware Specification Revision 2.1
PXI Software Specification Revision 2.1

National Instruments Example Finder—LabVIEW contains an
extensive library of VIs and example programs for use with R Series
devices. To access the NI Example Finder, open LabVIEW and select
Help»Find Examples, then select Hardware Input and Output»
R Series.

LabVIEW FPGA IPNet—Offers resources for browsing,
understanding, and downloading LabVIEW FPGA functions or IP
(Intellectual Property). Use this resource to acquire IP that you need
for your application, download examples to help learn programming
techniques, and explore the depth of IP offered by the LabVIEW
FPGA platform. To access the LabVIEW FPGA IPNet, visit

ni.com/ipnet.
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Introduction

This chapter describes the NI 781xR/783xR/784xR/785xR, the concept of
the Reconfigurable I/0 (RIO) device, optional software and equipment for
using the NI 78xxR, and safety information about the NI 78xxR.

About the Reconfigurable 1/0 Device

Table 1-1 lists an overview of the NI 78xxR R Series Intelligent DAQ RIO

devices.

Table 1-1. NI 78xxR R Series Intelligent DAQ RIO Device Overview

Device I/O Channels FPGA Al Sample Rate

NI PCI/PXI-7811R 160 DIO Virtex-1I XC2V1000 —

NI PCI/PXI-7813R 160 DIO Virtex-II XC2V3000 —

NI PCI/PXI-7830R 4 Al 4 AO, 56 DIO Virtex-II XC2V1000 200 kS/s
NI PCI/PXI-7831R 8 Al 8 AO, 96 DIO Virtex-II XC2V1000 200 kS/s
NI PCI/PXI-7833R 8 Al 8 AO, 96 DIO Virtex-1I XC2V3000 200 kS/s
NI PXI-7841R 8 AL 8 AO, 96 DIO Virtex-5 LX30 200 kS/s
NI PXI-7842R 8 AL 8 AO, 96 DIO Virtex-5 LX50 200 kS/s
NI PXI-7851R 8 Al 8 AO, 96 DIO Virtex-5 LX30 750 kS/s
NI PXI-7852R 8 Al 8 AO, 96 DIO Virtex-5 LX50 750 kS/s
NI PXI-7853R 8 Al 8 AO, 96 DIO Virtex-5 LX85 750 kS/s
NI PXI-7854R 8 Al 8 AO, 96 DIO Virtex-5 LX110 750 kS/s

A user-reconfigurable FPGA (Field-Programmable Gate Array) controls
the digital I/O lines on the NI 781xR, and the digital and analog I/O lines
on the NI 783xR/784xR/785xR. The FPGA on the R Series device allows
you to define the functionality and timing of the device. You can change the
functionality of the FPGA on the R Series device in LabVIEW using the
LabVIEW FPGA Module to create and download a custom virtual

© National Instruments Corporation
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Chapter 1

Introduction

instrument (V1) to the FPGA. Using the FPGA Module, you can
graphically design the timing and functionality of the R Series device.

If you only have LabVIEW but not the FPGA Module, you cannot create
new FPGA VIs, but you can create VIs that run on Windows or a LabVIEW
Real-Time (RT) target to control existing FPGA VIs.

Some applications require tasks such as real-time, floating-point
processing or datalogging while performing I/O and logic on the R Series
device. You can use the LabVIEW Real-Time Module to perform these
additional applications while communicating with and controlling the

R Series device.

The R Series device contains flash memory to store a startup VI for
automatic loading of the FPGA when the system is powered on.

The NI 78xxR uses the Real-Time System Integration (RTSI) bus to easily
synchronize several measurement functions to a common trigger or timing
event. R Series PCI devices access the RTSI bus through a RTSI cable
connected between devices. R Series PXI devices access the RTSI bus
through the PXI trigger lines implemented on the PXI backplane.

Refer to the NI R Series Intelligent DAQ Specifications, available at
ni.com/manuals, for detailed device specifications.

Using PXI with CompactPClI

Using PXI-compatible products with standard CompactPCI products is an
important feature provided by PXI Hardware Specification Revision 2.1
and PXI Software Specification Revision 2.1. If you use a PXI-compatible
plug-in card in a standard CompactPCI chassis, you cannot use
PXI-specific functions, but you still can use the basic plug-in card
functions. For example, the RTSI bus on the R Series device is available
in a PXI chassis but not in a CompactPCI chassis.

The CompactPCI specification permits vendors to develop sub-buses that
coexist with the basic PCI interface on the CompactPCI bus. Compatible
operation is not guaranteed between CompactPCI devices with different
sub-buses nor between CompactPCI devices with sub-buses and PXI.
The standard implementation for CompactPCI does not include these
sub-buses. The R Series device works in any standard CompactPCI chassis
adhering to the PICMG CompactPCI 2.0 R3.0 core specification.

R Series Intelligent DAQ User Manual 1-2 ni.com
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PXI-specific features are implemented on the J2 connector of the
CompactPCI bus. Table 1-2 lists the J2 pins used by the NI PXI-78xxR.
The NI 78xxR is compatible with any CompactPCI chassis with a sub-bus
that does not drive these lines. Even if the sub-bus is capable of driving
these lines, the R Series device is still compatible as long as those pins on
the sub-bus are disabled by default and are never enabled.

A Caution Damage can result if the J2 lines are driven by the sub-bus.

Table 1-2. Pins Used by the NI PXI-78xxR

NI PXI-78xxR Signal

PXI Pin Name PXI J2 Pin Number

PXI Trigger<0..7>

PXI Trigger<0..7> Al6, Al17, A18,B16, B18, C18, E16, E18

PXI Clock 10 MHz

PXI Clock 10 MHz E17

PXI Star Trigger

PXI Star Trigger D17

LBLSTAR<O..12>"

LBL<0..12> Al, Al19,C1, C19, C20, D1, D2, D15, D19,
El, E2, E19, E20

LBR<0..12>"

LBR<0..12> A2, A3, A20, A21, B2, B20, C3, C21,
D3, D21, E3, E15, E21

* NI PXI-781xR/783xR only

Overview of Reconfigurable 1/0

This section explains reconfigurable I/O and describes how to use the
LabVIEW FPGA Module to build high-level functions in hardware.

Refer to Chapter 2, Hardware Overview of the NI 78xxR, for descriptions
of the I/O resources on the NI 78xxR.

Reconfigurable 1/0 Concept

R Series Intelligent DAQ devices are based on a reconfigurable FPGA core
surrounded by fixed I/O resources for analog and digital input and output.
You can configure the behavior of the reconfigurable FPGA to match the
requirements of the measurement and control system. You can implement
this user-defined behavior as an FPGA VI to create an application-specific
I/0O device.
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Flexible Functionality

Flexible functionality allows the NI 78xxR to match individual application
requirements and to mimic the functionality of fixed I/O devices. For
example, you can configure an R Series device in one application for
three 32-bit quadrature encoders and then reconfigure the R Series device
in another application for eight 16-bit event counters.

You also can use the R Series device with the LabVIEW Real-Time
Module in timing and triggering applications, such as control and
hardware-in-the-loop (HIL) simulations. For example, you can configure
the R Series device for a single timed loop in one application and then
reconfigure the device in another application for four independent timed
loops with separate I/O resources.

User-Defined 1/0 Resources

You can create your own custom measurements using the fixed I/O
resources. For example, one application might require an event counter that
increments when a rising edge appears on any of three digital input lines.
With a multifunction R Series device, another application might require a
digital line to be asserted after an analog input exceeds a programmable
threshold. You can implement these behaviors in the hardware for fast,
deterministic performance.

Device-Embedded Logic and Processing

You can implement LabVIEW logic and processing in the FPGA of the
R Series device. Typical logic functions include Boolean operations,
comparisons, and basic mathematical operations. You can implement
multiple functions efficiently in the same design, operating sequentially or
in parallel. You also can implement more complex algorithms such as
control loops. You are limited only by the size of the FPGA.
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Reconfigurable 1/0 Architecture

Figure 1-1 shows an FPGA connected to fixed I/O resources and a bus
interface. The fixed I/O resources include A/D converters (ADCs),
D/A converters (DACs), and digital I/O lines.

<:> Fixed 1/0 Resource I
<:> Fixed 1/O Resource I
FPGA <:> Fixed /O Resource |

<::I) Fixed 1/0O Resource I

Bus Interface

Figure 1-1. High-Level FPGA Functional Overview

Software accesses the R Series device through the bus interface, and the
FPGA connects the bus interface and the fixed I/O to make possible timing,
triggering, processing, and custom I/O measurements using the LabVIEW
FPGA Module.

The FPGA logic provides timing, triggering, processing, and custom I/O
measurements. Each fixed I/O resource used by the application uses a small
portion of the FPGA logic that controls the fixed I/O resource. The bus
interface also uses a small portion of the FPGA logic to provide software
access to the device.

The remaining FPGA logic is available for higher-level functions such as
timing, triggering, and counting. The functions use varied amounts of logic.

You can