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 Important Information

Warranty
The PCI-FBUS is warranted against defects in materials and workmanship for a period of one year from the date of shipment, as evidenced by 
receipts or other documentation. National Instruments will, at its option, repair or replace equipment that proves to be defective during the 
warranty period. This warranty includes parts and labor. 

The media on which you receive National Instruments software are warranted not to fail to execute programming instructions, due to defects 
in materials and workmanship, for a period of 90 days from date of shipment, as evidenced by receipts or other documentation. National 
Instruments will, at its option, repair or replace software media that do not execute programming instructions if National Instruments receives 
notice of such defects during the warranty period. National Instruments does not warrant that the operation of the software shall be 
uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside of the package before 
any equipment will be accepted for warranty work. National Instruments will pay the shipping costs of returning to the owner parts which are 
covered by warranty.

National Instruments believes that the information in this document is accurate. The document has been carefully reviewed for technical 
accuracy. In the event that technical or typographical errors exist, National Instruments reserves the right to make changes to subsequent 
editions of this document without prior notice to holders of this edition. The reader should consult National Instruments if errors are suspected. 
In no event shall National Instruments be liable for any damages arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS ANY WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED BY FAULT OR NEGLIGENCE ON THE PART OF 
NATIONAL INSTRUMENTS SHALL BE LIMITED TO THE AMOUNT THERETOFORE PAID BY THE CUSTOMER. NATIONAL INSTRUMENTS WILL NOT BE LIABLE FOR 
DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS, OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY 
THEREOF. This limitation of the liability of National Instruments will apply regardless of the form of action, whether in contract or tort, including 
negligence. Any action against National Instruments must be brought within one year after the cause of action accrues. National Instruments 
shall not be liable for any delay in performance due to causes beyond its reasonable control. The warranty provided herein does not cover 
damages, defects, malfunctions, or service failures caused by owner’s failure to follow the National Instruments installation, operation, or 
maintenance instructions; owner’s modification of the product; owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, 
flood, accident, actions of third parties, or other events outside reasonable control.

Copyright
Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical, including photocopying, 
recording, storing in an information retrieval system, or translating, in whole or in part, without the prior written consent of National 
Instruments Corporation.

Trademarks
FieldPoint™, LabVIEW™, Lookout™, National Instruments™, NI™, ni.com™, NI-FBUS™, and NI-FMON™ are trademarks of 
National Instruments Corporation.

Product and company names mentioned herein are trademarks or trade names of their respective companies.

Patents
For patents covering National Instruments products, refer to the appropriate location: Help»Patents in your software, the patents.txt file 
on your CD, or ni.com/patents.

WARNING REGARDING USE OF NATIONAL INSTRUMENTS PRODUCTS
(1) NATIONAL INSTRUMENTS PRODUCTS ARE NOT DESIGNED WITH COMPONENTS AND TESTING FOR A LEVEL OF 
RELIABILITY SUITABLE FOR USE IN OR IN CONNECTION WITH SURGICAL IMPLANTS OR AS CRITICAL COMPONENTS IN 
ANY LIFE SUPPORT SYSTEMS WHOSE FAILURE TO PERFORM CAN REASONABLY BE EXPECTED TO CAUSE SIGNIFICANT 
INJURY TO A HUMAN.

(2) IN ANY APPLICATION, INCLUDING THE ABOVE, RELIABILITY OF OPERATION OF THE SOFTWARE PRODUCTS CAN BE 
IMPAIRED BY ADVERSE FACTORS, INCLUDING BUT NOT LIMITED TO FLUCTUATIONS IN ELECTRICAL POWER SUPPLY, 
COMPUTER HARDWARE MALFUNCTIONS, COMPUTER OPERATING SYSTEM SOFTWARE FITNESS, FITNESS OF COMPILERS 
AND DEVELOPMENT SOFTWARE USED TO DEVELOP AN APPLICATION, INSTALLATION ERRORS, SOFTWARE AND 
HARDWARE COMPATIBILITY PROBLEMS, MALFUNCTIONS OR FAILURES OF ELECTRONIC MONITORING OR CONTROL 
DEVICES, TRANSIENT FAILURES OF ELECTRONIC SYSTEMS (HARDWARE AND/OR SOFTWARE), UNANTICIPATED USES OR 
MISUSES, OR ERRORS ON THE PART OF THE USER OR APPLICATIONS DESIGNER (ADVERSE FACTORS SUCH AS THESE ARE 
HEREAFTER COLLECTIVELY TERMED “SYSTEM FAILURES”). ANY APPLICATION WHERE A SYSTEM FAILURE WOULD 
CREATE A RISK OF HARM TO PROPERTY OR PERSONS (INCLUDING THE RISK OF BODILY INJURY AND DEATH) SHOULD 
NOT BE RELIANT SOLELY UPON ONE FORM OF ELECTRONIC SYSTEM DUE TO THE RISK OF SYSTEM FAILURE. TO AVOID 
DAMAGE, INJURY, OR DEATH, THE USER OR APPLICATION DESIGNER MUST TAKE REASONABLY PRUDENT STEPS TO 
PROTECT AGAINST SYSTEM FAILURES, INCLUDING BUT NOT LIMITED TO BACK-UP OR SHUT DOWN MECHANISMS. 
BECAUSE EACH END-USER SYSTEM IS CUSTOMIZED AND DIFFERS FROM NATIONAL INSTRUMENTS' TESTING 
PLATFORMS AND BECAUSE A USER OR APPLICATION DESIGNER MAY USE NATIONAL INSTRUMENTS PRODUCTS IN 
COMBINATION WITH OTHER PRODUCTS IN A MANNER NOT EVALUATED OR CONTEMPLATED BY NATIONAL 
INSTRUMENTS, THE USER OR APPLICATION DESIGNER IS ULTIMATELY RESPONSIBLE FOR VERIFYING AND VALIDATING 
THE SUITABILITY OF NATIONAL INSTRUMENTS PRODUCTS WHENEVER NATIONAL INSTRUMENTS PRODUCTS ARE 
INCORPORATED IN A SYSTEM OR APPLICATION, INCLUDING, WITHOUT LIMITATION, THE APPROPRIATE DESIGN, 
PROCESS AND SAFETY LEVEL OF SUCH SYSTEM OR APPLICATION.



 Compliance

FCC/Canada Radio Frequency Interference Compliance

Determining FCC Class
The Federal Communications Commission (FCC) has rules to protect wireless communications from interference. The FCC 
places digital electronics into two classes. These classes are known as Class A (for use in industrial-commercial locations only) 
or Class B (for use in residential or commercial locations). All National Instruments (NI) products are FCC Class A products.

Depending on where it is operated, this Class A product could be subject to restrictions in the FCC rules. (In Canada, the 
Department of Communications (DOC), of Industry Canada, regulates wireless interference in much the same way.) Digital 
electronics emit weak signals during normal operation that can affect radio, television, or other wireless products.

All Class A products display a simple warning statement of one paragraph in length regarding interference and undesired 
operation. The FCC rules have restrictions regarding the locations where FCC Class A products can be operated.

Consult the FCC Web site at www.fcc.gov for more information.

FCC/DOC Warnings
This equipment generates and uses radio frequency energy and, if not installed and used in strict accordance with the instructions 
in this manual and the CE marking Declaration of Conformity*, may cause interference to radio and television reception. 
Classification requirements are the same for the Federal Communications Commission (FCC) and the Canadian Department of 
Communications (DOC). 

Changes or modifications not expressly approved by NI could void the user’s authority to operate the equipment under the FCC 
Rules.

Class A
Federal Communications Commission
This equipment has been tested and found to comply with the limits for a Class A digital device, pursuant to part 15 of the FCC 
Rules. These limits are designed to provide reasonable protection against harmful interference when the equipment is operated 
in a commercial environment. This equipment generates, uses, and can radiate radio frequency energy and, if not installed and 
used in accordance with the instruction manual, may cause harmful interference to radio communications. Operation of this 
equipment in a residential area is likely to cause harmful interference in which case the user is required to correct the interference 
at their own expense.

Canadian Department of Communications
This Class A digital apparatus meets all requirements of the Canadian Interference-Causing Equipment Regulations.

Cet appareil numérique de la classe A respecte toutes les exigences du Règlement sur le matériel brouilleur du Canada.

Compliance to EU Directives
Readers in the European Union (EU) must refer to the manufacturer’s Declaration of Conformity (DoC) for information* 
pertaining to the CE marking compliance scheme. The manufacturer includes a DoC for most hardware products except for those 
bought from OEMs. In addition, DoCs are usually not provided if compliance is not required, for example electrically benign 
apparatus or cables.

To obtain the DoC for this product, click Declarations of Conformity Information at ni.com/hardref.nsf/. This Web site 
lists the DoCs by product family. Select the appropriate product family, followed by your product, and a link to the DoC appears 
in Adobe Acrobat format. Click the Acrobat icon to download or read the DoC.

* The CE marking Declaration of Conformity contains important supplementary information and instructions for the user or 
installer.
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About This Manual

This manual contains instructions on how to install and configure the 

National Instruments PCI-FBUS board and the NI-FBUS software. The 

PCI-FBUS board is intended for use in PCs equipped with PCI slots.

The NI-FBUS software is intended for use with Windows 2000/NT/XP 

because Windows 9x is less robust than Windows 2000/NT/XP. This 

manual is written for users already familiar with their Windows operating 

system.

How To Use the Manual Set

Use the Foundation Fieldbus Overview to learn the basics of Fieldbus. The 

Foundation Fieldbus Overview also includes tutorials to lead you through 

developing a simple Fieldbus application.

Use this getting started manual to install and configure your PCI-FBUS 

board and the NI-FBUS software. To install your PCI-FBUS board in the 

Windows 2000/NT/XP system environment, use the Installation Guide: 

Foundation Fieldbus Hardware and NI-FBUS Software for Windows 

2000/NT/XP.

If you are using the NI-FBUS Configurator, use the NI-FBUS Configurator 

User Manual to install and use the NI-FBUS Configurator software.

If you are using the NI-FBUS Communications Manager Application 

Programmer Interface (API), use the NI-FBUS Communications Manager 

User Manual to learn how to use the NI-FBUS Communications Manager 

API for your application. Use the NI-FBUS Communications Manager 

Function Reference Manual to look up specific information about 

NI-FBUS Communications Manager functions, such as syntax and error 

messages.

Conventions

The following conventions appear in this manual:

» The » symbol leads you through nested menu items and dialog box options 

to a final action. The sequence File»Page Setup»Options directs you to 

pull down the File menu, select the Page Setup item, and select Options 

from the last dialog box.
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This icon denotes a tip, which alerts you to advisory information.

This icon denotes a note, which alerts you to important information.

This icon denotes a caution, which advises you of precautions to take to 

avoid injury, data loss, or a system crash.

PCI-FBUS In this manual, the term PCI-FBUS refers to the dual-port PCI-FBUS/2 

board, unless otherwise indicated.

bold Bold text denotes items that you must select or click in the software, such 

as menu items and dialog box options. Bold text also denotes parameter 

names.

Fieldbus The generic term Fieldbus refers to any bus that connects to field devices. 

This includes Foundation Fieldbus, CAN, DNET, and Profibus. In this 

manual, the term Fieldbus refers specifically to the Foundation Fieldbus.

italic Italic text denotes variables, emphasis, a cross reference, or an introduction 

to a key concept. This font also denotes text that is a placeholder for a word 

or value that you must supply.

monospace Text in this font denotes text or characters that you should enter from the 

keyboard, sections of code, programming examples, and syntax examples. 

This font also is used for the proper names of disk drives, paths, directories, 

programs, subprograms, subroutines, device names, functions, operations, 

variables, filenames and extensions, and code excerpts.

monospace bold Bold text in this font denotes the messages and responses that the computer 

automatically prints to the screen. This font also emphasizes lines of code 

that are different from the other examples.

monospace italic Italic text in this font denotes text that is a placeholder for a word or value 

that you must supply.

NI-FBUS software In this manual, the term NI-FBUS software refers to either the NI-FBUS 

Communications Manager or NI-FBUS Configurator software.

Platform Text in this font denotes a specific platform and indicates that the text 

following it applies only to that platform.
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Related Documentation

The following contain information you might find helpful as you read this 

manual.

General Fieldbus Web sites

• Fieldbus Foundation—responsible for the definition of the Foundation 

Fieldbus specification. www.fieldbus.org

• Relcom, Inc.—Wiring and test equipment for Foundation Fieldbus. 

www.relcominc.com/fieldbus

• Fieldbus, Inc.—Device developers and Foundation Fieldbus 

consulting. www.fieldbusinc.com

Fieldbus system development documentation

• Fieldbus Foundation resources

– Wiring and Installation 31.25 kbit/s, Voltage Mode, Wire Medium 

• Relcom Fieldbus resources online

– Wiring Design and Installation Guide

– Online Tutorial

– FAQ

– Sample Fieldbus Topologies

• Fieldbus Standard for Use in Industrial Control Systems, Part 2, 

ISA-S50.02.1992

Fieldbus device development documentation

• Developing Your First Foundation Fieldbus Device, available from 

the Fieldbus, Inc. Web site at www.fieldbusinc.com 

• Foundation Specification: 31.25 kbit/s Physical Layer Profile for the 

Foundation Fieldbus Physical Layer Specifications

• Function Block Application Process, Part 1

• Function Block Application Process, Part 2

• IEC Standard 1158-2 and ISA Standard ISA S50.02



© National Instruments Corporation 1-1 PCI-FBUS and the NI-FBUS Software

1
Introduction

This chapter lists what you need to get started and includes a brief 

description of the PCI-FBUS board and the NI-FBUS software. 

What You Need to Get Started

To install your NI-FBUS software, you need the following items:

❑ PCI-FBUS board 

❑ Installation disks

❑ Windows 2000/NT/XP installed on your computer

Hardware Description

The PCI-FBUS is a plug-in board that handles communication between a 

network-configurable device that complies with the Fieldbus Foundation 

H1 specification and a PC that has a PCI slot. The PCI-FBUS uses an 

Intel 386EX embedded processor, shared memory, and an interrupt to 

communicate with its driver. The PCI-FBUS supports the Fieldbus 

H1 transfer rate of 31.25 Kbits/s.

In this manual, the term PCI-FBUS refers to the dual-port PCI-FBUS/2 

board, unless otherwise indicated.

Software Description

Your kit includes either the NI-FBUS Communications Manager software 

or the NI-FBUS Configurator software. Depending on the system you 

purchase, you may receive both disks. If this is the case, you should use the 

NI-FBUS Configurator software.

The NI-FBUS Communications Manager software is used by the interface 

boards to communicate over the bus. Additionally, it provides a high-level 

API that allows advanced users to interface with the National Instruments 

Foundation Fieldbus communication stack and hardware. 
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The NI-FBUS Configurator is the most commonly used software of 

the two. In addition to providing the functionality of the NI-FBUS 

Communications Manager in a graphical format, it includes additional 

functionality to allow you to configure a Fieldbus network. It can 

automatically generate the schedule for the network and configure 

field devices and hosts to transmit and receive alarms and trends.

NI-FBUS Interface Configuration Utility
The NI-FBUS Interface Configuration Utility lets you view and change 

the hardware configuration parameters for your Fieldbus interfaces. 

In Windows 2000/NT/XP, you also can edit your hardware configuration 

parameters and add and delete interfaces. 

The NI-FBUS Interface Configuration Utility helps you to configure the 

following information:

• Logical name for each port on your Fieldbus board; you can access the 

port using the interface name

• Device description information

– Base directory for device description files

– Location of the standard text dictionary

You need to import device descriptions if you use the NI-FBUS 

Communications Manager to communicate with devices that have 

manufacturer-specific blocks or parameters.

• Fieldbus communication parameters for each Fieldbus interface

In Windows 2000/NT/XP, the NI-FBUS Configuration Utility 

(fbconf.exe) helps you to configure the number of boards.

Caution Although the NI-FBUS Interface Configuration Utility can be used to set certain 

low-level network software parameters, you should not modify the Advanced parameters 

without good reason. If you must modify parameters for certain devices, the device 

manufacturer will recommend settings. Modifying these parameters can have an adverse 

affect on data throughput rates. If settings are incorrectly modified, some devices might 

disappear off the bus. 

Choosing Configuration Software
Foundation Fieldbus links must be configured. Only with configuration 

software can you do things like set device addresses, clear devices, and 

download, which is necessary if you are setting up a system for the first 

time. Your configuration software must match the interface board your 
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computer is using to connect to the bus. National Instruments offers the 

NI-FBUS Configurator with a National Instruments Foundation Fieldbus 

interface board to let you configure your Fieldbus links.

Interface boards and configuration software are sold separately because 

multiple interface boards can reside in the same computer. The NI-FBUS 

Configurator, by default, is licensed for use on one machine, with up to four 

Fieldbus links (or segments). If you have more than four links (four ports 

on the boards), you need to purchase a link upgrade for each link in excess 

of four. To do so, download the order form from ni.com/fieldbus.

Note The connection to one interface port on the interface board is viewed as one link 

by the NI-FBUS Configurator, regardless of how many links might actually be joined by 

repeaters (important for software licensing of the NI-FBUS Configurator).

If you want to use the board to read and write values only and not configure, 

and you are a programmer, you can make calls to the API in the NI-FBUS 

Communications Manager. In that case you do not need the NI-FBUS 

Configurator. This is possible only if you have already used third-party 

hardware and configuration software to configure the link.

Table 1-1 describes the National Instruments Fieldbus software.

Table 1-1.  National Instruments Fieldbus Software

Software Application Short Name Description File Name

NI-FBUS 

Communications 

Manager

NIFB process “The Blue Box.” This 

must be running for 

you to use your 

PCI-FBUS board as a 

Fieldbus interface to 

communicate between 

the board and the bus.

nifb.exe

NI-FBUS Interface 

Configuration Utility

Interface Config Used to configure your 

PCI-FBUS board.

fbconf.exe

NI-FBUS 

Configurator

NI-FBUS 

Configurator

Used to configure the 

devices on the bus, set 

the parameters for 

control loops, and 

other Fieldbus 

configuration tasks.

fcs.exe
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Optional Fieldbus Network Tools

Your kit includes either the NI-FBUS Communications Manager software, 

NI-FBUS Configurator software, or both. In addition, you can order 

LabVIEW DSC, and/or Lookout from National Instruments. If you have 

not already done so, you can also order the NI-FBUS Configurator.

LabVIEW DSC helps you perform data acquisition and analysis, create 

a human-machine interface (HMI), or develop an advanced supervisory 

control application in a graphical development environment. 

LabVIEW DSC includes real-time process monitoring, historical trending, 

alarm and event reporting, online configuration, and PLC connectivity.

Lookout helps you create graphical representations on a computer screen 

of real-world devices such as switches, dial gauges, chart recorders, 

pushbuttons, knobs, sliders, and meters. After linking these images to your 

field instruments, you can configure Lookout to generate alarms, log data 

to disk, animate custom graphics, print reports, automatically adjust 

setpoints, historically trend information, warn operators of malfunctions, 

and so on.

NI-FBUS Dialog 

System

NI-FBUS Dialog Used to view the 

devices on the bus 

and manually read 

and write parameter 

values. Not for 

configuration.

nifbdlg.exe

Server Explorer Server Explorer Lets you configure 

the attributes of the 

communication 

resource, device, and 

items of your network, 

and the groups and 

items of your OPC 

server.

serverexplorer.exe

Table 1-1.  National Instruments Fieldbus Software (Continued)

Software Application Short Name Description File Name
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2
Installation and Configuration

Install the Software

(Windows 2000/NT/XP) Complete the following steps to install your 

NI-FBUS software. 

Note Install the software before you install your PCI-FBUS hardware.

Caution If you are reinstalling the NI-FBUS software over an existing version, write down 

your board configuration and any port configuration parameters you changed from their 

defaults. Reinstalling may cause you to lose any existing board and port configuration 

information.

1. Log in as Administrator or as a user that has Administrator 

privileges.

2. Insert the NI-FBUS version 3.0 or later CD-ROM.

3. Select Start»Run.

4. In the Run dialog box, type the following:

x:\setup

where x is the letter of the drive containing the NI-FBUS version 3.0 

or later CD-ROM.

5. The interactive setup program takes you through the necessary steps to 

install the software.

6. At the end of the setup, an Add New Board dialog box may appear. 

If you have not yet installed your board, click on Cancel. You will 

install your board in a later step.

The installation program copies nifb.dll and drvintf.dll into your 

\System32 directory, and it copies the nifb.sys driver into the 

\drivers directory. The installation program also adds information to the 

Windows registry. 

Continue to the Install the PCI-FBUS Board section to install your board.
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Install the PCI-FBUS Board

Note Before you install your board, double-check to make sure the settings on your board 

match the resources you have chosen.

1. Shut down your operating system and power off your computer. Keep 

the computer plugged in so that it remains grounded while you install 

the PCI-FBUS board.

2. Remove the top cover or access port of the I/O channel.

3. Remove the expansion slot cover on the back panel of the computer.

4. As shown in Figure 2-1, insert the PCI-FBUS board into any unused 

PCI slot with the Fieldbus connector sticking out of the opening on the 

back panel. Make sure all pins are inserted an equal depth into the 

connector. Although it might be a tight fit, do not force the board into 

place.

 

Figure 2-1.  Installing the PCI-FBUS Board

5. Screw the mounting bracket of the PCI-FBUS board to the back panel 

rail of the computer.

Personal

Computer

PCI/ISA Slot

PCI-FBUS
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6. Keep the top cover or access port off until you have verified that your 

resources are non-conflicting, as described in the Set the NI-FBUS 

Software to Use Your PCI-FBUS Board section.

7. Power on your computer.

8. Launch the Interface Configuration Utility. Find the PCI-FBUS board 

and right-click to Enable.

9. Close the Interface Configuration Utility and start the NI-FBUS 

Communications Manager or NI-FBUS Configurator.

Proceed to the Set the NI-FBUS Software to Use Your PCI-FBUS Board 

section. 

Set the NI-FBUS Software to Use Your PCI-FBUS Board

Note You can only connect one PCI-FBUS port to a link or Fieldbus. 

Set the Communication Parameters and Interface Name
Use the NI-FBUS Interface Configuration Utility to set the Fieldbus 

communication parameters and interface name.

1. Start the NI-FBUS Interface Configuration Utility. Select Start» 

Programs»National Instruments»NI-FBUS»Interface 

Configuration.

2. Select the port you want to edit, and click the Edit button. 

3. The NI-FBUS Interface Configuration Utility displays the default 

interface name and some configuration information.

4. Enter an interface name for the port or use the default name. 

The interface name is for local use on the PC.

5. Enter a unique tag in the Device Tag field or use the default device tag. 

The device tag is the name on the Fieldbus visible to the other devices.
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6. Your interface must be given either a fixed or visitor device address for 

you to start using NI-FBUS. This address must be unique on the link 

to which the interface is connected.

a. To assign a fixed address to your Fieldbus interface, select Fixed 

Address and enter a value in the range 0x10 to 0xF7.

By convention, the lower addresses starting at 0x10 are usually 

used for interface boards and link masters. Upper addresses, 

starting at 0xF7 and working down, are generally used for other 

devices. Using a lower address for your interface will reduce the 

likelihood that the interface will conflict with another device on 

the bus.

b. If you want your interface to be a temporary device that you do not 

intend to connect to the Fieldbus for an extended time, select 

Visitor Address. Over a long period of time, using a visitor 

address could break VCR endpoints and cause a 

VCR_FULL_ERROR.

c. If you want third-party Fieldbus configuration software to assign 

an address to your interface over the Fieldbus, select Default 

Address. You should only select a default address when you want 

third-party configuration software to assign a permanent address. 

A device at a default address cannot be communicated with until 

a permanent address has been assigned by the configuration 

software.

7. Select a Device Type. You should select Link Master Device.

8. Make sure that NI-FBUS is selected for Usage, unless you will be 

using the board in conjunction with the NI-FMON software.

If you are using this interface as a bus monitor, the other interface 

(if this is a two-port board) cannot be used for NI-FBUS. This means 

that you must have another link master on the link—either another 

PCI-FBUS board, or a device with link master capabilities. Refer to the 

Optional Fieldbus Network Tools section of Chapter 1, Introduction, 

for more information.

NI-FBUS assigns default values for other network communication 

parameters. 

Caution Do not modify the Advanced parameters without good reason. If you must 

modify parameters for certain devices, the device manufacturer will recommend settings. 

Modifying these parameters can have an adverse affect on data throughput rates. If settings 

are incorrectly modified, some devices might disappear off the bus.
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9. Click OK, then click OK again to exit the configuration utility.

10. Restart the NIFB process by selecting Start»Programs»National 

Instruments»NI-FBUS»NIFB for the changes you made in the 

NI-FBUS Interface Configuration Utility to take effect.

11. (Windows NT) If you change or delete the interface configuration, you 

must stop and restart the NI-FBUS Communications Manager 

nifb.exe so that the new configuration will take effect. You can start 

or stop the driver by selecting Start»Settings»Control Panel»

NI-FBUS, and clicking the Stop/Start button.

12. Replace the top cover on your computer, if you have not done so 

already.

Test the Installation

(Windows 2000/XP) Start the NIFB process by selecting Start»Programs»

National Instruments»NI-FBUS»NIFB. The NIFB process must be 

running in the background to use any Fieldbus application. 

(Windows NT) To make sure that your NI-FBUS software is installed 

correctly and is working properly, complete the following steps: 

1. After you configure your installation, restart Windows. You must 

restart your computer before you can use the NI-FBUS software.

2. Start the kernel-mode device driver NIFB by selecting Start»

Settings»Control Panel»NI-FBUS and clicking the Start button.

Tip You can have the device driver start automatically when your computer boots. Refer 

to Chapter 3, Start the NIFB Process, for instructions.

3. Start the NIFB process selecting Start»Programs»National 

Instruments»NI-FBUS»NIFB.

On successful startup, the NIFB displays a message saying that the process 

started up successfully, the title bar of the NIFB window changes to 

NI-FBUS (running), and a blue box icon appears on the Windows taskbar. 

It may take a few minutes for NIFB to start up and for this message to 

display.

If NI-FBUS does not start up successfully, the base memory address, IRQ 

line, or Fieldbus network address is incorrect. If the NIFB process does not 

start up successfully, refer to Appendix B, Troubleshooting and 

Common Questions.
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Changing or Deleting Existing Interface Information
(Windows 2000/NT/XP) To change or delete information about any interface 

that you have already entered, complete the following steps:

1. Select Start»Programs»National Instruments»NI-FBUS»

Interface Configuration.

2. Click the Boardx icon, where x refers to the board number of the 

interface you want to change or delete. 

3. Click the Edit button. You can edit the interface configuration 

information that you entered earlier, or click Delete to delete this 

interface entirely.

Interfaces are numbered beginning with zero. If you delete an 

interface, the NI-FBUS Interface Configuration Utility renumbers all 

the remaining interfaces. For example, if you delete Board0, it appears 

that you deleted the last interface, because all the remaining interface 

numbers are decreased by one automatically.

Run the NI-FBUS Interface Configuration Utility once to make sure the 

interface has been removed.

To reinstall the interface, refer to the Install the Software and the Set the 

NI-FBUS Software to Use Your PCI-FBUS Board sections.

Table 2-1.  Board Renumbering

Original Address Address after Deleting Board1

Board0 Board0

Board1 (deleted)

Board2 Board1

Board3 Board2
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Import Device Descriptions

The device description files contain information about the types of blocks 

and parameters supported by your Fieldbus device, along with online help 

describing the uses of given parameters. If your Fieldbus device uses 

manufacturer-specific device description files, you must import the device 

description files (shipped with the device or available from the device 

manufacturer). To do so, complete the following steps:

1. Insert the device description disk or CD (if supplied by your Fieldbus 

device manufacturer) into the disk drive of the host computer.

2. Select Start»Programs»National Instruments»NI-FBUS»

Interface Configuration to run the Interface Configuration Utility.

3. Click the DD Info button. The DD Info dialog box appears.

4. If the base directory field is blank, enter a base directory. The base 

directory you enter here will be where NI-FBUS looks for all device 

descriptions. Do not change the base directory after you have started 

importing device descriptions. If you do, NI-FBUS will not be able to 

find the device descriptions you previously imported. Your device 

description files will automatically be placed in the appropriate 

manufacturer ID subdirectory under this base directory. 

Your base directory will include one folder for each different 

manufacturer for which you have imported a device description. 

For example, if you import the device description for the National 

Instruments FP-3000 device, you will find a folder named 4e4943. 

This is the National Instruments Foundation Fieldbus device 

manufacturer ID number.

The next layer of folders is the device type. For example, the FP-3000 

has a device type ID number of 4005.

Underneath this layer of directories you will find the individual device 

description files (.ffo and .sym). 

5. If necessary, click the Browse button to select the standard text 

dictionary, provided with NI-FBUS. The text dictionary has a .dct 

extension.

6. Click the Import DD button. The Import DD dialog box appears.



Chapter 2 Installation and Configuration

PCI-FBUS and the NI-FBUS Software 2-8 ni.com

7. Click the Browse button and go to the .ffo device description file 

path. Click Open. Typically, the device description for your Fieldbus 

device is supplied on a disk from the manufacturer. For each device, 

there are two device description files, one that ends in .ffo and one 

that ends in .sym. Select the .ffo file, and the corresponding .sym 

file will be imported automatically. The file name will be in the form 

Digit Digit Digit Digit.ffo (for example, 0101.ffo).

Note If you are importing device descriptions for multiple devices, you might see that they 

can have the same filenames. Each file contains information about the device and its 

manufacturer, and will be placed appropriately in the hierarchy under the base directory.

8. Click OK. A window will appear that gives the full path to which 

the .ffo and .sym files were copied.

9. Click OK.

For more information on device descriptions, refer to the Device 

Descriptions section of the Foundation Fieldbus Overview document.

Fieldbus Cable Connector Pinout

If you want to make your own Fieldbus cable, make sure that it uses pins 6 

and 7 for the Fieldbus signals, as shown in Figure 2-2. Also make sure that 

it follows the specification in the Fieldbus Standard for Use in Industrial 

Control Systems, Part 2, ISA-S50.02.1992. The connector pinout of the 

PCI-FBUS is shown in Figure 2-2.

 

Figure 2-2.  Fieldbus Connector Pinout for the PCI-FBUS

1
2

3
4

5

6
7

8
9

No Connection

No Connection 

No Connection

No Connection

No Connection

No Connection

No Connection

Data – 

Data +
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Install and Wire Your Fieldbus Devices

What you need:

❑ Cable compliant with the Fieldbus Standard for Use in Industrial 

Control Systems, Part 2, ISA-S50.02.1992

❑ Terminator(s) with capacitor and resistor of appropriate size

Refer to the documentation that came with your device for complete 

instructions on how to install and wire your Fieldbus devices.

Termination
You must terminate your wiring in compliance with the Foundation 

Fieldbus specification. Foundation Fieldbus requires a resistor and a 

capacitor in parallel. You must place termination appropriately on the 

network, which will depend on your network topology. Refer to the Wiring 

and Installation 31.25 kbit/s, Voltage Mode, Wire Medium document or the 

Relcom, Inc. Wiring Design and Installation Guide document.

Replacing Devices
NI-FBUS is capable of dynamic device replacement. There is no need to 

restart NI-FBUS if a device on the link has its application changed but its 

device ID remains the same.
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3
Start the NIFB Process

The NIFB process must be running any time you want to use your 

PCI-FBUS board as a Fieldbus interface to communicate between the 

board and the bus.

(Windows 2000/XP)

1. Start the NIFB process by selecting Start»Programs»National 

Instruments»NI-FBUS»NIFB.

(Windows NT) If the NIFB kernel-mode driver has not already been started, 

you must do so manually.

1. Start the NIFB kernel-mode driver by selecting Start»Settings»

Control Panel»NI-FBUS and clicking the Start button.

2. Start the NIFB process by selecting Start»Programs»National 

Instruments»NI-FBUS»NIFB.

Note You also can start the driver by entering net start nifb at the command prompt.

If you receive the message System error 31 has occurred, the cause is most likely 

an interrupt or memory address conflict. Set the device to poll mode or change the memory 

address value.

Configure NIFB to Load at System Startup

If the driver and the process start up successfully, you can configure the 

kernel-mode driver (for Windows NT) and NIFB process to start 

automatically when you boot or restart your computer.

Note To do this on a Windows NT machine, you must be running Windows NT 4.0 

or later.

(Windows 2000/XP) Place a shortcut to nifb.exe in your Startup folder.

(Windows NT) Select Start»Settings»Control Panel»NI-FBUS. Click the 

StartUp button. Select Automatic. Then, place a shortcut to nifb.exe in 

your StartUp folder.
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Begin to Use Your NI-FBUS Software

If you are using the NI-FBUS Communications Manager, proceed to the 

NI-FBUS Communication Manager User Manual for information on using 

your software. If you are using the NI-FBUS Configurator, proceed to the 

NI-FBUS Configurator User Manual for information on using your 

software.

If NI-FBUS is unable to connect to and initialize an interface device, 

and you decide to continue NI-FBUS startup, NI-FBUS will not try to 

reconnect to that interface again. This is true of all interface types supported 

by this software.

If a PCI-FBUS interface is configured as a basic device, a link master 

device must be present on this link before NI-FBUS will start up.
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A
Specifications

This appendix describes the electrical, physical, and environmental 

characteristics of the PCI-FBUS hardware and the recommended operating 

conditions.

Power Requirement
PCI-FBUS/2 ........................................... 820 mA Typical

Physical
Dimensions............................................. 10.67 by 17.46 cm 

(4.2 by 6.88 in.)

I/O connector.......................................... DB-9 DSUB 

(1 per Fieldbus link)

Operating Environment
Ambient temperature.............................. 0 to 55 °C

Relative humidity ................................... 10 to 90%, noncondensing

Storage Environment
Ambient temperature.............................. –20 to 70 °C

Relative humidity ................................... 5 to 95%, noncondensing
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Safety
This product is designed to meet the requirements of the following 

standards of safety for electrical equipment for information technology use:

• IEC 60950, EN 60950 

• UL 1950, UL 60950

• CAN/CSA C22.2 No. 60950

Note For UL and other safety certifications, refer to the product label or to ni.com.

Electromagnetic Compatibility
Emissions................................................EN 55011 Class A at 10 m

FCC Part 15A above 1 GHz

Immunity ................................................EN 61326-1:1997/ +A2:2001,

Table 1

CE, C-Tick and FCC Part 15 (Class A) Compliant

For EMC compliance, operate this device with shielded cabling. 

CE Compliance
This product meets the essential requirements of applicable European 

Directives, as amended for CE Marking, as follows:

Low-Voltage Directive (safety)..............73/23/EEC

Electromagnetic Compatibility

Directive (EMC) .....................................89/336/EEC

Note Refer to the Declaration of Conformity (DoC) for this product for any additional 

regulatory compliance information. To obtain the DoC for this product, click Declarations 

of Conformity at ni.com/hardref.nsf/. 
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B
Troubleshooting and 
Common Questions

This appendix describes how to troubleshoot common problems that occur 

while getting started with Fieldbus.

Error Messages

Utility could not access or locate the registry.

• If using Windows 2000/NT/XP, make sure you are logged in to 

Windows with administrator privileges.

• Your registry entries for NI-FBUS may have been deleted or corrupted. 

Uninstall the NI-FBUS software, then reinstall the software as 

described in the Install the Software section of Chapter 2, Installation 

and Configuration.

Board cannot be found.

• Select Start»Programs»National Instruments»NI-FBUS»

Interface Configuration. Make sure your board appears under the list 

of interfaces.

• Make sure the PCI-FBUS driver is started. 

– (Windows 2000/XP) Select Start»Settings»Control Panel»

System» Hardware»Device Manager. Select National 

Instruments FieldBus Interfaces»PCI-FBUS/2, right-click, 

and select Properties. Make sure there are no conflicts.

– (Windows NT) Select Start»Settings»Control Panel»Devices» 

NIFB. Click the Start button. To avoid manual startup in the 

future, click Startup and select Automatic.

VCR_FULL_ERROR.

Delete the board from the Interface Configuration Utility, then reinstall. 
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NIFB Problems

When using the PCI-FBUS board with Windows 2000/NT/XP, NIFB 

returns an error message stating that the board cannot be found.

• Select Start»Programs»National Instruments»NI-FBUS»

Interface Configuration. Make sure your board appears under the list 

of interfaces.

• Make sure the PCI-FBUS driver is started. 

– (Windows 2000/XP) Select Start»Settings»Control Panel»

System» Hardware»Device Manager. Select National 

Instruments FieldBus Interfaces»PCI-FBUS/2, right-click, 

and select Properties. Make sure there are no conflicts.

– (Windows NT) Select Start»Settings»Control Panel»Devices» 

NIFB. Click the Start button. To avoid manual startup in the 

future, click Startup and select Automatic.

When a Fieldbus device is connected to the bus, the NIFB process often 

hangs when the title bar reads Waiting for Startup Completion. 

If I disconnect the cables, it starts fine.

This is probably due to a device address conflict. In the NI-FBUS Interface 

Configuration Utility, make sure that the interface is not at the same address 

as anything else on the link. You also can temporarily give the interface a 

visitor address to troubleshoot this problem.

The NIFB process hangs, does not start up, or never shows that it is 

running. 

• The Fieldbus network address is not unique. Remove the cable from 

the board. Restart the NIFB process. If it runs successfully, there is 

probably a Fieldbus network address conflict. If you have FP-3000 

network modules on the bank, powering off the modules and then 

powering on will cause them to look on the bus for available addresses 

and change addresses if necessary. If this does not solve the problem, 

you can try to change the board address. In the Interface Configuration 

Utility, select the port and click Edit. Make sure that the port does not 

have an address that conflicts with another device on the bus. You also 

can set the interface to a visitor address. In this case, the board will find 

and take an unused address. If this corrects the problem, find and 

change the address of one of the conflicting devices. Return the board 

to a fixed address.
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• Check for multiple copies of nifb.dll on the machine. If multiple 

copies are found, NI-FBUS was incorrectly reinstalled. Uninstall 

NI-FBUS, search for any remaining copies of nifb.dll, delete them, 

then reinstall the software.

• Check how many boards are showing up in the Interface Configuration 

Utility. Make sure that this matches the number of boards in the 

system. Also check that the number of ports match the physical 

hardware (one port versus two port boards).

• Link masters do not always work well together (if you have another 

link master on the link). Try setting the board to be a basic device in 

the Interface Configuration Utility. 

If an PCI-FBUS interface is configured as a basic device, another link 

master device must be present on this link before the NI-FBUS process 

will start up. For more about Basic and Link Master devices, refer to 

the Foundation Fieldbus Overview document.

Interface Configuration Problems

When using the NI-FBUS Interface Configuration Utility on a 

Windows 2000/NT/XP machine, the error message utility could 

not access or locate the registry appears.

1. Make sure you are logged in to Windows with administrator privileges.

2. Your registry entries for NI-FBUS may have been deleted or corrupted. 

Uninstall the NI-FBUS software, then reinstall the software as 

described in the Install the Software section of Chapter 2, Installation 

and Configuration.

In the Interface Configuration Utility, I see more boards than what 

physically exist in the machine.

♦ (Windows 2000/NT/XP) Select Edit for the extra board. In the next window, 

select Delete.

Caution You should not attempt to make unguided changes in the Windows registry. 

Doing so can cause many problems with your system.
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Resolving Resource Conflicts

Put the Board in Polled Mode
Putting the board in polled mode is a good way to eliminate one variable. 

To put the board in polled mode, complete the following steps.

(Windows 2000/NT/XP) Use the Interface Configuration Utility:

1. Select Start»Programs»National Instruments»NI-FBUS»

Interface Configuration.

2. In the Interface Configuration window, select the icon of the board you 

want to change and click the Edit button. If you are adding a board, 

click the Add Interface Device button.

3. Check the Polled Mode checkbox.

Use a Visitor Address
Using a visitor address is a good way to troubleshoot an address conflict 

since the board will find and take an available address.

Problems Using Manufacturer-Defined Features

NI-FBUS uses identifying information in the actual device to locate the 

device description for the device. The identifying information includes four 

resource block parameters: MANUFAC_ID, DEV_TYPE, DEV_REV, and 

DD_REV. If the identifying information is incorrect, NI-FBUS will not be 

able to locate the device description for the device. When it has located the 

device description, NI-FBUS matches the block types in the device 

description with the actual blocks in the device by using the Item ID of the 

block characteristics record. 

If the blocks in the device do not match the blocks in the description, or if 

there is no appropriate device description for the manufacturer, device type, 

device revision, and device description revision being returned by the 

device, then there is a device description mismatch. In either case, 

NI-FBUS uses only the standard dictionary (nifb.dct) and you will be 

unable to use any manufacturer-supplied functionality.
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These parameters can be read from the device resource block. 

The following procedure will help you troubleshoot a 

DD_SIZE_MISMATCH_ERROR by finding out if there is a device 

description available on your computer that matches what your device 

expects.

Complete the following steps to use the NI-FBUS Dialog utility to check 

device description files.

1. Start the NIFB process. Wait until the process has finished initializing.

2. Select Start»Programs»National Instruments»NI-FBUS»

NI-FBUS Dialog.

3. Right-click Open Descriptors and select Expand All.

4. After the expansion is complete, click Cancel to close the Expand All 

window.

5. Right-click the resource block for your device (it should be under 

Open Descriptors»Session»Interface Name»Device Name»VFD 

Name»Resource Block Name). Select Read Object.

6. Select the Read by Name radio button and enter MANUFAC_ID as the 

name. Click the Read button. Write down the hexidecimal number 

found in parenthesis (0xnumber) in the name column of Table B-1.

7. Repeat step 6 for the name DEV_TYPE.

8. Repeat step 6 for the name DEV_REV.

9. Repeat step 6 for the name DD_REV.

10. Repeat steps 5–9 for each device, then close the NI-FBUS Dialog 

utility.

11. In the Interface Configuration Utility, click the DD Info button. Write 

down the base directory specified for device descriptions. Close the 

Interface Configuration Utility.

Table B-1.  Device Names

Resource Block Parameter Name

MANUFAC_ID

DEV_TYPE

DEV_REV

DD_REV
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12. Use Windows Explorer to view the contents of the base directory 

specified in the Interface Configuration Utility. The Fieldbus 

specification defines the directory hierarchy for storing device 

descriptions. There is a different subdirectory for each device 

manufacturer. Under the base directory, you should see a directory 

with the number from step 6 for the first device.

13. Under the appropriate manufacturer directory, there is a directory for 

each device type that you have from that manufacturer. Check to make 

sure that you see a directory with the number from step 7.

14. Under the appropriate device type directory, there are the individual 

device descriptions. The device description file name is a combination 

of the device revision (the number from step 8) and the device 

description revision (the number from step 9). The device revision is 

the first two digits, and the device description revision is the second 

two digits. For example, if your number from step 8 was 2 and from 

step 9 was 1, you should see files called 0201.ffo and 0201.sym. 

Device descriptions are backwards compatible. This means that 

instead of seeing 0201, you might see 0202. This is allowed by the 

Fieldbus specification. Also, having additional files in this directory 

is not a problem. The NI-FBUS Configurator will use the most recent 

device description revision for a given device revision. If you do not 

have the appropriate .ffo and .sym files, you must obtain them from 

the device manufacturer. Be sure to properly import them by clicking 

DD Info and using the Import DD button in the Interface 

Configuration Utility. 

15. Repeat steps 12–14 for each device.

The second cause for this problem is when the contents of the file do 

not accurately describe the device characteristics, even if the device 

identification information matches the file identification information. 

This problem is caused when a device manufacturer makes a change to 

the firmware of the device without incrementing the device revision, in 

violation of the Foundation Fieldbus recommendation. If this is the case, 

you must contact your device manufacturer for a resolution.
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Configuring Advanced Parameters

Caution Do not modify the Advanced parameters without good reason. If you must 

modify parameters for certain devices, the device manufacturer will recommend settings. 

Modifying these parameters can have an adverse affect on data throughput rates. If settings 

are incorrectly modified, some devices might disappear off the bus. 

In the NI-FBUS Interface Configuration Utility, click the Advanced button 

on the dialog box for the port you want to configure. The Advanced Stack 

Configuration dialog box is shown in Figure B-1. 

Figure B-1.  Advanced Stack Configuration Dialog Box

The parameters involved in setting addresses are T1 and T3. These 

parameters represent delay time values that your board uses to compensate 

for the delays inherent in the device and in the set address protocol itself. 

T1 describes the expected response delay of the device at a given address. 

T3 describes the expected time for the device to respond at its new address.
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Uninstalling the Software

To uninstall your NI-FBUS software, select Start»Settings»Control 

Panel»Add/Remove Programs.

If you are only using the Communications Manager, select NI-FBUS 

Communications Manager to uninstall. If you are using the NI-FBUS 

Configurator, select NI-FBUS Configurator.

The uninstall utility does not remove the NI-FBUS directory itself or any 

files in the \Data\Nvm directory. To completely uninstall the software, 

manually remove the files in the \Data\Nvm directory and the NI-FBUS 

directory structure.
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C
Technical Support and 
Professional Services

Visit the following sections of the National Instruments Web site at 

ni.com for technical support and professional services:

• Support—Online technical support resources include the following:

– Self-Help Resources—For immediate answers and solutions, 

visit our extensive library of technical support resources available 

in English, Japanese, and Spanish at ni.com/support. These 

resources are available for most products at no cost to registered 

users and include software drivers and updates, a KnowledgeBase, 

product manuals, step-by-step troubleshooting wizards, 

conformity documentation, example code, tutorials and 

application notes, instrument drivers, discussion forums, 

a measurement glossary, and so on.

– Assisted Support Options—Contact NI engineers and other 

measurement and automation professionals by visiting 

ni.com/support. Our online system helps you define your 

question and connects you to the experts by phone, discussion 

forum, or email.

• Training—Visit ni.com/training for self-paced tutorials, videos, 

and interactive CDs. You also can register for instructor-led, hands-on 

courses at locations around the world.

• System Integration—If you have time constraints, limited in-house 

technical resources, or other project challenges, NI Alliance Program 

members can help. To learn more, call your local NI office or visit 

ni.com/alliance.

• Declaration of Conformity (DoC)—A DoC is our claim of 

compliance with the Council of the European Communities using the 

manufacturer’s declaration of conformity. This system affords the user 

protection for electronic compatibility (EMC) and product safety. You 

can obtain the DoC for your product by visiting 

ni.com/hardref.nsf.
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• Calibration Certificate—If your product supports calibration, you 

can obtain the calibration certificate for your product at 

ni.com/calibration.

If you searched ni.com and could not find the answers you need, contact 

your local office or NI corporate headquarters. Phone numbers for our 

worldwide offices are listed at the front of this manual. You also can visit 

the Worldwide Offices section of ni.com/niglobal to access the branch 

office Web sites, which provide up-to-date contact information, support 

phone numbers, email addresses, and current events.
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Glossary

Symbol Prefix Value

m milli 10–3

k kilo 103

A

Alarm A notification the NI-FBUS Communications Manager software 

sends when it detects that a block leaves or returns to a particular 

state.

API See Application Programmer Interface. 

Application Function blocks.

Application Programmer 

Interface

A message format that an application uses to communicate with 

another entity that provides services to it.

Asynchronous Communication that occurs at times that are not predetermined.

AT-compatible Compatible with the 16-bit Industry Standard Architecture.

B

Bank The combination of one FieldPoint network module and one or more 

terminal bases and I/O modules.

Basic device A device that can communicate on the Fieldbus, but cannot become 

the LAS.

Block A logical software unit that makes up one named copy of a block and 

the associated parameters its block type specifies. The values of the 

parameters persist from one invocation of the block to the next. It can 

be a resource block, transducer block, or function block residing 

within a virtual field device.
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Bus The group of conductors that interconnect individual circuitry in a 

computer. Typically, a bus is the expansion vehicle to which I/O or 

other devices are connected. Examples of PC buses are the ISA and 

PCI buses.

Bus scheduler See Link Active Scheduler.

C

C Celsius.

Cable A number of wires and shield in a single sheath.

Capacitor An electronic component that stores electrical charge. In a computer, 

capacitors are used in dynamic RAM cells and power supplies.

Channel A pin or wire lead to which you apply or from which you read the 

analog or digital signal.

Communication stack Performs the services required to interface the user application to the 

physical layer.

Control loop A set of connections between blocks used to perform a control 

algorithm.

CPU Central processing unit.

D

Data Link Layer The second-lowest layer in the ISO seven-layer model (layer two). 

The Data Link Layer splits data into frames to send on the physical 

layer, receives acknowledgment frames, and re-transmits frames if 

they are not received correctly. It also performs error checking to 

maintain a sound virtual channel to the next layer.

DD See Device Description. 

Descriptor A number returned to the application by the NI-FBUS 

Communications Manager, used to specify a target for future 

NI-FBUS calls.

Device A sensor, actuator, or control equipment attached to the Fieldbus.

Device address A memory address that you use to access a device in a computer 

system.
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Device Description A machine-readable description of all the blocks and block 

parameters of a device.

Device ID An identifier for a device that the manufacturer assigns. No two 

devices can have the same device ID.

Device tag A name you assign to a Fieldbus device.

Directory A structure for organizing files into convenient groups. A directory is 

like an address showing where files are located. A directory can 

contain files or subdirectories of files.

DRAM Dynamic Random Access Memory. Memory that requires electricity 

and refreshing to hold data.

Driver Device driver software installed within the operating system.

E

EMI Electromagnetic interference.

Event An occurrence on a device that causes a Fieldbus entity to send the 

Fieldbus event message.

F

Field device A Fieldbus device connected directly to a Fieldbus.

Fieldbus An all-digital, two-way communication system that connects control 

systems to instrumentation. A process control local area network 

defined by ISA standard S50.02.

Fieldbus cable Shielded, twisted pair cable made specifically for Fieldbus that has 

characteristics important for good signal transmission and are within 

the requirements of the Fieldbus standard.

Fieldbus Foundation An organization that developed a Fieldbus network specifically based 

upon the work and principles of the ISA/IEC standards committees.

Fieldbus Network Address Location of a board or device on the Fieldbus; the Fieldbus node 

address.

Foundation Fieldbus 

specification

The communications network specification that the Fieldbus 

Foundation created.

FP-3000 National Instruments network interface module for the FieldPoint I/O 

system.
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Function block A named block consisting of one or more input, output, and contained 

parameters. The block performs some control function as its 

algorithm. Function blocks are the core components you control 

a system with. The Fieldbus Foundation defines standard sets of 

function blocks. There are ten function blocks for the most basic 

control and I/O functions. Manufacturers can define their own 

function blocks.

Function Block Application The block diagram that represents your control strategy.

G

Ground An intentional or accidental conducting path between an electrical 

system or circuit and the earth or some conducting body acting in 

place of the earth. A ground is often used as the common wiring point 

or reference in a circuit.

H

H1 The 31.25 kbit/second type of Fieldbus.

HMI Human-Machine Interface. A graphical user interface for the process 

with supervisory control and data acquisition capability.

I

I/O Input/output.

IEC International Electrotechnical Commission. A technical standards 

committee which is at the same level as the ISO.

in. Inches.

IRQ Interrupt request.

ISA Industry Standard Architecture.

K

Kbits Kilobits.

Kernel The set of programs in an operating system that implements basic 

system functions.

Kernel mode The mode in which device drivers run on Windows NT.
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L

LabVIEW DSC The LabVIEW Datalogging and Supervisory Control (DSC) Module 

builds on the power of LabVIEW for high channel count and 

distributed applications. It adds easy networking, channel and 

I/O management, alarm and event management, historical 

datalogging, real-time trending, and OPC integration to the 

LabVIEW environment.

Link A Foundation Fieldbus network is made up of devices connected by 

a serial bus. This serial bus is called a link (also known as a segment). 

Link Active Scheduler The Fieldbus device that is currently controlling access to the 

Fieldbus. A device that is responsible for keeping a link operational. 

The LAS executes the link schedule, circulates tokens, distributes 

time, and probes for new devices.

Link master device A device that is capable of becoming the LAS.

Live list The list of all devices that are properly responding to the Pass Token.

Lookout National Instruments Lookout is a full-featured object-based 

automation software system that delivers unparalleled power and 

ease of use in demanding industrial measurement and automation 

applications.

Loop See Control loop.

M

mA Milliampere.

Mode Type of communication.

N

Network address The Fieldbus network address of a device.

Nifb.exe The NIFB process that must be running in the background for you to 

use your PCI-FBUS, AT-FBUS, or PCMCIA-FBUS interface to 

communicate between the board and the Fieldbus.

NI-FBUS API The NI-FBUS Communications Manager.

NI-FBUS Communications 

Manager

Software shipped with National Instruments Fieldbus interfaces that 

lets you read and write values. It does not include configuration 

capabilities.
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NI-FBUS Configurator National Instruments Fieldbus configuration software. With it, you 

can set device addresses, clear devices, change modes, and read and 

write to the devices.

NI-FBUS Fieldbus 

Configuration System

See NI-FBUS Configurator.

NI-FBUS process Process that must be running in the background for you to use 

your PCI-FBUS, AT-FBUS, or PCMCIA-FBUS interface to 

communicate between the board and the Fieldbus.

O

Object An element of an object dictionary.

OPC OLE for Process Control.

P

Parameter One of a set of network-visible values that makes up a function block.

PC Personal Computer.

PCI Peripheral Component Interconnection.

Physical Layer The layer of the communication stack that converts digital Fieldbus 

messages from the communication stack to actual physical signals on 

the Fieldbus transmission medium and vice versa.

PLC See Programmable Logic Controller.

Poll To repeatedly inspect a variable or function block to acquire data.

Programmable Logic 

Controller

A device with multiple inputs and outputs that contains a program 

you can alter.

R

Repeater Boost the signals to and from the further link.

Resistor Component made of material that opposes flow of current and 

therefore has some value of resistance.
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Resource block A special block containing parameters that describe the operation 

of the device and general characteristics of a device, such as 

manufacturer and device name. Only one resource block per device 

is allowed.

Roundcard A hardware interface for developing Foundation Fieldbus-compliant 

devices.

S

s Seconds.

Segment See Link.

Server Device that receives a message request.

Service Services allow user applications to send messages to each other 

across the Fieldbus using a standard set of message formats.

Session A communication path between an application and the NI-FBUS 

Communications Manager.

Signal An extension of the IEEE 488.2 standard that defines a standard 

programming command set and syntax for device-specific 

operations.

Stack A set of hardware registers or a reserved amount of memory used for 

calculations or to keep track of internal operations.

T

Tag A name you can define for a block, virtual field device, or device.

Terminator A device used to absorb the signal at the end of a wire.

Trend A Fieldbus object that allows a device to sample a process variable 

periodically, then transmit a history of the values on the network.

V

VCR See Virtual Communication Relationship. 

VFD See Virtual Field Device. 
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Virtual Communication 

Relationship

Preconfigured or negotiated connections between virtual field 

devices on a network.

Virtual Field Device The virtual field device is a model for remotely viewing data 

described in the object dictionary. The services provided by the 

Fieldbus Messaging Specification allow you to read and write 

information about the object dictionary, read and write the data 

variables described in the object dictionary, and perform other 

activities such as uploading/downloading data and invoking 

programs inside a device. A model for remotely viewing data 

described in the object dictionary.
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Index

A
advanced parameters, configuring, B-7

advanced stack configuration dialog box 

(figure), B-7

B
board renumbering (table), 2-6

C
cable connector, pinout for Fieldbus cable, 2-8

calibration certificate, C-2

changing or deleting existing interface 

information, 2-6

common questions, B-1

communication parameters, setting, 2-3

configuration, 2-1

advanced parameters, B-7

choosing software, 1-2

troubleshooting interface problems, B-3

contacting National Instruments, C-2

conventions used in the manual, vii

customer

education, C-1

professional services, C-1

technical support, C-1

D
Declaration of Conformity, C-1

device descriptions, importing, 2-7

device names, B-5

devices, replacing, 2-9

diagnostic resources, C-1

documentation

conventions used in the manual, vii

how to use the manual set, vii

online library, C-1

related documentation, ix

drivers

instrument, C-1

software, C-1

E
error messages, B-1

example code, C-1

F
Fieldbus

cable connector pinout, 2-8

installing and wiring devices, 2-9

optional network tools, 1-4

software (table), 1-3

H
hardware, description, 1-1

help

professional services, C-1

technical support, C-1

how to use manual set, vii

I
import device descriptions, 2-7

installation, 2-1

and wiring of Fieldbus devices, 2-9

testing, 2-5
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instrument drivers, C-1

interface

changing or deleting information, 2-6

setting name, 2-3

introduction, 1-1

K
KnowledgeBase, C-1

L
LabVIEW DSC, 1-4

Lookout, 1-4

N
National Instruments

calibration certificate, C-2

customer education, C-1

Declaration of Conformity, C-1

professional services, C-1

system integration services, C-1

technical support, C-1

worldwide offices, C-2

NIFB

configure to load at startup, 3-1

troubleshooting, B-2

NIFB process, starting, 3-1

NI-FBUS

interface configuration utility, 1-2

using the software, 3-2

NI-FBUS Communications Manager, 1-4

NI-FBUS Configurator, 1-4

O
online technical support, C-1

optional Fieldbus network tools, 1-4

P
PCI-FBUS

board installation, 2-2

figure, 2-2

Fieldbus connector pinout (figure), 2-8

software settings for, 2-3

phone technical support, C-2

pinout

Fieldbus cable connector, 2-8

Fieldbus connector pinout (figure), 2-8

polled mode, B-4

professional services, C-1

programming examples, C-1

R
related documentation, ix

renumbering (table), 2-6

replacing devices, 2-9

S
software

choosing configuration software, 1-2

description, 1-1

installation, 2-1

LabVIEW DSC, 1-4

Lookout, 1-4

National Instruments Fieldbus software 

(table), 1-3

NI-FBUS Communications Manager, 1-4

NI-FBUS Configurator, 1-4

uninstalling, B-8

using NI-FBUS software, 3-2

using the NI-FBUS board, 2-3

software drivers, C-1

specifications, A-1

support, technical, C-1

system integration services, C-1
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T
technical support, C-1

telephone technical support, C-2

termination of wiring, 2-9

testing the installation, 2-5

training, customer, C-1

troubleshooting, B-1

using manufacturer-defined features, B-4

troubleshooting resources, C-1

U
uninstalling the software, B-8

V
visitor address, B-4

W
Web

professional services, C-1

technical support, C-1

what you need to get started, 1-1

worldwide technical support, C-2
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