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LabVIEW™ FPGA Module Release Notes

Version 1.1

These release notes introduce new features and contain instructions for
installing the LabVIEW FPGA Module, configuring FPGA devices, and
selecting execution targets. This document also provides exercises to
introduce you to FPGA VIs and host VIs. Refer to the list of resources at
the end of this document for more information about developing
applications with the FPGA Module.
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What’s New in the LabVIEW FPGA Module 1.1

The LabVIEW FPGA Module 1.1 includes the following new features.
Refer to the LabVIEW FPGA Module User Manual or the LabVIEW Help,
available by selecting Help» VI, Function, & How-To Help, for more
information about the new features.

New FPGA Device Execution Targets—You now can choose from a
broader range of FPGA devices, including the NI PXI-7811R and the
NI PCI-7831R.

New I/0 Devices—You now can use CompactRIO I/O modules.

Embedded Project Manager—Use the Embedded Project Manager
to manage groups of FPGA VIs and the common information among
the VIs, such as I/O resource aliases. You must add an FPGA VIto a
LabVIEW Embedded Project (LEP) file to configure the FPGA Device
I/0O functions and to compile and run the VI.

Single-Cycle Timed Loop—A Single-Cycle Timed Loop repeats the
subdiagram inside it every clock cycle of the default FPGA clock until
the conditional terminal receives a particular Boolean value. Use the
Single-Cycle Timed Loop as you do a While Loop. The availability of
the Single-Cycle Timed Loop varies by execution target. Refer to the
hardware documentation in the LabVIEW Help, available by selecting
Help» VI, Function, & How-To Help, for information about
hardware support for the Single-Cycle Timed Loop.

I/O Property and Method Nodes—The I/O Property Node gets or
sets one or more properties on an I/O resource. The I/O resources
available and the associated properties vary by execution target and
configuration. The I/O Method Node invokes a method on an I/O
resource. A method can have zero or more parameters. The I/O
resources available and the associated methods vary by execution
target and configuration. Refer to the hardware documentation in
the LabVIEW Help, available by selecting Help» VI, Function,

& How-To Help, for information about available properties and
methods.

@ Note The I/O Method Node includes wait on edge or level methods. LabVIEW
automatically updates the Wait on Edge or Level function to the /O Method Node
when you open an FPGA Module 1.0 VI in the FPGA Module 1.1.

FPGA Module Release Notes

Error Terminals on FPGA Device I/0 Functions—You can
right-click an FPGA Device I/O function on the block diagram and
select Error Terminals from the shortcut menu to add standard
LabVIEW Error In and Error Out parameters to the function.

Saturation Arithmetic VIs—Use the Saturation Arithmetic VIs to
handle or avoid integer overflow when performing mathematical
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operations. You can configure these VIs to return a maximum or
minimum value if an overflow condition occurs instead of wrapping
the result.

*  FPGA Math & Analysis VIs—Use the FPGA Math & Analysis VIs
to perform integer math, analysis, and control operations in FPGA VIs.

¢  FPGA FIFO Functions—Use the FIFO Read and FIFO Write
functions in FPGA VIs to transfer data to and from loops, such as
Single-Cycle Timed Loops, or from one subVI to another.

* HDL Interface Node—If you have a block of HDL code you want to
use in an FPGA VI, you can enter the code in the HDL Interface Node
rather than rewriting the code in LabVIEW. You enter all the
parameters and the HDL code in the Configure HDL Interface Node
dialog box. You then wire the parameters you entered as you do any VI
or function on the block diagram. Do not use the HDL Interface Node
if you are not already familiar with an HDL programming language.

e Up Cast Function—The Up Cast function converts a VI-specific
hardware reference to a more generic hardware reference. You can
create a set of subVIs in the host VI to use with multiple FPGA VIs if
the FPGA VI front panels are constant.

Upgrading from LabVIEW FPGA Module 1.0

If you created FPGA VIs using LabVIEW 7.0 and the FPGA Module 1.0,
the VIs are broken in LabVIEW 7.1 until you add them to an LEP file.
Refer to the LabVIEW Help, available by selecting Help» VI, Function,
& How-To Help, for information about creating and managing LEP files
and adding VIs to LEP files.

If you created host VIs using LabVIEW 7.0 and the FPGA Interface
functions from the FPGA Module 1.0, the VI might be broken when you
open it in LabVIEW 7.1. Select Tools»FPGA Interface Update Utility
from the front panel or block diagram of the VI to restore the VI by
updating the HW Exec Ref and HW Exec Ref Out parameters in the VI
and its subVIs. Run the utility for each host VI you created using
LabVIEW 7.0.

What You Need to Get Started

This section contains a list of items you need before you can install the
FPGA Module and develop a custom hardware solution with a National
Instruments Reconfigurable I/O device, which also is known as an FPGA
device.
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U The following NI software packages:

LabVIEW 7.1 CD

(Optional) LabVIEW Real-Time Module 7.1 for ETS Targets CD
if you want to control or monitor the FPGA device in real-time
with an RT Series PXI system

(Optional) LabVIEW Real-Time Module 7.1 for RTX Targets CD
if you want to control or monitor the FPGA device in real-time
with RTX running on a desktop computer

(Optional) National Instruments Device Drivers CD
LabVIEW FPGA Module 1.1 CD

NI-RIO 1.1 for R Series Devices CD if you use the FPGA Module
with an R Series device, such as the NI 7831R

U An FPGA device and its getting started documentation

Installing the LabVIEW FPGA Module

Complete the following steps to set up a development computer with
LabVIEW, the LabVIEW Real-Time Module, the appropriate NI device
drivers, and the LabVIEW FPGA Module. The development computer

is a PC or PXI system running Windows and on which you install the
LabVIEW development system and the FPGA Module. You create and edit
FPGA VIs and host VIs on the development computer.

@ Note The NI Device Drivers and NI-RIO installers detect the NI software that is currently
installed and offer a selection of device drivers based on the components they detect. Both
LabVIEW and the LabVIEW Real-Time Module installers prompt you to install device
drivers as part of the installations. If you are installing LabVIEW and the LabVIEW
Real-Time Module, you can save time by installing device drivers only once after you
install LabVIEW and the LabVIEW Real-Time Module. If you are not installing the
LabVIEW Real-Time Module, you can install device drivers when you install LabVIEW.

To avoid installing device drivers with LabVIEW, perform a custom installation of
LabVIEW. On the Features screen, click the icon to the left of the Device Drivers
component and select Do not install drivers.

1. Log in to the development computer as an administrator or as a user
with administrative privileges.

2. Install LabVIEW 7.1 from the LabVIEW 7.1 installation CD. Refer to
the LabVIEW Release Notes for information about installing the
LabVIEW development system.

3. If you also plan to use the LabVIEW Real-Time Module, install the
LabVIEW Real-Time Module from the LabVIEW Real-Time

FPGA Module Release Notes

4 ni.com



Module 7.1 installation CD. Refer to the LabVIEW Real-Time Module
Release Notes for information about installing the LabVIEW
Real-Time Module and the device drivers you need.

4. Aspart of the LabVIEW or LabVIEW Real-Time Module installation,
install NI device drivers as needed.

5. Install the FPGA Module from the LabVIEW FPGA Module 1.1
installation CD, following the instructions that appear on the screen.
Select Complete when you reach the Select Installation Type step.
The FPGA Module installs program files, documentation, and
examples. The FPGA Module also copies files from Xilinx ISE to the
x:\NIFPGAL1Ll directory, where x is the drive on which you installed
LabVIEW 7.1.

6. Install NI-RIO from the NI-RIO 1.1 for R Series Devices installation

CD, following the instructions that appear on the screen. Select support
for the specific FPGA devices you are using.

Setting up RT Systems with FPGA Devices

If you need to access FPGA devices in remote RT Series PXI systems, set
up the RT target as described in the Measurement & Automation Explorer
Help, available by selecting Help»>MAX Help in the Measurement &
Automation Explorer window, making sure you download NI-RIO RT to
the RT target. NI-VISA and the NI-VISA Server are automatically installed
with NI-RIO RT.

If you need to use an FPGA device with the LabVIEW Real-Time Module

for RTX, refer to the hardware getting started documentation for
information about adding RTX support for the FPGA device.

Accessing and Configuring FPGA Devices

FPGA devices might be located in the local development computer or in
other systems on the network, which are known as remote systems. This
section contains instructions for accessing and configuring FPGA devices
in the following systems:

e Local development computer
* Remote systems

—  Networked RT system, such as a system running the Real-Time
Operating System (RTOS) and the RT Engine, located on the local
subnet

—  Networked RT system not located on the local subnet

—  Networked Windows computer, which can be a PC or PXI system
running Windows

© National Instruments Corporation 5 FPGA Module Release Notes



Configuring FPGA Devices in the Local Development Computer

Measurement & Automation Explorer (MAX) automatically detects FPGA
devices installed in the local development computer. If you install an FPGA
device in the development computer, you can locate the device in MAX
under the My System»Devices and Interfaces»RIO Devices category.
After you verify that MAX recognizes the FPGA device, you can begin
developing FPGA VIs in LabVIEW. Refer to the Targeting an FPGA
Device with LabVIEW section of this document for information about
selecting the FPGA device as the LabVIEW execution target.

Configuring FPGA Devices in Remote Systems

The FPGA Module uses the NI-VISA communication protocol to locate
remote FPGA devices, which are detected as VISA resources, and displays
them in MAX. Although NI-VISA has a very rich feature set, you do not
need to develop an in-depth understanding of NI-VISA to successfully use
the FPGA Module. As a user of the FPGA Module, you just run the
NI-VISA Server on the remote system to make FPGA devices installed
in that system accessible to other computers on the network.

The NI-VISA Server is a tool that enables users on a network to access
VISA resources on the computer on which the NI-VISA Server is running.
The NI-VISA Server can run on networked RT targets, located both on and
off the local subnet, and Windows computers.

@ Tip Remote systems can access the VISA resources on the development computer when
you run the NI-VISA Server on the development computer and grant access permissions,
as described in the Setting Access Permissions section of this document.

You configure FPGA devices interactively in MAX so you can select them
as execution targets from LabVIEW. You must complete the following
general steps before you can target LabVIEW to an FPGA device in a
remote system. Refer to the following sections for detailed information
about each step.

1. Make the FPGA device appear in MAX.

2. Set access permissions to grant or deny access to the FPGA device
from other computers on the network.

3. Enable remote finding for the remote FPGA device on the local
computer.

FPGA Module Release Notes 6 ni.com



Making FPGA Devices Appear in MAX

There are three different ways to make remote FPGA devices accessible
in MAX—one for each type of the following remote systems:

*  Networked RT systems located on the local subnet
* Networked RT systems not located on the local subnet

*  Networked Windows computers

Complete the steps in the following sections to make FPGA devices appear
in MAX.

Networked RT Systems on the Local Subnet

1. If you have not already installed NI-RIO RT, NI-VISA, and the
NI-VISA Server on the RT target, download them from MAX. Refer
to the Measurement & Automation Explorer Help, available by
selecting Help>MAX Help in the Measurement & Automation
Explorer window, for information about downloading software to
RT targets.

2. Restart the RT target. The NI-VISA Server runs automatically on
networked RT targets when you have NI-VISA and the NI-VISA
Server installed on the RT target. When the NI-VISA Server runs on
an RT target, the monitor output displays a message that the NI-VISA
Server started successfully.

3. Find the FPGA device in the Remote Systems category in MAX.
MAX automatically detects NI-VISA Servers running on networked
RT systems located on the local subnet. You can locate FPGA devices
under the Remote Systems»Remote System Name»Devices and
Interfaces»RIO Devices category, where Remote System Name is the
name or IP address of the remote system.

Figure 1 shows a remote system, named fpga012, that contains an
NI PXI-7831R FPGA device. Notice that MAX displays the FPGA
device VISA resource name and device type on the General tab.
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Figure 1. FPGA Device Installed on a Remote System

4. Refer to the Setting Access Permissions and Enabling Remote Finding
sections of this document for information about configuring access
permissions to remote FPGA devices and creating a find list so
LabVIEW can display available FPGA devices as possible execution
targets.

Networked RT Systems Not on the Local Subnet

1. If you have not already installed NI-VISA and the NI-VISA Server on
the RT target, download them using MAX from a computer on the
local subnet. Refer to the Measurement & Automation Explorer Help,
available by selecting Help»MAX Help in the Measurement &
Automation Explorer window, for information about downloading
software to RT targets.

2. Restart the RT target. The NI-VISA Server runs automatically on
networked RT targets when you have NI-VISA and the NI-VISA
Server installed on the RT target. When the NI-VISA Server runs on
an RT target, the monitor output displays a message that the NI-VISA
Server started successfully.

Although MAX can automatically detect NI-VISA Servers running on
RT targets located on the local subnet, MAX cannot automatically
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detect NI-VISA Servers running on remote RT targets not located on
the local subnet so you must manually add the remote system.

In MAX on the development computer, right-click the Remote
Systems category and select Create New from the shortcut menu.

Select Remote Device (not on the local subnet) and click the Next
button.

Specify the remote system using the network name or IP address of the
RT target and click the Finish button.

After MAX displays the remote system, locate the FPGA device
under the Remote Systems»Remote System Name»Devices and
Interfaces»RIO Devices category, where Remote System Name is
the name or IP address of the remote system, as shown in Figure 1.

Refer to the Setting Access Permissions and Enabling Remote Finding
sections of this document for information about configuring access
permissions to remote FPGA devices and creating a find list so
LabVIEW can display available FPGA devices as possible execution
targets.

Networked Windows Computers

1.

|

m
-

3111 PM

I

© National Instruments Corporation

On the remote computer that contains the FPGA device you want to
access, start the NI-VISA Server by selecting Start»Programs»
National Instruments» VISA»NI-VISA Server.

When the NI-VISA Server runs on a Windows computer, you see the
VISA icon in the Windows system tray, shown at left. MAX cannot
automatically detect NI-VISA Servers running on networked PCs or
PXI systems running Windows, so you must manually add the remote
system.

In MAX on the development computer, right-click the Remote
Systems category and select Create New from the shortcut menu.

Select Remote VISA System and click the Next button.

Specify the remote system using the network name or IP address of the
Windows computer running the NI-VISA Server and click the Finish
button.

After MAX displays the remote system, locate the FPGA device
under the Remote Systems»Remote System Name»Devices and
Interfaces»RIO Devices category, where Remote System Name is
the name or IP address of the remote system, as shown in Figure 1.

Refer to the Setting Access Permissions and Enabling Remote Finding
sections of this document for information about configuring access
permissions to remote FPGA devices and creating a find list so
LabVIEW can display available FPGA devices as possible execution
targets.
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Setting Access Permissions

Complete the following steps to allow other computers to access the remote
system.

1.

If the NI-VISA Server is running on an RT target, select the RT target
under the Remote Systems category in MAX. If the NI-VISA Server
is running on a Windows computer, open MAX on that computer and
proceed to the next step.

For RT targets, open the VISA Options page by clicking the Remote
Systems»Remote System Name»Software»NI-VISA 3.1 category,
where Remote System Name is the name or IP address of the remote
system, and then clicking the VISA Options tab. For Windows
computers, open the VISA Options page by selecting Tools»
NI-VISA»VISA Options.

On the VISA Options page, select VISA Server»Security to view the
Remote Access List, as shown in Figure 2.

=) g My System

Devices and Interfaces
& software

Remote Systems

FPGADNS

fpgallz

Devices and Interfaces
E@ Software

(@ MI-RIORT 1.1.0
(] MIVISA 3.1
(] MIVISA Server 3.1

l.\__, NI-¥ISA 3.1 - Measurement & Automation Explorer !E[ E
File Edit Yiew Tools Help
Configuration |2|Refresh  [save 1’Revert | % Show Help

fpgall2 . . .
Usze this page to configure which systems can access V154 resources on
thiz spstem. The gettings on thiz page apply only when the VISA server
on thiz spstem iz running.

A blank list means that no remote system has access to this spstem. The
wildcard value "' reprezents all remate spstems.

- 154 Server

Ity Fiefer to the context help for information about other valid values and the

meaning of the order of permizzions in the list.

Fiemote Access List:
é I Remate Address
v -

<Click here to add new permizzion:

I Eermission

Seess and remote
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I:I-- ) Bocess only
- 10.0.38.12
[]...% 10.0.38.69 Add e REreme ) Deny all access
— Enable Femote Finding
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zearches when finding resources. The button below will take you to
your local VIS4 options to enable this remate spstem for finding.
WISA Options >»> Remote |
[5) Atrbutes 537 yi5A Options |
4
Figure 2. Setting Access Permissions for Remote Systems
Add 4. Click the Add button, shown at left, to add a computer to the Remote

Access List and enter the name or IP address of the computer. You can
use the * wildcard to specify a group of computers or all computers on
the network. In general, use the * wildcard to set up general allowances
or denials, and follow those entries with more specific entries. Refer to
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the LabVIEW Help, available by selecting Help» VI, Function,
& How-To Help in LabVIEW, for general information about access
list entries and wildcards.

5. Select a Permission option to either allow access to the remote system
or deny access to the remote system.

E Save

Enabling Remote Finding

You can configure NI-VISA on the development computer to
automatically search specific remote systems when searching for VISA
resources, such as FPGA devices. The FPGA Module uses NI-VISA to find
available FPGA devices when LabVIEW starts so you can select an FPGA
device as an execution target. You must enable remote finding for an FPGA
device before you can target the FPGA device in LabVIEW. Complete the
following steps to create a find list.

WS4 Options »> Remate L.

6. Click the Save button, shown at left, to set the access permissions.

If you are currently configuring access permissions for a remote
system, click the VISA Options >> Remote button to open the

VISA Options page for the local VISA settings. Otherwise, select
Tools»NI-VISA»VISA Options to open the VISA Options page
and select VISA Settings»Remote, as shown in Figure 3.
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File Edit Yiew Tools Help
Configuration 2| Refresh Save | Revert Shaw Help
g ¥
EI@ Iy System 1= My System =
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E--@ Software ; g systems below when finding resources without specifying a
; Aliases remote system address in the search sting.
»@ VI Run-Time: Remate
=] [ Before VIS4 can access these remate spstems, you must also
- LabWIEW : F I " - o
& a VISA ;SSDO[ ¢ configure the security permissions of each remote WISA server
I:I-- LabWIEW =5 b ErvVer ta allow this system to access the remote resources.
[} LabVIEW Run-Time - Security - _
LabYIEW Run-Ti The following list containz the remote systems that have been
L LA un-Tims configured or found. Place a check nest to each remote
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4
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Figure 3. Enabling Remote Finding on Specific Remote Systems
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2. Place checkmarks in the checkboxes next to the remote systems that
you want VISA on the local computer to automatically search for
VISA resources.

@ Note Each time you start LabVIEW, LabVIEW searches for FPGA devices on the remote
systems for which you have enabled remote finding. LabVIEW attempts to query each
remote system for approximately 20 seconds. If LabVIEW cannot connect to a remote
system in that time, LabVIEW skips that remote system and moves to the next remote
system on the find list. If you know that a remote system is not available, remove the
checkmark next to the remote system in the find list so LabVIEW does not attempt to query
that remote system.

E Save

Click the Save button.

4. Restart LabVIEW so LabVIEW can recognize the new FPGA devices
and list them as execution targets. Refer to the Targeting an FPGA
Device with LabVIEW section of this document for information about
selecting execution targets in LabVIEW.

Targeting an FPGA Device with LabVIEW

FPGA Module Release Notes

With the FPGA Module, you must select the location on which you want a
VI to run, which is called an execution target. For example, you run FPGA
VIs on an FPGA device, so you will select an FPGA device as the execution
target. After you select an execution target, LabVIEW modifies the
palettes, VIs, functions, and development tools to offer only those that
make sense for the execution target.

To change the execution target from the LabVIEW dialog box, as shown
in Figure 4, select an FPGA device from the Execution Target pull-down
menu. The Embedded Project Manager window automatically appears.
Create a new LEP file or open an existing LEP file in the Embedded
Project Manager window to begin working on FPGA VIs. Alternatively,
you can switch the execution target from an open VI by selecting
Operate»Switch Execution Target. You also can switch the execution
target in the Embedded Project Manager window by selecting
Target»Execution Target.
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Figure 4. Selecting an Execution Target in the LabVIEW Dialog Box

You can create and compile FPGA VIs even if you do not have an FPGA
device by selecting a compile only execution target. For example, select
FPGA Device (PXI-7831R) <compile only> in the Execution Target
pull-down menu, as shown in Figure 4, and develop the FPGA VI as you
develop any VI. However, if you attempt to download and run the FPGA
VI, you will receive an error because the device is not present.

You can test the logic of an FPGA VI with traditional LabVIEW debugging
tools before compiling it by targeting an emulator. To target an emulator
rather than the FPGA device, select FPGA Emulator for the FPGA device
from the Execution Target pull-down menu. You must have an FPGA
device that supports the emulator. Refer to Chapter 5, Debugging FPGA
Vis, of the LabVIEW FPGA Module User Manual for information about
testing FPGA VIs with FPGA device emulators. Refer to the hardware
documentation for information about emulator support.

Getting Started with FPGA VIs and Host Vis

Use the FPGA Module examples to learn about building FPGA VIs and
host VIs, communicating between VIs running on the FPGA device and
on the host computer, and programming hardware functionality in the
FPGA VI. An FPGA VI is a VI that you download to an FPGA device that
determines the functionality of the hardware using the FPGA Device 1/0
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functions. A host VI is a VI that runs in software on the host computer and
controls and monitors the FPGA VI on the FPGA device using the FPGA
Interface functions.

In this section, you will learn to browse the FPGA Module examples with
the NI Example Finder, download and run an FPGA VI, and communicate
with an FPGA VI from a host VI.

Browsing Examples with the NI Example Finder

Complete the following steps to browse installed examples with the
NI Example Finder.

FPGA Module Release Notes

1.

Select Help»Find Examples in LabVIEW to browse all LabVIEW
examples installed on the development computer.

Select Directory Structure on the Browse tab to browse the examples
by directory structure. You also can select Task to browse the
examples by task. If you browse the examples by Task, you can find
examples for specific devices. Refer to the National Instruments
Example Finder Help, available by clicking the Help button in the
NI Example Finder, for information about configuring the NI Example
Finder.

Browse the examples in the FPGA directory. The FPGA Module
examples demonstrate a variety of tasks and concepts, including the
following:

e Using various FPGA devices

*  Performing basic I/O

*  Building hardware counters in LabVIEW

*  Exploring timing and triggering possibilities

¢  Communicating between the FPGA VI running on the FPGA
device and the host VI running on the host computer

e Using new and advanced features

You can find information about these topics and more in the
LabVIEW FPGA Module User Manual. Refer to the hardware
documentation for information specific to the FPGA device.

Navigate to the Getting Started\Programmatic -
I0 Primitives directory in the listbox.

Select Digital (FPGA).vi in the listbox. Notice that a description of the
Digital (FPGA) VI appears in the Description text box. All examples
in the Getting Started directory contain descriptions to help you
find a relevant example quickly.

14 ni.com



Exploring an FPGA VI

The Digital (FPGA) VI demonstrates basic concepts of programming an
FPGA device like the NI PXI-7831R using the FPGA Module. Complete
the following steps to view and run an example of an FPGA VI and verify
that you correctly installed and configured the FPGA device.

@ Note You must have an FPGA device available and configured to complete this exercise.
Refer to the Accessing and Configuring FPGA Devices section of this document for
information about configuring local and remote FPGA devices.

1. After completing the steps in the Browsing Examples with the NI
Example Finder section, double-click Digital (FPGA).vi in the listbox
of the NI Example Finder to launch the Digital (FPGA) VL.

2. Because this VIis designed to run on an FPGA device, select an FPGA
device as the execution target. Refer to the Targeting an FPGA Device
with LabVIEW section of this document for information about
selecting execution targets. The Embedded Project Manager
window appears when you select an FPGA device execution target.

@ Note The Digital VI is already compiled to run on the NI PXI-7831R. If you do not have
an NI 783 1R device, the VI is broken. You must target the FPGA device you are using and
recompile the VI. LabVIEW recompiles the VI the first time you target LabVIEW to a
different FPGA device and click the Run button. Refer to Chapter 4, Running FPGA Vls,
of the LabVIEW FPGA Module User Manual for information about compiling,
downloading, and running FPGA VIs.

3. Select File»Open Project in the Embedded Project Manager
window and navigate to LabVIEW 7.1\examples\FPGA\
Getting Started\Programmatic - IO Primitives\
Digital (FPGA) .lep. Click the Open button to open the LEP file
associated with the Digital (FPGA) VI.

@ Note If you do not open the LEP file associated with the Digital (FPGA) VI, LabVIEW
prompts you to open an Embedded Project when you click the Run button. Click the
Open Last Associated Project button to open the LEP file associated with the Digital
(FPGA) VI

4. Figure 5 shows the Embedded Project Manager window. Notice the
Digital (FPGA) VI appears in the Source Files list on the Source tab
with a dot by the filename. The dot indicates the Digital (FPGA) VI1is
the top-level VI of the LEP file. The top-level VI runs when you click
the Run button.
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! Digital (FPGA).lep = B3

File Project Target Hardware Tools ‘Window Help

= Source Files :I
L @ Digital (FPGA).vi

-
Kl »
SmuiEE | Aliases | FPi4 Device (PXI-7E31R)

Figure 5. Embedded Project Manager Window

5. Click the Aliases tab in the Embedded Project Manager window.
Notice that the I/O resources configured with aliases for the Digital
(FPGA) VI appear in the Aliases list. You can add, edit, or delete
aliases in the Alias Manager dialog box, available by selecting
Hardware»Alias Manager. Refer to the LabVIEW Help, available by
selecting Help» VI, Function, & How-To Help, for information about
using the Embedded Project Manager to manage FPGA VIs and
aliases.

6. Return to the front panel of the Digital (FPGA) VI. Figure 6 shows the
front panel of the Digital (FPGA) VI. Notice that the execution target
appears in the lower left corner of the window.
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Figure 6. Front Panel of the FPGA VI

Select Help»Show Context Help and move the cursor over the VI
icon in the upper right corner of the window. Notice the Context Help
window contains information to help you set up and run the example.
You can use the Context Help window in all FPGA Module Getting
Started examples to learn how to set up and run each example.

Click the Run button. The FPGA Module determines which VI
currently resides on the FPGA device, and if the Digital (FPGA) VI
does not exist on the FPGA device, the FPGA Module downloads and
runs it on the FPGA device.

Click the push buttons in the Digital QOutputs panel and notice how
they affect the LEDs in the Digital Inputs panel. For example, when
you click the DO 14 push button, the DI 14 LED turns on. When you
click the DO 15 button, the DI 15 LED turns on. However, if you click
the DO 4 or DO 5 push buttons, nothing happens. DO 4 and DO 5 are
not configured to write to the same connector pins that DI 0 and DI 1
read, the behavior of which is documented in the Context Help
window for this VL.
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9. Select Window»Show Block Diagram to view the block diagram,
as shown in Figure 7. Notice how the indicators and controls are wired
to the Digital Input and Digital Output functions.

> Digital (FPGA).vi Block Diagram

File Edit ©Operate Tools Browse ‘Window Help %
» [ [@[n][9] k& ot a

i
i

Digital Inpuk 0
Digital Impuk 1
Digital Input 14
Digital Input 15

¥ Digital Oukput 4
¥ Digital Qukput 5
rDigital Cukpok 14
rDigital Oukpok 15

-

FPaA Device (PXI-FE31R) Visa:II'II'II:I.D.SB.ES,I'RIOD::INSTRlI | » v

Figure 7. Block Diagram of the FPGA VI

Refer to the LabVIEW Help, available by selecting Help» VI,
Function, & How-To Help, for information about using these and
other FPGA Device I/O functions in FPGA VIs.

10. Return to the front panel and click the STOP button.

11. Return to the block diagram and double-click the Digital Input
function. The Configure Digital Input dialog box appears. Select
different inputs in the Preview list and notice how each input is
associated with a specific DIO pin in the Alias pull-down menu.

Table 1 shows the mapping of digital input and digital output aliases
to pin names on the NI PXI-7831R. Digital Input 14 and Digital
Output 14 refer to the same physical pin—pin 13. Also, Digital
Input 15 corresponds to Digital Output 15. However, Digital Input 0,
Digital Input 1, Digital Output 4, and Digital Output 5 all refer to
different pins. Refer to the hardware documentation for information
about connector pin and channel assignments.
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Table 1. Mapping of Digital Inputs and Outputs on Connector 0 for the NI PXI-7831R

Terminal Alias Connector Pin

Digital Input O Pin 36
Digital Input 1 Pin 37
Digital Input 14 Pin 13
Digital Input 15 Pin 47
Digital Output 4 Pin 40
Digital Output 5 Pin 41
Digital Output 14 Pin 13
Digital Output 15 Pin 47
Digital Ground Pin 2

12. Click the Cancel button to close the Configure Digital Input

dialog box.

13. Close the Digital (FPGA) LEP file. The Digital (FPGA) VI also closes.

Refer to Chapter 2, Creating FPGA Vls, of the LabVIEW FPGA Module
User Manual for information about designing FPGA VIs.

Exploring a Host VI

The Digital (Host) VI demonstrates basic concepts of communicating with
the FPGA VI running on the FPGA device from a VI running on a
Windows computer or networked RT target. Complete the following steps
to view and run an example of a host VI.

1.

After completing the steps in the Exploring an FPGA VI section, select
LabVIEW for Windows or an RT target as the execution target. Host
VIs run on the host computer, which can be a Windows computer or an
RT target.

From the NI Example Finder, browse according to directory structure
and open FPGA\Getting Started\Programmatic - IO
Primitives\Digital (Host) .vi.

Right-click the Open FPGA VI Reference function on the Digital
(Host) VI block diagram and select the type of FPGA device you have
from the shortcut menu.

Click the Run button.

@ Note You do not need to open an LEP file to run or manage host VIs. Use the Embedded
Project Manager with FPGA Vls.

© National Instruments Corporation
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Figure 8 shows the front panel of the Digital (Host) VI. If you target
LabVIEW to an RT target, the execution target appears in the lower left
corner of the window, as shown in Figure 8.

b Digital {(Host).vi

Figure 8. Front Panel of the Host VI

5. Click the push buttons in the Digital Qutputs panel and notice
how they affect the LEDs on the Digital Inputs panel. The Digital
(Host) VI behaves the same as the Digital (FPGA) VI in the Exploring
an FPGA VI section of this document.

6. Select Window»Show Block Diagram from the Digital (Host) VI
to view the block diagram. The block diagram appears as shown in
Figure 9.
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Figure 9. Block Diagram of the Host VI

Notice that the Digital (Host) VI uses the Open FPGA VI Reference
function to open and run the Digital (FPGA) VI. The image inside the
Open FPGA VI Reference function icon matches the icon for the
Digital (FPGA) VL

The Digital (Host) VI then uses the Read/Write Control function to
read from or write to the indicators and controls in the Digital (FPGA)
VI running on the FPGA device. Specifically the Read/Write control
reads the state of the digital inputs on the FPGA device and allows you
to change the state of the digital outputs on the FPGA device from the
host computer.

The Close FPGA VI Reference function closes the reference to the
FPGA VI. Refer to the LabVIEW Help, available by selecting
Help» VI, Function, & How-To Help, for information about using
these and other FPGA Interface functions in host VIs.

Return to the front panel and click the STOP button on the front panel
to stop the VL.

Close the Digital (Host) VI.

Refer to the FPGA Interface User Guide for information about creating
host VIs that you can use to programmatically interact with FPGA VIs.
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Where to Go from Here

National Instruments provides many resources to help you succeed with
your National Instruments products. Please use the following resources as
you start exploring LabVIEW and the FPGA Module.

FPGA Module Examples

Start with an existing FPGA Module example and use it as a framework for
developing FPGA VIs and host VIs.

From LabVIEW, launch the NI Example Finder by selecting Help»Find
Examples and browse the FpGA directory for examples. You also can
browse according to task to find examples for the FPGA device you use.
Refer to the Description text box for descriptions of the examples to
quickly locate a relevant example.

FPGA Module Templates

The FPGA Module offers templates to help you get started quickly. In the
LabVIEW dialog box, click the New button and browse template previews
and descriptions to find a template appropriate for your application. When
you find a template that you want to use, select it in the Create new list and
click the OK button.

Related Documentation

Refer to the following documents for conceptual information about
LabVIEW, the LabVIEW Real-Time Module, and the FPGA Module.

@ Note You must have Adobe Reader with Search and Accessibility 5.0.5 or later installed
to view the PDFs. Refer to the Adobe Systems Incorporated Web site at www . adobe . com
to download Adobe Reader.

FPGA Module Release Notes

e LabVIEW FPGA Module User Manual (PDF only)—Information
about using the FPGA Module to create FPGA VIs. Select
Start»Programs»National Instruments»LabVIEW 7.1»
Module Documents»LabVIEW FPGA Module User Manual to
view a PDF of the document.

e FPGA Interface User Guide (PDF only)—Information about creating
host VIs to run on Windows computers or RT targets and communicate
with FPGA VIs. Select Start»Programs»National Instruments»
LabVIEW 7.1»Module Documents»FPGA Interface User Guide
to view a PDF of the document.
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LabVIEW User Manual—Information about using LabVIEW to create
VIs. In LabVIEW, select Help»Search the LabVIEW Bookshelf to
search documentation for the LabVIEW development system.

LabVIEW Real-Time Module User Manual—Information about using
the LabVIEW Real-Time Module to create deterministic VIs. In
LabVIEW, select Help»Search the Real-Time Module Bookshelf to
search documentation for the LabVIEW Real-Time Module.

Refer to the LabVIEW Help and Context Help window for information
about using VIs and functions.

LabVIEW Help—Auvailable by selecting Help» V1, Function,

& How-To Help. Browse the FPGA Module book in the Contents
tab for an overview of the FPGA Module and hardware-specific
information included in the LabVIEW Help. Browse the FPGA
Interface book in the Contents tab for an overview of the FPGA
Interface information included in the LabVIEW Help.

Context Help window—Available by selecting Help»Show Context
Help.

Refer to the following hardware documentation for information about
specific FPGA devices. If you have an FPGA device not listed, refer to the
specific hardware documentation.

© National Instruments Corporation

CompactRIO Bookshelf—Information about using CompactRIO I/O
modules with the FPGA Module. Select Start»Programs»National
Instruments»CompactRIO»Search the CompactRIO Bookshelf to
search CompactRIO software and hardware documentation.

Getting Started with the NI 7831 R—Information about setting up
the NI PCI-7831R and the NI PXI-7831R devices. Select Start»
Programs»National Instruments»NI-RIO»PCI-7831R»
Getting Started with the NI 7831R or select Start»>Programs»
National Instruments»NI-RIO»PXI-7831R»Getting Started
with the NI 7831R to view a PDF of the document.

Getting Started with the NI PXI-7811R—Information about
setting up the NI PXI-7811R device. Select Start»Programs»
National Instruments»NI-RIO»PXI-7811R»Getting Started
with the NI PXI-7811R to view a PDF of the document.

NI 7831R User Manual—Information about the NI PCI-7831R

and the NI PXI-7831R devices. Select Start»Programs»

National Instruments»NI-RIO»PCI-7831R»NI 7831R User
Manual or select Start»Programs»National Instruments»NI-RIO»
PXI-7831R»NI 7831R User Manual to view a PDF of the document.
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e NI PXI-7811R User Manual—Information about the NI PXI-7811R
device. Select Start»Programs»National Instruments»NI-RIO»
PXI-7811R»NI PXI-7811R User Manual to view a PDF of the
document.

NI Web Site

Visit ni . com for the latest NI Developer Zone articles, examples, and
support information for the FPGA Module.

Known Issues

Refer to readme . html on the LabVIEW FPGA Module CD for
information about known issues with the FPGA Module.
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