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READ ME FIRST

PXI -8150 SERIES FOR WINDOWS 95/NT
This document contains information to help you understand the 

components of your kit, determine where to start setting up your kit, 

and learn about the NI-VISA features.
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What Do You Have?

Your kit contains hardware, software, and documentation. You may also 

have ordered some optional equipment or software.

Hardware
Your hardware includes either the PXI-8155 Series or the PXI-8156 Series 

controller, which you install in your PXI mainframe, and an AT-PS/2 cable.

™
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Software
Your PXI-8150 Series controller comes with National Instruments 

software already installed on its hard drive.

Windows 95 Kit
The Windows 95 kit contains the following software:

• Windows 95 CD-ROM

• NI-VISA for Windows 95/NT

• NI-488.2M Software for Windows 95 (PXI-8156 Series only)

• Diskette containing PXI System Initialization File for PXI-8155/8156 

and PXI-1000/1010

Windows NT Kit
The Windows NT kit contains the following software:

• Windows NT CD-ROM with boot disk

• NI-VISA for Windows 95/NT

• NI-488.2M Software for Windows NT (PXI-8156 Series only)

• Diskette containing PXI System Initialization File for PXI-8155/8156 

and PXI-1000/1010

Additional Installed Software
Your PXI controller’s hard drive contains the National Instruments 

LabVIEW and LabWindows™/CVI software. The National Instruments 

NI-DAQ software is also pre-installed on all PXI controllers to support the 

National Instruments data acquisition boards. A copy of all software media, 

excluding LabVIEW and LabWindows/CVI, is available in the 

c:\images directory for immediate access.

Both LabVIEW and LabWindows/CVI integrate the VISA library 

interfaces that are required to support your PXI embedded controller. You 

also get hundreds of complete instrument drivers, which are modular, 

source-code programs that handle the communication with your instrument 

to speed your application development.

Available Options
You may have ordered the following optional software:

• LabVIEW Development software (CD-ROM). You also receive the 

LabVIEW Configuration Disk so you can activate LabVIEW.

• LabWindows/CVI Development software (CD-ROM). You also 

receive the LabWindows/CVI Configuration Disk so you can activate 

LabWindows/CVI.
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Printed Documentation
Aside from this document, your kit contains the following printed manuals:

• Getting Started with Your PXI-8150 Series for Windows 95/NT 

contains an overview of the PXI hardware and the NI-VISA software, 

guides you through setting up your kit, and helps you get started with 

application development. You can also use this manual as a reference 

for the hardware and software default settings, to find the answers for 

commonly asked questions, and for information on reinstalling the 

software, if necessary.

• The PXI-8150 Series User Manual contains information on 

configuring and installing your PXI controller. You may not require 

this manual if you are performing a simple hardware installation that 

uses the standard default settings. However, you should keep this 

manual handy in case you decide to try a different switch or jumper 

setting at a later time. The user manual also contains information on 

BIOS, the front panel and connectors, LEDs, and system resources.

• NI-488.2M documentation includes the following manuals 

(PXI-8156 Series only):

– NI-488.2M User Manual for Windows 95 and Windows NT

– NI-488.2M Function Reference Manual for Win32

• Declaration of Conformity document concerning FCC and 

CE compliance

• Hardware registration card

Acrobat (Online) Documentation
Your kit includes manuals that are not in printed form. These other 

manuals are available as Adobe Acrobat version 3.0 portable document 

format (PDF) files. You can view these manuals online, navigate through 

them, and print them from your computer. Adobe Acrobat Reader 3.0 is 

installed on your PXI controller’s hard drive. In the event of an upgrade, or 

if you need to reinstall the Reader, you can obtain the latest Adobe Acrobat 

Reader directly from Adobe.

Adobe maintains a Bulletin Board Service (BBS), which you can use to 

upload files to Adobe Technical Support and download certain Adobe files. 

The number for the Adobe BBS is 206-623-6984. It is located in Seattle, 

Washington, which is in the Pacific time zone. If you live outside the 

United States or Canada, you are welcome to connect to the BBS, but may 

first want to try Adobe’s Web site (http://www.adobe.com/) or FTP 

site (ftp://ftp.adobe.com/), which may be accessible at a 

significantly lower connection cost.
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The following list shows the path and filenames of the Acrobat manuals 

that are available on your hard drive (where Winxx is either Win95 or 

WinNT):

• c:\VXIpnp\Winxx\NIvisa\Manuals\NI-VISAUsersMan.pdf

This is the NI-VISA User Manual, which describes how to program 

using VISA.

• c:\VXIpnp\Winxx\NIvisa\Manuals

\NI-VISAProgrammersMan.pdf

This is the NI-VISA Programmer Reference Manual, which describes 

in detail the attributes, events, and operations you use in NI-VISA.

• c:\Images\pxi815x\Manuals\5446TRM.pdf

This is the CL-GD5446 Technical Reference Manual provided by 

Cirrus Logic describing their software utilities.

Here are some tips on using PDF files efficiently:

• To view and print the online documentation, launch the Acrobat 

Reader and open the PDF documents. You can assemble your own 

printed documentation by printing out either the entire document or 

only the sections relevant to your application.

• To use hypertext links, click on any entry in the table of contents to 

jump directly to that topic’s page. You can jump to major sections 

within each manual quickly and easily by clicking on the bookmarks. 

When you open your PDF documents, the bookmarks show. A 

bookmark with a triangle in front of it has bookmarks within it. 

To reveal the next level, click on the triangle. To collapse to a higher 

level, click on the triangle.

• You can change the magnification of the documents either by selecting 

the magnifying glass tool in the toolbar and clicking anywhere on the 

manual page or by using the various options in the View menu.

• You can quickly find and go to every occurrence of any word or phrase 

in the entire document. Select the Tools»Find... option and type in the 

key word or phrase you want to find.

• The PDF file assigns consecutive numbers to each page throughout the 

document and displays this page number in the lower-left corner of the 

Acrobat window. When you choose the View»Go To Page... option or 

are printing pages, you must use the page numbers in the lower-left 

corner of the window, not the number displayed at the bottom center of 

each manual page or listed in the contents and index. The number 

shown in the bottom center of the page is for printed documents only.
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Important Information for Windows NT Users

This section contains information about preparing your Windows NT 

system and where to find a copy of the Windows NT installer should you 

need to reinstall it.

Logon and Password
You must provide a logon name to receive Windows NT administrator 

privileges. Log on as Administrator. The password is not configured on 

your unit at this point, so you can just press the <RETURN> key.

After you have successfully logged on to Windows NT, you need to 

immediately change the password to ensure a secure Windows NT system.

Reinstalling Windows NT
Your PXI embedded controller comes with a copy of the Windows NT 

installation disks on your hard drive in case you need to reinstall 

Windows NT. To begin installation, boot from a DOS floppy disk and then 

type WINNT /B from the C:\IMAGES\OS\NT40\i386 directory.

The Windows NT operating system on your hard drive has been 

pre-installed with the latest Windows NT Service Pack. National 

Instruments recommends you use the latest version available. You can find 

a copy of the installation disks on your hard drive in the 

C:\IMAGES\OS\NT40\NT4_SPx directory.

Should it be necessary to reinstall the Service Pack, you can either reinstall 

from the copy on your hard drive or you can download the latest Service 

Pack version from the Microsoft Corporation World Wide Web site at 

www.microsoft.com.

Where Do You Start?

1. Compare your kit contents with the description in the preceding What 

Do You Have? section. Contact National Instruments regarding any 

discrepancies.

2. If you ordered the LabVIEW or LabWindows/CVI software option, 

your kit includes either a LabVIEW or LabWindows/CVI 

configuration disk. Because both LabVIEW and LabWindows/CVI are 

pre-installed on your hard drive in a nonfunctional mode, you need to 

insert the configuration disk when prompted to activate the installed 

software.
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Note: If you do not insert the configuration disks when prompted, Setup deletes the 

pre-installed LabVIEW and LabWindows/CVI software from your hard drive. 

However, you can reinstall them from disk, as described in the next section.

Otherwise, if you ordered a kit that does not contain the configuration 

disks, install LabVIEW or LabWindows/CVI from disk if you want to 

use either programming environment. Then reinstall the NI-VISA 

software from disk or from the copy located in the c:\images 

directory. The NI-VISA installer updates necessary files in the 

LabVIEW and LabWindows/CVI directories to ensure that the latest 

development files are being used.

3. If you require peripheral support for Ethernet, video, or IDE, refer to 

the file c:\images\pxi815x\drivers.txt. The drivers.txt 

file contains the following information:

• Section 1 explains the procedure for recreating the hard drive 

image should the operating system crash.

• Section 2 describes how to access the online documentation.

• Section 3 explains how to install the software drivers for the 

various peripherals on your PXI controller.

• Section 4 describes how to install NI-DAQ for use with the 

National Instruments PXI data acquisition boards.

• Section 5 includes important information for Windows NT 4.0 

users.

• Section 6 describes how to install USB under Windows 95.

4. Please refer to the file c:\VXIpnp\Winxx\README.TXT for 

important information that may affect your application program, 

including known issues and software corrections with this release, and 

additional information relevant for NI-VISA API development.

You can also reference the National Instruments www.natinst.com 

or ftp.natinst.com sites for driver updates, examples, and product 

news.

What Is VISA?

VISA is a standard I/O Application Programming Interface (API) for 

instrumentation programming. VISA by itself does not provide 

instrumentation programming functionality for interfaces other than Serial. 

VISA is a high-level API that calls into system-level drivers. As an 

example, the NI-VISA implementation of VISA uses the NI-VXI 

system-level driver for National Instruments VXI controllers. If you are a 

GPIB or GPIB-VXI user, you must also install the NI-488.2 system-level 

driver for National Instruments GPIB controllers.
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VISA can control VXI, PXI, GPIB, or Serial instruments, making the 

appropriate driver calls depending on the type of instrument being used. 

VISA uses the same operations to communicate with instruments 

regardless of the interface type. For example, the VISA command to write 

an ASCII string to a message-based instrument is the same whether the 

instrument is Serial, GPIB, VXI, or PXI. As a result, VISA gives you 

interface independence. This makes it easier to switch bus interfaces and 

means that users who must program instruments for multiple interfaces 

need learn only one API.

Another advantage of VISA is that it is an object-oriented API that will 

easily adapt to new instrumentation interfaces as they evolve, making 

application migration to the new interfaces easy.

Because VISA is the industry standard for developing instrument drivers, 

most instrument drivers currently written by National Instruments use 

VISA and therefore support Macintosh, Windows 3.x, Windows 95, 

Windows NT, Solaris 1, Solaris 2, and HP-UX, if the system-level drivers 

are available for that platform.

NI-VISA Release Notes

This section describes the new utilities and features in this release of 

NI-VISA for Windows 95/NT.

New Utilities
This release of NI-VISA for Windows 95/NT includes two new utilities to 

help you configure, develop, and debug your system quickly: T&M 

Explorer and NI Spy.

You can use T&M Explorer to view your entire T&M system and configure 

various components. When you launch T&M Explorer, a list of your PXI, 

VXI, GPIB, and Serial devices appears on your screen. To view the 

properties of each device (such as logical address, address space used, 

primary address), right-click on the device in the list. When you view the 

properties of a National Instruments device, you can configure the 

hardware settings directly from the properties list.

T&M Explorer replaces many earlier utilities, such as VISAconf, and 

integrates with the NI-DAQ Configuration Utility. T&M Explorer also has 

new features, such as an option to launch VISAIC from T&M Explorer, and 

troubleshooting to guide you through configuration conflicts and errors.

NI Spy tracks the calls your application makes to National Instruments 

T&M drivers, including NI-VISA and NI-488.2. It highlights functions that 



return errors, so you can quickly determine which functions failed during 

your development. NI Spy can also log your program’s calls to these 

drivers, so you can check them for errors at your convenience.

Supported Application Development Environments
This release of NI-VISA for Windows 95/NT supports the following 

Application Development Environments (ADEs):

• LabVIEW version 4.x

• LabWindows/CVI version 4.x

• Borland C/C++ version 4.5.x

• Microsoft Visual C/C++ version 4.x, 5.x

• Microsoft Visual Basic version 4.x, 5.x

Note: Although NI-VISA has been tested and found to work with these ADEs, other 

ADEs or higher versions of the ADEs listed above may also work.
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