
 
 PXIe-5423

https://www.apexwaves.com/modular-systems/national-instruments/pxi-waveform-generators/PXIe-5423?aw_referrer=pdf
https://www.apexwaves.com/modular-systems/national-instruments/pxi-waveform-generators/PXIe-5423?aw_referrer=pdf
https://www.apexwaves.com/modular-systems/national-instruments/pxi-waveform-generators/PXIe-5423?aw_referrer=pdf


GETTING STARTED GUIDE

PXIe-5423
40 MHz Bandwidth, 16-Bit PXI Waveform Generator

This document explains how to install, configure, test, and use the PXIe-5423. The PXIe-5423
ships with NI-FGEN driver software, which you can use to program the module.

Note  Before you begin, install and configure your chassis and controller.

Caution  This icon denotes a caution, which advises you to consult documentation
where this symbol is marked.

Caution  You can impair the protection provided by the PXIe-5423 if you use it in
a manner not described in this document.
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Electromagnetic Compatibility Guidelines
This product was tested and complies with the regulatory requirements and limits for
electromagnetic compatibility (EMC) stated in the product specifications. These requirements
and limits provide reasonable protection against harmful interference when the product is
operated in the intended operational electromagnetic environment.

This product is intended for use in industrial locations. However, harmful interference may
occur in some installations, when the product is connected to a peripheral device or test object,
or if the product is used in residential or commercial areas. To minimize interference with
radio and television reception and prevent unacceptable performance degradation, install and
use this product in strict accordance with the instructions in the product documentation.

Furthermore, any changes or modifications to the product not expressly approved by National
Instruments could void your authority to operate it under your local regulatory rules.

Caution  To ensure the specified EMC performance, operate this product only with
shielded cables and accessories.

Caution  To ensure the specified EMC performance, the length of all I/O cables
must be no longer than 3 m (10 ft).

Verifying the System Requirements
To use the PXIe-5423, your system must meet certain requirements.

For more information about minimum system requirements, recommended system
requirements, and supported ADEs, refer to the readme for your selected software support.
Readmes are available on the driver software DVD and online at ni.com/updates.

Unpacking the Kit
Refer to the following figure to identify the contents of the PXIe-5423 kit.
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Figure 1. PXIe-5423 Kit Contents
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1. PXIe-5423

2. PXIe-5423 Getting Started Guide (this document)

3. Maintain Forced-Air Cooling Note to Users

Caution  To prevent electrostatic discharge (ESD) from damaging the module,
ground yourself using a grounding strap or by holding a grounded object, such as
your computer chassis.

1. Touch the antistatic package to a metal part of the computer chassis.
2. Remove the module from the package and inspect it for loose components or other signs

of damage.

Caution  Never touch the exposed pins of connectors.

Note  Do not install a module if it appears damaged in any way.

3. Unpack any other items and documentation from the kit.

Store the module in the antistatic package when the module is not in use.

Other Equipment
There are several required items not included in your PXIe-5423 kit that you need to operate
the PXIe-5423. Your application may require additional items not included in your kit to
install or operate your PXIe-5423.

Required Items

• A PXI chassis and chassis documentation
• A PXI controller or PC with a device for PXI remote control system that meets the

system requirements specified in this guide and chassis documentation
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Optional Items

• PXI slot blocker kit (NI part number 199198-01)
• SCB-19 connector block (NI part number 785642-01)
• SHH19-MH19-AUX shielded single-ended cable, 1 M (NI part number 784091-01)

Visit ni.com for more information about these additional items.

Preparing the Environment
Ensure that the environment you are using the PXIe-5423 in meets the following
specifications:

Maximum altitude 2,000 m (800 mbar) (at 25 °C ambient
temperature)

Pollution Degree 2

Operating ambient temperature range 0 °C to 55 °C (Tested in accordance with
IEC 60068-2-1 and IEC 60068-2-2. Meets
MIL-PRF-28800F Class 3 low temperature
limit and MIL-PRF-28800F Class 2 high
temperature limit.)

Operating relative humidity range 10% to 90%, noncondensing (Tested in
accordance with IEC 60068-2-56.)

Indoor use only.

Related Information

Refer to the PXIe-5423 Specifications at ni.com for complete specifications.

Installing the Software
You must be an Administrator to install NI software on your computer.
1. Install an ADE, such as LabVIEW or LabWindows™/CVI™.
2. Visit ni.com/downloads/drivers and search for NI-FGEN.

3. Download the latest version of NI-FGEN by clicking Download and then running the
executable (.exe) file.

4. Follow the instructions in the installation prompts.

Note  Windows users may see access and security messages during
installation. Accept the prompts to complete the installation.

5. When the installer completes, select Restart in the dialog box that prompts you to restart,
shut down, or restart later.
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Installing the PXIe-5423

Caution  To prevent damage to the PXIe-5423 caused by ESD or contamination,
handle the module using the edges or the metal bracket.

Caution  Clean the hardware with a soft, nonmetallic brush. Make sure that the
hardware is completely dry and free from contaminants before returning it to
service.

The PXIe-5423 is a single-slot module with one backplane connector. The module may be
installed into any PXI Express-compatible slot.
1. Ensure the AC power source is connected to the chassis before installing the PXIe-5423.

The AC power cord grounds the chassis and protects it from electrical damage while you
install the PXIe-5423.

2. Power off the chassis.
3. Inspect the slot pins on the chassis backplane for any bends or damage prior to

installation. Do not install a module if the backplane is damaged.
4. Position the chassis so that inlet and outlet vents are not obstructed.

For more information about optimal chassis positioning, refer to the chassis
documentation.

5. Remove the black plastic covers from all the captive screws on the module front panel.
6. Identify a supported slot in the chassis. The following figure shows the symbols that

indicate the slot types.

Figure 2. Chassis Compatibility Symbols

NI PXIe-1062Q

1 2 3 4 5

1. PXI Express System Controller Slot

2. PXI Peripheral Slot

3. PXI Express Hybrid Peripheral Slot

4. PXI Express System Timing Slot

5. PXI Express Peripheral Slot

PXIe-5423 modules can be placed in PXI Express peripheral slots, PXI Express hybrid
peripheral slots, or PXI Express system timing slots.

7. Touch any metal part of the chassis to discharge static electricity.
8. Ensure that the ejector handle is in the downward (unlatched) position.
9. Place the module edges into the module guides at the top and bottom of the chassis. Slide

the module into the slot until it is fully inserted.
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Figure 3.  Module Installation
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NI PXIe-1075

1

1. Chassis

2. Hardware Module

3. Ejector Handle in Downward (Unlatched) Position

10. Latch the module in place by pulling up on the ejector handle.
11. Secure the module front panel to the chassis using the front-panel mounting screws.

Note  Tightening the top and bottom mounting screws increases mechanical
stability and also electrically connects the front panel to the chassis, which can
improve the signal quality and electromagnetic performance.

12. Cover all empty slots using EMC filler panels or fill using slot blockers to maximize
cooling air flow, depending on your application.

13. Power on the chassis.

Related Information

Why Is the ACCESS LED Off When the Chassis Is On? on page 14

PXIe-5423 Pinout and LEDs

Front Panel

Refer to the following figure and tables for information about the one- and two-channel
PXIe-5423 front panel connectors and LEDs.
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Table 1. PXIe-5423 Signal Descriptions

Signal Connector

Type

Access Description

     1 CH 0 SMA Output Generates waveforms from an analog output
terminal.

2 CH 1

3 PFI 0 Input/Output Imports digital trigger signals and exports
digital event signals. Imported digital trigger
signals can start or step through waveform
generation, and exported event signals indicate
the state of the generation engine.

4 PFI 1

5 AUX 0 MHDMR Routes digital trigger and event signals with
eight bidirectional PFI lines and provides a
+3.3 V power source.

The ACCESS LED indicates basic hardware status.
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Table 2. PXIe-5423 ACCESS LED Indicators

LED Color Indication

   6 No color (off) The PXIe-5423 is not yet functional.

Amber The PXIe-5423 is being accessed.

Green The PXIe-5423 is ready to be programmed by NI-FGEN.

The ACTIVE LED indicates the PXIe-5423 hardware state.

Table 3.  PXIe-5423 ACTIVE LED Indicators

LED Color Indication

   7 No color (off) The PXIe-5423 is not generating.

Amber The PXIe-5423 is armed and waiting for a trigger.

Green The PXIe-5423 has received a trigger and is generating a waveform.

Red The PXIe-5423 has detected an error. NI-FGEN must access the
PXIe-5423 to determine the cause of the error. The LED remains red until
the error condition is removed. Example errors include the following:
• Phase-locked loop (PLL) unlocked: The PXIe-5423 has detected an

unlocked condition on a previously locked PLL. A PLL that is
unlocked while in reset does not show an error.

• The PXIe-5423 has powered down because the internal temperature
exceeded the maximum limit. The over-temperature condition must
be corrected and the hardware reset. To reset the hardware, call
niFgen Reset Device or niFgen_ResetDevice.1

AUX 0 Connector

Note  The AUX 0 connector accepts a standard, third-party HDMI™ type C cable,
but the AUX 0 port is not an HDMI interface and the specified performance of the
AUX 0 connector is not guaranteed if a third-party HDMI cable is used. Use NI
cable assembly SHH19-MH19-AUX for all AUX 0 connections. Do not connect the
AUX 0 port on the PXIe-5423 to the HDMI port of another device. NI is not liable
for any damage resulting from such signal connections.

Refer to the following figure and table for information about the PXIe-5423 AUX 0 connector
pins.

1 For more information about keeping the PXIe-5423 within internal temperature limits, refer to the
Maintain Forced-Air Cooling Note to Users included with your PXIe-5423 and at ni.com.
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Table 4. AUX 0 Pin Signal Descriptions

Pin Signal Description

   1 GND Ground reference for signals

2 NC No connection

3 GND Ground reference for signals

4 GND Ground reference for signals

5 NC No connection

6 GND Ground reference for signals

7 GND Ground reference for signals

8 AUX 0/PFI 0 Bidirectional PFI line

9 AUX 0/PFI 1 Bidirectional PFI line

10 GND Ground reference for signals

11 AUX 0/PFI 2 Bidirectional PFI line

12 AUX 0/PFI 3 Bidirectional PFI line

13 GND Ground reference for signals

14 AUX 0/PFI 4 Bidirectional PFI line
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Table 4. AUX 0 Pin Signal Descriptions (Continued)

Pin Signal Description

   15 AUX 0/PFI 5 Bidirectional PFI line

16 AUX 0/PFI 6 Bidirectional PFI line

17 AUX 0/PFI 7 Bidirectional PFI line

18 +3.3 V +3.3 V power output (200 mA maximum)

19 GND Ground reference for signals

PXIe-5423 SCB-19 Pinout
NI recommends using the SCB-19 connector block to connect digital signals to the AUX 0
connector on the PXIe-5423 front panel. Refer to the following figure and table for
information about the SCB-19 signals when connected to the AUX 0 front panel connector.

1 2 3 4 5 6 7 8 9 10

14 15 16 17 18 19 20 21 22 23

11 12 13

24 25 26

Table 5. SCB-19 Signal Descriptions

Pin Signal Description

   1 PFI 0 Bidirectional PFI line

2 PFI 1 Bidirectional PFI line

3 PFI 2 Bidirectional PFI line

4 PFI 3 Bidirectional PFI line

5 NC No connection

6 NC No connection

7 NC No connection
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Table 5. SCB-19 Signal Descriptions (Continued)

Pin Signal Description

   8 NC No connection

9 PFI 4 Bidirectional PFI line

10 PFI 5 Bidirectional PFI line

11 PFI 6 Bidirectional PFI line

12 PFI 7 Bidirectional PFI line

13 +3.3 V +3.3 V power (200 mA maximum)

<14..26> GND Ground reference for signals

Configuring the PXIe-5423 in MAX
Use Measurement & Automation Explorer (MAX) to configure your NI hardware. MAX
informs other programs about which NI hardware products are in the system and how they are
configured. MAX is automatically installed with NI-FGEN.
1. Launch MAX.
2. In the configuration tree, expand Devices and Interfaces to see the list of installed NI

hardware.

Installed modules appear under the name of their associated chassis.
3. Expand your Chassis tree item.

MAX lists all modules installed in the chassis. Your default names may vary.

Note  If you do not see your module listed, press <F5> to refresh the list of
installed modules. If the module is still not listed, power off the system, ensure
the module is correctly installed, and restart.

4. Record the identifier MAX assigns to the hardware. Use this identifier when
programming the PXIe-5423.

5. Self-test the hardware by selecting the item in the configuration tree and clicking Self-
Test in the MAX toolbar.

The MAX self-test performs a basic verification of hardware resources.

Related Information

What Should I Do if the PXIe-5423 Doesn't Appear in MAX? on page 15
What Should I Do if the PXIe-5423 Fails the Self-Test or Self-Calibration? on page 15
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Self-Calibrating the PXIe-5423
Self-calibration adjusts the PXIe-5423 for variations in the module environment using an
onboard high-precision calibration ADC. Perform a complete self-calibration after the first
time you install the PXIe-5423.
1. Install the PXIe-5423 and let it warm up for 15 minutes.

Note  Warm up begins when the PXI Express chassis has been powered on and
the operating system has completely loaded.

2. Self-calibrate the PXIe-5423 by clicking the Self-Calibrate button in MAX or calling
niFgen Self Cal or niFgen_SelfCal.

The PXIe-5423 modules are externally calibrated at the factory but you should perform a self-
calibration in all of the following situations:
• After first installing the PXIe-5423 in a chassis
• After any module that is in the same chassis as the PXIe-5423 is installed, uninstalled, or

moved
• When the PXIe-5423 is in an environment where the ambient temperature varies or the

PXIe-5423 temperature has drifted more than ±5 °C from the temperature at the last self-
calibration

• Periodic adjustment for small performance drifts that occur with product aging

Related Information

What Should I Do if the PXIe-5423 Fails the Self-Test or Self-Calibration? on page 15

Generating Waveforms with the NI-FGEN Soft

Front Panel
Complete the following steps to generate a standard waveform or an arbitrary waveform using
the NI-FGEN Soft Front Panel (SFP):
1. Launch the NI-FGEN SFP.
2. Verify that the PXIe-5423 appears on the NI-FGEN SFP display.
3. If you are using a two-channel PXIe-5423, choose a channel from the Channel list.

To generate waveforms on multiple channels, repeat steps 3 and 4 to load a waveform to
each channel.
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4. Click one of the following Mode buttons and complete the following associated steps to
configure your PXIe-5423 for waveform generation:
• Standard Function Output 

1. Click one of the waveform pattern buttons to choose the type of standard
function to produce.

2. Select a variable to set from the drop-down listbox.
3. Set the frequency, amplitude, DC offset, phase, or duty cycle using the dial to

control the value.
• Single Arbitrary Waveform Output 

1. Click the Current Waveform Pattern button  and then click Load
Waveform from disk.
The Select File dialog box opens and displays waveform example files.

Note  You also can download a waveform by selecting File»Load
New Waveform.

2. Choose a waveform file and click OK.
The File Load dialog box and Waveform Preview window launch. You can
close or minimize the Waveform Preview window.

3. In the File Load dialog box, choose a waveform from the Waveform list.
4. Click OK.

5. Click Run to start waveform generation.

To optimize the waveform, select Edit»Device Configuration and adjust the settings.

NI-FGEN Instrument Driver
You can control your signal generator programmatically using the supplied PXIe-5423
Interchangeable Virtual Instrument (IVI) driver and an ADE.

The NI-FGEN API features a set of operations and attributes that exercise all of the
functionality of the PXIe-5423 hardware, including configuration, control, and other model-
specific functions.

You can run the NI-FGEN examples to demonstrate basic waveform generator applications.
Examples display the functionality of the PXIe-5423 and serve as programming models and
building blocks for your own applications. LabVIEW, LabWindows/CVI, C, and .NET
examples are located at Start»All Programs»National Instruments»NI-FGEN»NI-FGEN
Examples.

Generating Waveforms with NI-FGEN and

LabVIEW
1. Launch LabVIEW.
2. Select Help»Find Examples.
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3. Select Hardware Input and Output»Modular Instruments»NI-FGEN (Signal
Generators)»Arbitrary Waveform Generation.

4. Double-click an example to open it.

The Fgen Basic Arb Waveform example demonstrates how to get started using arbitrary
waveform mode.

5. Complete the steps on the block diagram.
6. In the Resource Name list, select the device name assigned to the PXIe-5423 in MAX.
7. Click Run to start the example program.

Troubleshooting
If an issue persists after you complete a troubleshooting procedure, contact NI technical
support or visit ni.com/support.

Why Is the ACCESS LED Off When the Chassis Is

On?
The LEDs may not light until the module has been configured in MAX. Before proceeding,
verify that the PXIe-5423 appears in MAX.

If the ACCESS LED fails to light after you power on the chassis, a problem may exist with the
chassis power rails, a hardware module, or the LED.

Caution  Apply external signals only while the PXIe-5423 is powered on.
Applying external signals while the module is powered off may cause damage.

1. Disconnect any signals from the module front panels.
2. Power off the chassis.
3. Remove the module from the chassis and inspect it for damage. Do not reinstall a

damaged module.
4. Install the module in a different chassis slot from which you removed it.
5. Power on the chassis.

Note  If you are using a PC with a device for PXI remote control system,
power on the chassis before powering on the computer.

6. Verify that the module appears in MAX.
7. Perform a self-test.

If the ACCESS LED still fails to light and failures continue, contact NI technical support or
visit ni.com/support.

Related Information

PXIe-5423 Pinout and LEDs on page 6
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What Should I Do if the PXIe-5423 Doesn't Appear in

MAX?
1. In the MAX configuration tree, expand Devices and Interfaces.
2. Expand the Chassis tree to see the list of installed hardware, and press <F5> to refresh

the list.
3. If the module is still not listed, power off the system, ensure that all hardware is correctly

installed, and restart the system.
4. Navigate to the Device Manager.

Operating System Description

  Windows 10/8.1 Right-click the Start button, and select Device Manager.

Windows 7 Select Start»Control Panel»Device Manager.

5. Verify the PXIe-5423 appears in the Device Manager.
a) Under an NI entry, confirm that a PXIe-5423 entry appears.

Note  If you are using a PC with a device for PXI remote control system,
under System Devices, also confirm that no error conditions appear for the
PCI-to-PCI Bridge.

b) If error conditions appear, reinstall NI-FGEN and the PXIe-5423.

What Should I Do if the PXIe-5423 Fails the Self-Test

or Self-Calibration?
1. Restart the system.
2. Launch MAX, and perform the self-test or self-calibration again.
3. Power off the chassis.
4. Reinstall the failed module in a different slot.
5. Power on the chassis.
6. Perform the self-test or self-calibration again.

Where to Go Next
Refer to the following figure to locate more information about using the PXIe-5423.
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Figure 4. Resources for the PXIe-5423

*This item is also installed with the driver software.
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PXIe-5423 Firmware Licensing
Software is licensed pursuant to the software license agreements provided with the software
or, in the absence of such license agreements, the National Instruments Software License
Agreement available at ni.com/legal at the time of purchase.

For a copy of the software licenses applicable to the firmware for this hardware product, as
well as copies of third party licenses and any required notices shipped with the firmware, visit 
ni.com/info and enter the Info Code PXIe5423ThirdPartyLicensing.

Worldwide Support and Services
The NI website is your complete resource for technical support. At ni.com/support, you have
access to everything from troubleshooting and application development self-help resources to
email and phone assistance from NI Application Engineers.

Visit ni.com/services for NI Factory Installation Services, repairs, extended warranty, and
other services.
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Visit ni.com/register to register your NI product. Product registration facilitates technical
support and ensures that you receive important information updates from NI.

A Declaration of Conformity (DoC) is our claim of compliance with the Council of the
European Communities using the manufacturer’s declaration of conformity. This system
affords the user protection for electromagnetic compatibility (EMC) and product safety. You
can obtain the DoC for your product by visiting ni.com/certification. If your product supports
calibration, you can obtain the calibration certificate for your product at ni.com/calibration.

NI corporate headquarters is located at 11500 North Mopac Expressway, Austin, Texas,
78759-3504. NI also has offices located around the world. For telephone support in the United
States, create your service request at ni.com/support or dial 1 866 ASK MYNI (275 6964). For
telephone support outside the United States, visit the Worldwide Offices section of ni.com/
niglobal to access the branch office websites, which provide up-to-date contact information,
support phone numbers, email addresses, and current events.
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