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GETTING STARTED GUIDE

NI PXIe-5696
250 kHz to 20 GHz Amplitude Extender

Note  Before you begin, install and configure your chassis and controller.

This document explains how to install, configure, and test the NI PXIe-5696 (NI 5696) as a
20 GHz amplitude extender (AE) module to the NI PXIe-5654 (NI 5654) RF signal generator.
The NI 5696 ships with the NI-RFSG instrument driver, which you use to program the device.

Note  The NI 5696 AE module is supported for use with only the NI 5654 RF
signal generator.

To access NI 5696 documentation, navigate to Start»All Programs»National Instruments»
NI-RFSG»Documentation.

The specifications document for your device is installed with the driver software. Refer to 
ni.com/manuals for the most recent specifications for your device.

Caution  The protection provided by this product may be impaired if it is used in a
manner not described in this document.

Hot Surface  If the NI 5696 has been in use, it may exceed safe handling
temperatures and cause burns. Allow the NI 5696 to cool before removing it from
the chassis.
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Electromagnetic Compatibility Guidelines
This product was tested and complies with the regulatory requirements and limits for
electromagnetic compatibility (EMC) stated in the product specifications. These requirements
and limits are designed to provide reasonable protection against harmful interference when the
product is operated in the intended operational electromagnetic environment.

This product is intended for use in industrial locations. However, harmful interference may
occur in some installations, when the product is connected to a peripheral device or test object,
or if the product is used in residential or commercial areas. To minimize interference with
radio and television reception and prevent unacceptable performance degradation, install and
use this product in strict accordance with the instructions in the product documentation.

Furthermore, any modifications to the product not expressly approved by National Instruments
could void your authority to operate it under your local regulatory rules.

Caution  To ensure the specified EMC performance, operate this product only with
shielded cables and accessories.

Caution  To ensure the specified EMC performance, the length of all I/O cables
must be no longer than 3 m (10 ft).

Verifying the System Requirements
To use the NI-RFSG instrument driver, your system must meet certain requirements.

Refer to the product readme, which is available on the driver software media or online at 
ni.com/manuals, for more information about minimum system requirements,
recommended system, and supported application development environments (ADEs).

Unpacking the Kit

Caution  To prevent electrostatic discharge (ESD) from damaging the device,
ground yourself using a grounding strap or by holding a grounded object, such as
your computer chassis.

1. Touch the antistatic package to a metal part of the computer chassis.
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2. Remove the device from the package and inspect the device for loose components or any
other sign of damage.

Caution  Never touch the exposed pins of connectors.

Notify NI if the device appears damaged in any way. Do not install a damaged device.
3. Unpack any other items and documentation from the kit.

Store the device in the antistatic package when the device is not in use.

Verifying the Kit Contents
Figure 1. NI 5696 Kit Contents
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1. NI PXIe-5696 Amplitude Extender Module

2. Semi-Rigid SMA-to-SMA Cable, Labeled T, Part

Number 155082A-01

3. Semi-Rigid SMB-to-SMB Cable, Part Number

157672A-05

4. Driver Software DVD

5. NI PXIe-5696 Getting Started Guide (This

Document)

6. Read Me First: Safety and Electromagnetic

Compatibility

7. Maintain Forced-Air Cooling Note to Users
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Other Equipment
There are several required items not included in your device kit that you need to install or
operate the NI 5696.

Required Items

• A PXI Express chassis and chassis documentation. The NI PXIe-1085 chassis is one
available option for your device. For more information about compatible chassis options,
refer to ni.com

• A PXI Express embedded controller or MXI controller system that meets the system
requirements specified in this guide and chassis documentation.

• An NI PXIe-5654 RF signal generator module.

Optional Items

• A 1 N · m standard SMA torque wrench (NI part number 780487-01).

Preparing the Environment
Ensure that the environment you are using the NI 5696 in meets the following specifications.

............................................................................Operating ambient temperature
(IEC 60068-2-1, IEC 60068-2-2)

0 °C to 55 °C

............................................................................Operating relative humidity
(IEC 60068-2-56)

10% to 90%, noncondensing

............................................................................Maximum altitude 2,000 m (800 mbar) (at 25 °C ambient
temperature)

............................................................................Pollution Degree 2

Indoor use only.

Caution  Clean the hardware with a soft, nonmetallic brush. Make sure that the
hardware is completely dry and free from contaminants before returning it to
service.

Note  Refer to the NI PXIe-5654 Specifications at ni.com/manuals for complete
NI 5696 specifications.

Installing the Software
You must be an Administrator to install NI software on your computer.
1. Install an ADE, such as LabVIEW or LabWindows™/CVI™.
2. Insert the driver software DVD into your computer. The installer should open

automatically.
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If the installation window does not appear, navigate to the drive, double-click it, and
double-click autorun.exe.

3. Follow the instructions in the installation prompts to install the NI-RFSG driver software.

Note  Windows users may see access and security messages during
installation. Accept the prompts to complete the installation.

4. When the installer completes, restart your system.

Installing the NI 5696

Caution  To prevent damage to the device caused by ESD or contamination, handle
the device using the edges or the metal bracket.

You must install NI-RFSG before installing the hardware.

Before you install the hardware, refer to the guidelines in the Maintain Forced-Air Cooling
Note to Users included with the module to ensure that the chassis can cool the device
effectively.

To use the included cables, you must install the NI 5696 amplitude extender module in the slot
immediately to the right of the NI 5654 RF signal generator module.
1. Ensure the AC power source is connected to the chassis before installing the modules.

The AC power cord grounds the chassis and protects it from electrical damage while you
install the modules.

2. Power off the chassis.
3. Inspect the slot pins on the chassis backplane for any bends or damage prior to

installation. Do not install a module if the backplane is damaged.
4. Remove the black plastic connectors from all the captive screws on the module front

panel.
5. Identify a supported slot in the chassis. The following figure shows the symbols that

indicate the slot types.

Figure 2. Chassis Compatibility Symbols

NI PXIe-1062Q

1 2 3 4 5

1. PXI Express System Controller Slot

2. PXI Peripheral Slot

3. PXI Express Hybrid Peripheral Slot

4. PXI Express System Timing Slot

5. PXI Express Peripheral Slot

NI 5696 modules can be placed in PXI Express peripheral slots, PXI Express hybrid
peripheral slots, or PXI Express system timing slots.
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6. Touch any metal part of the chassis to discharge static electricity.
7. Ensure that the ejector handle is in the unlatched (downward) position.
8. Place the module edges into the module guides at the top and bottom of the chassis. Slide

the device into the slot until it is fully inserted.

Figure 3.  Module Installation
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1. Chassis
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3. Ejector Handle in Down (Unlatched) Position

9. Latch the module in place by pulling up on the ejector handle.
10. Secure the device front panel to the chassis using the front-panel mounting screws.

Caution  It is important to completely screw the device into the slot, both for
mechanical stability and for creating a solid ground connection, which reduces
signal noise. Improperly secured devices may affect the accuracy of device
specifications.

11. Cover all empty slots using filler panels or slot blockers to maximize cooling air flow.
12. Power on the chassis.

Related Information

Installing the Software on page 4

Direct Connections to the NI 5696
The NI 5696 is a precision RF instrument that is sensitive to ESD and transients. Ensure you
take the following precautions when making direct connections to the NI 5696 to avoid
damaging the device.

Note  Do not apply external signals to the NI 5696. Applying external signals may
cause damage.
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• Ensure you are properly grounded when manipulating cables or antennas connected to the
NI 5696.

• If you are using noninsulated devices, such as a noninsulated RF antenna, ensure the
devices are maintained in a static-free environment.

• If you are using an active device, such as a preamplifier or switch routed to the NI 5696,
ensure no signal transients are sourced to the NI 5696.

Connecting to the NI 5654
Figure 4. NI 5654 with NI 5696 Front Panel Interconnection
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1. Semi-Rigid SMB-to-SMB Cable

2. Semi-Rigid SMA-to-SMA Cable, Labeled T

1. Use the SMB-to-SMB cable to connect the ALC OUT connector on the NI 5696 front
panel to the ALC IN connector on the NI 5654 front panel.

2. Use Cable T to connect the RF OUT connector on the NI 5654 front panel to the RF IN
connector on the NI 5696 front panel.

NI PXIe-5696 Getting Started Guide | © National Instruments | 7



3. Hand-tighten all SMA cable ends on the SMA connectors. The cable connectors should
tighten without much torque or effort.

4. Carefully complete tightening all SMA connectors to 1 N · m using an appropriate torque
wrench or torque screwdriver and SMA driver bit (not included). Tighten only until the
wrench clicks.

Caution  Incorrect torque at SMA connections can degrade signal fidelity and
phase-locked loop (PLL) performance and may cause insertion loss. Use an
appropriate torque wrench or torque screwdriver and SMA driver bit to ensure
all SMA connections are properly torqued. SMA connectors for connections to
external equipment may require torque different from 1 N · m, depending on
the connector type, material, and manufacturer.

5. Power on your PXI Express chassis and controller system.
6. Verify that the ACCESS LED is illuminated on all modules. If an LED is not illuminated,

refer to the Troubleshooting section of this document.

Related Information

Configuring the NI 5696 in MAX on page 11
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NI 5696 Amplitude Extender Module
The NI 5696 amplitude extender contains five connectors and two multicolor LEDs.

Figure 5. NI 5696 Amplitude Extender Module Front Panel
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Table 1. Device Front Panel Icon Definitions

Refer to the user documentation for required maintenance measures to ensure user
safety and/or preserve the specified EMC performance.

The signal pins of this product's input/output ports can be damaged if subjected to
ESD. To prevent damage, turn off power to the product before connecting cables and
employ industry-standard ESD prevention measures during installation, maintenance,
and operation.
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Table 2. NI 5696 Front Panel Connectors

Connector Use

  RF AMP OUT Output terminal that routes the amplified output signal to the ATTN IN
connector.

Caution  Do not disconnect the cable that connects
RF AMP OUT to ATTN IN. Removing the cable from or
tampering with the RF AMP OUT or ATTN IN front panel
connectors voids the product calibration, and specifications are
no longer warranted.

ATTN IN Input terminal that connects to the RF AMP OUT connector.

Caution  Do not disconnect the cable that connects
RF AMP OUT to ATTN IN. Removing the cable from or
tampering with the RF AMP OUT or ATTN IN front panel
connectors voids the product calibration, and specifications are
no longer warranted.

RF IN Input terminal that amplifies the incoming signal from the NI 5654 and
provides additional signal conditioning.

This terminal connects to the RF OUT connector of the NI 5654.

ALC OUT Output terminal that connects to the ALC IN connector of the NI 5654.

Caution  Connect this output terminal to only the ALC IN
connector of the NI 5654. Do not connect this output terminal to
an external source or damage may occur.

RF OUT Output terminal for a leveled RF output signal over the specified power
range.
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Table 3. NI 5696 Front Panel LEDs

LED Indications

  ACCESS Indicates the basic hardware status of the module.

OFF—The module is not yet functional or has detected a problem with the PXI
Express power rail.

AMBER—The module is being accessed. Accessed means that the device setup is
being transferred in order to control the device.

GREEN—The module is ready to be programmed by NI-RFSG.

ACTIVE Indicates the state of the module.

OFF—The module is not enabled.

GREEN—The module has been initiated and is running.

RED—The module has detected an error state; this may indicate an internal
failure or thermal shutdown condition.

Configuring the NI 5696 in MAX
Use Measurement & Automation Explorer (MAX) to configure your National Instruments
hardware. MAX informs other programs about which devices reside in the system and how
they are configured. MAX is automatically installed with NI-RFSG.
1. Launch MAX.
2. In the configuration tree, double-click Devices and Interfaces to see the list of installed

devices.

Installed devices appear under the name of their associated chassis.
3. Expand your Chassis tree item.

MAX lists all devices installed in the chassis. Your default device names may vary.

Note  If you do not see your device listed, press <F5> to refresh the list of
installed devices. If the device is still not listed, power off the system, ensure
the device is correctly installed, and restart.

4. Record the device identifier MAX assigns to the hardware. Use this identifier when
programming the NI 5696.

5. Associate the NI 5696 amplitude extender module with the NI 5654 RF signal generator.
a) Select the NI 5654 in the configuration tree.
b) In the Associated Devices section, select the NI 5696 from the system component

drop-down listbox.
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c) Click Save in the MAX toolbar.

Note  Module associations may be lost when you move the modules to
different chassis slots.

6. Self-test the device by selecting the device in the configuration tree and clicking Self-Test
in the MAX toolbar.

The MAX self-test performs a basic verification of hardware resources.

Related Information

Refer to the NI RF Signal Generators Help for information about renaming devices.

Programming the NI 5696
When using the NI 5696 with the NI 5654, you can generate signals interactively using the
NI-RFSG Soft Front Panel (SFP), or you can use the NI-RFSG instrument driver to program
your device in the supported ADE of your choice.
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Table 4. NI 5696 Programming Options

Application

Programming

Interface (API)

Location Description

   NI-RFSG SFP Available from the Start
menu at Start»All
Programs»National
Instruments»NI-RFSG»
NI-RFSG Soft Front
Panel.

The NI-RFSG SFP controls, generates,
and presents data similar to stand-alone
RF vector signal generators. The NI-RFSG
SFP operates on the PC, so it provides
additional processing, storage, and display
capabilities.

NI-RFSG
Instrument Driver

LabVIEW—Available on
the LabVIEW Functions
palette at Measurement
I/O»NI-RFSG.

NI-RFSG configures and operates the
device hardware, performs waveform
programming and generation, and
performs basic modulation tasks using
LabVIEW VIs or LabWindows/CVI
functions. After you associate the NI 5654
and NI 5696 modules in MAX, NI-RFSG
operates the modules as a single
instrument.

LabWindows/CVI—
Available at Program
Files»IVI Foundation»
IVI»Drivers»niRFSG.

Microsoft Visual C/C++ Add all required include and library files
to your project to create an NI-RFSG
application in Microsoft Visual C/C++.

Related Information

For detailed instructions about how to generate signals in a specific ADE, refer to the Getting
Started section of the NI RF Signal Generators Help.
Refer to the Creating an Application with Microsoft Visual C and C++ topic of the NI RF
Signal Generators Help to manually add all required include and library files to your project.

NI-RFSG Examples
Examples demonstrate the functionality of the device and serve as programming models and
building blocks for your own applications. The NI Example Finder is a utility available for
some ADEs that organizes examples into categories and allows you to easily browse and
search installed examples. You can see descriptions and compatible hardware models for each
example or see all the examples compatible with one particular hardware model.

You can locate LabVIEW or LabWindows/CVI examples with the NI Example Finder. Within
LabVIEW or LabWindows/CVI, select Help»Find Examples and navigate to Hardware
Input and Output»Modular Instruments.
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Generating a Signal Using the NI-RFSG Soft Front

Panel
To verify your device configuration, use the NI-RFSG Soft Front Panel (SFP) in MAX to
generate a simple signal.
1. Within MAX, select the NI 5654 RF signal generator module in the configuration tree.
2. Select Soft Front Panel from the MAX toolbar.

The NI-RFSG SFP launches.
3. Within the NI-RFSG SFP, specify a frequency and a power level for signal generation.

Caution  Clicking RF On/Off generates a signal from the RF OUT connector
of the NI 5696 front panel. Disconnect any equipment that can be damaged by
the test signal prior to clicking the RF On/Off button on the NI-RFSG SFP.

4. Click RF On/Off to begin signal generation.

Note  Refer to the Troubleshooting section of this document if an
ACTIVE LED does not turn on or if the NI-RFSG SFP generates an error.

During signal generation, the ACTIVE LED on the NI 5696 hardware module
illuminates.

5. Click RF On/Off to stop signal generation.

Building a Basic NI-RFSG Application
You can build a basic NI-RFSG application in LabVIEW for generating continuous sine wave
signals.

Adding the Core NI-RFSG VIs to a Blank VI
Create a new application that includes the core NI-RFSG VIs.
1. Launch LabVIEW.
2. To create a blank VI, select File»New VI.
3. Display the block diagram by selecting Window»Show Block Diagram.

Tip  Activate the LabVIEW context help by selecting Help»Show Context
Help.

4. Right-click the VI block diagram to launch the Functions palette.
5. Navigate to the NI-RFSG VIs on the NI-RFSG palette.

Tip  You can use the Search button on the Functions palette to find the NI-
RFSG palette.

6. Add the core NI-RFSG VIs from the NI-RFSG palette to the block diagram, and wire the
VIs together as shown in the following figure.
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Figure 6. Basic NI-RFSG Block Diagram

7. Right-click the resource name input on the niRFSG Initialize VI, and select Create»
Control to create a front panel control where you specify the RF signal generator device
name.

Figure 7. Resource Name Input on the niRFSG Initialize VI

8. Right-click the frequency (Hz) input on the niRFSG Configure RF VI, and select
Create»Control.

9. Right-click the power level (dBm) input on the niRFSG Configure RF VI, and select
Create»Control.

10. Display the VI front panel by clicking it or by selecting Window»Show Front Panel.
11. In the VI front panel power level (dBm) control, enter 0. In the frequency (Hz) control,

enter 100M (100 MHz).
12. In the VI front panel resource name control, enter the NI 5654 device name that you

specified in MAX.

Adding a While Loop
Add a While Loop to continuously generate the signal and check the generation status until
you click the Stop button.
1. Display the VI block diagram, and select the While Loop on the Structures palette.

Tip  You can use the Search button on the Functions palette to find the
Structures palette.

2. Enclose the niRFSG Check Generation Status VI in the While Loop, as shown in the
following figure.

Figure 8. The niRFSG Check Generation Status VI Enclosed in the While Loop
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3. Right-click the While Loop tunnels, and select Replace with Shift Register.
4. Select the Or function on the Boolean palette. Place the function inside the While Loop.
5. Wire the output of the Or function to the conditional terminal of the While Loop.
6. Select the Unbundle by Name function on the Cluster, Class, & Variant palette. Place the

function inside the While Loop.
7. Wire the error out output of the niRFSG Check Generation Status VI to the Unbundle by

Name function.
8. Wire the output of the status element to an input of the Or function.
9. Right-click the unused input of the Or function, and select Create»Control to create a

Boolean control.
10. In the VI front panel, right-click the Boolean control created in step 9, and select

Replace»Modern»Boolean»Stop Button to create a Stop button.

Figure 9. While Loop with Stop Button

Adding an Error Indicator
Add an error indicator to the VI front panel.
1. Create an error indicator by right-clicking the error out output of the niRFSG Close VI

and selecting Create»Indicator.
2. Verify that the VI block diagram and VI front panel now look similar to the following

figures.
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Figure 10. Basic Sine Wave Generation VI Block Diagram

Figure 11. Basic Sine Wave Generation VI Front Panel

3. Open the VI front panel, and select the NI 5654 module name specified in MAX in the
resource name control.

4. Click the Run button on the toolbar to initiate sine wave generation.
5. Click the VI front panel STOP button to stop sine wave generation.

You have successfully generated a continuous sine wave signal using the NI-RFSG instrument
driver and the NI 5696.
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Troubleshooting
If an issue persists after you complete a troubleshooting procedure, contact NI technical
support or visit ni.com/support.

Why Is the ACCESS LED Off When the Chassis is On?
The LEDs may not light until the device has been configured in MAX. Before proceeding,
verify that the NI 5696 appears in MAX.

If the ACCESS LED fails to light after you power on the chassis, a problem may exist with the
chassis power rails, a hardware module, or the LED.

Caution  Apply external signals only while the NI 5696 is powered on. Applying
external signals while the device is powered off may cause damage.

1. Disconnect any signals from the module front panels.
2. Power off the chassis.
3. Remove the module from the chassis and inspect it for damage. Do not reinstall a

damaged device.
4. Reinstall the module in a different chassis slot.
5. Power on the chassis.
6. Verify that the device appears in MAX.
7. Reset the device in MAX and perform a self-test.

What Should I Do if the NI 5696 Doesn't Appear in

MAX?
1. In the MAX configuration tree, click Devices and Interfaces.
2. Expand the Chassis tree to see the list of installed devices, and press <F5> to refresh the

list.
3. If the module is still not listed, power off the system, ensure that all hardware is correctly

installed, and restart the system.
4. Navigate to the Device Manager.

Operating System Description

  Windows 8 Right-click the Start screen, and select All apps»Control Panel»
Hardware and Sound»Device Manager.

Windows 7 Select Start»Control Panel»Device Manager.

Windows Vista Select Start»Control Panel»System and Maintenance»Device
Manager.

Windows XP Select Start»Control Panel»System»Hardware»Device
Manager.
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5. If you are using a PXI controller, verify that a National Instruments entry appears in the
system device list. Reinstall NI-RFSG and the device if error conditions appear in the list.
If you are using an MXI controller, right-click PCI-to-PCI Bridge, and select Properties
from the shortcut menu to verify that the bridge is enabled.

What Should I Do if the Module Fails the Self-Test?
1. Restart the system.
2. Launch MAX, and perform the self-test again.
3. Power off the chassis.
4. Reinstall the failed module in a different slot.
5. Power on the chassis.
6. Perform the self-test again.

NI PXIe-5696 Getting Started Guide | © National Instruments | 19



Where to Go Next
Refer to the following figure for information about other product tasks and associated
resources for those tasks.

custom applications within

an application programming 

interface (API).

NI-RFSG Examples* 

NI RF Signal  

Generators Help* 

NI-RFSG Soft Front Panel 
NI-RFSG Instrument Driver 

about hardware features 

or review device  

specifications.

more about your products through ni.com. 

NI PXIe-5654

Specifications* 

NI RF Signal  

Generators Help* 

the application development 

environment (ADE)

 for your application.

Learn LabVIEW Basics 

Getting Started with

LabWindows/CVI 

Support

ni.com/support

*This item is also installed with the driver software.

EXPLORE LEARN CREATE

DISCOVER

RF Solutions

ni.com/rf

Services

ni.com/services

NI Community

ni.com/community

Located at ni.com/gettingstarted Located at ni.com/manuals Located using the NI Example Finder

Tip  The NI RF Signal Generators Help is an HTML version of a traditional user
manual that includes detailed information about RF fundamentals, device features,
and programming with NI-RFSG.

Worldwide Support and Services
The National Instruments website is your complete resource for technical support. At ni.com/
support, you have access to everything from troubleshooting and application development
self-help resources to email and phone assistance from NI Application Engineers.

Visit ni.com/services for NI Factory Installation Services, repairs, extended warranty, and
other services.
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Visit ni.com/register to register your National Instruments product. Product registration
facilitates technical support and ensures that you receive important information updates from
NI.

A Declaration of Conformity (DoC) is our claim of compliance with the Council of the
European Communities using the manufacturer’s declaration of conformity. This system
affords the user protection for electromagnetic compatibility (EMC) and product safety. You
can obtain the DoC for your product by visiting ni.com/certification. If your product supports
calibration, you can obtain the calibration certificate for your product at ni.com/calibration.

National Instruments corporate headquarters is located at 11500 North Mopac Expressway,
Austin, Texas, 78759-3504. National Instruments also has offices located around the world.
For telephone support in the United States, create your service request at ni.com/support or
dial 1 866 ASK MYNI (275 6964). For telephone support outside the United States, visit the
Worldwide Offices section of ni.com/niglobal to access the branch office websites, which
provide up-to-date contact information, support phone numbers, email addresses, and current
events.
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Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for information on National Instruments trademarks.

Other product and company names mentioned herein are trademarks or trade names of their respective companies. For patents

covering National Instruments products/technology, refer to the appropriate location: Help»Patents in your software, the

patents.txt file on your media, or the National Instruments Patent Notice at ni.com/patents. You can find information about

end-user license agreements (EULAs) and third-party legal notices in the readme file for your NI product. Refer to the Export

Compliance Information at ni.com/legal/export-compliance for the National Instruments global trade compliance policy and

how to obtain relevant HTS codes, ECCNs, and other import/export data. NI MAKES NO EXPRESS OR IMPLIED WARRANTIES

AS TO THE ACCURACY OF THE INFORMATION CONTAINED HEREIN AND SHALL NOT BE LIABLE FOR ANY ERRORS.

U.S. Government Customers: The data contained in this manual was developed at private expense and is subject to the

applicable limited rights and restricted data rights as set forth in FAR 52.227-14, DFAR 252.227-7014, and DFAR 252.227-7015.

© 2015 National Instruments. All rights reserved.
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