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Important Information

Warranty

Copyright

Trademarks

WARNING

The media on which you receive National Instruments software are warranted not to fail to execute programming
instructions, due to defects in materials and workmanship, for a period of 90 days from date of shipment, as evidenced
by receipts or other documentation. National Instruments will, at its option, repair or replace software media that do not
execute programming instructions if National Instruments receives notice of such defects during the warranty period.
National Instruments does not warrant that the operation of the software shall be uninterrupted or error free.

A Return Material Authorization (RMA) number must be obtained from the factory and clearly marked on the outside
of the package before any equipment will be accepted for warranty work. National Instruments will pay the shipping costs
of returning to the owner parts which are covered by warranty.

National Instruments believes that the information in this manual is accurate. The document has been carefully reviewed
for technical accuracy. In the event that technical or typographical errors exist, National Instruments reserves the right to
make changes to subsequent editions of this document without prior notice to holders of this edition. The reader should
consult National Instruments if errors are suspected. In no event shall National Instruments be liable for any damages
arising out of or related to this document or the information contained in it.

EXCEPT AS SPECIFIED HEREIN, NATIONAL INSTRUMENTS MAKES NO WARRANTIES, EXPRESS OR IMPLIED, AND SPECIFICALLY DISCLAIMS
ANY WARRANTY OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. CUSTOMER’S RIGHT TO RECOVER DAMAGES CAUSED
BY FAULT OR NEGLIGENCE ON THE PART OF NATIONAL INSTRUMENTS SHALL BE LIMITED TO THE AMOUNT THERETOFORE PAID BY THE
CUSTOMER. NATIONAL INSTRUMENTS WILL NOT BE LIABLE FOR DAMAGES RESULTING FROM LOSS OF DATA, PROFITS, USE OF PRODUCTS,
OR INCIDENTAL OR CONSEQUENTIAL DAMAGES, EVEN IF ADVISED OF THE POSSIBILITY THEREOF. This limitation of the liability of
National Instruments will apply regardless of the form of action, whether in contract or tort, including negligence.

Any action against National Instruments must be brought within one year after the cause of action accrues. National
Instruments shall not be liable for any delay in performance due to causes beyond its reasonable control. The warranty
provided herein does not cover damages, defects, malfunctions, or service failures caused by owner’s failure to follow
the National Instruments installation, operation, or maintenance instructions; owner’s modification of the product;
owner’s abuse, misuse, or negligent acts; and power failure or surges, fire, flood, accident, actions of third parties,

or other events outside reasonable control.

Under the copyright laws, this publication may not be reproduced or transmitted in any form, electronic or mechanical,
including photocopying, recording, storing in an information retrieval system, or translating, in whole or in part, without
the prior written consent of National Instruments Corporation.

Lookout™ and NI-DAQ™ are trademarks of National Instruments Corporation.

Product and company names listed are trademarks or trade names of their respective companies.

Reliability of operation of the Lookout software can be impaired by adverse factors, including but not limited to
fluctuations in electrical power supply, computer hardware malfunctions, computer operating system software fitness,
fitness of compilers and development software used to develop a Lookout application, installation errors, software and
hardware compatibility problems, malfunctions or failures of process monitoring or process control devices, transient
failure of electronic systems (hardware and/or software), unanticipated uses or misuses, or error on the part of the user
or application designer. (Adverse factors such as these are hereafter collectively termed “system failures.”)

Any process or sub-part of a process where a system failure would create a risk of harm to property or persons
(including the risk of bodily injury and death) should not be reliant solely upon electronic monitoring due to the risk
of system failure. To avoid damage, injury or death, the user or application designer must take reasonably prudent
steps to protect against system failures, including by not limited to the safeguard of independent stand-alone alarm
mechanisms and the installation within easy reach of plant floor personnel of manual shutoff switches on dangerous
equipment.
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About This Manual

Organization of the Product User Manual

The Lookout Reference Manual is organized as follows:
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Chapter 1, Installing Lookout, describes how to install your Lookout
software.

Chapter 2, Introduction, describes the Lookout architecture and
presents the background necessary to fully understand how Lookout
provides solutions for your continuous process, discreet, or batch
applications.

Chapter 3, Getting Started, explains how to start and get around within
Lookout. It describes the Lookout screen and introduces some
important mouse and keyboard shortcuts.

Chapter 4, Using Lookout, discusses the basics of using Lookout,
including selecting objects, creating objects, editing object databases,
and other operations.

Chapter 5, Developer Tour, guides you through the development of a
simple process file.

Chapter 6, Serial Communications, describes serial communications
and details how to define settings for three different serial connections:
hardwired, radio (RTS/CTS), and dial-up.

Chapter 7, Expressions, explains the features and uses of Lookout
expressions, which are flexible, real-time math statements.

Chapter 8, Graphics, describes adding static and dynamic graphics to
a control panel and creating and using custom graphics.

Chapter 9, Alarms, describes generated alarms and configuration
services provided by the Lookout alarm subsystem. As a Lookout
environment service, the alarm subsystem filters, displays, logs, and
prints alarms.

Chapter 10, Security, describes Lookout accounts and the environment
service security subsystem, which oversees process file security,
control security, viewing security, and action verification. With this
system, you selectively determine which operators control particular
objects, which operators view particular control panels, and which
objects prompt the operator for command verification.
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Chapter 11, Logging Data and Events, describes three Lookout
methods for logging real-time system data to disk—Spreadsheet
Logger, Citadel Threaded Database Logger, and Event Logger—and
report generation.

Chapter 12, Structured Query Language, describes Structured Query
Language (SQL), Open Database Connectivity (ODBC), and
accessing Citadel data using both SQL and ODBC.

Chapter 13, Dynamic Data Exchange, explains how to use Dynamic
Data Exchange (DDE) with Lookout. DDE is the Microsoft
message-based protocol used by applications like Microsoft Excel
and Lookout to link to data in other applications.

Chapter 14, Networking, explains how to use Lookout to monitor and
control your process from any workstation (node) on the network.

Chapter 15, Redundancy, describes how to configure two process
control computers for redundancy, providing automatic transfer of
control should the primary computer fail.

Chapter 16, Runtime Menu Commands, describes Lookout menu bar
pull-down commands available in Normal mode (that is, not Edit)
mode.

Chapter 17, Edit Mode Menu Commands, describes Lookout menu bar
pull-down commands available in Edit mode. You use Edit mode to
perform all system configuration and editing.

Chapter 18, Object Class Reference, describes Lookout object classes,
listed in alphabetical order. Input parameter syntax and data members
are documented for each object class, along with a description of the
functionality of each object class and an example of how to use the
object.

Appendix A, Customer Communication, contains forms you can use to
request help from National Instruments or to comment on our products
and manuals.

The Index contains an alphabetical list of key terms and topics in this
manual, including the page where you can find each one.
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Conventions Used in This Manual

<>

»

bold

bold italic

italic

monospace

monospace italic

The following conventions are used in this manual:

Angle brackets enclose the name of a key on the keyboard—for example,
<Shift>. Angle brackets containing numbers separated by an ellipsis
represent a range of values associated with a bit or signal name—for
example, DBIO<3..0>. Key names are capitalized

A hyphen between two or more key names enclosed in angle brackets
denotes that you should simultaneously press the named keys—for
example, <Control-Alt-Delete>.

The » symbol leads you through nested menu items and dialog box options
to a final action. The sequence File»Page Setup»Options» Substitute
Fonts directs you to pull down the File menu, select the Page Setup item,
select Options, and finally select the Substitute Fonts options from the
last dialog box.

This icon to the left of bold italicized text denotes a note, which alerts you
to important information.

This icon to the left of bold italicized text denotes a caution, which advises
you of precautions to take to avoid injury, data loss, or a system crash.

Bold text denotes the names of menus, menu items, parameters, dialog
boxes, dialog box buttons or options or data entry fields, icons, windows,
or Windows 95 tabs.

Bold italic text denotes a, note, caution, warning, comment, or related
objects or functions.

Italic text denotes variables, emphasis, a cross reference, or an introduction
to a key concept. This font also denotes text from which you supply the
appropriate word or value, as in Windows 3.x.

Text in this font denotes text or characters you would type, such as the
contents of a dialog box data entry field, or expression, Lookout data
members, programming examples, and syntax examples. This font is also
used for the proper names of disk drives, paths, directories, functions,
operations, variables, and filenames and extensions.

Italic text in this font denotes that you must enter the appropriate words or
values in the place of these items.
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Related Documentation

Lookout Object Developer’s Toolkit Reference, National Instruments Part
Number 321709A-01

Customer Communication

Lookout Reference Manual

National Instruments wants to receive your comments on our products
and manuals. We are interested in the applications you develop with our
products, and we want to help if you have problems with them. To make it
easy for you to contact us, this manual contains comment and configuration
forms for you to complete. These forms are in Appendix A, Customer
Communication, at the end of this manual.
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Getting Started

Chapters 1 through 5 contain information to help you get started quickly
and easily with Lookout.

In particular, Chapter 2, Introduction, and Chapter 5, Developer Tour,
contain both theory and practical examples to help you learn how to
quickly become productive using Lookout. Chapter 3, Getting Started,
and Chapter 4, Using Lookout, are helpful in familiarizing you with the
Lookout interface and learning how to use the Lookout tools.

Lookout Reference Manual

Chapter 1, Installing Lookout, describes how to install your Lookout
software.

Chapter 2, Introduction, describes the Lookout architecture and
presents the background necessary to fully understand how Lookout
provides solutions for your continuous process, discreet, or batch
applications.

Chapter 3, Getting Started, explains how to start and get around within
Lookout. It describes the Lookout screen and introduces some
important mouse and keyboard shortcuts.

Chapter 4, Using Lookout, discusses the basics of using Lookout,
including selecting objects, creating objects, editing object databases,
and other operations.

Chapter 5, Developer Tour, guides you through the development of a
simple process file.
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Installing Lookout

Hardware Requirements

Lookout requires a 386-, 486-, or Pentium class IBM PC-compatible
personal computer. The computer should have at least 8§ MB of RAM
memory and 400 MB of free hard disk space. It should have a CD-ROM
drive, a floppy drive, a mouse (preferably bus version), and video
display/controller combination with at least VGA (640 x 480) capability.

Because Lookout can run 24 hours a day, your computer should have some
form of AC power surge protection. An uninterruptible power supply
(UPS) provides the ultimate protection. A UPS provides complete isolation
between the AC power source and the computer and has backup battery
power if there are blackouts and brownouts. A quality surge protector will
protect your computer from most electrical surges and spikes if you do not
need battery backup.

Software Requirements

Lookout 3.8 includes both 16-bit and 32-bit versions. Future releases of
Lookout will include 32-bit versions only.

16-bit Lookout software can run on Microsoft Windows 3.1 or higher,
Windows for Workgroups 3.11 or higher, and Windows 95. It requires
DOS 3.0 or higher.

While you can run 16-bit Lookout on a Windows NT system, National
Instruments recommends that you use the 32-bit version.

32-bit Lookout software can run on Windows 95 and Windows NT.
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Installing Lookout

To Install Lookout

Lookout Reference Manual

Insert Lookout Disk 1 into drive A or drive B on your computer. If you
are installing from a CD, insert the CD into your CD drive.

If you are using Windows 95, click the Start button, then click on
Run...

Run EE3

Type the name of a progran, folder, or document, and
Windows will open it for you.

Open: IA: setLp.exe d

(]S I Cancel Browse... |

If you are using Windows 3.x or Windows NT, select File»Run... from
the Windows Program Manager.

Enter A: \sSETUP if you are using drive A. Enter B: \SETUP if you are
using drive B, and so on. Then select OK.

If you are installing Lookout on a 16-bit Windows platform such as
Windows 3.1 or 3.11, Setup automatically installs 16-bit Lookout.

If you are installing Lookout on a 32-bit platform such as Windows 95
or Windows NT, Setup gives you the option of installing either the
16-bit or 32-bit version of Lookout. While the 16-bit version of
Lookout runs on 32-bit platforms, it is best to load the 32-bit version
if you are running windows 95 or Windows NT.

If prompted, choose either 16-bit or 32-bit Lookout.

Next, Lookout gives you the option of installing its ODBC driver.
(This driver is required if you wish to query the Citadel historical
database using SQL). See Chapter 12, Structured Query Language,
for more information regarding this feature.

Shut down all applications that may currently be using ODBC. Such
applications include spreadsheets, word processors, database
programs, MS Query, and similar applications.
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6. Choose 16-bit ODBC, 32-bit ODBC, or none—you can install it later
if you like.
If you are installing Lookout on a 16-bit Windows platform such as

Windows 3.1 or 3.11, Setup automatically installs the 16-bit ODBC
driver.

As with Lookout itself, if you are installing on a 32-bit platform such
as Windows 95 or Windows NT, you can install either the 16-bit or
32-bit version of the ODBC driver. You should load the 16-bit driver if
you loaded the 16-bit version of Lookout, and the 32-bit driver if you
loaded the 32-bit version of Lookout.

Setup prompts you for a hard disk subdirectory name in which to
install the Lookout files.

7. Atthis point in the installation, you can choose whether or not to install
the Lookout online help.

8. Use Browse to enter the name of an alternate directory or select OK to
accept the recommended directory name.

9. Follow the remaining instructions to complete the Lookout
installation.

Starting Lookout for the First Time

The first time you launch Lookout, it prompts you for registration
information.

Notes Be sure to register your Lookout Package to receive your permanent unlock code!
As an unregistered package, Lookout is limited to 50 1/0 points and only runs for
30 days. When you register Lookout, you unlock it for permanent use at your
appropriate 1/0 count. If you do not register Lookout by the end of the 30 day
period, it lapses to a demo system. You must complete the license agreement and
mail or fax a copy of the agreement to National Instruments in order to register
Lookout. Upon receipt of the registration form, National Instruments generates a
key code to unlock Lookout and faxes or mails it to you.

Lookout requires a hardware key in some countries. Contact National
Instruments if you are not sure whether your system requires a hardware key. If
you were supplied a key with Lookout, be sure to plug it into the parallel port on
your computer before activating Lookout.
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To Start Lookout for the First Time
1. Launch Lookout by selecting Start»Programs»Lookout»Lookout,
or double-click on the Lookout icon.

The registration dialog box appears.

Keycode Entry =]

This dialog box is used to enter or modify your keycode information. Please enter your name,
keycode, organization and serial number exactly as they appear on the fax or mailer you
received from National Instruments.

Click on OK to continue or Cancel if you do not wish to enter this information now.

Name: || |

Organization: | |

Serial Number: | |

Keycode: | |
OK I Cancel |
2. Enter your name in the Name field.
3. Enter the Organization name exactly as it appears on the key code fax

sent in response to your registration, including punctuation marks.
This text is used in combination with the key code and so it must be
exact.

4. Enter the Serial Number of your package. (This can be found on your
registration form.)

5. Enter your 12-character Keycode. The key code is not case sensitive
and you can leave the hyphens out if desired. Notice that there are no
spaces near the hyphens.

6. After completing the entries, press <Enter> or select OK.

If you enter the proper information correctly, Lookout appears on your
screen with no process running.

If you have not yet received your key code from National Instruments,
you can enter your registration data later. Select OK and Lookout will
inform you that you have not registered your package yet. Select OK
again until Lookout launches.
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Registration Unsuccessful | ]

You have not entered a valid keycode to unlock your copy of Lookout.
You may still use Lookout for a 30-day period during which you will be
limited to a maximum of 50 170 points.

Please refer to your registration form for information on contacting
National Instruments to get your keycode.

Once you have obtained your keycode, choose System from the
Options menu, click on Change Registration Info, and complete your
registration information.

Lookout =]

The key code you entered is notwalid
far this serial number/company combination.

If you are certain that you typed the information correctly and Lookout
still does not accept it, call the National Instruments technical support
line for help.

Automatic Process Loading

If your computer runs Lookout 24 hours a day, you may want to ensure that,
if the computer temporarily loses power, it will automatically reboot and
begin executing the process when power returns.

Enter the name of the process file you want to load automatically when
Lookout begins in the Startup process file ficld of the Systems Option
dialog box.
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System Options | ]
Startup process file: IWaterPIant.Ikp| Log alarms to:
—If security level is below: LPT1:

Lookoutwill always be maximized LPTZ: |

User cannot switch to another prograrm

ID
I_ {limited support for Windows NT) Change Registration Info
i
ID
i

Menu bar will not be visible

tenu and title bars will nat be visible Sy - |
Limit active popups to: |4 {1-94) oK. I
(-9
) Cancel |
—Yirtual Keyboard Pops Up On
™ LeftMouse Click ™ Right Mouse Click
¥ Sawve state file every 300 (114403 minutes
Data files location: Ic:\program filesynational instruments'lookout\citadel’,
Titne zone: ™ Currently within Daylight Savings Time
I(GMT—B:DD) Central Standard Time, Mexico City, Georgetown (Texas) j

To make sure Lookout loads and runs when your computer boots or
reboots, consult your operating system documentation instructions on
how to set a default startup application.
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Introduction

Lookout is a powerful yet easy-to-use MMI and SCADA software package
for industrial automation. Lookout runs under Windows and communicates
with field I/O from PLCs, RTUs, and other devices. Typical Lookout
projects include continuous process monitoring and supervisory control,
discrete manufacturing, batch applications, and remote telemetry systems.

Thoroughly object-oriented and event driven, Lookout is a configurable
package that requires no programming or scripting—ijust fill in the blanks.

With Lookout, you can create graphical representations on a computer
screen of real-world devices such as switches, dial gauges, chart recorders,
pushbuttons, knobs, sliders, meters, and then link your images to the actual
field instruments using PLCs, RTUs, DAQ boards, or other I/O devices.
You can configure Lookout to generate alarms, log data to disk, animate
custom graphics, print reports, automatically adjust setpoints, historically
trend information, and warn operators of malfunctions.

Lookout has many diverse capabilities such as Statistical Process Control
(SPC), recipe management, Structured Query Language (SQL), built-in
security, flexible data logging, sophisticated animation, complex alarming,
radio and dial-up telemetry support, audit trails of events and setpoint
adjustments, multimedia support, touch screen compatibility, DDE &
NetDDE, and more.

With Lookout you can develop an application completely on-line, without
shutting down. You do not have to recompile or download a database every
time you make a modification, nor do you have to switch back and forth
between programs. You do not even have to run separate development and
configuration programs. Instead, you can add, delete and modify control
panels, logic, graphics, PLCs, RTUs, I/O, and other field devices without
ever interrupting your process.

Because Lookout is object-oriented and event-driven, you can use Lookout
with other programs in the Microsoft Windows multitasking environment.
for example, while Lookout monitors and controls your process, you can
use a spreadsheet to analyze production figures of hourly average flow
rates, then start a word processor to generate a memorandum, paste the
spreadsheet into the memo and send it to a laser printer.
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Architecture

The remainder of this chapter describes the Lookout architecture and
presents the background necessary to fully understand how Lookout
provides solutions for your continuous process, discreet, or batch
applications.

What is an Object?

Lookout Reference Manual

Once you understand the basic Lookout basic components, and the
fundamentals regarding object-oriented and event-driven structure, using
the program becomes much easier.

A Lookout object is a self-contained software unit that has a predefined
database, a set of parameters, and built-in functionality. The following
diagram depicts the functionality, data members and parameters of an
object.

Object

Functionality

Logical
Values
Parameters

Numeric
Values

Text
Values

Text Data
Members

Logical Data
Members

Database

Numeric Data
Members

Figure 2-1. An object encapsulates data, parameters, and functionality in one bundle.

Think of an object as a software model of something physical. For example,
a light switch is something physical. You can turn it on and off. In Lookout,
a Switch object represents the physical switch. You can turn it on and off,
too.

Parameters define the limits of object functionality. For example, the
Switch object Security Level parameter determines who can turn it on and
off. The object database stores information indicating the current switch
position.
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Functionality

Different object classes are designed to perform different functions. For
example, the Pot (potentiometer) object class operates differently from the
Switch object class. This is the functionality built into every object class.

Functionality is the way an object works, operates, or performs a task.
Functionality is a general concept that applies in the same way to all objects
in a given object class. Parameters, however, can be unique, and define the
specific functionality of an individual object.

The object class definitions featured in Chapter 18, Object Class
Reference, outline the functionality of a given object class.

Parameters

The object parameters define its characteristics. Lookout uses object
parameters to complete the definition of the object functionality. For
example, Data rate, Parity, and Stop bits are a few of the parameters that
define how a Modbus object works. Other examples include the Control
security level of a Switch object; Minimum, Maximum, and Resolution
of a Pot object; and Data of an Average object.

Every object class supports a set of parameters that you must fill in or select
when creating a new object. Some parameters support expressions, which
can be variable. Others require constant values. Some ask you to pick
specific settings.

Parameters that accept expressions appear as yellow data entry fields.
These parameters can receive signals (that is, they are writable). See
Chapter 7, Expressions, for more detailed information on expressions.

All the parameters for any given class are visible in the object definition
dialog box.

© MNational Instruments Corporation 2-3 Lookout Reference Manual



Chapter 2 Introduction

Lookout Reference Manual

New switch |
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Ok | Cancel | - I—

Cantral security level: IEI W Log everts

Figure 2-2. Switch Definition Dialog Box

Database

Each object has its own built-in database. The individual parts of this
self-contained database are called data members. Some object classes
(that is, types of objects) have a very limited database, while others have
extensive databases. The database of an object representing a PLC might
have hundreds of data members; but a Switch object database has only
three data members. You do not have to build a database—the data
members are automatically available when you create the object.

In the case of a switch, the implicit value of the object is a part of the
self-contained database. Data members can either generate (write) signals,
receive (read) signals, or both.

Every data member contains a single value that can be one of three types:
numeric, logical, or text. They must read or write compatible signals. For
example, you cannot connect a data member that generates a logical signal
to a data member that receives a numeric signal.

Lookout performs strong type checking when you connect objects. It will
generate an error message if you try to connect incompatible signals.

The built-in data members for each object are referred to as native
members, and can be thought of as the default or automatic data members.
You can add to and modify the database to suit your specific needs.

Every object class has an explanation of its database located in its
definition. The following excerpt is an example of the switch object class
database explanation.
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Table 2-1. Switch Object Class Database Members

Data Members Type Read | Write Description
(implicit) logical yes no switch position
enable logical no yes If set to TRUE, enables DDE. If set to
FALSE, disables DDE. The default
value is on. This data member does
not interfere with existing code.
visible logical no yes When false, the switch object cannot

be seen on the display panel. When
true, the switch can be seen and

controlled.

Data Members

Data members are the individual parts of the self-contained object
database. There are three types of data members: Logical, Numeric, Text.
Some object classes also have (implicit) data members.

Logical Data Members

Logical data members contain a value that represents a binary or on/off
state. A light switch is a logical device—it is either on or off.

Logical data members are typically used to control equipment that can be
turned on and off, to indicate that a piece of equipment is running, or
indicate whether a limit switch is open or closed.

The Switch object generates a logical signal that is on when the switch is
up and off when the switch is down. In the same way, the Pushbutton object
generates a logical value that is on while the pushbutton is depressed. The
Pulse object generates a logical signal that turns on and off at prescribed
intervals, creating a logical pulse.

The logical signals that some objects generate can be displayed graphically
on a control panel. See Chapter 8, Graphics, for more information.

Lookout recognizes the following logical constants as expressions:
Logical constants that represent an on state: yes, true, on

Logical constants that represent an off state: no, false, off
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Numeric Data Members

A numeric data member is a floating point number representing analog
values such as tank level, pressure, flow rate, voltage, and temperature.
Numeric data members also represent time, either as a time period (span)
or as an absolute time (that is, a particular time of day/week/month/year).

The Pot (potentiometer) object generates a numeric signal compatible with
the numeric signals that monitor and control the analog input and output
points on a PLC. Numeric signals range from —1.7 x 10398 to0 1.7 x 103%,
and the magnitude can be as small as 1.7 x 10308,

Numeric constants are entered using decimal digits (0 — 9), the minus sign
(-), the exponent symbol (E or e), and the time format separator (:).

Examples of numeric constants
0
—123.779999
1.5E7 = 15,000,000
-3.7E-3  =-0.0037
—-.0036
123356636.2345791

Time or Time signals are stored by Lookout as numeric values that
represent days and fractions of a day. For example, you enter one hour as
1:00:00. Lookout interprets the number to the right of the rightmost colon
(:) as seconds, the number to the right of the second colon from the right as
minutes, the next number as hours, and the number to the left of the third
colon from the right as days. If there are no colons in the entry, the time
period is assumed to be given in days.

Examples of numeric time period constants

0:23 = 23 seconds, or
0.0002662 days
75:00 = 75 minutes, 0 seconds, or

0.05208 days

12:00:05:01 = 12 days, 0 hours, 5 minutes, 1 second, or

12.003484 days
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Examples of numeric time period constants
199:: = 199 hours, 0 minutes, 0 seconds, or
8.2917 days
0:10.023 = 10.023 seconds, or
0.0001160 days
12.75 = 12.75 days
17:64:22.5 = invalid number, because hours are specified:
minutes must be <= 59

You may enter one hour as 1:00:00, but Lookout stores the number as
0.04167 (or 1/24 of a day). Days are represented by the integer portion of
the number. The number zero represents Jan. 1, 1900.

You can display the numeric signals that some objects generate on a control
panel. See Chapter 8, Graphics, for more information.

If you display the numeric signal digitally, Lookout provides a long list of
numeric formats to choose from. These are listed below.

Table 2-2. General Numeric Format

(General)

number displayed in most compact form possible
123.789 displayed as 123.789

Table 2-3. Leading zeroes

000000000

123.789 displayed as 000000124

00000000

123.789 displayed as 00000124

0000000

123.789 displayed as 0000124

000000

123.789 displayed as 000124

00000

123.789 displayed as 00124

0000

123.789 displayed as 0124

000

123.789 displayed as 124

00

123.789 displayed as 124

0

123.789 displayed as 124

© MNational Instruments Corporation
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Table 2-4. Fractional numbers with trailing zeroes

0.0 123.789 displayed as 123.8
0.00 123.789 displayed as 123.79
0.000 123.789 displayed as 123.789
0.0000 123.789 displayed as 123.7890
0.00000 123.789 displayed as 123.78900
0.000000 123.789 displayed as 123.789000
0.0000000 123.789 displayed as 123.7890000
0.00000000 123.789 displayed as 123.78900000
Table 2-5. Exponential/Scientific notation
0EO 123.789 displayed as 1E+2
0.0E+0 123.789 displayed as 1.2E+2
0.00E+0 123.789 displayed as 1.24E+2
0.000E+0 123.789 displayed as 1.238E+2
0.0000E+0 123.789 displayed as 1.2379E+2
0.00000E+0 123.789 displayed as 1.23789E+2
0.000000E+0 123.789 displayed as 1.237890E+2
0.0000000E+0 123.789 displayed as 1.2378900E+2
0.00000000E+0 123.789 displayed as 1.23789000E+2
Table 2-6. Hexadecimal formats
0x0 123.789 displayed as 0x7B
0x00 123.789 displayed as 0x7B
0x000 123.789 displayed as 0x07B
0x0000 123.789 displayed as 0x007B
0x00000 123.789 displayed as 0x0007B
0x000000 123.789 displayed as 0x00007B
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Table 2-6. Hexadecimal formats (Continued)

0x0000000

123.789 displayed as 0x000007B

0x00000000

123.789 displayed as 0x0000007B

You can also use numeric signals to represent absolute times and periods of
time. Because dates and times are represented by numeric values, you can
add, subtract, and include dates and times in expressions, just as you would

any other numeric signals.

A time period represents a span of time or a duration. Time periods are
indicated in hours, minutes, seconds, and fractions of seconds. Numeric
formats that represent time periods are characterized by capital letters

(that is, H rather than h).

Table 2-7. Time Periods

H 0.4789 displayed as 11 (hours)

HH 0.4789 displayed as 11.5 (hours)

H.HH 0.4789 displayed as 11.49 (hours)

M 0.4789 displayed as 690 (minutes)

MM 0.4789 displayed as 689.6 (minutes)

M.MM 0.4789 displayed as 689.62 (minutes)

S 0.4789 displayed as 41377 (seconds)

S.S 0.4789 displayed as 41377.0 (seconds)

S.SS 0.4789 displayed as 41376.96 (seconds)

HH:MM 0.4789 displayed as 11:29 (11 hours, 29 minutes)
HH:MM:SS 0.4789 displayed as 11:29:36 (11 hours, 29 min, 36 seconds)
HH:MM:SS.S 0.4789 displayed as 11:29:36.9

HH:MM:SS.SS 0.4789 displayed as 11:29:36.96

HH:MM:SS.SSS 0.4789 displayed as 11:29:36.960

MM:SS 0.4789 displayed as 689:36 (689 minutes, 36 seconds)
MM:SS.S 0.4789 displayed as 689:36.9

© MNational Instruments Corporation
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Table 2-7. Time Periods (Continued)
MM:SS.SS 0.4789 displayed as 689:36.96
MM:SS.SSS 0.4789 displayed as 689:36.960

Lookout Reference Manual

Absolute dates and times indicate a specific moment in time. Lookout
stores all absolute dates and times as numeric signals. It uses the 1900 date
system in which the number 1 corresponds to midnight, January 1, 1900.
The number 2 corresponds to midnight, January 2, 1900 and so on. For
example, the number 34491.5 represents noon, June 6, 1994.

Numeric formats that represent absolute times are characterized by lower
case letters (for example, hh:mm instead of HH:MM).

Table 2-8. Absolute Dates and Times

hh:mm 34668.7889 displayed as 18:56 (6:56 p.m.)
hh:mm:ss 34668.7889 displayed as 18:56:02
mm/dd hh:mm 34668.7889 displayed as 11/30 18:56

mm/dd hh:mm:ss

34668.7889 displayed as 11/30 18:56:02

mm/dd/yy

34668.7889 displayed as 11/30/94

mm/dd/yy hh:mm

34668.7889 displayed as 11/30/94 18:56

mm/dd/yy hh:mm:ss

34668.7889 displayed as 11/30/94 18:56:02

dd/mm hh:mm

34668.7889 displayed as 30/11 18:56

dd/mm hh:mm:ss

34668.7889 displayed as 30/11 18:56:02

dd/mm/yy

34668.7889 displayed as 30/11/94

dd/mm/yy hh:mm

34668.7889 displayed as 30/11/94 18:56

dd/mm/yy hh:mm:ss

34668.7889 displayed as 30/11/94 18:56:02

Text Data Members

Text data members contain text character strings. These character strings
consist of all displayable characters. You can use text signals to display
alarm descriptions on the alarm panel, to display labels on a control panel,
and in parameters or expressions. You can enter text signals as constants,
or you can construct them with the many text functions available in
expressions. Be sure to enclose text constants within quotes (*“”) when
using them within expressions.
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Examples of Text Constants

“Water Temperature:”

1731

(empty text string)

“Low level in ‘Polymer 2’ tank”

113 i)

gpm

(implicit) Data Members

Many object classes have an (implicit) data member. This implicit value
is either logical, numeric, or textual, depending on the object class, and
follows the same rules that apply to all other data members. The implicit
member represents what Lookout considers to be the most commonly used
data member of that object class. In many cases, it is the only data member
of a class. It saves you time, and reduces the amount of typing required to
designate a data member.

For example, Lookout could make you specify the numeric signal
generated by a pot object by typing Pot1.numeric where Pot1 is the
tagname and numeric is the current value of the pot. Instead, you enter
Pot1 and Lookout knows you are referring to the implicit value of the pot.
If you examine the Pot definition in Chapter 18, Object Definitions, you
will see that the (implicit) data member is the current value of the pot.

Object Classes

An object is an individual instance of a particular object class. For example,
Lookout has both Pot and Switch object classes, from which you might
create 20 pots and 30 switches. In this case, you would be creating a total
of 50 objects using only two object classes.

Lookout has an extensive library of object classes. To create an object,
select the desired object class from the list that appears when you choose
Create. This defines the type of object you want. Then you give the object
a unique name (a tagname) and define its parameters.

Global object classes are a special kind of object class. Each contains
global system data such as the number of currently active alarms. You
cannot create, modify or delete a global object, but you can use its data
members just as you would use any other object data members.

When you create or open a Lookout process file, Lookout automatically
creates three global objects: $Alarm, $Keyboard, and $System.
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Object Connections

In Lookout, you connect objects, allowing signals to pass between the
objects—much the same way you would wire a time delay relay to a motor
starter relay, for instance. You can do this by connecting database members
together, or by connecting database members to parameters.

Connections
between
Two Objects

Numeric

Parameters Parameters

Database Database

<

Figure 2-3. Example connections between two objects

For example, you might make the numeric data member of a Pot object the
source for the High Limit parameter of an Alarm object. When you adjust
the pot, the Alarm High Limit changes.

Supervisory Control

Lookout Reference Manual

As you create and connect objects, you form a web, or system, containing
many objects, all linked to perform a supervisory control strategy.

It is how you design your supervisory system, behind the control panel, that
makes your process run. Your system routes signals from field components
to bar graphs and visual indicators on control panels. It activates and
deactivates alarms. You can design it to make complex decisions based on
the values of field control signals and setpoints adjusted through pots and
switches on control panels. You can include complex spreadsheet-style
formulas as a part of your supervisory design. See Chapter 5, Developer
Tour, for more detailed information on how to create objects and connect
them together.

2-12 © National Instruments Corporation



Chapter 2 Introduction

Event-Driven Processing

An important concept to understand is that Lookout is entirely
event-driven, not loop-driven. To understand the significance of this design
requires a digression, to explain how standard loop-driven programs work.

Loop-driven applications execute code sequentially from top to bottom,
and loop back to the top to execute the same code over and over.

Loop Driven

Paradigm
Endless do loop,
constantly reading
and writing values
to and from the
central database.
Loop driven logic
needlessly and

perpetually
retesting values
and rules.
4
Driver Is
Separate
Application

Passive
Notification

Figure 2-4. Example of conventional, Loop-Driven software program

In this programming model, a given section of code or rule may execute
millions of times before the result changes. This wastes computer processor
time and slows down responses to frequent events.

The more rules you add to loop-based systems, the slower the response
time. Also, as you add more tagnames to the central database, speed and
overall performance degrades. This is because many central databases use
a passive notification system in which the rules of the loop-driven logic
must scan an ever larger database for their appropriate values. The larger
the database, the longer it takes the rule to find the data it needs to resolve
its function.
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In sharp contrast to this programming model, Lookout is entirely
event-driven. Each object remains quiescent, doing nothing until an event
occurs.

Events
(Active Notification)

RS

Control
Panel

~~~.__Driver Is Just
Another Object

Figure 2-5. Lookout object-oriented and event-driven architecture

An event is a change in a data value. When an incoming signal changes, the
object activates, processing the value according to its functionality. Objects
only send out signals when the result of their processing changes. This is

how an event propagates throughout your system, creating a chain-reaction
that affects only the objects in the chain. This is called active notification.

Individual objects activate only when notified of an event. This
event-driven paradigm closely simulates the responsiveness of physical
switches, pushbuttons, and relays, and is the reason Lookout is so fast.

Advantages of Active Notification

Consider the advantages of active notification over passive notification.
Active notification is inherently event-driven while passive notification
requires a constant do-loop to check for a change in a data value.

A good example would be two people trying to exchange information.
There are only two ways for the first to send data to the second.

One way is for person two to ask person one for information, and for person
one to respond. The requires one person to ask the other repeatedly if
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anything has changed (in other words, has an event occurred?). This is what
loop-driven rules do when they constantly query the central database.

You can imagine the wasted time and effort if every once every minute,
someone asked you to tell them about the latest events of the
day—especially if your response was almost always “nothing new to
report.”

On the other hand, person one could just tell person two when something
happens (that is, when an event occurs). This is what happens when you
connect two objects in Lookout.

As you can imagine, adding objects in Lookout adds significantly less
demand for processor time than adding new rules or enlarging the central
database of a traditional loop-driven system.

Because Lookout is entirely event-driven, the order in which you create the
objects and connect them does not affect how your supervisory strategy
works.

Environment Services

While the cornerstone of object technology is the object itself, objects need
an environment in which to function. Objects require the use of system
resources like the serial port, hard disk, multimedia functions, and more.
For example, multiple PLC objects may need to use the same
communication port on your computer. In such a situation, Lookout must
provide a service—that is, a mechanism the objects can use to gain access
to the communication port in an orderly and timely fashion.

A service, then, is a tool that Lookout makes available to objects, or a
function Lookout performs outside of its object-oriented structure. Each
service provides a special function. The following sections describe
Lookout environment services.

Serial Port Communication Service

You can configure certain protocol object classes to represent and
communicate with PLCs and RTUs through the serial ports of your
computer. This service arbitrates serial port usage between objects
representing PLCs and RTUs. For example, a single two-way radio
connected to a serial port on the computer can communicate with several
different brands of RTUs out in the field, each one using a different
protocol. See Chapter 6, Serial Communications, for more information on
configuring communications.
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Database Service

With the database service you can define or modify native data member
parameters.

For example, the Modbus object class includes a native data member called
40001. You can give this native data member an alias (or nickname) such
as PumpSpeed, and define associated unit conversions, alarming,
deadband, and other parameters.

With Lookout you can also directly import database information from
external packages like Siemens APT. See Chapter 5, Developer Tour, for
more information on Database services provided by Lookout.

Graphics Service

Lookout has an extensive library of standard graphics. These include
various switches, potentiometers, pushbuttons, bar graphs, valves, tanks,
pumps, and so on. You can also create your own custom graphic and add it
to your Lookout library. See Chapter 8, Graphics, for more information on
graphics.

Alarm Service

The alarm subsystem is a powerful and flexible mechanism for generating,
displaying, logging, and printing alarms. This subsystem has several
distinct parts including the alarm window, object parameters like Alarm
Group and Alarm Priority, alarm filters, display parameters, and print
settings.

Lookout permanently archives alarms to disk. You can easily print this
alarm history. See Chapter 9, Alarms, for additional information.

Multimedia Service

Lookout also provides a multimedia service you can use to play sound
wave files.

Security Service

Lookout has a highly sophisticated and comprehensive three-tier security
system. The tiers include control security, viewing security, and action
verification. You can selectively determine which operators have control
of what objects, which operators can view what control panels, and which
objects prompt operators for verification of commands. See Chapter 10,
Security, for more information on Security.
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Historical Logging Service

With the Logging service you can store real-time system information to
disk in comma-delineated ASCII files, or in a special Lookout database
called Citadel.

The Lookout Event Logger keeps track of who did what, and when they did
it. Lookout logs operator commands, from closing a process file to flipping
a switch or adjusting a pot. Along with each event, Lookout logs the
account name (operator), date and time of the event, tagname of the object
adjusted, and the before and after settings of the object. See Chapter 11,
Logging Data and Events, for additional information on Logging services.

ODBC Service

Because of the Lookout Open Database Connectivity (ODBC) service, you
can use other applications, such as Microsoft Access, to query the Lookout
historical database. See Chapter 12, Structured Query Language, for
additional information on ODBC services.

DDE Service

Lookout can send its live process values to other applications, and it can
receive real-time values from other applications. The Lookout system acts
as both a DDE client and a DDE server. See Chapter 13, Dynamic Data
Exchange, for further information on DDE.

Networking Service

Lookout provides a full client-server networking service through the use
of NetDDE. Use the Lookout NetDDE service to link nodes as servers,
clients, or in a peer-to-peer configuration. With this service you can
monitor and control your process from multiple workstations on a network.
See Chapter 14, Networking, for information on networking Lookout
computers.

Redundancy Service

Use the Lookout redundancy service to configure two computers for
redundancy, providing automatic transfer of monitoring and control should
one of the computers fail. See Chapter 15, Redundancy, for information on
configuring computer redundancy.
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Getting Started

This chapter explains how to start and get around within Lookout. It
describes the Lookout screen and introduces some important mouse and
keyboard shortcuts.

Starting Lookout

To Start Lookout
Note If you are using Lookout outside of the United States, you may be required to use

a hardware key. Be sure to plug the key into the parallel port on your computer
before activating Lookout. If you do not, the program will not run.

Launch Lookout by selecting Start»Programs»Lookout, or double-click
on the Lookout icon.

The first time you start Lookout, you should see the following display.

[_[5]x]

(nobody) 1Use Only.

10/011452

At this point, Lookout does not have a process file open. No monitoring and
control are taking place.
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To Open a Process File

1. If you have a Lookout process file available, select the File»Open...
menu item from the Lookout menu bar.

2. In the File name data field, enter the name of a Lookout process file,
or choose a process file from the list and select OK.

Lookout process files have a . LkP file extension. If Lookout finds a valid
process file, Lookout opens the file and immediately begins executing the
process.

When a process file opens, Lookout makes additional menu selections
available and displays control panels and the alarm window.

The Lookout Screen

Lookout first appears on your screen maximized, taking up the entire

screen.
. i~ Lookout - svgaeval lkp [_[51x]
T|t|e Bar Edit Options Alams  Window Pun  Help
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T Pressure [ Speed in RPM. Speed in RPM.
Hi i Actual ] Setpoint Actual (2] Setpoint
1 1600 1600|1600 1600
> S 1400 1400|1400 1400
1200 1200|1200 1200
1000 1000|1000 1000
‘Separator #2 800 800 | 800 800
] 600 600 | 600 600
= T 400 400 | 400 400
+ i 3 Y 200 200 | 200 200
(5] 0 0
EES = 1065 (3) [1478
{|| s wate! (gpd) 9 £
i | 1600 ﬂ off ,m
120
1000 | [xit Auto
: : : 200
Tew e i Teitw  isiets  1eiem 18 0
E
Raw Water Pump 1 | _Raw Water Pump 2 | | X
HS Pump1 | HS Pump2 | HS Pump3 | | 'T
[ exas s =T [ WatepiP i EIT=TES = MainMenu =TT M|n|m|zed
o] ST (o x| e T e [ x| e T s [ x| [P estSep =11 F| | Help B0 x]
[Floging I [ Louisianan EIIE)| [ F Okiahoman I Fhelp TR Contro' Panels
I el s sy =1l 3 | i mina =T IS |7 Conkie Pis = =1 E3 || information =161 5 | RS aaina s =1 =1
12/1515:16 (nohody) National Instruments Internal Use Orly 0: 0 alarms
ghstart| 8 The YnotAd._| ElAdabe Fram. | SYEAM_Web\. | SYEAD_DATAL | SYEAD_DATAL |[F Lookout - CBYEA ierm

The Title Bar

The title bar at the top of the Lookout window displays the program name
and the title of the currently executing process. If a control panel is
maximized, the control panel name appears in the title bar.
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The menu bar displays the currently available menu commands. These
commands may or may not be available to the operator, depending on his
or her security level.

The status bar is at the bottom of the Lookout window. It changes when
toggled into and out of edit mode. When not in edit mode, the status bar is
gray and the time and date are displayed on the left end of the bar. The
account name of the currently logged on operator comes next. The
company name as entered during registration appears in the middle,

and the alarm status is on the right end of the status bar.

[03703 71831 | (nohodhy)

Mational Instrurnents Internal Use Only: \ 2:2 alarms

When in edit mode the status bar turns yellow. The X and Y coordinates of
the currently selected item appear on the left end of the bar. The width and
height of the currently selected item come next. The tagname, filename, or
expression of the selected item appears in the middle, and the alarm status
appears on the right end of the status bar.

| 39,202 | 4mex3o0 |

Trends.chart | 2.2 alarms

To toggle in and out of edit mode, select Edit»>Edit Mode, or press
<CTRL-Space>

The Lookout Workspace

The Lookout workspace is the area between the menu bar and the status
bar. The workspace is the area in which you view and operate control
panels. The alarm window also appears within the workspace. You
organize and arranged control panels in this workspace area.

The visible workspace on your screen is only a window into the Lookout
virtual workspace. If control panels or their associated icons are partially
or completely outside the visible workspace, Lookout automatically
displays horizontal and vertical scroll bars along the right side and bottom
of the visible workspace. If scroll bars are visible, you can scroll around in
the virtual workspace to see all of your control panels.
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Control Panels
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Control panels consist of switches, knobs, bar graphs, digital displays,
trend graphs, and other components that you can use to visually monitor
and control your operations. Panels can be full-screen, minimized, or any
size in between. You can move the panels around the screen by grabbing
the title bar of a panel with the mouse cursor and dragging it to a new
location. Control panels can also “pop up” when an event occurs such as
when a pushbutton is pressed or when an alarm is activated. There is no
limit on the number of control panels you can create or the number of
objects displayed on any one panel.

There are two types of control panels, Normal and Popup. A Normal
control panel can be maximized, normal size, or minimized within the
Lookout workspace. A Popup control panel in either a Popup state or
minimized. When a Popup control panel is popped up, it remains on top
of all other panels until you minimize it.

Control panels do not have a standard appearance. You can customize
each control panel for your particular control strategy with switches,
potentiometers, and other graphical objects. Some control panels may only
display information, while others combine control and display information.
The information displayed always represents the most current values
available to Lookout through its communications with your I/O devices.

With Lookout you have considerable latitude in how you make control
panels look and operate. For example, you can draw your own switches and
substitute them in place of the standard switches. You can easily make a
pushbutton or switch work backwards from the way one might ordinarily
expect. You might insert time delays and conditions behind the panel that
may not be obvious just from viewing the panel.

Control panels are windows into your process you use to control equipment
by flipping switches, pressing buttons and turning knobs. Unlike real
switches and knobs, you can assign security levels to individual controls,
as well as entire control panels within Lookout. You can use this feature to
lock out operators that do not have high enough security levels for specific
devices. See Chapter 10, Security, for more information on Security.

Unlike physical switches and knobs, you can display the same control
object multiple times, both on the same control panel and on different
control panels. For example, when you turn a knob in one location, all
copies of that knob turn at the same time, in each location of that control.
The same control object may appear differently in each location. You might
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display a potentiometer as a horizontal slide on one panel, a pair of
increment/decrement buttons on another panel, and a knob on yet another
panel.

Operator Input

There are numerous methods for plant operators to make setpoint
adjustments or switch from one control panel to another. These include
mouse, trackball, touchscreen, and keyboard activated commands.

When the cursor moves over a controllable object, the cursor turns into a
hand, indicating you now have control of the object. Controllable objects
include such things as switches, pots and pushbuttons.

When using a keyboard, the arrow keys move the cursor around the screen.
The <Tab> key jumps the cursor from one controllable object to another,
and the <Space> bar acts as the left mouse button, so you can click on a
controllable object without actually using a mouse.

You can also tie keyboard function keys to control panels and other objects,
so you can switch between control panels or issue control commands just
by pressing a function key.

Virtual Keypad

When you are in operating mode, you can click on a digital pot control and
bring up a virtual numeric keypad to enter numeric values, either with a
mouse or a touch sensitive screen.

Virtual Keybhoard

Lookout also has a virtual keyboard you can use with a touch sensitive
screen or a mouse.

To enable the Virtual Keyboard, select Options»System... and then check
Left Mouse Click or Right Mouse Click in the Virtual Keyboard Pops Up
section of the dialog box.

When this feature is enabled, clicking in a data entry field or touching the
field on a touch sensitive screen displays the Virtual Keyboard.
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The Development Environment

The Process File

With the Lookout architecture, you can quickly develop a complete process
file. All development is interactive. You do not have to program or
compile. Just create objects and connect their signals. The development
cycle creates three unique files for every application: a process file, a
source code file, and a state file.

Lookout
A A
\4 \4 \4
Sg :)J cr‘c;e Progess Stgte
File File File
(Iks) (.Ikp) (Ist)

A process file is a compiled executable file that contains complete
configuration information for your particular process or application. It is
updated every time you select the File»Save command. Process files are
binary files with an . LKP (Lookout Process) file name extension. You do
not directly edit or modify process files with a text editor. Rather, Lookout
compiles the . LKP file on an object-by-object basis as you create each
object. With this approach you can stay on-line while creating, updating,
or editing your application. There is no need to shut down your process.
Lookout does not cease operation while you add or delete controllers, /0,
graphics, or modify your logic.

The Source Code File

Lookout Reference Manual

Lookout also automatically updates a corresponding source code file
when you invoke the File»Save command. This file contains complete
documentation for your process file, including object definitions,
tagnames, I/O configuration, communications, control logic, control panel
layout and other object parameters. Source code files have an . LKS
(Lookout Source) file name extension. These are standard ASCII text files
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that you can print or view with any word processor or text editor. You can
use this information for debugging and documentation purposes.

The State File

The state file contains the actual values of object data members. These
values include setpoints and other important data held within and used by
objects. You might think of the state file as permanent memory for Lookout
setpoints and real-time trends. Lookout uses the state file to store the
position of switches, potentiometers, and trend lines. When Lookout first
loads an application, it reads the appropriate state file to determine what
state the pots, switches, trend lines, and so on should be in upon startup.

Note Hypertrends do not use the state file. Hypertrends use the Citadel database.

The state file updates any time you save, close or exit the Lookout
application file. It can also update on a periodic basis as defined in the
System Options dialog box. You invoke this dialog box by selecting the
Options»System... menu command. State files have an . LsT (Lookout
State) file name extension.

The Development Process

The first step in developing a process file is creating a control panel object.
Control panels are windows you use to place other objects, such as
switches, pots, and trends to be displayed. You can make them look like
physical control panels, complete with switches, pushbuttons, bezels,
insets, lamps, gauges, and so on. Your imagination is the only limit to how
the control panels look and function.

If you select the File»New... command, it automatically invokes the dialog
box for creating the first control panel object.

After you create at least one control panel, you can then create and display
any number of other objects. Remember that objects can be displayed on a
single control panel or on multiple control panels. For example, you can
insert the same switch on several panels. If you flip the switch on one panel
it immediately flips on all the other panels.

The first objects you might want to create could be those that represent your
PLCs and RTUs. These object classes often use your computer
communication ports, so you may have to configure your ports for radio,
dial-up modem, or hard-wired connection, as appropriate. See Chapter 6,
Serial Communications, for information on configuring communications.
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When you create an object that represents a PLC, RTU, or other I/O device,
its associated functionality and database are part of the object. The
functionality built into this type of object class includes a protocol driver,
enabling the object to talk with the physical device. The native (default)
database includes all registers, bits, I/O signals, parameters and other
values that the physical device can transmit to or receive from Lookout.

At this point, you may want to add data members to the native databases
for your objects. Such new data members, called aliases, can include
descriptive names, signal scaling parameters, alarming parameters, and
SO on.

As you create objects, you can connect them to other objects. The type of
objects you create (such as Pot, Switch, Modbus, Trend, and so on) and the
manner in which you connect them determine how your system interacts
with your process.

Many object classes you use take advantage of the Environment Services
that Lookout provides. For example, you can assign a security level to the
Pot object class, and the Alarm object class uses the Alarm processing
subsystem. As you create objects that take advantage of these services, you
should configure the services to custom fit your application requirements.

Invoke the File»Save command to save your logic and graphic
configuration to disk, and creates or updates the . LKP, . LKS and . LST files.

It is a good idea to save often while working, to avoid inadvertent loss of
work. It is also a good practice to back up your work to a separate disk,
regularly.

Configuration Shortcuts

Mouse Shortcuts

Lookout Reference Manual

This manual references a number of mouse-implemented shortcuts.
Becoming familiar with mouse commands is easy and pays significant
dividends during application development.
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Function

Mouse Action

To select object display, graphic,
text, expression, or any item on a
display panel

Click: Select the item by pointing
the cursor at the item and clicking
the left mouse button. (See Note.)

To create a new object from an
existing object

CTRL-Drag: Select the item(s)
you want more of. Hold the CTRL
key down and drag the selected
item(s). This makes a completely
new instance of the control:
<CTRL>-Dragging Potl will
produce a new object named Pot2.

To copy object display, graphic,
text, expression, or any item on a
display panel

Shift-Drag: Select the item(s) to
be copied. Hold the Shift key
down and click the left mouse
button while dragging the item(s).
This makes a duplicate of the
selected object that is linked to the
original. Both the original and the
duplicate have the same tag name.

To modify display or definition
parameters of an object, graphic,
text, expression, or any item on a
display panel

Right-Click: Select the item(s) to
modify. Position the cursor over
the item(s) and click the right
mouse button.

Remembering Tagnames

Many dialog boxes contain expression fields. Expression fields are yellow
to indicate that you can get help identifying or remembering a tagname and
associated data members by pressing the right mouse button (right-clicking

on the selected expression field).

You can select multiple items on a display panel by clicking in a panel and
dragging the box outline around the objects you want to work with. Subsequent
commands affect the entire group at once or toggle from one item to the next,
prompting you for new instructions. You can stop this process at any time by
holding the <Shift> key down and selecting either the OK or Cancel buttons in the
current dialog box.

Assume, for example, that you want to trend the flow in a return water line.
You start to create the trend object, but you cannot remember the tagname
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you want to trend. Right-click on the trend line expression field (the field
in which you normally type the tagname to trend).

When you right-click any expression field, Lookout presents the
Expression Editor dialog box, as shown in the following diagram.

Expression editor | ]
[pic1.flow
— Signals:
plc. Howe
Tags: [rata members:
OwenSinl4 =" [F400001-465000 =]
OwenSin3 F40001-43393

Modbus

Garbled
MoResponze
PratocolEmors
5400001-465000
54000143339

hUMmeric

()8 | Cancel |

Figure 3-1. The Expression Editor Activated by Right-clicking on a Yellow Data Field

Using the Expression Editor dialog box, you can easily paste object names
and their data members directly into the expression field. After you select
an object and a data member, paste them into the expression editor data
field, and click on OK, Lookout writes your expression into the trend
expression data field.

Tag: IHawPumpTrends

DkI

Trend width: I‘I:DD el |
¥ Show button bar
~ Trendline:
B lines Line 1 expression = & Logical © Numeric

dccept | [oict fow
Delete |

Position:

Height:

Erevitus: | |2
Mext |

Line color:

|5
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Using Lookout

This chapter discusses the basics of using Lookout, including selecting
objects, creating objects, editing object databases, and other operations.

If you have not read the discussion of Lookout architecture in Chapter 2,
Introduction, and the discussion of basics in Chapter 3, Getting Started,
you should go back and read those chapters. This chapter builds on
information presented in the earlier chapters, and assumes that you have
absorbed that information

The keys to using Lookout are objects—their parameters and data

members. The technique for using Lookout involves solving problems by
selecting objects and making connections.

Selecting Objects

How do you decide what objects to pick and what connections to make?

Some decisions are easy—you will certainly use driver objects for the
different PLCs, RTUs and other devices you need to monitor and control.
Other decisions are driven by what you want to do.

To solve problems with Lookout, ask yourself which object does what you
need done.

Lookout has many objects with obvious uses, such as pushbuttons,
switches, and trend displays. Other Lookout objects may not be as
immediately obvious as to how they might be used. To familiarize yourself
with Lookout objects, you should browse through Chapter 18, Object Class
Reference.

After you become familiar with the Lookout objects, you have a better idea
of which object to select—or which objects to investigate—to solve the
problem you are facing at the moment.
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Creating Objects

To Create an Object

Complete the following steps to create a Lookout object.

1.  Make sure you are in Edit Mode. (Select Edit»Edit Mode if
necessary.)
2. From the Lookout menu bar, select the Object»Create... command.
For this example, select the Pot class of objects, found in the Control
category.
Select object class: | ]
¥ Categorize
—Fat
""" @ Counter ;I Create a potentiometer to track and/or alter the value of &
""" @ DataTable numetricvariable. A Pot can be displayed on a Panel as a
""" @ DelayOff slider, rotating knoh, or as a digital display/input.
----- @ DelayOn
----- @ Derivative
----- @ ElapsedTime
----- @ Flipflop
----- @ Integral
----- @ Interpolate
----- @ Interval
----- @ Junction
----- @ LatchGate File Mame: POT CBX
""" : m_ﬁ‘_"m“m Date Modified: ~ Fri Mar 0B 20:13:24 1998
----- inimurn e
_____ @ Meutralzone File Size: 102912 bytes
----- @ OneShot
""" @ PD Ok | Cancel
----- I BPot
----- @ Fulse =l

Lookout Reference Manual

Figure 4-1. The Select Object Class list box

When you select an object class, a dialog box you use to define the
object parameters appears.
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Tag: lF'ot‘I—
Minirriurm: l—
I awimurn: l— — |

Resolution: l—

— Position source

o

 Remote
’VPosition= I
= DDE

Senice; Itripper
Tapie: Itest
IEerm: IF'ot‘I

Control security level: ID ¥ Log events

Figure 4-2. An Object Definition Dialog Box

3. Assign a unique tagname to the object. Valid tags are described in
Object Tagnames, below.

4. Define the object parameters. Each object class has unique parameters,
described in Chapter 18, Object Class Reference.

Some parameters can be defined as expressions—roughly the
equivalent of spreadsheet formulas—that you can use to manipulate
data. See Chapter 7, Expressions.

5. Select OK to create the new object.

Many object classes are not displayable on a control panel, such as a
protocol driver object for a typical PLC, or an object such as
Neutralzone or Pulse (both Lookout objects with special
functionality).

Other object classes, like Pots, are displayed on a control panel. When
you create such an object, Lookout presents you with a Display dialog
box you use to define how the object is displayed.
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Insert: Potl | ]
= m 100
75 % I B Y B B

Cancel |

Figure 4-3. Pot Display Dialog Box

6. In the Display dialog box, choose how you want the object to be
represented and select OK.

7. Position the object on the control panel and adjust the size.

Note You can copy objects to paste onto another Lookout panel, but if the panels are of
different sizes, the pasted objects may not appear in the proper location on the new
panel.

Object Tagnames

A tagname is the name that you give to a specific object. Tagnames include
the characters A —Z, a—z, 0 — 9, and the underscore character ( _ ).
Tagnames must begin with a letter, and can be up to thirty two (32)
characters long. Spaces and tabs are not allowed.

Lookout recognizes uppercase and lowercase characters as the same
character, so SW2 and sw2 are the same tagname.

You must assign each object a unique tagname. Lookout does not allow you
to create or modify an object if the tagname is not unique or if it does not
follow the proper tag naming convention.

Examples of Valid Tagnames

Pump3_HOA
HighServicePump3_Run
ClearWellLvl_at_Hiway289_and_I35
ShaftTempF

Pushbutton1

runtime

Swl

Sw2
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Using Lookout keywords (object class names and function names) as
tagnames is not allowed. For example, you cannot use terms such as
Switch, DelayOn, STDEV, Modbus, nif, and Trend.

Invalid Tagnames Reason
3Pump_HOA begins with number
_HighServicePump3_Run begins with underscore)
ClearWellLvl at Hiway289 and 135 contains spaces
#ShaftTempF begins with #
Pushbutton reserved word
ThisTaglsWellOverThirtyTwoCharacters too long
and reserved word

Editing Object Databases

Lookout creates the native database of an object automatically when you
create the object. The native database is documented at the end of each
object class definition in Chapter 18, Object Class Reference.

You can create new data members or modify the parameters of any existing
native data member. These parameters include such things as alarm
setpoints, deviation filters, scaling factors, historical logging, and alias

names.
Note Any object in Lookout can have its native database modified. However, this is most
practical for objects with large native databases, such as driver objects and Data

Table objects.

To Edit Datahase Parameters

1. For the purposes of this example, create a Modbus object. Use the
tagname PLC_1.

The Modbus object can be added to your system without a physical
connection while you are learning to use Lookout. Let the default
settings stand when you create the object.
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2. From the Lookout menu bar, select Object»Edit Database....

Edit object database: | ]

|Pane|1

Potl

Ok I Cancel

3. In the Edit object database list box, choose PLC_1.
The following dialog box appears.
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PLC_1 database | ]

Configured points: [Mative members: —#larm conditions

Group:l 'l

100001-165000

10001-19999 ™ Generate logical alarm
1-9999 o

300001-365000 Friarity: I
30001-399394

400001.1-465000.16 =

logical read fwrite

Alias (optional): Member:

Description
on | Off:
[ Invertlogical signal I_.Dgto historical database
Lifespan
= Perpetusl

= |365 ez

S I Delete Select object... | Irmpart... | Export... Cluit

4. For each data member to be configured:

a. Identify the desired data member by entering it into the Member
data field. If you are modifying a data member that has been
previously configured, you can select it from the Configured
points list box.

For this example, select 40011 as the modbus data member. Enter
FlowRate as the alias

Note Parameter fields automatically change depending on the data member you select.
Lookout automatically determines whether the data member is logical or numeric,
and presents you with the appropriate parameter attributes.

b. Configure appropriate parameters shown in the following
illustration. See the individual parameter sections in this chapter
for details on setting each parameter.
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PLC_1 database | ]

Mative members:

Configured points:

10001-19939
1-9939
300001-365000
30001-39999
400001.1-465000.16

numeric read fwrite

—Alarm conditions

Group:lwater vl
Condition  Lewvel Friority
HiHi: |190

Hi: 150
La: 60

Lole: |2

11

Deadband:

Alias (optional): Member:
[FlowRate [400011
—Description

— Filters (engineering units)

IPotabIe YWater Flow

Prefix: IFIDW Suffie. |MGD

Deviation: 2

1

" Forced:

—Scaling v Log to historical database
tinimum taximum Lifespan
R units: {5400 [32000  Perpetual
Eng. units: ID IZDD & |60 days
Sawve I Delete | Select object... | Irmpart... | Export...

Cluit

Lookout Reference Manual

c. Select Save or Update. (If you are modifying a data member that
was previously defined, the Save button changes to an Update

button.)

Lookout stores all the new parameter settings for the specified data
member when you select Save or Update. In addition, Lookout adds
the modified data member to the Configured points list box for future
reference. Lookout immediately reflects these changes throughout
your configuration.

5. Select Quit to exit the dialog box.

Numeric Membher Parameters

The following diagram and paragraphs describe numeric data member
parameters. Logical data members, covered in the following section, share
a number of the same parameters.

© National Instruments Corporation
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PLC_1 database [x]
Configured points: [Mative members: —Alarm condtions ———————
Group:lwater vl
100001 165000
10001-19999 Condition  Lewvel Friority
1-9339 HiHi: I IB
300001-365000
30001-399394 Hi: I IB
400001.1-465000.16 =
Lo: I |5
numeric read fwrite Lol l— I?_
Alias (optional): Member:
[FlowRate 400071 Deadhand: |
—Description — Filters (engineering units)
IPotabIeWaterFlow Dewviation: |2
Prefix: IFIDW Suffise [MGD [~ Forced: I
—Scaling v Log to historical database
tinimum taximum Lifespan
R units: {5400 [32000 C Perpetual
Eng. units: ID IZDD & e days
Sawve I Delete | Select object... | Irmpart... | Export... Cluit

© MNational Instruments Corporation

Alias renames any native data member. You can think of an alias as a sort
of nickname. For example, the Modbus driver object includes the native
data member 40011 that represents an analog input. You can give this
native data member an alias like F1owRate. From then on, you can
reference the alias FlowRate instead of its native name 40011. All
associated parameters (such as Scaling) are also applied to the alias value.

An alias is a good way to insulate your Lookout configuration from changes
in your PLC, RTU, or I/O configuration. For example, consider a flow
transmitter wired to an analog inputat 40011. You can give 40011 the alias
name FlowRate, just as you did in the example. Multiple control panels
can then display the FlowRate data member and numerous other objects
in Lookout can use it. If you later rewire the transmitter to the analog input
at 40012, you need only modify the alias FlowRate to reflect the new I/O
address. Lookout instantly reflects this change everywhere FlowRate is
used.

You can modify all associated parameters of an existing alias except the
alias name itself. If you attempt to modify an existing alias name, the
Update button changes to a Save button and you will only create a new
alias.
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Most developers implement aliases on objects with large native databases,
such as driver objects (like Modbus and Tiway) and Data Table objects.

= Note An alias is optional. You can apply scaling, alarming, and logging parameters to
any native data member and save it to the Configured points list without giving it
an alias name.

The Description appears as the message text in the alarm window. It can
have spaces, and it can be lengthy. You do not have to enter quotes in this
field.

Prefix and Suffix are part of the description, but do not appear in the alarm
window. They are just additional descriptive text.

Define Scaling by entering Raw units and Eng. units. The raw numeric
data member is converted (scaled) to an engineering unit value. The PLC in
this example generates a raw value ranging from 6,400 to 32,000. Lookout
converts that raw signal to range from 0 mgd to 200 mgd. The conversion
is linear. See your hardware specifications and calibration records for the
minimum and maximum raw units associated with analog devices. If you
leave the Raw units and Eng. units fields blank, Lookout performs no
scaling on the signal.

Deviation filters out insignificant variations of numeric signals. The
following figure shows two values plotted on a trend. One line is the raw
unfiltered value. The other, stair-stepped line, represents the filtered value
after passing through a Deviation of 2.

o ||| |—|

3540 143550 143900 143510 14:39:20 143930 143840 14:39:50  14:40:00

The Citadel database also uses Deviation as the criteria which triggers
logging of new historical data to disk. See Chapter 11, Logging Data and
Events, for more information on logging data.
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Use the Forced data field to manually enter a constant value for the data
member. When you select the Forced check box and enter a value in the
field, Lookout forces the engineering unit value to be equal to the value you
entered—regardless of the actual value of the native data member. You
might use this when a sensor fails or during sensor maintenance, or any
time a PLC receives a bad signal from the transmitter.

Use the Alarm condition parameters to define alarm limits and their
associated priorities. Lookout compares the alarm setpoints to the
engineering units value (that is, the post-scaled, post-filtered number). If
you do not enter scaling parameters, Lookout applies the alarm parameters
directly to the raw signal.

You can assign an alias or native data member to any existing alarm Group
or you can create a new Group. To create a new Group, enter the new
group name in the field. See Chapter 9, Alarms, for more information on
alarms.

Use the alarm Deadband parameter to prevent fluttering between alarm
and normal states when the signal value hovers near an alarm limit. The
following figure shows a value plotted against its Hi and Lo alarm
setpoints.

High

Low

Alarm
RAv, 1380
Normal
Normal \
Deadband — 72.0

60.0
AIarm/ v

Figure 4-4. Alarm processing of a data member whose alarm setpoints are
shown and whose Deadband is 12
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Lookout generates an alarm the moment the value violates the Hi or Lo
alarm setpoints. The alarm returns to normal when the value drops below
the high alarm setpoint minus the Deadband, or goes above the low alarm
setpoint plus the Deadband. The Deadband also applies to all HiHi and
LoLo alarm limit setpoints.

The Log to historical database parameters define how long to store a
value in the Citadel database on your hard drive. If you do not select this
option, Lookout does not log the value to your disk. If any scaling or
filtering parameters are defined, Lookout logs the scaled, filtered value
(that is, the engineering unit value). See Chapter 11, Logging Data and
Events, for more information on logging data.

Logical Member Parameters

Some of the parameters of logical data members are different from those of
numeric data members. Scaling of a logical signal consists of the Invert
Logical Signal check box. When you choose this check box, an ON value
is represented by an OFF value, and so on. When you do not select it, ON
is ON and OFF is OFF.

A logical database signal is shown in the following figure.

PLC_1 database [x]
Configured points: [Mative members: —#larm conditions
FlowRate 000001-065000 = Group:ISteam vl
_ 100001-165000
10001-19999 ¥ Generate logical alarm
300001-365000 Priority: |8
30001-39939
400001.1-465000.16 x|
logical read fwrite logical read fwrite
Alias (optional): Member:
[vate_1 [7

Description

IStatus of high pressure relief vale

On:

IOpened Off: ICIDsed

I Inwvert logical signal

MNew database entry sawved.

I dste I Delete Select object... | Irmpart... | Export... Cluit

v Log to historical database
Lifespan
 Parpetual

& |50 days

Lookout Reference Manual
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Alarm parameters of a logical signal include the alarm Group assignment
field and the Generate Logical Alarm check box. When selected, the data
member generates an alarm whenever the value is ON; the alarm condition
clears whenever the value is OFF. Notice that if the Invert Logical Signal
check box is selected, the value used here is the inverted value. See
Chapter 9, Alarms, for more information about alarms.

Text Member Parameters

The text data member database contains only Alias, Member, and
Description fields.

Importing and Exporting Object Databases

Use the import database service to copy database member parameters from
an Excel spreadsheet file directly into an object. Use the export database
service to copy an object database into an Excel spreadsheet file. This is
what you can do using these services:

*  Export object database parameter definitions to Excel for the purpose
of documentation.

*  Export an object database to Excel, perform global replacements on
data member parameters, and then import the changes.

* Create a tag list in Excel or in an application that exports to Excel,
then copy that tag list into Lookout.

* In aprocess using multiple duplicate driver objects (such as a gas
pipeline or water distribution system), define a single driver object
database parameters in Excel. Import that database into multiple driver
objects.

Although you can import and export any object database, you may find that
these services are most useful for objects with large native databases, such
as driver objects and Data Table objects.

Exporting an Object Database
To export an object database:
1. From the Lookout menu bar, select Object»Edit Database....
2. In the Edit object list box, choose the object you want.

The following diagram shows a Modbus object that already has a
number of logical and numeric data members defined.
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PLC_1 database | ]

—Alarm conditions

Configured points: Mative members:

FICT01Als 000001-065000 | | GrougChiled Water 7]
FICT01Fler 100001-165000

FIC101Mode 10001-19999 ¥ Generate logical alarm
FICT 0T Cutput 1-9999 o

FICT01Run 300001-365000 Friarity: |5

FICT01 Setpaint 30001-399394

FIC101Speed 400001.1-465000.16 =

logical read-anly

Alias (optional): Member:

[FicTo1Alam 10003

Description

IChiIIed YWater #1 Flow Controller Alarm Status

On: | Off: |
v Log to historical database
Lifespan

I Inwvert logical signal

 Parpetual
(365 days

I dste I Delete Select object... | Irmpart... | Export... Cluit

3. In the database dialog box, click on the Export button.

Export PLC_1 database to... 21=]
Save jn: |@My_Apps j gl l_
| Japps
File name: Save |
Sawve as type: IExceI Spreadshests(*xls) j el |

4. In the Export Object Database to... dialog box, choose a directory
path, enter a filename and click on OK.

When you export a database, Lookout does not export every possible data
member (many driver objects have a capacity for thousands of members).
Instead, Lookout exports configured points; that is, data members that have
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at least one parameter already defined. Lookout also exports native
members that are in use (that is, connected to other objects).

The spreadsheet file that the Lookout Export command creates is in Excel
Version 2.0 format. An example of the . XLs file is shown in the following
illustration.

Member Description Prefix Suffix Eng min

FIC101Alarm 10003 Chilled Water #1 Flow Controller Alarm Status

FIC101Flow 40001 Chilled Water #1 Flow Rate CFs

FIC101Mode 10002 Chilled Water #1 Flow Controller Mode tanual

FIC1010utput 40003 Chilled Water #1 Flow Controller Qutput %

FIC101Run 10001 Chilled Water #1 Feed Pump Off

FIC101Setpoint 40004 Chilled Water #1 Flow Controller Setpaint %

FIC101Speed 40002 Chilled Water #1 Feed Pump Speed %

Creating a Database Spreadsheet

The easiest way to create a database spreadsheet for an object is to create
the object in Lookout, define the parameters for one logical data member
and one numeric data member, and then export the database. The export
function automatically creates all the necessary column labels, and the two
data members furnish examples you can follow.

Notice that Row 1 contains column labels. These include the names of all
possible data member parameters. Lookout references the labels, not the
column numbers, so you must spell all column labels exactly. Lookout
ignores white space and is case-insensitive. The table below lists all
possible column labels.

Table 4-1. Spreadsheet Column Labels

Command Member Alias Description

Prefix Suffix Eng min Eng max

Raw min Raw max Invert? Deviation

Force? Forced value Alarm group Lolo level

Lolo priority Lo level Lo priority Hi level

Hi priority Hihi level Hihi priority Logical priority

Log data? Lifespan (Empty if not (Empty if not
assigned) assigned)
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Lookout requires the column labels Command and Member. All other
column labels are optional. Command must be in Cell Al. The order in
which the other column labels appear makes no difference.

When you import a database, Lookout reads the first 30 columns (A — AD)
and ignores columns that do not have labels.

The rows below the column labels (below Row 1) each represent a database
member. For example, Row 5 in the spreadsheet sample above represents
the data member whose alias name is FIC101Mode.

You can easily add rows to define new points. Copy the rows associated
with FIC101 and then modify the new rows slightly by identifying different
native members and giving them new aliases and descriptions.

Member Description Suffix Eng min

insert FIC101Alarm 10003 Chilled YWater #1 Flow Controller Alarm Status

insert FIC101Flowi 40001 Chilled Water #1 Flow Rate CFS 0
insert  FIC10TMode 1000 [y ey e -
insert FIC1010utput  4000:

insert FIC101Run

insert FIC101Setpoint  4000¢ a

insert FIC101Speed 4000 Yes ‘ ~ho CE‘”EE“ Help ‘ 0

insert FIC102Aarm 10006 Chilled Water #2 Flow Controller Alarm Status

insert FIC102Flowi 40005 Chilled VWater #2 Flow Rate CFS 0

insert FIC102Mode 10005 Chilled VWater #2 Flow Controller Mode Auto Manual

insert FIC1020utput 40007 Chilled Water #2 Flow Controller Qutput % a

insert FIC102Run 10004 Chilled Water #2 Feed Pump On Off

insert FIC102Setpoint 40008 Chilled Water #2 Flow Controller Setpoint % a '
insert FIC1025peed 40006 Chilled Water #2 Feed Pump Speed % a

1000 3) 'ple_1.xls' was created in & previous version of Microsoft Excel. Do you want to update itto the
current Micrasoft Excel format?

2
|41| A ¥l pre_t

I#l i

If you are working with a version of Excel more recent that 4.0, the program
asks you if you want to update your spreadsheet to a newer format when
you select File»Save. This dialog box is shown in the illustration above.
Be sure to select No. Lookout does not currently accept Excel spreadsheet
files from versions greater than 4.0.

Importing an Object Database

Lookout Reference Manual

When you import a database, Lookout reads the first 30 columns (A — AD)
and ignores columns that do not have labels as well as Column AE and
beyond.

Each row in the Command column (Column A) contains either the keyword
insert or the keyword delete. When you import a database, Lookout
ignores rows that do not have the insert or delete keyword. It adds

4-16 © National Instruments Corporation



Chapter 4 Using Lookout

those records whose command keyword is insert. It removes those
records whose command keyword is delete. To determine exactly which
records to delete, Lookout uses the record alias name; or if the record does
not have an alias name, it matches the record member name.

To import an object database:

1. From the Lookout menu bar, select Object»Edit Database.
2. In the Edit object list box, choose the object you want.

3. In the object database dialog box, click on the Import button.

Import PLC_1 database from... 21=]

Lookin: |53 My_Apps = &l e =

File name: Iplc_1 s Open |
Files of type: IExceI Spreadshests(*xls) j el |

4. In the Import Object Database from... dialog box, choose a directory
path, select the filename and click on OK.

When finished, Lookout presents you with a set of database import
statistics, as shown in the following illustration.
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PLC_1 Database Import Statistics ]
—Results of database import:
—Successful records Database entries:——————————
Created: 7 Presdiously: 7
Updated: 5 MMy 14
Unchanged: 2
Deleted: 0
Spreadshest row numbers:
—Unsuccessful records
Invalid member: 0
Feadfwrite privilege lost: 0
Type change attempted: 0
Qut of memony: 0
MNat deleted: 0
Total records processed: 14
As you can see below, the points added to the database spreadsheet were
successfully added to the Configured points list.
PLC_1 database [x]
Configured points: [Mative members: —#larm conditions
FICT01 Setpaint =] [ooooot-nesoon - Gmup:IChiIIed Wikter vl
FICT01Speead 100001-165000
10001-19999 ¥ Generate logical alarm
FICT02F o 1-9999 o
FICT02Mode 300001-365000 Friarity: |5
FICT020utput 30001-399394
FIC102Run x|’ |400001.1-465000.16 x|
logical read-anly
Alias (optional): Member:
[FicTn2aiam 10006
Description

Lookout Reference Manual

IChiIIed YWater #2 Flow Controller Alarm Status

o D

v Log to historical database

I Inwvert logical signal -
Lifespan
 Parpetual

(365 days

I dste Delete Select object Irmpart... | Export... Cluit
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Copying an Object Database

The import and export features make it easy to copy the database of an
object. This is especially useful when creating large SCADA applications,
such as gas pipelines with multiple compressor stations.

The key to defining multiple driver objects that require duplicate databases
is to first create an object in Lookout for each RTU or PLC. Then create a
single database in Excel. Next, import that database into each driver object.

Connecting Objects

In Lookout, you connect objects to pass control signals between the
objects—in much the same way you would wire a time delay relay to a
motor starter relay, for instance. Once connected, objects pass signals
between their various data members and parameters.

There are two basic methods to connect objects: from data member
to parameter, or from data member to data member. The method you
use depends on what you are trying to accomplish.

5 Note One tip for using Lookout— when you choose an object in the Edit Connections
dialog box, always select the object you want to connect to.

Connecting Data Members to Parameters

The following example uses the (implicit) data member of a Pot object as
the Data source of an Average object. You can tell that Data is a parameter
because it appears in the Average object dialog box.

1. Create a Pot object as shown. See the Creating Objects section earlier
in this chapter for detailed information.
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Tag: IPDH

kinimum: [0
|
Maxirnurm: |1DD
Cancel |
Eesolution: |1|

—Position source

& Local
- Remote

EasiticEn = I

' DDE

EEfIEE I
i I
[teri I

Contral security level: ID V¥ Log evants

2. Now, create an Average object. Connect the potentiometer numeric
signal to the Data parameter. The Average object calculates the
average level of Pot 1 over time, as described in the Average object
definition in Chapter 18, Object Class Reference.

Tan: W
Data = |P0t1

Reset= I

Enable = I

Ok I Cancel

Identifying Object Data Members

Because many objects generate multiple signals you can use as inputs to
other objects, the object tagname is not always sufficient to identify the
desired signal. You must identify both the object tagname and the
appropriate data member. For example, a Modbus object generates
thousands of signals, some logical and some numeric. To specify exactly
which signal you want from a particular Modbus object, enter the object
tagname followed by a period (.) and the data member you want.
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If you have a Modbus object with a tagname PLC1, and you want to display
the value residing in holding register 40001 and the status of coil 100,
reference those particular data members by typing PL.C1.40001 in one
expression and PLC1.100 in another expression.

Connecting Data Members to Data Members

The following information expands on the previous example, in which you
created a potentiometer named Pot 1. In this example, you create a Modbus
object and connect the numeric signal generated by the pot to a 16-bit
holding register at address 40001 on the PLC.

1. Create a Modbus object. You do not have to have a real PLC connected
to your system. Just accept the default parameter settings in the
Modbus dialog box and click OK.

2. From the Lookout menu bar, select the Object»Edit Connections...
menu command. You use this menu command any time you are
connecting to the database of another object.

3. Inthe Edit Object Connections list box, choose the object that contains
the data member you are connecting to.

Remember, you are connecting the Pot 1 signal fo data member 40001
in the Modbus object.
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Edit object connections: | ]

Averagel
Modbusl
Fanel
PLC_1
Fotl

Ok I Cancel

4. In the Select member data field, enter the data member you want to

connect 7o.
Modbus1 connections | ]
Modbus1.40001 = f
Existing numeric connection
o ememeer Accept | Clear | Cluit |
40001
—Signals:
Existing connections: Tags: (class)
PollRate $Keyvhboard
$Systarm
Averagel
Modbusl
Fanel x|
Writable members: Feadable members: numeric
000001-065000 -
1-9999 Citadel.active
400001.1-465000.16 Citadel.unacked
4000071-465000 cormrm.active
40001.1-49999.16 comrm.unacked
40001-49499 x| DDE.active x|
Select I Select ohject.. | ﬂl $Alarm.active
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Click on the Select button to identify the data member to be written
to. Notice the dialog box now reflects the specific member;

Modbus1.40001 =. Also notice the equal ( =) sign. This prompts you
to connect an expression to Modbus1.40001. In this case, use the
expression Pot1.

5. Inthe yellow expression field, enter the tagname Pot1.

Modbus1 connections | ]

todbus1.40001 =
Existing numeric connection

—Selectmember:

|Pot1

Connection accepted

40001

Existing connections:

Using Lookout

. Accept | Clear | Cluit |
—Signals:
Tags: Fot

40001
FollRate

Writable members:

000001-065000
1-9939
400001.1-465000.16
400001-465000
40001.1-49499.16
40001-49939

Select

Select object... |

numeric

Feadable members:

Faste | Fotl

6. Click on the Accept button. This confirms the connection You should
see a message confirming the action. You will also see data member
40001 added to the Existing connections list box.

You have now connected a data member of one object to a data member of
another object. Any change in the (implicit) value of Pot 1 is, by definition,
an event, sending a signal to all the other objects Pot1 is connected to.
Because it is now connected to Modbus1.40001, adjusting Pot 1 changes
the value of data member 40001 in object Modbus1.

© MNational Instruments Corporation
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Displaying Data Members on Control Panels

To Display a Data Member on a Control Panel

From the Lookout menu bar, select Insert»Expression....

In the Tags list box, select the object you want, or type the tagname
and data member in the yellow expression field. See Chapter 7,
Expressions, for more information.

Insert expression | ]
—Signals:
Faste | Modbus1 FlowRate
Tags: Data members:
$Alarm D400001-465000 =]
$Keyvhboard D40001-49394
$Systarm Exceptions
Averageal F400001-465000
_ |F40001-43939
Fanel : ite
PLZ_T
Fotl MoResponse
FrotocolErrors
5400001-465000
540001-49999 x|
Modhbus numeric
0] | Cancel |

Lookout Reference Manual

In this case, select the Modbus PL.C object. When you select an object,
Lookout lists the object data members.

In the Data members list box, select the data member you want.
Click on Paste and then select OK.

Lookout responds by presenting the Display Numeric (or logical)
signal dialog box. The type of dialog box depends on the type of data
member being inserted (numeric or logical). In this case the signal is
numeric (Modbusl.FlowRate).
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Text Color S oy F o
ackground style — — Frame style ——
mEEREREER EEEE s L
Background color nse e
D. ..  Rectangle & Mone
........ & Transparent
Wi 0 © Left & Centarad ¢ Right [ Display Stis—
U I & Digital
haximum IZDD  Bar(up)
0 = Bar (down)
MNumetric farmat I- = Bar (right)
IGeneraI j = Bar (leff)

Fant... |1DptAriaIEloId OK I Cancel

Select the display parameters you want, and click on OK.
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Note

The following tour guides you through the development of a simple process
file. Any time you want to learn more about a particular object class,
function, or feature, refer to the appropriate section of the manual for a
more detailed explanation.

If you have not used Microsoft Windows, you should first familiarize yourself with
concepts outlined in the Microsoft Windows User Guide. Learn how to use the
pull-down menus, maneuver within dialog boxes and switch between Windows
applications before continuing.

Building a Lookout Monitoring System

The example system monitors the water level in an elevated tank several
miles away (remote RTU), and controls a pump located in the plant (local
PLC). When the tank drops below a certain level the pump kicks on to fill
up the tank, when the tank is full the pump shuts off. The tank is a 50-foot
tall water storage tank.

The system to be controlled by this process file consists of a PLC and an
RTU, both of which communicate using the standard Modbus protocol.
Modbus is the example protocol because of its widespread use in the
process control and SCADA industries.

You will connect to the PLC using hardwired serial communications.
You will tie the RTU to Lookout with radio communications. Assume
that Lookout is at a remote radio (not the master repeater).

Create the Control Panel

Activate Lookout. It appears with a blank window.

Choose File»New... to begin development of your sample process file.
Lookout opens a New Control Panel dialog box.
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0:0alams

Fill in the Control Panel Tag name and Title accordingly and pick Normal
as the panel type, and maximize the panel. It should now take up the entire
workspace and the panel title appears in parenthesis at the end of Lookout
title bar. You can choose not to build your control panels full screen,
designing them around their normal state, instead.

£~ Lookout - (untitled) - [Overview]

I( ]
g File Edit Insert Object Amange Change Options Alarms Window Help =181x]

| 0:0alams

Note Consider screen resolution when creating display panels (for example, VGA vs.
Super VGA). The same panel can appear differently on computers using different
resolution display drivers. Please read about screen resolutions in the Panel
section of Chapter 18, Object Class Reference, before designing your panels.
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Ordinarily, you would now add the logic and graphics that control and
display the pump and tank. First, however, create a potentiometer that
simulates a fluctuating tank level instead of directly connecting the Modbus
register for that analog input. You can use this control to simulate an analog
signal if you do not have readily available Modbus devices. After
demonstrating the process with a simulation pot, you can connect the

system to its respective Modbus registers.

Select Object»Create... and pick Pot from the list of object classes in the

Control category.

Select object class: | ]

¥ Categorize

----- @ Counter

..... @ DelayOff
..... @ DelayOn
----- @ Derivative

----- @ Flipflop
----- @ Integral

----- @ Interval
----- @ Junction
----- @ LatchGate
----- @ Maximum
----- @ Minirmurm

----- @ OneShot
..... @ FID

----- @ DataTable

----- @ ElapsedTime

----- @ Interpolate

----- @ Meutralzone

|

|

—Pot

Create a potentiometer to track and/or alter the value of &
numetricvariable. A Pot can be displayed on a Panel as a
slider, rotating knob, or as a digital display/input.

File Name:
Date Modified:
File Size:

Fri bdar 06 20:13:24 1998

Cancel

Select the object class you want and double-click on it, or select OK.

Fill in the dialog box as shown in the following illustration.

© MNational Instruments Corporation
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New potentiometer: | ]

Tag: ISimuIationLeveI
inimum: ID—
Maxirmum: IED—

Resolution: |1—

—Position source

k

Cancel

i

& Local
- Remote

EasiticEn = I

' DDE

EEfIEE I
i I
[teri I

Contral security level: ID V¥ Log evants

Select OK when you finish. Lookout immediately prompts you to select a
display type for the pot.

Insert: SimulationLevel | ]

o) ==

() K] (2] (4

wertical slider

Cancel |

Choose the vertical slider display and select OK. Lookout inserts the
pot on the active control panel. You can now stretch or reposition the
potentiometer anywhere on the panel using the sizing handles.
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£” Lookout - (untitled) - [Control Panel]

Sizing File Edit Insett Ohject Arrange Change Options  Alarms  Window Help 18] =l
Handles —a = u
n
[ 170017 | 3zxesr | Potl vslide | 0:0alarms
Now select Insert»Expression....
Insert expression | ]
ISimuIationLeveI
—Signals:
SimulationLewvel
Tags: Data members:
$Alarm
$keyboard
$Systarm
Pat NUMErc
(0] | Cancel |
Pick simulationLevel as the value to be inserted. Select the Paste
button to insert the tagname in the expression field and select OK. You
could also type the tagname in the expression field. Double-clicking on
the tagname also pastes it to the expression field.
© MNational Instruments Corporation 5-5
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Lookout prompts you to select display characteristics for the numeric
signal you just named. Pick the same parameters as below. The example
uses dark blue as the Bar Color and gray as the Background Color. Notice
the Background Style is inset and the Maximum is 100.

Bar Color
ackground style— —Frame style ——
. . Back d styl F |
 Flate  Black
EEEEEEE € Pl € ol
Background color nse e
D. ..  Rectangle & Mone
........ & Transparent

—Display Style —

- et o Eentered R
tinimum ID  Digital
haximum |1DD & Bar (up)

= Bar (down)
MNumetric farmat = Bar (right)
IGeneraI j = Bar (leff)

it |1DptAriaIEloId OK I Cancell

Note Lookout makes extensive use of color grids in many of its dialog boxes. These
color grids may look slightly different from computer to computer.

After selecting OK in the Display Numeric Signal dialog box, Lookout
places the bar graph on the control panel. You can resize or move it around
the screen. Arrange your control panel to look like the example.
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£” Lookout - (untitled) - [Control Panel]

Eile Edit Insert Object Arrange Change Options  Alarms  Window  Help 18] =l

[ [ [ | 0:0alarms

This bar graph simulates the water level in the tank. To give it a more
realistic look, lay a graphic of a tank on top of it to act as a mask.

Select the Insert»Graphic... command and pick the graphic file
tankl_a.wmf. Because the example uses a metafile you can resize
it to just fit over the bar graph, masking out part of the bar graph.
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£” Lookout - (untitled) - [Control Panel]
Eile Edit Insert Object Arrange Change Options  Alarms  Window  Help 18] =l

[ [ [ | 0:0alarms

Press <CTRL-SPACE> to toggle out of edit mode and move the slider up
and down to see the fill effect created with your tank mask and bar graph.
Then get back into edit mode so you can create a trend of the tank level.

Save the work you have already done before going any further. You should
get into the habit of periodically saving your process file when developing
anew system or making modifications to an existing one. Select File»Save
from the menu commands, type tutorial for your filename, and

select OK.

Save Process File As... EHE
Sawe in; Ia lookout j gl l_

1997
citadel
graphics
My_Apps
Samples
sentinel
sinecl2

File name: Itutorial| Seve

Sawve as type: IProcess Files™lkp) j |

Cancel

[ Bratectfile frarm et withyaur sceaunt namey passwerd
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Your work is now stored on the hard drive as TUTORIAL . LKP. You should
see the new filename in the Lookout title bar followed by the active control
panel title.

Adding Data Display
Select Object»Create... from the menu commands and pick the
HyperTrend class.

Complete the parameters as shown. If your trend has a Show button bar
option, select it.

Create HyperTrend | ]

Tag: |TankTrend Ok |
Trend width: |1:DD Cancel |

IV Show button har

— Trendlines
Mo lines Mew line expression =  Logical & Numetic
Accapt ISimuIationLeveﬂ

Delete | Minimurm: Maximurn:
ID ISD
EreyiEus |
Line color:

[l et |
N HE B
HENENEEEEN EEEm

Notice that the examples defines Trend Width to be just 1 minute in
length. This is so you can instantly observe fluctuations in your simulation
pot. Normally the trend width would be much longer—1 day or 1 week for
example.

After entering the value you want to trend (SimulationLevel), be sure to
select the Accept button. Now select the OK button. The display dialog box
appears.
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Faper colar
R | HE =
HEEEEEEESE EEEE
Grid color

|| HE =
ENEEEEEES EEaE
Timeline labels Harizontal grid style

" Wertical hajor increments |1D

 Yarical (small)

 Harizantal Minar increments |2

& Horizontal (small)

 Molabels 0K | Cancel |

Choose your display parameters and select OK again. Like all other
objects, you can resize and/or move the trend on your control panel.

7 Lookout - tutorial lkp - [Control Panel]

File Edit Options Alarms Window Bun  Help 18] =l
4444 D rpp 1) 02487 133533 §
I [
L | e
i 1A f ......
byl ) | !l
i AT
1] [ 1 [
1 b0 L | M
i) YA
T 1L 15
| |
! !
] |
f £33
1
il 133445 133500 133515 133530
[10/2413:35 | (nobody) [ Mational Instruments Internal Lse Only | 0:0alarms

Again toggle out of Edit mode and move the slider up and down to see the
effect. (You might also want to save your file.)
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Adding Control Objects

Now it is time to create an HOA switch and a Neutralzone object to control
your pump. Get back into edit mode and create a Pot object. This serves as
your three position switch (1=Hand, 2=0ff, 3=Auto). Choose knob as the

display style.
Tag: IHOA

kinimum: |1
',_

awimum: |3
Cancel |

Fesolution: |1

—Position source

& Local
- Remote

EasiticEn = I

' DDE

EEfIEE I
i I
[teri I

Contral security level: ID V¥ Log evants

After inserting the pot, add appropriate text with the
Insert»Text/plate/inset... command. Then lasso the text and knob and
group them with the Arrange»Group command. You can now move the
entire group of objects as a single item.
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7 Lookout - tutorial lkp - [Control Panel]

File Edit Insett Ohject Arrange Change Options  Alarms  Window  Help 18] =l
44 »r))@ el
=
20:50 14:20:45 14:21:00 14:21:15 14

Hand| Auto|

[ [ | 0:0alarms

Now create a Neutralzone object. Call it PumpAuto.

Revise Neutralzone | ]
Tag: IPumpAuto
Signal = ISimuIationLeveI

High limit= |48

Low limit= [40

Ok I Cancel

The next step is to create an Expression object. Call it PumpRun.
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Create expression [ ]

Tag: IPumpRun

IHOA =1 0R (HOA = 3 and Pump.Auto. below)

—Signals:
FurmpAuta.below \LI

Tags: Data members:

ahove Cancel |

SirmulationLewvel

MNeutralzone logical

Notice the logic of the expression. If the HOA switch = 1 you are in the
Hand position and want the pump to run, OR if the HOA switch = 3 you
are in the Auto position AND you need to determine if the Neutralzone is
calling for the pump to run (below specifies the signal is below the low limit
and you need the pump to start). If the HOA switch = 2, you are in the Off
position and the result of the expression is false.

Select the OK button and Lookout presents the Insert Expression dialog
box. Be sure to pick PumpRun if it is not already in the window and
select OK.
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Insert expression [ ]

—Signals:

Faste | FumpPFun

Tags: Data members:

$Alarm
$keyboard
$Systarm
HOA
Fanel
FurnpAuto

SirmulationLewvel
TankTrend

(expression) logical

oK I Cancel

The result of PumpRun is a logical signal. Because of this you can choose
two graphic files to be displayed—one for the “on” signal and one for the
“off” signal. Click on the Custom selection and scroll through the On list
box until you find the PMP1_RD.wmf file. Then scroll through the Off list
box and select PMP1_GRN.WME. After you choose the appropriate files,

select OK.
Display logical signal | ]

oK I Cancel
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As before, the example uses two windows metafiles that can be resized by
dragging a sizing handle. Resize and position the pump as shown in the
following illustration.

7 Lookout - tutorial lkp - [Control Panel]

File Edit Options Alarms Window Bun  Help 18] =l
444 ) Ll
|
|
| |
| lie E
— Loiford 3R ...

o

—

143500 143510 143520 1435530 143540 143550

[10/2414:35 | (nobody) [ Mational Instruments Internal Lse Only | 0:0alarms

Before you leave Edit Mode and test your system, add one final item to see
a digital reading of the water level in the tank. You could insert a new
expression and choose digital as the display style; however, use a Lookout
shortcut instead.

Click on the tank—the phrase tanks\tankl-a.wmf appears in the status
bar. This tells you what you selected. Because you have stacked the graphic
on top of the bar graph you must click one more time to select the next item
down in the stack. The status bar should now read SimulationLevel. You
can now quickly copy and modify the expression display parameters. Hold
the <Shift> key down while dragging the bar graph (this type action is
called shift-drag). This makes a copy of the bar graph. See Mouse Shortcuts
in Chapter 3, Getting Started, for instructions on using the mouse. Now
select and position the cursor over the new bar graph. Click the right mouse
button to modify the display properties.

Complete the dialog box as follows and select OK.
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Revise numeric signal display K|
Text Calor Bock ey - N

. .. . ackground style— —Frame stle——
EEEEEEEEN EEEN (- b,
Background color e ite
|:| . . ¢ Rectangle & MNane
........ .  Transparent

- © Left & Centarad ¢ Right [ Display Stis—
Minimurn ID

bawimum 100

MNumetric farmat

IGeneraI j

 Bar (up)
= Bar (down)
= Bar (right)
= Bar (leff)

Fant... |

oK I Cancel

Now resize the digital display and position it over the tank.

£” Lookout - tutorial lkp - [Control Panel]
File Edit Insett Ohject Arrange Change Options  Alarms  Window Help
(LYY 2
=3
Hand|
14:40:20 14:40:30 14:40:40 14:40:50 14:41:00 14:41:10
| s78.88 | 33xe3 |

SimulationLewvel

| 0:0alarms

Lookout Reference Manual

Toggle out of edit mode so you can test your system. Turn the HOA switch
to the Auto position and run the slider up and down to see if the Neutralzone
is working correctly. Then turn the HOA switch to the Off and Hand
positions to complete your testing. The pump should change colors

according to your logic.
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Now return to edit mode and dress up the screen with plates, scales, text,

and so on.

First select Insert»Text/plate/inset... and choose Plate as the background
style. Do not enter any text in the window. Select OK. This is an extremely
easy and useful technique for quickly creating different color plates and
insets. Spend a little time experimenting with different combinations of

plates, insets, and background colors.

Insert text/platefinset

Text |1 Minute Trend Charﬂ

Text calor

Background color

LN H
ENENEEE

 Justify left & Justify centered

Background style Frame style
&+ Flate  Black
 Inset  White
 Rectangle & Mone

& Transparent

 Justify right

1 Minute Trend Chart|

Font... |1DptAriaIEloId

Cancel |

After inserting the plate, move it to the top left corner of the control panel
and drag the sizing handle to stretch the plate. Then move the plate behind
everything else with the Arrange»Move to Back command. You can then
resume the positioning and sizing of the plate or other objects.

© National Instruments Corporation 5-17
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7 Lookout - tutorial lkp - [Control Panel]
Eile Edit Insert Object Arrange Change Options  Alarms  Window  Help 18] =l

1 Minute Trend Chart|

R o 2

4650 144700 144710 144720 144730 144740 14

off

[ | 0:0alarms

Continue adding plates, insets and text and in a few minutes your screen
should look something like the example. You may need to reposition or
resize several existing objects.

Change the vertical slider to a horizontal slider and reposition it. Select the
slider with the left mouse button and then click the right mouse button to
revise its display parameters. See Mouse Shortcuts in 3, Getting Started,
for mouse operation instructions.

Revise: SimulationLevel | ]

o= 0 [

() K] (2] (4

hatizontal slider

Cancel |

After moving the slider to the bottom of the control panel, add scales—one
for the slider and one for the trend.
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complete the dialog box accordingly.

Insert scale B
Orientation
hinimum: |1
10 10
010 i . I
j Eo L hendmum: 1]
kajor unit: |1D
D% ED B R inar unit: [25
10 10 w0 inar unit: .
haottorn, increasing right ¥ tdinor tick marks

IV Lahels

Lakel font...

10 pt Arial Bold

Cancel |

Lakel format:

IGeneraI

After positioning the scale next to the trend, shift-drag the scale to create a

copy. Then click the right mouse button to modify the second scale for your
horizontal slider.

¢ Lookout- samplel.lkp - [Overview]
EHB Edit [nset Object Arange Change Options  Alarms Window  Help == x|
1 Minute Trend Chart
S ] 031306 120832 § o
7 -
] S S S s Y I
e F N R ¥ T O LU LA A A A
INLEATN iy hYs o LI P 00O AN D Y an
i v YOI WL E Y
Y i il
I
30
20
10
120810 120820 120830 120840 120550 120900 120210 120820 12093 C
Off
m !
T T T T [ T T T [ T T T [ T T
0 10 20 30 40 50 Hand Auto
[ | | [ 1:1alarms
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Again toggle out of Edit mode and test the system by moving the slider and
knob.

Of course you do not have to go through the preliminary steps of creating
simulation signals on future projects. However, many times it is a good idea
to test your logic before connecting the real thing.

Connect the PLC and RTU

Lookout Reference Manual

Start the steps necessary to connect your PLC and RTU to Lookout. Begin
by configuring your communication ports. Select the Options»Serial
Ports... command from the menu. Configure COM1 for hardwired serial
connection to your local PLC and select Accept. Then select COM2 from
the Serial Port list box and pick Radio (RTS/CTS). You use this port to
talk to the remote RTU at the elevated tank. Select Accept again and you
are finished—now select Quit.

Serial Port Settings | ]
Serial port: Receive gap: |5
—Serial connection bytes

& Harchwired
EE delsy et ID
= Dial-up Y
¢ Radio (RT5/CTS) A E tifme aut: I'IDD
MEEEs

= DiE et
Dieling|arefi [sTxamvEDT

Eefries:

|3
Yy aitfar CErhE EE: IBD SEEEHES
Eause hetweeh calls: |2 SEEHHS

Defaults | Accept I Cluit |

Now connect a Modbus protocol controller to your process. First you must
create a Modbus object with Object»Create....
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Create Modbus Secondary | ]

Tag: ILD cal_PLC

& todbus Serial

Chapter 5 Developer Tour

Mo

dbus Plus Netwark

—Communication Settings

Address: |1 Serial port:

—Data rate Farity Data bits Stop hits ﬂl
115200 & Mone 7 (O Difaults |
 B7EOD  Ood L] 15
¢ 38400  Even e pr— |
18200  hark
&+ 9E00  Space Al EEe

priatity: IB
4800
2400 Fhone number: I
1200
© 500 PalRate =  [0:01
300 — I
110 o
Fetry attermpts: |4 Feceive timeout: 500
MEECs

This is the local PLC located in the plant that controls the operation of the
pump. Remember, you are hardwired to this PLC using COMI.

The next step is to connect the neutralzone signal to a coil on the PLC. This
signal turns the pump on and off. Select Object»Edit Connections... from
the menu and pick Local_ PLcC.

First, enter 100 in the Select member data field. Then click on the Select
button. This tells Lookout that you are going to connect a signal to coil 100
on a Modbus device named Local_PLC. Now type in PumpAuto.below
in the top expression window, and select the Accept button. You just
connected an expression to coil 100 and a message appears confirming this.

© MNational Instruments Corporation
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Local_PLC connections ]
Local_PLC.100 = IPumpAuto.beIow
Existing logical connection Connection accepted

o ememeer Accept | Clear | Cluit |

100

—Signals:

Existing connections: Tags: MNeutralzone

100

PollRate

Writable members: Feadable members: logical

abowve

400001.1-465000.16

400001465000

40001.1-49999.16

40001-49499 x|

Select Select object... | Paste | P

umpduto.below

You now need to create another Modbus obje

ct for the remote RTU. Each

controller has its own respective object in Lookout. Each of these objects
determines its polling scheme, read/write blocking, and so on.

Create Modbus Secondary | ]
Tag: IRethe_RTU & hodbus Serial " Modhbus Plus Metwaork
—Communication Settings

Address: |1 Serial port:

—Data rate Farity Data bits Stop hits ﬂl
115200 & Mone 7 (O Difaults |
 B7EOD  Ood L] 15
38400  Even 2 Abvanced.. |
18200  hark
&+ 9E00  Space Al EEe

priatity: IB
4800
2400 Fhone number: I
1200
© 500 PalRate =  [0:01
300 — I
110 o
Fetry attermpts: |4 Feceive timeout: 500
MEECs
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Because you are communicating through a remote radio to the RTU, you
must select a serial port configured for radio communications. In this case,
it’'s COM2.

All you have left to do is replace the signal in the neutralzone object from
SimulationLevel (the slider) to the analog input coming from the RTU
at the elevated tank. Select Object»Modify... from the menu and pick
PumpAuto.

Enter Remote_RTU. 40001 to read the TankLevel coming from the
controller as a 16-bit integer value.

Tag: IPumpT
Signal = [Remote_RTU 40001]
High limit= |48
Low limit= [40
Ok | Cancel

You now have a full-blown working process file. Although you are
performing the relatively simple task of turning a pump on and off based
on a tank level, you learned many of the basic principles behind the
object-oriented structure of Lookout. You also covered several shortcuts
for copying and modifying graphics and expressions.

5 Note It is important to remember that Lookout remains on-line—polling PLCs and
RTUs, logging data, alarming, executing control logic, and so on—even when you
are in edit mode. You never have to shut down your physical system to modify your
Lookout application—this includes adding or deleting physical 1/0, PLCs, RTUs,
loop controllers, and so on.
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Conclusion

There are only a few basic principles to learn if you want to master
Lookout—the most important being the concept of an object. Once you
realize what objects are, how they behave, and how to use their data
members, you should be able to quickly learn Lookout and begin building
your application.

You do not need to memorize every object class in Lookout, but you should
scan their definitions and data members to familiarize yourself with their
functionality.

To review, an object bundles functionality with an integrated database. An
object has parameters that define how it works. You define these parameters
when you create or modify the object.

In the predefined object database, the data members can be numeric,
logical, or textual. Data members can generate signals (that is, they are
readable), receive signals (that is, they are writable), or both.

As a final analogy, think of the many object classes in Lookout as a
comprehensive set of tools. Each object is designed to solve a particular
problem. However, you must open the toolbox (documentation) to learn
what is available, in order to become an efficient developer.
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Chapters 6 through 17 describe the features and services of Lookout in
detail. These chapters will familiarize you with the details of how to do
many of special things you may need to do with Lookout.

e Chapter 6, Serial Communications, describes serial communications,
namely COMSUB, and details how to define settings for three
different serial connections: hardwired, radio (RTS/CTS), and dial-up.

*  Chapter 7, Expressions, explains the features and uses of Lookout
expressions, which are flexible, real-time math statements.

*  Chapter 8, Graphics, describes adding static and dynamic graphics
to a control panel and creating and using custom graphics.

e Chapter 9, Alarms, describes generated alarms and configuration
services provided by the Lookout alarm subsystem. As a Lookout
environment service, the alarm subsystem filters, displays, logs,
and prints alarms.

*  Chapter 10, Security, describes Lookout accounts and the environment
service security subsystem, which oversees process file security,
control security, viewing security, and action verification. With this
system, you selectively determine which operators control particular
objects, which operators view particular control panels, and which
objects prompt the operator for command verification.

e Chapter 11, Logging Data and Events, describes three Lookout
methods for logging real-time system data to disk—Spreadsheet
Logger, Citadel Threaded Database Logger, and Event Logger—and
report generation.

e Chapter 12, Structured Query Language, describes Structured Query
Language (SQL), Open Database Connectivity (ODBC), and
accessing Citadel data using both SQL and ODBC.
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Chapter 13, Dynamic Data Exchange, explains how to use Dynamic
Data Exchange (DDE) with Lookout. DDE is the Microsoft
message-based protocol used by applications like Microsoft Excel
and Lookout to link to data in other applications.

Chapter 14, Networking, explains how to use Lookout to monitor and
control your process from any workstation (node) on the network.

Chapter 15, Redundancy, describes how to configure two process
control computers for redundancy, providing automatic transfer of
control should the primary computer fail.

Chapter 16, Runtime Menu Commands, describes Lookout menu bar
pull-down commands available in Normal mode (that is, not Edit)
mode.

Chapter 17, Edit Mode Menu Commands, describes Lookout menu bar
pull-down commands available in Edit mode. You use Edit mode to
perform all system configuration and editing.
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Serial Communications

This chapter describes serial communications, and details how to define
settings for three different serial connections: hardwired, radio (RTS/CTS),
and dial-up.

Introduction to Driver Objects

Certain object classes represent and communicate with external physical
devices such as PLCs, RTUs, and controllers. A few examples include
Modbus, Tiway, AB_PLCS5, and Optomux. We use the generic term driver
to refer to these types of object classes. The functionality built into driver
objects enables them to communicate with the physical devices that they
represent. Lookout communicates with the outside world primarily through
driver objects.

In traditional systems, drivers are separate applications running
independently of the operator interface. Driver programs compete for CPU
time with applications such as database managers, MMIs, and historical
data loggers, necessitating multitasking and increased CPU power. In
contrast, Lookout drivers are not separate applications. Lookout driver
objects work as any other object in the Lookout event-driven environment,
except that they communicate with external devices.

With traditional systems, you assign a particular driver to a specific serial
port. In such configurations, multiple drivers cannot share a single serial
port. Lookout does not associate baud rate, data bits, parity, or stop bits
with a particular serial port. In this way, drivers that implement different
protocols and baud rates can use the same port and the same modem or
radio frequency.

This capability allows you to mix and match RTUs, PLCs, and other
devices over a single radio frequency without communication conflicts

or special hardware. For example, you can use a single two-way radio
connected to a serial port to communicate with several different brands
of RTUs out in the field, each one using a different protocol. You can have
seventy-five remote PLCs share a set of five dial-up modems.
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All this is possible because of the Lookout communication service. Objects
use the communications service, an environment service, to gain access to
serial ports in an orderly and timely fashion.

% Note Some Lookout driver objects communicate with physical devices through
dedicated hardware. These driver objects do not use serial ports but instead rely
on their own proprietary network cards for interfacing to the outside world. A
few examples include Modbus Plus (SA85 card), Data Highway (KT card), and
DeltaTau (PMAC card). You do not need to configure serial ports for these objects
classes. Refer to the appropriate object class documentation in Chapter 18, Object
Class Reference, to verify if a particular object class uses a serial port.

Understanding the Communications Service

The Lookout serial communication service, allocates serial port usage
between driver objects. At the frequency of the object Poll Rate, a driver
object notifies the communications service that it needs to use a specific
serial port to poll a device. If the requested serial port is not in use, Lookout
allocates the serial port to the driver object. When the driver object takes
control of the serial port, it defines port communication parameters such as
baud rate and protocol and polls its device. When polling is complete, the
driver object releases the port so the communications service can allocate
it to other driver objects.

You can uniquely configure each serial port for hardwired, radio, or dial-up
communications through the Serial Port Settings dialog box. Refer to the
Defining Serial Port Settings section for more detailed information.

Note You must define serial port communication settings on every type of Lookout
product, including Development/Runtime, Runtime-Only, and Express systems.

Lookout Reference Manual
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Defining Serial Port Settings

This section walks you through the steps to configure serial port settings for
hardwired, radio, and dial-up communications.

1. From the Lookout menu bar, select Options»Serial Ports... The
Serial Port Settings dialog box (Figure 6-1) appears.

Serial Port Settings | ]
Serial port: ICOM1 'l Feceive gap: |3

—Serial connection bytes
-~ .
Hardired BiSidely e 1

Rdio (RTS/CTS) | CTStmeout  [100

[MEEES

—Dial-up settings

Dialing prefic [aTxamvEDT

Retries: |3—

‘Wait for connection: IBU— seconds
Pause between calls: |2— seconds

Defaults | Accept I Cluit |

Figure 6-1. Serial Port Settings Dialog Box

2. In the Serial port data field, select the communication port you are
defining. In this example, cCOM1.

3. Define the serial port parameters for the appropriate communication
port. Refer to the remaining sections in this chapter for complete
descriptions of the parameters.

Click on Accept to save the parameter changes for the serial port.

Click on Quit to exit the dialog box.

Selecting the Serial Port

The Serial port data field is a drop-down list box. Use it to select the
communication port you are defining. Microsoft Windows supports up to
nine serial ports; however, most computers support only two serial ports
without additional hardware.
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Setting Receive Gap

The Receive gap setting is available for all serial connection types.

This number specifies the number of empty bytes (or amount of time) a
driver receives from a controller before the driver recognizes the end of a
message frame and asks for another message. Normally you should leave
this at the default setting of 5. However, if you are experiencing garbled
communication alarms, you might try increasing this number to allow more
dead time before Lookout decides it has received a complete message. For
example, with a slow baud rate of 1200, you might have to increase the
Receive gap setting to approximately 30.

Selecting the Serial Connection

Lookout Reference Manual

Hardwired Settings

Hardwired serial connections require no hardware handshaking for line
control. Use this setting for all serial communication types except dial-up
telephone and remote radio transceivers. You should also use this setting
when directly connecting Lookout to the Master Repeater on a radio system
or through a leased-line modem. Because a Master Repeater is a full duplex
device that does not require keying and unkeying of the frequencys, it acts
much like a physically hardwired network. Other hardwired connection
types include RS-232, RS-422, RS-485, and leased telephone lines.

RTS/CTS Handshaking Settings

RTS/CTS is a local hardware handshaking mechanism between the local
computer and the local communication device. Use the Radio (RTS/CTS)
serial connection when connecting the serial port to a device that requires
RTS/CTS hardware handshaking, such as a radio transceiver that must be
keyed up during data transmission and unkeyed during data reception.
Other half-duplex communication media such as RS-485 may require
RTS/CTS hardware handshaking. Although the RTS/CTS scheme works
identically for other RTS/CTS communication schemes, assume that you
are communicating via radio for this discussion.

When you select RTS/CTS hardware handshaking, Lookout controls the
RTS, or request-to-send pin, and monitors the CTS, or clear-to-send pin,
during data transmission (pins 4 and 5 on a 25-pin RS-232 connector).
Therefore, you must have at least the RTS pin (pin 4) wired straight
through on your RS-232 cable. The CTS pin (pin 5) is optional.
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Lookout initiates a serial transmission on an RTS/CTS port by first
asserting RTS to key the radio. Lookout then begins monitoring the state
of the CTS pin. When the radio transmitter is fully keyed and ready to
transmit, the radio asserts CTS and Lookout immediately begins data
transmission. If the radio does not assert CTS within the CTS timeout
setting (default is 100 msecs), Lookout assumes the radio is ready to
transmit and transmits anyway.

The CTS timeout setting is the maximum amount of time that Lookout
waits after asserting RTS for CTS before transmitting. Most radios
typically take between 10 and 80 milliseconds to key up. Consult your radio
specifications and DIP switch settings to determine the key-up delay on
your radio.

If your radio can assert CTS when it is ready to transmit, add about

50 milliseconds to the radio key-up delay specification and use this total
value for the CTS timeout. If your radio does not assert CTS, you should
begin by adding about 20 milliseconds to your radio keyup time. Then
increase this value in 10 millisecond increments until the remote radio
begins to correctly receive the first bytes of the message.

Some radios may assert CTS before they are actually ready to transmit. In
this case, disconnect the CTS line (pin 5 on a 25-pin RS232 connector) and
set the CTS timeout to a value high enough to let the radio fully key before
transmission.

After it transmits the last byte of data, Lookout continues to assert RTS,
keeping the radio keyed until the RTS delay off time period expires. You
should set this value to the default of zero milliseconds so that Lookout
unkeys the radio as soon as possible to prepare to receive the response.

When unkeyed, most radios generate an audible squelch tail that the remote
device might decode as unexpected garbage bytes. Some remote devices
reject the entire message instead of just decoding the valid data and
ignoring the extra garbage bytes. In this case, keep the radio keyed for
several milliseconds using the RTS delay off setting. This time period
delays the squelch tail long enough for the remote device to recognize the
last data frame as valid before receiving garbage bytes caused by the
squelch tail.

If you set the RTS delay off setting too high, the remote device begins
transmitting its response before the local radio is unkeyed, causing a
communication alarm in Lookout.
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Dial-Up Modem Settings

Use the Dial-up serial connection when you use a modem in conjunction
with a switched telephone line (not leased line). You can customize the
dial-up settings for your particular modem and phone line.

The default Dialing prefix settings are based on the Hayes Corporation
AT command set, which is an industry standard for data modems. The
following table explains the Lookout default settings. For additional
commands, refer to your modem operation manual.

Table 6-1. Dialing Prefix

AT Attention code that must precede all commands

D Dial phone number with these modifiers: P for pulse; T for tone

En Local echo mode: E for no echo

Mn Speaker on or off: M for speaker always off

vn Verbal or numeric result codes: v for numeric result codes

Xn Result code and dialing options: x4 waits for dial tone before
dialing, and recognizes busy signal

When you use an external dial-up modem with Lookout, the DTR line in
your cable between the modem and the computer must be wired straight
through. This line is pin 20 on a 25-pin RS-232 connector and pin 4 on a
9-pin connector. Lookout uses the DTR line to command the modem to
disconnect (hang up) and return to the command mode.

Some factory modems are not configured to respond to the DTR line. After
Lookout first successfully dials out to a remote modem and finishes the
polling cycle, it drops the DTR line but the modem remains connected. If
the modem does not respond after several seconds of Lookout attempting
to raise and drop the DTR line, Lookout generates an alarm stating that the
modem is not responding. If you receive this alarm message, your modem
is not configured to monitor the DTR line.

The Hayes Corporation standard command for configuring the modem to
hang up and enter command mode upon loss of DTR is &D2. You can use
a terminal program to make this setting permanent on most modems by
entering the modem command AT&D2&W to store the setting permanently
in nonvolatile modem memory. Or you can just add &D2 into the Dialing
prefix. The default Dialing prefix is ATX4MVEDT, so you might change it
to AT&D2X4MVEDT.
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Retries specifies the number of times Lookout dials the specified phone
number and attempts to connect to the modem at the other end of the line.
If Lookout fails to connect after the specified Retries, it generates an alarm
and moves on to the next phone number in the polling queue (if a queue
has formed).

Wait for connection specifies the length of time Lookout waits to receive
a connect signal back from the modem it is calling. The time period begins
when Lookout first sends the local modem the dialing prefix command. The
time should be long enough for the local modem to receive a dial tone, dial
the phone number, allow the remote modem to pick up the line, and send
back a connect message. If the specified time is too short, your system
could be operating correctly but never make a connection.

Pause between calls is the length of time Lookout waits after hanging
up before it sends the local modem the next dialing prefix signal. If the
specified time is too brief, your system may not hang up the existing call
but still instead attempt to call the next number.

Note Your specific modems, radios, and local phone lines may operate faster or slower
than the default settings. You may need to use a trial-and-error approach to find
the best settings for your system.
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Expressions

This chapter explains the features and uses of Lookout expressions, which
are flexible, real-time math statements.

To work effectively in Lookout, you must understand Lookout expressions.
They resemble spreadsheet-style formulas with a mixture of constants and
variable signals from objects. They can be short and simple, or extremely
complicated with several signal inputs, function calls, and multiple levels
of parentheses. Lookout provides an extensive library of built-in functions
that includes logical, mathematical, statistical, text, trigonometric, and
time functions.

A single expression may incorporate any number of numeric, logical, and
text signals within its calculation. However, the result of the expression can
be only one of three types: numeric, logical, or text. If you attempt to create
an illegal expression, such as adding a logical value to a numeric value,
Lookout beeps and displays an error message. The outermost function or
operator in the expression returns a variable type that determines the overall
signal type of the expression.

Simple expressions consist of single value. Simple expressions do not
contain any modification, manipulation, math, or logic (for example, a
single object tagname like Pot 1). When you add any functionality to a
simple expression, you create a complex expression (for example,
Potl > 33).

The following examples are typical expressions. Depending on your system
requirements, your expressions might be much more involved.

True

Always returns the value true (on).

Potl

Returns the current value of Potl.

879.03
Always returns the value 879.03.
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1:04:33

Returns the value 0.0448264. If formatted in hours, minutes, and
seconds, it is displayed as 1:04:33.

Pressure * 2.31

Multiplies Pressure by 2.31.

(Switch1 or Switch2) and TankLevel > 65.2

If Switchl or Switch?2 is true, and TankLevel is greater than 65.2,
return true. Otherwise, return false.

Pressure >= Setpoint and !ReliefValve and TimeOccuring > 0:30

If Pressure is greater than or equal to Setpoint, and ReliefValve is false,
and TimeOccuring is greater than 30 seconds, return true. Otherwise,
return false.

nif(PLC1.AutoPos, AutoTemp, nif(PLC1.ManPos, ManualTemp,0))

If the alias member AutoPos of PLC1 is true, return the value of
AutoTemp. If the alias member ManPos of PLCI is true, return the
value of ManualTemp. Otherwise, return the value 0.

tif(HOA=1,“Hand” tif(HOA=2,“Off”,*Auto”))

If the HOA switch is at position 1, return Hand. If the HOA switch is
at position 2, return Of £. Otherwise, return Auto.

You can accomplish much the same thing with the following t choose
expression as you can with the previous tif expression

tchoose(HOA," "hand"'," Off"","' Auto'")

If the HOA switch is at position 1, return Hand. If the HOA switch is
at position 2, return Of £. If the HOA switch is at position 3, return
Auto.

Make sure that your expressions do not attempt to calculate illegal
operations, such as dividing by zero or finding the arc cosine of a number
greater than 1. If a signal can assume a value causing Lookout to attempt
an illegal mathematical operation, you should specifically test for that
condition in the expression. Expressions trap illegal mathematical
operations and generate alarms in the Math alarm group. The alarms do not
reset until you correct the expression. The following list includes some of
the illegal conditions that Lookout traps:

e attempting to divide by zero

e taking the square root of a negative number
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e numeric underflow

e numeric overflow

Note If any value referenced in an expression changes when an even occurs, the
expression automatically recalculates. This is the same event-driven concept that
objects implement.

Creating Expressions

Because Lookout uses expressions in many places, you can create
expressions as independent objects, parameters in objects, connections to
object data members, or you can insert expressions on control panels.

Through dialog boxes, you create expressions during application
development. There are two types of data entry fields in Lookout dialog
boxes—white and yellow. White data entry fields accept only constant
values, and yellow data entry fields accept expressions.

Note In dialog boxes, all yellow data entry fields accept expressions.

Expressions on Control Panels

With the Insert»Expression... command, you graphically display the
result of an expression on a control panel. However, this method does not
create an object; therefore, it does not create an output signal that other
expressions or objects can use. (There is no tag associated with

the expression.)

With the shift-drag and shift-right-click mouse actions, you can modify
expressions on control panels and their graphical display. See
Configuration Shortcuts in Chapter 3, Getting Started, for specific
instructions.

Every result type (logical, numeric, or text) has a corresponding display
dialog box, as shown in Figure 7-1, Figure 7-2, and Figure 7-3. See
Chapter 8, Graphics, for more information on displaying graphics.
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nsert expression

Display logical signal

[switch

Signals:

Paste | Switchl

Data mermbers

Switch

Iogical
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(€ Custom

Cancal
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Figure 7-1. Example of logical Expression and Corresponding Display Dialog Box
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Figure 7-2. Example of numeric Expression and Corresponding Display Dialog Box

Insert expression

[itSwich "Lookout’ National nstruments")

Signals:

National_Instruments

Data mermbers

text

Cancal

TextEntry

Display text signal

[x]
Text calor ek d syl = "

. o oEEE e — -RmmeD
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lgllll=== =I= © Trensperent
© Justity left & Justify centered © Justity right

oK
National Instruments|
Cancel

Fort. 10 pt Arial Bold

Figure 7-3. Example of text Expression and Corresponding Display Dialog Box

Expression Objects

With the Object»Create... menu command, you can create an Expression
object. Like other object classes, the global (expression) object class

requires a unique tagname.

Other expressions and/or objects can reference the output of an
(expression) object. When you need to define a unique condition that your
application uses multiple times, use an (expression) object. Instead of
defining the same expression in many places, you can create it one time
and use its tagname wherever the condition applies. For example, the
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expression tag A11vValvesOpen in the following Create expression
dialog box is easier to reference than the long expression.

Tag: IAIIVaIvesOpen

IVaIve1 and Yale? and Yale3 and Vahed

—Signals:

Paste | $Alarm.active \LI

Tags: Data members:
Cancel |

$keyboard Citadel active
$Systarm Citadel unackead
Expl DDE.active
Mational_Instruments DOE . unacked
Panell Disk.active
Fotl x| |Disk.unacked x|
(class) numeric

Expressions as Parameters

Many object classes accept expressions as parameters. When they do, the
parameter expects the expression to return a certain signal type—numeric,
logical, or text. Refer to the specific object class definition in Chapter 18,
Object Class Reference, to verify the type of each parameter.

With the following dialog box, we can create a DelayOn object.

Create DelayOn timer: | ]

Ta: ITimer1

On/off signal = IVaIVe1 and Yalve?

Timer delay = IAIarmOnDeIay

Display format: IMM:SS j

Ok I Cancel |

The parameter On/off signal expects a logical expression and Timer delay
requires a numeric expression. Both valvel and valve?2 are tagnames for
switches. Connecting them with and produces a logical result and satisfies
the type condition of the first parameter. AlarmOnDelay is the tagname of
a potentiometer used to adjust the timer delay setpoint, which creates a
numeric signal, satisfying the type condition of the second parameter.
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Because the Timer delay parameter is an expression, we have many
configuration possibilities, including the following:

*  Enter a constant. In this case, the delay never changes.

e Enter the name of an output signal from another object such as a Pot.
In this case, the operator adjusts.

*  Enter a complex expression that automatically calculates the delay
based on multiple inputs.

Similar configuration solutions exist for the On/off signal parameter.

When an expression parameter fields is yellow, you can get help building
your expressions. For example, assume that you cannot remember whether
the valve tagname in the previous example was Valvel, Valve_1, or
ValveOne. If you position the cursor over the yellow expression field and
right-click, the Expression Editor dialog box appears. Using this dialog
box, you can select the proper tagname (Valvel) and paste it directly into
the expression field. Click on OK and Lookout writes the expression into
the targeted parameter field.

Expressions as Connections

Lookout Reference Manual

You can connect object data members with expressions. Writable data
members accept expressions as inputs, much like parameters. To connect
an expression to a data member, use the Object»Edit Connections...
menu command. See Chapter 5, Developer Tour, for detailed information
on connecting expressions to data members.
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Modbus1 connections | ]
Modhbus1.1 = IVaIve1 orYahe?]

Mew logical connection

—Selectmember:

1

Accept | Clear | Cluit |

—Signals:
Existing connections: Tags: Switch
FollRate TexasPh =]

YalveCount ]
YalveTimer =l
Writable members: Feadable members: logical

100001-065000 -

400001.1-465000.16
400001465000

40001.1-49999.16

40001-49499 x|

Select I Select object... | Faste | Wakel

Figure 7-4. Edit Connections Dialog Box
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Expression Dialog Box

When you right-click on a yellow parameter field, select the
Insert»Expression.... menu command, <Shift> right-click on an existing
expression that appears as a graphic on a control panel, the expression
dialog box appears.

Insert expression | ]
[Madbus1 400001]
—Signals:
Faste | Modbus1.400001

Tags: Data members:

LovisianaFh =] |ooo0o1-085000 -

LouisianaFil 100001-165000

MaintenuPanel 10001-19999

MainkdenuPh 1 |1-993g

MixerCount 300001-365000

MixerDump 30001-39999

MixerDumpPulse 400001.1-465000.16

Modbust IR 00001465000

DilFlowSwitch 40001.1-49999.16

DilRig1Fulse 40001-499349

DilRig2Pulse x| |BadCRC x|

Modhbus numeric

oK | Cancel |
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Figure 7-5. Insert Expression Dialog Box

There are three fields in the Insert expression dialog box in Figure 7-5.
You can enter your expression in the top yellow field. The lower left field
lists all object Tags that generate readable signals. The lower right field is
a list of the readable Data members for the currently selected object.
Notice that the dialog box indicates the object class selected in the Tags list
(Modbus) and the signal type selected in the Data members list (numeric).

You can enter an expression directly or use the Paste button to select and
insert tagnames in the expression field. As you select different tags from the
list box, the name to the right of the Paste button changes accordingly.

Some objects have multiple readable data members, such as a Modbus

object. Lookout concatenates the tagname, followed by a period and the
selected data member.

7-8 © National Instruments Corporation



Chapter 7 Expressions

Once you combine the desired tagname and data member, click on the
Paste button. Lookout pastes the tagname into the expression field.
Clicking on the Paste button a second time copies another instance of
the tagname to the expression window—this time at the cursor.

5 Note Instead of selecting a tagname and then clicking on the Paste button, double-click
on the tagname. Lookout instantly pastes the tagname to the expression window
Jfor you. Many other dialog boxes use the same methodology.

Obviously, you can manually type or modify a tagname, a data member, or
a mathematical function in the expression field at any time. Because you
might have many hard-to-remember, defined objects, the Tags list box
serves as a quick reference for all of your previously defined objects.

Expression Syntax

In an expression, operators are instructions to perform an operation on a
value or to combine values to form a new value. For example, a simple
operator is the / symbol. It divides one value by another; the formula (5 / 2)
reads five divided by two and produces a result of 2.5. The five and two in
the preceding example are operands (the / operator requires numeric
operands).

White Space

You can use tabs and spaces between operators, functions, and function
parameters in Lookout to make expressions easier to read. In this manual,
we use spaces between operators for added clarity.

We call spaces and tabs white space characters because they provide space
between parameters. We maintain this practice for the same reasons that
we use space between words and paragraphs in a book—to achieve greater
organization and clarity. Because Lookout ignores white space characters,
you can use white space characters to separate object names in an
expression. However, you cannot embed white space characters within tags
or alias names.
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Arithmetic Operators

The following operators perform basic arithmetic operations. They require
numeric operands and produce numeric results.

Table 7-1. Arithmetic Operators

+ Addition

- Subtraction

* Multiplication

/ Division

g Percentage (divides preceding value by 100)

~ Exponentiation

- Negation (additive inverse of the following value)

Text Operator

The text operator is the ampersand character (&). An ampersand joins two
text strings. For instance, the expression “Call me“ & “Ishmael”
produces a text signal of Call me Ishmael. Typical uses for the text
operator include

e imbedding a numeric value within a text string
e using it in an action verification expression
e using it in an alarm message

* sending out to a remote PLC display panel

The expression “Flow rate is” & TEXT (Flow, “0.00”)& “gpm”
produces a text signal of Flow rate is 141.23 gpm, assuming Flow is
a numeric signal whose value rounds to 141.23.
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Comparison Operators

Comparison operators compare two numeric values and produce a logical
result of either TRUE or FALSE (on or off).

Table 7-2. Comparison Operators

< Is less than

> Is greater than

<= Is less than or equal to
>= Is greater than or equal to
= Is equal to
<> Is not equal to

When setting up process control strategies, you often want to compare
two numeric values. You can use the result of the following expression to
control a tank fill valve: TankLevel<50 is TRUE while TankLevel is less
than 50 and FALSE while TankLevel is greater than or equal to 50.

Tag: IExp1

ITankIeveI <50

—Signals:
Paste | Tanklevel \LI

Tags: Data members:

SludgePmp? - Cancel |

Temperature

TestSeplPanel

TestSeplPh

TestSep1Phi ot
TestSepzPanel x|

Fot numeric

You can then connect this logical result to a PLC or RTU to control the fill
valve. The valve opens when the tank level drops below 50 and closes when
the tank level rises above 50. Notice, however, that this method can cause
the valve to fluctuate between open and closed too often if the tank level
hovers around 50.
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Neutralzone is an object class with built-in dead band and is more
appropriate for controlling the tank fill valve. The following example is
a better usage of the comparison operator:

Tan: IW
Signal = ITankIeveI
High limit= [0
Low limit= [45
Ok I Cancel |

Avoid using the is equal to(=) and is not equal to (<>) comparison
operators to compare an analog value from a PLC or the result of
mathematical calculations in an expression. Because numeric (floating
point) values have about 17 significant digits, TankLevel = 40 might
never be exactly true. If you know the signals are integer values, such as the
numeric signal from the potentiometer in the following example, use the
= and <> operators.

Tag: IHOA

Minimurm: |1
Maximurn: |3 |

Cancel
Eesolution: 1|

—Position source

& Local
- Remote

EasiticEn = I

' DDE

EEfIEE I
i I
[teri I

Contral security level: ID V¥ Log evants

Notice from the following Create expression dialog box we are creating a
three position switch with the Pot object class, where 1=Hand, 2=0Off, and
3=Auto.
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Now we can create an expression object that turns the pump on in two
conditions: if the HOA switch is in the Hand position or if the switch is in
the Auto position and the TankLevel is less than 40.

Create expression [ ]

Tag: IPumpRun

IHOA =1 or (HOA = 3 and Tanklewvel < 40)

—Signals:

Data members:
Cancel

Paste | $Alarm.active \LI

Chemical.active
Chemical.unacked
Citadel.active
Citadel.unacked

cormrm.active

comrm.unacked x|

(class) numeric

Notice that the HOA signal is exactly 1.00, 2.00, or 3.00.

Expression Functions

There are over fifty built-in expression functions, generally classified as
follows:

* logical functions

*  lookup functions

*  mathematical functions
*  statistical functions

* text functions

e trigonometric functions

e date/time functions

The remainder of this chapter describes each function, specifies the syntax,
and provides an example on how to use each.
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Logical Functions

AND Syntax logicall AND logical2 AND logical3...
Example Switchl AND Potl > 50.0
Description If Switch1 is on and Pot1 is greater than 50.0, return TRUE,

otherwise return FALSE. Returns TRUE if all logical
parameters are TRUE.

FALSE Syntax FALSE
Example False
Description Returns the logical value FALSE. Accepts no parameters.
LIF Syntax LIF (logical, logical resultl, logical result2)
Example LIF (Switchl, False, Potl > 50.0)
Description If logical is TRUE, return logical resultl, otherwise return

logical result2. In the example, if Switch1 is on, it outputs the
logical value FALSE. Otherwise, it returns the logical result of

Pot1 > 50.0.
NIF Syntax NIF (logical, numeric resultl, numeric result2)
Example NIF (Switchl, 99.9, Potl)
Description If logical is TRUE, return numeric resultl, otherwise return

numeric result2. In the example, if Switch1 is on, it outputs the
numeric value 99.9. Otherwise it outputs the value of Potl.

NOT Syntax NOT (logical) or !logical

Examples NOT (Switchl) or !Switchl

Description If logical is TRUE, return FALSE, else return TRUE. In the
example, if Switchl is on, return FALSE, but if Switchl1 is off,

return TRUE.
OR Syntax Jogicall OR logical2 OR logical3...
Example Switchl OR Potl > 50.0
Description Returns TRUE if at least one logical parameter is TRUE. In the

example, if either Switchl is on or Potl is greater than 50, or
both, the expression returns TRUE. If neither condition is true,
it returns FALSE.
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TIF Syntax TIF (logical, text resultl, text result2)
Example TIF (Switchl, “Text Message”, TextInputl)
Description If logical is TRUE, return text resultl, otherwise return text
result2. Notice the use of quotation marks. In the example, if
Switchl is on, it outputs Text Message; otherwise, it outputs
the current text value of TextInputl.
TRUE Syntax TRUE
Example TRUE
Description Returns the logical value TRUE. Accepts no parameters.
XOR Syntax logicall XOR logical2Z XOR logical3...
Example Switchl XOR Potl > 50.0
Description Returns TRUE if only one logical parameter is TRUE. In the

example, If Pot1 is greater than 50 and Switchl is on, it outputs
FALSE because both logical parameters are TRUE. If Potl is
less than 50 and Switchl is on, it outputs TRUE because only
one logical parameter is TRUE.
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Lookup Functions

LCHOOSE Syntax

LCHOOSE (numeric, logicall, logical2z,
logical3,...)

Example

LCHOOSE (Potl, Switchl, TRUE, Pbl)

Description

Returns the 1ogical parameter corresponding to the integer
portion of the numeric parameter. If the numeric parameter
is less than 2.0, LCHOOSE returns logicall. If the numeric
parameter is greater than the number of logical parameters,
LCHOOSE returns the last 1ogical parameter listed. In the
example, if the value of Pot 1 is .5, 1, or 1.4, it returns the value
of Switchl.If Pot1is 2.0 or 2.8, LCHOOSE returns the logical
value TRUE. If Pot 1 is 3.0 or higher, LCHOOSE returns the value
of Pbl.

NCHOOSE Syntax

NCHOOSE (numeric, numericl, numeric2,
numeric3,...)

Example

NCHOOSE (Potl, Pot2, Pot3, 14.3)

Description

Returns the numericx parameter corresponding to the integer
portion of the numeric parameter. If the numeric parameter
is less than 2.0, NCHOOSE returns numericl. If the numeric

parameter is greater than the number of numericx parameters,
NCHOOSE returns the last numericx parameter listed. See the
description of the LCHOOSE example.

TCHOOSE Syntax

TCHOOSE (numeric, textl, text2, text3,...)

Example

TCHOOSE (Potl, “Auto”, “Manual”, “Local”,
“Locked”)

Description

Returns the text parameter corresponding to the integer
portion of the numeric parameter. If the numeric parameter
is less than 2.0, TCHOOSE returns text1. If the numeric
parameter is greater than the number of text parameters,
TCHOOSE returns the last logical parameter listed. See the
description of the LCHOOSE example.
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Mathematical Functions

ABS Syntax ABS (numeric)
Example ABS (Potl - 50.0)
Description Returns the absolute value of numeric. In the example, if Pot1

is zero, the function returns 50.0.

EXP Syntax EXP (numeric)
Example EXP (Pot1l)
Description Returns the base of the natural logarithm, e (2.71828182),

raised to the power of numeric. In the example, if Potl is 2.0,
the function returns 2.718281822 or approximately 7.38906.
EXP is the inverse of the function, LN. To calculate the values
of other powers, use the exponentiation operator ().

FACT Syntax FACT (numeric)
Example FACT (4.2)
Description Returns the factorial of the integer portion of numeric. In the

example, the function returns the factorial of 4, or 1*2%3*4, or
24. The factorial of zero, FACT(0), or any number less than
zero is one (1).

INT Syntax INT (numeric)
Example INT (4.2)
Description Rounds numeric down to the nearest integer. In the example,
the INT function returns 4. Notice also that INT (-8.5) = -9.
See also TRUNC.
LN Syntax LN (numeric)
Example LN (PLC.AIl)
Description Returns the natural logarithm of numeric. In the example, if

PLC.AIl = 1000.0, the function returns 6.90776.

LOG Syntax LOG (numericl, numericZ2)
Example LOG (Pot1,2)
Description Returns the logarithm of numericl to the numeric2 base, where

numericl is a positive real number. In the example, if Potl =
8.0, the function returns 3.0.
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LOG10 Syntax LOG10 (numeric)
Example LOG10 (Pot1l)
Description Returns the base-10 logarithm of numeric, where numeric is a
positive real number. In the example, if Potl = 100.0, the
function returns 2.0.
MOD Syntax MOD (numericl, numeric?2)
Example MOD (50, 8)
Description Returns the modulus (remainder) of numericl divided by
numeric2, where numeric2 is not equal to zero. In the example,
50 divided by 8 equals 6 with a remainder of 2. Therefore, the
function returns 2.
PI Syntax PI()
Example PI()
Description Returns an approximation of PI: 3.1415927. Accepts no
parameters.
PRODUCT Syntax PRODUCT (numericl, numeric2, numeric3,...)
Example PRODUCT (2, 4, 6,10)
Description Returns the product of all the numerics. In the example, the
function returns 2*4*6*10 or 480.
RAND Syntax RAND ()
Example RAND () * Potl
Description Generates a new random number between zero and one every
time the formula that this function is a part of is recalculated.
Accepts no parameters. In the example, every time the value of
Potl1 changes, the function generates a new random number
and multiplies it by the value of Potl.
ROUND Syntax ROUND (numericl, numeric?2)
Example ROUND (Pot1, 2)
Description Rounds the value of numericl to numeric2 decimal places. In

the example, if Potl equals 15.745, the function returns 15.75.
If numeric2 equals zero, the function returns an integer. If
numeric2 is less than zero, the function returns zero.
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SIGN Syntax SIGN (numeric)
Example SIGN (Potl)
Description Returns 1 if numeric is positive, 0 if numeric is 0, —1 if numeric
is negative. In the example, if Pot1 is —0.00001, the function
returns —1.
SQRT Syntax SORT (numeric)
Example SORT (ABS (Pot1l))
Description Returns the square root of numeric, where numeric is a positive

real number. In the example, if Potl is —25.0, the absolute
function first converts the pot value to positive 25 and the
square root function calculates J25 =5.

TRUNC Syntax TRUNC (numeric)
Example TRUNC (8.9)
Description Truncates numeric to its integer component by removing its

fractional part. In the example, the TRUNC function returns 8.
Notice also that

TRUNC (-8.9) = -8. See also INT.
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Statistical Functions

AVG Syntax AVG (numericl, numeric2, numeric3,...)
Example AVG(2,4,-6,12)
Description Returns the arithmetic mean (average) of all the numerics

listed. This function requires at least two numeric parameters.
In the example, the function returns (2+4—-6+12) /4 or 3.0.

MAX Syntax MAX (numericl, numericZ2, numeric3,...)
Example MAX (2,4,-6,12)
Description Returns the highest value of all the numeric values listed. This

function requires at least two numeric values. In the example,
the function returns 12.

MIN Syntax MIN (numericl, numeric2, numeric3,...)
Example MIN(2,4,-6,12)
Description Returns the lowest value of all the numeric values listed. This

function requires at least two numeric values. In the example,
the function returns —6.

STDEV Syntax STDEV (numericl, numeric2, numeric3,...)
Example STDEV (2.9,4.5,5.0,4.3,3.8)
Description Returns the sample standard deviation of the numeric values

listed. (Standard deviation is a measure of dispersion,
calculated as the positive square root of the variance.) This
function calculates the standard deviation using the non-biased
or n—1 method. This function requires at least two numeric
values. In the example, the function returns 0.796869.

STDEVP Syntax STDEVP (numericl, numeric2, numeric3,...)
Example STDEVP (2.9,4.5,5.0,4.3,3.8)
Description Returns the standard deviation of a full population of numeric

values. This function calculates the standard deviation using
the biased or n method. This function requires at least two
numeric values. In the example, the function returns 0.712741.
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SUM Syntax SUM (numericl, numeric2, numeric3,...)
Example SUM(2,4,-6,12)
Description Returns the sum of all the numeric values listed. This function
requires at least two numeric values. In the example, the
function returns 12.
VAR Syntax VAR (numericl, numeric2, numeric3,...)
Example VAR(2.9,4.5,5.0,4.3,3.8)
Description Returns the sample variance of the numeric values listed.
(Variance is a measure of dispersion.) This function calculates
the variance using the non-biased or n—1 method. This function
requires at least two numeric values. In the example, the
function returns 0.635.
VARP Syntax VARP (numericl, numeric2, numeric3,...)
Example VARP (2.9,4.5,5.0,4.3,3.8)
Description Returns the population variance of the numeric values listed.
This function calculates the variance using the biased or n
method. This function requires at least two numeric values. In
the example, the function returns 0.508.
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Text Functions

EXACT

Syntax

EXACT (textl, text2)

Example

EXACT (TextEntryl, “batch a”)

Description

Returns TRUE if fext] exactly matches fext2, otherwise returns
FALSE. This function is case sensitive. In the example, the
function returns TRUE if the text result of TextEntry1 exactly
matches batch a (note that the entry in this example is all
lowercase).

FIND

Syntax

FIND (textl, text2, numeric)

Example

FIND (“ON”,”Reactor A is ON”,1)

Description

Searches for text! within fext2 starting after numeric
characters, and returns the position of the first character where
the match begins. This function is case sensitive. The output of
this function is numeric. It returns 0 if no match is found. In the
example, the function searches the entire string for the word,
ON and returns 14, indicating the position of the first character
of the word. Refer also to the SEARCH function.

FIXED

Syntax

FIXED (numericl, numericZ2)

Example

“The flow is” & FIXED (Potl, 2)

Description

Rounds the value of numericl to numeric2 decimal places and
then converts numericl to a text string. In the example, if the
value of Potl equals 123 . 456, the FIXED function returns the
text value 123. 46. Thus, the entire text string would read The
flow is 123.46. If numeric2 is negative or omitted,
numericl is rounded to the nearest whole number. For example,
FIXED (123.588) returns 124. See also TEXT.

LEFT

Syntax

LEFT (text, numeric)

Example

LEFT (“Reactor A is ON”,9)

Description

Retrieves the specified number of characters from the lefthand
end of fext and outputs it as a text value. In the example, the
function returns Reactor A.
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LEN Syntax LEN (text)

Example LEN (“Reactor A is ON”)

Description Returns the length of the text string (the number of characters
in text). In the example, the function returns the numeric
value 15.

LOWER Syntax LOWER (text)

Example EXACT (LOWER (TextEntryl), “batch a”)

Description Converts text to all lower case. In the example, the LOWER
function ensures that a match is found whether TextEntry1
content reads Batch A, BATCH A, or batch A.

MID Syntax MID (text, numericl, numeric?2)

Example MID (“Reactor A is ON”,9,7)

Description Retrieves numeric2 characters from zext, beginning at character
numericl. In the example, the function returns the text value A
is ON.

PROPER Syntax PROPER (text)

Example PROPER (“reactor A is ON”)

Description Capitalizes the first character of each word in text. In the
example, the function returns the text value Reactor A
Is On.

REPLACE Syntax REPLACE (textl, numericl, numeric2, text2)

Example REPLACE (“Reactor A is ON”,9,1,“B”)

Description Replaces numeric2 characters with fext2 beginning with
character numericl in textl. This function requires that the
number of characters in fext2 matches the value of numeric2.
In the example, the function returns the text value Reactor B
is ON.

REPT Syntax REPT (text, numeric)
Example REPT (“Lookout”,Pot1)
Description Repeats text numeric times. In the example, if the value of Potl

is 8, the function returns the text value, Lookout Lookout
Lookout Lookout Lookout Lookout Lookout
Lookout.
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RIGHT Syntax RIGHT (text, numeric)
Example RIGHT (“Reactor A is ON”,7)
Description Retrieves the specified number of characters from the

righthand end of fext and outputs it as a text value. In the
example, the function returns the text value A is ON.

SEARCH Syntax SEARCH (textl, text2, numeric)
Example SEARCH (“on”, "Reactor A is ON”,1)
Description Finds fext] within text2 beginning at numeric character, and

returns the position of the first character where the match
begins. This function is not case sensitive. The output is
numeric. It returns O if no match is found. In the example, the
function searches the entire string for the word ON, on, On,
or oN and returns 14, indicating the position of the first
character of the word. Refer also to FIND.

TEXT Syntax TEXT (numeric, text)
Example TEXT (Pot1,™0.00")
Description Like FIXED, the TEXT function converts numeric to a textual

value. While FIXED allows you to specify the number of
decimal points, TEXT allows you specify a desired numeric
format in the text parameter. If Potl equals 12.3456, the
function would return the textual value 12.35. See Numeric
Formats in Chapter 5, Developer Tour. See also FIXED.

TRIM Syntax TRIM (text)
Example TRIM(“Reactor A is ON”)
Description Trims multiple spaces from between words. In the example,

there are multiple spaces on either side of the word, A. This
function returns Reactor A is ON, eliminating all repeated

spaces.
UPPER Syntax UPPER (text)
Example EXACT (UPPER (TextEntryl), “BATCH A")
Description Converts fext to all capital letters (upper case). In the example,

the UPPER function ensures that a match is found whether
TextEntryl content reads Batch A, BATCH A, or batch A.
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ACOS Syntax ACOS (numeric)

Example ACOS (Pot1l)

Description Returns the arccosine of numeric (that is, it returns the angle of
the cosine you specify as numeric). Numeric must range
between —1 and 1. The result is output in radians and ranges
from O to TT. In the example, if Potl = 0.5, the function returns
1.0472 radians (60 degrees). You can express the arccosine in
degrees by multiplying the result by 180/t

ASIN Syntax ASIN (numeric)

Example ASIN (Potl)

Description Returns the arcsine of numeric (that is, it returns the angle of
the sine you specify as numeric). Numeric is the sine of the
angle and must range between —1 and 1. The resulting value is
given in radians and ranges from —1v2 to 2. In the example, if
Potl = —1, the function returns —1.5708.

ATAN Syntax ATAN (numeric)

Example ATAN (Pot1)

Description Returns the arctangent of numeric (that is, it returns the angle
of the tangent that you specify as numeric). The resulting value
is given in radians and ranges from —Tv2 to TV2. In the example,
if Potl = 180, the function returns 1.56524 radians (about
90 degrees).

ATAN2 Syntax ATAN2 (numericX, numericy)
Example ATAN2 (5, 5)
Description Returns the arctangent of the specified x- and y-coordinates

(that is, it returns the angle of a line extending from the origin
(0,0) to a point specified by the numericX, numericY coordinate
pair that you specify). The resulting value is given in radians
and ranges from greater than —Ttto TU In the example, the
function returns 0.785398 radians (45 degrees).
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COS Syntax COS (numeric)
Example COS (Pot1)
Description Returns the cosine of numeric where numeric is the angle in

radians. In the example, if Potl = 1.047, the function returns
0.500171. You convert degrees to radians by multiplying

by 17180.
SIN Syntax SIN (numeric)
Example SIN (Potl)
Description Returns the sine of numeric where numeric is the angle in

radians. In the example, if Pot1l = 3.14159, the function returns
1.2246E-16 (effectively zero). You convert degrees to radians

by multiplying by 1/180.
TAN Syntax TAN (numeric)
Example TAN (Pot1*PI()/180)
Description Returns the tangent of numeric where numeric is the angle in

radians. In the example, the value of Potl is 45, but it is in
degrees, not radians. Convert it to radians by multiplying it by
17/180. In this example, the function returns 1.
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Date/Time Functions

NOW Syntax NOW (logical)
Example NOW (SKeyboard.F1)
Description Returns a numeric value representing the current system date

and time when any signal within the parentheses change. The
result is a floating point number in which the integer represents
the date and the fraction represents the time of day. In the

example, when you press the function key F1, the date and time
are output as a single number, like 34738.3. If you change the
Numeric Format of the number to mm/dd/yy hh:mm:ss, the
same number would be shown as 02/08/95 07:49:02.

TODAY Syntax TODAY (logical)
Example TODAY ($Keyboard.F1)
Description Returns a numeric value representing the current system date

when any signal within the parentheses change. The result is
an integer that represents the number of days that have passed
since Jan. 1, 1900. In the example, when you press the function
key F1, the date is output as a single number, such as 34738. If
you change the Numeric Format of the number to mm/dd/yy,
the same number would be shown as 02/08/95.

Note If you want to display the current time only, subtract the today function from
the now function.

Example: NOW ($Keyboard.F1) — TODAY ($Keyboard.F1)

In this example, if you want the result to update itself every second, replace
$Keyboard.F1 with a one second pulse timer.
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Graphics

This chapter describes adding static and dynamic graphics to a control
panel and creating and using custom graphics.

Any visible item on a Lookout control panel is a graphic. All graphics are
either static or dynamic. Static graphics never change state, but dynamic
graphics change state to represent process variations. Lookout provides
an extensive graphics library. These graphics range from switches,
potentiometers, and pushbuttons to bar graphs, valves, tanks, pumps,
plates, insets, scales, and more. However, there might be times when the
standard Lookout graphics do not exactly fit your needs. You can use the
third-party drawing package included with your copy of Lookout, or any
other drawing software, to create your own custom graphics.

Note Consider screen resolution when creating display panels (VGA vs. Super VGA).
The same panel appears differently on computers using different resolution
display drivers. Please read about screen resolutions in the description of Panel
objects in Chapter 18, Object Class Reference, before designing your panels.

Static Graphics

Static graphics never change state. They exist on a control panel much the
same way a picture hangs on your wall, never changing or moving. Static
graphics range from text labels, plates, insets, and scales to complex
schematic overviews and scanned photographic images.

Displaying Text, Plates, Insets, Rectangles, and Lines

Effective use of text, plates, and insets make control panels intuitive and
easy to use. The example below demonstrates how plates and insets
organize information about two pumps.
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- Raw Water Pumps

To create static text, plates, insets, rectangles or lines in Lookout, select the
Insert»Text/plate/inset... command. The following dialog box appears.

Insert text/platefinset ]

Text I

Text colar S oy F o
ackground style rame style

mEEREREER EEEE ST L

Background color P F:Zitangle & Norluj

.|=|=.=.== & Transparent

 Justify left & Justify centered  Justify right

Cancel |

JE|

Font... |1DptAriaIEloId

If you want to create a rectangle, line, plate or inset, leave the Text field
blank and choose a Background style. The preview window displays the
element as it appears on a control panel.
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To create a vertical or horizontal line, choose Rectangle. After clicking
on OK, size the rectangle to the desired width and length. If you need
the rectangle an exact size, remember to use the yellow status bar. It
indicates dimensions.

I+ Note Lookout uses color grids in many dialog boxes. The grids make selecting colors
quick and visually helpful. However, they might look slightly different from
computer to computer.

Some computer display adapters can display only 16 solid colors on the
screen. The standard VGA adapter in conjunction with the Windows VGA
driver supports only 16 colors directly. Windows uses a technique called
dithering to simulate the display of colors not directly supported as solid
colors. For example, Lookout may display orange as an alternating pixel
pattern of red and yellow bits on the screen.

Some objects in Lookout require solid colors, so if you specify a dithered
color, Lookout uses the nearest solid color instead. For example, a Trend
object requires a solid color for its background and solid colors for the trend
lines. Furthermore, Lookout always displays text in a solid color. If you
specify pastel green for a trend line color, you might get yellow instead. Bar
graphs and control panel backgrounds can display dithered colors.

Note Some display adapters support 256 or even 16 million colors on the screen at one
time. Even though Lookout allows you to specify only 28 colors, Lookout displays
custom graphic files on control panels using all available colors.

Displaying Static Custom Graphics

Lookout supports two graphical file types—Windows Device-Independent
Bitmap (.BMP) and Windows Metafile (. WMF).

To display static bitmap and metafile graphic files on a control panel, select
the Insert»Graphic... command. The Insert graphic dialog box appears.
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Select graphic
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From the Insert graphic dialog box, you can scroll through various
directories containing a variety of graphic files. The list box includes all
bitmaps and metafiles located in the GRAPHICS subdirectory under the
root LOOKOUT directory. As you select each category, you see thumbnail
sketches displayed in the preview window to the right of the list box.
Because graphics might stretch or shrink to fit in the preview window,
they might not appear exactly as they do on a control panel.
Note If you know the name of the file, type the first letter of the filename. The list box

automatically scrolls to the first file beginning with that letter.

Lookout Reference Manual

If you choose a bitmap (. BMP) file, you can use the Transparent pixel
data fields to specify which color pixels in that graphic you want to be
transparent in Lookout. Imagine the viewing area as an X-Y coordinate
plane with 0,0 being the top left corner of the graphic (not the entire
viewing area). You can enter any X and Y coordinates, and the
corresponding pixels become transparent, as do all other pixels that color.
The Transparent pixel fields do not have any default values. If you leave
the X and Y fields blank, no pixels become transparent.
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You can use a multicolor bitmap as a type of mask. For this to work, inside
of the bitmap (the gray area) must be transparent and the rest of the graphic
opaque—masking the underlying part of the control panel. You can insert
another Lookout element, such as a bar graph, to furnish a convenient
visual warning, such as a rising color level.

You could guess the X,Y coordinates of any grey pixel on the graphic. It
helps to know that the center of the graphic is -1,-1. Because -1,-1 is a
black pixel in this example, you would have to offset your choice to -1,0,
(for example). Because this is a gray pixel, all other gray pixels become
transparent when inserted on a control panel.

Note Windows metafiles are normally easier to use and manipulate than bitmap
images. Unlike bitmaps, metafiles can be resized in Lookout. Because of their
inherent structure, you can also use metafiles as masks without specifying
transparent pixels. Had the example above used a .WMF graphic, the area in
gray would have appeared in the Lookout window as a crosshatched area.
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Dynamic Graphics

Many process control panels require some type of animation, such as a
pump changing colors to represent on and off. Table 8-1 lists the Lookout
tools that make use of animation.

Table 8-1. Tools for Displaying Dynamic Graphics

Object Class

Description

Animator object
class

An Animator object provides full graphical animation including horizontal
and vertical motion, dynamic resizing and visibility, dynamic sequencing,
and color changing.

Multistate object
class

A Multistate object displays up to six different custom graphics based
on advanced if-then-else logic.

Pipe object class

A Pipe object makes a rectangle or line (of any dimension) change colors or
blink, based on advanced if-then-else logic.

DialGauge object
class

A DialGauge object displays a numeric signal as a sweeping needle on an
analog gauge or dial.

Gauge object class

A Gauge object makes a numeric expression (digital number or barchart)
change colors or blink based on advanced logic.

Spinner object
class

A Spinner object is a small rotating disk. It can be turned on and off with a
logical signal, and its rotation speed and direction are controlled by a
numeric value.

Switch object class

A Switch object can represent its two positions using standard switch
symbols or custom graphics.

Pushbutton object
class

A Pushbutton object looks like a button that changes when depressed, but
you can also make it transparent. You might use transparent pushbuttons over
custom graphics.

Pot object class

A Pot object can be displayed as a knob, vertical slider, horizontal slider,
increment and decrement buttons, or a digital number.

Logical expression

When you create an expression that results in a logical value, you can
represent that value using standard lights, text, or custom graphics.

Numeric
expression

When you create an expression that results in a numeric value, you can
represent that value using a digital number or a vertical or horizontal bar
chart.

Text expression

When you create an expression that results in a text value, you can represent
that value using any style and size font loaded on your computer.

Lookout Reference Manual
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For information on a specific object class, refer to Chapter 18, Object Class
Reference. For information on expressions, refer to Chapter 7, Expressions.

Displaying Dynamic Logical Signals

Logical expressions and Switch objects are two commonly used graphical
animation tools. You can display the signal a Switch object generates in a
variety of ways.

 Control Panel

Switch ON

 Control Panel

Switch OFF

The Switch is shown in both the On and Off positions. The graphics on the
right side of the control panel show three ways of graphically displaying the
logical signal generated by the Switch.

Notice the difference between the graphics representing the Switch object
and the graphics representing the Switch signal. The graphics representing
the Switch signal are expressions of the (implicit) value of the switch,
created through the Insert»Expression... menu command.

To create a Switch object, first choose the logical signal that you want to
represent with dynamic graphics (for example, a logical input from a PLC).
Then select an object to display the logical signal. For this example, use a
Switch to simulate a contact from a motor starter relay.

Create a Switch and call it PumpSwitch. After you define the Switch
parameters, Lookout presents the display parameters dialog box for the
Switch object. You can choose to represent PumpSwitch with one of the
standard graphics, or you can use custom graphics. For this example, select
a standard graphic and click on OK.
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Display switch: Switchl

& Standard
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" Custom

Cancel |

To insert an expression representing the signal generated by the Switch
object, use the Insert»Expression... command and select PumpSwitch.

Insert expression

| ]
IPumpSwitch|

—Signals:

Paste | PumpSwitch
Tags:

Data members:
$Alarm
$keyboard
$Systarm
Fanell

Switch logical

oK I Cancel

When you click on OK, Lookout presents the Display logical signal dialog
box. From the Display logical signal dialog box, select display
characteristics for a logical signal expression.
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Display logical signal
—{ Standard —————— N

\ \\._\
® © o x\\&\

On Off

—{* Custom

\\\\\\\\\\\\\\\\\\\\\

N
\
I
1

§\\\\\\\\\\\.{k\\\
— Text
On: I
ot |

oK I Cancel |

Click on the Custom selection, and then on the On and Off list boxes,
scrolling through the choices until you find the appropriate graphic. Your
On and Off graphic selections appear as thumbnail sketches in the two
preview windows to confirm and verify your selection.

Click on OK and test your example by flipping the switch. The graphics
should change according to your selections in the On and Off preview
windows. To customize your switch, experiment with the Text selection
in the Display logical signal dialog box.

Use this same basic method to display any dynamic signal on a control
panel. If you want to represent more than two conditions with dynamic
graphics, use a Multistate object. Similarly, you can use a Pipe object to
make a line or rectangle dynamically change colors and blink.

Displaying Dynamic Numeric Signals

This section shows how to use a Pot object to display dynamic numeric
signals. Figure 8-1 shows the Pot as a slider, a digital entry, and increment
and decrement buttons—all are graphical representations of the same Pot
object. The graphics to the right and below the control panel are two ways
of graphically displaying the numeric signal generated by the Pot.
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=] 467 (=

Figure 8-1. Pot Object as a Slider, a Digital Entry, and Increment and
Decrement Buttons

To use a Pot object to display a signal, first choose the numeric signal that
you want to represent with dynamic graphics, such as an analog input from
a PLC. Then select an object to graphically display the dynamic numeric
signal. For this example, create a Pot object and name it PumpSpeed. After
you define the Pot parameters, Lookout presents its display parameters
dialog box. In this example, the dialog box is named Insert: PumpSpeed.
You can choose to represent the Pot with any of the standard graphics.

Insert: Potl | ]

3]

wertical slider

Cancel |

Use the Insert»Expression... command and select PumpSpeed to insert an
expression that represents the signal generated by the Pot object.
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IPumpSpeed|

—Signals:

Tags:

Paste | PumpSpeed

$alarm
$keyboard
$Systarm
Fanell

Fot

Data members:

numeric

o]

Cancel

When you click on OK, Lookout presents the Display numeric signal
dialog box. From this dialog box, select the display characteristics for a

numeric signal expression.

If you choose Digital display style, you can use the Font button to select
the desired font style and size. You can also specify a Numeric format
for the value. For more information on numeric formats, see Chapter 5,

Developer Tour.

Display numeric signal | ]
Bar Color
. .. Background stle—— —Frame style——
........  Plate  Black
(o (o i
Background color Inset White
D. ..  Rectangle & Mone
........ & Transparent
- et o Eentered R [ Display Stis—
tinimum ID  Digital
aimum (100 & Bar (up)
= Bar (down)
MNumetric farmat = Bar (right)
IGeneraI = Bar (leff)
it |1DptAriaI Baold OK I Cancel

Click on OK and test your example by adjusting the pot. The graphics
should change according to your selections.
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If you want to represent the numeric signal with moving custom graphics,
use the Animator object class.

Displaying Dynamic Text Signals

You can display dynamic text messages on a control panel with text
expressions. You can easily display up to two separate text messages using
logical signals, but there are times when you need to display three or more
separate text messages in a single statement. If you do have more than two
separate messages, a numeric signal might determine which message

to display.

To graphically display a dynamic text signal, first choose the numeric
signal that you want to use to control which message is displayed, perhaps
an analog input from a PLC. Then select a graphical object to display that
signal. This example uses a Pot object.

Create a Pot object and call it Pot 1. Define the Pot minimum, maximum,
and resolution parameters as 1, 4, and 1 respectively. Select the
Insert»Expression... command and enter the expression from Figure 8-2.
See Chapter 7, Expressions, for information on the TCHOOSE function.

Insert expression [ ]

ITchoose (PhraseSelector, "Lookout Programmers", "are widely known", "to be", "Babe/HotGuy magnets"

—Signals:
Paste | FhraseSelector
Tags: Data members:
$alarm
$keyboard
$System

F

Fot numeric

oK I Cancel

Figure 8-2. Using Expressions To Display Dynamic Text Signals

When you click on OK, Lookout presents the Display text signal dialog
box. From this dialog box, select display characteristics for a text signal
expression. Use Inset as your background style.
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Text calor S oy F o
. .. . ackground style rarme style

&+ Flate  Black

EENEEEEEE EEEE vt

Background color
LN |
ENENEEE

 Justify left & Justify centered  Justify right

 Rectangle & Mone
& Transparent

Lookout Programmers|

Cancel |

Font... |1DptAriaIEloId

Click on OK and test your example by adjusting the pot. The text should
change according to your expression.

Creating Custom Graphics

There may be times when none of the Lookout standard graphics exactly
fit your needs. To meet those needs, National Instruments includes a
third-party drawing package with every copy of Lookout. You can use it,
or any other drawing software, to create your own custom graphics.
Lookout supports both Windows Device-Independent Bitmaps (. BMP)
and Windows Metafiles (. WMF).

After you create a custom graphic file, copy it to the GRAPHICS
subdirectories in your LOOKOUT root directory. Because Lookout can use
only graphics located in the GRAPHICS directory and subdirectories, keep
all standard and custom graphics in the GRAPHICS subdirectories. Lookout
can access your custom graphic file any number of times in the same or
different process files from the GRAPHICS subdirectories.

Step-by-Step Example: Creating Custom Graphics

This section contains an example demonstrating the creation of custom
graphics for use in Lookout. This example sketches out the creation of an
elevated tank graphic you can use to show water level in a real tank. You
export that tank graphic to Lookout, implement the display in Lookout, and
test it. The example may only parallel what you would have to do with your
own graphics creation program, but should serve as an illustration of the
important points.

© MNational Instruments Corporation 8-13 Lookout Reference Manual



Chapter 8

Lookout Reference Manual

Graphics

If you have not already mastered using a drawing program, you should
allow yourself time to become accustomed to using the third party software
included with your Lookout kit, or to using the drawing application of your
choice.

Creating the Graphic
1. Draw half of the tank.
2. Copy the tank half and mirror the image to create the other half.

3. Connect and refine the halves to create an enclosed tank object.

Ve

o

4. Refine your image until it looks the way you want
5. Draw arectangle around the tank and connect both the rectangle and
tank into a single object.

6. To match the background color of the mask to the control panel, select
the object group and click on the gray color bar selection.

7. Select invisible for the line style.
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Exporting the Graphic to Lookout

1.
2.

Export your new graphic as a Windows Metafile (.WMF).

Change the export directory to C: \LOOKOUT\GRAPHICS and name
your new graphic ELEVTANK . WMF.

Export.

Testing the Graphic in Lookout

1.

Eall

© MNational Instruments Corporation

Launch Lookout.
Create a Pot object using the Object»Create... command.
Select Insert»Expression..., choose the Pot object, and click on OK.

In the Display numeric signal dialog box, select Bar (up) for the
Display style, Rectangle for the Background Style, and click on OK.
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5. Use the Insert»Graphic... command to insert your new graphic,
ELEVTANK . WMF, over the bar graph.

6. Position the graphic over the bar graph and stretch it to size.

7. Toggle out of edit mode and test your example by moving the slider up
and down.
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Graphic File Types

Lookout accepts both Windows Device-Independent Bitmaps (. BMP) and
Windows Metafiles (. WMF).

Bitmaps

Bitmaps are raster files, made up of differently colored pixels. Because
each pixel in the bitmap takes up one pixel on the screen, bitmap images
are always rectangular and never resizable. You can display raster images
on control panels that are not rectangular in Lookout by using transparent
pixels for the parts of the rectangle you do not want to show.

Bitmap files typically have a . BMP file extension. The Paint program that
comes with Windows can read .PCX bitmap files (another very common
bitmap format) and convert those files to Windows bitmaps.

Metafiles

Metafiles are vector files, consisting of coordinates that are connected by
lines and curves, as well as area-fill commands. A vector file may consist
solely of two sets of coordinates connected by a line or a complex set of
colored area fills and colored lines and curves to create line art images.
Metafiles images are not necessarily rectangular.

Because metafiles contain a set of coordinates, they can be resized and
stretched to any size or aspect ratio. Microsoft does not add information
in the basic metafile file format for metafile size information. The Aldus
Corporation (authors of PageMaker) created a metafile header that contains
metafile size information. Most software packages that generate metafiles
also add this header information. Without the header, Lookout cannot
maintain the correct aspect ratio (width to height ratio) for a metafile. To
determine if a metafile has this information, resize the graphic on a control
panel while holding down <Ctrl>. If aspect information is available,
Lookout does not stretch the metafile drawing out of proportion.

Bitmaps or Metafiles?

Which format is better: bitmap or metafile? Both have strengths and
weaknesses. You may want to use a combination of metafiles and bitmaps.
Bitmaps effectively handle large background schematics or system
overviews, and metafiles work well for individual pumps, valves, lamps,
and other miscellaneous graphics.
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Bitmaps usually display faster than metafiles. In fact, a complex drawing
rendered as a bitmap may display 100 times faster than the corresponding
metafile. If you want to display scanned photographic quality images with
hundreds of colors, use bitmaps.

Metafiles are resizable—you can stretch them to any size or aspect ratio.
Metafiles are typically smaller than bitmap files, so they take up less disk
space and consume less memory than bitmap files. You can use one file that
contains a metafile drawing of a pump to display several pumps of various
sizes on the screen. With most drawing programs, you can save your line
art images as metafiles. You can also copy the image on screen to the
Windows clipboard and paste it into a paint program for bitmap conversion.

Memory Considerations

Lookout Reference Manual

Lookout loads each graphic into computer memory the first time it is
displayed. The image remains in memory until Lookout or another
application needs more memory than is available. When more memory is
needed, the graphic is discarded from memory and reloaded from disk the
next time it is displayed, so that you can display more bitmaps and
metafiles on the screen than can be held in memory at one time.

If you are running Windows in enhanced mode on a 386 or 486 computer,
you have virtual memory. Windows uses virtual memory to swap memory
images between RAM and disk, giving applications the appearance of more
memory. If available memory becomes low and Windows must use virtual
memory to handle applications and data between disk and memory, you
might notice a slower application speed. For more information on virtual
memory, refer to your Windows user guide. If your computer disk drive
light flashes every time you pull up a new control panel in Lookout,
consider purchasing more RAM.
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This chapter describes generated alarms and configuration services
provided by the Lookout alarm subsystem. Objects and database
parameters generate alarms in Lookout. As a Lookout environment
service, the alarm subsystem filters, displays, logs, and prints alarms.

Defining Alarm Conditions

You can create an alarm condition two ways. First, you can define alarm
parameters when modifying an object database (Database-Generated
Alarms). Second, you use Alarm objects to define alarm conditions
(Alarm Object method).

Database-Generated Alarms

Most objects contain numeric or logical data members. If they exceed
specified conditions, you want Lookout to generate an alarm. These
conditions can include High, Low, High-High, and Low-Low. Select
Object»Edit Database... to modify alarm parameters for an object data
member in its database dialog box (see Figure 9-1).

This method offers the most efficient way to define standard or simple
alarm conditions. Furthermore, this method is especially useful when
configuring alarms for data that originate from objects with large databases,
like driver objects and DataTable objects. See Editing Object Databases in
Chapter 4, Using Lookout, for more information.
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Figure 9-1. Creating Database-Generated Alarms

For dedicated Alarm objects, you define and create Alarm objects on an
individual basis with the Object»Create... command. You can create

alarms that are triggered by any event or combination of events you specify

in the Create Alarm dialog box using as simple or complex an alarm
criterion as needed. You do not have to use the traditional set of alarm

conditions (that is, High, Low, Rate-of-Change). See the Alarm section in

Chapter 18, Object Class Reference, for additional information.

Alarm objects are not the only source of alarm signals. Most object classes

generate their own alarm signals—driver, Spreadsheet, and Expression

objects can also generate alarms.

Several object classes generate circular reference alarms. A circular

reference alarm defines a condition where the signal generated by an object

is sent back to that object as a parameter, either directly or indirectly.
Circular references are always priority 10 alarms, and you should correct

them during process file testing.
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Figure 9-2. Creating an Alarm Object

The Alarm Subsystem

Alarm Groups

You use the alarm subsystem, which is comprised of several components,
to control how alarms are displayed, acknowledged, printed, grouped,
prioritized, and filtered. Before you implement a structure for your
alarming system, you should understand these various components.

For organizational purposes, you can classify alarms into groups. Alarm
groups allow operators to temporarily filter unwanted alarms and
acknowledge alarms on a group-by-group basis.

You can create any number of alarm groups and assign any number of
alarms to any group. However, you should carefully plan your alarming
structure so operators can filter alarms by meaningful groups. With a
carefully planned structure, you can handle specific groups and/or priorities
if your system experiences a large number of alarms. See the Alarm object
in Chapter 18, Object Class Reference, and Editing Object Databases in
Chapter 4, Using Lookout, for additional information.
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Alarm Priorities

Assign each alarm a priority level ranging from 1 to 10, where Priority 1
is the lowest priority alarm and Priority 10 is the highest priority alarm.

Priority 1 alarms do not require operator acknowledgment. When they are
deactivated, Priority 1 alarms are removed from the Alarms window by
Lookout, regardless of acknowledgment. Lookout does not permanently
log Priority 1 alarms to disk.

You should assign Priority 1 to only minor, inconsequential alarms. Often,
priority 1 alarms do not exist in control strategies. If an occurrence is
significant enough to be classified as an alarm condition, you should assign
a priority level that requires operator acknowledgment and permanent disk
file logging.

Priority 2 and higher alarms require operator acknowledgment before they
are removed from the alarm list. However, Lookout does not log Priority 2
alarms to disk. Assign a Priority 2 level or lower to alarms that do not need
to be permanently recorded.

Priority 3 and higher alarms require operator acknowledgment before
Lookout removes them from the alarm list. Lookout immediately stores
Priority 3 and higher alarms to disk in binary format when they are
activated, deactivated, and acknowledged.

The Data files location parameter in the System Options dialog box
specifies the root directory under which all data logging should begin.
Lookout stores alarm files in monthly subdirectories under this root
directory. See the Options»System command in Chapter 16, Runtime Menu
Commands, for more information. Priority level 3 through 10 alarms
function identically and are logged to the ALARMS . DAT file in the data
directory under the specified root directory for the current month.

Note The Lookout Express package does not log alarms to disk. Rather, you can
view alarms that are active—or inactive but not yet acknowledged—in the
Alarms window.

Lookout Reference Manual
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Alarms Window

The Alarms window lists all active and unacknowledged alarms. Alarms
are listed in chronological order with the most recent alarm at the top of the
list. If there are too many alarms to see at once, you can use the scroll bar
at the right of the Alarms window to scroll through the list.

To view the Alarms window, press <Ctrl-A>, select Alarms»Show or click
on the alarm indicator box on the far right side of the Lookout Status bar at
the bottom of the screen (see Figure 9-3).

7 Lookout - svgaeval lkp - [Water Plant Overview]
Eile Edit Options  Alarms  Window Bun  Help 18] =l

High Service
Pumps

Water Plant Overview

Clear Well

um
|Clariﬁer #1
Elevated

Turbid 1.9 nty ¢ Tank

.M : Flow 627 gpr
[[Pumps ] a1

Turbid 2.1 nty

Flow 376 gpm

Turbid 1.7 ntu ¢

Flow 0 gpm —

2 Pump 1

= xPumpZ

To siudge
o ponds

Click on the pumps
or select the push-
button to adjust.

[12/0812:21 | (nobody) [ Mational Instruments Internal Lse Only [ o J alarms

Click here to call Alarm Window /

Figure 9-3. Activating the Alarms Window from the Status Bar
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To quickly identify alarm statuses, use the Lookout Alarms window color
scheme, as defined in Table 9-1.

Table 9-1. Alarm Colors

Color Alarm Status

Red Active

Blue Unacknowledged, Inactive

Red and Black | Acknowledged, Active
(Alarm information, including time, group, priority,
and tag, appears in black and the description in red).

When you acknowledge an inactive alarm or an acknowledged alarm
deactivates, Lookout removes the alarm from the Alarms window. Because
anew line is added to the list every time the alarm activates, Lookout might
list the same alarm condition multiple times in the Alarms window. After
listing 100 instances of the same alarm, Lookout swaps the oldest alarm
condition for each new occurrence. Therefore, it displays the most recent
100 occurrences of each individual alarm in the Alarms window. Other
alarms continue to accumulate as expected until they reach their individual
limits of 100 occurrences.

To view detailed information about a particular alarm, select the alarm in
the Alarms window and use the Alarms»Acknowledge... command.
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Alarm Display Options

With the Alarms»Display Options... command, you can change the
display style of the Alarms window (Top, Bottom, Floating, or Minimized)
and modify internal Alarms window display formats such as font, header,
and other alarm information.

—Window style Show:
 Top V¥ Header
 Bottom vV Group
e i IV Priority

¥ Tag

—Window height ———

|3 lines (2-20) ’—I
oK
Fant... | Cancel |

10 pt Arial Bold

The Window style determines the position of the Alarms window in the
Lookout workspace. If you select Floating, the Alarms window appears as
a popup style control panel that you can resize and move on the screen. You
can minimize a floating Alarms window at any time.

If you use either the Top or Bottom window type, the Window height
specifies the number of alarms Lookout can display in the Alarms window.
The actual height of the Alarms window adjusts automatically depending
on the selected font and Window height setting. You can resize a floating
Alarms window at any time with the sizing border. If more alarms occur
than can be displayed in the Alarms window at once, a scroll bar appears
along the right side of the window.

Figure 9-4 is an example of an Alarms window with Window style set to
Bottom, all Show options selected, and Window height set to 3.

Alarms [_] Ix]
i aroup P Tag N escription |

Figure 9-4. Example Alarms Window
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Alarm Filters

Lookout Reference Manual

Use the Alarms»Filter Options... command to filter the alarms by group,
priority, and occurrence through the Alarm Filters dialog box.

Alarm Filters | ]

—Display alarms

Al occurrences
& host racent occurances At or abowve priority

|5 (1-10

Include old alarms:

|1 ] (0-500)
Display All |

— Display Groups

I~ All groups

7 groups selected
¥ Audible alarms Catiee! |

Figure 9-5. Alarm Filters Dialog Box

Most Recent Occurrences removes multiple occurrences of an alarm and
displays only the latest occurrence. This feature is useful when an alarmed
event continuously reoccurs and generates multiple alarm instances. All
Occurrences displays every instance of a particular alarm (up to 100
occurrences of the same alarm).

With the Display Alarms at or above Priority setting, you display alarms
with the specified alarm priority setting or higher and exclude all lower
priority alarms.

With the Display Groups selections, you specify the alarm groups you
want to display in the Alarms window and Lookout excludes all others.
Select the groups you want to see or check the All Groups box to display
every alarm group. You must deselect the All Groups box before you can
choose individual Display Groups.

You can toggle the Audible Alarms option on and off. When enabled, new
alarm occurrences beep on your computer speaker. After the first six beeps,
the beeping frequency reduces to once every ten seconds and continues at
that frequency until the alarm is acknowledged. Lookout continues to beep
until you acknowledge every alarm. To quickly silence the beeping without
acknowledging the alarm, press <Ctrl-S>.
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The configuration shown in Figure 9-5, instructs Lookout to display the
most recent alarm occurrence in the Conveyors, Pipeline, and Plant groups
with a priority of 6 or higher. There might be active alarms occurring in
other groups or in the selected groups with lower level priorities. There
might be multiple occurrences of the same alarm, but these alarms are not
displayed in the Alarms window because of the filter settings.

If you filter some alarms, an operator might not realize that an alarm is
occurring because it is not displayed in the Alarms window. To determine
how many alarms are filtered out, use the information from the right corner
of the Status Bar, which displays the number of visible alarms out of the
total number of alarms (visible:total). The difference between the two
values is the number of filtered alarms. In Figure 9-6, there are 15 visible
alarms, 25 total alarms, and 10 filtered alarms.

. 15: 25 alarms

Figure 9-6. Determining the Number of Filtered Alarms from the Status Bar

To see all alarms, click on the Display All button in the Alarm Filters
dialog box and then click on OK. The Alarms window displays all active
and unacknowledged alarms. The status bar reflects the change.

|| 25 25 alarms
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Alarm Print
1% Note
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Because it does not log alarms to disk, the Lookout Express package does not
allow printing of logged alarms.

The Alarms»Print... command invokes a dialog box that you use to
specify the time period of the alarms to print.

Print Alarms | ]

HF LaserJet 4/4k Flus on HF on

—Printrange—————— -

© Today
© Yesterday Cancel
 Pravious 24 hours )
: — Printouts

 This week
 Lastweek C Snapshat Only
" This manth & Snapshot & Journal
 Lastmonth
@ T

Tk — Columns:
# Range:

Fram: [3/9/97 2:30 @
¥ Frioti
To: 710797 17:50 v

mm/dedfyy hhimm /Ri=g

Font... | 10 pt Courier Bald

In the example above, the Range option specifies an arbitrary time span. By
entering the exact dates and times (in military style), you can print all of the
alarms logged during the specified time period. When you click on Print,
Lookout opens the appropriate alarm file(s), formats the report according
to the Columns settings, and sends the output to the Windows print
manager (which sends the report to your printer).

The Printouts selections determine the exact alarm information included
in the report. Snapshot Only provides a picture of the alarm statuses at the
beginning of the specified print range but does not indicate what happened
during the time span. Snapshot & Journal creates a printout of everything
that occurred during the time span from the beginning of the range.

9-10 © National Instruments Corporation



Chapter 9 Alarms

Alarm Acknowledgment

Before you can acknowledge an alarm, you must select it. To select an
alarm, click on the alarm line in the Alarms window. A check mark appears
in the far left column indicating that the alarm is selected. To deselect an
alarm, click on the alarm line again and the check mark disappears. You
can select and deselect any combination of alarms in this manner.

Use the Alarms»Select All command to select all alarms for
acknowledgment. Because selecting each alarm individually can be very
time consuming, this command is especially useful if your process is
experiencing a high number of alarms.

Use the Alarms»Deselect All command to deselect all alarms that were
previously selected for acknowledgment. If you want to deselect only
specific alarms, click on the individual alarms you want deselected.

The Alarms»Acknowledge... command acknowledges alarms that you
have selected for acknowledgment. If you have not selected alarms when
you invoke this command, the following message box appears:

= Acknowledge Alarms

® No alarms selected for acknowledgement

If you select one or more alarms for acknowledgment, a dialog box
similar to Figure 9-7 appears to provide additional information about the
alarm(s). Through this dialog box, you can acknowledge alarms on an
individual basis (by clicking on Acknowledge) or on a global basis

(by clicking on Acknowledge All). When you acknowledge an inactive
alarm or when an acknowledged, active alarm deactivates, Lookout
removes it from the Alarms window.
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Acknowledge Alarms: (nobody) | ]
Tag: FPLC 2 Group:  comm Friority: 8
Description

Mo communication response from Modbus secondary[00]

Set: 12/0512:32:58
Feset: (still active)

Duration:  (still active)

EreyiEus | Acknowledge |

[l et | Acknowledge All |

Figure 9-7. Acknowledging Alarms

The Acknowledge All button acknowledges all selected alarms—not all
alarms. With the Previous and Next buttons, you can tab through all the
alarms selected for acknowledgment. When you acknowledge an alarm,
Lookout logs to disk the date, time, and account name of the operator that
acknowledged it. Click on the Quit button to close the dialog box.

A special global object, $Alarm, acknowledges alarms with pushbuttons or
other logical expressions. This allows you to bypass the menu commands
or acknowledge alarms from remote Lookout network nodes. For instance,
you could create a single pushbutton that acknowledges all alarms, or you
could create multiple pushbuttons for acknowledging specific groups of
alarms.

With the $Alarm object, you can access numeric signals that indicate the
number of currently active alarms or the number of unacknowledged
alarms in a particular group. See $Alarm in Chapter 18, Object Class
Reference, for more information.
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This chapter describes Lookout accounts and the environment service
security subsystem, which oversees process file security, control security,
viewing security, and action verification. With this system, you selectively
determine which operators control particular objects, which operators view
particular control panels, and which objects prompt the operator for
command verification.

Lookout requires operators to log on with a predefined name and
corresponding password (if any). To log on, use the File»Log on...
command, press <Ctrl-L>, or click on the Account name box in the status
bar. Collectively, the name and password are known as an account. Each
account has a security level. Because Lookout uses account names when
logging events to disk and when operators acknowledge alarms, you can
identify the operator logged on when an event occurs.

You can access the name and security level of the currently logged Lookout
user through the $System object, using the username and seclevel data
members.

Note The Lookout Express system does not log events to disk.

The Lookout virtual keyboard that you can use with a touch sensitive screen
or a mouse is subject to the same security options.

To enable the Virtual Keyboard, select Options»System... and then check
Left Mouse Click or Right Mouse Click in the Virtual Keyboard Pops
Up section of the dialog box.

When this feature is enabled, clicking in a data entry field or touching the
field on a touch sensitive screen displays the Virtual Keyboard. The Virtual
Keyboard is subject to the same security constraints as other input methods.

Accounts

Using the Options»Accounts... menu command, anyone with a security
level of 10 can create, revise, or delete system user accounts through the
Account Maintenance dialog box (see Figure 10-1).
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0 Note

You should carefully consider users and the security level you assign each. Assign

only those people responsible for system security level 10 access. Users with
security levels of 8 and higher can close process files, exit Lookout, and, in
development versions of Lookout, edit process files.

Lookout Reference Manual

Account Maintenance

aitchrmark

2 accounts listed
aitchmark's account

Fewvise..

Delete...

Create...

du

Dane

Security level: 10

Last login: 11/03/97 11:06
Idle time: 45 minutes
Logins: 1

Fassword : Yes
Fassword age: 45 days

Figure 10-1. Create, Revise, or Delete System User Accounts in the
Account Maintenance Dialog Box

To delete an account, select the account name and click on the Delete...
button. To revise an account, select the account name and click on the
Revise... button. To create an account, click on the Create... button.
Whether creating or revising an account, you access the following

dialog box.

Create Account | ]

Your password:

—

—Account settings

Account name:

INewbie

Confirm password: IW
Security level |5

Idle time : |45 minutes

MNew password:

Ok I Cancel |
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Your password—Enter your password. Lookout requires it before you can
add or revise an account.

Account name, New password and Confirm password—Use any
combination of alphanumeric characters. Security Level ranges from
1 to 10.

Idle time—The amount of time the computer sits idle (no mouse
movement or keyboard action) before Lookout automatically logs off the
operator. If you enter 0 (zero), idle time is disabled. For security reasons,
you might want to use this feature to automatically log off high level
accounts if the computer is left unattended too long. After an account logs
off, the account (nobody) is logged on.

As with any other account, you can modify the (nobody) account security
level. You can set up (nobody) with a security level of 10. If you do set the
security level to 10, realize that a low level operator can log off, let
(nobody) log on with a security level of 10, and access all Lookout
commands. National Instruments recommends that you create your
security level 10 accounts and change the (nobody) account to security
level 0, which is the only account name that supports security level 0.

Note If you are the only account with level 10 security and you forget your password,
there is no way to access the System»Accounts... command, and there is no way
to modify account settings. Contact National Instruments for assistance.

Process File Security

You can protect your process files from being edited by another person.
Log in with an account name and a non-empty password, and select
File»Save As from the menu. The following dialog box appears.
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Save Process File As... EHE
Sawve in: IaAPPS
File name: ISecure.Ikp Seve |
Sawve as type: IProcess Files™lkp) j el |
v Protectfile from editing with our account name/password:

Check the Protect file from editing with your account name/password
box at the bottom of the dialog box to save the file with your password as
protection. To edit the file again, you have to log in under the same account
with the same password.

Note You cannot open an encrypted file with an earlier version of Lookout, even if you
create an account with the same account name and password in that version.

When you protect a process file, Lookout does not save the . LKS file.
Because the . LKS file serves as a backup file during application
development, you should not use the encrypted-save feature until after you
have completed your application and made a backup copy of both the . LKP
and . LKS files on a separate archive disk.

Control Security

Several object classes in Lookout support control security, including

the Pot, Switch, and Pushbutton. Each class provides some type of
control—pots control numeric output signals, and switches and
pushbuttons control logical output signals. Each class accepts the
control security level parameter, which determines whether an operator
can control the object. See Chapter 18, Object Class Reference, for
additional information on these object classes.

To determine if an operator can control a particular object, Lookout
compares the security level control of an object to the security level of the
currently logged-on account (the operator). If the account security level is
equal to or greater than the security level of the object, the mouse cursor
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changes into a hand when positioned over the object and the operator can
adjust and control of the object.

If the account security level is lower than that of the object, the cursor
changes into the international symbol for forbidden, and the operator
cannot control the object.

You can implement this feature on an object-by-object basis, instead of for
an entire class. System integrators can secure high priority switches, pots,
and pushbuttons from operators, while still allowing operators to adjust
lower-level security objects.

Lookout globally applies the Control Panel object security setting to all
individual objects on that panel and assigns the higher security level (either
the control panel or the individual object) when determining whether an
operator can control an object. See the discussion of the Panel object in
Chapter 18, Object Class Reference, for additional information.

Viewing Security

Lookout provides viewing security for control panels, controllable objects,
and system settings. With these security options, you can restrict access to
control panels, objects, and Windows system resources.

Control Panels

A Control Panel object defines viewing security for the entire control panel.
For example, if you set Viewing security to level 6 on a particular panel,
operators with level 5 or lower cannot view that control panel and might
not even know that panel exists. If a level 6 (or higher) operator logs on, the
control panel instantly becomes available for display. This feature is useful
for hiding panels that are rarely used or that contain sensitive information.
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Controllable Objects

System Settings

Lookout Reference Manual

Controllable objects such as Pots, Switches, and Pushbuttons all have a
writable data member called visible. When visible is true, you can see
the object on a control panel. When visible is false, you cannot see or
adjust the object. To ensure that the object is always visible when it is first
created, visible defaults to true.

You can connect the visible data member of a controllable object (for
example, a Pot object) to a controller mode indicator. When the controller
is in computer control mode, the visible data member of the Pot might
be true, allowing the operator to see the Pot and adjust the setpoint. But
when the controller is not in computer control mode, the visible data
member might be false, hiding the Pot from the operator and prohibiting
operator control.

You can also use the username or seclevel data members of the $System
object to control the visibility of a control object, depending on the name
or security of the person logged on to Lookout at any given time.

With the Options»System... menu command, you can define system
options in the System Options dialog box (Figure 10-2) to keep Lookout
maximized, the menu bar invisible, title bars invisible, and popups to a
minimum.
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System Options | ]

Startup process file: Ifilename.lkp Log alarms to:

—If security level is below: LFT1:

Lookoutwill always be maximized LPTZ: |

User cannot switch to another prograrm
{limited support for Windows NT) Change Registration Info

IB_
|4_

|4_ tenu bar will nat be visible
|3_

2

tenu and title bars will nat be visible Sy - |
Limit active popups to: |4 {1-94) oK. I
(-9
) Cancel |
—Yirtual Keyboard Pops Up On
[~ Left Mouse Click Iv!
¥ Sawve state file every 300 (114403 minutes
Data files location: Ic:\program files\national instruments!loakouty
Titne zone: ™ Currently within Daylight Savings Time
I(GMT—B:DD) Central Standard Time, Mexico City, Georgetown (Texas) j

Figure 10-2. Defining Security in the System Options Dialog Box

Lookout will always be maximized—When you enter a security level,
Lookout prohibits users below that security level from closing Lookout.

Menu bar (and title bars) will not be visible—When you enter a security
level, users below that security level cannot view the menu bar or the title
bar and, therefore, cannot change to a different Windows application.
This feature is not completely supported under Windows NT 4.0. With
Windows NT 4.0, you can still use <Ctrl-Esc> or the Windows key to
activate the Windows Start menu or <Ctrl-Alt-Delete> to bring up the
Task Manager.

Limit active popups to:—This option requires two values: a security level
and the number of popups. Users below that security level can view up to
the specified number of popups at one time. This feature keeps new users
from becoming lost. See Options»System menu command in Chapter 16,
Runtime Menu Commands, for more information.
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Action Verification

The Switch and Pushbutton object classes support action verification.
When you define action verification for an object, Lookout displays a
message box stating your Verify message and prompts you to select
either Yes or Cancel. If you click on Yes, Lookout completes the
previous operator command (for example, flips the switch or presses
the pushbutton). If you Cancel, Lookout ignores the previous
operator command.

All action verification parameters accept text expressions, which can
contain dynamic data. As an example, consider a switch that controls a
pump responsible for filling a storage tank. However, that pump should not
fill the tank if the water level is too high. You might enter an expression
similar to the following for the Switch Verify On parameter:

“This turns on the sludge return pump #2. Are you sure
you really want to do this?”

The warning message appears every time you turn on the switch. Notice the
water level is dynamic—it changes to reflect the value of 1evel when the
switch is flipped.

SludgePmp2 =]

@ This turns on the sludge return pump #2. Are you sure you really want to do this?

[ila] |

When you turn off the switch, no warning message appears because the
Verify Off parameter was not specified. If you want to disable the Verify
On warning message, delete the entire expression from the data field.

Note Pushbutton verification works in much the same way. However, when you select
Yes, the pushbutton creates only a momentary output signal. When action
verification is enabled, it is impossible to hold the button down for any length

of time.

Lookout Reference Manual
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This chapter describes three Lookout methods for logging real-time system
data to disk—Spreadsheet Logger, Citadel Historical Database Logger, and
Event Logger—and report generation.

The Spreadsheet Logger creates standard ASCII text files in comma
separated value (.csv) file format. You can open and edit these files with
common spreadsheet and database programs. The Citadel Historical
Database Logger creates an historical database that Lookout HyperTrend
objects access in real time. You can retrieve this data using Structured
Query Language (SQL). The Event Logger creates a chronological audit
trail of who did what and when.

You might implement all three methods on a single system. They are not
mutually exclusive.

Note See Chapter 9, Alarms, for more information on the Alarm Logger, which logs
alarms to disk.

Spreadsheet Logger

When you want to create permanent ASCII files that you can later
open with software packages such as Excel, Lotus, and Foxpro, use a
Spreadsheet object to store real-time system data to disk.

You can generate more than one spreadsheet for a single process if you
use multiple Spreadsheet objects in one process file (an . LKP file). You
can have different spreadsheet files in different subdirectories and each
might have different data stored using different logging criteria. See the
Spreadsheet Logger section in Chapter 18, Object Class Reference, for
more information on the Spreadsheet object.
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Create spreadsheet storage object | ]
Ta: ISheeﬂ
—File configuration———————  —Mechanisms to trigger data logging—————————————————
Interval logging
MName =
Idata Interval = Innif(PLC.FIDW>4D,1 :00.15:00)

(hh:mm:ss.ss orvariable)
Type: |cswv -

Logging = Ion

Directory tree location {turns interval logging on and off)

& Daily
& honthly Log now = |$keyb0ard.f2
 Yearly {log data every time signal goes true)
" Perpetual
Bl ™ Log on every data change
—Data fields

3 data fields:

01 Modbus1.000001
02 Modbus1
03 Modbus1.300001

Ok |
=N

Cancel
Editing field 04 {new field) =

hodbus1.300001
Dol Farmat: Field:
;ﬂel IG eneral j |4

Figure 11-1. A Spreadsheet Object with Complex Mechanisms Defined
for Triggering Logging

Data Location

Lookout stores spreadsheet files in subdirectories specified by the Data
files location field in the System Options dialog box (see Figure 11-2).
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System Options | ]
Startup process file: Ifilename.lkp Log alarms to:
—If security level is below: LPT1:

Lookoutwill always be maximized LPTZ: |

User cannot switch to another prograrm

IB

I_ {limited support for Windows NT) Change Registration Info
4

|4

2

Menu bar will not be visible

tenu and title bars will nat be visible Sy - |
Limit active popups to: |4 {1-94) oK. I
(-9
) Cancel |
—Yirtual Keyboard Pops Up On
™ LeftMouse Click ¥ Ri
¥ Sawve state file every 300 (114403 minutes
Data files location: Ic:\program files\national instruments!loakouty
Titne zone: ™ Currently within Daylight Savings Time
I(GMT—B:DD) Central Standard Time, Mexico City, Georgetown (Texas) j

Figure 11-2. System Options Dialog Box Specifies Spreadsheet File
Root Directory Path

CSV Files

All Lookout spreadsheet files use the comma-separated value (.CSV)
format. A . csv file contains text separated by commas. Each line of the file
represents a row of spreadsheet data. The first row lists signal names and
describes the data stored in each column of the file. The first column of the
spreadsheet file specifies the date and time data in each row was logged.
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X Microsoft Excel - Data.csv

ﬁEile Edit “iew Insen Format  Tools  Data DAQ  Serial  GFIB  Window Help _|&]
x|

De|El Slale] & ] olod| = (4] 21ZY it @4

i A Bl z|u| S[==[E] 8]0, [46].%)

E9 = |

A | B ] C | D | E i=
1 Time Presssure TankLevel  ReliefValve = Temperature
| 2 | 9/29/97 1544 46 1 0 78 L
| 3 | 9/29/97 1545 37.64 31.37 0 76
EN 9/29/97 1545 30.63 50.92 0 ik
| 5 | 9/29/97 1545 23.99 58.3 0 78
| 6 | 9/29/97 1545 19.19 64.94 1 79
|<r<| » | [, Dgt?(q’rs?ngeé?ﬂsﬁeee £ Sheetd [ Sr:eétsq,( Sheett / si;ﬁﬂ . | Tiuj
Ready | [Sum=0 | | I A

You can view and edit spreadsheet files using a standard word, but
spreadsheet programs such as Microsoft Excel provide a more intuitive
interface for viewing or editing data and printing custom reports.

File and Disk Errors

If Lookout cannot find the data directory or spreadsheet files or cannot log
data to disk, it generates a priority eight alarm with a descriptive error
message. For example, you can set the directory tree location to Monthly
and your Data files location as c: \ 1ookout. If Lookout encounters a full
disk while writing to a file named data.cCsSv, the alarm text reads:

(Disk is full) “c:\lookout\1994\sep\data.csv”.

When you correct the problem that caused the alarm, the alarm
automatically resets.

Concurrent File Access

Lookout Reference Manual

When logging data, Lookout opens the file long enough to add a new row
of data and then closes the file. Lookout can log approximately 10 new

rows of data per second. (The time stamps associated with each row are

rounded to the nearest second.) Because Lookout runs under the Windows
multitasking environment, you can open the spreadsheet or database while
Lookout is running. If you have the data file open in a spreadsheet program
such as Excel, Lookout cannot add new rows of data to the file. If Lookout
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does not have write access to the file, it generates an alarm explaining
the problem:

Error writing spreadsheet file: Permission denied
[c:\lookout\1993\sep\data.csv]

If Lookout cannot log data to the spreadsheet file, it creates a temporary
buffer in memory to which it logs all the spreadsheet data. When you close
the spreadsheet file, Lookout updates it and resets the alarm.

Information Overload

If you create a Spreadsheet object that logs fifty data fields (tagnames
and/or expressions) at five-minute intervals, you generate 14,400 data
points per day or 432,000 data points per month. It can be difficult to
determine which data are critical information.

Note Carefully consider the importance of each data point and the time interval
between data points to avoid information overload for both you and your
spreadsheet program.

If you have logged more than 16,384 rows of data, the current version of
Excel cannot load the entire spreadsheet file. Spreadsheets created with
one-minute intervals generate 44,641 rows of data if the directory tree
location is set to Monthly. Spreadsheets created with two-minute intervals
generate 22,321 rows of data if the directory tree location is set to Monthly.
To decrease the number of data rows, try changing the directory tree
location to Daily, which generates only 1,440 rows of data per day at
one-minute logging intervals. You can also use a text editor to divide the
larger file into smaller files with fewer data rows.

Besides limiting rows to 16,384, Excel limits spreadsheets to 256 columns
of data. One column is reserved for the date and time.

Citadel Historical Database Logger

When you need to view historical information using Lookout HyperTrends
or access historical data using Structured Query Language (SQL), use the
Citadel Historical Database Logger to store real-time numeric and logical
data in a compressed format.

Lookout logs data only when the value of a point changes, not at a timed
interval. The logged data accurately reflects the actual behavior of the point
being logged because the same value of a point is not recorded over and
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Data Location

over. With Citadel, disk usage is exactly proportional to the amount of
information recorded.

Once the data is stored to disk, you can view it with a HyperTrend object in
Lookout or with SQL. HyperTrends serve as windows into your database.
SQL, an industry-standard language supported by most database packages,
enables other applications to directly retrieve data from Citadel.

Because Citadel uses Universal Coordinated Time (GMT) to time stamp
the data, you do not need to compensate for data logged in different time
zones. The HyperTrend object automatically converts from universal to
local time before displaying a data history. Identify your time zone in the
System Options dialog box, shown in Figure 11-2.

The Data files location field in the System Options dialog box specifies
the root directory under which all data logging is stored, including the
database. Citadel creates a special CITADEL subdirectory in the Lookout
directory. This subdirectory holds your historical database files. Never
move or rename the subdirectory or files.

Unlike spreadsheet files, only one historical database per copy of Lookout
exists. If you want to develop multiple process files where each process file
has its own unique historical database on a single computer, install Lookout
multiple times on the same computer but in different directories. You can
then specify different locations for each database—one for each copy of
Lookout.

Creating a Historical Database

Lookout Reference Manual

Citadel stores historical information using traces. Trace refers to the line of
continuity for a specific data member name or point. A trace connects all
the historical values for a given point, which displays as a continuous line
in a HyperTrend object. If Lookout is unexpectedly interrupted or a data
member is temporarily modified to not log to disk, a trace can be broken. If
the trace is broken, the HyperTrend plots the trace as a continuous line with
void sections to represent gaps in the data. You cannot remove individual
traces from the database, but you can add new traces to the database by
configuring a new point.

11-6 © National Instruments Corporation



Chapter 11 Logging Data and Events

You can log any numeric or logical data member of any object to the
historical database. Use the following procedure to add a trace to the

Citadel database:

1. Select the Object»Edit Database... menu command and an object
that contains data you want to log.

2. Identify the value you want to log in the Member data field. If the
value was previously configured, select it from the Configured
points list.

3. Check the Log to historical database checkbox and choose an
appropriate Lifespan. See Logging Criteria for an explanation of time
span settings.

4. Enter a value in the Deviation field. See Logging Criteria for an
explanation of Deviation settings.

Configured points:

Mative members:

—Alarm conditions

FIC1 01 Alarm

000001-065000
100001-165000

ﬂ Group:IChiIIed Waater vl

FICT01Mode 10001-19599 Condition  Lewel  Priority
FICTIT Opuput 1-4984 HiHi: |45 |5
FICT01Run 300001-365000

FICT01 Setpaint 30001-399394 Hi: |4D |5
FIC101Speed 400001.1-465000.16 =

Le: |1D |5

numeric read fwrite Lol |5— IB_
Alias (optional): Member:
[FICT01FLow 40007 Deadband:  [2
—Description — Filters (engineering units)
IChiIIedWater#1 Flow Rate Dewviation: ID.25

Prefix: I Suffic. |CFS [~ Forced: I
—Scaling v Log to historical database

Minimum haxirmum Lifespan

Raw units: [ [r5535 C Perpetual

Eng. units: ID ISD & e days

I dste I Delete | Select object... | Irmpart... | Export... Cluit

Figure 11-3. Using the PLC Database Dialog Box to Create a New Trace

Click on the Save or Update button. (If you are modifying an existing

configured point, the button automatically changes to Update.)

Citadel database.
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Click on the Select object button and select the next object containing
data you want to log.

Repeat steps 2 through 6 until you have created the traces that
you need.

Click on Quit.

Logging Criteria

To create a new trace in the Citadel historical database, Lookout needs the
following information: data member name (Alias), Deviation,
and Lifespan.

Information Overload

Data member name (Alias)—Lookout must give a name to each trace
in the historical database for archiving and retrieval purposes. If Alias
is not specified, Lookout uses the native data member name as
displayed in the Member field. If an alias is assigned to the native data
member, Lookout uses the Alias name instead. The name used for the
trace is the same name saved to the Configured points list box. In
Figure 11-3, the name is PLC.FIC101FLOW.

Deviation—If an analog value surpasses or equals the Deviation
setting, Lookout saves a new value to disk in the database. If you
implement Scaling parameters, Lookout compares the Deviation
setting to changes in the Eng. units values to determine when to log
a new point. If you leave the Scaling parameters blank, Lookout
compares the Deviation setting to the raw (unscaled) signal. The
Deviation parameter is not available on logical signals because
Lookout logs all state transitions of logical values to disk.

Lifespan—Lookout needs to know how long you want to maintain this
trace of data in the historical database. Lookout maintains the data for
at least the time span specified in the Log to historical

database parameters.

Lookout does not discard old data immediately. Disk space containing
old data is reused when new data is logged.

Because Lookout creates and maintains the historical database in 1 MB
chunks, you must have a least 1 MB of available disk space to begin
logging data. When the first 1 MB file fills up with data, Lookout creates a
second 1 MB file in the same directory. When the second fills up, Lookout
continues to create 1 MB files until all traces can be maintained on disk for
the time spans specified in the Log to historical database lifespan data

Lookout Reference Manual
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field. Lookout monitors the status of your hard drive and generates an
alarm when your disk falls below 500 KB of available space.

Use discretion when determining Deviation settings on each trace of data.
If Deviation is not specified, any change of an analog value results in a new
point being logged to disk, and you might generate too much data. If the
Deviation setting is too large, very little information might be saved to
disk.

Event Logger

When you want to create a chronological schedule of events or an audit
trail, use the Lookout Event Logger. The Event Logger logs all events:
operator commands, Event objects, and all global events (running Lookout,
closing Lookout, opening a process file, closing a process file, entering edit
mode, exiting edit mode, and logging on and off).

Operator commands include events such as closing a process file, entering
edit mode, and adjusting a pot. Along with each event, Lookout logs the
account name (the operator), date and time of the event, tagname of the
object adjusted, and the previous and subsequent settings of the object.
Because all of this information is logged, you create an exhaustive audit
trail for that specific workstation.

Use the Event object class to define and log your own event messages based
on a user-defined trigger. See the Event section in Chapter 18, Object Class
Reference, for additional information.

Data Location

Lookout stores event files named EVENT . DAT in monthly subdirectories
specified by the Data files location parameter in the System Options
dialog box. At the beginning of each month, Lookout creates a new
monthly subdirectory and event file. If you specify C: \DATA as the Data
files location, Lookout saves your event files as follows:

C:\DATA\1993\OCT\EVENT.DAT
\NOV\EVENT .DAT

\DEC\EVENT .DAT
\1994\JAN\EVENT .DAT
\FEB\EVENT .DAT

To view these files, print them out with the File»Print»Events...
command.
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Information Overload

The event logger can store information on an individual object instance for
switches, pots, and pushbuttons. Every time you flip a switch, adjust a pot,
or depress a pushbutton, Lookout logs the event to disk. If you enable the
Event Logger for all instances of these object classes, you might collect
more data than you need.

By selectively enabling the Event Logger on critical switches, pots, and
pushbuttons, you cut down on the amount of information logged to the
event file. For example, you might place a dozen switches on a control
panel, but only one of those twelve requires data logging. Rather than log
events for all twelve switches, enable the Event Logger only on that
single switch.

Report Generation

Control Panel Reports

Lookout Reference Manual

Panel objects have a special data member named print. When print
changes from FALSE to TRUE, Lookout copies a picture of the control panel
and sends that copy to your printer using the Windows Print Manager. See
Panel section in Chapter 18, Object Class Reference.

To configure your custom report, design a control panel and connect a
logical trigger signal to the panel. You can connect any logical expression
to the print member. The control panel does not have to be visible to be
printed. Therefore, an operator can view one screen (panel) while printing
another screen.

Lookout determines the printed panel size based on dimensions entered in
the Revise control panel settings dialog box.

Revise control panel settings

Tag: IPaneH
Title: ICDntroI Panel
—Panel type Background color:

& Mormal

Ll [ ||
 FPopup ........ . .

 Popup no icon
wan, i
Height: IBDD Cancel |

— Security levels
Yiewing: ID
Control: ID
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When Panel type is set to Normal, Lookout assumes that the panel is
maximized. Even though your control panel might be maximized, Lookout
prints only the area defined by your Panel object Width and Height
settings. For example, you might have a panel that looks like Figure 11-4
when maximized.

£~ Lookout - svgaeval.lkp - [Logging. Alarming & Security]

File Edit Options Alarms  Window Bun  Help =& x|
Data Logging Alarming Security
Temperature Chemical Plant Pumps ll
Group Group Group
m Alarm1 Alarm2 Alarm3
100 100 100
Pressure 90 90 90 8
m_ | 0.0 | 80 80 80
70 70 70
60 60 60
Flaw 50 50 50 5]
0 | u ‘0 @ w 7] o EwE
Tanklavel 20 20 20
anideve oo | 10 10 10 I [Level5] [Levela] [Levein]
0 0 0
Valvel Valve2 Pumpl Pump2 4
=
2 Alarm4 Alarm Alarmé LI
[esion ] [ we ]
4444 r»rpp @O Analog Data Logical Data
Regional Map
Water Plant
Cockie Plant
[12/05 16:03 | (nobody) [ MNational Instruments Internal Use Onky [ 1:1alarms

Figure 11-4. Printing a Normal Panel Object

The panel in Figure 11-4 has a specified Height of 300 pixels and a Width
of 400 pixels. At a video resolution of 800 x 600, the printed panel would
look something like the following figure.
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Modify the Height and Width dimensions of your Panel object to match
your screen resolution. This problem applies only to Normal style panels.
Popup and Popup no icon style panels print according to the WYSIWYG
principle (What You See Is What You Get).

Third-Party Reports

Lookout Reference Manual

You can generate reports using Lookout and a third-party spreadsheet
program. Current spreadsheet software provides extensive macro
command capabilities you can use to quickly generate reports from
Lookout.You can write Excel macros that prompt you for the report date,
automatically open the correct spreadsheet file(s), extract the data, and
print reports with combinations of numeric tables and graphs. You can
launch these macros from Lookout or automatically invoke them using
predefined timers.
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Structured Query Language

This chapter describes Structured Query Language (SQL), Open Database
Connectivity (ODBC), and accessing Citadel data using both SQL

and ODBC.
Note The Express version of Lookout does not log data or contain tools for extracting
logged data.

Introduction

The Citadel historical database includes an Open Database Connectivity
(ODBC) driver, which enables other applications to directly retrieve data
from Citadel using Structured Query Language (SQL) queries.

What is ODBC?

ODBC is a standard developed by Microsoft. It defines the mechanisms for
accessing data residing in database management systems (DBMSs). Nearly
all Windows-based applications that can retrieve data from a database
support ODBC.

What is SQL?

Structured Query Language (SQL) is an industry-standard language used
for retrieving, updating and managing data. In Lookout, you can use SQL
to build queries to extract data from Citadel. The Citadel ODBC driver also
includes many built-in data transforms to simplify statistical analysis of
retrieved data.

Configuring the Citadel ODBC Driver

1. Shut down all applications that might use ODBC. Applications such
as spreadsheets, word processors, database programs, and Microsoft
Query might use ODBC. You also need to shut down Lookout if you
are using the SQL object.
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2. If you are using Windows 95, click the Start button and select
Settings»Control Panel. Otherwise, choose the Control Panel
icon from the Main program group.

3. In the Control Panel window, choose the 32-bit ODBC icon or
the ODBC icon if you are using the 16-bit ODBC driver.

4. In the Data Sources dialog box, choose Drivers....

€10DBC Data Source Administrator EHE

User D3N | System DSN | File DSN | ODEC Drivers | Tracing | About |

User Data Sources:

Add...
MName | Driver |
( el Lookout 32-hit Citadel Database Bemowve |
dBASE Files Microsoft dBase Driver (*.dibf)
Excel Files Microsoft Excel Driver (*xs) Canfigure... |
FoxPro Files Microsoft FoxPro Driver (*.dif)

M3 Access 7.0 Database Microsoft Access Driver (*mdhb)
M3 Access 97 Database  Microsoft Access Driver (*mdhb)
Text Files Microsoft Text Driver (it *.cav)

An ODBC User data source stores information about how to connectto the
indicated data provider. A User data source is only wvisible to you, and can
only be used on the current machine.

oK I Cancel Al Help

5. Choose the citadel driver and select Setup....

National Instruments Lookout ODBC Setup | ]

Change data source name, description, database path, ortimezone
infarmation. Then choose OK.

Ciata Source Mame: ICitadeI 32-hit

Description: |32—bit Lookout Citadel Database ODBC Driver

Database Fath: IC:\Iookout\citadel

Time zone: ™ Currently within Daylight Savings Time

I(GMT—B:DD) Central Standard Time, Mexico City, Georgetown (Texas) j

Compatibility Options

Maximurn Colurmn Name Length: |82

" Convert special characters
oK I Cancel

Lookout Reference Manual 12-2 © National Instruments Corporation



Chapter 12 Structured Query Language

6. Make changes as appropriate. For example, if Lookout and the Citadel
database are not in the C: \LOOKOUT directory, you might have to
modify the database path.

5 Note Some applications are not completely ODBC compliant. If you plan to use
Microsoft Query, Microsoft Access, or Visual Basic, ensure Maximum Column
Name Length does not exceed 62 characters. These applications cannot handle
longer tag names. Applications that are completely ODBC-compliant can handle
tag names up to 126 characters long. All traces whose tag names exceed the
Maximum Column Name Length are excluded from queries.

Note If you plan to use Microsoft Access or Visual Basic, select Convert special
characters to force Lookout tag names into an accepted format by replacing
characters within the tag names with the characters in Table 12-1.

Table 12-1. Special Access SQL Characters

Special Character Converted Character
period ( .) backslash (\)
ampersand ( & ) atsign (@)
exclamation ( !) vertical bar (| )

7. Select OK and Close to exit.

Accessing Citadel Data

Traces Tahle

The ODBC driver presents Citadel data to other applications as a traces

table. The table contains a field or column for each data member logged to
the Citadel database and three fields you can use to specify query criteria
and to time-stamp retrieved data: Interval, LocalTime, and UTCTime.

Interval specifies the query value sample rate. Interval can range from
10 ms to several years. Interval defaults to 1 (one day).

Because Citadel is event-driven, it only logs a value when the value
changes. Using Interval, you can query Citadel for values evenly spaced
over a period of time.
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Data Transforms

LocalTime and UTCTime are time-stamps that indicate when values are
logged. Citadel stores the time in UTCTime format and derives
LocalTime from the stored time.

The following where clause query uses Interval and LocalTime to select
data over a specified time at one-minute intervals. Notice that time and date
formats are the same as those used in Lookout.

SELECT * FROM Traces

WHERE LocalTime>“12/1 10:00”
AND LocalTime<“12/2 13:00”
AND Interval=%“1:00"

Your queries can include special commands that perform data transforms
to manipulate and analyze historical data. See Table 12-2 for a list data
transform commands.

Table 12-2. Data Transforms

Command Transformation

Min{Datapoint} Returns the minimum for Datapoint across the interval.

Max { Datapoint} Returns the maximum for Datapoint across the interval.

Avg{Datapoint} Returns the average for Datapoint across the interval.

Stdev{Datapoint} Returns the standard deviation for Datapoint across the interval.

Starts{ Datapoint} Returns the number of starts (that is, the number of transitions from OFF
to ON) for Datapoint across the interval. For numeric points, 0.0 is
interpreted as OFF, and all other numbers are treated as ON.

Stops{Datapoint} Returns the number of stops (that is, the number of transitions from ON
to OFF) for Datapoint across the interval.

ETM{Datapoint} Returns the amount of time Datapoint was in the ON state across
the interval.

Qual{Datapoint} There might be gaps in the historical data traces in Citadel because of

machine shutdown, Lookout shutdown, or a similar occurrences. Qual

returns the ratio of time for which valid data exists for Datapoint across
the interval to the length of the interval itself. If valid data exists for only
one-half of the interval, Qual returns 0.5.

Lookout Reference Manual
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Using these data transforms you can directly calculate and retrieve complex
information from the database such as averages and standard deviations, so
you do not need to extract raw data and then manipulate it in another
application.

For example, you need to know how many times a compressor motor
started in December. You also need to know its total runtime for the month.
Use the following query to get your answers:

SELECT“Starts{PLC.MotorRun}”,
“ETM{PLC.MotorRun}"”
FROM Traces
WHERE LocalTime>=“12/1/95"
AND LocalTime<“1/1/96”
AND Interval=%“31"

SQL Examples

The following examples are typical query statements; however, your
queries might be much more involved, depending on your system
requirements.

SELECT *
FROM Traces

Retrieves the current value of every data member logged to Citadel.
Because your query does not occur at the same moment in time as a
PLC poll, signals scanned from PLCs are not included in the
retrieved data.

SELECT *
FROM Traces
WHERE Interval=“0:01"

Retrieves the value of every data member logged today in one-second
increments. Notice that the interval value is enclosed in
quotation marks.

SELECT LocalTime, “Potl”

FROM Traces

WHERE LocalTime>"“8:50"
AND Interval="0:01"

Retrieves and time-stamps the value of Pot1 in one-second increments
from 8:50 this morning to now. Tag names are enclosed by quotes.
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SELECT LocalTime, “ABl1.I:3”, “Max{AB1.I:3}”
FROM Traces
WHERE LocalTime>“10/1/95”"

AND LocalTime<“11/1/95”

AND Interval="1:00"

Retrieves and time-stamps an Allen-Bradley PLC input in one-minute
intervals for the month of October. This query also indicates the
highest occurring input value of each minute.

SELECT LocalTime, “OVEN1_SP”, “PLC.OVEN1_PV”,
“Max {PLC.OVEN1_PV}”, “Min{PLC.OVEN1_PV}”,
“Avg{PLC.OVEN1l_PV}"”

FROM Traces

WHERE LocalTime>="“14:00"

AND LocalTime <“15:00”
AND Interval=“1:00:00"

Retrieves an oven temperature at 3:00 p.m. and shows the highest, lowest,
and average temperatures between 2 p.m. and 3 p.m.

Accessing Citadel Data with Microsoft Query

Microsoft Query is a graphical data retrieval tool supplied with Microsoft
Office and Microsoft Excel that you can use to build your SQL statement
using interactive dialog boxes.

The following example uses Microsoft Query Version 2. If you have a
different version, some of the steps or dialog boxes may vary. Refer to your
Microsoft documentation for further information.

1. Launch Microsoft Query.

2. Choose File»New... and select the Citadel data source.

Select Data Source

Awailable Data Sources:

Cancel

Other...

Bemowve

I

Note If Microsoft Query is unable to connect to Citadel, make sure you have logged data
to Citadel and entered the correct Database path in the ODBC Setup dialog box.
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= Note If Citadel is not listed in the Data Source dialog box, it might not have been
accessed yet. Choose Browse... and select Citadel from the ODBC data sources.
If Citadel is not listed as an ODBC Data Source, you need to install it. Citadel is
installed as a part of the Lookout installation process. If you did not install Citadel
when you installed Lookout, you should re-install the complete package.

3. In the Add Tables dialog box, double click Traces.

Add Tables

Close

Options...

e I

L L

atalhase: I

4. Close the dialog box.

Microsoft Query presents the full Query Window with the Traces
table. The tag names in the Traces table is a comprehensive list of
all tag values that have been logged to Citadel.

I Microsoft Query =] 3

File Edit ¥iew Format Takle Criterim Becords Window Help

EEEE]

Traces

"Modbus1i40002
"Modbus144000
"Modbus144000
"Modbus144000
"Modbus1i 7"
"Modbus1iadin'=

LocalTime [ "Modbusiyadin® | [
P [1997-12-06 12:38:11 49
_ |1997-12-07 12:38:11

-

3

|
Select View Criteria to show/ec | [ [

A4

Figure 12-1. The Query Window with Traces Table
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To view a trace, double click on or drag the field you want to view to a
blank column in the data pane. In the proceeding illustration,
LocalTime and "Modbusl.adin" have been dragged down.

To view a data transform value, enter the function directly into a blank
column. For example, to view the minimum value of PLC.AI2, you
would enter “min{PLC.AI2}". You mustinclude the quotation marks
and braces.

The data set in Figure 12-1 was retrieved using no specific criteria, so
the ODBC driver used the default. Although there are several ways to
specify criteria, in this example, we use the criteria pane.

Click on the View Criteria button. The pane appears in the Query
window.

Add a field to the criteria pane by double-clicking on the field, or by
dragging it to the blank column in the criteria pane.

I Microsoft Query =] 3
File Edit “iew Format Tahle Criteria Records indow
Help
EIEE = B
®w Queryl [H[=] B3
Traces . . .
"Tanklevel’® = View Criteria
'"Temperature" button
"throttle"
"alkeal"
"ahke?! 1
Interval hd
. . SQL button
Criteria Field: | Interval | ~
Walue:
or: h
[l »
LocalTime | "Modbusiyadin" | J
[P [1997-12-06 12:38:11 49 [
L [1997-12-0612:38:12 54.7586
L [1997-12-0612:38:13 50.3273
L [1997-12-0612:38:14 50
L [1997-12-0612:38:15 495273
L [1997-12-06 12:38:16 49
L [1997-12-0612:38:17 49
L [1997-12-0612:38:18 49.8989
L [1997-12-0612:38:19 48 =
W iRecorall DI <[] i
Ready [ e [ [
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When you enter qualifying criteria values, use the syntax demonstrated
in SQL Examples earlier in this chapter. See the following illustration.

As soon as you specify criteria, Microsoft Query retrieves the specified
data. You can save your query at any stage of development, and, as you
build your query, the application builds an SQL statement.

Click on the SQL button to view or edit the query statement.

sSQL E
S0L Statement: oK
SELECT Traces LocalTime, Traces."Modbus1hadin" ﬂ Cancal |
FROM Traces Traces

WHERE (Traces Intersal='0:01"

Accessing Citadel Data with Microsoft Excel

1.
2.

© MNational Instruments Corporation

Launch Excel.

Choose Data»Get External Data.... This Excel command directly
launches Microsoft Query.

Use an existing query or create a new one. See Accessing Citadel Data
with Microsoft Query for information on querying.

When you finish building your query, return the result set with the
File»Return Data to Microsoft Excel... command. Excel prompts
you with the Get External Data dialog box, enabling you to change
or confirm the destination cells of the result set. If you want to query
Citadel later to update the result set, check the Keep Query Definition
checkbox.

Click on OK to write the data to an Excel worksheet.

Get External Data | ]
Option

¥ Keep Query Definition 8

¥ Include Field Names Cancel

™ Include Row Nurmbers

i

Help
" Keep Password

Destination:
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6. To update your result set, select any cell within the worksheet result
set, choose Data»Get External Data... command, and click on the
Refresh button.

Accessing Citadel Data with Microsoft Access

Note

Lookout Reference Manual

The SQL/92 standard states that a delimited identifier is any string of no more
than 128 characters enclosed in quotation marks. It further states that characters
within a delimited identifier are exempt from SQL syntax checking.
Unfortunately, Microsoft Access performs its own syntax checking for ODBC
queries using a non-standard SQL syntax—even within delimited identifiers. For
this reason, National Instruments provides a Convert Special Characters selection
in the Citadel ODBC Setup dialog box. When selected, the ODBC driver converts
the special characters to accepted Access characters. See Table 12-1 for a
complete list of special characters.

When you query Citadel using Microsoft Access, you must use the
Microsoft Access non-standard SQL syntax in your select statement.
Remember to consider the following elements:

e Convert special characters for Access compatibility (see Table 12-1)

e Place double quotes around Lookout trace names to identify them as
delimited identifiers

*  Enclose identifiers in square brackets ([ ])

e Place pound signs (#) around time stamps

For example, to retrieve LocalTime, Potl, and Tiwayl.v101 where
LocalTime is greater than 11/20/95 18:00:00, and where Interval is one
second, enter the following query:

SELECT LocalTime, ["Potl"], ["Tiwayl\V101"]
FROM Traces

WHERE LocalTime > #11/20/95 6:00:00 PM#
AND Interval = '0:01'

1. To query Citadel from within Microsoft Access, open a database and
use the File»Get External Data»Link Table command.

2. Choose the Machine Data Source tab in the Select Data Source
dialog box.
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3. Highlight citadel as shown in following illustration.

Select Data Source EHE

File Data Source  Machine Data Source |

Data Source Name | Type | Description |

C el it User 32-hit Lookout Citadel Database ODBCD...
dBASE Files User
Excel Files User
FoxPro Files User
M3 Access 7.0 Database User
M3 Access 97 Database User
TextFiles User

Atdachine Data Source is specific ta this machine, and cannot be shared. "User" data
sources are specific to & user on this machine. "System" data sources can be used by
all users on this machine, or by a systerm-wide service.

oK I Cancel Help

Figure 12-2. The Select Data Source Dialog Box

4. Click on OK.
In the Link Tables dialog box, choose Traces. The new table links to
your database.

Link Tables EHE

Tahles |

Traces oK |
Cancel |

Select All |
Deselect All |

[© Sawve password

6. At this point, you can build queries in Access to extract data directly
from the Citadel database. See your Access documentation for more
detailed information on this process.
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Accessing Citadel Data with Visual Basic

% Note Visual Basic software relies on Microsoft Access DLLs for performing ODBC
queries. Because it uses the Access non-standard SQL syntax, be sure that Convert
Special Characters is selected in the Citadel ODBC Setup dialog box. See the note
under Accessing Citadel Data with Microsoft Access.

You use the Citadel ODBC Driver in Visual Basic the same way you would
use any other ODBC driver. To retrieve and view data, you have to create a
data control and at least one text control.

1.
2.

Place a data control on an open form.

Set its Connect property to DSN=Citadel and double-click on its
Record Source property to identify Traces as its source table.

If you want to select all of the data for all traces in the Citadel database,
leave the Record Source property set to Traces. If you want to
narrow your query, enter an SQL select statement in the Record
Source property.

For example, to retrieve LocalTime, Potl, and AB1.I:3 where
LocalTime is greater than 11/20/95 18:00:00 and less than 18:30:00,
and where Interval is one minute, enter the following query:

SELECT LocalTime, ["Potl"], ["AB1\I:3"]
FROM Traces

WHERE LocalTime > #11/20/95 6:00:00 PM#
AND LocalTime < #11/20/95 6:30:00 PM#
AND Interval = '1:0'

% Note Remember to use the Microsoft Access SQL syntax in the select statement, convert
special characters for Access compatibility (see Table 12-1), place double quotes
around Lookout trace names to identify them as delimited identifiers, enclose
identifiers in square brackets ([ 1), and place pound signs (#) around time stamps.

4.

Lookout Reference Manual

Place a text control on the form.

Set its Data Source property to the name of your data control—for
example, Datal.

Click on the Data Field property to highlight it and then use the
property sheet drop-down combo box to select the desired field name.
All logged data members should be listed including LocalTime,
Interval, and Pot1.

Repeat steps 4 through 6 for each data member you want to display on
your form.
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This chapter explains how to use Dynamic Data Exchange (DDE) with
Lookout. DDE is the Microsoft message-based protocol used by
applications like Microsoft Excel and Lookout to link to data in other
applications.

When the data in a source application changes, it dynamically updates all
linked data (in real-time). With DDE you can dynamically link other
Windows applications to Lookout.

There are several DDE protocol formats. Lookout supports the standard
Microsoft formats, X1Table and CF-TEXT. XlTable is often referred to as
the Fast table format; CF-TEXT is often called text format. Lookout also
supports hot DDE links and NetDDE.

Any two applications participating in dynamic data exchange are engaging
in a DDE conversation. In such a conversation, Lookout acts as either the
client application or the server application (or both, in a peer-to-peer
configuration). If Lookout is getting data from another application,
Lookout is the client. But if another application is getting data from
Lookout, Lookout is the server.

The client application is responsible for establishing a DDE link with the

server. When Lookout is a client, it first tries to establish an X1Table DDE
connection (because this is the most efficient). If the server application does
not support this format, Lookout uses the CF_TEXT DDE format.

To establish a DDE link, the client application must identify the location
of the desired data. A three-tier address identifies the location of the data:
Service, Topic, and Item. Look in the application documentation to
determine its service, topic, and item.

Service specifies the name of the server application the client is linking to.
Each application that supports DDE has a unique service name. For
example, LOOKOUT is the service name of Lookout, and EXCEL is the
service name of Microsoft Excel.

Topic is the second level in the three-tier address. For many server
applications like Excel and Lookout, topic specifies a particular file. In
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Lookout, the topic is the process file name, minus the . LKP extension. For
example, you would refer to a process file named PLANT . LKP as Plant
when using it as the topic in a DDE link.

Item identifies the specific data or value being linked between the server
and the client. A Lookout item is the object tagname, followed by a specific
data member (such as TagName . datamember) if needed. See Identifying
Object Data Members in Chapter 4, Using Lookout, for detailed
information on selecting objects and data members. An item in a
spreadsheet is the name of a cell, such as B3.

Linking Lookout to Other Applications

Lookout can act as a DDE Client, DDE Server, and both DDE Client and
Server. Therefore, there are three basic ways to link Lookout to another
application using DDE:

¢  Lookout as the Server
¢ Lookout as the Client

¢ Lookout as both Client and Server (peer-to-peer)

Note All readable numeric, logical, and text values in Lookout are automatically
available to any other application through DDE. No special setup is required.

DDE Server

Lookout Reference Manual

Because Microsoft Excel is widely used and accepted, it is used in the
Lookout DDE examples.

In this example, you can send information from Lookout to another
application, making Lookout the server. First, create a potentiometer in
Lookout so you can link its value in real-time to a cell in Excel. Any time
the pot is adjusted, the value in the spreadsheet cell automatically changes.

1. Ensure Lookout is not in Edit Mode.

2. Hold down the <Ctrl> key and click the left mouse button on the object
you want to link to. In this case, select the Pot object you just created.

3. Lookout beeps when it successfully copies the object value to the
clipboard. The object can be a slider, bar graph, switch, pushbutton,
digital display, text entry object, knob or almost anything else in
Lookout that contains a value.

4. Start Excel and select the cell you want to link to.
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5. [If your version of Excel is 5.0 or above, select Edit»Paste Special....
Then click on Paste Link. If you have an older version of Excel, select
Edit»Paste Link.

You have just created your first DDE link. Repeat this process as many
times as is needed. If you are linking large numbers of objects to Excel, you
might want to use the Excel copy and edit tools to speed up the process.

Not all applications support the Windows Clipboard shortcut method as
described above. Therefore, you may have to manually enter the
appropriate Lookout Service, Topic, and Item in the other application to
create a DDE link to that package. The format in which you enter this
information varies from one package to another. For this reason, you should
refer to the documentation of the client application for instructions.

DDE Client

In this example you import information from another application into
Lookout. For instance, you might want to use a value calculated inside a
spreadsheet as a process control setpoint for a Lookout application. In this
kind of DDE link, Lookout is the client and the spreadsheet application is
the server. Because Lookout is the client, it is responsible for establishing
the link to the server data. Therefore, you must identify the service, topic
and item in Lookout. These are object parameters in the DdeLink object
class.

5 Note You cannot create or modify objects in Runtime-Only versions of Lookout.
Therefore, you must perform this procedure using a Development/Runtime
Lookout system.

1. Select Object»Create... and select the DdeLink class.

Create DdeLink | ]
Tag: |DDET

DDE parameters:

Service: IExceI

Topic: Ifilename.xls

[tarm: |r1 -1

Ok I Cancel

© MNational Instruments Corporation 13-3 Lookout Reference Manual



Chapter 13 Dynamic Data Exchange

2. In Service, enter the name of the software package (Excel in this
example).

3. In Topic, enter the name of the spreadsheet file.
4. In Item, enter the address of the cell you want to read a value from.

Notice that the entered cell address is r1c1. This translates to
row1/columnl1 (cell A1) in Excel. The Excel DDE structure requires
this format.

5. Click on OK, and then select OK again when Lookout prompts you to
insert the expression DDE1. Finally, pick the desired display format and
click on OK.

To test your link, enter a numeric value into cell Al of your spreadsheet.
Whatever value you enter into the spreadsheet is immediately written to the
DDE expression on your panel. Of course, you can connect the DDE object
you just created to other Lookout objects. See DdeLink definition in
Chapter 18, Object Class Reference, for more information.

Note The DdeTable object is another way of linking data to Lookout using DDE. This
object class links large quantities of data though the more efficient XITable
Jormat. See DdeTable definition in Chapter 18, Object Class Reference, for more
information.

DDE Peer-to-Peer

Assume you want to take the Lookout as a Server example one step farther.
Suppose you want to adjust the pot to change a value in Excel and also be
able to enter a different value in Excel to adjust the pot. That is, to send data
both ways through a DDE link. You can easily create such two-way links
for user-controlled objects (that is, switches, pots and pushbuttons).

Note You cannot create or modify objects in Runtime-Only versions of Lookout.
Therefore, you must perform this procedure using a Development/Runtime
Lookout system.
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Tag: IPDH

Minimurm: ID
Maxirnurm: |1DD
e

Cancel
Fesolution:

—Position source

 Local
- Remote

EasiticEn = I

Service: IEXCB|
Topic: Ifilename.xls
Item: IPDﬂ

Contral security level: ID V¥ Log evants

Select Object»Create... and define a new Pot; or select Object>Modify
and select the existing Pot object.

1. Change Position source from Local to DDE.

In Service, enter the name of the software package (Excel).

In Topic, enter the name of the data file.

In Item, enter the address of the cell you want to read a value from.

Click on OK to create or modify the definition of the object.

AN

If the object is new, insert its display member into the panel so you can
test your link.

To test your link, enter a value into the spreadsheet cell you specified and
watch the pot. Then adjust the pot and watch the spreadsheet cell. You
should see the values within the two applications change in unison.

Note If you link to a Pot object, the linked value is numeric, so you enter a numeric
value into the spreadsheet cell. But if you link to a Switch or Pushbutton object,
the linked value is logical. Linked logical values are shown in spreadsheet cells as
true or false. To change the value of a logical value in a spreadsheet cell, enter
trueor false, 0 Or 1, onor off.
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DDE Alarms

Lookout Reference Manual

Cannot establish DDE conversation with <service>, <topic>

This alarm occurs if a Lookout client is unable to connect to the server
corresponding to the given service and topic. The alarm also occurs if the
server terminates the conversation (for example, if the server is shut down).
The alarm is deactivated when the Lookout client successfully connects to
an item on the server.

Verify that the service and topic were typed correctly when creating the
object that is using DDE. Verify that the server application is running. If the
server is on another computer on the network, verify that the network is up.
If the server is on a computer running Windows NT, verify that you are
authorized to log on to that computer and that the current user logged onto
the NT machine has trusted the DDE share to which you are trying to
connect (see the discussion of trusted DDE shares in the Networking
chapter of this manual).

DDE client error for <service>, <topic>, <item>: (received NACK for
advise)

DDE client error for <service>, <topic>, <item>: (received NACK for
request)

Verify that the named item exists on the server and that the server supports
DDE links for the item. This alarm occurs when Lookout is a client.

DDE client error for <service>, <topic>, <item>: (received NACK for
poke)

This alarm occurs if you are using Lookout as both client and server, and
have made a remote connection to an item that is not writable in a
DataTable, Pushbutton, Pot, Switch, or TextEntry. The only Lookout
objects that support writes (pokes) are DataTable, PushButton, Pot, Switch,
and TextEntry. These support writes into their implicit data members only.

If the server is running Windows NT, it is possible that the DDE share on
the computer is configured to support reads (advises) but not writes
(pokes).

DDE client error for <service>, <topic>, <item>: (advise timed out)
DDE client error for <service>, <topic>, <item>: (request timed out)
DDE client error for <service>, <topic>, <item>: (poke timed out)
Verify that the server application is running. Verify that the item exists on
the server. If the server is on another computer on the network, verify that
the network is up.
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DDE client error for <service>, <topic>, <item>: (received invalid
data)

DDE server: corrupt data block poked to item <item>, topic <topic>
Either the server received a corrupt data block from the client or the client
received a corrupt data block from the server. This may be the result of
network trouble. If the alarm is consistent and predictable, then you may
have discovered a bug. Call National Instruments technical support for
further help.

DDE server: failed to post advise for item <item>, topic <topic>
Verify that the client application is running. Verify that the item still exists
on the client. If the client is on another computer on the network, verify that
the network is up.
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Networking

With Lookout you can monitor and control your process from any
workstation (node) on the network. You can use the Lookout networking
capabilities to:

*  View the same or different screens simultaneously on separate nodes,
*  Make setpoint adjustments from any node,

*  Acknowledge alarms from any node,

*  Configure specific nodes for monitoring only,

*  Configure a peer-to-peer architecture,

¢ Configure a client-server architecture,

*  Configure network nodes to communicate via standard telephone
lines, and

e  Configure network nodes to communicate via radios.

Networking multiple Lookout nodes is a powerful and advanced capability.
This chapter and the examples in it refer to many concepts and terms
explained elsewhere in the manual. Before attempting to work with
networking, make sure you have a strong understanding of the Lookout
architecture and are comfortable working within Lookout on a single node.

To network using Lookout you must meet the following requirements:

*  You must purchase and install on each computer a separate, licensed
copy of Lookout.

*  You must equip each computer on the network with compatible
network hardware.

*  You must install Microsoft Windows for Workgroups, Windows 95,
or Windows NT on each computer.

Because Lookout is a native Windows application, it supports all the
networks that Microsoft Windows supports, including Microsoft Windows
Network, Microsoft LAN Server, Novell NetWare, Banyan VINES,
3Com 3+Open, DEC Pathworks, IBM LANServer, and so on.
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Networking Considerations

Networking with Lookout is just passing data back and forth between two
or more Lookout nodes. In Lookout, data is passed between and contained
within objects. However, there are two basic methods for passing data
between multiple Lookout nodes. The first method is Multilink
Networking, which requires a NetDDE (Network Dynamic Data Exchange)
link for each and every value being passed between the nodes.

The second method is Table Networking. Table Networking implements a
data concentrator at each node where only tables (which concentrate the
data) are linked between nodes. Although both methods involve connecting
objects over a network using NetDDE, the implementation and total effect
can be quite different.

If you plan to use one of the NetDDE methods, you will have to configure
automatic NetDDE activation and possibly Trusted DDE Shares. See the
Networking with DDE section in this chapter for setup instructions.

There is one more method for implementing network-like capabilities
between multiple Lookout nodes. Unlike the first two methods, however,
this technique does not rely on data being passed between Lookout nodes.
Instead, you use PLCs, RTUs, or I/O to share data between Lookout nodes.
This method is called Hardware Networking.

Multilink Networking

Multilink networking consists of passing data from an object on one
computer to another object on a different computer. Once linked, any
change to the value of one object is instantly propagated to and reflected
by the second object on the other computer.
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Node 1 Node 2
Object 1 |- »{ Object 1
Object 2 |« - Object 2

. - DDE Links between iy .
Object 3 | Objects on Different Nodes P\ Object 3
Object 4 | - Object 4
Object 5 ¢ »| Object 5

Figure 14-1. Multilink Networking

The way in which data is passed between two objects across a network
depends on whether or not they are controllable objects.

Linking Controllable Objects
User-controlled objects have a DDE option. These objects include:
*  Pot objects,
*  Switch objects
e Pushbutton objects.

Controllable objects each have three Position source options: Local,
Remote, and DDE. When you choose DDE, you instruct the object to take
its value from a remote source. This could be a cell in a spreadsheet, another
DDE aware application, or a second copy of Lookout running on the
network.

Linking Controllable Objects Together Across a
Network

You need at least two computers connected by a functioning network to
use the following example. This example refers to the two computers as
Station]1 and Station2.

1. At Stationl, create a Switch object called Switchl. Leave Position
source at the default setting of Local.
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—Position source
& Local
- Remote
On = I EasiticEn = I
off= | " DDE

EEfIEE I
i I
[teri I

Control security lewvel: IU IV Log events

Ok | Cancel |

2. At Station2, create a corresponding Switch object called Switchl.
However, change the Position source to DDE. (Although you are not
required to give objects matching tagnames over a network, it makes
your documentation easier to follow, and your applications easier to

maintain.)
- —Position source
Tag: ISW|tch1
: o  Local
Action verification messages  Bemote
On= I EasitiEhn= I
off= | 4% DDE

Senvice: I\\Stati0n1\NDDE$|
Topic: Ifilename.xls
Iterm: ISwitcm

Control security lewvel: IU IV Log events

(o]

Cancel |

3. In Service, enter \\Stationl\NDDES$, where Stationl is the
network name of the other computer.

Stationl is the network name of the other computer. The
backslashes, NDDE, and dollar sign are required by Microsoft
Windows.

4. In Topic, enter Filenames, where Filename is the name of the
Lookout process file on the other computer.

Again, the dollar sign is required but the . LKP file extension is not.

5. InItem, enter the name of the object at the other computer that you
want to link to (in this case, the other object is also called Switchl).

6. Click on OK.
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Test your network by flipping the switch. When you toggle the switch at
either station, it instantly flips at the other workstation. You can add to,
modify, delete, or revise your logic on either computer, completely on-line,
and still maintain the network link between the two objects.

Linking Non-Controllable Objects

If a Lookout object is not a Pot, Switch, or Pushbutton, it probably does not
have built-in DDE capabilities. However, all you are really trying to do is
pass data between two computers. Once the data is in Lookout, any object
can access it, so you can create a DdeLink object to receive data from
another application using DDE or NetDDE. See the discussion of the
DdeLink object in Chapter 18, Object Class Reference, for more
information. In this example, the other application is Lookout, running on a
second computer.

To Access Real-Time Data at Another Computer

You need at least two computers connected by a functioning network to
follow this example. This example refers to the two computers as Stationl
and Station2.

1. At Stationl, create an Average object. It can average whatever values
you want, but give it the tagname Averagel.

2. AtStation2, create a DdeLink object and name it Averagel. Although
you are not required to give objects matching tagnames over a network,
it makes your applications easier to maintain.

Create DdeLink E
Tag: IAveragm

DDE parameters:

Service: [\\Station1\NDDE$

Topic: Ifilename!B

ltem: IAverage1|

Ok I Cancel
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3. In Service, enter \\Stationl\NDDES, where Stationl is the
network name of the other computer.

Stationl is the network name of the other computer. The
backslashes, NDDE, and dollar sign are required by Microsoft
Windows.

4. In Topic, enter Filenames, where Filename is the name of the
Lookout process file on the other computer.

Again, the dollar sign is required but the . LKP file extension is not.

5. Enter the name of the object at the other computer that you want to link
to in the Item field (in this case, it is also called Averagel).

6. Click on OK.

Finish the definition of the DdeLink object by inserting the DDE
expression into your panel.

After you establish the link, you can connect other objects at Station2 to
the Averagel DdeLink object. Remember, just because you named the
DdeLink object Averagel does not make it a Lookout Average object.
It just receives data from the Average object at Stationl.

Table Networking

Table networking consists of consolidating all the data that needs to be
shared over the network in a single table or array of values. You might think
of these tables as “data concentrators”—although they can do much more
than just serve as a repository for data. See the discussion of the DataTable
object in Chapter 18, Object Class Reference, for more information. You
can link a table via NetDDE to a corresponding table on another computer.
Once linked, the tables update each other on any and all changes within
their databases.

Note Table networking is one of the most involved and advanced concepts in Lookout.
You should have a complete understanding of objects, database connections,
events, and general Lookout architecture before attempting table networking.

Lookout Reference Manual
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Node 1 Node 2

- DDE Link between -
- "Data Concentrators” '@
‘ Object 4

Figure 14-2. Table Networking

Object 4

Linking multiple DataTables for networking purposes is simple enough if
you plan before jumping headfirst into your application. The following
example shows how table networking is done.

This example consists of three computers, each running a copy of Lookout.
Set up three nodes on the network with the names Station1, Station2 and
Station3. Stationl is the only node directly connected to a PLC, but you
want to monitor and control the I/O from any of the three nodes. The
following diagram depicts the network structure of this example.

1/O hardware could
be PLCs, RTUs,
controllers, or any —b‘ PLC ‘ ‘ PLC ‘ ‘ PLC ‘ ‘ PLC ‘
other device Lookout T T " -

communicates with.

&
Station 1 Station 2 ‘ Station 3

Local Area Network

By doing a little planning, you can configure Lookout at Stationl so that
you can reuse its process file at Station2 and Station3. The following
diagram depicts the general design of the Lookout process file at Station].
Notice that driver objects are connected to the DataTable object using
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Lookout Reference Manual

dotted lines while all other objects are connected using solid lines. This is
for illustrative purposes only.

Station 1

(Other)
Object

Driver
Object

(Other)
Object Object

Driver Driver
Object Object

The focus of this picture is the driver objects and their connections to the

DataTable. Eventually you will modify this process file to run at Station2

and Station3 by deleting all connections to Driver objects, and then deleting
the driver objects themselves at Stations 2 and 3.

Driver
Object

(Other)

DataTable
Object

(Other)
Object

It is important to route all signals to and from driver objects through the
DataTable. If you want to display an analog input from a PLC on a control
panel, do not connect the PLC signal directly to the control panel. Instead,
first connect it to the DataTable and then connect the appropriate DataTable
cell to the control panel. If you need to connect an operator setpoint to an
output on a PLC, do not connect the setpoint directly to the PLC. First
connect the setpoint to the DataTable and then connect the appropriate
DataTable cell to the output on your PLC. This is only necessary for signals
that originate from, or are destined for, a driver object. Although this
procedure adds another step to your Lookout configuration for Stationl,
it greatly simplifies the development of the process files for Station2 and
Station3.

Now that you have developed an application at Stationl, move over to
Station2. Copy the process file to the Station2 computer and delete all the
connections to and from your Driver objects. Then delete the Driver objects
themselves.

Remember, you do not want Station2 attempting to communicate with the
PLCs because there is no physical connection to that proprietary network.
Station2 should get its information from Station].
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The only thing left to do is modify the DataTable object at Station?2.
Change its Table location parameter to DDE. In Service, enter
\\Stationl\NDDES. In Topic, enter Filename$, where Filename i
the name of the process file at Station1. In Item, enter the tagname of the
DataTable object at Stationl. Your DataTables are now bidirectionally
connected through a NetDDE link.

At this stage, you can easily add more operator stations to the network.
Copy the process file from Station2 to Station3, or to any number of other
Lookout nodes on the network. No changes to the files themselves are
necessary.

Your Lookout network topography should now look something like this.

Station 1

Driver
Object

(Other)
Object

Driver
Object

(Other)
Object

Driver
Object

(Other)
Object

DataTable
Object

(Other)
Object

Station 2

(Other)
Object

(Other)
Object

DataTable
Object

(Other)
Object

(Other)
Object

Driver
Object
NetDDE

Connections Station 3

(Other)
Object

(Other)
Object

DataTable
Object

(Other)
Object

(Other)
Object
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Hardware Networking

There is one fundamental concept that must be present in order to
implement the Hardware networking method. All Lookout nodes you want
networked must have direct communication access to all your hardware as
displayed in the diagram below. Because of this, the Hardware networking
method is only applicable in certain circumstances.

1/0 hardware could
be PLCs, RTUs,
controllers, or any —b‘ PLC ‘ ‘ PLC ‘ ‘ PLC ‘ ‘ PLC ‘
other device Lookout ‘ ‘ ‘

communicates with.

Station 1 Station 2 Station 3

This is the most straightforward of the three networking methods to
implement. Configure a process file at one node and copy it to all other
nodes that have direct communication access to your hardware. The only
thing to remember when building your process file is to configure all Pots,
Switches, and Pushbuttons with the Remote parameter setting. This
ensures that they stay in sync with the point they are writing to. In other
words, if a switch at one Lookout nodes changes the status of an output, all
the respective switches at the other Lookout nodes will reflect the change
and automatically flip to stay in sync. See the Pot, Switch, and Pushbutton
descriptions in Chapter 18, Object Class Reference, for more information
on the Remote parameter.

Your hardware, network, and communications topology are the
determining factors on whether you can use hardware networking. The
hardware networking method is seldom available because it is rare that all
your Lookout nodes can communicate directly with all your hardware.

Lookout Reference Manual 14-10 © National Instruments Corporation



Chapter 14 Networking

Multilink and Table Networking Comparison

There are advantages and disadvantages to both Multilink and Table
networking. Multilink is quick and easy for small jobs. However, every
NetDDE link requires processor time, so the more links you have, the more
CPU overhead is used. Remember, each value passed between computers
requires a separate DdeLink object. Your computer can quickly become
bogged down if hundreds of links are constantly sending values back and
forth.

On the other hand, while the Table method may require more initial
planning and development time, there will be only one NetDDE link
between computers connecting the DataTables. This method dramatically
reduces the amount of DDE traffic on the network. That is why table
networking is the method of choice for large systems where computers
are sharing hundreds or thousands of values across the network.

So how many points are too many? There is no single answer, but Lookout
has been used with Table Networking method on systems having over
6000 values, and the network update time is well under one second with
only three percent CPU usage.

Networking with DDE

Lookout uses Network DDE (Dynamic Data Exchange) for client/server
networking.

Two components of Microsoft Windows are required when using Network
DDE: the Network DDE agent (NETDDE . EXE) and the NetDDE Share
Database Manager (DSDM). Exactly how these components are used
depends on the operating system on which Lookout runs: Windows for
Workgroups, Windows 95, or Windows NT.

The program NETDDE . EXE is an agent that runs in the background and
transfers DDE messages between computers. This program should be
running before an instance of Lookout is started if you intend for that
session to act as a server. Lookout does not automatically run NETDDE . EXE
itself.
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Running NETDDE.EXE Automatically

The following three sections show how to make sure that NETDDE . EXE
runs every time you start Windows.

Lookout Reference Manual

Windows for Workgroups

1.

In Microsoft Windows, choose the Control Panel icon or run
CONTROL. EXE using the Program Manager File»Run... dialog box.

In the Control Panel window, choose the Network icon.
Click on the Startup option.

In the Startup Settings dialog box, make sure that the Enable Network
DDE box is checked.

Double-click on OK and OK again to close the Control Panel.

Windows 95

In Windows 95, Click Start»Settings»Taskbar...

In the Taskbar Properties dialog box, choose the Start Menu
Programs tab.

Click on the Add... button.

In the Command line field of the Create Shortcut dialog box, enter
NETDDE . EXE; then click Next.

Choose the Start Menu»Programs»StartUp folder, then click Next.

Select a name (such as NetDDE) for the shortcut; select Finish and
OK.

Windows NT

1.

A

In the Program Manager, double-click on the Control Panel icon, or
run CONTROL . EXE using the Program Manager File»Run... dialog
box. If you are using NT version 4.00, click Start, point to Settings,
and choose the Control Panel.

In the Control Panel window, double-click on the Services icon.
From the list of services, select Network DDE.

Click on the Startup... button.

In the Startup Type box, select Automatic.

Select OK and Close to exit the Control Panel.
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Adding a Trusted DDE Share

To allow someone else to connect to a DDE share (for example,
process$) on your computer when you are logged in, you must frust the
DDE share. When another person connects to the share remotely, the
application he connects to is running in your security context, not his own,
because you are the logged-on user. You must give permission for him to
access the share. Even another person who is an administrator cannot trust
a share for your account.

In Windows for Workgroups and Windows 95, trusted shares are
automatically created by Lookout.

In Windows NT, you must use the program DDESHARE . EXE to add a trusted
share. Exactly how you set this up depends on the level of security you
require. The following sequence of steps describes how to set up a share
that gives everyone on the network full DDE access to Lookout:

1. From the Program Manager, select File»Run... If you are using NT
version 4.00, click Start and select Run.

Enter DDESHARE . EXE.

Select Shares»DDE Shares...

In the DDE Shares dialog box, select Add a Share...
In the DDE Share Properties dialog box:

wok w

a. For the Share Name, enter the name of the Lookout process file
that you want to share, omitting the . LKP extension, and adding a
‘$’ at the end. For example, if your process file was
PROCESS . LKP, you would enter:

PROCESSS
on this line.
b. For the Static Application Name, enter Lookout.

c. For the Static Topic Name, enter the process file without
extension, such as PROCESS.

d. Leave the Allow start application and is service boxes
unchecked.

e. Inthe Item Security box, select the Grant access to all
items box.

f.  Click on the Permissions... button.
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g. Inthe DDE Share Name Permissions dialog box:

— In the Names list, select EVERYONE. If there is no entry for
EVERYONE, use the Add... button and associated dialog box
to create it.

—  In the Type of Access box, select Full Control.
—  Select OK.
h. Select OK.

6. You should now be back in the DDE Shares dialog box. Select the
share you just created and click on the Trust Share button.

7. In the Trusted Share Properties dialog box, select the Initiate to
Application Enable button; click on OK.

In the DDE Shares dialog box, click on OK.
9. Exit the DDE Shares program.

Note In order for the DDE share to be available, it must be trusted by the user currently
logged in to the computer (using steps 6 through 9). Alternatively, the share may
be provided as a service by selecting the “Is service” box in the “DDE Share
Properties” dialog box. In this case, the share is always available to anyone listed
in the “DDE Share Name Permissions’ dialog box.

Note When a Lookout client tries to connect to a DDE server on a computer running
NT, it may query the user for a user name and password that are valid on the server
computer. In this case, the user password should not be NULL, or the attempt to
connect to the server will fail.
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Redundancy

With Lookout you can configure two process control computers for
redundancy, providing automatic transfer of control if the primary

computer should fail.

Note This chapter pertains to systems that implement networking of multiple Lookout
nodes. It is not necessary to read this chapter for stand-alone systems. You should
understand process files (. LKP) and state files (.1ST) before using attempting to

use this chapter.

You can set up computer redundancy using the Lookout standby feature.
Standby refers to a network configuration in which one computer is
designated the primary computer and another is designated the standby
computer. The primary computer normally monitors and controls the
process while the standby computer monitors the primary computer. If the
standby node fails to receive a heartbeat from the primary node within a
certain time period, the standby computer automatically takes over and
assumes the role of the primary computer. The following figure depicts a
typical Lookout network structure with the standby option configured.

I/0O hardware could
be PLCs, RTUs,

controllers, or any PLC
other device Lookout -
communicates with. !

| network.lkp
primary.lkp l primary.lkp

Primary Machine Standby Machine

network.lkp

Local Area Network
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Standby Basics

There are three basic principles assumed in the diagram above.

First, both the primary and standby computers must have direct access to
your field I/0O. If the primary computer fails for any reason, you cannot
rely on it anywhere in your backup strategy. Your standby computer
must have the same direct access to all your I/O, because it will assume
the responsibility of the primary computer. There are several ways to
accomplish this, depending on your hardware, network, and
communications topology. Call National Instruments technical support
for suggestions if you need help.

The second principle is that you can designate any node on the network as
the standby computer. It does not need to be the closest physical computer
on the network, though this is typically the case due to the restraints
imposed by the first principle. During normal operations (that is, while
the primary computer if functioning properly), the standby computer is
identical to all other nodes on the network. In other words, Lookout is
running identical process files on all network nodes (NETWORK . LKP in this
example). However, the standby computer should also have a copy of the
primary computer process file in its Lookout directory, PRIMARY . LKP in
this example. As soon as the standby computer fails to receive a scheduled
watchdog signal from the primary, it automatically closes the

NETWORK . LKP process file and opens the PRIMARY . LKP file. From that
point on, the standby node assumes the role of the primary computer and
all other Lookout nodes automatically recognize this fact.

Note When a failover occurs, (that is, when the standby computer takes control of the
process), all Lookout Network DDE links from other computers to the primary
computer are automatically redirected to the standby computer.

The third and last standby principle takes no additional configuration on
your part, but is important to understand for peace of mind. A stand-alone
Lookout application is responsible for periodically updating its own state
file. In a standby system configuration, the primary computer not only
updates its own state file, but also the state file of the standby computer.
When a failover occurs, the standby computer takes over where the primary
computer left off, ensuring bumpless transfer of control.
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Failover Scenarios

There are four reasons for the standby computer to take control of the
process:

e  The primary computer is down (that is, it is not turned on, Windows
is not running, or an application fault has locked the computer).

e The primary computer is running, but it is not running Lookout.

*  The primary computer is running Lookout, but it is not running the
correct process file.

*  The primary computer is running the correct process file within
Lookout, but the two computers cannot communicate over the
network.

The purpose of the standby feature is to provide automatic failover to a
second computer. It does not automatically return to its previous
primary-standby status once your network or other problems are corrected.
Actually, the standby computer will automatically switch back from the
primary process file to the standby process file as soon as it detects that the
primary computer is back up and running. You should, however, copy the
state file from the standby computer back to the primary computer before
restarting Lookout on it if you want a bumpless transfer.

To restore your Lookout network to its original setup (that is, with the
primary computer running its PRIMARY . LKP file and the standby computer
running its NETWORK . LKP file), first ensure bumpless transfer by copying
the state file from the standby computer back to the primary computer. Do
this before you restart Lookout on the primary computer if you want to have
the settings in their current state.

Configuring Standby

Follow this general procedure to implement the Standby feature:

1. Define network settings for both computers. See the To Define
Network Settings section below for information on how.

2. Ensure that the primary computer has network access to the Lookout
directory on the standby computer hard drive. See the To Enable File
Sharing in Windows 3.1.1 and To Enable File Sharing in Windows 95
and Windows NT sections of this chapter for information on how.

3. You must enable file sharing in order for Lookout on the primary
computer to update the state file on the standby computer.
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4. Copy the process file from the primary computer to the Lookout
directory on the standby computer. In the previous example this file
was named PRIMARY . LKP.

5. Configure Lookout standby settings for both computers. See the To
Configure Standby Options section of this chapter for information on
how.

To Define Network Settings

On both the primary and standby computers:
1. In Microsoft Windows, open the Control Panel.
2. In the Control Panel window, choose Network.

3. Inthe Network dialog box, assign the computer a name.

Network EHE

Configuration Identification |Access Controll

Windows uses the following infarmation to identify wour
computer on the network. Flease type a name for this
computer, the waorkgroup it will appear in, and a short
description of the computer.

Computer name: ICDmputer_1

YWarkgroup: ILDDkD ut_Systern
Computer -
Description: Ipcwm%

oK I Cancel

4. Make the Computer Name of the primary and standby computers
consecutive. Give the primary computer the first name of the pair, and
the standby computer the second name of the pair. For example, Xxxa
and xxxB or System01 and System02. Notice in the examples that
the names are identical except for the last character.
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Make sure both computers belong to the same Workgroup.
In the Windows 3.1.1, choose the StartUp option.

In the StartUp Settings dialog box, check the Enable Network DDE
check box.

8. Choose OK to accept your settings.

If you change the settings, the computer prompts you to restart the
computer.

To Enable File Sharing in Windows 3.1.1

1. Configure the standby computer to be able to share files:
In Microsoft Windows 3.1.1, choose the Network Setup icon.
b. Inthe Network Setup dialog box, choose Sharing.
c. In the Sharing dialog box, check the box enabling file access by

others.

'gl 1 want to be able to give others access to my files.
Run ‘File Manager® to share your files with C 1
Ran T

B want to be able to allow others to print to my printer(s].
o

Run "Print Manager’ to share your printer(s] with
others.

If you change the settings, the computer prompts you to restart
Windows.

2. Configure the standby computer so that the Lookout directory on its
hard disk can be shared with the primary computer:

a. In Microsoft Windows, select the file manager icon.

b. In the File Manager window menu bar, select Disk»Share As....
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Share Name: [LODKOUT |
Path: [c\LooKouT | [Cancer |
Comment: | |

[ Re-share at Startup

Access Type: _R§

O Read-Only

Depends on Password

Full Access Password: I:I

[ Passwords:

c. In Path, enter the path name of the Lookout subdirectory. For
example, enter C : \LOOKOUT.

d. In Share Name, enter the name you want to assign to this
directory. Make the name recognizable. In this example, call the
directory LOOKOUT.

e. In the Share Directory dialog box, ensure that the check box
enabling Reshare at Start-Up is selected.

f.  In the Share Directory dialog box, ensure that the check box
enabling Full access is selected and select OK.
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To Enable File Sharing in Windows 95 and Windows NT

1. Configure the standby computer to be able to share files using the
sharing options in the Network control panel.

Lookout_System

2. Select the Lookout directory on the standby computer and configure it
to be shared.
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lookout Properties EHE

General Sharing |

 Mat Shared
— & Shared As:

Share Name: ILDDkDut

Comment; I

MName: Access Rights:

Eemowve | Erlif. |

oK | Cancel | Apply |

3. Using the Add option, add the authorized computers or users you want
to be able to share to. Make sure full access privileges are granted.

To Configure Standby Options

1. On the primary computer:
From the Lookout menu bar, select Options»System....

b. Inthe System Options dialog box, select the check box to enable
Lookout to Save state data every ___ minutes.

You can change the frequency if desired.
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System Options | ]
Startup process file: Ifilename.lkp Log alarms to:
—If security level is below: LPT1:

Lookoutwill always be maximized LPTZ: |

User cannot switch to another prograrm

IB
I_ {limited support for Windows NT) Change Registration Info
4
|4
2

Menu bar will not be visible

tenu and title bars will nat be visible Sy - |
Limit active popups to: |4 {1-94) oK. I
(-9
) Cancel |
—Yirtual Keyboard Pops Up On
[~ Left Mouse Click Iv!
¥ Sawve state file every 300 (114403 minutes
Data files location: Ic:\program filesynational instruments'lookout\citadel’,
Titne zone: ™ Currently within Daylight Savings Time
I(GMT—B:DD) Central Standard Time, Mexico City, Georgetown (Texas) j

2. Inthe System Options dialog box, select the Standby button. You
should now see the Standby Options dialog box.

a. In the Standby Options dialog box, choose Primary computer.

b. In the Save standby state in file data field, enter the full path
name to where you want to save a duplicate copy of the state file
on the standby computer. In this example, the Workgroup network
settings are defined such that drive S: on the primary computer
represents drive C: on the standby computer.

Standby Options | ]
¥ Primary computer

Sawe standhby state in file: ISl\IDDkDut\primary.lst

1 Standby computer

LaEd pracess file

ififie pulsE i EARDREE ISDD SEEEHES

c. Select OK to save your changes.
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Standby Options | ]

T Primary computer

On the standby computer:

In Lookout, select Options»System...
In the System Options dialog box, select the Standby... button.
In the Standby Options dialog box, choose Standby computer.

S standbsstatelfile: I

¥ Standby computer

Load process file IC:\LDDkout\primaw.lkp|

if no pulse from FAROIKOR in |1 50 seconds

In the Load process file data field, enter the full path name of the
process file you want Lookout to automatically load if a failover
situation should occur.

To continue the example, enter:
C:\LOOKOUT\PRIMARY . LKP

Notice that the path name is different from what you entered in
Step le. This is because you are now at the standby computer,
referencing the local hard disk.

In the if no pulse from... data field, enter the desired frequency of
the watchdog timer. The standby computer loads the identified
process file and assumes control of your process if no pulse is
received from the primary computer within the watchdog timeout
period.

Select OK to save your changes.
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This chapter describes Lookout menu bar pull-down commands available
in Normal mode (that is, not Edit) mode.

=~ Lookout - (untitled) - [Control Panel]

Ctrl+0

Every menu command has a predetermined security level associated with
it. Only operators whose security levels are equal to or greater than that of
a particular command can access that menu command. See Chapter 10,
Security, for more information on security.

File Commands

File»New

I

le»0pen

Security Level: 9
Shortcut Keys: <CTRL+N>

The File»New... command is the first step in creating a new process file. It
is important to notice that you must use the File»Save... or File»Save As...
command to save your work and create a new process file.

Security Level: 8
Shortcut Keys: <CTRL+O>
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File»Close

Lookout Reference Manual

Use the File»Open... command to open a process file for execution.
Lookout can only execute one process file at a time. If there is already a
process running, Lookout asks if you want to abort the currently executing
process before it opens a new process file.

When you select File»Open..., a dialog box pops up that you can use to
select the current disk drive/directory and scroll through a list of process
files. Once you find the process file you want to open, click on the file name
in the file list box or type the file name and press the OK button, or just
double-click on the file name in the list box.

Open Process File HE
Look in: IaSamples j gl

File name: ISvgaevaI.Ikp Open

Files of type: IProcess Files™lkp) j el |

If a process file is already open when you select a new file, a message box
pops up asking if you want to abort the current process. The current process
continues to execute until you answer yes.

Security Level: 8
Shortcut Keys: none

The File»Close command halts execution of the currently loaded process
file. If you made changes to your process file and have not saved your work,
Lookout first prompts you to do so before letting you close your process.

Lookout =]

@ Ok to abort current process?

[ila] |
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The process continues to execute until you answer Yes.

A Caution  The File»Close command shuts down process execution—be sure that this is what
you want to do before selecting this command. Your Lookout application may be
controlling critical processes and shutting it down could cause serious problems.

File»Save

Security Level: 9
Shortcut Keys: none
The File»Save command saves the currently executing process to disk.
Lookout replaces the old process file on disk with a new version that
reflects all changes made: new or deleted objects, different display
characteristics, new or modified I/O connections, setpoint adjustments, and
so on. This includes saving changes to the . LKP, . LKS, and the . LST files.
See Chapter 3, Getting Started, for more information about these files.
If you are creating a new process file from scratch, the File»Save command
invokes the Save Process File As... dialog box, prompting you for
instructions on naming the file.

Save Process File As... (2] ]

Save n: IaMy_AppS j gl l_

apps ry_2nd.lkp tabletestlkp

chbscrshts. kg oy 3rellkp tabletest? lkp

dagl lkp nada.lkp therr.lkp

demo.lkp samplel.lkp throttle.lkp

donutlkg scrnshot?.lkp timetstkp.lkp

hyperlkp scrnshotsre.lkp tutarial.lkp

& jrml lkp & spinnerlkp

ry_1stlkp tablesamp.lkp

File name: Inewdemo.lkp \ﬂl

Sawve as type: IProcess Files™lkp) j el |

[ Bratectfile frarm et withyaur sceaunt namey passwerd

File»Reopen

Security Level: 8
Shortcut Keys: none

The File»Reopen command reloads the currently executing process from

disk. This in turn clears all alarms from the alarm window. All trends and
setpoints, however, retain their previous values.
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File»Print»Alarms
File»Print»Events

Security Level: 1
Shortcut Keys: none

Use the File»Print commands to print alarm and event reports. When you
select one of these commands, a dialog box appears, prompting you to
specify the time span to be printed. Use the Print Range option to specify
any arbitrary time span (in military time). Notice that the Alarm and Event
dialog boxes are slightly different. See Chapter 9, Alarms, for more
information on printing alarms.

Print Alarms []
HF Laserlet 4/40 Flus an HF an HF LaserJet 4/4M Plus on HF on
—Printrange—————— - —Printrange——————— -
 Today
 “astarday Cancel | Cancel |
—Printouts ——————— :
 This week
 Lastweek  Snapshot Only & Lesimmal
€ This month & Snapshot & Journal € This month
 Lastmaonth  Lastmaonth
 Thi  Thi
This year  Calumns: This year
 Range:  Range:
i I vV Group i I
To li ¥ Priority To: Ii
mm/dedfyy hhimm ey mrnfddfyy hhemm
Fant... |1D pt Courier Bald Fant... |1D pt Courier Bald

File»Log on

Security Level: 1
Shortcut Keys: <CTRL+L>

Use the File»Log on... command to log on to Lookout as the current
operator/integrator with your predefined account name and
password—although Lookout does not necessarily require a password.
See Chapter 10, Security, for more information.
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le»Log off

File»Password

File»Exit

Chapter 16 Runtime Menu Commands

Welcome to Lookout [<]
Account name: IMy_Name
Fassword: I

Lo | ok | cancel |

Only one person can log on at a time. You can also initiate this command
by clicking on the account box in the status bar near the bottom left hand
corner of the screen, where the account name appears.

Security Level: 1
Shortcut Keys: <CTRL+L>

The File»Log off command instantly logs off the current account name and
leaves (nobody) logged onto the system. You can also initiate this
command by clicking on the account box near the bottom left hand corner
of the screen, where the account name appears. When the Welcome to
Lookout dialog box appears, select the Log Off button. See Chapter 10,
Security, for more information.

Security Level: 1
Shortcut Keys: none

Use the File»Password... command to change a password. People can
easily change their own passwords as needed with this command. Lookout
also keeps track of how old any given password is so that you can monitor
password age. See Chapter 10, Security, for more information.

Security Level: 8
Shortcut Keys: none

The File»Exit command halts the executing process and exits Lookout.
After selecting File»Exit, Lookout gives you the opportunity to save the
process file and asks you to verify that you want to abort the current
process.
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A Caution  The File»Exit command shuts down process execution—be very sure that this is
what you want to do before selecting this command. Your Lookout application may
be controlling critical processes and shutting it down could cause serious
problems.

Edit Command

Edit»Edit Mode

Security Level: 9
Shortcut Keys: <CTRL+SPACE>

The Edit menu commands are only available when Lookout is in Edit
Mode. You can use Edit Mode to create and/or modify a process file. It is
important to notice that Lookout remains on-line, even when in Edit Mode!
Take care when assigning security levels 9 and 10 to system accounts as
anyone with these security levels has access to this command.

The menu bar at the top of the Lookout screen adds additional commands
when you toggle into Edit Mode. You can use these additional commands
for process configuration. See Chapter 17, Edit Mode Menu Commands,
for more information.

Option Commands

Options»System

Lookout Reference Manual

Security Level: 9
Shortcut Keys: none

The Options»System... command is used to configure various
system-level operating parameters. The first parameter, Startup process
file, instructs Lookout to automatically load a predetermined process file
every time it starts. This command, used in conjunction with the method
described in the Automatic Process loading section of Chapter 3, Getting
Started, ensures that any time your computer reboots or Windows restarts,
the appropriate application loads. You can also specify a particular Control
Panel to maximize upon startup. See Panel object definition for additional
information.
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System Options | ]
Startup process file: I Log alarms ta:
—If security level is below: LPT1:

Lookoutwill always be maximized LPTZ: |

User cannot switch to another prograrm
{limited support for Windows NT) Change Registration Info

ID_
ID_

ID_ tenu bar will nat be visible
ID_

0

tenu and title bars will nat be visible Sy - |
Limit active popups to: |4 {1-94) oK. I
(-9
) Cancel |
—Yirtual Keyboard Pops Up On
™ LeftMouse Click ™ Right Mouse Click
¥ Sawve state file every 300 (114403 minutes
Data files location: Ic:\program files\national instruments!loakouty
Titne zone: ™ Currently within Daylight Savings Time
I(GMT—B:DD) Central Standard Time, Mexico City, Georgetown (Texas) j

The second parameter is the Log alarms to setting that defines whether to
send alarm records to the printer automatically as they occur—and if so,
through which port. Alarm records include alarm activation,
acknowledgment, and deactivation. Normally, this should be set to none
and the Lookout File»Print»Alarms... command should be used to print
custom alarm reports on demand.

Use the third set of parameters, in the If security level is below area,
to define windowing limitations based on the security level of the user
currently logged on. See Chapter 10, Security, for more information.

Set the Virtual Keyboard Pops Up On parameter to suit your personal
preference.

The Save state file every v (1-1440) minutes parameter defines the
frequency at which the Lookout State file (. LST) is updated. The Lookout
state file contains setpoints and other important data values held within
objects. It is normally updated when the Lookout application file is saved,
closed or exited. However, hardware on which Lookout is installed may be
vulnerable to power upsets. When there is a power loss, Lookout, like all
software, immediately shuts down. In such cases, it does not have a chance
to update the state file. This parameter tells Lookout to save data to the
state file periodically. On subsequent restart, Lookout reinstates all of the
setpoints and other important data values that were last captured in the
state file.
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Options»Accounts

Lookout Reference Manual

Use the Change Registration Info... button to enter registration data, such
as your key code. See Chapter 2, Introduction, for more information on
Registration.

The Standby... button, configures your system for computer-level
redundancy. See Chapter 15, Redundancy, for more information.

You can set the root directory where Lookout logs your spreadsheet,
Citadel database, event files, and alarm files in this dialog box. In the
figure, Data files location specifies C: \program files\national
instruments\lookout asthe root directory under which all data logging
should begin. Depending on which logging techniques are implemented,
Lookout may store the files in additional subdirectories under the specified
root directory.

Use the Time zone setting to make sure Lookout saves data to the Citadel
database with International Coordinated time stamps (Greenwich Mean
Time.). Based upon your selection, Lookout automatically converts the
International Coordinated time stamps back into local time when plotting
trends. This ensures your database reflects the correct local time wherever
you are using it. Be sure to select Daylight Savings Time when your region
observes these clock adjustments.

Security Level: 10
Shortcut Keys: none

Use the Options»Accounts... command to create, revise, and delete
system user accounts. See Chapter 10, Security, for more information on
accounts.
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Account Maintenance

Create...

aitchrmark

Fewvise..

Delete...

2 accounts listed Digiiiz

du

aitchmark's account

Security level: 10

Last login: MNewer
Idle time: 45 minutes
Logins: 0
Password : Yeas
Fassword age: 0 days

The Options»Modbus... command only appears when a Modbus object
exists in the currently executing process file. This command calls an
information box that describes the Modbus version settings and provides
statistical data on protocol communications. See Chapter 18, Object Class
Reference, for more information on the Modbus object class.

Options»Serial Ports

Security Level: 9
Shortcut Keys: none

Use the Options»Serial Ports... command to configure your computer
serial port communication topology. Each serial port can have a unique
setting: Hardwired, Dial up, or Radio. See Chapter 6, Serial
Communications, for more information.
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Serial Port Settings | ]
Serial port: ICOM1 'l Feceive gap: |5

—Serial connection bytes
-~ .

Hardired BiSidely e 1
A E tifme aut: |1DD

[MEEES

—Dial-up settings

Dialing prefic [aTxamvEDT

Retries: |3—

‘Wait for connection: IBU— seconds
Pause between calls: |2 secands

Defaults | Accept I Cluit |

Options»Import APT Database

The Options»Import APT Database... command only appears if a Tiway
object exists in the currently executing process file. Choose this command
to import an APT tag file and create new database members for the selected
Tiway object. See Chapter 5, Developer Tour, for information on object
databases. Also see Chapter 18, Object Class Reference, for information on
the Tiway Object Class and the APT database.

Run Commands

Run»Add

Lookout Reference Manual

Security Level: 9
Shortcut Keys: none

The Run»Add... command adds up to ten DOS-style commands to the run
submenu list. Operators subsequently invoke these commands with a click
of the mouse—without leaving Lookout. For instance, you might want to

print a custom report on demand. The following example loads Excel and
runs the macro daily.x1m, which pulls historical data off the hard drive,
places it into a preconfigured report template, and sends it to the printer.
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Add Bun Command

Description: IDain Repart
Command Line: Ic:\excel\daily.xlm
Security level |8|—
 |conic
f_ rI:Jdg;:nrrilzed Add Cancel Test

The Security Level setting applies to the any command you are add or
revise. This means you can configure multiple commands, some of which
may only be invoked by high level operators.

Run»Revise
Security Level: 9
Shortcut Keys: none
Use the Run»Revise... command to modify previously configured run
commands.
Revise Run Command
Command: IDain Feport j
Description: IDain Feport
Cormmand Line: IC:\exceI\dain.xlm
Security level |9|
 |conic
& Mormal - I
 Maximized Bevise Cancel Test
Run»Delete

Security Level: 9
Shortcut Keys: none

Use the Run»Delete... to remove previously configured run commands.
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Alarm Commands

Alarms»Show

Security Level: 1
Shortcut Keys: <CTRL+A>

The Alarms»Show command instantly displays the alarm window as a
floating style window if it is not already being displayed. You can select
this command when you want to quickly and easily locate the alarm
window from any location on any control panel. Notice the shortcut
keystroke, <CTRL+A>. You can also call the alarm window by clicking on
the alarm box in the far right end of the status bar at the bottom of the
screen. See Chapter 9, Alarms, for more information.

Alarms»Display Options

Security Level: 1
Shortcut Keys: none

The Alarms»Display Options... command changes the display style of
the alarm window (Top, Bottom, Floating). You can also use this command
to modify internal alarm display formats such as font, header, and various
alarm information. See Chapter 9, Alarms, for more information.

—Window style Show:
 Top V¥ Header
 Bottom vV Group
 Floati ¥ Friority

¥ Tag

—Window height ———

|3 lines (2-20) ’—I
oK
Fant... | Cancel |

10 pt Arial Bold

Alarms»Filter Options

Lookout Reference Manual

Security Level: 2
Shortcut Keys: none
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Use the Alarms»Filter Options... command to filter the alarms displayed
in the alarm window by group, priority, and occurrence. See Chapter 9,
Alarms, for more information on filtering alarms.

Alarm Filters | ]

—Display alarms

¢ host racant occurances At or abowve priority
—Display Groups ———— I1 (1-10)

Include old alarms:

ID (0-500)
Display All |

I~ All groups

All 8 groups selected
¥ Audible alarms Catiee! |

Alarms»Print

Security Level: 1
Shortcut Keys: none

The Alarms»Print... command invokes a dialog box you can use to
specify the time period of the alarms you want to print See Chapter 9,
Alarms, for more information on printing alarms.

Print Alarms | ]

HF Laserdet 4/4h Plus on Optra on

—Printrange—————— -
|

f""Yesterday Cancel
 Pravious 24 hours )
: — Printouts

 This week
 Lastweek C Snapshat Only
" This manth & Snapshot & Journal
 Lastmonth
@ T

Tk — Columns:
 Range:

Frar; Ii ¥ Group
To li ¥ Priority

mm/dedfyy hhimm /Ri=g

Font... | 10 pt Courier Bald
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Alarms»Select All

Security Level: 2
Shortcut Keys: none

The Alarms»Select All command is a shortcut method for selecting all
visible or non-filtered alarms for acknowledgment. Alarms that are not
visible because of filtering or because the alarm window is minimized will
not be selected. This is especially useful if your process is experiencing
high numbers of alarms. Selecting each alarm individually can be very
time consuming. See Chapter 9, Alarms, for more information on
acknowledging alarms.

Alarms»Deselect All

Security Level: 2
Shortcut Keys: none

This command is a shortcut method for deselecting all alarms that are
currently selected for acknowledgment. If you want to deselect only
specific alarms, click on the individual alarm line. See Chapter 9, Alarms,
for more information on acknowledging alarms.

Alarms»Acknowledge

Security Level: 2
Shortcut Keys: none

Operators select the Alarms»Acknowledge... command to acknowledge
alarms that are currently selected for acknowledgment. See Chapter 9,
Alarms, for more information on acknowledging alarms.

Window Commands

Window»Arrange Icons

Window»Arrange Icons arranges the control panel icons across the
bottom of the Lookout workspace in neat columns and rows. Lookout
spaces them according to the setting for icon spacing in the Microsoft
Windows Control Panel.

Window»Minimize All

Lookout Reference Manual

Window»Minimize All minimizes all control panels and displays their
icons across the bottom of the Lookout workspace.
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Window» nTitle

The titles of all control panels appear at the bottom of the Window menu,
each with a number you can use when selecting panels with the keyboard
instead of the mouse. You can locate a particular panel by finding its title
in this list and selecting it. Lookout then displays the panel in the
workspace. Of course, if the panel is outside of the visible workspace, you
may have to scroll around in the workspace to make the panel visible.

Window»More Windows

If you have too many control panels to fit in the window menu, the More
Windows command appears at the bottom of the Window menu. The
Window»More Windows command pops up a dialog box you can use to
scroll through the control panel titles and select the window to display by
double-clicking on the panel title.
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Edit Mode Menu Commands

Note

A Caution

This chapter describes the Lookout menu bar pull-down commands
available in Edit mode. You use Edit mode to perform all system
configuration and editing. To toggle into and out of Edit mode,
select Edit»Edit mode, or press <CTRL+SPACE>.

When you toggle into Edit mode, Lookout adds four additional menu
pull-downs to the menu bar: Insert, Object, Arrange, and Change. In
addition, it adds several submenu commands to the Edit pull-down menu.
This chapter describes all the commands accessible while in Edit mode.

Lookout continues execution of the process file while in Edit mode. From the very
beginning of developing a new process file, Lookout is on-line, running any
control logic you have configured to that point. Create a new object, connection,
or expression and Lookout immediately adds it to the currently running process
file. Because Lookout remains on-line all the time, you never have to shut down
the process to add or delete controllers, I/0 points, or modify your logic.

Take extreme care when assigning security levels 9 and 10 to user accounts. Both
of these security levels can access Edit mode and modify a process file!

Edit Commands

Edit»Undo

Security Level: 9
Shortcut Keys: <CTRL+Z>

You can use the Edit»Undo command to undo the last ten (10) changes
made to a control panel. You cannot, however, undo all changes. You can
only undo graphical changes, not underlying object or logic modifications,
such as connections or ranges.

For example, create several objects and insert them on a control panel. Add
some text. Now move them around the screen, delete them, change fonts,
colors, and so on with the Change menu command. Lookout keeps track of
these graphical changes in a ten-deep stack. You can then select Edit»Undo
and Lookout will undo the most recent change. Select Edit»Undo again
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t»Cut

Ed

Irm

dit»Copy

t»Paste

Irm

d

Note

Lookout Reference Manual

and Lookout will undo the next most recent modification, and so on.
There are several things, such as invoking revise dialog boxes, that can
wipe the Lookout undo buffer clean. Do not be surprised if you cannot
undo something that happened several steps previous to your action.

Security Level: 9
Shortcut Keys: <CTRL+X>

The Edit»Cut command removes selected items from the control panel and
moves them to the Windows Clipboard. You can paste these items back
onto the same control panel or a different control panel.

Security Level: 9
Shortcut Keys: <CTRL+C>

The Edit»Copy command copies selected items from the control panel to
the Windows Clipboard. You can then paste these items onto the same
control panel or a different control panel.

Security Level: 9
Shortcut Keys: <CTRL+V>

The Edit»Paste command retrieves previously cut or copied information
from the Windows Clipboard, and pastes it on the active control panel.
You may repeatedly paste the same information from the Clipboard until
you cut or copy new items into the Clipboard.

When you cut or copy an item on a control panel, Lookout remembers the position
(X-Y pixel coordinate) of the item relative to the source panel upper left corner.
When you subsequently paste the item onto another control panel, Lookout pastes
it at the remembered position. For this reason, when you paste an item onto a
smaller panel, it might not be visible; rather its position may be outside the panel
dimensions (to the right or below). You may have to resize the panel to see the
pasted item.
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Edit»Delete

Edit»Select All

Edit»Edit Mode

Chapter 17 Edit Mode Menu Commands

Security Level: 9
Shortcut Keys: <Delete>

The Edit»Delete command removes the current selection from a control
panel. This command is disabled if nothing is selected. You can delete
individual objects, graphics, and expressions or you can lasso large groups
of items for deletion. If you delete something by mistake, select the
Edit»Undo command and the deleted item reappears on the control panel.

Deleting an object from a control panel only erases the graphical
representation of that object, not the object itself (see the Object»Delete
command later in this chapter). For example, you can display on a control
panel a pulse timer whose output signal is connected to another object. If
you delete the timer display off the screen, the underlying timer object is
still present, working in the background.

Security Level: 9
Shortcut Keys: none

The Edit»Select All command selects all the displayed entities on the
active control panel.

Security Level: 9
Shortcut Keys: <CTRL+SPACE>

This command acts as a toggle switch you can use to flip into and out of
Edit mode. Lookout only toggles to and from edit mode when a process file
is running. When Lookout is in Edit mode, the status bar at the bottom of
the Lookout window changes color from gray to yellow and displays
different information.
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Insert Commands

Insert»Displayable Object

Security Level: 9
Shortcut Keys: <Insert>

The Insert»Displayable Object... command invokes a list box you use to
select a pre-existing object for display on the active control panel. This
command does not create a new object, it inserts on the screen a display
element representing the selected object.

Display Object

1)
AlarmHelpPh
AlarmHelpPhi
ChocolatePipe
CookiePanelPh
CookieRecipe
DatalogTrend
Flow
FootPulse
GasFlowSwitch
GingerPipe
HEANDR
HSPump1
HSPump2
HSPump3
HSPump4
InfaPh
InfaPh1
Log&larmSecPh
LogHelpPh x|

Fushbuttan 117 tags listed

oK | Cancel |

% Note Immediately after clicking on the OK button, a second dialog box appears for you
to use in choosing the display characteristics of the selected object. What this
dialog box looks like depends on the object class of the selected tagname.
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Insert»Expression
Security Level: 9
Shortcut Keys: <CTRL+E>
The Insert»Expression... command is a flexible, real-time calculator.
It creates, calculates, and then displays the result of spreadsheet-style
formulas that include a mixture of constants and signals from objects.
There are over fifty built-in functions that you can use in expressions
including logical, mathematical, statistical, text and trigonometric
functions. See Chapter 7, Expressions, for more information.
Insert expression | ]
|
—Signals:
Paste | $Alarm.active
Tags: Data members:
$keyboard Chemical active
$Swstem Chemical.unacked
AddressPanel comm.active
AddressPh comm.unacked
Alarm1 DDE.active
Alarmz DDE.unacked
Alarm3 Disk.active
Alarmd Disk.unacked
Alarmb Lookout.active
Alarmb x| |Lookoutunacked x|
(class) numeric
)¢ I Cancel |

Insert»Text/Plate/Inset

Security Level: 9
Shortcut Keys: <CTRL+T>

Use Insert»Text/Plate/Inset... to add text and/or three-dimensional
plates and beveled insets to a control panel. This dialog box has two
windows—one to enter the text you want (if any), and another larger
window that serves as a preview screen for your current selections. The
preview window lets you view the display characteristics before you
select OK and insert the text, plate or inset.
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Insert»Graphic
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Insert text/platefinset ]

Text INationaI Instruments

Text colar Bock gy - N
ackground style rame style
EEEEEEEEE’ EEEE ° P S
Background color e ite
D. .. :  Rectangle & Mone
.......  Transparent
 Justify left & Justify centered  Justify right

National Instruments|

| 18 ptArial Bold

You can easily create plates and insets by selecting the appropriate
Background style without entering any text. Plates and insets are useful
tools that you can use generously when creating control panel layouts.
They work especially well for grouping or segregating data. Take a few
minutes to experiment with different fonts, text colors, background colors,
and so on.

Security Level: 9
Shortcut Keys: none

Use the Insert»Graphic... command to display Windows
Device-Independent Bitmap (. BMP) and Windows Metafile (. WMF) graphic
files on a control panel. This dialog box lists all bitmap and Windows
metafiles located in the GRAPHICS subdirectories under the root LOOKOUT
directory. See Chapter 8, Graphics, for more information.
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I_1 arrows
I_1 conveyor
|1 hoppers
Elindicatr}
I_1 meters
-1 misc

I_1 mixers
|1 motors
|1 pipes
|1 pumps
|- switches
|1 system
|_1 tanks

I_1 valves

indicatr
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/;;;,}/////

Cancel |

% [0

v [o

o]

Insert»Scale

Security Level: 9

Shortcut Keys: none

The Insert»Scale... command invokes a dialog box you use to create your
own custom scale in a matter of seconds. Scales are useful with bar graphs,
sliders and trend charts.

© MNational Instruments Corporation
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Insert scale | ]
Crientation
Minimurm: ID
10 10 )
} E 0| Maximurn: 100
n @ 0 10

Major unit: |1D
o ° m,.9 Tl . .
10% Eo i hinor unit: |2.5

left side, increasing up V Minor tick marks

o Lefoefs Lakel format: ﬂl

Lakel font... | IGeneraI j
18 pt Arial Bold

Click on the Orientation you want and fill in the Minimum and
Maximum values for the scale. Major unit specifies the number of units
between major tick marks. Only major units have labels. You can remove
labels from your scale altogether by deselecting the Labels box. Minor
unit specifies the number of units between minor tick marks. You can
remove minor tick marks by deselecting the Minor tick marks box.
Color, Label format, and Label font can be specified for special effects.

Insert»Control Panel

Security Level: 9
Shortcut Keys: <CTRL+P>

Use the Insert»Control Panel... command to add control panels to your
process. Control panels are objects and, therefore, must have unique Tag
names. However, you can repeat the Title of a control panel as many times
as you want. Additionally, you do not have to follow the tagname syntax
guidelines when filling out a panel Title field. See the Panel object in
Chapter 18, Object Class Reference, for more information.
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New Control Panel
Tag: IPaneI3

Title: Ipressure gauges|

—Panel type Background color:

& Mormal

Ll [ ||
 FPopup ........

 Popup no icon

— Security levels
Yiewing: ID

R
widtn, [512
Contral: ID 4|

Height: |384 Cancel

Insert»Positions
Security Level: 9
Shortcut Keys: none
& right of
O |eft of
 ahove
" helow
" centered on
current selection
by |1 0 pixels
Cancel |
The Insert»Positions... command tells Lookout where on a control panel
to place the next inserted item. The direction and distance specified by this
dialog box are relative to the currently selected item on the active control
panel.
© National Instruments Corporation 17-9
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The following example demonstrates how the position settings would work
in a typical case

 Control Panel  Control Panel

Select a bar graph The next item is inserted
10 pixels to the right of the
selected item.
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Object Commands

Object»Create

Security Level: 9
Shortcut Keys: <CTRL+Insert>

¥ Categorize
= —Histagram

1 Calculation Calculate and display the distribution of a sampled signal.
&= Cl_:mtml Also display the central tendency and wariahility of the
|1 Display sample set. Calculate the process capability ratio (PCR).
|1 Drivers confidence interval, mean, variance and standard
|1 Drivers (Applicom) dewviation.
|1 Logging
|_1 Monitoring
|_1 Networking
a_ Statistical Process Control

: el

File Marne: HISTOGRM.CBX
Date Modified:  Fri kar 06 20:07:56 1998
File Size: 87552 bytes

I_1 Timers

Ok I Cancel

The Object»Create... command invokes the Select Object Class dialog
box. This list box displays all the available object classes divided into
categories. Objects in each category are listed in alphabetical order. You
can select an object class with the mouse and select the OK button—or just
double-click on the class. See Chapter 18, Object Class Reference, for
more information on specific objects.

Deselecting the Categorize checkbox lists all Lookout objects
alphabetically.
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Lookout Reference Manual

Create pushbutton | ]
Tag: IReset_Pb

Button text: IResetaII counters

Watify on = I“DD youwant to do this?"]

—Position source

& Local
- Remote

EasiticEn = I

7 it output

' DDE

EEfIEE I
i I
[teri I

Contral security level: ID V¥ Log evants

oK I Cancel |

After choosing an object class, Lookout displays a dialog box that you use
to define the object parameters. Fill in the parameters according to your
requirements and click on OK. See Chapter 18, Object Class Reference,
for more information on object classes.

When you click on the OK button, Lookout creates a new object with the
specified connections, if any. Lookout does not have to display objects on
a control panel; they can exist without being displayed. However, many
objects immediately prompt you to select display characteristics for
insertion on a control panel (for example, the Pushbutton object).

If you select Cancel, Lookout does not display the object you just created.
However, the object still exists. You can display the object at a later time
using the Insert»Displayable Object... command.
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Chapter 17 Edit Mode Menu Commands

Display pushbutton: Reset_Pb | ]
Text calor Sz
& Button

. .. . & Transparent
HEEEEEEEE EEEE
Button colar 0K |

[N N -EE
ECEEEEEN | EEE o |

 Justify left & Justify centered  Justify right

Reset all counters

Font... |1BptAriaIElold

Security Level: 9
Shortcut Keys: none

© MNational Instruments Corporation

Select object to modify: | ]

FawPumpTrendPanel =]
FawPurmpTrendPh

FawPumpTrendPhl

FawPurmpTrends

FecipeCountF

FecipeCount3

FecipelLatch

FecipePulseF

FecipePulseh

FecipePulses

FecipeStartPh

FecipeStopPh

Fecipevakes J
FegionalHelpPanel

FegionalHelpPh

FegionalHelpPhl

FegionalPanel

ReEionale

RunPh
EunPhi
SecPil
SecPh? =
’TI Cancel |
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Use the Object»Modify... command to edit any pre-existing object, no
matter what class the object belongs to. This command invokes a dialog box
with an alphabetical listing of all existing tagnames.

Choose a tagname and click on OK, or just double-click on the tagname.

A dialog box for the identified object appears with the pre-existing
parameters already filled in. You can modify the object by altering its
parameters—even change the tagname. See Configuration Shortcuts in
Chapter 3, Getting Started, for more information on modifying objects.

Note Changing the tagname does not create a second, new object. It replaces the
existing tagname with a new one. Also, all other connected objects immediately
reflect the new tagname.

Revise pushbutton: | ]
Tag:

Button text: IResetaII counters

Watify on = I“DD wouwant to do this?"

—Position source

& Local
- Remote

EasiticEn = I

7 it output

' DDE

EEfIEE I
i I
[teri I

Contral security level: ID V¥ Log evants

oK | Cancel |
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Object»Delete

Security Level: 9
Shortcut Keys: none

Select object to delete: | ]
FecipelLatch =]

FecipePulseF
FecipePulseh
FecipePulses
FecipeStartPh
FecipeStopPh
Fecipevakes
FegionalHelpPanel
FegionalHelpPh
FegionalHelpPhl
FegionalPanel
FegionalPh

RunPh J
FunPhb1

SecPhbl

SecPhb2

SecPhb3

SecPotl

SecPot2

SecPot3

SecPot4

SecPots x|

Use the Object»Delete... command to choose a specific object from an
alphabetical list and delete it. The Select Object dialog box appears,
prompting you to pick a tagname for deletion.

If you select an object that another object is using (that is, another object is
connected to it), or that is displayed on a control panel, Lookout refuses to
permit the deletion and gives a warning. You must first delete all references
to, and displays of, the object you want to delete.

Reset_PB <]

° Cannot delete object due to dependencies

Objects are not the only things that can be dependent on other objects.
Expressions that use the tagname of an object you are trying to delete also
create a dependency.
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i Note If you think you have deleted all the dependencies of an object and still get this
message box, you may want to look at the source file for your process (. LKS file).
You can then do a search command with your text editor or word processor to find
all occurrences of the problem tagname.

Object»Edit Connections

Security Level: 9
Shortcut Keys: none

Use the Object»Edit Connections... command to tie signals to writable
data members of an object. You most commonly use this command to
connect signals to outputs on controllers and other field devices (PLCs,
RTUs, Loop Controllers, and so on). Other object classes such as Pots and
Panels also take advantage of this function. See Chapter 5, Developer Tour,
for more information on connecting objects.

When you select Object»Edit Connections..., notice that many tagnames
are not listed. Lookout displays only the objects that accept signals. See
Chapter 5, Developer Tour, for more information.

Object»Edit Database

Security Level: 9
Shortcut Keys: none

Use the Object»Edit Database... command to define parameters of the
database members for an object. These include alias names, descriptions,
alarm parameters, scaling parameters, logging parameters, and so on. You
can also use this command to import and export databases. You most
commonly use this command in association with DataTables and driver
objects. See Chapter 5, Developer Tour, for more information on database
editing.

Arrange Commands

Lookout Reference Manual

The Arrange commands are useful tools for quickly building professional
looking control panels. Understanding and mastering these commands
significantly speeds up development time and improves the look and feel
of your screens. Although this manual explains the functionality of each
command, the best way to familiarize yourself with the entire command set
is to experiment with commands individually.
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Arrange»Align

Security Level: 9
Shortcut Keys: none

The Align command organizes a group of selected objects on a control
panel. It is often used in conjunction with the Arrange»Space Evenly
command. First select the objects you want to align. Then select the
appropriate align command (described in the following table).

Command Description Shortcut Key

Left Aligns selected symbols to the left | <CTRL+LEFT>
side of the bounding box

Right Aligns selected symbols to the <CTRL+RIGHT>
right side of the bounding box

Top Aligns selected symbols to the top | <CTRL+UP>
of the bounding box

Bottom Aligns selected symbols to the <CTRL+DOWN>
bottom of the bounding box

Vert. Center | Aligns selected symbols to the <F9>
vertical center of the bounding box

Horiz. Aligns selected symbols to the <SHIFT+F9>

Center horizontal center of the bounding
box

Note Instead of selecting an entire group of objects by click-dragging, you can select

multiple objects by holding the <SHIFT> key down while individually selecting
each object. You can also use this technique to skip objects that you would
otherwise select within the bounding box.

Arrange»Space Evenly
Security Level: 9

This command is useful when trying to align and evenly space a number of
objects on a control panel. Lookout evenly spaces the selected objects, on

their centers, either across or down the bounding box. As mentioned above,
this command is often used in conjunction with the Align command.
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Arrange»Group

Arrange»Ungroup

Command Description Shortcut Key

Across Evenly spaces the selected objects <ALT+RIGHT>
horizontally across the bounding box

Down Evenly spaces the selected objects <ALT+DOWN>
horizontally down the bounding box

Security Level: 9
Shortcut Keys: <CTRL+G>

The Arrange»Group command combines the selected individual objects,
including text, into a single unit. This command is typically used to
combine or group multiple related objects for further alignment. You can
also create layered subgroups (that is, groups within larger groups).

Security Level: 9
Shortcut Keys: <CTRL+U>

The Arrange»Ungroup command ungroups the currently selected group
into its various components. This command works on only one group at a
time. If you have layered subgroups, you can selectively ungroup them one
layer at a time. Notice that if two separate groups are selected in a single
lasso, the Arrange»Ungroup command is not available.

Arrange»Move to Front

Security Level: 9
Shortcut Keys: <CTRL+F>

Arrange»Move to Front moves the currently selected item(s) on top of all
the other items, shifting all other displayed items back.

Arrange»Move to Back

Lookout Reference Manual

Security Level: 9
Shortcut Keys: <CTRL+B>

Arrange»Move to Back moves the currently selected item(s) behind all

the other items, shifting all other displayed items closer to the front.
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Change Functions

Chapter 17

Edit Mode Menu Commands

Change»Font

Change»Text Color

© MNational Instruments Corporation

Use change functions to modify how text, bar charts, numeric and slider
representations of pot objects and other display elements look on the
screen. This is a useful tool for quickly making global changes to many
items at once (for instance, to change the text color for all items currently
selected). It is also the only way to change the background color of a slider.

Security Level: 9
Shortcut Keys: none

Change»Font... invokes a dialog box that modifies the font on all the

currently selected items.

Font

Font: Font style:

[arial Bold
Fegular =]

T Arial Black 1 ltalic

T Arial Narrow

T Arial Rounded MT Bold Bold Italic

T Book Antiqua

T Bookman Old Style

T Bookshelf Symbol 1 x| =l
—Sample

AaBbYyZz

Script:
IWestern j

Security Level: 9
Shortcut Keys: none

Change»Text Color... invokes a dialog box that you can use to modify the
text color of all the currently selected items. This command also affects the

bar (foreground) color on bar graphs.
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Change Text Color

| [
CONENEEENE "EER
Text CO|0I’- oK, I Cancel |

Change»Background Color

Security Level: 9
Shortcut Keys: none

Change»Background Color... invokes a dialog box that modifies of the
background color on all the currently selected items.

L L
HENENENEN
oK I Cancel |

Change»Numeric Format

Security Level: 9
Shortcut Keys: none

Change»Numeric Format... invokes a dialog box you can use to change
the numeric format on all the currently selected items. See Numeric Data
Members in Chapter 2, Introduction, for more information on numeric
formats.

Change Format | ]

|n.n

0.00 =
0.000

0.0000

0.00000

0.000000

0.0000000 x|

Cancel |
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Change»Justify Text

Chapter 17

Security Level: 9
Shortcut Keys: none

Edit Mode Menu Commands

The Change»Justify Text subcommands modify text alignment on all the
currently selected text items. This command also applies to digitally

displayed data.
Command Description Shortcut Key
Left Aligns selected text and data to the none
left side
Right Aligns selected text and data to the none
right side
Center Centers selected text and data none

© MNational Instruments Corporation
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Part i

Object Reference

Chapter 18, Object Class Reference, describes Lookout object classes,
listed in alphabetical order. Input parameter syntax and data members

are documented for each object class, along with a description of the
functionality of each object class and an example of how to use the object.

Both the Lookout native objects and the various driver objects are detailed
in this section.
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Object Class Reference

This chapter describes Lookout object classes, listed in alphabetical order.
Input parameter syntax and data members are documented for each object
class, along with a description of the functionality of each object class.

Note Lookout assists you in building graphical screen displays when possible.
Immediately after creating a new object that supports implicit data members or
is displayable, Lookout automatically invokes another dialog box. If the object is
displayable (like Pots, Switches, and Trends), the appropriate Display Parameter
dialog box appears, prompting you to select a display type. If the object is not
displayable but supports an implicit signal (like Counters, LatchGates and
OneShots), Lookout automatically invokes the Insert Expression dialog box and
pastes the appropriate tagname in the window. You can then click on the OK
button to display the result of the signal as an expression on a control panel.

You can elect to not display an object or its signal by clicking on the
Cancel button at any time. If you change your mind later, you can display
the object or its signal using the Insert»Displayable Object... or
Insert»Expression... commands, respectively.

Some object classes have neither a display member nor an implicit
signal—instead they have multiple data members. In these cases, Lookout
does not automatically invoke a second dialog box. However, if you want
to display the result of a logical or numeric data members on a control
panel, you can use the Insert»Expression... command and choose the
appropriate tagname and data member.

See Chapter 5, Developer Tour, for more information on creating objects,
modifying their databases, and linking them together.
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AB_PLC2,
AB_PLC5,
AB_SLC500

Lookout uses the AB object classes to communicate with the Allen-Bradley
family of PLC controllers using a variety of interfaces.

Lookout can communicate with a member of the PLC-2 family in the
following ways:

Through a Data Highway Plus (DH+) connection to an Allen-Bradley
1785-KA3 PLC-2 adapter module using an Allen-Bradley 1784-KT,
1784-KTx, or 1784-PCMK card, or an S-S Technologies 5136-SD
direct-link interface card installed in the computer,

Through the serial port using an Allen-Bradley KF2 module (which
converts serial DF1 to DH+) to an Allen-Bradley 1785-KA3 PLC-2
adapter module, or

Through a direct DF1 serial connection to the PLC programming port.

Lookout can communicate with a member of the PLC-5 family in the
following ways:

Through a direct Ethernet connection to the PLC AUI port,

Through a direct DH+ connection using a 1784-KT, 1784-KTkx,
1784-PCMK, or 5136-SD card installed in the computer,

Through the serial port via a KF2 module which converts serial DF1
to DH+, or

Through a direct DF1 serial connection to the PLC programming port.

Lookout can communicate with a member of the SLC-500 family in the
following ways:

Lookout Reference Manual

Through a direct DH+ connection using a 1784-KT, 1784-KTx,
1784-PCMK, or 5136-SD card installed in the computer,

Through the serial port via a KF2 module which converts serial DF1
to DH+,

Through the serial port using an Allen-Bradley 1747-KE card
(which plugs into the SLC chassis and converts DF1 to DH 485),

Through the serial port using a stand-alone Allen-Bradley 1770-KF3
communication interface module which converts DF1 to DH 485,
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*  Through a direct DF1 serial connection to a SLC 5/03 or SLC 5/04
programming port, or

*  Through a direct DH485 connection using a 1784-PCMK card in
conjunction with either a 1747-AIC or 1761-NET-AIC module.

Create Allen-Bradley PLC-5 | ]
Tag: FLC Address (0-77):
[281 f1 actal
Interface: PLC model:
[s-25136-3D =l |pcsis =l
—1784-KT card settings
Card number
’76‘1 g2 3 4 C85 CE 7 C8 ‘
Mermory address: Fort: MNode address:
{D400 = feso Bl o octal
[~ Card exists in this computer Baud rate:
IS?.Bk vl
IR 3 4 (ol 7 8

fallcards) «~10 11 ¢©12 €15 & none

FollRate-  |001 [ o ]
Fall= I Cancel |
Communication alarm priority: IB—

Fetry attermpts: |4— Feceive timeout:  |300 msecs
Skip every IE— poll requests after comm failure

Figure 18-1. Allen-Bradley Parameter Dialog Box

PLC Address refers to the PLC network node address setting as
configured on the physical device. If devices share a common Interface,
they require unique addresses. When using DF1 protocol (serial
communications), valid addresses range from 0 to 254 decimal. When
using DH+, valid addresses range from O to 77 octal.

PLC Model specifies the particular type of PLC or SLC you are
representing with this object. The PLC Model you select determines
what native data members comprise the object.

PollRate is a numeric expression that determines how often to poll the
device. Lookout polls the device at the specified time interval. Normally,
this is a simple time constant such as 0:01 (one second). See Numeric Data
Members in Chapter 2, Introduction, for information on entering time
constants.
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Poll is a logical expression. When this expression changes from false to
true, Lookout polls the device. You can use a simple expression like the
signal from a pushbutton, or a complex algorithm.

Communication alarm priority determines the priority level of the
alarms generated by the AB object.

Retry attempts specifies the consecutive number of times Lookout
attempts to establish communications with a device if it is not getting a
valid response. After it tries the number of Retry attempts specified, the
object generates an alarm and begins to Skip every n poll requests after
comm failure. Once Lookout reestablishes communications, it polls the
device on its regular cycle, as defined by PollRate.

Receive timeout is the time delay Lookout waits for a response from a
device before retrying the poll request.

Interface identifies the type of communication hardware you are using.
The selection you make here determines what protocol parameters you
have to specify. The paragraphs that follow describe interface-specific
protocol parameters.

Allen-Bradley Serial Port Interface Parameters

Lookout Reference Manual

The KE/KF/Serial Interface selection enables serial port
communication via a KE card, a KF3 module or KF2 module. When
using your serial port, Lookout employs the Allen-Bradley full-duplex
(peer-to-peer) DF1 protocol. The previous diagram shows an Allen
Bradley object configured for serial communications.

Serial port specifies which RS-232C port the object uses for
communication to the physical device.

Data rate, Parity, and Error detection reference the settings on the
hardware device. The AB object classes support both BCC (block check
character) and CRC (cyclic redundancy check) error detection. BCC
provides a medium level of data security. CRC ensures a higher level of
data security. Choose the settings as configured on your PLC or SLC.

Phone number specifies the number to be dialed if the serial port setting
is configured for dial-up. This number only applies to the individual object.
See Options»Serial Ports of Chapter 17, Edit Mode Menu Commands, for
more information.
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Allen-Bradley DH+ Interface Parameters

1= Note When you configure an AB_PLC2, AB_PLCS, or AB_SLC500 for DH+, Lookout
creates a file called n1L1LBRAD . INI. This file contains the configuration settings
that you enter for your KT card(s). If you plan to run the process file on a Lookout
Runtime System, be sure to copy the INI file along with your process (. LKP) file

to the target computer.

The 1784-KT, 1784-KTx, 1784-PCMK, and S-S 5136-5D Interface
selections enable direct connection of your computer to a DH+ network.
The diagram below shows an AB_SLC500 configured for DH+
communications using a 1784-KTx card.

Create Allen-Bradley SLC-500 | ]

Tag: FLC Address (0-77):
[281 f1 actal

Interface: FLC model:

[DH+ Direct) I SLCE/04 4 l

—1784-KT card settings

(3'1("2("3(“4(“5("8("?(“8‘

Mermory address: MNode address:
|D4DD 'l ID octal

’—Card number

™ Card exists in this cormputer Baud rate:

57 6k A
IRQ: 3 4 (ol 7 8
(gllcards) =10 11 12 15 none
PollFiate = IDiD1 | Ok I

Communication alarm priority:

Fall= I Cancel |
IB

Retry attempts: |4 Feceive timeout:  |300 msecs
Skip every |5 poll requests after comm failure

Figure 18-2. AB_SLC-500 Definition Parameters Dialog Box Configured
for DH+ Communications

Card number selects which network interface card that the PLC is
connected to in case your computer has multiple KT or S-S cards.

Card DH+ node address identifies the address of the interface card in the
DH+ network. Valid addresses range from O to 77 octal. The node address
of the card must be unique—that is, it must not be the same as the address

of any other device on the DH+ network.
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Memory address specifies the base address location of the selected
interface card memory. Your selection should match the settings on the
card. If you are using multiple interface cards, be sure each card has a
unique address. The network interface cards use dual-ported memory.
For this reason, if you are using a memory manager such as EMM386 it
is important to add a memory exclusion statement to your CONFIG.SYS
file. The table on the following page lists base memory address selections
and corresponding exclusions for all legal memory addresses for the
1784-KT card.

The 1784-KT interface card has on-board network termination resistors.
If you are using such a card and if your computer is the last node on the
network and if the cable does not already have a terminating resistor on it,
then select the Enable link termination resistor check box.

Use the Card exists in this computer check box to instruct Lookout
whether or not to look for the interface card in the computer. Be sure to
check this box when you are ready to start polling your PLCs. When you
check this box and select OK, Lookout initializes the card, activates its
self-test, and downloads its driver firmware. Then polling begins. Leave
the Card exists in this computer check box deselected (this is the default
setting) if the card is not in your computer (for example, if you are
developing a process on a computer different from the one that will be
running the process) or if you do not want to poll any PLC connected to the
card.

If you deselect the Card exists in this computer check box, you are
disabling communications using this interface card with all PLCs
connected to it.

Table 18-1. Allen-Bradley DH+ Interface Memory Addresses

AB 1784-KTx
Memory AB 1784-KT 1784-PCMK SS-5136-SD
Address Exclude Exclude Exclude* Recommendation
A000 A300-A3FF A000-AOFF A000-A3FF Typically used by VGA
dri . Use if th
A400 AT00-ATFF | A400-A4FF | A400-A7FF rvers, tse I 1o Other
option is available.
A800 ABO00-ABFF A800-A8FF A800-ABFF
ACO00 AF00-AFFF ACO00-ACFF ACO00-AFFF
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Table 18-1. Allen-Bradley DH+ Interface Memory Addresses (Continued)

AB 1784-KTx
Memory AB 1784-KT 1784-PCMK SS-5136-SD
Address Exclude Exclude Exclude* Recommendation

B000 B300-B3FF B000-BOFF B000-B3FF Used by MDA & CGA
drivers. Use if no Dxxx

B400 B700-B7FF B400-B4FF B400-B7FF .. .
option is available.

B800 BBO00-BBFF B800-B8FF B800-BBFF

BCO00 BFO00-BFFF BCO00-BCFF BCO00-BFFF

C000 C300-C3FF C000-COFF C000-C3FF Typically used by BIOS.
Use if no D tion i

C400 C700-C7TFF | C400-CAFF | C400-C7FF se 11 10 XA OPHOR IS
available.

C800 CBO00-CBFF C800-C8FF C800-CBFF

CC00 CF00-CFFF CCO00-CCFF CCO00-CFFF

D000 D300-D3FF DO000-DOFF DO000-D3FF Normally available.Try to
use one of these first.

D400 D700-D7FF D400-D4FF D400-D7FF

D800 DBO00-DBFF D800-D8FF D800-DBFF

DC00 DFO00-DFFF DCO00-DCFF DCO00-DFFF

* The 5136-SD memory exclusions recommended above are based on 16K memory mapping. Because you are using the

SS card to emulate the KT card, there is no advantage to using its 32K memory access capability.

© National Instruments Corporation 18-7

Baud rate (1784-KTx, 1784-PCMK, 5136-SD only) selects the baud rate
of the DH+ network. The default is 57.6k baud. Before selecting a higher
baud rate, be aware of that only a few PLCs (such as the SLC5/04) support
higher baud rates; that every node on a DH+ network must support the baud
rate used on that network; that the maximum network cable length is
smaller for higher baud rates; and that the correct values for the termination
resistors at the ends of the network cable are different for higher baud rates.
Consult the manuals that came with your hardware for more detailed
information.

IRQ (all cards) identifies the interrupt setting of all DH+ interface cards
installed in the computer. This selection should match the IRQ settings
on all of the interface cards.

Assigning an interrupt to the interface card(s) improves overall computer
performance somewhat. Any time one of the cards receives an input, it
generates an interrupt recognized by Lookout.
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A Caution

Object Class Reference

Allen-Bradley Ethernet Interface Parameters

The Ethernet Interface selection enables direct communication between
your computer and a PLC using a standard Ethernet network. The
following diagram shows an AB_PLC5 configured for Ethernet

Lookout Reference Manual

Be sure to verify that no other drivers or cards are mapped to the selected memory
address or use the same interrupt.

communications.
Create Allen-Bradley PLC-5 | ]
Tag:
81
Interface: PLC model:
[Etheret =l |pcsis =l
—Ethernet settings
IPaddress:  [199.1.14]
FollRate-  |001 [ o ]
Pall - f —
ance |
Communication alarm priority: IB
Retry attempts: |4 Feceive timeout:  |300 msecs
Skip every |5 poll requests after comm failure

Figure 18-3. AB_PLC5 Definition Parameters Dialog Box Configured

for Ethernet Communications

IP address specifies the Internet protocol address of the PLC. An Internet
protocol address consists of four numbers, separated by periods. Each
number ranges from zero to 255 decimal. Thus, a typical Internet address
might be 128.7.9.231. Ensure that the IP address you enter matches the
Internet protocol address of the PLC your object represents. You can also

enter the IP address by name.

18-8
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Using the 5136-SD card from S-S Technolog

To use the 5136-SD card, select the

Chapter 18 Object Class Reference

ies, Inc.
S-S 5136-SD interface in the Create

Object dialog box. It is not necessary to run the sdinst . exe program that
ships with the card because Lookout downloads the KT-emulation module
automatically as part of the initialization process. It is, however, necessary
to tell Lookout the port address specified by the switch settings on the card.

Create Allen-Bradley PLC-5 | ]
Tag: FLC Address (0-77):
[281 f1 actal
Interface: PLC model:
[s-25136-3D =l |pcsis =l
—1784-KT card settings

Card number
’7(3‘1 g2 3 4 C85 CE 7 C8 ‘
Mermory address: Fort: MNode address:
{D400 = feso Bl o octal
™ Card exists in this cormputer Baud rate:

576k -

IR 3 4 (ol 7 8
(allcards) 40 11 12 15 & none
FollRate-  |001 [ o ]
Pall - f

Communication alarm priority:

Ia— Cancel |

Retry attempts: |4 Receive timeout.  |500

Skip every |5 poll requests after comm failure

Msecs

Figure 18-4. AB_PLC5 Definition Parameters Dialog Box Configured

for the 5136-SD card

Allen-Bradley Data Members

Each AB object contains a great deal of data. All readable and writable
members (inputs/outputs) are bundled with the object. As soon as you
create an AB object you immediately have access to all the object data

members.

The AB object classes automatically generate an efficient read/write
blocking scheme based on the inputs and outputs you are using in your
process file. You are not required to build your own I/O blocking table.
However, you can ensure peak performance by organizing your PLC data

into contiguous groups.

© MNational Instruments Corporation 18-9
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Table 18-2. AB_PLC2 Data Members

Data Member Type Read | Write Description
0-7777 numeric yes yes 16-bit signed binary word ranging from
-32,768 to +32,767
0_0-7777_17 logical yes no One bit within a 16-bit binary word
CommPFail logical yes no Object-generated signal that is ON if,

for any reason, Lookout cannot
communicate with the PLC.

OffHook logical no yes When true, instructs the PLC to retain
exclusive use of its assigned
communication port. This prevents
Lookout from hanging up between
polls, saving the redial overhead. This
also prevents other blocks from
communicating over the same channel.

Poll logical no yes When transitioned from false to true,
the Lookout object polls the PLC device

PollRate numeric no yes Specifies the frequency at which the
Lookout object polls the PLC device

Update logical yes no Object-generated signal that pulses
each time the object polls the device

Table 18-3. AB_SLC500 Data Members

Data Member Type Read | Write Description
B:0 - B255:255 numeric yes yes 16-bit signed binary word ranging from
—32,768 to +32,767
B:0_0-B255:255_15 logical yes yes One bit within a 16-bit binary word
B_0 - B255_4095 logical yes yes One bit within the specified datafile.

For example, B3_32 specifies datafile
3, word 2, bit 1.

C:0.ACC - numeric yes yes Counter accumulated value. Two-byte
C255:255.ACC signed word ranging from —32,768 to
+32,767
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Table 18-3. AB_SLC500 Data Members (Continued)

Data Member Type Read | Write Description

C:0.PRE - C255:255.PRE numeric yes yes Preset counter value. Two-byte signed
word ranging from —-32,768 to +32,767

C:CD -C255:CD logical yes yes Counter down-enable bit.

C:0_CU - C255:255_CU | logical yes yes Counter up-enable bit.

C:0_DN -C:255:255_DN| logical yes yes Counter done bit.

C:0_OV - (C255:255_0V| logical yes yes Counter overflow bit.

C:0_UA - C255:255_UA| logical yes yes Counter update accumulation bit
(HSC in fixed controller only)

C:0_UN - C255:255_UN| logical yes yes Counter underflow bit.

CommPFail logical yes no Object-generated signal that is ON if,

for any reason, Lookout cannot
communicate with the SLC.

F:0-F255:255 numeric yes yes Floating point value

I:1-1:30 numeric yes yes Unsigned 16-bit input value ranging
from 0 to 65,535

:1_0-1:30_15 logical yes yes One bit within a 16-bit input word

N:0 - N255:255 numeric yes yes 16-bit signed integer value ranging
from -32,768 to +32,767.

N:0_0 - N255:255_15 logical yes yes One bit within a 16-bit signed integer
word

0:1-0:30 numeric yes yes Unsigned 16-bit output value ranging
from O to 65,535

0:1_0-0:30_15 logical yes yes One bit within a 16-bit output word

OffHook logical no yes When true, instructs the PLC to retain

exclusive use of its assigned
communication port. This prevents
Lookout from hanging up between
polls, saving the redial overhead.

This also prevents other blocks from
communicating over the same channel.
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Table 18-3. AB_SLC500 Data Members (Continued)

Data Member Type Read | Write Description
Poll logical no yes When transitioned from false to true,
the Lookout object polls the SLC device
PollRate numeric no yes Specifies the frequency at which the
Lookout object polls the SLC device
R:0.LEN - numeric yes yes Control “length” signed integer ranging
R255:255.LEN from —32,768 to +32,767
R:0.POS - R255:255.POS| numeric yes yes Control “position” signed integer
ranging from -32,768 to +32,767
R:0_DN - R255:255_DN| logical yes yes Control “done” single-bit logical
indicator
R:0_EM - R255:255_EM]| logical yes yes Control “empty” single-bit logical
indicator
R:0_EN -R255:255_EN | logical yes yes Control “enable” single-bit logical
indicator
R:0_ER - R255:255.ER | logical yes yes Control “error” single-bit logical
indicator
R:0_EU - R255:255_EU | logical yes yes Control “enable unloading” single-bit
R:0-UL - R255:255_FD | logical yes yes Control “found” single-bit logical
indicator
R:0_IN - R255:255.IN logical yes yes Control “inhibit comparison” flag
single-bit logical indicator
R:0_UL - R255:255_UL | logical yes yes Control “unload” single-bit logical
indicator
S:0 - S:96 numeric yes yes SLC status file containing a signed
integer ranging from —32,768 to
+32,767 (see Allen-Bradley
documentation)
S:0_0-S:96_15 logical yes yes Individual SLC status bits (see
Allen-Bradley documentation)
T:0.ACC - numeric yes yes Accumulated timer value ranging
T255:255.ACC from —32,768 to +32,767
Lookout Reference Manual 18-12 © National Instruments Corporation
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Table 18-3. AB_SLC500 Data Members (Continued)

Data Member Type Read | Write Description

T:0.PRE - T255:255.PRE| numeric yes yes Preset timer value ranging from
—32,768 to +32,767

T:0_DN - T255:255_DN | logical yes yes Timer “done” single-bit logical
indicator

T:0_EN - T255:255_EN | logical yes yes Timer “enabled” single-bit logical
indicator

T:0_TT - T255:255_TT | logical yes yes Timer “timing” single-bit logical
indicator

Update logical yes no Object-generated signal that pulses
each time the object polls the device

Table 18-4. AB_PLC5 Data Members
Data Member Type Read | Write Description

B:0 - B999:999 numeric yes yes 16-bit signed binary word ranging from
—32,768 to +32,767

B_0 - For B999_15999 | logical yes yes One bit within the specified datafile;
for example, B3_32 specifies datafile 3,
word 2, bit 1.

C:0.ACC - numeric yes yes Counter accumulated value. Two-byte

C999:999.ACC signed word ranging from —32,768 to
+32,767

C:0.PRE - C999:999.PRE numeric yes yes Preset counter value ranging from
-32,768 to +32,767

C:0_CD - C999:999_CD | logical yes yes Counter down-enable bit.

C:0_CU - C999:999_CU | logical yes yes Counter up-enable bit.

C:0_DN - C:999:999_DN| logical yes yes Counter done bit.

C:0_0OV -C999:999_OV| logical yes yes Counter overflow bit.

C:0_UA - C999:999_UA| logical yes yes Counter update accumulation bit
(HSC in fixed controller only)

C:0_UN - C999:999_UN| logical yes yes Counter underflow bit.
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Table 18-4. AB_PLC5 Data Members (Continued)

Data Member Type Read | Write Description

CommPFail logical yes no Object-generated signal that is ON if,
for whatever reason, Lookout cannot
communicate with the PLC.

F:0-F999:999 numeric yes yes Floating point value

I.0 - I:277 numeric yes yes Unsigned 16-bit input value ranging
from O to 65,535

1.0_0-1:277_17 logical yes yes One bit within a 16-bit input word
(octal)

N:0 - N999:999 numeric yes yes 16-bit signed integer value ranging
from —32,768 to +32,767.

N:0_0 - N999:999_15 logical yes yes One bit within a 16-bit signed integer
word

0:0 - 0:277 numeric yes yes Unsigned 16-bit output value ranging
fromO to 65,535

0:0_0-0:277_17 logical yes yes One bit within a 16-bit output word
(octal)

OffHook logical no yes When true, instructs the PLC to retain
exclusive use of its assigned
communication port. This prevents
Lookout from hanging up between
polls, saving the redial overhead. This
also prevents other blocks from
communicating over the same channel.

Poll logical no yes When transitioned from false to true,
the Lookout object polls the PLC device

PollRate numeric no yes Specifies the frequency at which the
Lookout object polls the PLC device

R:0.LEN - numeric yes yes Control “length” signed integer ranging

R999:999.LEN from —32,768 to +32,767

R:0.POS - R999:999.POS| numeric yes yes Control “position” signed integer
ranging from —32,768 to +32,767

R:0_DN - R999:999_DN| logical yes yes Control “done” single-bit logical
indicator
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Table 18-4. AB_PLC5 Data Members (Continued)

Data Member Type Read | Write Description

R:0_EM - R999:999_EM]| logical yes yes Control “empty” single-bit logical
indicator

R:0_EN - R999:999_EN | logical yes yes Control “enable” single-bit logical
indicator

R:0_ER - R999:999.ER | logical yes yes Control “error” single-bit logical
indicator

R:0_EU - R999:999_EU | logical yes yes Control “enable unloading” single-bit
logical indicator

R:0_FD - R999:999_FD | logical yes yes Control “found” single-bit logical
indicator

R:0_IN - R999:999.IN logical yes yes Control “inhibit comparison” flag
logical indicator

R:0_UL - R999:999 UL | logical yes yes Control “unload” single-bit logical
indicator

S:0 - S:127 numeric yes yes PLC status file containing a signed
integer ranging from —32,768 to
+32,767 (see Allen-Bradley
documentation)

S:0_0-S:127_15 logical yes yes Individual PLC status bits (see
Allen-Bradley documentation)

T:0.ACC - numeric yes yes Accumulated timer value ranging from

T999:999.ACC —-32,768 to +32,767

T:0.PRE - T999:999.PRE| numeric yes yes Preset timer value ranging from
-32,768 to +32,767

T:0_DN - T999:999 DN | logical yes yes Timer “done” single-bit logical
indicator

T:0_EN - T999:999_EN | logical yes yes Timer “enabled” single-bit logical
indicator
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Table 18-4. AB_PLC5 Data Members (Continued)

Data Member Type Read | Write Description
T:0_TT -T999:999_TT | logical yes yes Timer “timing” single-bit logical
indicator
Update logical yes no Object-generated signal that pulses
each time the object polls the PLC
device

Allen-Bradley Error Messages

Lookout Reference Manual

AB objects report the statuses of commands they issue to AB devices.
When Lookout receives a response from an AB device, it reads the status
(STS) byte and, if necessary, the extended status (EXT STS) byte to verify
the device executed the Lookout command properly. If the command was
not executed properly, Lookout reports the failure as an alarm containing
the status code and its meaning. The following is an example of such an
alarm:

EXT STS = 0OF: not enough levels in address

AB object classes can also generate alarms internally. Below is a list of
AB alarms generated by Lookout, their descriptions, and possible
responses. In the messages, KT is used to refer to any of the DH+ interface
cards (1784-KT, 1784-KTx, 1784-PCMK, or 5136-SD) and SS is used to
refer to the 5136-SD card.

Cannot resolve ip address: address

The AB object failed to find any node on the network that corresponds to
the given IP address. Confirm that the IP address entered in the Modify
Object dialog box is correct.

Cannot get session id from plc
The AB object sent a message to the PLC requesting a TCP/IP session and
failed to receive a satisfactory response.

Cannot communicate with device (code=dd)

The AB object timed out while waiting for a response (via TCP/IP) from
the PLC. If the code is 0, the object timed out while trying to establish the
TCP/IP connection; if the code is 1, the object timed out while waiting for
a session id from the PLC; if the code is 2, the object timed out while
waiting for a response to a poll request. Confirm that the IP address of the
PLC has been entered correctly and that the PLC is reachable over the
TCP/IP network.
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Download of file sdipds.ss1 failed

Lookout was unable to write the KT-emulation program file to the
5136-SD card physical memory. This could be due to either an invalid
port or memory address or to a faulty or improperly seated card.

Invalid memory address for card: O0xAAAA

The memory address specified for the card (for example, D400) is not
valid for this model of card. The address must be a multiple of 0x0100 and
lie in the range 0xA000 to 0xDFO00. Moreover, the KT, KTx, PCMK, and
5136-SD cards support different sets of valid memory addresses. See the
documentation that shipped with the card for details.

Invalid node address for card: xx
Node addresses must be between 0 and 63 decimal.

Invalid port number for SS card: OxPPP
The port number specified for the 5136-SD card is invalid. See the
documentation that shipped with the card for the list of valid port addresses.

Invalid port or memory address

Lookout was unable to write to the 5136-SD card physical memory. This
could be due to either an invalid port or memory address or to a faulty or
improperly seated card.

KT card failed to find resources

KT card receive mailbox is in an invalid state

KT card send mailbox is in an invalid state

You will probably never see one of these alarms. If you do, call National
Instruments and ask for Technical Support.

KT card dual-ported memory test failed at location xxxx

The interface card failed a memory test when it was first powered on. The
memory test reads, writes and rereads the dual-ported memory to ensure
memory access by the card. Verify that the card is configured for the
memory address that you specified. Verify that your memory manager
(like EMM386) excludes the appropriate portion of memory. Verify that
your card is not trying to use the same memory location as another card.
You may need to restart the card by calling up the AB object definition
dialog box and selecting OK. If that does not work try rebooting the
computer. Other causes can include memory conflicts, a bad interface
card, or a misbehaving driver.
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KT card CTC test timed out

KT card CTC test failed with status code xx

The interface card failed the Counter Timer Circuit test when it was first
powered on. This test verifies proper functionality of the card timer and
counter modes over all CTC channels. You may need to restart, reseat,
or replace the interface card.

KT card timed out while loading protocol code

KT card failed with status code xx while loading protocol

Lookout was not able to transfer a loader file to the card and subsequently
download the card protocol firmware. Try to restart the interface card by
calling up the AB object definition dialog box and selecting OK. If that
does not work try rebooting the computer.

KT card is no longer responding

The Lookout AB object did not receive the interface card heartbeat within
the last second. Normally, the card generates a heartbeat any time it
receives the DH+ network token. If the alarm does not deactivate after

30 seconds, try to restart the card by calling up the AB object definition
dialog box and selecting OK. If that does not work try restarting Lookout
or rebooting the computer.

KT card memory address conflicts with card n

Lookout found another interface card with the same memory address. Be
sure that the memory address on each interface card is different and that the
corresponding Memory address in the Lookout object matches the card
address.

KT card not present in this computer

The Card exists in this computer check box is deselected (this is the
default setting). Select Object»Modify to retrieve the PLC definition
parameters dialog box and select the Card exists in this computer check
box and OK to initialize the card.

KT card RAM test timed out

KT card RAM test failed with status code xx

The interface card failed a memory test when it was first powered on. The
memory test writes a pattern to on-board RAM and reads its content to
verify the card memory is working. Confirm that the memory address
specified in the Object»Modify dialog box is correct. You may need to
restart, reseat, or replace the card.
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KT card signature test failed

The AB object does not recognize the card. Make sure that the interface
card is actually installed in the PC and that you indicated the correct
memory address in Lookout. You may need to reseat the card, or the
card may require repair. Also ensure that you did not identify more
Card Numbers than actual physical cards.

KT card SI0 test timed out

KT card SIO test failed with status code xx

The interface card failed the Serial Input Output test when it was first
powered on. You may need to restart, reseat, or replace the interface card.

KT card send mailbox timed out

The AB object timed out while waiting for the KT card to signal that it

is ready to be given a new message to send. This is most likely due to a
communication problem between the computer and the PLC. Confirm that
the network cable is properly installed and that the PLC is turned on.

NAK response received

The AB object received a NAK (not acknowledged) response when it
polled the device. The device received a command from Lookout but it did
not accept the message. The command that the device received may be
incomplete or contain irregularities due to poor network performance. If
your Serial Port is configured for radio, you may need to adjust the RTS
delay off setting. Also consider increasing the number of Retry attempts.

No response -- no ACK for our transmission

Lookout is not getting any response from the device. This could be caused
by just about anything. Verify that the Data rate, Parity, and Error
detection settings are the same as the settings on the device. Make sure you
are using the proper Serial port on your computer. Verify that the device
interface module and other network equipment is connected and working
properly. If you are using a modem, verify that your object Phone number
and the serial port Dial-up settings are correct. This may also be caused by
low level noise or reflections on the highway, or marginal circuitry on a
card.

No response within timeout period

No response received after receiving ENQ

The AB object received an acknowledgment of its poll from the device. The
device accepted the command from Lookout. However, the device did not
appear to send anything else back in response. You may have to increase
Receive timeout to make sure Lookout allows enough time to receive the
message.
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EOT response received

The AB object received an EOT (end of transmission) response when it
polled the device indicating that the device did not have a message ready to
give in response to the Lookout poll request. It is unlikely that you will ever
see this error message.

Received TSN does not match

Response message garbled -- bad CRC or bad BCC

Response message garbled -- no DLE EXT

Response message garbled -- bad DLE follower

The AB object is receiving messages from the device. However, the
messages may be failing the selected data integrity test. Verify that the
object Error detection setting is the same as the settings on the device.
Another cause may be that the last part of the message is actually getting
clipped off before it is completed. You may have to increase the Receive
gap Serial Port setting to ensure Lookout is receiving the entire message.
If your Serial Port is configured for radio this could be caused by an audible
squelch tail occurring at the end of a radio transmission. You may need to
adjust the RTS delay off or the CTS timeout settings. Also consider
increasing the number of Retry attempts.

Socket communications error dd: msg

The AB object has encountered a problem while attempting to
communicate using TCP/IP. The error number dd and corresponding error
message msg give further information. Confirm that the IP address of the
PLC has been entered correctly and that the PLC is reachable over the
TCP/IP network.

SS card failed
This message is suffixed with an error message read from the card itself.
You may need to contact the vendor of your card for technical support.

SS card failed while performing diagnostics

Lookout successfully wrote the KT-emulation program to the 5136-SD
card, but the program failed to terminate. Try running the sdinst .exe
program that ships with the 5136-SD card, using the CHK option to
confirm that the card is working properly.

Unable to access physical memory at segment OxAAAA

Lookout was unable to access the memory at the given segment address.
The memory may already be in use by the operating system or by another
application. Either change the object memory address (which may involve
changing switch settings on the card itself) or, if you are using a memory
manager, make sure that it is excluding the correct portion of memory.
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Unable to open port OxPPP for SS card

Lookout was unable to open the port number specified for the 5136-SD
card. Make sure that you have specified the port that is selected by the
jumper settings on the card. Make sure that port and the following two ports
(for example, 250, 251, and 252) are not in use by any other devices in your
computer.

Unexpected data response length

Unexpected response

Unhandled error

You will probably never see one of these alarms. If you do, call National
Instruments and ask for Technical Support.
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Accumulator

Accumulator is a totalizer. It samples the numeric Input any time the
Sample value transitions from off to on, adding each new sample to the
previous running total. It resets the totalized value to zero when Reset
transitions from off to on.

Tag: IAccum1
Input = ||
Sample = I
Reset= I
Ok | Cancel

Figure 18-5. Accumulator Definition Parameters Dialog Box

Input is a numeric expression while Sample and Reset are logical
expressions.

The following HyperTrend demonstrates the relationship between Input,
Sample, and Reset.

+ T
Outputjp=
I—FA'_
l_‘ I'J [ ]
.—,_ r—'_‘ = [l I:J_| rJl l_I I
|r‘|put I o s R O e 0 O O e il s e
20 1501830 1501940 1501850 15:20:00 152010 1520
= Note Accumulator does not have a display parameters dialog box. However, you can

easily display the result of its output signal by referencing it in an expression.
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Table 18-5. Accumulator Data Member

Data Members Type Read | Write Description
(implicit) numeric yes no Current totalized value, totalized since the
most recent Reset signal. Updated at the
defined Sample rate.
Comments Reset could be a regular pulse interval created by a Pulse timer, as shown in

the dialog box on the previous page.

The Counter object class totalizes a number of logical events and the
Integral object class totalizes rates. Use Accumulator to totalize numeric
variables.

Related Objects Average, Minimum, Maximum, Sample

© MNational Instruments Corporation

18-23

Lookout Reference Manual



Chapter 18

AdvantechPCL

Object Class Reference

Note

The AdvantechPCL object class enables Lookout to communicate with the
Advantech PC-MultiLab Card, model PCL-711B. The MultiLab Card
installs in your computer and provides one analog output, eight analog
inputs, 16 digital inputs and 16 digital outputs.

New Advantech PC-Labcard | ]
Tag:
Card [0 port address: 220 -
Scanning interval: 50
milliseconds
Communication alarm priority: IB
Ok I Cancel |

Figure 18-6. AdvantechPCL Definition Parameters Dialog Box

Card I/0 port address indicates the base I/O port address you chose using
DIP switch settings on the card. The Advantech card uses 16 consecutive
I/O port address locations in your computer. So if you identify base address
220 (hex), it uses addresses 220 to 22F. Valid base addresses range from
000 to 3F0. If your computer does not have an Advantech card installed,
be sure to select no card.

I/0 ports identify to the CPU the location of basic system components such as

serial ports, video cards, and disk controllers. Check your computer hardware
manual and add-on board configurations to be sure you are assigning a unique
I/O port address to the Advantech card.

Lookout Reference Manual

Scanning interval is a numeric parameter that determines how often
Lookout scans the card for changed values. Valid intervals range from
10 to 1000 milliseconds.

Al gain specifies the input amplification gains of all analog input signals
(AIO — AI7). For the highest possible resolution, you should amplify the
input signals so that their maximum voltage swing equals their maximum
input range. The following table lists recommended settings.
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If your maximum voltage range is... use Al gain...
+5V 1
+2.5V 2X
+1.25V 4X
+0.625V 8X
+0.3125V 16X

Communication alarm priority determines the priority level of the alarms
generated by the AdvantechPCL object class.

AdvantechPCL Data Members

The table that follows lists data members supported by the AdvantechPCL
object class.

Data Member

Type

Read

Write

Description

AIO — AI7

Analog

yes

no

Analog input where AIO represents A/D 0O
(pin 1 on CN1) and AI7 represents A/D 7
(pin 15 on CN1). Each input is a 12-bit
integer, ranging from 0 to 4095.

AO0

Analog

no

yes

Analog output where AOO represents
D/A (pin 17 on CN1). This output is a
12-bit integer, ranging from 0 — 4095
(+5V or +10V, depending on jumper
JP1).

CommpFail

logical

yes

no

Object-generated signal that is on if, for
whatever reason, Lookout cannot
communicate with the card.

DIO — DI15

logical

yes

no

Digital input where DIO represents pin 1
and DI15 represents pin 16 on CN4.
Returns False when a monitored signal is
open (>2.0V), True when the signal is
shorted (<0.8V).
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Data Member Type Read Write Description
DOO0O - DO15 logical no yes Digital output where DOO represents pin
1 and DOL1S5 represents pin 16 on CN3.
Update logical yes no Object-generated signal that pulses each
time the object scans the device.
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Alarm

Alarm is a flexible and powerful object class you use to create various
logical- and numeric-triggered alarms that are displayed in the alarm
window.

Note You should first read about the Lookout alarm system in Chapter 9, Alarms, to aid
you in designing the most efficient alarming scheme for your application.

Tag: W Alarm group: Im
Message = I“Reliefvalve failed to open after 30 seconds"
Condition = IPLC1.ReIieNIv and DelayOn Timer

~ Logical alarm
Friori YWave
{1-1 D)t:y IB file: Ic:\sounds\siren.wav Browse... |

— Mumeric alarm

ity

nlERlEEN=

Hilevel= | |
GIEVEE I I
i |

el Evel=

Eate aheianee=s I I

IWittires I (Exarmmles UIEr EEr mitute]

=il |=0= I

Cancel |

Figure 18-7. Typical Settings for a Logical Style Alarm

There are two basic alarm types: logical and Numeric. When Logical
alarm is selected, Lookout prompts you to enter a logical expression in
the Condition field. It then uses the logical Condition to trigger and reset
the alarm. If the alarm Condition is true, the alarm is active, and if the
condition is false, the alarm goes inactive. You can also connect an audio
Wave file to individual logical alarms. See Playwave for additional
information.

Lookout queues alarm .wAvV files, with up to 100 files in the queue. Each
alarm .wav file plays completely before the next file plays. If more than
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100 alarms fill the queue, new alarms cancel the currently playing files and
begin playing instead.

When you pick the Numeric alarm selection, the name of the Condition
field changes to Signal. This prompts you to enter a numeric expression in
the field against which your various alarm setpoints are measured. Hi-Hi,
Hi, Lo, and Lo-Lo are all numeric expressions. Rate of change generates
an alarm when the signal is actively changing by the set amount for the
period of time between any two Sample pulses. The Unit time setting
determines the time units for the rate of change.

Tan: M Alarm group: Im
Message = I"Boilerpressure iz out of range"”
Signal = IBDiIerPressure

~ Logical alarm

ity e,

=)
(=11 ID i Ic:\sounds\siren.wav Brawee.. |

—& Mumeric alarm

Friority:
HiHilevel = [275 [2
Hilewvel = IHiSetpoint IB
Lo lewvel = I I
Lo-Lo level = ILDLDSetpDint IB
Rate of change = |3.5 |4|
Unit time: IDD:D1:DD.D (Exarnple: 1:00 for per minute)

Sample = IPuIse ftrue, 0:0:1.0, 0.0y

Cancel |

Figure 18-8. Typical Settings for a Numeric Style Alarm

Alarm group specifies the group name associated with the alarm object.
All previously defined groups appear in the list box and may be selected
with the mouse.

Priority ranges from 1 to 10 where 10 is the most important.

Message is a text expression whose result is displayed in the alarm window
when this object generates an alarm. If alarm style is numeric, the relevant
alarm trigger prefixes your message (for example, HiHi level: Alarm
message). See Chapter 9, Alarms, for additional information
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Alarm Data Members

Table 18-6. Alarm Data Members

Data Members Type Read Write Description

active logical yes no Result of logical alarm status. True if
alarm is active and false if alarm is
inactive.

hi logical yes no Result of numeric alarm hi data member
status.

hihi logical yes no Result of numeric alarm hihi data member
status.

lo logical yes no Result of numeric alarm lo data member
status.

lolo logical yes no Result of numeric alarm lolo data member
status.

rate logical yes no Result of numeric alarm rate data member
status.

Comments A common alarm condition is caused by a measured value going out of an
acceptable range. For example, a storage tank whose level is too low or too
high can generate several alarms: Hihi: Tank level is out of range, or
Lo: Tank level is out of range. If you use a numeric style alarm to trigger
the alarm and if the tank level fluctuates or “jitters” around the alarm level
settings, a new alarm record is generated in the alarm window each time the
tank level fluctuates above or below the level settings. To alleviate this
condition, you could use the Neutralzone object to filter out minor tank
fluctuations.

Note As discussed in Chapters 5 and 9, alarms can also be defined through parameter
settings on object data members. Many times, this is the most efficient method
of defining and creating alarm conditions. See Database-Generated Alarms in
Chapter 9, Alarms, and Editing Object Databases in Chapter 4, Using Lookout,
Jfor more information.
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$Alarm

$Alarm connections [ ]

$Alarm.ack =

Mew logical connection

—Selectmember:

$Alarm is a global object. It makes available global alarm data such as the
number of currently active alarms.

You can use $Alarm data members just like other data members. By
inserting an expression you can display the number of active alarms in any
particular group. Or, by connecting a pushbutton to an acknowledge data
member, operators can acknowledge alarms through pushbutton selection.

Assume, for example, that you want to create a pushbutton that
acknowledges all alarms. First create a pushbutton object. Next, use the
Object»Edit Connections... command to connect the pushbutton (Pb1)
to the . ack data member of $Alarm. Such a connection is shown below:

[Por]

Accept | Clear | Cluit |

ack

Existing connections: Tags: Fushbuttan

—Signals:

cormrn.ack
DDE.ack
Digk.ack

Select

Writable members: Feadable members: logical

activatePanel
Citadel.ack

$alarm
$keyboard
$Systarm
Fanell

|

| Selectobject... | Ph1

Lookout Reference Manual

Figure 18-9. Edit Connections Dialog Box for using $Alarm

The expression (Pbl) acknowledges all active alarms any time the
pushbutton is depressed. You could make similar connections to
acknowledge individual alarm groups.

You can define new alarm groups through Alarm objects and by modifying
object database parameters. As you create each new alarm group, Lookout
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adds new readable and writable data members to the $Alarm object.
$Alarm data members are described in the following table.

Alarm Data Members

Table 18-7. $Alarm Data Members

Data Member Type Read | Write Description

ack logical no yes Upon transition from FALSE to
TRUE, acknowledges all alarms.

Active numeric yes no Total number of currently active
alarms (that is, alarm conditions that
still exist).

ActivatePanel logical no yes | Calls Alarm Window upon transition
from FALSE to TRUE, making it
visible on the screen.

Groupname text yes no Alarm group name associated with the
most recent alarm

Groupname.active numeric yes no Number of currently active alarms
within the specified group.

Groupname .unacked numeric yes no Number of unacknowledged alarms
within the specified group.

Groupname.ack logical no yes Upon transition from FALSE to
TRUE, acknowledges all alarms
within the specified group.

Message text yes no Text of the message of the most recent
alarm

MinimizePanel logical no yes Closes Alarm Window upon transition
from FALSE to TRUE, changing it to
an icon.

Priority numeric yes no Alarm priority associated with the
most recent alarm

PriorityOl.active — numeric yes no Number of currently active alarms of

Priority10.active the specified priority.

PriorityOl.unacked — numeric yes no Number of unacknowledged alarms of

Priority10.unacked the specified priority.
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Table 18-7. $Alarm Data Members (Continued)

Data Member Type Read | Write Description

Tagname text yes no Object tag name associated with the
most recent alarm

Unacked numeric yes no Total number of unacknowledged
alarms (that is, alarm conditions that
have not yet been acknowledged).

Update logical yes no Pulses high every time there is a new
alarm

Comments Groupname in the preceding table represents the name of any specified
alarm group. The $Alarm object contains an .active, .unacked, and .ack
data member for every alarm group.

Using $Alarm with Other Objects

Every time a new alarm appears in Lookout, $Alarm.Message,
$Alarm.Tagname, $Alarm.Groupname, and $Alarm.Priority

are updated with the appropriate information for the new alarm. Then
$Alarm.Update pulses high to alert you that those four data members
contain fresh values.

Lookout Reference Manual

These data members can serve many purposes, but they are specifically
designed to work with the Pager object class. In a typical application, you
could use sAlarm.Update to initiate a page, possibly including the other
four data members in the text of the page. With this system you can also
filter which alarms you want to page, and which alarms the pager ignores.
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Alternator

Alternator is an object class Lookout uses to control a series of devices with
various commands. Typically this means rotating the usage of the devices
at specified times.

New Alternator | ]

Tag: IAItern atar]

Devices: |3
Maximurn run time: IDD:D1:DD:DD

DO:HH:MM:EE

Delay between device starts: 00:00:05:00
DO:HH:MMSS

Device failure alarm priority: |5
Device response time: |DD:DD:DD:DS

DO:HH:MM:EE

Device name: IPump
Timer update: |nn:nn:nn:m|

DO:HH:MM:EE

Ok I Cancel |

Figure 18-10. Alternator Definition Parameters Dialog Box

Devices determines the maximum number of devices that can be controlled
by the alternator.

Maximum run time is the maximum amount of time that any one device
is allowed to run continuously. This function can be disabled by entering 0.

Delay between device starts is the minimum amount of time between
device starts that are initiated by the alternator object. This function can be
disabled by entering 0.

Device failure alarm priority determines the priority level of alarms
generated by the alternator. This defaults to 5.

Device response time is the amount of time the alternator waits for a
response from a device before activating an alarm. This function can be
disabled for individual devices by not connecting anything to the
Response data member.
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Device name is a string describing the type of device that is being
controlled by the alternator. This is used to create the alarm messages and
is also the name of the group to which the alarms belong.

Timer update specifies the resolution of the timers used by the alternator
to decide which devices to turn on and off. This also specifies how often the
alternator updates the ElapsedTime and RunTime data members.

Alternator Data Members

Table 18-8. Alternator Data Members

Data Member Type Read | Write Description
ElapsedTimel - numeric yes no Elapsed time device has been on since
ElapsedTime100 last reset
DeviceConnectl - logical yes no States whether device is in the active
DeviceConnect100 sequence considered by the alternator
DeviceOnl - logical yes no Confirmation of the actual device state
DeviceOn100
DeviceRequestl - logical yes no Output to whatever drives the device
DeviceRequest100
Advance logical no yes Turns on the next device in the
sequence and turns off the last device
in the sequence

Command numeric no yes How many devices the alternator is to
have running

HOAmodel - numeric no yes States whether device is in Hand, Off,

HOAmode100 or Auto mode

Resetl - Reset100 logical no yes Used to reset the ElapsedTime data
member

Responsel - logical no yes Response bit from device

Response100

RunTimel - RunTime100, numeric yes no Elapsed time device has been on
continuously
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Connecting the Alternator

The DeviceRequest data members should be connected to whatever
drivers are controlling your devices. Notice that when you connect the
DeviceRequest data member to anything, the DeviceConnect data
member goes high. This connection is the only one required for the
alternator to consider your device connected. The RunTime,
ElapsedTime, DeviceConnect, and DeviceOn data members can be
connected to or not depending on whether you want that information.

The Command data member is the essential writable data member to
connect to. The connection to Command can be any numeric expression,
but a pot is probably most convenient, especially for testing and
demonstration purposes. It only accepts values in the integer range from
zero to the number of Device connections specified as a parameter. To
the Response data members should be connected a response bit from
each device. If no connection is made to Response the alternator does
not require any response from the device. The Advance, Reset, and
HOAmode data members are not essential either; You need only make
connections to them if you want their functionality. Advance and Reset
typically are connected to pushbuttons, and HOAmode typically connects
to a pot. The HOAmode data member only accepts values in the integer
range from one to three.

Command and Advance

The Command data member is the number of devices that the alternator
is to have running at one time. When you send the alternator its first
command, it requests a corresponding number of devices to turn on. The
DeviceRequest data member for each of these devices goes high to signify
this. When the devices respond that they are in fact on via the Response
data member, (if it is connected) the alternator recognizes that the device
is on and the DeviceOn data member goes high. Conversely, if the
Command data member specifies that devices are to be turned off, the
DeviceRequest data members for the corresponding number of devices
goes low. The devices should then respond accordingly via the Response
data member.

When you give the alternator a numeric command, it takes into account the
number of devices currently running, and makes its requests accordingly.
Because of this, it is important to know how the alternator counts the
number of devices running. Devices running as a result of a Hand command
from the HOAMode data member are NOT counted. All other running
devices (including those with active alarms) are.
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When the alternator is asked to turn on a new device it chooses the device
that has been off the longest. When asked to turn off a device it chooses the
device that has been on the longest.

The Advance command turns on one device and turns off another device.

Maximum Run Time and Delay Operation

The Maximum run time parameter specifies how long any one device can
be running. Each device has its own timer to ensure that this is enforced.
When one of these timers informs the alternator that its device has been
on for the maximum allowed time, the alternator executes a command
identical to the Advance command. Notice that there are two cases where
the maximum time limit is not enforced strictly. One of them is when you
have turned on a device via the HOAmode data member. (Its operation is
discussed below.) The other is when it conflicts with the operation of the
Delay between device starts feature.

Delay between device starts is specified as a parameter, and limits how
often the alternator can turn on devices. An example of the operation of the
Delay between device starts would be beginning with a new alternator that
has none of the devices on. You issue a command using the Command data
member of 3. If the delay feature is in use, the alternator sends three ON
requests separated by the amount of time specified by Delay between
device starts.

Hand - Off - Auto Modes

The HOAmode data member gives the user direct control over each
device. The integer value of this numeric data member corresponds to

an operating mode. (See Table 18-9 below.) When the HOAmode data
member is in Auto mode (as it is by default if you never connect anything
to this data member) it is subject to the commands of the alternator. Its
DeviceConnect data member will be high to signify that the alternator
recognizes it. When you select Hand mode, two things happen: The device
is disconnected and is sent an on request. Similarly in Off mode the device
is disconnected and requested off. In these two modes, the alternator does
not recognize or request anything of these devices. If you select Auto mode
again, the device is reconnected.
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Table 18-9. HOA Modes

HOA mode Integer
Hand 1
Off 2
Auto 3

Elapsed Time, Run Time, and Reset

The ElapsedTime data member keeps track of how long a particular device
has been on since its last reset (or since it was created). Its value is in days,
so by viewing it through a numeric expression you may select any time
format.

The RunTime data member keeps track of how long a particular device
has been on continuously. Its value is in days, so by viewing it through a
numeric expression you may select any time format.

The Reset data member is used to reset ElapsedTime.

Alternator Status Messages

Not responding to on request

A device that was sent an ON request via the DeviceRequest data member
did not respond that it had in fact turned on. The alternator attempts to turn
it on again when its turn comes and the alarm remains active until the
device responds properly to an alternator command.

Not responding to off request

A device that was sent an OFF request via the DeviceRequest data member
did not respond that it had in fact turned off. The alternator attempts to turn
it off again when its turn comes and the alarm remains active until the
device responds properly to an alternator command.

Turned on unexpectedly
A device that was previously off and that the alternator expected to remain
off turned on without reason. The alternator attempts to turn it off when its
turn comes, and the alarm remains active until the device responds properly
to an alternator command.
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Turned off unexpectedly
A device that was previously on and that the alternator expected to remain
on turned off without reason. The alternator attempts to turn it on when its
turn comes, and the alarm remains active until the device responds properly
to an alternator command.

Not responding to HOA command

A device did not respond properly to a command from the HOAmode data
member. The alternator attempts to request it when its turn comes, and the
alarm remains active until the device responds properly to an alternator
command.
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Animator

The Animator object class provides full graphical animation including
horizontal and vertical motion, dynamic resizing and visibility, dynamic
symbol sequencing and programmable color changes.

When you first create an animator object, the Select graphic dialog box
appears.

Select graphic ]

| arrows
|1 conveyor
|1 hoppers
I_1 indicatr
|1 meters
|_1 misc
|1 mixers =—8 | i

R P s

o e

\ i X N
n e
|1 valves

2
]

3
&
]
\
=
8
R

{]

mischiharse.bmp

Transparent pixel:

49 graphic images ’7 @ I_3 v I_3

Figure 18-11. Select Graphic Dialog Box

Select the graphic you want to animate. To animate colors, you must select
a Windows Metafile ( WMF). A moving animation must have the series of
images you want to animate arranged in a single bitmap so that each cell of
the animation can be defined by a grid of rows and columns.

© MNational Instruments Corporation 18-39 Lookout Reference Manual



Chapter 18 Object Class Reference

Animations

Lookout Reference Manual

To create a moving animation, select the Animation tag.

Create Animator Object EHE

Caolor  Animation |

Tag: IAnimatoﬂ

chprogram filesinational

100% Size (in pixels):

Width Height
|4a |14n

= IHDrizontaIPot

Y= IVe icalPot

Size = ISizePDt

Wisible = I\a’isibilitySwitch

Filmstrip:
& Cel  Rate (cels/sec) Brap Grid
Cel/Rate = Fiaws Columns

[RatePod [5 f1

oK I Cancel

Figure 18-12. Animator Definition Parameters Dialog Box, Animation Tab

The graphic file you select determines what images appear on the screen.

You delineate the images in a bitmap graphic by dividing it into a grid of

Rows and Columns. In the example above, the single column is 48 pixels
Wide and each row is 28 pixels High. Conceivably, the grid could consist
of 32,000 cells. 100 cells would be more practical.

Each grid cell is a filmstrip image. Internally, the Animator assigns a cell
number to each image. It normally plays the filmstrip by progressing from
left to right and top to bottom, from the lowest cell number to the highest
cell number.
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The Rate (cells/sec) selection you use to specify a frequency at which the
Animator progresses from one cell image to the next. The rate value can be
positive or negative and can range from 0.0000005 (one frame every
23.148 days) to 100 frames per second.

If the rate value is negative, the Animator plays the filmstrip backwards,
starting at the last cell.

You can use the Cell selection in the definition dialog box to identify a
particular cell number to display. For example, you might use this selection
to display a specific image when a PLC register is equal to a particular
value. This is similar to the multistate object, but can provide many more
states, depending on the number of cells in the bitmap.

The X and Y parameters specify the horizontal and vertical position of the
image, respectively. These numeric parameters range from 0 to 100, and
together provide the X-Y position of the image as a percent of the Animator
dimension on a control panel.

Size is a numeric parameter that ranges from 0 to 100 percent, where
100 percent is the full size of a single cell as specified by W and H.

Visible is a logical parameter that causes to the image to appear when it
goes true and disappear when it goes false.

Color Animation
To create color changes programmatically, select the Color tab.
With this option, you can set the color map on a .WMF graphic using a

series of five logical conditions and a default state. If no condition is true,
the default state (or color map) is imposed.

You can choose a custom color map by clicking on the color sample
associated with each logical condition. You can then select any color from
the palette available on your computer.

Select the Show Original Colors box if you want the original color map of
the .WMF file to be imposed for that condition.
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Create Animator Object m

Color |Animati0n|

Tag: IAnimatoﬂ

chprogram filesinational

7 Maotice:

Only metafile images (“wmf) are
effected by color change settings.
COther file farmats will be displayed in
their ariginal colors.

\ — Gray Proximity
Froximity of the ariginal color to gray
necessary befare itwill be changed to
the new colar.

Gray Proximity (0-100) ID

Show Original Colars | Show
Original Colars
If = | |
Elseif= | m
Elseif= | o
Elseif= | _ | r
Elseif= | m
Else N
ok | cancel

Figure 18-13. Animator Definition Parameters Dialog Box, Color Tab

Gray Proximity determines the color saturation point at which the selected
color replaces an original color. When this parameter is set to 0, most colors
change. When this parameter is set to 100, most colors will not change. You
can test the effects of this setting by putting your cursor over the color
button and observing the change in the graphic displayed in the dialog box
window.

Notice that the if and else if statements are evaluated in sequence. If several
conditional expressions are true at once, Multistate displays the graphic
associated with the first true expression.

For instance, if your If parameters use less-than comparisons, such as
PumpSpeed<50, the following Else if parameter must have a larger
comparison value, such as PumpSpeed<75. If you use a smaller
comparison value, such as PumpSpeed<25, the color change will not take
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place. In other words, the comparison values must be used from smallest to
largest.

In the same way, if you are using greater-than comparisons, such as
PumpSpeed>50, you must list your comparison values from largest to
smallest, so that the next Else If parameter would have to be something like
PumpSpeed>25.

Put If parameters using equality, such as PumpSpeed=50, before
parameters using inequalities.

A few minutes experimentation should help you understand the interactions
of the color choice conditions.

Animator Data Members

Table 18-10. Animator Data Members

Data Member Type Read Write Description

none — — — Animator objects do not have data
members

Comments Consider using an Integral object instead of a Counter/Pulse combination
when trying to achieve smooth animation.

Related Objects Multistate, Pipe, Gauge, Spinner, DialGauge
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Applicom

Create Applicom Local [ ] Create Applicom Telemecanique | ]
Tag: Tag: Applicom

Board Id :

Address of status word:
(-1 = no status word)

Scanning Interval (ms):

Communication alarm priority: IB Cammunication alarm priarity: IB

Applicom is a set of object classes Lookout uses to communicate with a
series of devices and protocols, including the Applicom on-board database
(Local mode), April 1000, Klockner-Moeller, Otic Fischer & Porter,
Profibus DP, Profibus FMS, Profibus L2, SAIA-SBus, Siemens S7TMPI,
Siemens H1, Siemens S5 AS511, and Telemecanique.

Pictured below on the left is the dialog box for creating an Applicom Local
object. At right is the dialog box for creating an Applicom Telemecanique
object. The Telemecanique object has the same parameters as all the other
Applicom objects except for Applicom Local, and makes a good
representative sample for the group.

|1— Board Id: |1—
I— Channel Id: IU—
i Equipment ld: IU—
IW— Scanning Interval (ms): IEU—

Fetry attermpts before failure: |1 5

Lookout Reference Manual

Figure 18-14. Applicom Definition Parameters Dialog Boxes
Board ID identifies the board you are trying to address.

Address of status word is the address of the specific cyclic function of
your Applicom board that you want to interact with using this Applicom
Local object.

Channel ID identifies the Applicom channel your device is
communicating on.

Equipment ID is the Applicom equipment ID for the device you are
connecting to.
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Scanning interval is the time period between polls. Valid range is 10 -
65535 (expressed in msec).

Communication alarm priority determines the priority level of the alarms
generated by the object.

Retry attempts before failure specifies the consecutive number of times
Lookout attempts to establish communications with a device if it is not
getting a valid response. After it tries the number of Retry attempts
specified, the Applicom object generates an alarm and releases the
communication port back to the communications service which then moves
on to the next device in the polling queue (if any). Refer to Chapter 6, Serial
Communications, for more detailed information.

Table 18-11. Lookout Applicom Object Classes and the Corresponding Protocols/Devices

Object Class Device/protocol
Applicom Local Any device or protocol supported by Applicom cards. See the Special
Instructions on Using the Applicom Local Object Class section, for
more detailed information on using this object.
Applicom JBUS Devices using Jbus protocol (mostly those made by April).
April 1000 April 1000 PLC using Ethway or Fipway protocols.

Klockner-Moeller

Klockner-Moeller SUCOS PS32 and PS316 PLC using the Sucoma
link.

Otic Fischer & Porter Otic Fischer & Porter controllers of series 2000, 5000, and 2000
supervisor using the DATALINK protocol.

Profibus DP Profibus DP with any I/O module or PLC that communicates on
a Profibus network using the Decentralized Periphery protocol
(includes some Siemens S5 PLCs).

Profibus FMS Profibus FMS protocol with any master or slave FMS device on a
Profibus network (includes most Siemens PLCs).

Profibus L2 Profibus L2 protocol with Siemens S5 PLC using Siemens France
messaging system. (The PLC must be running a program also
distributed with the Applicom hardware.)

SAIA-SBus SAIA SBus master protocol.

Siemens S7TMPI

Siemens MPI protocol with Siemens S7 PLCs.

Siemens H1

Sinec H1 protocol with various Siemens PLCs.
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Table 18-11. Lookout Applicom Object Classes and the Corresponding Protocols/Devices (Continued)

Object Class

Device/protocol

Siemens S5 AS511

AS511 (programming port) protocol with Siemens S5 PLCs.

Telemecanique

Uni-Telway, Ethway and Fipway protocols with all Telemecanique

PLCs.

Applicom Data Members

Table 18-12. Applicom Local Data Members

Data Member Type Read | Write Description

B0-B31999 logical yes yes output bits

WO0-W31999 numeric yes yes output words

D0-D31998 numeric yes yes internal double words

FO-F31998 numeric yes yes internal floating words

00-013999 numeric yes yes internal bytes

WS0-WS31999 numeric yes yes signed output words

DS0-DS31998 numeric yes yes signed internal double words

0S0-0S13999 numeric yes yes signed internal bytes

Update logical yes no goes FALSE when a poll starts and
TRUE when a poll completes

CommPFail logical yes no object-generated signal that is ON if
Lookout cannot communicate with the
device(s)

Table 18-13. Applicom JBUS Data Members
Data Member Type Read | Write Description

B0-B4294967295 logical yes yes internal bits

BI0-B14294967295 logical yes no input bits

BO0-B0O4294967295 logical yes yes output bits

00-04294967295 numeric yes yes internal bytes
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Table 18-13. Applicom JBUS Data Members (Continued)

Data Member Type Read | Write Description
0I0-014294967295 numeric yes no input bytes
000-004294967295 numeric yes yes output bytes
WO0-W4294967295 numeric yes yes internal words
WIO-WI14294967295 numeric yes no input words

WO0-W04294967295 numeric yes yes output words

0S0-084294967295 numeric yes yes signed internal bytes
OIS0-0154294967295 numeric yes no signed input bytes
00S0-00S84294967295 numeric yes yes signed output bytes
WS0-WS4294967295 numeric yes yes signed internal words
WIS0-WI154294967295 numeric yes no signed input words
WOS0-W0S4294967295 | numeric yes yes signed output words
00.0-04294967295.7 logical yes yes | bitin internal bytes
00.0-04294967295.7 logical yes yes bit in internal bytes
WO0.0-W4294967295.15 logical yes yes bits in internal words
D0-D4294967295 numeric yes yes internal double words
F0-F4294967295 numeric yes yes internal floating words
Update logical yes no goes FALSE when a poll starts and

TRUE when a poll completes

CommPFail logical yes no object-generated signal that is ON if
Lookout cannot communicate with
the device(s)

Table 18-14. Applicom April 1000 Data Members

Data Member Type Read | Write Description
MX0-MX16383 logical yes yes not safeguarded internal bits
RX0-RX8191 logical yes yes safeguarded internal bits
IX00000-IX96931 logical yes no input bits
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Table 18-14. Applicom April 1000 Data Members (Continued)
Data Member Type Read | Write Description

QX00000-QX96931 logical yes yes output bits

MWO0-MW409599 numeric yes yes data words

MWS0-MWS409599 numeric yes yes signed data words

MDO0-MD409598 numeric yes yes double words in the data words

MDS0-MDS409598 numeric yes yes signed double words in the data words

FDO0-FD409598 numeric yes yes floating words in the data words

Update logical yes no goes FALSE when a poll starts and
TRUE when a poll completes

CommPFail logical yes no object-generated signal that is ON if
Lookout cannot communicate with the
device(s)

Table 18-15. Applicom Klockner-Moeller Data Members
Data Member Type Read | Write Description

B0-B4294967295 logical yes yes internal bits

BI0-B14294967295 logical yes no input bits

BO0-B04294967295 logical yes yes output bits

00-04294967295 numeric yes yes | internal bytes

0I0-014294967295 numeric yes no input bytes

000-004294967295 numeric yes yes | output bytes

WO0-W4294967295 numeric yes yes internal words

WI0-WI14294967295 numeric yes no input words

WO0-W04294967295 numeric yes yes output words

0S0-084294967295 numeric yes yes signed internal bytes

OIS0-01S4294967295 numeric yes no signed input bytes

00S0-00S4294967295 | numeric yes yes signed output bytes

WS0-WS4294967295 numeric yes yes signed internal words
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Table 18-15. Applicom Klockner-Moeller Data Members (Continued)

Data Member Type Read | Write Description
WIS0-WIS4294967295 numeric yes no signed input words
WOS0-WO0S4294967295 | numeric yes yes signed output words
00.0-04294967295.7 logical yes yes | bit in internal bytes
W0.0-W4294967295.15 logical yes yes bits in internal words
D0-D4294967295 numeric yes yes | internal double words
DS0-DS4294967295 numeric yes yes signed internal double words
F0-F4294967295 numeric yes yes | internal floating words
Update logical yes no goes FALSE when a poll starts and
TRUE when a poll completes

CommPFail logical yes no object-generated signal that is ON if
Lookout cannot communicate with
the device(s)

Table 18-16. Applicom Otic Fischer & Porter Data Members

Data Member Type Read | Write Description

L0-L65535 logical yes yes bits

B0-B65535 numeric yes yes bytes

BS0-BS65535 numeric yes yes Signed Bytes

B0.0-B65535.7 logical yes yes bits in bytes

C0-C65535 numeric yes yes floating word on three bytes

HO0-H65535 numeric yes yes floating word on five bytes

Update logical yes no goes FALSE when a poll starts and
TRUE when a poll completes

CommPFail logical yes no object-generated signal that is ON if
Lookout cannot communicate with the
device(s)
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Table 18-17. Applicom Profibus DP Data Members

Data Member Type Read | Write Description
B0-B4294967295 logical yes yes internal bits
BI0-BI4294967295 logical yes no input bits
BO0-B0O4294967295 logical yes yes output bits
00-04294967295 numeric yes yes internal bytes
0I0-014294967295 numeric yes no input bytes
000-004294967295 numeric yes yes output bytes
WO0-W4294967295 numeric yes yes internal words
WI0-W14294967295 numeric yes no input words

WO0-W04294967295 numeric yes yes output words

0S0-054294967295 numeric yes yes signed internal bytes
OIS0-0IS4294967295 numeric yes no signed input bytes
00S0-0084294967295 | numeric yes yes signed output bytes
WS0-WS4294967295 numeric yes yes signed internal words
WIS0-WI1S4294967295 numeric yes no signed input words
WOS0-W0S4294967295 | numeric yes yes signed output words
00.0-04294967295.7 logical yes yes | bitin internal bytes
WO0.0-W4294967295.15 logical yes yes | bits in internal words
D0-D4294967295 numeric yes yes internal double words
DS0-DS4294967295 numeric yes yes signed internal double words
FO0-F4294967295 numeric yes yes internal floating words
Update logical yes no goes FALSE when a poll starts and
TRUE when a poll completes
CommPFail logical yes no object-generated signal that is ON if
Lookout cannot communicate with the
device(s)
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Table 18-18. Applicom Profibus FMS Data Members

Data Member Type Read | Write Description
BID0-BID65535 logical yes yes bits (simple variables)
BIDOSUBO-BID65535S | logical yes yes bits
UB240
OID0-0OID65535 numeric yes yes bytes (simple variables)
OIDOSUBO-OID65535S | numeric yes yes bytes
UB240
WIDO0-WID65535 numeric yes yes words (simple variables)
WIDOSUBO-WID65535 | numeric yes yes words
SUB120
DIDO-DID65535 numeric yes yes doubles words (simple variables)
DIDOSUBO-DID65535S | numeric yes yes doubles words
UB60
FIDO-FID65535 numeric yes yes floating words (simple variables)
FIDOSUBO-FID65535SU| numeric yes yes floating words
B60
OIDS0-OIDS65535 numeric yes yes signed bytes (simple variables)
OIDOSUBSO0-OID6553 | numeric yes yes signed bytes
5SUBS240
WIDS0-WIDS65535 numeric yes yes signed words (simple variables)
WIDOSUBSO0-WID6553 | numeric yes yes signed words
5SUBS120
Update logical yes no goes FALSE when a poll starts and
TRUE when a poll completes

CommPFail logical yes no object-generated signal that is ON if
Lookout cannot communicate with the
device(s)
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Table 18-19. Applicom Profibus L2 Data Members

Data Member Type Read | Write Description
F0.0-F255.7 logical yes yes bits in flag bytes
S0.0-S4095.7 logical yes yes bits in Sflags (internal bytes)
10.0-1127.7 logical yes no input bits
Q0.0-Q127.7 logical yes yes output bits
DB1D0.0-DB255D255.15| logical yes yes bits of DB word
DX0D0.0-DX255D255.15| logical yes yes bits of DX word
FYO0-FY255 numeric yes yes flag bytes
SY0-SY4095 numeric yes yes Sflags (internal bytes)
IBO-IB127 numeric yes no input bytes
QY0-QY127 numeric yes yes output bytes
FWO0-FW254 numeric yes yes words in flag bytes
SWO0-SW4094 numeric yes yes words in Sflags (internal bytes)
IWO0-IW126 numeric yes no input words
QWO0-QW126 numeric yes yes output words
DB1DWO0-DB255DW255| numeric yes yes Update pulse: words in DB
DX0DWO0-DX255DW255| numeric yes yes Update pulse: words in DX
FDO-FD255 numeric yes yes double words in flag bytes
SDO0-SD4095 numeric yes yes floating words in Sflags
DB1DDO0-DB255DD254 | numeric yes yes double words in DB
DX0DDO0-DX255DD254 | numeric yes yes double words in DX
FDOKG-FD252KG numeric yes yes floating words in flag bytes
SDOKG-SD4092KG numeric yes yes floating words in Sflags
DB1DDOKG-DB255DD2 | numeric yes yes floating words in DB
54KG
DXO0DDOKG-DX255DD2| numeric yes yes floating words in DX
54KG
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Table 18-19. Applicom Profibus L2 Data Members (Continued)

Data Member Type Read | Write Description

FYSO0-FYS255 numeric yes yes signed flag bytes

SYSO0-SYS4095 numeric yes yes signed Sflags (internal bytes)

IBSO-IBS127 numeric yes no signed input bytes

QYS0-QYS127 numeric yes yes signed output bytes

FWS0-FWS254 numeric yes yes signed words in flag bytes

SWS0-SWS4094 numeric yes yes signed words in Sflags (internal
bytes)

IWS0-IWS126 numeric yes no signed input words

QWS0-QWS126 numeric yes yes signed output words

DB1DWS0-DB255DWS | numeric yes yes signed words in DB

255

DXODWS0-DX255DWS | numeric yes yes signed words in DX

255

FDS0-FDS255 numeric yes yes signed double words in flag bytes

SDS0-SDS4095 numeric yes yes signed double words in Sflags

DB1DDS0-DB255DDS numeric yes yes signed double words in DB

254

DX0DDS0-DX255DDS numeric yes yes signed double words in DX

254

Update logical yes no goes FALSE when a poll starts and
TRUE when a poll completes

CommPFail logical yes no object-generated signal that is ON if
Lookout cannot communicate with
the device(s)
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Table 18-20. Applicom SAIA SBus Data Members

Data Member Type Read | Write Description

FO-F8091 logical yes yes flags

10-18091 logical yes no input

00-08091 logical yes yes output

RO-R4095 numeric yes yes binary registers

RS0-RS4095 numeric yes yes signed binary registers

R0.0-R4095.31 logical yes yes bits in binary registers

Q0-Q4095 numeric yes yes floating registers

DBORO0O-DB7999R7999 numeric yes yes binary data block

DBORO0.0-DB7999R7999.31 | logical yes yes bits in binary data block

DBORO0.0-DB7999R7999.31 | logical yes yes bits in binary data block

DB0QO0-DB7999Q7999 numeric yes yes floating data block

Update logical yes no goes FALSE when a poll starts and
TRUE when a poll completes

CommPFail logical yes no object-generated signal that is ON
if Lookout cannot communicate
with the device(s)
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Table 18-21. Applicom Siemens S5 AS511 Data Members

Data Member Type Read Write Description
F0.0-F255.7 logical yes yes bits in flag bytes
S0.0-S4095.7 logical yes yes bits in Sflags (internal bytes)
10.0-1127.7 logical yes no input bits
Q0.0-Q127.7 logical yes yes output bits
DB1D0.0-DB255D255.15 logical yes yes bits of DB word
DX0D0.0-DX255D255.15 logical yes yes bits of DX word
FYO0-FY255 numeric yes yes flag bytes
SY0-SY4095 numeric yes yes Sflags (internal bytes)
IBO-1B127 numeric yes no input bytes
QY0-QY127 numeric yes yes output bytes
FWO0-FW254 numeric yes yes words in flag bytes
SWO0-SW4094 numeric yes yes words in Sflags (internal bytes)
IWO0-IW126 numeric yes no input words
QW0-QW126 numeric yes yes output words
DB1DWO0-DB255DW255 numeric yes yes Update pulse: words in DB
DX0DWO0-DX255DW255 numeric yes yes Update pulse: words in DX
FDO-FD255 numeric yes yes double words in flag bytes
SDO0-SD4095 numeric yes yes floating words in Sflags
DB1DDO0-DB255DD254 numeric yes yes double words in DB
DX0DDO0-DX255DD254 numeric yes yes double words in DX
FDOKG-FD252KG numeric yes yes floating words in flag bytes
SDOKG-SD4092KG numeric yes yes floating words in Sflags
DB1DDOKG-DB255DD254KG | numeric yes yes floating words in DB
DX0DDOKG-DX255DD254KG | numeric yes yes floating words in DX
FYSO0-FYS255 numeric yes yes signed flag bytes
SYS0-SYS4095 numeric yes yes signed Sflags (internal bytes)
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Table 18-21. Applicom Siemens S5 AS511 Data Members (Continued)

Data Member Type Read Write Description
IBSO-IBS127 numeric yes no signed input bytes
QYS0-QYS127 numeric yes yes signed output bytes
FWS0-FWS254 numeric yes yes signed words in flag bytes
SWS0-SWS4094 numeric yes yes signed words in Sflags (internal
bytes)

IWSO0-IWS126 numeric yes no signed input words

QWS0-QWS126 numeric yes yes signed output words

DB1DWS0-DB255DWS255 numeric yes yes signed words in DB

DX0ODWS0-DX255DWS255 numeric yes yes signed words in DX

FDS0-FDS255 numeric yes yes signed double words in flag
bytes

SDS0-SDS4095 numeric yes yes signed double words in Sflags

DB1DDS0-DB255DDS254 numeric yes yes signed double words in DB

DX0DDS0-DX255DDS254 numeric yes yes signed double words in DX

Update logical yes no goes FALSE when a poll starts
and TRUE when a poll
completes

CommPFail logical yes no object-generated signal that is
ON if Lookout cannot
communicate with the device(s)

Table 18-22. Applicom Siemens S7 MPI Data Members
Data Member Type Read | Write Description

MO0.0-M65535.7 logical yes yes bits in flag bytes

DB1.DBX0.0-DB8191. logical yes yes bits in DB byte

DB65535.7

E0.0-E65535.7 logical yes no input bits

A0.0-A65535.7 logical yes yes output bits
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Table 18-22. Applicom Siemens S7 MPI Data Members (Continued)

Data Member Type Read | Write Description
MBO0-MB65535 numeric yes yes flag bytes
DBODBB0-DB32767. numeric yes yes bytes in DB
DBB65535
EBO-EB65535 numeric yes no input bytes
ABO0-AB65535 numeric yes yes output bytes
MWO0-MW65534 numeric yes yes words in flag bytes
DB0.DBW0-DB32767. numeric yes yes words in DB
DBW65534
EWO0-EW65534 numeric yes no input words
AWO0-AW65534 numeric yes yes output words
MDO0-MD65532 numeric yes yes double words in flag bytes
DB0.DBD0-DB32767. numeric yes yes double words in DB
DBD65532
MBS0-MBS65535 numeric yes yes signed flag bytes
DBODBBS0-DB32767. numeric yes signed bytes in DB
DBBS65535 yes
EBS0-EBS65535 numeric yes no signed input bytes
ABS0-ABS65535 numeric yes yes signed output bytes
MWS0-MWS65534 numeric yes yes signed words in flag bytes
DB0.DBWS0-DB32767. | numeric yes yes signed words in DB
DBWS65534
EWS0-EWS65534 numeric yes no signed input words
AWS0-AWS65534 numeric yes yes signed output words
MDS0-MDS65532 numeric yes yes signed double words in flag bytes
DB0.DBDS0-DB32767. | numeric yes yes signed double words in DB
DBDS65532
MDOF-MD65532F numeric yes yes floating words in flag bytes
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Table 18-22. Applicom Siemens S7 MPI Data Members (Continued)
Data Member Type Read | Write Description

DB0.DBDOF-DB32767. | numeric yes yes floating words in DB

DBD65532F

Update logical yes no goes FALSE when a poll starts and
TRUE when a poll completes

CommPFail logical yes no object-generated signal that is ON if
Lookout cannot communicate with the
device(s)

Table 18-23. Applicom Siemens S7 PPl Data Members
Data Member Type Read | Write Description

MO0.0-M65535.7 logical yes yes bits in flag bytes

DB1.DBX0.0-DB8191. logical yes yes bits in DB byte

DB65535.7

E0.0-E65535.7 logical yes no input bits

A0.0-A65535.7 logical yes yes output bits

MBO0-MB65535 numeric yes yes flag bytes

DBODBB0-DB32767. numeric yes yes bytes in DB

DBB65535

MBS0-MBS65535 numeric yes yes signed flag bytes

DBODBBS0-DB32767. numeric yes yes signed bytes in DB

DBBS65535

EBS0-EBS65535 numeric yes no signed input bytes

ABS0-ABS65535 numeric yes yes signed output bytes

MWS0-MWS65534 numeric yes yes signed words in flag bytes

DB0.DBWS0-DB32767. | numeric yes yes signed words in DB

DBWS65534

EWS0-EWS65534 numeric yes no signed input words

AWS0-AWS65534 numeric yes yes signed output words

MDS0-MDS65532 numeric yes yes signed double words in flag bytes

Lookout Reference Manual 18-58 © National Instruments Corporation



Chapter 18 Object Class Reference

Table 18-23. Applicom Siemens S7 PPI Data Members (Continued)

Data Member Type Read | Write Description
DB0.DBDS0-DB32767. | numeric yes yes signed double words in DB
DBDS65532
EBO0-EB65535 numeric yes no input bytes
ABO0-AB65535 numeric yes yes output bytes
MWO0-MW65534 numeric yes yes words in flag bytes
DB0.DBW0-DB32767. numeric yes yes words in DB
DBW65534
EWO0-EW65534 numeric yes no input words
AWO0-AW65534 numeric yes yes output words
MDO0-MD65532 numeric yes yes double words in flag bytes
DB0.DBD0-DB32767. numeric yes yes double words in DB
DBD65532
MDOF-MD65532F numeric yes yes floating words in flag bytes
DB0.DBDOF-DB32767. numeric yes yes floating words in DB
DBD65532F
Update logical yes no goes FALSE when a poll starts and
TRUE when a poll completes

CommPFail logical yes no object-generated signal that is ON if
Lookout cannot communicate with the
device(s)

Table 18-24. Applicom Siemens H1 Data Members
Data Member Type Read | Write Description

C1-C2097152 logical yes yes Bits

X1-X2097152 logical yes no Input bits

Y1-Y2097152 logical yes yes Output bits

V1-V2097152 numeric yes yes Internal words

VS1-VS2097152 numeric yes yes Signed internal words
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Table 18-24. Applicom Siemens H1 Data Members (Continued)

Data Member Type Read | Write Description
V1.0-V2097152.15 logical yes yes Bits in internal words
VD1-VD2097151 numeric yes yes Internal double words
VDS1-VDS2097151 numeric yes yes Signed internal double words
K1-K2097152 numeric yes yes Constant words
KS1-KS2097152 numeric yes yes Signed constant words
K1.0-K2097152.15 logical yes yes Bits in constant words
VF1-VF2097151 numeric yes yes Floating words
KFI1-KF2097151 numeric yes yes Floating constant words
WX1-WX2097152 numeric yes yes Input words
WXS1-WXS2097152 numeric yes yes Signed input words
WY1-WY2097152 numeric yes yes Output words
WSY1-WYS2097152 numeric yes yes Signed output words
TCP1-TCP65536 numeric yes yes Timer/counter preset
TCC1-TCC65536 numeric yes yes Timer/counter current
DSP1-DSP65536 numeric yes yes Drum step preset
DSC1-DSC65536 numeric yes yes Drum step current
DCP1-DCP65536 numeric yes yes Drum count preset
STW1-STW65536 numeric yes yes System status words
Update logical yes no goes FALSE when a poll starts

and TRUE when a poll completes
CommPFail logical yes no object-generated signal thatis ON
if Lookout cannot communicate
with the device(s)
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Table 18-25. Applicom Telemecanique Data Members

Data Member Type Read | Write Description

B0-B4095 logical yes yes internal bits

100.0-1F7.F logical yes no input bits

000.0-OF7.F logical yes yes output bits

WO0-W32767 numeric yes yes internal words

IW00.0-IWF7.7 numeric yes no words in input registers

OW00.0-OWF7.7 numeric yes yes words in output registers

Special

DWO0-DW32766 numeric yes yes internal double words

WS0-WS32767 numeric yes yes signed internal words

IWS00.0-IWSF7.7 numeric yes no signed words in input registers

OWS00.0-OWSF7.7 numeric yes yes signed words in output registers

Special

DWS0-DWS32766 numeric yes yes signed internal double words

FWO0-FW32766 numeric yes yes internal floating words

Update logical yes no goes FALSE when a poll starts and
TRUE when a poll completes

CommPFail logical yes no object-generated signal that is ON if
Lookout cannot communicate with the
device(s)

General Information on Using the Applicom drivers for Lookout

The Applicom drivers for Lookout are all contained in APPLICOM. CBX
(16- or 32-bit) which is designed to work with the Applicom server
software distributed with every Applicom card. These drivers assume that
you have version 2.9 or later of the Applicom software installed on the
same computer under the same operating system as your copy of Lookout.
The appLICOM. CBX file presently supports 12 different object classes
corresponding to 12 different protocols or object types.
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Before you start using Lookout with Applicom, you must follow certain
configuration and testing procedures to ensure that Lookout can
communicate with your devices. The steps include configuration, loading,
testing, and if you choose, cyclic function configuration.

First, however, take special notice of the two different modes for using the
Lookout Applicom driver—Image and Local. The distinction between these
two modes is crucial to using the Lookout Applicom object classes.

Applicom Local and Image Modes

You can configure the Applicom server software to constantly poll a
remote device and store data in a database onboard your Applicom card.
You use Local mode to access that data.

In Lookout, you address the data using a generic addressing scheme (as a
bit number, or word number, and so on.). The Applicom card takes care of
polling the device and writing out new values to registers on the device. If
there are any problems in communicating with the device, an error code
may be generated and stored in a specified database location. The Lookout
driver can then use the data at that location to generate alarms.

In Image mode you address data on the remote device according to the
addressing scheme commonly used with the particular class of devices.
In this mode, Lookout asks for data directly from a remote device and is
notified of communication errors when they arise. The Lookout Applicom
driver then retries the particular data transfer repeatedly, generating alarms
when the data transfer continues to fail.

You use the Applicom Local object class for local mode functionality,
and the other device- or protocol-specific object classes for image mode
functionality. You can use Applicom Local concurrently with any of the
other Applicom classes.

The Image mode classes are the typical way to use the Applicom driver for
most applications. However, the Local mode provides a convenient way to
achieve two goals: providing access to data from multiple applications
(because any application may use the Applicom functions to access the
local mode database); and allowing inputs from one device connected to a
card to be written to outputs on another device connected to the same card
without the interference of the Windows operating system or the client
application (for example, Lookout).
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Configuration of the Applicom Server

After you install the Applicom server software, you must first configure it
using the PCcConf utility provided as part of the Applicom software. Refer
to the Software Installation section of your Applicom documentation for
details on using Applicom software. You use the PCConf utility to set the
basic types of devices connected to the Applicom card and the protocols
used to connect to them. You also set all the communication parameters
with this program.

While configuring your system with PCCon £, make note of the Channel
number and Equipment number for the device(s) you are using Lookout to
communicate with. You will need these values as parameters when you
create Lookout objects in Image mode.

Loading of the Applicom Server

After you configure the Applicom Server, you must download the
appropriate firmware module to the card and then configure it. You do this
by running the Applicom program PCInit. The configuration software
notifies you at this time if there is any physical problem with the installation
of the card.

You must run PCInit every time you restart the computer if you plan to
communicate with the Applicom card and connected devices during that
session. Because of this, you may consider putting a shortcut to this
program in the Startup program group.

At this point, the Applicom server should be ready to communicate with
Lookout and with the remote devices connected to the card. Before starting
Lookout and attempting to communicate, you should first test the
connections using some of the Applicom programs.

Testing the Applicom Server

The ReadWait program in the Applicom server group is a good example
of a program that can be used to test the connectivity of the Applicom card
with a remote device. You can also use WritWait, Essai, and Essaigb.
Try performing read or write operations using these programs to test
whether you can perform basic data transfer operations between the card
and the devices. If these tests fail, Lookout will not be able to communicate
with the devices either.

If your tests succeed and Lookout fails to communicate with the Applicom
devices, it is likely that the problem is in the Lookout object configuration.
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Because the Applicom programs require you to use the channel and
equipment numbers from the PCConf program, testing helps you verify
that you have the correct numbers.

Creating the Cyclic Functions

There is only one more step before you start using the Lookout drivers, and
it is required only if you are planning to use the Applicom Local object
class. In that case, you must first configure the cyclic functions that
exchange data between the onboard database of the Applicom card and the
remote devices.

You do this by using either the Applicom CreateCyc or PCCyc utility
programs. These programs require that you enter a channel number, an
equipment number, and whether the required operation is a read or a write.
You also enter the address of the data on the remote device and the
requested address of the data in the database. Once you have created and
saved the cyclic functions, you can test them using the GetDB and SetDB
programs in the Applicom server.

After you verify that the card can communicate with the remote device, you
can start using Lookout. Create a Lookout object of the appropriate class,
enter the required parameters, and start communicating with the remote
device.

Special Instructions on Using the Applicom Local Object Class

Lookout Reference Manual

The Applicom Local object class behaves very differently from the Image
mode object classes. To use it, you must have configured cyclic functions
on your Applicom card using the Applicom PCCyc or CreateCyc
programs.

After you configure these functions, you can create one or more Applicom
Local objects in Lookout to read from or write to the Applicom database
directly. The syntax is a generic syntax which does not correspond with the
syntax you use with the PLC. The address you specify in Lookout must be
the address of the data on the Applicom board, not the address on the
remote device.

You can also specify a status word in the PCCyc program for each cyclic
function you create. You can then specify a single status address in the
object creation/modification dialog box for Applicom Local to get Lookout
alarms any time the corresponding cyclic function is unable to exchange
data successfully.
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The Applicom Local object class is compatible with the other object classes
so that you can create multiple Applicom object classes of any type and use
them all at the same time.

Applicom Status Messages

The requested address is incorrect

You have requested data for an invalid address. Check the address and try
again. For further details check the Applicom documentation for an
explanation of error code 2.

Incorrect data type

The type of the data on the device is not compatible with the requested type.
This may occur for different reasons in different protocols. For further
details check the Applicom documentation for an explanation of error
code 3.

Irretrievable data

The data you are trying to access is irretrievable. Please check that the
device is connected and has all the appropriate models. For further details
check the Applicom documentation for an explanation of error code 4.

Response timed out

The device did not respond to a message within the time-out period. Check
that the device is connected. For further details, check the Applicom
documentation for an explanation of error code 33.

Check word or parity fault
Check the channel and target equipment configuration and the wiring to the
equipment. For further details, check the Applicom documentation for an
explanation of error code 34.

Data not available in cyclic read
There was an error in reading from the card. Contact National Instruments
technical support if this error occurs.

Equipment not configured

Configure the equipment with PCConf. If you have already done so, check
that you are using the correct (logical) equipment ID, as configured in
PCConf.

Deferred read or write request when deferred request register is full

There was an error in writing to the card. Contact National Instruments
technical support if this error occurs.
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Deferred request transfer attempt with transdif when request register
is empty

There was an error in writing to the card. Contact National Instruments
technical support if this error occurs.

Communication software not initialized
The Applicom board was not initialized using the PCInit software. Close
Lookout, run PClInit and try running Lookout again.

Board number not configured
The board number you are attempting to use is not one that has been
configured. Please check the configuration using PCConf.

No Applicom interface
There is no Applicom interface present. Check that PClnit executed
correctly.

Timeout elapsed. Message lost

A communication problem occurred that may be related to the
configuration of the remote equipment or the bus that the equipment is on.
For further details, check the Applicom documentation for an explanation
of error code 55.

Negative acknowledgment (NAK) from equipment

A message was received by the destination equipment but not processed
due to lack of resources. For further details, check the Applicom
documentation for an explanation of error code 56.

Communication refused by the equipment.

The equipment is not responding to communication requests. This may
be caused by a misconfigured device or by a bad connection with the
Applicom card. Check the device configuration, check the Applicom
configuration and use the Applicom utilities to check that there is
communication between the two.

Bad frame received
The remote device is not behaving correctly. Check the configuration of the
device.

Errorcode ID: refer to Applicom documentation
Your application has returned an error specific to your Applicom device.
Consult your Applicom documentation for further information.
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Aquatrol

Aquatrol is a protocol driver class Lookout uses to communicate with
Aquatrol W1500 controllers.

Create Aquatrol Secondary | ]
Tagname: |aelEs

Address: |1DD kModel: |W1SDD 'l

Communication Settings

Serial port: ICOM1 'l Data hits: I? 'l
Baud Rate: |1ZDD 'l Stop hits: |1 'l
Parity: INDne j Phaone: I
FuollRate = Ig;m
Pall = I Cancel |

Communication alarm priority: IB Configuration |

Retry attempts: |4 Feceive timeout:  [1000  msecs

Skip every |5 poll requests after comm failure

Figure 18-15. Aquatrol Definition Parameters Dialog Box

Address is the address of the RTU as configured on the device. The address
can be in the range of 100 to 999 inclusive.

Model is W1500 only at this time.

Serial port specifies which port the object uses for communication to
the external device. This does not specify the communication type.
Communication type is determined by the Options»Serial Ports...
command.

Data rate, Parity, Data bits, and Stop bits reference the settings on the
hardware device.

Phone specifies the number to be dialed if the serial port setting is
configured for dial-up. This number only applies to the individual protocol
object.

PollRate is a numeric expression that determines how often to poll the
device. Lookout converts the numeric value of PollRate into a time signal
that represents days and fractions of a day. Aquatrol then polls the device

© MNational Instruments Corporation 18-67 Lookout Reference Manual



Chapter 18 Object Class Reference

at the specified time interval. Normally, this is a time constant such as
0:01 (one second). See the Numeric Data Members section in Chapter 2,
Introduction, for information on entering time constants.

Poll is a logical expression. When this expression changes from false to
true, Lookout polls the device. You can use a simple expression like the
signal from a pushbutton, or a complex algorithm.

Communication alarm priority determines the priority level of
object-generated alarms (0 — 10).

Retry attempts specifies the consecutive number of times Lookout
attempts to establish communications with a device if it is not getting a
valid response. After it tries the number of Retry attempts specified, the
Aquatrol object generates an alarm and releases the communication port
back to the communications service which then moves on to the next device
in the polling queue (if any).

Receive timeout is the time delay Lookout uses in waiting for a response
from a device before retrying the request.

The Skip every... setting instructs Lookout not to poll a device it has lost
communication with on every scheduled poll. Instead, Lookout skips the

device in the polling cycle accordingly. Once communications have been

reestablished, the device is polled on its regular cycle.

RTU Configuration Dialog Box

Lookout Reference Manual

RTU Configuration | ]
In Out Counters

Digitals | |2 Start |n
Analogs |5 |5 Runtime ID
Totalizers ID

Fepeater address I (not used if blank)
Default Values | Cancel | oK I

Figure 18-16. RTU Configuration Dialog Box

You must configure Lookout to match the configuration in your Aquatrol
device.

Digital (In/Out) specifies configuration for the number of discrete I/O.
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Analogs (In/Out) specifies configuration for the number of analog I/O.
Totalizers specifies configuration for the number of totalizers.

Start specifies configuration for the number of start counters.
Runtime specifies configuration for the number of runtime counters.

Repeater Address is the final destination address if a repeater is being
used.

Note The Aquatrol must be configured with all 1/0 grouped together by kind. Digital
inputs must be the first physical inputs on the device, followed by digital outputs.
Analog inputs are next, followed by analog outputs. If you do not configure the
I/0 this way, you can receive invalid data.

Aquatrol Data Members

All readable and writable members (inputs/outputs), polling instructions,
read/write blocking, serial port usage, and so on, are bundled with the
object. Therefore, as soon as you create an Aquatrol object you
immediately have access to all the object data members (see data
member list below).

5 Note Lookout protocol driver objects automatically generate an efficient read/write
blocking scheme based on the inputs and outputs being used in your process file.
You are not required to build your own 1/0 blocking table.

Table 18-26. Aquatrol Data Members

Data Member Type Read | Write Description

All1-AI48 numeric yes no Analog Input, 16 bit.

AO1-A048 numeric no yes Analog Output, 16 bit.

ColdRestart logical yes no True if the device power has cycled
on/off or the reset button has been
pushed.

CommPFail logical yes no True if serial communications have
failed.

ConfigError logical yes no True if the configuration of the device
does not match the configuration set in
the configuration dialog of the
Aquatrol device.
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Table 18-26. Aquatrol Data Members (Continued)

Data Member Type Read | Write Description

DataFail logical yes no True if the device has had a data
failure.

DI1-DI48 logical yes no Discrete Input, 1 bit.

DO1-D0O48 logical no yes Discrete Output, 1 bit.

EEPROMerror logical yes no True if the device has an EEPROM
erTor.

LowBattery logical yes no True if the device has a low battery.

PowerFail logical yes no True if there is no power to the device,

R1-R48 numeric yes no Runtimes, 16 bit.

Poll logical no yes True initiates a Poll sequence.

PollRate numeric no yes Time interval of Polling sequence.

S1-S48 numeric yes no Starts, 16 bit.

T1-T48 numeric yes no Totalizers, 16 bit.

Update logical yes no False during Polling sequence.

WarmRestart logical yes no True if the device has been reset
locally.

Aquatrol Status Messages

Lookout Reference Manual

No response within timeout period

No response within timeout period for repeated message. Lookout did not
received the expected response within the Receive timeout period. The
object sent an inquiry and received an acknowledgment, but the device did
not send an expected response to the request. This might happen if the
response was interrupted. You may have to increase Receive timeout.

Frame Error (garbled): Invalid destination address
Lookout has received a frame with an invalid return address. Make sure that
no duplicate addresses exist on the Aquatrol network.

Frame Error (garbled): Invalid source address

Lookout has received a frame from a device that you are not actively
polling. Make sure that there is only one outstanding master request at a
time.
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Frame Error (garbled): Invalid message length for configuration
Lookout has received a frame whose length conflicts with the length
expected based on the configuration settings in the Aquatrol device
configuration dialog box.

Frame Error (garbled): Invalid CRC
Lookout has received a frame with an invalid CRC (cyclic redundancy
check). Check for signal noise on Aquatrol network.

Invalid discrete address #: Check configuration settings

Invalid analog address #: Check configuration settings

Invalid runtime address #: Check configuration settings

Invalid start address #: Check configuration settings

Invalid totalizer address #: Check configuration settings

All the above errors mean that a I/O point being either read or written is
out of range with respect to the configuration set in the Aquatrol device
configuration dialog box.
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ASCIl is a protocol driver class Lookout uses to communicate with any
serial device that accepts ASCII characters. This object is only available
with 32-bit versions of Lookout.

An ASCII object contains no predefined data points. When you create an
ASCII object, you must define your data request strings as well as the
template Lookout uses to parse the response frame.

Create ASCIl Secondary | ]

—Communication Settings

Serial port: ICOM1 'l
Baud Rate: I%DD 'l
Farity: INDne 'l

Fhone number: I

Data hits: IB 'l
|1 vl

Stop hits:

tonitar serial port T

Communication alarm priority: I8

Retry attempts: |4 Receive timeout;  |250 msecs
Skip every |5 poll requests after comm failure

o]

Cancel |

Figure 18-17. ASCII Definition Parameters Dialog Box

Serial port specifies which COM port the object uses for communicating
to the external device. This does not specify the communication type.
Communication type is determined by the Options»Serial Ports...
command.

Baud rate indicates the rate that Lookout uses to communicate with the
hardware device.

Data bits indicates the number of data bits that Lookout uses to
communicate with the hardware setting should match the selection made on
the physical device. device. This setting should match the selection made
on the physical device.
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Stop bits indicates the number of stop bits that Lookout uses to
communicate with the hardware device. This setting should match the
selection made on the physical device.

Parity indicates the parity that Lookout uses to communicate with the
hardware device. This setting should match the selection made on the
physical device.

Phone number specifies the number to be dialed if the selected serial port
is configured for dial-up. This number only applies to the individual
protocol object.

Monitor Serial Port specifies whether you can receive unsolicited frames.

Communication alarm priority determines the priority level of alarms
generated by the ASCII object. Such alarms are typically related to
communications with the physical device.

Retry attempts specifies the number of times Lookout attempts to
establish communications with a device if it is not getting a valid response.
After it tries the number of Retry attempts specified, the ASCII object
generates an alarm and releases the communication port back to the
communications service which then moves on to the next device in the
polling queue (if any). Refer to Chapter 6, Serial Communications, for
more information.

Receive timeout is the amount of time Lookout waits for a response from
a device before retrying the request.

The Skip every N poll requests after comm failure setting instructs
Lookout not to poll a device it has lost communication with on every
scheduled poll. Instead, Lookout polls the device only once in the specified
number of poll cycles. Once communication has been reestablished, the
device is polled on its regular cycle.

ASCII Data Members

Table 18-27. ASCII Data Members

Data Member Type Read | Write Description
RequestFormat text no yes Format used to create request frame.
ResponseFormat text no yes Format used to parse response frame.
Send logical no yes Sends request frame.
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Table 18-27. ASCII Data Members (Continued)

Data Member Type Read | Write Description

RQV1,RQV100 numeric no yes Variable list used to populate request
frame with numeric values.

RQVI1.txt, RQV100.txt | text no yes Variable list used to populate request
frame with text values.

RQV1.logical, logical no yes Variable list used to populate request

RQV100.logical frame with logical values.

RSFilter text no yes All characters in this string will be
filtered out of the incoming response
before processing.

RSSuml:1 - numeric yes no Response byte sum

RSSum?255:255

RQSum:1:1 - numeric yes no Request byte sum

RQSum?255:255

RSV1, RSV100 numeric yes no Variable list used to store values
retrieved from response frame.

RSV1.txt, RSV100.txt text yes no Variable list used to store values
retrieved from response frame.

RSV1.logical, logical yes no Variable list used to store values

RSV100.logical retrieved from response frame.

OffHook logical no yes Keeps the driver from releasing the
serial port.

Request text yes no Exact request frame sent.

Response text yes no Exact response frame received.

CommPFail logical yes no Object-generated signal that is on if
Lookout cannot communicate with the
device(s).

Update logical yes no Object-generated signal that pulses
low each time it polls the device.

RSVn, RSVn.txt and RSVn.logical all represent the same value in different forms
RQVn, RQVn.txt and RQVn.logical all represent the same value in different forms

Lookout Reference Manual
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Request and Response Format Strings

The request and response format strings consist of static characters and
markers that control how the request and response frames respectively are
formatted or decoded. The request format string is used to create the
request frame, which is sent to the device, while the response format string
is used to decode the response frame, which comes from the device.

Static characters in the format strings are reproduced exactly in the request
or response frame. Markers specify the location within the frame and type
of data which should be found there, such as five characters read as an
unsigned integer, for example. The ASCII object constructs a request frame
by processing the sequence of static characters and markers in the request
format string, and including data from RQV data members.

The response format string decodes a response frame using an analogous
process, storing the results in RSV data members.

To construct a request frame, the ASCII object parses the request format
string character by character. Static characters are copied directly to the
request frame. When a marker is encountered the ASCII object reads a
value from the appropriate RQV variable and places it into the request
frame.

There are 100 RQV and RSV values provided for in the ASCII object data
member collection. The first marker in a format string uses the value from
RQV1 (or RQV1.txt or RQV1.logical), the next marker uses the value
RQV2, and so on. Values taken from Response strings are stored in RSV
data members in the same way.

Keep in mind that writing into RQV1 changes the value both for RQV 1.text
and RQV1.logical. Their only difference is the format in which they are
represented. The same principle applies to the RSV data members.

Note There is no precedence to the order in which multiple objects connected to the
same variable number initialize upon opening the process file. Consider, for
example, the case in which a Pot object is connected to RQV1 while a TextEntry
object is connected to RQV1.txt. You should take care to initialize such variables
to the proper value after opening a process file.

To decode a response frame, the ASCII object compares the response frame
to the response format string character by character. The static characters in
the response frame must match those in the response format string or the
decoding process terminates. Static characters are, in effect, discarded by
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the ASCII object as they are matched between the response format string
and the response frame.

When the ASCII object encounters a marker, it places the data indicated by
the marker into the appropriate RSV data member.

The conversion of a portion of the response frame to a data type specified
by a marker in the response format string must be valid, or the process will
terminate.

If nothing halts the process, decoding terminates when the end of the
response frame string is reached.

There are examples of both request frames and response frames at the end
of this section, but for the examples to make sense, you must first
understand the ASCII object markers.

ACSII Object Markers

The general format for a marker is:
Y%[width][type]

Each field in the marker format is a single character or a number signifying
a particular format option.

The % sign denotes the beginning of the marker. If the percent sign is
followed by a character that has no meaning as a format-control character,
that character and the following characters (up to the next percent sign) are
treated as static characters, that is, a sequence of characters that must match
the frame exactly. For example, to specify that a percent-sign character is a
static character part of the frame, use % %.

Width is a positive decimal integer specifying the number of characters
that particular value occupies in the frame. By default ASCII pads the value
with blank spaces if the value takes up fewer characters than the value
specified by width. Including a O before the width value forces the ASCII
object to pad with zeroes instead of blank spaces.

Type determines whether the field is interpreted as a character, a string,
or a number.
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Table 18-28. Data Types Allowed by ASCII

Character Data Type
d Decimal integer
X, X Hexadecimal integer
u Unsigned decimal integer
f Floating-point
S String
b Byte (binary)

The simplest format specification contains only the percent sign and a type
character (for example, %s). That would place the value in the response
frame in the RSV 1.txt data member.

Request Format
String RQV1 Request Frame
>%5d 34 > 34
>%05d 34 >00034

The request format string also has a precision value in the form

% |width].[precision][type]. This specifies the number of digits to the
right of the decimal point, if any, in the request frame. If you use a float
(%f) and do not specify a precision value, the ASCII object assumes a
default of 6.

Characters are converted and stored in RSV data members from response
frames in the order they are encountered in the response format. However,
fewer than [width] characters may be read if a white-space character
(space, tab, or newline) or a character that cannot be converted according
to the given format occurs before [width] is reached.

Values needed for request frames come from the RQV data members, and
are also used in the order in which they occur in the request format.

To read strings not delimited by space characters, or that contain spaces,
you can substitute a set of characters in brackets ([ ]) s (string) type
character. The corresponding input field is read up to the first character that
does not appear in the bracketed character set. Using a caret (") as the first
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character in the set reverses this effect: the ASCII object reads input field
up to the first character that does appear in the rest of the character set

Response Response
Format String RSV1.txt Frame
$S[A-Z,a-1z1% Natl Inst $Natl Inst$
>[7s] days >day

Notice that %[a — z] and %[z — a] are interpreted as equivalent to
%|abcde...z], and that the character set is case sensitive.

The brackets only work in response format strings. They have no effect in the
request format string.

The ASCII object scans each field in the response frame character by
character. It may stop reading a particular field before it reaches a character
for a variety of reasons:

e The specified width has been reached.
e  The next character cannot be converted as specified.

e The next character conflicts with a character in the response format
string that it is supposed to match.

¢ The next character fails to appear in a given character set.

No matter what the reason, when the ASCII object stops reading a field,
the next field is considered to begin at the first unread character. The
conflicting character, if there is one, is considered unread and is the first
character of the next field.

Entering ASCII Object Format String

For a static connection to one of the format data members, enter your
format string in the yellow field box in the Edit Connections dialog box.
Remember to begin and end the format strings with quotation marks so that
Lookout accepts the string input.

You can also connect any valid text data member, such as a text entry
object, to the format data members.
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Request Frame Construction Examples

Request Request
Format String RQV Frame

<01%4u%s RQV1=1234 <011234Steph
RQV2.txt=Steph

<01%04u%s RQV1=34 <010034Steph
RQV2.txt=Steph

<01% 4u%s RQV1=34 <01 34Steph
RQV2.txt=Steph

A zero in front of the four pads with zeroes; a space pads with spaces.

Response Format Examples

Response Response
Frame Format String RSV
*(16.38: *(%52f: RSV1=16.38

Note

frame.

The decimal point counts as a character when decoding floats (%f). Also, decimal
points denoting precision are not allowed when decoding a float in the response

>>Test Text<<

>>%s<<

RSV1.txt=Test

The space between the words terminates the conversion. See the bracketed

character example above in order to span a space or other special

characters.
>>Test Text<< >>%s%8<< RSV1.txt=Test
RSV2.txt=Text
>>DogCat<< >>%35%3s<< RSV1.txt=Dog
RSV2.txt=Cat

The response format uses a space as a delimiter.
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Using Sum Data Members

The ASCII object includes summing data members you can use to calculate
checksum characters. This can be a checksum you want to write into an
outgoing request frame or a checksum you want to verify in an incoming
response frame.

For example, if you want to calculate a checksum for the request 2008,
you would use an RQSum (request sum) data member. In the case of 200B,
you would use RQSuml : 4, which would give you a sum of the ASCII byte
values of characters 1 through 4. Once you have this sum, you can
manipulate it mathematically any way necessary for the checksum value
you need. You can then insert this value at the end of your frame as a byte
(%b) or a series of bytes.

The same technique works in reverse for RSSum (response sum) data
members.

For example, consider the response z00A@. You know that you are
expecting 4 bytes plus a checksum. Assuming that this checksum
calculation involves the first four characters, use RSSuml : 4 to the byte sum
of characters 1 through 4. After performing the appropriate mathematical
manipulation, you can compare this value with the actual byte read from the
frame, and determine when there is a checksum failure.

Note There are many different methods for calculating checksums, and these data
members cannot support all of them. Before attempting to use them for checksum
calculation, make sure your checksum can be calculated from a simple byte sum
of characters in the frame.

ASCII Error Messages

No response from device within timeout period

Lookout received no response from the device within the Receive timeout
period. The ASCII object was able to establish a socket, but when it sent a
message to the device, the device did not respond—as if it were not there.
You may have to significantly increase Receive timeout (and Poll Rate)
to ensure Lookout is allowing enough time to receive the expected
response. Also, verify your cable connections, power, configuration
settings, and IP settings.
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Not enough data to send a valid frame

This means that the ASCII object has not received enough data to fill in all
the variables in the Request Format frame. This could mean that you do not
have connections made to all of the RQVs that the ASCII object is
expecting.

Frame Error (garbled)
ASCII got a response frame, but static characters in the response did not
match up to the response format string.

Data type or length does not match format string
ASCII got a response frame, but certain characters in the response were not
in the format stated by the markers in the response format string.

Related Objects IPASCII
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Average

Average actively calculates the average value of Data over time. Average
is only active when the Enable expression is true and resets to zero when
the Reset expression transitions from off to on. Average also maintains an
array of up to 35 previous averaged values. If Enable is left blank, the
object always actively calculates the average.

Tan: W
Data = I
Reset= I
Enable = I
Ok | Cancel

Figure 18-18. Average Definition Parameters Dialog Box

Data is a numeric expression while Reset and Enable are logical
expressions.

= Note Average does not have a display parameters dialog box. However, you can easily
display the result of its output signal by referencing it in an expression.

Average Data Members

Table 18-29. Average Data Members

Data Members Type Read | Write Description

(implicit) numeric yes no Current average calculated since the
most recent Reset signal. Updated
approximately once per second.

1-35 numeric yes no Previous average values. Signal 1 is
the most recent prior average since the
Reset signal went high.

DataReset logical no yes Upon transition from FALSE to
TRUE, resets to zero all data
members—including the current
average and all previous averages.

Lookout Reference Manual 18-82 © National Instruments Corporation



Chapter 18 Object Class Reference

Comments The Reset expression could be a regular pulse interval created by a
TimeOfxxxx timer, so that the pulse is synchronized to the top of the hour or
day. For example, if you want to calculate the daily average flow rate, use
the output signal from a TimeOfDay timer or a daily Spreadsheet object to
reset the average calculation at the beginning of each day. If you want to
calculate the average flow rate only when a pump is running, use the input
signal from the pump motor relay in the Enable parameter.

Related Objects Minimum, Maximum, Sample
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Counter

Counter counts the number of times that the Count expression transitions
from off to on. The digital display shows the number of pulses counted so
far, and is updated approximately once per second—however, it can
receive and count multiple pulses within a given second. The counter can
count to just under 4,503,600,000,000,000 or 142,710 years worth of pulses
at one pulse per second. When the Reset expression transitions from off to
on, the counter resets to zero.

Tag:
Count = I
Feset= I

Ok | Cancel

Figure 18-19. Counter Definition Parameters Dialog Box

Both Count and Reset are logical expressions.

Note Counter does not have a display parameters dialog box. However, you can easily
display the result of Counter output signal by referencing its data member in an
expression.

Counter Data Members

Table 18-30. Counter Data Members

Data Member Type Read | Write Description

(implicit) numeric yes no numeric total of pulse count

Comments You should not use Counters to count external pulse signals that cycle more
often than about once per second. For higher counting speeds, use the
accumulator capabilities built into your PLC.

Related Objects Accumulator, Integral
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Cutler-Hammer

Cutler-Hammer is a protocol driver class Lookout uses to communicate
with Cutler-Hammer devices using serial communications.

It supports reading and writing of all predefined data points allowed by
the particular Cutler-Hammer model. When you create a Cutler-Hammer
object, you have immediate access to all the object data members. See the
Cutler-Hammer Data Member Set table for more information on data
members for this object.

Create Cutler-Hammer Secondary

Figure 18-20. Cutler-Hammer Definition Parameters Dialog Box

Address specifies which Cutler-Hammer device you are communicating
with using this object. This number is between 0 and 191, and is set on the
device. (An address number of 255 broadcasts to all devices connected to
the network.)

PLC Model specifies what model of Cutler-Hammer device you are using.
The only model supported now is the Cutler-Hammer D50.

Serial port specifies which comm port the object uses for communicating
to the external device. This does not specify the communication type.
Communication type is determined by the Options»Serial Ports
command.
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i Note For Lookout to communicate correctly with the Cutler-Hammer D50, you must
configure your COM port as radio using the Options»Serial Ports_command.

Lookout Reference Manual

Data rate indicates the baud rate that Lookout uses to communicate with
the hardware device. This setting should match the selection made on the
physical device.

Data bits indicates the number of data bits that Lookout uses to
communicate with the hardware device. This setting should match the
selection made on the physical device.

Stop bits indicates the number of stop bits that Lookout uses to
communicate with the hardware device. This setting should match the
selection made on the physical device.

Parity indicates the parity that Lookout uses to communicate with the
hardware device. This setting should match the selection made on the
physical device.

Phone number specifies the number to be dialed if the selected serial port
is configured for dial-up. This number only applies to the individual
protocol object.

PollRate is a numeric expression that determines how often to poll the
device. Lookout converts the numeric value of PollRate into a time signal
that represents days and fractions of a day. The object then polls the device
at the specified time interval. Normally, this is a time constant such as
0:01 (one second). See the Numeric Data Members section in Chapter 2,
Introduction, for information on entering time constants.

Poll is a logical expression. When this expression changes from false to
true, Lookout polls the device. You can use a simple expression like the
signal from a pushbutton, or a complex algorithm.

Communication alarm priority determines the priority level of alarms
generated by the Cutler-Hammer object. Such alarms are typically related
to communications with the physical device.

Retry attempts specifies the consecutive number of times Lookout
attempts to establish communications with a device if it is not getting

a valid response. After it tries the number of Retry attempts specified,
the Cutler-Hammer object generates an alarm and releases the comm port.
See Chapter 6, Serial Communications, for more information.
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Receive timeout is the time delay Lookout uses in waiting for a response
from a device before retrying the request.

The Skip every N poll requests after comm failure setting instructs
Lookout to not poll a device it has lost communication with on every
scheduled poll. Instead, Lookout skips the device in the polling cycle
accordingly. Once communications have been reestablished, the device is
polled on its regular cycle.

Cutler-Hammer Data Members

As with all Lookout drivers, you can access I/O points and other data
through data members. The following is a table of data members currently
supported by the Cutler-Hammer object class.

Table 18-31. Cutler-Hammer Data Member Set

Data Member Type Read | Write Description
R00000.logical - logical yes yes External inputs and outputs, and
R02915.logical special function registers
MO00000.1ogical - logical yes yes Internal relay
MO03115.logical
MO0000 - M0031 numeric yes yes Internal relay
K00000.logical - logical yes yes Keep relay
KO01515.1ogical
K0000 - K0015 numeric yes yes Keep relay
WO0000 - W2815 numeric yes yes Timers, counters, and word registers
Update logical yes no Goes high when Lookout begins a

poll cycle on the device
CommPFail logical yes no Goes high if Lookout cannot
communicate with the device
Poll logical no yes When transitioned from low to high,
Lookout begins a poll cycle on the
device
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Table 18-31. Cutler-Hammer Data Member Set (Continued)

Data Member

Type Read | Write Description

PollRate

numeric no yes Specifies the frequency at which
Lookout polls the device

For a more complete definition of the function of these data members, see Cutler-Hammer documentation.

Not all of these data members are valid for every Cutler-Hammer device. See Cutler-Hammer documentation to see which
data members are valid for your particular model number.

Cutler-Hammer Status Messages

Lookout Reference Manual

No response within timeout period

Lookout received no response from a device within the Receive timeout
period. The Cutler-Hammer object is able to use the comm port, but when
it polls the device, it does not respond—as if it is not even there. If you have
daisy-chained several devices, you may have introduced an inherent delay.
You may have to significantly increase Receive timeout (and Poll Rate)
to ensure Lookout is allowing enough time to receive the expected
response. This increase has nothing to do with the processing capabilities
of Lookout. Rather it is based solely on Data rate and the number of
devices on the chain. Also, verify your baud rate settings, cable
connections, power, configuration settings, comm port settings, and polling
addresses.

Invalid query acknowledge frame
This means that the query acknowledge frame sent from the PLC in
response to the command sent by Lookout out was invalid.

Invalid PLC address in response frame

This means that the address within the response frame from the PLC does
not match exactly the address in the command sent out by Lookout. You
may possibly be requesting an address that is outside the valid range from
Cutler-Hammer devices.

Invalid CRC in response
This means the checksum (CRC in this case) failed in a frame received by
Lookout. Check cabling or for two or more devices with the same address.

Garbled or invalid frame
Frame received without format characters in their proper positions. Check
the Receive gap setting.
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Invalid response frame
This means that the response frame from the PLC did not have the expected
number of bytes in it.

Invalid function code in response frame
This means that the function code within the response frame from the PLC
does not match the function code in the command sent out by Lookout.

Wrong query, length, or designation

This is an error returned as an error code frame from the Cutler-Hammer
device. This means that the device could not successfully interpret the
query you just sent it.

Designated range exceeded

This is an error returned as an error code frame from the Cutler-Hammer
device. It means you have requested an address beyond the valid range of
addresses.

Command too long in length

This is an error returned as an error code frame from the Cutler-Hammer
device. This means that the frame just sent has exceeded the maximum
amount information that can be transported in a single frame. (256 bytes)

Abnormal communications command
This is an error returned as an error code frame from the Cutler-Hammer
device.

Cutler-Hammer models supported:
D50
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DataTable

Object Class Reference

Note

DataTables are used in the following applications:
e Multiplexing various data sources into a single display template.

* Importing or exporting large quantities of data to other applications
using DDE. (Unlike the DdeTable, the DataTable provides
bidirectional DDE communications. See DdeTable.)

e Networking multiple Lookout nodes (see Chapter 14, Networking).

A DataTable contains a matrix of rows and columns, much like a
spreadsheet. Each column is represented by a letter (A —IV). Each row

is represented by a number (1 — 1,000). Letter-number combinations
represent intersections of rows and columns. Such intersections are called
cells. Any given cell contains a value. A cell value can be numeric, logical,
or textual.

DataTables are advanced tools that require a mastery of Lookout object databases.

Make sure you understand editing, connecting to, and using object databases and
aliases before creating a DataTable object. See Chapter 5, Developer Tour, for
more information on object databases.

Lookout Reference Manual

Create table B
Tag: ITabIe1
— Tahle location Import{Export
Filename =
 DDE I“tblsmp1.xls“

The following dialog box appears when you create a DataTable:

R IEXCB|

File Type: IXLS 'l Alarm pririty: IB
Security level: ID

(o]

= = ISheeﬂ

v L t:
o ITabIe1 ¥ Log events

Cancel

Figure 18-21. DataTable Definition Parameters Dialog Box

Specify DDE parameters if you want to use the DataTable to import large
quantities of data from an external source. Typical external sources include
another DataTable within a networked Lookout application or an array of
spreadsheet data. See Chapter 14, Networking, for more information on
networking.
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Specify Local if you are using the DataTable to export large quantities of
data from Lookout. Also specify Local if you are using the DataTable to
multiplex various signals into a single display or graphic template.

The export and import data members control the transfer of data between
Lookout and a Microsoft Excel spreadsheet. The spreadsheet filename
must be entered in the Import/Export section of the Create table dialog
box.

The data table import and export data members only work with Microsoft Excel
Version 4 at this time. This feature does not work with Excel Version 5 or greater.

Instead of entering a file name in the Import/Export dialog box, you can
enter a Lookout expression in the Filename field. You can then import and
export different files using a switch setting, a text entry box, or some other

expression input. If something goes wrong with the transfer of data,
including data corruption, Lookout reports an alarm.

Multiplexing Displays and Graphics

You can use DataTables to multiplex signals into a single control panel,
used as a template. For instance, assume you have nine identical pump
stations. At each site you have a single PLC monitoring the pressure, flow
rate, and status of two pumps. You are also controlling an analog output
with an operator setpoint from Lookout. Instead of developing nine
identical control panels in Lookout, you can build just one panel and
multiplex the signals from the nine sites into a single set of graphics.

The following figure is a graphical representation of the connections for a

possible DataTable.
A B C D E F
1 |Sitel FLC1 press FLCT flow FLCT pmp1  |PLC1 pmp2
2 |Site2 FLCZ press PLCZ flow » FLCZ pmp1  |PLCZ2 pmp2
3 |Site3 PLC3press  |PLC3 flow %% PLC3.pmp1  |PLC3.prmp?2
4 |Sited PLC4 press  |PLCA flow % % PLC4 pmp1  |PLC4.prp?2
5 |Sited FLCS press PLCS flow 2 L FLCS pmp1  |PLCS pmp2
6 |Site FLCE press PLCE flow wé FLCE pmp1  |PLCE pmp2
7 |Site7 PLC7.press  |PLCT flow h PLC7.pmp1  |PLC7.prmp?2
8 |Sited FLCE press FPLCE flow FLCE pmp1  |PLCE pmp2
9 [Sited PLCY press PLCAO flows PLCO pmp1  |FPLCY. pmp2
Figure 18-22. Graphical Representation of a DataTable Showing Connections
5 Note At this time there is no actual view in Lookout for you to see this table. It is a

representation, not a screen capture of a Lookout dialog box or display element.
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Each row of the table is connected to the site name, the data you want to
keep track of from the PLC at that site, and a place for the operator setpoint
data for that site.

Notice the tagnames of the nine PLCs (pLC1, PLC2...). Each value has an
alias (press, flow, pmpl, pmp2). Each cell represents a connection made
from that PLC output to the that cell of the DataTable.

The open column D represents the connection of a single Pot object called
Setpoint to the column—not to individual cells. This way Lookout only
changes the value of a cell in column D when that particular row has been
made active. You connect the individual cells in column D (D1 through D9)
to the correct holding registers (outputs) on the respective PLCs. For
example, Tablel.D1 would be connected to the appropriate data member
of PLC1 — Tablel.D2 to the appropriate data member of PLC2, and so on.
In other words, when you intend to multiplex signals to a panel through a
data table connect inputs from a PLC or RTU to individual cells. Connect
operator setpoints (outputs) to columns.

DataTable Example

To practice using a DataTable, you can create a PLC simulator as shown in
the following illustration. You can use a separate control panel for each
PLC output simulator, or place all the objects you make on one panel.

Site1Pressure
(glpg:aéfgss) sT— pumpi_1 (simulates PLC1.pmp1)
2+ pump1_2 (simulates PLC1.pmp2)
Site1Flow ——
(simulates
PLC.flow) \__ Setpoint indicator
(operator input)

Lookout Reference Manual

Use two slider pots as your pressure and flow outputs, and two switches as
the on/off indicators for pumps one and two. You can use the dial gauge at
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the bottom to check the operator input, Setpoint. Instead of connecting
the cells of your data table to PLC outputs, you connect directly to the
Lookout objects, named after the outputs for clarity.

You should create at least three sets of PLC input/output simulators, The
following example refers to the 9 PLCs mentioned in the Multiplexing
Displays and Graphics section, but you can explore using a data table
using 2 or 3 simulators.

Connect specific DataTable cells from the D column to the Setpoint
indicator for each PLC simulator.

After you have built your simulators, open a new Control Panel to use as
your display and create a DataTable. You will create the rest of the display

in a later step.

When it first appears, the DataTable contains the number 0. This indicates
the contents of cell Al. You can increase the size of the display window,
but you cannot show the entire array of data in the table. You can view the
contents of any cell in column A by clicking on the window when you are
in run mode. Selecting the contents of that cell activates that row of the data
table.

Enter text expressions into the cells of column A to act as your table index.
For example, enter the string "Site 1"as the connection to your DataTable
Al.txt data member. Connect the outputs of your PLC simulators to the
cells in the B, C, E, and F columns discussed below. You will connect an
operator input to the entire column D, and than later connect individual
cells in the D column to your PLC simulators.

A B C D E F
1 |Site 1 Site1Pressure | Site1Flow pump1_1 |pumpl_2
2 |Site 2 Site?Pressure | Site2Flow pumpZ_1 |pump2_2
3 |Site 3 Site3Pressure | Site3Flow pump3_1 |pump3_2
4 |Site 4 SitedPressure | SitedFlow pumpd_ 1 |pumpd_2
5 |Site 5 SiteSPressure | SiteSFlow pumps_1 |pump5_2
6 |Site B SiteBPressure | SiteBFlow pumpé_1 |pumpb_2
7 |Site 7 Site7Pressure | Site7Flow pump?_1 |pump?_2
8 |Site 8 SiteBPressure | SiteSFlow pumpé_1 |pumps_2
9 |Site 9 Site9Pressure | Site9F low pumpg_1 |pump9_2
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Connecting Signals to DataTables

To connect a value to a particular cell or column within a DataTable,
use the Object»Edit Connections... command. Select the specific data
member of the DataTable to be written, and identify the data member of
the source object.

Connecting to Cells

The value from SitelPressure is numeric. To write the value of
SitelPressure into cell B1, connect the simulated output to B1—not
Bl.logical or Bl.txt. The Edit connection dialog box is shown in the
following illustration.

Tablel connections B
Taklel.B1 = Isite1pressure
Existing numeric connection
o ememeer Accept | Clear | Cluit |
[B1
—Signals:
Existing connections: Tags: Fot
Bl B Purnpd_1 =]
[=H Furmpd_2
B3 i
Cl [
c2
C9 x|
‘Whitahle members: Readable members: numeric
1.1-1000.20 -
AJ-.20
Alogical 11 logical 20
At 1-I et 20
Allogical-1000 logical
Al b1 000.1 x|
Select | Selectobject.. | Paste | site’] pressure

Lookout Reference Manual

Figure 18-23. Edit Connections Dialog Box

After you establish a connection to a cell, the value within the cell changes
any time the expression changes. Any time the value of SitelPressure
changes, the value within cell B1 changes.

Connecting to Columns

To connect the value of the Setpoint potentiometer to column D,
select D—not D. logical or D.txt—as shown in the following
illustration. As with the previous value, you use D because you are using
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a numerical value. There is no number following the D because you are
connecting to a column, not a cell.

Tablel connections | ]
Tablel.D = [Setpoint

Existing numeric connection

o ememeer . Accept | Clear | Cluit |
D

—Signals:
Existing connections: Tags: Fot
Furmpd_1 =]
Pumpa_2
Sital Flow J
sitelpressure
Site2Flow x|
Writable members: Feadable members: numeric
1.1-1000.20 -~
Ad-N.20
Alogical 11 logical 20
At 1 .20
Allogical-1000 logical
Al b1 000.1 x|

Select Select object... | Faste | Setpaint

Figure 18-24. Edit Connections Dialog Box

Once a connection to a column is established, the value within the cell at
the currently selected row changes when the expression changes. So, if you
activate row 4 and change the value of Setpoint changes, the value within
cell D4 changes. No other cells are affected until you move the cursor to
activate another row and the operator adjusts the pot.

Reading a Cell Value Back to a Lookout Object

When you connect the display panel potentiometer called Setpoint to
Tablel.D, you should configure your pot with the appropriate Remote
parameter to ensure that it automatically adjusts to track the value in any
cell (within the specified column) when the cursor moves to a new row.
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Revise potentiometer: | ]

Tag: ISetpoint

Minimurm: ID

Fesolution:

Ok
Maxirnurm: |1DD -
e

Cancel

—Position source

 Local

o+ Remote

Pasition = [Table1 D)

' DDE

EEfIEE I
i I

[teri

Contral security level: ID v

Log events

The Display Panel

Now that your DataTable (called Tablel) is

complete, you can return to

your display panel (where you placed the DataTable object initially) and
begin to build a single control panel that allows you to multiplex the data

from your PLCs. A sample panel is shown in

18-96
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 Control Panel

Pressure Flow Rate Setpoint

Table1.E.logical

Table1.F.logical

Table1 display
(no connection

necessary)
Potentiometer connected to Table1.D
(Column D)

Table1.C

Instead of using expressions that reference the actual values from your
driver objects to display values, use the column names from Tablel. For
instance, the bar graph and numeric readout for Pressure both represent the
expression Tablel.B. The actual value for Tablel . B depends on the what
row is currently active in the DataTable. In the illustration row 1 is active,
so all the expressions return the value in their respective columns at row 4.
The callouts in the picture indicate how the control panel was developed.
All are Lookout expressions except the Pot and the DataTable, which are
displayable objects.

Operating Your Multiplexed Panel

The plate in bottom right corner of the control panel is the DataTable object
(Tablel). To view a different site with the control panel (that is, to activate
adifferent row, thereby selecting a different PLC), click on Tablel and the
following dialog box should appear.
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Site 3
Site 4
Site b
Site 6
Site 7
Site §
Site 9

Tablel | ]
ISite1

EreyiEus |

Mext

This list box gets the
row names from
Column A in the
Data Table

Cancel |

DataTable Cursors

Lookout Reference Manual

By selecting a site, you connect your control panel to the PLC at that site.
This is referred to as moving the cursor to that row.

The cursor is a DataTable pointer that you can move from row to row to
activate the values in the cells of that row. There are several methods for
controlling the location of the cursor:

Connect a numeric expression to the cursor data member. A typical
example would be to connect a potentiometer (minimum = 1,
maximum = the number of rows in table, resolution = 1) to the cursor.

Connect logical expressions to appropriate row numbers. A typical
example would be to create a pushbutton for every row and then
connect them to their respective row numbers.

Use the display (list box) built into the DataTable object. A typical
example was described above where you connected text values to cells
in column A and then displayed the table as a plate.

The following example provides a graphical representation of a DataTable
(called Tablel) showing typical values within its many cells. You can
create a multiplex effect in Lookout by referencing column names and then
selecting the row with the information you want to use. If you reference
column names (instead of individual cells), the DataTable outputs only the
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values within the currently selected row. If you reference individual cells,
the DataTable outputs the current value within the cell—no matter where

the cursor is.

A B C E F

1 1

2 0 1

3 480 78 0 1

4 |Site 4 57.8 410 51 1 1

5 |Site S 51.8 560 92 1 0

6 |Site B 88.3 490 40 0 1

7 |Site 7 79.4 530 B3 1 0

8 |Site 8 921 520 71 1 0

9 |Site 9 59.9 550 G2 0 1

Outputs = Site2 77.9 460 78 0 1
Figure 18-25. DataTable with Cursor at Row 2 and Corresponding Outputs
The value of cell B2 is currently 77.9. Therefore, the Tablel.B data
member is also 77.9. If you move the cursor to row 9, the value of
Tablel.B changes to 59.9, as shown below.
A B C E F

1 |Site 1 67.8 540 0 1

2 |Site 2 779 460 0 1

3 |Site 3 573 480 0 1

4 |Site 4 57.8 410 1 1

5 |Site S 51.8 560 1 0

6 |Site B 88.3 490 0 1

7 |Site 7 79.4 530 1 0

8 |Site § 921 520 1 0

9 0 1

Outputs = Site9 59.9 550 62 0 1

Figure 18-26. DataTable with Cursor at Row 9 and Corresponding Outputs

Using Multiple Cursors

The above description assumes you are using just one cursor. But a
DataTable can have up to 20 cursors. Multiple cursors allow you to select
multiple rows at the same time. When using multiple cursors, you also
use multiple names for each column. For a given column, each name is
associated with a given cursor. If you are using two cursors in the above
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example (cursor and cursor. 2), you can reference the column name of
a given column as follows:

Table 18-32. Column Names

A B C D E F
cursor A.txt B C D E.logical F.logical
cursor.2 A.txt.2 B.2 C2 D.2 E.logical.2 Flogical.2

Earlier, when you were using just one cursor, you connected the value of a
potentiometer called Setpoint to column D. Subsequently the value of
Setpoint was written to the cell at the row selected by the cursor. But
when there are multiple cursors, you have to select which cursor you are
writing to. Thus, depending on how you want your table to work, you might
connect the potentiometer to both Tablel.D and Tablel.D.2.

DataTable Data Members

Table 18-33. DataTable Data Members

Data Members Type Read | Write Description

(implicit) DdeTable no no Not displayable in Lookout, but it can
be referenced by a DDE link from
another application.

Al -1V16384 numeric yes yes Specified cell interpreted as numeric
value

Al.logical logical yes yes Specified cell interpreted as logical

-IV16384.1ogical value

Al.txt -IV16384.txt text yes yes Specified cell interpreted as text value

Cursor.1 — Cursor.20 numeric yes yes Specifies the currently selected row of
the indicated cursor.

1.1-1000.20 logical no yes Specifies row (1, 2, 3, ...1000) or
specifies row.cursor (for example,
24.2 is the selector for row 24,
cursor 2). Upon transition from false
to true, the specified cursor moves to
specified row.
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Table 18-33. DataTable Data Members (Continued)

Data Members Type Read | Write Description

A.1-1V.20 numeric yes yes Specifies column names (for
example, A, B, C...IV) or specifies
column names and associated cursor
numbers (such as, A.1, B.1, A.2, B.2,
and so on.)

Read—returns a numeric value from
the cell specified by the column and
currently selected row of the indicated
CUrsor.

Write—writes a numeric value into
the cell specified by the column and
currently selected row of the indicated

Cursor.
Alogical.1 — logical yes yes Specifies column names
IV.logical.20 (for example, A.logical, B.logical,

Cl.logical, ...IV.logical) or specifies
column names and associated cursor
numbers (such as, A.logical.l,
B.logical.1, A.logical.2, B.logical.2,
and so on.)

Read—returns a logical value from
the cell specified by the column and
currently selected row of the indicated
cursor.

Write—writes a logical value into the
cell specified by the column and
currently selected row of the indicated
CUrsor.
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Table 18-33. DataTable Data Members (Continued)

Data Members Type Read | Write Description

A.txt.1 —IV.txt.20 text yes yes Specifies column names (for
example, A.txt, B. txt, C. txt, ...IV.
txt) or specifies column names and
associated cursor numbers (such as,
A.txt.1, B. txt.1, A. txt.2, B. txt.2, and
SO on.)

Read—returns a text value from the
cell specified by the column and
currently selected row of the indicated
Cursor.

Write—writes a text value into the
cell specified by the column and
currently selected row of the indicated
Cursor.

enable logical yes yes If TRUE (the default), enables DDE.
If FALSE, disables DDE. The default
value is on. The input is ignored for
non-DDE TextEntry objects.

export logical no yes When this input transitions from false
to true, the Lookout data table is
exported to the designated
spreadsheet file.

import logical no yes When this input transitions from false
to true, the Lookout data table imports
data from the designated spreadsheet.

Update logical yes no Pulses each time the cursor changes
rows. Often used to “call up” a control
panel.

Related Objects DdeTable, DdeLink
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Note

DdeLink creates a unidirectional Dynamic Data Exchange (DDE) link to
another application. The other application could be running on the same
computer or on another computer over a network. DdeLink objects provide
an easy way to import remote values into Lookout. See Chapter 13,
Dynamic Data Exchange, for more information on DDE. For each DdeLink
object you define, Lookout creates a separate link to the other application.
If you need to import large quantities of data, you should use the DdeTable
or DataTable object. See DdeTable and DataTable for more information.

DdeLink does not have a display parameters dialog box. You can easily display the
result of a DdeLink output signal by referencing its data member in an expression.

DdeLinks on Same Computer

If you are importing values from another application running on the same
computer, your DDE parameters will look similar to the ones below.

Create DdeLink | %]
Tag: |DDET

DDE parameters:

Service: IExceI

Tapic: |5heet1

[tarm: |r1 -1

Ok I Cancel |

Figure 18-27. DdeLink Definition Parameters Dialog Box (Same Computer)

Service specifies the application name, Topic specifies the file, and Item
points to the individual value (rlcl refers to the cell at row1, columnl.
Unfortunately, Excel does not support the more convenient A1 cell
references with DDE).

DdeLinks to Remote Computer

If you are importing values from another application running on a remote
computer, your DDE parameters will look similar to the ones below.
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Create DdeLink | %]
Tag: |DDET

DDE parameters:

Senvice: I\\CDmputerName\NDDE!ﬁ

Topic: IProcessFiIe!B

ltem: ITagname

Ok I Cancel |

Figure 18-28. DdeLink Definition Parameters Dialog Box (Remote Computer)

Notice the differences in the Service, Topic, and Item parameters.
The backslashes (\\) and dollar signs ($) are standard requirements for
making network connections in Microsoft Windows for Workgroups.
ComputerName specifies the network name of the computer you are
connecting to. If you are connecting to a value in another Lookout
application, ProcessFile is the Lookout file name running on the
remote computer, and Tagname refers to the tag you are linking to.

DDELink Data Members

Table 18-34. DdeLink Data Members

Data Members Type Read | Write Description

(implicit) numeric yes no DDE link interpreted as numeric
value

enable logical yes yes If TRUE (the default), enables DDE.
If FALSE, disables DDE. This input
is ignored for non-DDE TextEntry
objects.

logical logical yes no DDE link interpreted as logical value

txt text yes no DDE link interpreted as text value

hot logical yes no Status of DDE link

Related Objects DdeTable, DataTable
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DdeTable

DdeTable creates a unidirectional Dynamic Data Exchange (DDE) link to
another application. The other application could be running on the same
computer or on another computer over a network. See Chapter 13,
Dynamic Data Exchange, for more information on DDE. You can use
DdeTable to import large quantities of data from other applications. The
table format is much more efficient at transferring data than the Link format
because a table can contain hundreds or even thousands of data points that
all share a single link. On the other hand, the link format can only transfer
a single value per link—and every link requires a certain amount of CPU
overhead. If you are only importing a relatively small amount of data, you
may find the DdeLink technique easier to implement.

Note DdeTable does not have a display parameters dialog box. You can display the result
of a DdeTable output signals by referencing its data members in expressions.

DdeTable on Same Computer

If you are importing values from another application running on the same
computer, your DDE parameters will look similar to the ones below.

Create DdeTable | ]
Tag: |DDET

DDE parameters:

Service: IExceI

Tapic: |Sheet1

[tarm: |r1 -1

Ok | Cancel |

Figure 18-29. DdeTable Definition Parameters Dialog Box (Same Computer)

Service specifies the application name, Topic typically specifies the file,
and Item specifies the particular data item name.
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The example below shows an Excel spreadsheet with the highlighted range
named Data.

Data = Pressures

Pressures [@ICIERIGINE Times

NG| N BN =

You can now display any value in the range Data with the Lookout
DdeTable object created above.

Select Insert»Expression... and then choose the DdeTable data member
corresponding to the Excel spreadsheet cell containing the value you want
to display. Make sure that the type of data member you select matches the
type data in the spreadsheet cell.

Insert expression | %]
[PDE1 A1 b
—Signals:
Paste | DDET.AT txt
Tags: Data members:
$alarm {implicif)
$Keyvhboard Al logical-16384.logical
$Swstem Al bat16384 0
A1-v16384
Panell enahle
hot
DdeTahkle text

oK I Cancel

Figure 18-30. Inserting a DdeTable Expression
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Notice the reference for the displayed item in the Lookout status bar.

£~ Lookout - (untitled) - [Control Panel]
Eile Edit Insert Object Arrange Change Options  Alarms  Window  Help &=l

L I— M
EPressures

| sos2 | EEx23 | DDE1.AT tet | 0:0alarms

DdeTable to Remote Computer

Using the DdeTable object over a network is somewhat different from the
example above.

Create DdeTable | ]
Tag: |DDET

DDE parameters:

Senvice: I\\CDmputerName\NDDE!ﬁ

Topic: IProcessFiIe!B

ltermn: ILocaITabIe1|

Ok I Cancel |

Figure 18-31. DdeTable Definition Parameters Dialog Box (Remote Computer)

Notice the differences in the Service, Topic, and Item parameters.

The backslashes (\\) and dollar signs ($) are standard requirements for
making network connections in Microsoft Windows for Workgroups.
ComputerName specifies the network name of the computer you are
connecting to. If you are connecting to a DdeTable or DataTable in another
Lookout application, ProcessFile is the Lookout file name running on
the remote computer, and LocalTablel refers to the DdeTable or
DataTable object you are linking to.
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DDETable Data Members

Table 18-35. DdeTable Data Members

Data Members Type Read | Write Description

(implicit) numeric yes no Cell Al interpreted as a numeric
value

Al -1V16384 numeric yes no Specified cell interpreted as a numeric
value

Al.logical — logical yes no Specified cell interpreted as a logical

IV16384.1ogical value

Al.txt —IV16384.txt text yes no Specified cell interpreted as a text
value

enable logical yes yes If TRUE (the default), enables DDE.
If FALSE, disables DDE. This input
is ignored for non-DDE TextEntry
objects.

hot logical yes no Status of DDE link

Related Objects DataTable, DdeLink
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DelayOff

DelayOff is an adjustable delay timer. When On/off signal transitions
to off, the Timer delay begins to count down. At the end of the delay
countdown, the output signal turns off. On/off signal must remain off
during the time delay period for the output signal to turn off. The output
immediately turns on when the On/off signal turns on.

Timer delay can range from 0.0 seconds to several years, and the effective
resolution is 0.1 seconds over the entire range. The timer display digitally
shows the time delay remaining, and is updated approximately once per
second. If the On/off signal is high, the timer display shows on. If the
Timer delay period has expired, the display shows of £.

Create DelayOff timer: | ]
Ta: IPumpRun

On/off signal = IPumpSwitch

Timer delay = ID:ZD

Display format: IMM:SS j

Ok I Cancel |

Figure 18-32. DelayOff Definition Parameters Dialog Box

The On/off signal is a logical expression while Timer delay is a numeric
expression. Normally, this is a simple time constant such as 0:20—twenty
seconds. See Numeric Data Members in Chapter 5, Developer Tour, for
information on entering time constants.
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Display timer: PumpRun | ]
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Cancel

]

Figure 18-33. DelayOff Display Parameters Dialog Box

DelayOff Data Members

Table 18-36. DelayOff Data Members

Data Member Type Read | Write Description
(implicit) logical yes no Logical timer value
Comments

The DelayOff timer can prevent a pump from short-cycling.

Related Objects DelayOn, Interval, OneShot, Pulse, TimeOf

Lookout Reference Manual 18-110 © National Instruments Corporation




Chapter 18 Object Class Reference

DelayOn

DelayOn is an adjustable delay timer. When On/off signal transitions
to on, the Timer delay begins to count down. At the end of the delay
countdown, the output signal turns on. On/off signal must remain on
during the time delay period for the output signal to turn on. The output
immediately turns off when the On/off signal turns off.

Timer delay can range from 0.0 seconds to several years, and the effective
resolution is 0.1 seconds over the entire range. The timer display digitally
shows the time delay remaining and is updated approximately once per
second. The timer display shows of £ when the On/off signal is low. If the
Timer delay period has expired, the display shows on.

Create DelayOn timer: | ]
Ta: IPumpRun

On/off signal = IPumpSwitch

Timer delay = ID:15|

Display format: IMM:SS j

Ok I Cancel |

Figure 18-34. DelayOn Definition Parameters Dialog Box

The On/off signal is a logical expression while Timer delay is a numeric
expression. Normally, this is a simple time constant such as 0:20—twenty
seconds. See Numeric Data Members in Chapter 5, Developer Tour,

for information on entering time constants.
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Display timer: PumpRun | ]
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Figure 18-35. DelayOn Display Parameters Dialog Box
DelayOn Data Members

Table 18-37. DelayOn Data Members

Data Member Type Read | Write Description
(implicit) logical yes no Logical timer value
Comments

The DelayOn timer can be used to prevent pumps from cycling too often,
to allow one operation to complete before another begins, or to require a
condition to exist for a period of time before an alarm is activated.

Related Objects DelayOff, Interval, OneShot, Pulse, TimeOfxxx
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DeltaTau is a protocol driver object class Lookout uses to communicate
with Delta Tau Data Systems PMAC Motion Controllers. Create a
DeltaTau object for each card installed in the computer.

This object class communicates with Delta Tau PMAC cards through
dual-ported memory, so be sure that your PMAC hardware includes the
dual-ported RAM option.

New DeltaTau Controller | ]

Tag:
Card base address: IDDDD vl
Scanning interval: |5U Cancel |

milliseconds

Communication alarm priority: IB

Delta Tau card configured to use PC memory beginning at address D0O0O.

Card base address specifies the beginning memory location of the dual
ported RAM address. It should match card settings.

Scanning Interval identifies the frequency that the DeltaTau object in
Lookout polls the PMAC Motion Controller. Intervals can range from
10 ms to 1,000 ms.

Communication alarm priority specifies the priority level of alarms
generated by the object.

DeltaTau Data members

Like other protocol driver objects, DeltaTau objects contain a great deal
of data. All readable and writable members (inputs/outputs), polling
instructions, and so on, are bundled with the object. Therefore, as soon as
you create a DeltaTau object you immediately have access to all the object
data members. The following table lists data members for the DeltaTau
object
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Table 18-38. DeltaTau Data Members

Data Member Type Read | Write Description

DS0 - DS8190 numeric yes yes Signed 32-bit word ranging from
—2,147,483,648 to 2,147,483,647

DWO0 - DW8190 numeric yes yes 32-Bit double-precision word ranging
from 0 to 4,294,967,295

FO - F8188 numeric yes yes 32-bit IEEE floating point word

S0 —S8190 numeric yes yes Signed 16-bit word ranging from
— 32,768 to 32,767

Update logical yes no Driver-generated signal that pulses
each time Lookout scans the PMAC
Motion Controller card

W0 - W8190 numeric yes yes 16-Bit word ranging from O to 65,535

WO0.0 - W8190.15 logical yes yes 1 Bit in a 16-Bit word
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Derivative

Derivative can also be called a rate of change object—it calculates the rate
of change of the incoming numeric input signal. You can use this class to
calculate the rate at which a tank is filling or draining, or to convert a

changing totalized flow value into a flow rate. The output units are in Input

Units/Time Unit.
Tag: IDerivative1
Input = IRTU1 TanklLewvel
Update=  [RTU1 Update
Time unit: |1 00
Ok I Cancel

Figure 18-36. Derivative Definition Parameters Dialog Box

The above example calculates the rate of change in the water level of a
tank. Lookout polls the RTU connected to the tank level transmitter every
5 minutes, so this example uses the RTU update data member as the Update
pulse for the Derivative object. Tanklevel is in feet and Time unit is

1 minute, so the output result is in feet per minute.

Input is the numeric expression you are monitoring for rate of change.

Update can be a logical expression or numeric constant. If you specify
Update as a numeric constant, it creates an internal pulse timer with a pulse
period of the specified time and a pulse duration of zero. See Numeric Data
Members in Chapter 5, Developer Tour, for information on entering time
constants. If you specify Update as a logical variable, the variable should
pulse at the frequency you want to use.

The Update expression triggers the calculation of a new rate-of-change
based on the Input value at the prior Update, and the current Input value.
The current Input value is then stored as the prior Input value for the next
calculation. The Update period should be greater than the refresh rate of
the incoming signal; or if the Input is generated directly by external I/O,
the update data member generated by the PLC object should be used. If
the Update period is less than the Input refresh rate, the rate of change
calculation fluctuates erratically between zero and a high value.
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Time unit is a numeric expression used as the basis for unit time on the
Input signal. For instance, if the rate of change should be in feet per minute,
the Input signal would be feet, and Time unit would be one minute (entered
as 1:00). Typically the Time unit is one second (0:01), one minute (1:00),
one hour (1:00:00), or one day (1:00:00:00). However, you can specify any
unit, such as 5:23 (a rate of change in Input units per five minutes and 23
seconds).

Note Derivative does not have a display parameters dialog box. You can display the
result of a Derivative output signal by referencing its data member in an
expression. When you complete the parameters in creating a Derivative object,
an Insert Expression dialog box appears automatically.

Derivative Data Members

Table 18-39. Derivative Data Members

Data Member

Type Read | Write Description

(implicit)

numeric yes no Rate of change

Comments Derivative performs the inverse function of Integral—you can theoretically
run a signal through an Integral object and then a Derivative object (or vice
versa) and you would end up with the original signal. (Discretization of the
time calculations by the computer may cause the final and original signals
to differ somewhat).

It is important to consider the resolution of the process variable measured
by the PLC when determining the Update period for this object. For
instance, if a pressure transmitter connected to a PLC only has a resolution
of 0.5 psi and you want to measure rates down to 1 psi/minute, the Update
pulse must be greater than 30 seconds even if the PLC is polled once per
second (i.e., 0.5 psi/l psi/min. = 30 sec.). For this application, the Update
pulse should probably be about two minutes.

Related Objects Integral

Lookout Reference Manual
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DialGauge

The DialGauge object class displays a numeric signal as a sweeping needle
on an analog gauge or dial.

New dial gauge | ]
Tag: IDiaH
Signal = IAirPressure

Minimurm: ID

awimum: 100

Dial needle parameters
Starting angle: 225 degrees clockwise from vertical

Fotational sweep:  [270 degrees clockwise

Ok I Cancel

Figure 18-37. DialGauge Definition Parameters Dialog Box

Signal is a numeric expression.

Starting angle. indicates the position of the needle when the Signal is at its
Minimum value. As shown here, you specify the starting needle position
by counting the degrees clockwise from vertical.

00
270°
225°
Default
Starting 180°
Angle

Rotational sweep specifies the number of degrees clockwise that the
needle will rotate as the Signal approaches the Maximum value. As shown
in the diagram here, you count the Rotational sweep in degrees clockwise
from the Starting angle.

© MNational Instruments Corporation 18-117 Lookout Reference Manual



Chapter 18 Object Class Reference

o
270” ﬂ
Starting
Angle
180°

After you specify the DialGauge definition parameters, Lookout presents a
display parameters dialog box, as shown here. You use this dialog box to
specify needle color, thickness, and length.

Display dial gauge | ]
Meedle colar:

0 ECEEN
HNENEENEN NEEE
Meedle thickness: |1 pixels(1-10)

MNeedle length: 100 %

oK | Cancel |

Figure 18-38. DialGauge Display Parameters Dialog Box

Needle thickness defines how wide your needle will be. Thickness can
range from one pixel (hairline) to 10 pixels wide.

Needle length specifies the length of the needle as a percent of the radius.
At 30 percent, for example, only the outer tip of the needle is visible—you
cannot see the part of the needle closest to the origin. At 100 percent, the
needle extends the full radius of the circle.
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30%

DialGauge Data Members

Table 18-40. DialGauge Data Members

Data Members Type Read | Write Description
(implicit) numeric yes no Current value of signal parameter
o %
40 80
a0 a0
20 . 100
10 110
0 120

Comments The DialGauge object class only displays a needle. You may wish to enhance
it with a corresponding scale or dial face as shown. You can create a scale
or dial face by importing one from a graphics package. See Creating Custom
Graphics in Chapter 8, Graphics, for more information.

Note If you choose to import a scale or dial face from an external package, you should
use a bitmap instead of a metafile. This makes the display refresh cleaner when the
needle changes position.

Related Objects Expression, Gauge
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DL205,
DL405

Lookout Reference Manual

DL205 and DL405 are protocol driver object classes Lookout uses to
communicate with Koyo 205 and 405 PLCs, and other devices that use
the CCM protocol.

Koyo sells the 205 and 405 models under private brand labels. PLCDirect
offers the units as the DirectLOGIC 205 and 405 PLCs, and Siemens offers
the 405 unit as the TI405 series.

The DL205 and DL405 object classes support the Koyos native protocol,
CCM, which is also called DirectNET by PLCDirect and HostLink by
Siemens. This documentation refers to this protocol as CCM.

The DL205 and DL405 object classes support both point-to-point and
multidrop configurations. You can connect Lookout to a PLC programming
port, built-in DirectNET/HostLink port, or to the PLC DCM (data
communication module). These PLC communication ports use two
different versions of the CCM protocol: K-sequence and N-sequence.
Lookout supports both.
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Create DL205 ]
Tag: FLC Address:
o |
Model Frotocol
[DLe4n = [Lowerport() ]
—Serial Settings
Setial port: Data rate
ICOM1 'l 38400

Farity

Data bits
' Mane 7 (3
 Even Stop hits
& Odd ’7 @1 2

& G
9600
4800
2400
1200

Fhone number:

FollRate-  |001

Pall - f

Communication alarm priority:

Ia— Cancel |

Retry attempts: |4 Feceive timeout: 300 msecs
Skip every |5 poll requests after comm failure

Figure 18-39. DL205 Parameters Configured for one PLC in a
Multidropped Configuration

Protocol identifies the CCM port you use to communicate with the device.
If you are planning to connect Lookout to a single PLC in a point-to-point
configuration, choose the UPPER PORT (k) Protocol and use the PLC
programming port. It supports K-sequence CCM. With this version of the
CCM protocol you can write directly to logical outputs.

If you are planning to network multiple PLCs in a multidrop configuration
where Lookout is the host computer, you must use the built-in PLC
DirectNET/HostLink port, or its DCM. Choose the LOWER PORT (n) or
DCM (n) Protocol as appropriate. These ports support N-sequence CCM.
The N-sequence CCM protocol does not permit writes directly to logical
data members.

Although you can connect logical signals to data members such as Y0 in Lookout,
any time you attempt to write to such a data member using the N-sequence CCM
protocol, the write request is ignored. (This is due to the limitations of N-sequence
CCM protocol.) If you have to write out a logical value using N-sequence, consider
parsing the corresponding VU address into a binary number and setting the bit

you want to use by writing a corresponding decimal integer. If you write a zero or
65535 to the corresponding VU-memory location, you will write all zeros or ones

to every bit in the register.
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Lookout Reference Manual

PLC Address is a slave address and refers to the address setting as set on
the physical device. If you are connecting to the PLC programming port,
set PLC Address to 1. If multiple devices share a common line, enter the
unique addresses of the device (1 to 255).

Use Model to choose the PLC model you want to use. If you are using a
model not listed, select a model whose data set most closely fits the model
you are using.

Serial port specifies which COM port on your computer that the object
uses for communicating to the PLC. This does not specify the
communication type. Communication type is determined by the
Options»Serial Ports... command.

Data rate, Parity, Data bits, and Stop bits should match the PLC settings.

Phone number specifies the number to be dialed if the selected serial port
is configured for dial-up. This number only applies to the individual
protocol object.

PollRate is a numeric expression that determines how often to poll the
device. The object then polls the device at the specified time interval.
Normally, this is a simple time constant such as 0:01 (one second). See
Numeric Data Members in Chapter 2, Introduction, for information on
entering time constants.

Poll is a logical expression. When this expression changes from false to
true, Lookout polls the device. You can use a simple expression like the
signal from a pushbutton, or a complex algorithm.

Communication alarm priority determines the priority level of alarms
generated by the object. Such alarms are typically related to
communications with the physical device.

Retry attempts specifies the consecutive number of times Lookout
attempts to establish communications with a device it does not get a valid
response from. After the object retries communications the specified
number of times, it generates a communication alarm and Lookout moves
on to the next device in the polling queue (if any). Refer to Chapter 6, Serial
Communications, for more information.

Receive timeout is the time delay Lookout uses in waiting for a response
from a device before retrying the request.
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The Skip every... setting instructs Lookout to not poll a device it has lost
communication with on every scheduled poll. Instead, Lookout skips the
device in the polling cycle accordingly. Once communications have been
reestablished, the device is polled on its regular cycle.

DL205 and DL405 Data Members

Protocol driver objects contain a great deal of data. V-memory addresses,
registers, inputs and outputs are all bundled with the object. Therefore, as
soon as you create a DL205 object you have immediate access to the entire
data member set of the object (see data member list below).

As with all Lookout drivers, you can access I/O points and other data
through data members. The DL205 and DL405 object classes automatically
generate an efficient read/write blocking scheme based on the inputs and
outputs you are using in your process file. So, you do not have to build your
own I/0O blocking table. When Lookout polls a device, it optimizes frame
exchange according to the data length required and overhead needed. The
maximum data frame size that these drivers request is 256 data bytes. The
drivers use LRC and parity error checking to validate data.

The following is a table of data members currently supported by the DL205
and DL405 object class.

Table 18-41. DL205 and DL405 Data Members

Data Member Type

Read

Write

Description

C0-C3777 logical

yes

yes

Control Relays—addressed in octal
and mapped to V40600 — V40700

CommPFail logical

yes

no

Object-generated signal that is on if,
for whatever reason, Lookout cannot
communicate with the device

CTO0 - CT377 logical

yes

yes

Counter status bits—addressed in
octal and mapped to V41140 —
v41147

OffHook logical

no

yes

When TRUE, this flag instructs the
DL object to retain exclusive use of its
assigned communication port

Poll logical

no

yes

When this value transitions from
FALSE to TRUE, Lookout polls the
device.
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Table 18-41. DL205 and DL405 Data Members (Continued)

Data Member Type Read | Write Description

PollRate numeric no yes Lookout expression that determines
the device polling frequency.

S0 -S1777 logical yes yes Stages—addressed in octal and
mapped to V41000 — V41037

SPAO — SPA177 logical yes yes Lower special relays—addressed in
octal

SPB320 — SPB717 logical yes yes Upper special relays—addressed in
octal

TO —T377 logical yes yes Timer status bits—addressed in octal
and mapped to V41100 — V41107

Update logical yes no Object-generated signal that pulses
low each time it polls the device

V0 -V41230 numeric yes yes Signed V-memory register containing
16-bit integer ranging from —32768 to
32767 dec.

V0.0 - V41230.17 logical yes no Individual bits within V-memory

registers—the least significant bit is
0, the most significant bit is 17 (octal).

VBCDO-VBDC41230 numeric yes yes V-memory as BCD

VDO - VD41227 numeric yes yes Double—reads two adjacent
V-memory registers as a single 32-bit
integer ranging from O to

4,294,967,296.

VDBCDO- numeric yes yes V-memory double as BCD

VDBCD41227

VFO — VF41227 numeric yes yes Float—reads two adjacent V-memory
registers as a single 32-bit floating
point value.

VU0 - VU41230 numeric yes yes Unsigned—V-memory register
holding 16-bit unsigned integer
ranging from 0 to 65535
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Table 18-41. DL205 and DL405 Data Members (Continued)

Data Member Type Read | Write Description

X0 -X1777" logical yes yes Discrete input points—addressed
in octal and mapped to V40400 —
V40407

YO-Y1777" logical yes yes Discrete output points—addressed
in octal and mapped to V40500 —
V40507

*205 series PLCs are limited to 128 input and output points total. You can mix these addresses as necessary, but understand

that Y17 and X17 refer to the same memory location on DL205.

DL205 and DL405 Status Messages

No response within timeout period

Lookout did not receive the expected response within the Receive timeout
period. The object sent an inquiry and received an acknowledgment, but the
device did not send an expected response to the request. This might happen
if the response was interrupted. You may have to increase Receive
timeout.

No return inquiry response from secondary unit

Lookout received no response from the device within the Receive timeout
period. The driver object is able to use the COM port, but when it polls the
device, it does not respond—as if it is not even there. You may have to
increase Receive timeout to ensure Lookout is allowing enough time to
receive the expected response. Also, verify your baud rate settings, cable
connections, power, configuration settings, COM port settings, and polling
addresses.

Bad LRC

The object is receiving a poll response from the device, but it could not
decipher the response because it is garbled. Verify that all devices
connected to the COM port have unique addresses. The last part of the
message may actually be getting clipped off before it is completed.
Consider increasing the number of Retry attempts. You may have to
increase the Receive gap Serial Port setting to ensure Lookout is receiving
the entire message. If your Serial Port is configured for radio, this could be
caused by an audible squelch tail occurring at the end of a radio
transmission. Try adjusting RTS delay off and CTS timeout.
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No acknowledgment for header frame

You sent an inquiry and some kind of data write or read, but the device has
not responded. The object was expecting an acknowledgment for an
instruction frame and did not receive it. You may be asking for an invalid
memory address. Recheck your PLC memory address configuration. Also
verify that the PLC communication port supports the CCM Protocol that
you selected.

Invalid request frame
You are probably trying to use an invalid memory address. Recheck your
PLC address configuration.
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Dynamic

Dynamic is a protocol driver class Lookout uses to communicate with
equipment such as programmable logic controllers (PLCs), remote
terminal units (RTUs), or any other piece of equipment that uses Dynamic
as its communication protocol.

Protocol driver objects contain a great deal of data. All readable and
writable members (inputs/outputs), polling instructions, read/write
blocking, serial port usage, etc. are bundled with the object. Therefore,
as soon as you create a Dynamic object you immediately have access to
all the object data members (see data member list below).

The driver currently supports reading and writing of all predefined data
point types including analog input, state input, pulse count input, pulse
duration input, pulse period input, high speed accumulator inputs, state
outputs, pulse outputs, analog outputs, and AGA data.

The driver automatically configures the RTU database to match the data
points referenced in the Lookout process file and verifies that the points
specified in the process file actually exist on the RTU. If you reference
undefined or unavailable points, the driver posts an alarm message to the
Lookout alarm system.

The Dynamic protocol driver automatically takes advantage of the RTU
exception reporting capabilities to maximize communication efficiency.
The driver requires that the RTU be set for physical point addressing—refer
to the RTU hardware technical reference manual for the dipswitch locations
that set this parameter.

Note Lookout protocol driver objects automatically generate an efficient read/write
blocking scheme based on the inputs and outputs being used in your process file.
You are not required to build your own 1/0 blocking table.

The Dynamic protocol driver was written for Texas Instruments Model
8635, 8640 and 8641 RTUs (Remote Terminal Units) with RTX 5.41
EPROMs—earlier releases of RTX have significant bugs and do not
operate correctly with the Lookout Dynamic driver.
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New Dynamic RTU: | ]
Tag: |RTU7

—Communication Settings

Address: |?| Serial port: ICOM1 'l

—Data rate —— —Data bits —
18200 7
@ 9600 (O]
£ 4300 Stop hits
2400
bl 2
® - 2. Cancel |
300 Defaults |
110

Alarm priority: |1D
Fetries: |3

Phone number:  |1-512-565-6655
PalRate = [1:00:00
Fall = IPushbutton?

Figure 18-40. Dynamic Parameter Configuration Dialog Box

In the example shown above, Lookout is connected to a Dynamic-speaking
RTU with an address of 7. Lookout is using serial portl (which was
previously configured for Dial-up communications), and calling the
specified phone number. Each poll occurs every 1 hour or when the
operator depresses Pushbutton?7.

Address refers to the PLC or RTU address setting as set on the device
dipswitches. If devices share a common line, they require unique addresses
(1 to 255).

Serial port specifies which port the object uses for communication to the
external device. This does not specify the communication type.
Communication type is determined by the Options»Serial Ports...
command.

Data rate, Parity, Data bits, and Stop bits reference the settings on the
hardware device.

The Defaults button replaces the current settings with default values.

Alarm priority determines the priority level of Dynamic-generated
alarms.
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Phone number specifies the number to be dialed if the serial port setting is
configured for dial-up. This number only applies to the individual protocol
object.

PollRate is a numeric expression that determines how often to poll the
device. Dynamic then polls the device at the specified time interval.
Normally, this is a simple time constant such as 0:01 (one second). See
Numeric Data Members in Chapter 2, Introduction, for information on
entering time constants.

Poll is a logical expression. When this expression changes from false to
true, Lookout polls the device. You can use a simple expression like the
signal from a pushbutton, or a complex algorithm.

As with all Lookout drivers, you can access I/O points and other data
through data members. The following is a table of data members currently
supported by the Dynamic object class.

Dynamic Data Members

Table 18-42. Dynamic Data Members

Data Members

Type Read | Write Description

AIO — AI239

numeric yes no Analog inputs—returns a normalized
numeric value that ranges from 0 to
32000 and spans the full input analog
range.

AOO0 - AO239

numeric no yes Analog outputs—sets voltage level of
analog outputs, and accepts a
normalized number from 0 to 32000.

btul — btud

numeric yes no AGA data

dpl —dp4

numeric yes no Differential pressure (psi). 1 — 4
specifies meter run being referenced.

HSAO - HSA127

numeric yes no High-speed accumulator
inputs—counts the number of digital
pulses on an HSA input. Rollover is
detected automatically by driver, so
maximum pulse count is 4.5 x 1015
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Table 18-42. Dynamic Data Members (Continued)

Data Members Type Read | Write Description
MeterCodel — text no yes First 8 characters of this text string are
MeterCode4 used to create a filename with a .CSV

extension. Entire text string is used as
a field within the .CSV file. 1 — 4
specifies meter run being referenced.

NoComm logical yes no Driver-generated signal that is on if
Lookout cannot communicate with
the device for whatever reaso