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GETTING STARTED

NI SMD-7613/7614/7615/7616
Stepper Drives and NI 9512 C
Series Modules

This document explains how to install and configure the NI SMD-7613/4/5/6 stepper drives for
use with the NI 9512 C Series drive interface module.
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What You Need to Get Started

You need the following items to get started.

Hardware
[0 NI 9512 C Series stepper drive interface module

[0 NI Real-Time controller
—  CompactRIO controller and chassis that support the RIO Scan Interface

@ Tip To determine if your controller and chassis support the RIO Scan Interface go
toni.com/info and enter the Info Code rdsoftwareversion.

or

NI 9146, 9147, 9148, or 9149 Ethernet RIO Expansion Chassis.
or

— NI 9144 distributed chassis and compatible RT controller

L] 424 V power supply (such as the NI PS-15) for the CompactRIO controller
(NI part number 781093-01)

[J Separate +24 V power supply for the NI 9512 (such as the NI PS-15)
[J NI PS-12 or NI PS-13 power supply for the NI SMD-7613/4/5/6

[0 NI SMD-7613/4/5/6 stepper drive
d

NI or third-party stepper motor

@ Note NI offers stepper motors matched to the NI SMD-7613/4/5/6. Refer to
ni.com/motion for motor options. National Instruments highly recommends using
these motors for the best user experience.

[J  (Optional) ENC-7740 encoder for ST17 motors (NI part number 748991-01) or ENC-7741
encoder for ST23 motors (NI part number 748992-01)

[J Encoder cable to connect the encoder to the NI 951x terminal block
(NI part number 783661-10)

Ethernet connection and cable for the CompactRIO controller
DB25M-Pigtail 25-pin Dsub cable (NI Part Number 190911-04)

NI 951x Cable and Terminal Block bundle (NI part number 780553-01)
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Software

O

O
(]
(]

LabVIEW 2010 (minimum)
LabVIEW 2010 Real-Time Module (minimum)
LabVIEW 2010 f1 NI SoftMotion Module (minimum)

NI-RIO 3.5.1 (minimum)

Figure 1. NI 9512 to NI SMD-7613/74/5/6 Connections
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Getting Started with NI SMD-761x and NI 9512 Modules | © National Instruments |



Hardware Installation and Configuration

This section covers the hardware setup for the Real Time system, NI 9512 C Series module, and
NI SMD-7613/4/5/6 stepper drive.

Step 1: Set Up the Real Time System

Complete the following steps to set up the Real Time system depending on your hardware.

1. Refer to the Getting Started guide included with the Real-Time controller to assemble it,
connect it to power, discover it on the network, and install the software in NIl MAX.

2. Install the NI 9512 module in an available slot that supports High Speed Interface (HSI) in
your chassis.

Note Older model chassis, such as cRIO-902x, cRIO-907x, cRIO-908x, NI 9144,
and NI 9148, have HSI support on slots 1 through 4. Refer to your chassis
documentation for more information about HSI slot support.

Step 2: Connect the NI 9512 to the 37-Pin Terminal
Block

1.  Connect the MDR and DSUB connectors on the NI 951x Y-cable to the MDR and DSUB
connectors on the NI 9512 module.

2. Connect the 37-pin DSUB to the DSUB connector on the NI 951x terminal block.

Figure 2. NI 9512 37-Pin Terminal Block Pin Assignments

Forward Limit [_T~[] [ & | Digital Output 1t
Home [I~[] | & | Reverse Limit
com (T[] & | Reserved
Digital Input 0 [~ | E1 | Veup
CcoM }E‘"[ i [ ©| Reserved
Encoder 0 Index+ }@"’[ i @ com
Encoder 0 Index— [ I~ | £ |'E]| Encoder 0 Phase A+
com [I=[] | & ]| Encoder 0 Phase A—
+5V OUT ([TI[] | @ &| Encoder 0 Phase B+
Position Compare ([ I3[ | @ |'&| Position Capture
Reserved E: E 3 E Encoder 0 Phase B—
Reserved ([ Is[| [@| [Tl | ©| Reserved
Digital Output 0t [(Tia[] | @| [T | &| Reserved
Voup! }Ex[ @ ([Tel | @ comt
Digital Input 11 [TJa[{ | & }E&[ | Drive Enablet
Direction (CCW)+" }Es[ @| [el | @ pigital Input 3t
com' IR0 |@| [Tgl | & pirection (cow)-t
step (cw)+t [T=0 [@| ([Tl | | pigital Input 2
shield [T [@| [Tl | @i Step (cW)-

tIndicates DSUB connector signals.
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Step 3: Connect the 37-Pin Terminal Block to the +24 V
Power Supply

= Note Do not plug in or turn on the power supply until after you complete Step 10:

)

Power on the Drive and Verify Connections.

Connect the V+ terminal from the 24 V power supply to one of the two V,, inputs on the
37-pin terminal block. The 37-pin terminal block provides a V,, input for the NI 9512 on
pin 14 and pin 22.

Connect the V- terminal from the 24 V power supply to one of the COM terminals on the
37-pin terminal block. The 37-pin terminal block provides COM on pins 3, 5, 8, 17, 24,
and 32.

Step 4: Connect the Drive Command Signals

Complete the following steps to connect the Drive Command signals to the NI 9512 terminal
block by using the DB25M- Pigtail 25-pin Dsub cable (NI Part Number 190911-04).

1.

Connect the SMD-7613/4/5/6 STEP+ (pin 10) and DIR+ (pin 12) terminals to the 37-pin
terminal block +5V OUT terminal (pin 9).

Connect the SMD-7613/4/5/6 STEP- (pin 11) terminal to the 37-pin terminal block Step
(CW)+ terminal (pin 18).

Connect the SMD-7613/4/5/6 DIR- (pin 9) terminal to the 37-pin terminal block Direction
(CCW)+ terminal (pin 16).
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Figure 3. SMD-7613/4/5/6 Drive Command and I/O Connector
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Step 5: Connect the Drive Enable Signal

The Drive Enable signal controls the enable function of the drive. To use this signal, connect the
SMD-7613/4/5/6 X3/ENABLE terminal (pin 7) to the 37-pin terminal block Drive Enable
terminal (pin 33).

Step 6: (Optional) Connect the Encoder Signals

If your motor includes an encoder, complete the following steps to connect the encoder to the
NI 9512 by wiring the encoder cable to the 37-pin terminal block:

é Note SMD-7614 and SMD-7616 include encoder inputs. The encoder signals must
be connected to the NI 9512 for SoftMotion to have access to the Encoder Feedback.

1. Ifan NI Encoder is being used, connect the appropriate end of the encoder cable
(NI part number 783661-10) to the encoder.

Connect the encoder wires to the 37-pin terminal block as indicated in Table 1.

Insulate any unused wires.

6 | nicom | Getting Started with NI SMD-761x and NI 9512 Modules



Table 1. NI SMD-7613/4/5/6 to 37-Pin Terminal Block Connections

37-Pin 37-Pin
Encoder Encoder Cable Terminal Block Terminal Block

Signal Name Wire Color Pin Number Signal Name
CHA blue 25 Encoder 0 Phase A+
CH A- blue/white 26 Encoder 0 Phase A-
CHB yellow 27 Encoder 0 Phase B+
CH B- yellow/white 29 Encoder 0 Phase B-
INDEX orange 6 Encoder 0 Index+
INDEX- orange/white 7 Encoder 0 Index-
GND black 8 CoOM
+Vee red 9 +5V OUT

Step 7: Connect the NI PS-12/13 Power Supply to the
NI SMD-7613/4/5/6

Note Do not plug in or turn on the power supply until after you complete Step 10:
Power on the Drive and Verify Connections.

Complete the following steps to connect the power supply to AC input power and to the
NI SMD-7613/4/5/6.

Figure 4. NI PS-12/13 Power Supply Terminals

Made in China °@“5 RoH$ CE
V. [=[NJ[L]

+V ADJ

1 +24 V(NI PS-12) or +48 V (NI PS-13) Output 4 AC Input Neutral
2 424 V (NI PS-12) or +48 V (NI PS-13) Ground 5 AC Input Line
3 AC Input Ground (Protective Earth)
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Figure 5. SMD-7613/4/5/6 Power and Motor Connector
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Connect an AC input cable to the line, neutral, and protective earth connectors.

Connect the SMD-7613/4/5/6 V+ terminal to the power supply +V connector.

Connect the 7613/4/5/6 V- terminal to the power supply -V connector.

Connect the SMD-7613/4/5/6 green ground screw to earth ground.

Connect the NI 9512 COM to the NI PS-12/13 -V terminal to ensure a common reference.

Al

\% Note Refer to the NI SMD-7613/7614/7615/7616 User Manual on ni . com/
manuals for more information about connecting the power supply.

Step 8: Connect the SMD-7613/4/5/6 to the Motor

The drive supports various stepper motors. The connection to the stepper motor depends on the
number of leads present. Refer to the following figures to connect your stepper motor.

= Note Motor wire colors are correct for NI stepper motors compatible with the
NI SMD-761x. These wire colors may not match a third-party stepper motor.
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Four Lead Motors

Four lead motors can only be configured according to the following diagram.

Figure 6. Four Lead Motor Connection

Phase A+
Phase A—

Yellow Phase B+

Phase B—

Six Lead Motors

Six lead motors can be connected in series or center tap.

Figure 7. Six Lead Motor Connected in Series

No Connect

Phase A+
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Phase B+

No Connect
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Figure 8. Six Lead Motor Connected in Center Tap
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Eight Lead Motors

Eight lead motors can be connected in series or parallel.

Figure 9. Eight Lead Motor Connected in Series

Phase A+
Phase A—
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Figure 10. Eight Lead Motor Connected in Parallel
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Step 9: Connect the NI SMD-7613/4/5/6 to the Network

1.  Connect the NI SMD-7613/4/5/6 to an Ethernet network on the same subnet as the
development computer.

2. Set the rotary switch to one of the preset IP addresses or to the F position to configure the
drive to use DHCP.

\é Note This document assumes you have configured the drive for DHCP. For
information about other settings refer to the NI SMD-7613/7614/7615/7616 User
Manual on ni.com/manuals.

Step 10: Power on the Drive and Verify Connections

After all hardware connections have been made complete the following steps to confirm the
hardware setup.

1. Turn on all power supplies.

2. Verify that the Drive Status LED on the NI SMD-7613/4/5/6 flashes or is solid green.
Figure 11 shows the location of the Drive Status LED.

Figure 11. Drive Status LED Location
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Ifthe Drive Status LED does not flash or turn solid green, turn off all power, verify the connections,
and try again. Refer to the Worldwide Support and Services section for additional tips.

Step 11: Configure the Drive using NI Stepper
Configuration Utility

The NI Stepper Configuration Utility allows the drive to be customised for a specefic motor.
Complete the following steps to customize the motor by using the NI Stepper Configuration
Utility.

1. Visitni.com/downloads to download the NI Stepper Configuration Utility.

2. Install and open the Stepper Configuration Utility on the computer connected to the same
network as the drive.

Figure 12. The NI Stepper Configuration Utility Window

¥ 192.168.1.10 NI Stepper Configuration Utility ¥1.0.3 5 =
File Drive Help

—_—

Motion

3.  Enter the IP address of the drive as configured using the rotary switch in the previous steps
and click Upload from Drive. This will retrieve the model number of the drive you are
using.
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4.

Click Motion... button in the top-left corner. The option to select the Motion Control mode
is displayed.

Figure 13. Motion Control Mode
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5. Click Pulse & Direction Mode to program the drive to receive step and direction signals
from the NI 9512 module.
Figure 14. The Pulse & Direction Mode window
Fulse & Direction Control
Steps/Rew
20000
Step Smoothing Filter Cancel
2500 H
g Help
Input Noise Filter
10 MHz
6. In the Pulse & Direction Control window, enter the microstepping resolution in the
Steps/Rev control. By default, this value is set to 20,000 steps/revolution. Click OK.
7.  Click Motor... button in the bottom-left corner to configure the motor connected to the

drive.
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Figure 15. The Motor Configuration window
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menu to select the model.

If a third-party stepper motor is being used, select Custom motor then click Define
Custom Motor... to enter the rated current, holding torque, and rotor inertia of the motor.

Configure the remaining parameters (Running Current, Idle Current, Idle Current Delay,
and the Load Inertia) for your application. Refer to the Help menu for full descriptions of

these parameters.

When configuration is complete, click Download to Drive to save these settings to the

drive.
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Software Installation and Configuration

This section covers installing and configuring software for the NI 9512 C Series module.

\é Note These instructions assume you have installed all required software from the
What You Need to Get Started section on your development machine.

Step 1: Install Software on and Configure the NI RT
Controller

Complete the following steps to configure the controller and install software on it.

1. Launch Measurement & Automation Explorer (MAX) on the development computer by
clicking the MAX icon on the desktop, or by selecting Start»All Programs»
National Instruments»NI MAX.

2. Select the controller under Remote Systems in the Configuration pane. If you do not see
the controller, you may need to disable the firewall on the development computer.

3. Verify that the Serial Number in the Identification section matches the serial number on
the device.

4. Expand the controller item in the tree, right-click Software, and select Add/Remove
Software.

5. Select a recommended software set that includes NI-RIO 3.5.1 (minimum) with NI Scan
Engine Support.

6. Click Next and enable the following add-ons:
*  LabVIEW SoftMotion Module
e NI Industrial Communications for EtherCAT if using the NI 9144,

7. Click Next to install the selected software on the controller. Click Help if you need
information about installing recommended software sets.

8. Close MAX.

Step 2: Create a Project and add NI RT Controller

Complete the following steps to create a LabVIEW project.
1. Launch LabVIEW by selecting Start»All Programs»National Instruments»LabVIEW.

2. Click the Empty Project link in the Getting Started window to display the Project
Explorer window. You can also select File»xNew Project to display the Project Explorer
window.

3. Select Help and make sure that Show Context Help is checked. You can refer to the
context help throughout the tutorial for information about items on the block diagram.

Depending on the hardware configuration being used, continue to the following respective
sections.
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A

CompactRIO Controller

If you are using a CompactRIO controller, complete the following steps to add the device to the
project and detect the C Series modules.

1.

vk wN

Right-click the top-level project item in the Project Explorer window and select New»
Targets and Devices from the shortcut menu to display the Add Targets and Devices
dialog box.

Make sure that the Existing target or device radio button is selected.
Expand Real-Time CompactRIO.
Select the CompactRIO controller to add to the project and click OK.

If you have LabVIEW FPGA installed, the Select Programming Mode dialog box
appears. Select Scan Interface to put the system into Scan Interface mode.

@ Tip Use the CompactRIO Chassis Properties dialog box to change the

9.

10.

B.

programming mode in an existing project. Right-click the CompactRIO chassis in the
Project Explorer window and select Properties from the shortcut menu to display
this dialog box.

Click Discover in the Discover C Series Modules? dialog box if it appears.
Click Continue.

Right-click the controller item in the Project Explorer window and select Properties from
the shortcut menu to display the RT Target Properties dialog box. Select Scan Engine
from the Category list to display the Scan Engine page.

Set the Scan Period to 5 ms or lower.
Click OK to close the RT Target Properties dialog box.

EtherCAT Master and NI 9144 EtherCAT Expansion Chassis

If you are using the NI 9144 chassis, complete the following steps to add the EtherCAT master
device and detect the C Series module.

1.

16

Add the Master Real Time Controller to the project. Right click the top level project item
in the Project Explorer window and select New»Targets and Devices from the shortcut
menu to display the Add Targets and Devices dialog box.

Make sure that Existing target or device radio button is selected.

Expand the folder that corresponds to the device you are adding, such as Real Time
Industrial Controller, Real Time PXI, and so on.

Select Real Time to add to the project and click OK.

In the LabVIEW Project Explorer window, right-click the master controller and select
New»Targets and Devices.

Inthe Add Targets and Devices dialog window shown in Figure 16, select Existing target
or device and expand the category EtherCAT Master Device to auto-discover the EtherCAT
port on the master controller. An EtherCAT master device and modules can be added
manually at any time.
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Figure 16. Adding the EtherCAT Master
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When all the slave devices are discovered, the LabVIEW Project Explorer window lists each
slave device and any installed C Series modules.

C. NI 9146/7/8/9 Ethernet RIO Expansion Chassis

Complete the following steps to add the device to the project and detect the C Series modules if
the NI 9146/7/8/9 Ethernet RIO Expansion chassis is being used.

1.

wok we

10.

Right-click the top-level project item in the Project Explorer window and select New»
Targets and Devices from the shortcut menu to display the Add Targets and Devices
dialog box.

Make sure that the Existing target or device radio button is selected.
Expand Ethernet RIO.
Select the Ethernet RIO expansion chassis to add to the project and click OK.

If you have LabVIEW FPGA installed, the Select Programming Mode dialog box
appears. Select Scan Interface to put the system into Scan Interface mode.

Tip Use the Chassis Properties dialog box to change the programming mode in an
existing project. Right-click the chassis in the Project Explorer window and select
Properties from the shortcut menu to display this dialog box.

Click Discover in the Discover C Series Modules? dialog box if it appears.
Click Continue.

Right-click the controller item in the Project Explorer window and select Properties from
the shortcut menu to display the Ethernet RIO Properties dialog box. Select Scan Engine
from the Category list to display the Scan Engine page.

Set the Scan Period to 5 ms or lower.
Click OK to close the Ethernet RIO Properties dialog box.
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Step 3: Add a SoftMotion Axis to the Project

Complete the following steps to create a LabVIEW project and add a SoftMotion Axis to it.

1.

Right-click the controller item in the Project Explorer window and select New»

NI SoftMotion Axis from the shortcut menu to open the Axis Manager dialog box.

Click Add New Axis to create an NI SoftMotion axis associated with the NI 9512 module.

Axes are automatically bound to an available module. You can double-click the axis name
to rename the axis and give it a descriptive name.

Figure 17. Axis Manager Dialog Box

3.

Axis Manager

Add Mew Axis ‘ Change Einding ‘ Delete Axis ‘ Copy Axis ‘

Bound Hardware
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Click OK to close the Axis Manager dialog box. The new axis is added to the Project

Explorer window.

\% Note You cannot associate more than one axis with the same C Series module.

Figure 18. Project Explorer Window with Modules in Scan Interface Mode
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Step 4: Configure the NI 9512 Axis

The Axis Configuration dialog box includes configuration options for stepper drive command
signals, feedback devices, motion and digital I/O, trajectory, and axis setup. Figure 19 shows the
parts of the Axis Configuration dialog box for the NI 9512 C Series module. Refer to the
SoftMotion Module book of the LabVIEW Help for detailed information about each
configuration option.

Figure 19. Axis Configuration Dialog Box
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= Note The Axis Configuration dialog box user interface may not match this image

exactly depending on which version of the LabVIEW NI SoftMotion Module you are

using.
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Complete the following steps to configure the axis I/O settings for use with the
NI SMD-7613/4/5/6 stepper drive.

Right-click the axis in the Project Explorer window and select Properties from the

shortcut menu to open the Axis Configuration dialog box.

1.

2.
a.
b.
c.

Configure the following settings on the General Settings page (| ).

Confirm that Loop Mode is set to Open-Loop. Axes configured in open-loop mode
produce step outputs but do not require feedback from the motor to verify position.

Set Feedback Source to Encoder 0, if you have connected an encoder, or None if you
do not have an encoder connected.

Confirm that the Axis Enabled and Enable Drive on Transition to Active Mode
checkboxes contain checkmarks. These selections configure the axes to automatically
activate when the NI Scan Engine switches to Active mode.

Note Disable these options to prevent axes from automatically activating when the
NI Scan Engine switches to Active mode.

If you have connected an encoder, click the Encoder button ( {7£€% ) and configure the

Units and Counts Per Unit.

a.
b.

& 0

‘a

)

In the Active State section set the Line State for A, B, and Index to High.
In the Index Reference Criteria section set the Line State for A and B to Inactive.
Select rev from the Units text box, or type revolutions if you prefer.

Set the Counts per rev to 8,000. This setting is the encoder resolution in quadrature
counts per revolution and corresponds to the encoder lines per revolution multiplied
by four.

Note The counts per revolution should be set accordingly if a dual shaft motor with
a third party Encoder is being used.

Figure 20. Axis Configuration Encoder Page
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4.  Click the Stepper button (Eﬁ[_ﬁ) to open the Stepper page.

a.

Ensure that the Stepper Output settings match the following:

e Output Mode—Step and Direction

¢ Output Type—Single-Ended

*  Active State—Low

Configure the Units and Steps Per Unit.

e Select rev from the Units text box, or type revolutions if you prefer.
. Set Steps Per revolution to 20,000.

Note The Steps Per revolution setting must match the configuration in the Stepper
Configuration Utility. If you change the Steps/Rev setting using the Stepper
Configuration Utility, update this setting to match.

(Optional) Click the Monitor button ( * ) and make the following changes to
enable NI SoftMotion to disable the drive and turn off the Drive Enable signal when
the specified position error limit is exceeded.

@ Note The Monitor button is greyed out if Feedback Source on the Axis Settings

page is set to None.

. Enable the Enforce Position Error Limit checkbox.

*  Set Position Error Limit to a reasonable tolerance for your system, such as 1.

5. Click the Drive Enable button ( O ) and ensure that the Drive Enable settings match the
following:

Output Type—Sourcing
Active State—Off
Safe State—On

6. Ifyou connected the Out+/Out- signal, click the Digital I/O button (JLr ) and complete
the following steps to configure the DI 0 signal:

a.

Double-click the text in the Mapping column and select Drive Fault/Alarm from the
dropdown list.

Ensure that the DI 0 settings match the following:
¢ Input Type—Sinking
*  Active State—On

*  Digital Filter—50 ps
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7. Complete the following additional steps if you do not have limits and home connected at
this time:

a.  Click the Limits & Home button ( [«=t).

In the Forward Limit and Reverse Limit sections ensure that the settings match the
following:

@ Note These configuration settings disable limits for initial setup and testing
purposes. National Instruments recommends connecting and enabling limits in your
final application. The SMD-7613/4/5/6 has limit switch inputs for use in Ethernet
streaming mode. When used with the NI 9512, limit switches should be wired to the
37-pin connector block.

. Clear the Enable checkbox from both Forward Limit and Reverse Limit.

. Set the Active State for both Forward Limit and Reverse Limit to Off. This
prevents a limit warning even though limits are turned off.

c.  Open the Home section and clear the Enable checkbox.

8.  Configure any additional I/O settings according to your system requirements, such as
position compare or position capture signals.

9. Click OK to close the Axis Configuration dialog box.

10. Right-click the controller item in the Project Explorer window and select Deploy All to
deploy the axis information.

11. Select File»Save Project to save the project.

Step 5: Enable and Test the Drive Using LabVIEW

Use the Interactive Test Panel to test and debug your motion system and configuration settings
on the selected axis. With the Interactive Test Panel you can perform a simple straight-line move
and monitor feedback position and position error information, move and I/O status information,
change move constraints, get information about software errors and faults, and view position or
velocity plots of the move.

Complete the following steps to test your setup after configuring the axis using the Axis
Configuration dialog box.

1. Right-click the axis in the Project Explorer window and select Interactive Test Panel
from the shortcut menu. Opening this dialog box sends the axis settings to the hardware and
activates the I/O on the module.

2. On the Move tab set Move Mode to Relative Position and Target Position to 20 rev.
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On the Move Constraints tab set Velocity to 2 rev/sec, Acceleration and Deceleration to
20 rev/sec?, and Acceleration Jerk and Deceleration Jerk to 200 rev/sec®. Using the
encoder counts per revolution and stepper steps per revolution values specified in this
tutorial the motor will move 20 revolutions at 120 rpm.

@ Tip Click the Help button ( “;? ) on the bottom of the dialog box for detailed

information about the items available in this dialog box.

Click the Enable button ( &) ) on the bottom of the dialog box to enable the drive.

Click the Start button (= ) on the bottom of the dialog box to start the move with the
configured options.

Use the Status and Plots tabs to monitor the move while it is in progress.

Finalize your motion system setup by connecting and configuring additional I/O such as
limits as required by your system using the 37-pin terminal block.

Where To Go From Here

The following documents contain additional information that you may find helpful. All
referenced documents ship with the product and are available at ni . com/manuals.

Operating instructions for the controller and C Series module.
NI SMD-7613/7614/7615/7616 User Manual

LabVIEW NI SoftMotion Module Help—Use this help file to learn about using the

NI SoftMotion Module in LabVIEW including information about function blocks and
using the NI SoftMotion Module with the LabVIEW Project. To access this help file from
LabVIEW, select Help»LabVIEW Help, then expand the LabVIEW NI SoftMotion
Module book on the Contents tab.

LabVIEW Help—Use the LabVIEW Help to access information about LabVIEW
programming concepts, step-by-step instructions for using LabVIEW, and reference
information about LabVIEW VIs, functions, palettes, menus, tools, properties, methods,
events, dialog boxes, and so on. The LabVIEW Help also lists the LabVIEW documentation
resources available from National Instruments. Access the LabVIEW Help by selecting
Help»LabVIEW Help.

SoftMotion Examples—After the configuration and testing of the motion system is
complete, use SoftMotion API to program the motion control application in LabVIEW.
Access the SoftMotion Examples by selecting Help»Find Examples»Hardware Input
and Output»Motion Control»SoftMotion.
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Worldwide Support and Services

The National Instruments Web site is your complete resource for technical support. At
ni.com/support you have access to everything from troubleshooting and application
development self-help resources to email and phone assistance from NI Application Engineers.

Visit ni . com/services for NI Factory Installation Services, repairs, extended warranty,
calibration, and other services.

Visit ni.com/register to register your National Instruments product. Product registration
facilitates technical support and ensures that you receive important information updates from NI.

A Declaration of Conformity (DoC) is our claim of compliance with the Council of the European
Communities using the manufacturer’s declaration of conformity. This system affords the user
protection for electromagnetic compatibility (EMC) and product safety. You can obtain the DoC
for your product by visiting ni . com/certification. If your product supports calibration,

you can obtain the calibration certificate for your product at ni.com/calibration.

National Instruments corporate headquarters is located at 11500 North Mopac Expressway,
Austin, Texas, 78759-3504. National Instruments also has offices located around the world to
help address your support needs. For telephone support in the United States, create your service
request at ni . com/support and follow the calling instructions or dial 512 795 8248. For
telephone support outside the United States, visit the Worldwide Offices section of ni . com/
niglobal to access the branch office Web sites, which provide up-to-date contact information,
support phone numbers, email addresses, and current events.

Refer to the N/ Trademarks and Logo Guidelines at ni . com/trademarks for more information on NI trademarks. Other product and company
names mentioned herein are trademarks or trade names of their respective companies. For patents covering NI products/technology, refer to the
appropriate location: Help»Patents in your software, the patents . txt file on your media, or the National Instruments Patents Notice at
ni.com/patents. You canfind information about end-user license agreements (EULAs) and third-party legal notices in the readme file for your
NI product. Refer to the Export Compliance Informationatni . com/legal/export-compliance for the NI global trade compliance policy
and how to obtain relevant HTS codes, ECCNs, and other import/export data. NI MAKES NO EXPRESS OR IMPLIED WARRANTIES AS TO THE
ACCURACY OF THE INFORMATION CONTAINED HEREIN AND SHALL NOT BE LIABLE FOR ANY ERRORS. U.S. Government Customers: The data
contained in this manual was developed at private expense and is subject to the applicable limited rights and restricted data rights as set forth in
FAR 52.227-14, DFAR 252.227-7014, and DFAR 252.227-7015.
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