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GETTING STARTED GUIDE

PXIe-5172
100 MHz, 250 MS/s, 14-Bit PXI Express Oscilloscope

Note  Before you begin, complete the installation and configuration procedures in
your chassis and controller documentation.

This document explains how to install and start using the PXIe-5172.

Safety Guidelines

Notice—Take precautions to avoid data loss, loss of signal integrity, degradation of
performance, or damage to the model.

Caution—Take precautions to avoid injury. Consult the model documentation for
cautionary statements when you see this icon printed on the model. Cautionary
statements are localized into French for compliance with Canadian requirements.

Shock Warning—Take precautions to avoid electrical shock.

Hot Surface—Take precautions to avoid physical burns.

Caution  Observe all instructions and cautions in the user documentation. Using
the model in a manner not specified can damage the model and compromise the
built-in safety protection. Return damaged models to NI for repair.

Attention  Suivez toutes les instructions et respectez toutes les mises en garde de la
documentation utilisateur. L'utilisation d'un modèle de toute autre façon que celle
spécifiée risque de l'endommager et de compromettre la protection de sécurité
intégrée. Renvoyez les modèles endommagés à NI pour réparation.

EMC Guidelines
This product was tested and complies with the regulatory requirements and limits for
electromagnetic compatibility (EMC) stated in the product specifications. These requirements
and limits provide reasonable protection against harmful interference when the product is
operated in the intended operational electromagnetic environment.

This product is intended for use in industrial locations. However, harmful interference may
occur in some installations, when the product is connected to a peripheral device or test object,



or if the product is used in residential or commercial areas. To minimize interference with
radio and television reception and prevent unacceptable performance degradation, install and
use this product in strict accordance with the instructions in the product documentation.

Furthermore, any changes or modifications to the product not expressly approved by NI could
void your authority to operate it under your local regulatory rules.

Notice  To ensure the specified EMC performance, operate this product only with
shielded cables and accessories. The length of all I/O cables must be no longer than
3 m (10 ft).

Notice  This product may become more sensitive to electromagnetic disturbances
in the operational environment when test leads are attached or when connected to a
test object.

Verifying the System Requirements
To use the PXIe-5172, your system must meet certain requirements.

For more information about minimum system requirements, recommended system
requirements, and supported application development environments (ADEs), refer to the
readme for your selected software support. Readmes are available on the driver software
media or online at ni.com/manuals.

Unpacking the Kit

Notice  To prevent electrostatic discharge (ESD) from damaging the device, ground
yourself using a grounding strap or by holding a grounded object, such as your
computer chassis.

1. Touch the antistatic package to a metal part of the computer chassis.
2. Remove the device from the package and inspect the device for loose components or any

other sign of damage.

Notice  Never touch the exposed pins of connectors.

Note  Do not install a device if it appears damaged in any way.

3. Unpack any other items and documentation from the kit.
4. Verify that you received the following contents.

• PXIe-5172 Module
• PXIe-5172 Getting Started Guide
• Maintain Forced-Air Cooling Note to Users
• NI-SCOPE Note to Users
• Instrument Design Libraries for Reconfigurable Oscilloscopes Note to Users
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Store the device in the antistatic package when the device is not in use.

Other Equipment
Your application may require additional items not included in your kit to interact with your
device. The following accessories can connect to the PXIe-5172.
• PXI Chassis Slot Blocker kit (NI part number 199198-01)
• SMB (m)-to-SMB (m) cables
• AUX 0 cable (SHH19-MH19-AUX, NI part number 784091-01)
• AUX 0 accessory terminal block for connecting to external signals, including clocks or

digital resources (SCB-19, NI part number 783959-01)

To use probes with the PXIe-5172, NI recommends using a cable adaptor (SMB (f)-to-
BNC (f), NI part number 781449-01 for one adaptor, or NI part number 781449-10 for ten
adaptors). With an adaptor, you can use the following probes:
• CP500X—500 MHz, 1.2 m, 10X Cable Divider Probe
• CP400X—400 MHz, 2 m, 10X Cable Divider Probe
• SP500X—500 MHz, 10x Passive Probe
• SP500C—500 MHz, 100x Passive Probe
• NI-5191—800 MHz, Differential Active Probe
• SA1000X—1 GHz Single-Ended Active Probe
• SA1500X—1.5 GHz Single-Ended Active Probe
• SA2500X—2.5 GHz Single-Ended Active Probe

Preparing the Environment
Ensure the environment in which you are using the PXIe-5172 meets the following
specifications.

Operating environment

Ambient temperature range 0 °C to 45 °C (Tested in accordance with
IEC-60068-2-1 and IEC-60068-2-2. Meets
MIL-PRF-28800F Class 3 low temperature
limit and MIL-PRF-28800F Class 4 high
temperature limit.)

Relative humidity range 10% to 90%, noncondensing (Tested in
accordance with IEC 60068-2-56.)

Maximum altitude 2,000 m (800 mbar) (at 25 °C ambient
temperature)

Pollution Degree 2
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Indoor use only.

Note  For complete specifications, refer to the specifications document for your
device at ni.com/manuals.

Software Options
NI provides multiple software options for interacting with the PXIe-5172: InstrumentStudio,
the NI-SCOPE soft front panel (SFP), NI-SCOPE instrument driver software, and the
instrument design libraries.

Table 1.  PXIe-5172 Software Options

Use Case Software Option

  

Acquire and analyze data without
programming.

InstrumentStudio (first available in
NI-SCOPE 18.1; 64-bit systems only)

NI-SCOPE SFP (PXIe-5172 support first
available in NI-SCOPE 17.1; 32-bit systems only
beginning with NI-SCOPE 18.1)

Create custom measurements and
automation applications.

NI-SCOPE instrument driver

Customize the behavior of the device
FPGA to create application-specific
instrument designs.

Instrument design libraries with the LabVIEW
FPGA Module

Note  You can use a combination of these software options for your application.
However, when using the NI-SCOPE driver and the instrument design libraries in a
single application, only one option can access the device at a time.

Installing the Software
1. Close all programs before installing the software.
2. Optional: To use instrument design libraries, complete the following steps.

a) Install NI LabVIEW.
b) Install NI LabVIEW FPGA Module.
c) Install the latest service pack for LabVIEW and any LabVIEW modules you are

using.
3. Visit ni.com/downloads to download the NI-SCOPE driver software and, if desired, the

LabVIEW Instrument Design Libraries for Reconfigurable Oscilloscopes driver software.
Follow the instructions in the installation prompts to install the default installation.
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Windows users may see access and security messages during installation. Accept the
prompts to complete the installation.

Note  For troubleshooting information, contact NI technical support or visit 
ni.com/support.

4. When the installer completes, restart your system.

Installing the PXIe-5172

Notice  To prevent damage to the PXIe-5172 caused by ESD or contamination,
handle the module using the edges or the metal bracket.

You must install the software before installing the hardware.

Before you install the hardware, refer to the guidelines in the Maintain Forced-Air Cooling
Note to Users included in the PXIe-5172 kit to ensure that the PXIe-5172 can cool itself
effectively. This document is also available at ni.com/manuals.

The PXIe-5172 is a single-slot module with one backplane connector. The module may be
installed into any PXI Express-compatible slot.
1. Ensure the AC power source is connected to the chassis before installing the PXIe-5172.

The AC power cord grounds the chassis and protects it from electrical damage while you
install the PXIe-5172.

2. Power off the chassis.
3. Inspect the slot pins on the chassis backplane for any bends or damage prior to

installation. Do not install a module if the backplane is damaged.
4. If the chassis has multiple fan speed settings, ensure the fans are set to the highest setting.

Notice  Inadequate air circulation could cause the temperature inside the
chassis to rise above the optimal operating temperature for the PXIe-5172,
potentially causing thermal shutdown, shorter life spans, or improper
performance.

5. Position the chassis so that inlet and outlet vents are not obstructed.

For more information about optimal chassis positioning, refer to the chassis
documentation.

6. Remove the black plastic covers from all the captive screws on the module front panel.
7. Identify a supported slot in the chassis. The following figure shows the symbols that

indicate the slot types.
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Figure 1. Chassis Compatibility Symbols

NI PXIe-1062Q

1 2 3 4 5

1. PXI Express System Controller Slot

2. PXI Peripheral Slot

3. PXI Express Hybrid Peripheral Slot

4. PXI Express System Timing Slot

5. PXI Express Peripheral Slot

The PXIe-5172 can be placed in PXI Express Hybrid peripheral slots, PXI Express
system timing slots, or PXI Express peripheral slots.

8. Touch any metal part of the chassis to discharge static electricity.
9. Place the module edges into the module guides at the top and bottom of the chassis. Slide

the module into the slot until it is fully inserted.

Figure 2.  PXIe-5172 Module Installation

PXI-1000B

1

3

6

2

5

4

1. Chassis

2. System Controller

3. Hardware Module

4. Front-Panel Mounting Screws

5. Module Guides

6. Power Switch
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10. Secure the module front panel to the chassis using the front-panel mounting screws.

Note  Tightening the top and bottom mounting screws increases mechanical
stability and also electrically connects the front panel to the chassis, which can
improve the signal quality and electromagnetic performance.

11. Cover all empty slots using EMC filler panels or fill using slot blockers to maximize
cooling air flow, depending on your application.

12. Power on the chassis.

PXIe-5172 Front Panel and Pinout

Front Panel

PXIe-5172
100 MHz Oscilloscope

50Ω:
≤ 10V peak

1MΩ:
≤ 42V peak

AUX 0
+5V MAX

CH 0

CH 1

CH 2

CH 3

PXIe-5172
100 MHz Oscilloscope

50Ω:
≤ 10V peak

1MΩ:
≤ 42V peak

AUX 0
+5V MAX

CH 0

CH 1

CH 2

CH 3

CH 4

CH 5

CH 5

CH 7
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Table 2. Connectors

Signal Connector Type Description

   CH 0 through CH 7 SMB Analog input connection; digitizes data and triggers
acquisitions.

AUX 0 MHDMR Sample Clock or Reference Clock input, Reference
Clock output, bidirectional digital PFI, and 3.3 V
power output.

AUX 0 Connector Pinout

16

14
12

18
19

17

15

13

10
11

8

6

4

2
1

3

5

7

9

Table 3. AUX 0 Connector Pin Assignments

Pin Signal Signal Description

   1 GND Ground reference for signals.

2 CLK IN Used to import an external Reference Clock or Sample Clock.

3 GND Ground reference for signals.

4 GND Ground reference for signals.

5 CLK OUT Used to export the Reference Clock.

6 GND Ground reference for signals.
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Table 3. AUX 0 Connector Pin Assignments (Continued)

Pin Signal Signal Description

   7 GND Ground reference for signals.

8 AUX 0/PFI 0 Bidirectional PFI line.

9 AUX 0/PFI 1 Bidirectional PFI line.

10 GND Ground reference for signals.

11 AUX 0/PFI 2 Bidirectional PFI line.

12 AUX 0/PFI 3 Bidirectional PFI line.

13 GND Ground reference for signals.

14 AUX 0/PFI 4 Bidirectional PFI line.

15 AUX 0/PFI 5 Bidirectional PFI line.

16 AUX 0/PFI 6 Bidirectional PFI line.

17 AUX 0/PFI 7 Bidirectional PFI line.

18 +3.3 V +3.3 V power (200 mA maximum).

19 GND Ground reference for signals.

PXIe-5172 SCB-19 Pinout
NI recommends using the SCB-19 connector block to connect digital signals to the AUX 0
connector on the PXIe-5172 front panel. Refer to the following figure and table for
information about the SCB-19 signals when connected to the AUX 0 front panel connector.

1 2 3 4 5 6 7 8 9 10

14 15 16 17 18 19 20 21 22 23

11 12 13

24 25 26
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Table 4. SCB-19 Signal Descriptions

Pin Signal Signal Description

   1 PFI 0 Bidirectional PFI line.

2 PFI 1 Bidirectional PFI line.

3 PFI 2 Bidirectional PFI line.

4 PFI 3 Bidirectional PFI line.

5 NC No connection.

6 CLK IN Used to import an external Reference Clock or Sample Clock.

7 NC No connection.

8 CLK OUT Used to export the Reference Clock.

9 PFI 4 Bidirectional PFI line.

10 PFI 5 Bidirectional PFI line.

11 PFI 6 Bidirectional PFI line.

12 PFI 7 Bidirectional PFI line.

13 +3.3 V +3.3 V power (200 mA maximum)

14 to 26 GND Ground reference for signals.

Configuring the Hardware in MAX
Use Measurement & Automation Explorer (MAX) to configure your National Instruments
hardware. MAX informs other programs about which devices reside in the system and how
they are configured. MAX is automatically installed with the instrument design libraries and
NI-SCOPE.
1. Launch MAX by navigating to Start»All Programs»National Instruments»NI MAX.
2. In the Configuration pane, expand Devices and Interfaces to see the list of installed

devices. Installed devices appear under the name of their associated chassis.
3. Expand your Chassis tree item.

MAX lists all devices installed in the chassis. PXIe-5172 devices appear as NI-RIO
devices in the list. Your default device names may vary.

Note  If you do not see your hardware listed, refer to the Troubleshooting
section of this document.
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4. Record the device identifier MAX assigns to the hardware. Use this identifier when
programming the PXIe-5172.

Note  When you install, uninstall, or move an NI-RIO device in your system,
resource identification of your NI-RIO devices may change. Whenever any of
these changes occur, verify resource identification of all your NI-RIO devices
in MAX, and, if necessary, make changes to your software and documentation.

Related Information

What Should I Do if the PXIe-5172 Doesn't Appear in MAX? on page 13

Self-Calibration
Self-calibration adjusts the PXIe-5172 for variations in the module environment. Perform a
complete self-calibration after first installing your module and letting it warm up for 15
minutes.

Note  Warm-up begins after the chassis is powered, the device is recognized by the
host, and the device is configured using the instrument design libraries or
NI-SCOPE. Running an included sample project or running self-calibration using
NI MAX will configure the device and start warm-up.

The PXIe-5172 modules are externally calibrated at the factory; however, you should perform
a self-calibration in any of the following situations:
• After first installing the PXIe-5172 into your chassis
• After any module in the chassis is installed, uninstalled, or moved
• When the system is in an environment where the ambient temperature varies or the

module temperature has drifted more than ±5 °C from the temperature at the last self-
calibration

• To periodically adjust for small performance drifts that occur with product aging

To programmatically self-calibrate the PXIe-5172 when using instrument design libraries, use
the Self Calibrate VI located on the Functions»FPGA Interface»Software-Designed
Instruments» Oscilloscopes»NI PXIe-5172»Calibration palette.

To programmatically self-calibrate the PXIe-5172 when using NI-SCOPE, use the Self
Calibrate VI located on the Functions»Measurement I/O»NI-SCOPE»Calibration palette.

You can also self-calibrate the PXIe-5172 by pressing the Self Calibrate button for the device
in MAX.

Related Information

What Should I Do if the PXIe-5172 Fails the Self-Test or Self-Calibration? on page 14
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Interacting with the Device in Software

Making a Measurement with InstrumentStudio
1. Connect CH 0 to an input signal.
2. Launch InstrumentStudio at Start»National Instruments.
3.

In the instrument header menu in the upper-right corner of the panel ( ), add the
PXIe-5172 to the large panel with Add/Remove Devices.

4. Click Auto to automatically configure device settings for the detected signal.
5. If the soft front panel is not already running, click Run/Stop.
6. Add oscilloscope measurements to the channel by selecting Add/Remove in the

measurement table of the oscilloscope.

For more information on the measurements available for oscilloscopes in InstrumentStudio,
refer to the InstrumentStudio Manual at ni.com/manuals.

Making a Measurement with LabVIEW
1. Launch LabVIEW.
2. Select Help»Find Examples.
3. Open the example VI that you want to use by selecting Hardware Input and Output»

Modular Instruments»NI-SCOPE (High-Speed Digitizers).

Tip  If you are not sure which example to run, use the Quick Start VI, which is
found under Hardware Input and Output»Modular Instruments»NI-
SCOPE (High-Speed Digitizers)»Demos»niScope EX Quick Start.vi.

4. Follow any setup instructions in the VI and specify any desired settings.
5. Click Run to run the example program.

Making a Measurement with .NET
1. Navigate to <Public Documents>/National Instruments/NI-SCOPE/

Examples/DotNET 4.X/VS20XX.
2. Select the example you want to run and navigate to the cs folder.
3. Open the Visual Studio solution.
4. Click the Start button.
5. In the Resource Name drop-down menu, select the device name assigned to the device in

MAX.
6. Specify the desired settings and click Acquire.
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Making a Measurement with Instrument Design

Libraries
You can verify proper installation and configuration of your device by making a measurement
using a LabVIEW sample project.

This measurement requires installation of the instrument design libraries.
1. Launch LabVIEW.
2. Select File»Create Project.
3. On the left side of the Create Project window, select Oscilloscopes.
4. On the right side of the Create Project window, select the Stream to Host (PXIe-5172)

sample project and click Next.
5. Specify a name, location, and device target for the project in the Create Project window

and click Finish.
6. In the project tree, navigate to My Computer»Project Documentation, open the .html

file, and navigate to the Running this Sample Project section of the documentation.
7. Follow the instructions in the project documentation for making the measurement.

Troubleshooting
If an issue persists after you complete a troubleshooting procedure, contact NI technical
support or visit ni.com/support.

What Should I Do if the PXIe-5172 Doesn't Appear in

MAX?
1. In the MAX configuration tree, expand Devices and Interfaces.
2. Expand the Chassis tree to see the list of installed hardware, and press <F5> to refresh

the list.
3. If the module is still not listed, power off the system, ensure that all hardware is correctly

installed, and restart the system.
4. Navigate to the Device Manager.

Option Description

  Windows 10 Right-click the Start Menu icon and select Device Manager.

Windows 8 Right-click the Start screen and select All apps»Control Panel»
Hardware and Sound»Device Manager.

Windows 7 Select Start»Control Panel»Device Manager.
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5. Verify the PXIe-5172 appears in the Device Manager.
a) Under an NI entry, confirm that a PXIe-5172 entry appears.

Note  If you are using a PC with a device for PXI remote control system,
under System Devices, also confirm that no error conditions appear for the
PCI-to-PCI Bridge.

b) If error conditions appear, reinstall NI LabVIEW Instrument Design Libraries for
Reconfigurable Oscilloscopes and the PXIe-5172.

What Should I Do if the PXIe-5172 Fails the Self-Test

or Self-Calibration?
1. Restart the system.
2. Launch MAX, and perform the self-test or self-calibration again.
3. Power off the chassis.
4. Reinstall the failed module in a different slot.
5. Power on the chassis.
6. Perform the self-test or self-calibration again.

Where To Go Next
Refer to the following resources and information that you may need as you create your own
application.

EXPLORE LEARN CREATE

DISCOVER

custom applications within

an application programming

interface (API).

Instrument Design Libraries

Reconfigurable Oscilloscope

Sample Projects*

about hardware features

or review device

specifications.

more about your products through ni.com.  

the application

development environment (ADE)

for your application.

LabVIEW 2016 FPGA

Module Help

Getting Started with

LabVIEW  

NI Reconfigurable

Oscilloscopes Help

NI Oscilloscopes

ni.com/oscilloscopes

Services

ni.com/services

Updates

ni.com/updates

Located online at ni.com/manuals

*This item is also installed with the driver software.

NI PXIe-5170R
14-Bit Oscilloscope

PXIe-5172

Specifications

Support

ni.com/support

NI-SCOPE Examples*
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Worldwide Support and Services
The NI website is your complete resource for technical support. At ni.com/support, you have
access to everything from troubleshooting and application development self-help resources to
email and phone assistance from NI Application Engineers.

Visit ni.com/services for information about the services NI offers.

Visit ni.com/register to register your NI product. Product registration facilitates technical
support and ensures that you receive important information updates from NI.

NI corporate headquarters is located at 11500 North Mopac Expressway, Austin, Texas,
78759-3504. NI also has offices located around the world. For support in the United States,
create your service request at ni.com/support or dial 1 866 ASK MYNI (275 6964). For
support outside the United States, visit the Worldwide Offices section of ni.com/niglobal to
access the branch office websites, which provide up-to-date contact information.

PXIe-5172 Getting Started Guide | © National Instruments | 15

http://www.ni.com/support
http://www.ni.com/services
http://www.ni.com/register
http://www.ni.com/support
http://www.ni.com/niglobal


Information is subject to change without notice. Refer to the NI Trademarks and Logo Guidelines at ni.com/trademarks for

information on NI trademarks. Other product and company names mentioned herein are trademarks or trade names of their

respective companies. For patents covering NI products/technology, refer to the appropriate location: Help»Patents in your

software, the patents.txt file on your media, or the National Instruments Patent Notice at ni.com/patents. You can find

information about end-user license agreements (EULAs) and third-party legal notices in the readme file for your NI product. Refer

to the Export Compliance Information at ni.com/legal/export-compliance for the NI global trade compliance policy and how

to obtain relevant HTS codes, ECCNs, and other import/export data. NI MAKES NO EXPRESS OR IMPLIED WARRANTIES AS

TO THE ACCURACY OF THE INFORMATION CONTAINED HEREIN AND SHALL NOT BE LIABLE FOR ANY ERRORS. U.S.

Government Customers: The data contained in this manual was developed at private expense and is subject to the applicable

limited rights and restricted data rights as set forth in FAR 52.227-14, DFAR 252.227-7014, and DFAR 252.227-7015.
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