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Getting Started with the 
LabVIEW  Touch Panel Module 
for Windows CE
Version 8.2

The LabVIEW Touch Panel Module extends the LabVIEW graphical 

development environment to Touch Panel devices so you can create 

human-machine interface (HMI) applications for Touch Panel devices 

running Windows CE. You can create custom touch panel displays to 

communicate with National Instruments embedded real-time platforms, 

such as Compact FieldPoint, CompactRIO, and Compact Vision System.

The Touch Panel Module takes advantage of some of the features that 

debuted in LabVIEW 8.0 and the version 8.0 of the PDA Module. You use 

a LabVIEW project to define a Touch Panel target for which you can build, 

deploy, and run a Touch Panel application on a Touch Panel device.

If you previously used the LabVIEW PDA Module to program the 

NI TPC-2006, the Touch Panel Module provides the same graphical 

programming environment and similar features that you already use with 

LabVIEW and the PDA Module. You can use TCP, UDP, and serial to 

communicate with a Touch Panel target. If you have an ARM Touch Panel 

device, such as the NI TPC-2006, you can use shared variables to share data 

among VIs in the same Touch Panel application or to read data from and 

write data to other network-published shared variables. The NI TPC-2006 

hardware now supports 3D front panel controls if you have the updated 

graphics driver. Refer to the National Instruments Web site at ni.com to 

download the driver.

This manual contains system requirements, installation instructions, and a 

tutorial that shows you how to create a LabVIEW project and build, run, 

deploy, and debug a Touch Panel application.

™
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System Requirements

The Touch Panel Module has the following requirements:

• A desktop computer with Windows 2000 with Service Pack 4.0 or later 

or Windows XP.

• LabVIEW 8.2 Base, Full, or Professional Edition.

• 2.5 GB available disk space.

• A Touch Panel device, such as the NI TPC-2006, running Windows 

CE 4.2 or 5.0.

Refer to the LabVIEW Release Notes, available by selecting Start»All 

Programs»National Instruments»LabVIEW 8.2»LabVIEW Manuals 

and opening LV_Release_Notes.pdf, for standard LabVIEW 

development system requirements.
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Installing the Touch Panel Module

Complete the following steps to install the Touch Panel Module.

1. On Windows 2000/XP, log in as an administrator or as a user with 

administrator privileges.

2. Install LabVIEW 8.2, if not already installed. Refer to the LabVIEW 

Release Notes, available by selecting Start»All Programs»National 

Instruments»LabVIEW 8.2»LabVIEW Manuals and opening 

LV_Release_Notes.pdf, for standard LabVIEW installation 

instructions.

3. Install the LabVIEW 8.2 Touch Panel Module.

The Touch Panel Module includes Microsoft ActiveSync. Installing 

the Touch Panel Module could interfere with any existing installations 

of Visual Studio, Windows Embedded, or Windows CE toolkits.

4. Activate the Touch Panel Module.

You must activate the Touch Panel Module before you can build 

Touch Panel VIs into Touch Panel applications. The Touch Panel 

Module runs in evaluation mode if you do not activate it, which means 

you can create Touch Panel VIs, but you cannot build the Touch Panel 

VIs into Touch Panel applications. You have the option of activating 

the Touch Panel Module at the end of the installation. You also can use 

the NI License Manager, available by selecting Start»All Programs»

National Instruments»NI License Manager, to activate National 

Instruments products. Refer to the National Instruments License 

Manager Help, available by selecting Help»Contents in the National 

Instruments License Manager, for more information about activating 

NI products.

5. Restart the computer when the installer completes.

6. Install the additional tools you need. Refer to the Installing the 

Additional Tools section for more information about the additional 

tools.

Uninstalling the Touch Panel Module

In addition to uninstalling the Touch Panel Module, you also must uninstall 

the following:

• Microsoft ActiveSync

• Microsoft Device Emulator version 1.0 - ENU

• Microsoft Visual C++ 2005 Redistributable
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Installing the Additional Tools

You must install additional tools depending on the functionality you need.

Shared Variable Support
You must install support for shared variables on the Touch Panel target 

before you can run a Touch Panel application with shared variables.

Note Shared variables are supported only on ARM Touch Panel targets, such as the 

NI TPC-2006.

Complete the following steps to install or uninstall support for shared 

variables on a Touch Panel target.

1. Connect the Touch Panel device to ActiveSync on the host computer.

2. Navigate to and run labview\PDA\Utilities\Variables\

Setup.exe.

You also can right-click the Touch Panel target in the Project Explorer 

window and select Install»Support for Shared Variables from the 

shortcut menu.

PNG Image Support
You must install support for PNG images on the Touch Panel target if the 

Touch Panel VI contains PNG images on the user interface.

Complete the following steps to install or uninstall support for PNG images 

on a Touch Panel target.

1. Connect the Touch Panel device to ActiveSync on the host computer.

2. Navigate to and run labview\PDA\Utilities\LVPNG\

Setup.exe.

You also can right-click the Touch Panel target in the Project Explorer 

window and select Install»Support for PNG Images from the shortcut 

menu.
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If You Need x86 Target Support
The Touch Panel Module installs support for ARM Touch Panel targets. 

If you need support for x86 Touch Panel targets, install the following 

Microsoft eMbedded Visual Tools:

• Microsoft eMbedded Visual C++ 4.0

• Microsoft eMbedded Visual C++ SP 4 or later

• SDK for Windows Mobile 2003-based Pocket PCs

Refer to the National Instruments KnowledgeBase at ni.com/info and 

enter the info code pdaevc for the most recent information about 

downloading and installing the Microsoft eMbedded Visual Tools.

Tutorial

Use this tutorial to learn how to use the Touch Panel Project Wizard to 

create a project and build, deploy, run, and debug a Touch Panel 

application.

The VI in this tutorial simulates a signal, computes the averaged auto power 

spectrum of the signal, and displays the result in a graph.

Creating the LabVIEW Project
Use LabVIEW projects to group together LabVIEW files and 

non-LabVIEW files, create build specifications for building a Touch Panel 

VI into a Touch Panel application, and deploy the application to a 

Touch Panel device. You must use a project to build a Touch Panel VI into 

a Touch Panel application.

Complete the following steps to create a LabVIEW project, add a 

Touch Panel target, and add an existing Touch Panel VI to the project using 

the Touch Panel Project Wizard.

1. Launch LabVIEW. In the Getting Started window, click New to open 

the New dialog box.
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2. Select Project»Project from Wizard»Touch Panel Project in the 

Create New list as shown in Figure 1.

Figure 1.  Launching the Touch Panel Project Wizard

3. Click the OK button to open the Touch Panel Project Wizard.
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4. Define the project information as shown in Figure 2.

a. Select New Touch Panel project, import VI from the Project 

type list to create the LabVIEW project using an existing VI.

Tip The blank VI project type creates a project with a new Touch Panel template VI rather 

than importing an existing VI.

b. Specify a project name and the location where you want to save 

the project and the VI in the Project location text box. The default 

location is C:\Document and Settings\<user name>\

My Documents\LabVIEW Data\. The default project name is 

Untitled project.lvproj. For this tutorial, enter 

Touch Panel Tutorial in the Project location text box.

c. Click the Browse button next to the VI path text box and navigate 

to labview\examples\TouchPanel\tutorial\Touch 

Panel Tutorial.vi to select the VI to import. Click the OK 

button to add the Touch Panel Tutorial VI to the project you are 

creating.

Figure 2.  Defining the Project Information

5. Click the Next button.
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6. Select the Touch Panel device you are using from the Device type 

drop-down list as shown in Figure 3.

Figure 3.  Selecting the Touch Panel Device Type

7. Click the Next button.

8. The System preview page, shown in Figure 4, shows a preview of the 

project the wizard creates when you click the Finish button. Notice the 

checkmark in the Create a build specification checkbox. This 

checkmark indicates you want to create a build specification 

immediately after you create the project. Refer to the Creating the 

Touch Panel Build Specification section for more information about 

creating build specifications.
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Figure 4.  Previewing the Project

9. Click the Finish button. Because the Create a build specification 

checkbox contains a checkmark as shown in Figure 4, the Touch 

Panel Build Specification Properties dialog box opens when you 

click the Finish button.

Creating the Touch Panel Build Specification
Build specifications contain the build settings and code generation options 

to use when you build a Touch Panel VI into a Touch Panel application. 

You can create the build specification when you create the project or wait 

until you are ready to build the Touch Panel VI into a Touch Panel 

application.

You must create a build specification before you can build a Touch Panel 

VI into a Touch Panel application.

Note This tutorial creates the build specification through the Touch Panel Project Wizard. 

You also can create a build specification at any time by right-clicking the Touch Panel 

target in the Project Explorer window and selecting New»Application (EXE) from the 

shortcut menu.
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Complete the following steps to create a Touch Panel build specification. 

1. Define the settings for the Touch Panel application as shown in 

Figure 5.

a. Enter a name for the build specification in the Build specification 

name text box. This is the name that appears under Build 

Specifications in the Project Explorer window. 

b. (Optional) By default, the name of the Touch Panel application is 

the same as the top-level Touch Panel VI. If you do not want to use 

the top-level Touch Panel VI name for the Touch Panel application 

name, remove the checkmark from the Same as top-level VI 

checkbox and enter a name in the Target filename text box.

c. Browse to and select the destination directory for the Touch Panel 

application on the host computer, which is where LabVIEW saves 

the .exe, in the Destination directory text box.

d. Enter the destination directory for the Touch Panel application on 

the Touch Panel target in the Remote path for target application 

text box.

Figure 5.  Defining the Touch Panel Application Information
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Note Although it is common to use the same name for the Touch Panel VI, application, 

and build specification, you are not required to do so.

2. Click the Help button to open the LabVIEW Help and read a 

description of each build setting.

3. Select the Device Information category to view which target and 

processor this build specification applies to.

4. Select the Source Files category to select the source files to include 

when you build the Touch Panel VI into a Touch Panel application. 

When you use the Touch Panel Project Wizard to create a build 

specification, LabVIEW automatically uses the VI you import as the 

top-level VI. When you create build specifications outside of the 

wizard, you must manually select the Touch Panel Tutorial VI and 

click the blue arrow button, shown at left, to move the VI to the 

Top-level VI text box as shown in Figure 6. Touch Panel VIs can have 

only one top-level VI.

Figure 6.  Selecting the Source Files

Note The Machine Alias category is not used in this tutorial. You use the Machine Alias 

category to overwrite the default IP address of a shared variable host target so you can 
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move the shared variable to a different host without rebuilding the application. Refer to the 

Using Shared Variables in PDA and Touch Panel VIs topic in the LabVIEW Help for more 

information about using shared variables.

5. Select the Generated Files category to view the filenames and path to 

the files the Touch Panel Module will generate when you build the 

Touch Panel VI into a Touch Panel application.

6. Click the OK button. The build specification you just created appears 

in the Project Explorer window under the Touch Panel target as 

shown in Figure 7.

Figure 7.  Project Explorer Window

7. Click File»Save Project in the Project Explorer window to save the 

project. Build specifications are saved with the project.

Building the Touch Panel VI into a Touch Panel Application
and Deploying

After you develop the Touch Panel VI on the host computer, you build the 

VI into an executable Touch Panel application that you can run on a 

Touch Panel target. Pick one of the options in the Using the Shortcut Menu 

section or the Using the Run Button section to build, run, and deploy a 

Touch Panel application.

Using the Shortcut Menu
Right-click the build specification in the Project Explorer window and 

select one of the following from the shortcut menu:

• Deploy—Builds the Touch Panel VI into a Touch Panel application, 

if necessary, and deploys the application to the Touch Panel target. 

This option does not automatically run the Touch Panel application.
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• Run—Builds the Touch Panel VI into a Touch Panel application, 

if necessary; deploys the application to the Touch Panel target, if 

necessary; and automatically runs the Touch Panel application.

• Build—Builds the Touch Panel VI into a Touch Panel application. 

This option does not deploy or automatically run the Touch Panel 

application.

Using the Run Button
The behavior of the Run button differs from LabVIEW for Windows:

• If you want to build, run, and deploy—Click the Run button in a 

Touch Panel VI to build the Touch Panel VI into a Touch Panel 

application, deploy the Touch Panel application to the Touch Panel 

target, and run the Touch Panel application on the Touch Panel target. 

LabVIEW prompts you to create a build specification if you do not 

have an existing build specification for the Touch Panel VI. If you have 

multiple build specifications, LabVIEW uses the default build 

specification, which the Touch Panel Module indicates with a green 

square around the Touch Panel build specification glyph in the Project 

Explorer window.

• If you want to build without deploying or running—Press the 

<Ctrl> key while you click the Run button in a Touch Panel VI to build 

the Touch Panel VI into a Touch Panel application without deploying 

or running the Touch Panel application. LabVIEW prompts you to 

create a build specification if you do not have an existing build 

specification for the Touch Panel VI. If you have multiple build 

specifications, LabVIEW uses the default build specification, which 

the Touch Panel Module indicates with a green square around the 

Touch Panel build specification glyph in the Project Explorer 

window.

Closing the Touch Panel Application
Tap the Exit button in the Touch Panel application on the Touch Panel 

target to close the Touch Panel application.

Debugging the Touch Panel Application
You must create a build specification that enables debugging before you 

can debug a Touch Panel application. Enabling debugging generates extra 

debugging information and can significantly increase the size of the 

Touch Panel application.

When LabVIEW on the host computer connects to the Touch Panel target, 

the Touch Panel application runs on the Touch Panel target. The front panel 

is fully functional on the Touch Panel target. However, the front panel 



Getting Started with the LabVIEW Touch Panel Module 14 ni.com

controls have no effect on the Touch Panel application, and the indicators 

of the Touch Panel VI on the host computer do not reflect the execution of 

the Touch Panel application on the Touch Panel target.

The block diagram acts as a conduit between the Touch Panel application 

running on the Touch Panel target and the Touch Panel VI running on the 

host computer, where you can probe signals, set breakpoints, and step 

through code as you do in any other VI.

Tip You can modify an existing build specification by double-clicking the build 

specification in the Project Explorer window or right-clicking the build specification and 

selecting Properties from the shortcut menu. This tutorial creates a second build 

specification for debugging.

Creating a Debugging Build Specification
Complete the following steps to create a debugging build specification as 

shown in Figure 8.

1. Right-click Build Specifications under the Touch Panel target and 

select New»Application (EXE) from the shortcut menu to open the 

Touch Panel Build Specification Properties dialog box.

2. Enter (Debug) Touch Panel Tutorial in the Build specification 

name text box.

3. Remove the checkmark from the Same as top-level VI checkbox so 

you can change the Touch Panel application name.

4. Enter (Debug) Touch Panel Tutorial.exe in the Target 

filename text box.

5. Place a checkmark in the Enable debugging checkbox to generate 

debugging information when you build the Touch Panel VI into a 

Touch Panel target.
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Figure 8.  Creating the Debugging Build Application

6. Select the Source Files category to select the source files to include 

when you build the Touch Panel VI into a Touch Panel application. 

Select the Touch Panel Tutorial VI and click the button, shown at left, 

to move the VI to the Top-level VI text box.
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7. Click the OK button. The build specification you just created appears 

in the Project Explorer window as shown in Figure 9.

Figure 9.  Two Touch Panel Build Specifications in the Project Explorer Window

Adding a Probe to the Touch Panel VI
Probes display information about the data that passes through a wire. As 

you interact with the Touch Panel application on the Touch Panel target, 

you can see data passing through the wire in the Touch Panel VI on the host 

computer.

Complete the following steps to add a probe to the Touch Panel Tutorial VI.

1. Select Window»Show Block Diagram in the VI to open the block 

diagram if it is not visible.

The block diagram acts as a conduit between the Touch Panel 

application running on the Touch Panel target and the Touch Panel VI 

running on the host computer.

2. Change the event case in the Event structure to “Frequency”: Value 

Change.
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3. Right-click the wire flowing into the frequency input of the Sine 

Waveform VI and select Probe from the shortcut menu.

A floating Probe window appears after you create a probe. LabVIEW 

numbers the Probe windows automatically and displays the same 

number in a glyph on the wire you probe as shown in Figure 10.

Figure 10.  Adding a Probe to the Block Diagram

Deploying and Debugging a Touch Panel Application
You must use the debug build specification to deploy the Touch Panel VI, 

which contains debugging information, to the Touch Panel target before the 

probe in the Touch Panel VI on the host computer can update the values 

passing through the wire.

Complete the following steps to deploy and debug the Touch Panel 

application.

1. Right-click the build specification for the Touch Panel VI you want to 

build and deploy, which is (Debug) Touch Panel Tutorial in Figure 9, 

and select Debug from the shortcut menu. Save any VIs if prompted.

The Touch Panel Module builds the Touch Panel VI into a Touch Panel 

application, deploys the Touch Panel application to the Touch Panel 

target, and runs the Touch Panel application on the Touch Panel.

Tip You also can start a debugging session by clicking the Step Over or Step Into buttons 

or by clicking the Pause button and then clicking the Run button on the block diagram 

toolbar.

2. Move the Frequency slider in the Touch Panel application running on 

the Touch Panel target. The value in the Probe window on the block 
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diagram on the host computer updates as you move the slider in the 

Touch Panel application.

Note Any changes you make on the front panel of the Touch Panel VI on the host 

computer have no effect on the Touch Panel application running on the Touch Panel target.

3. Tap the Exit button in the Touch Panel application on the Touch Panel 

target to stop the Touch Panel application and end the debugging 

session.

Related Documentation

LabVIEW includes extensive online and print documentation for new and 

experienced LabVIEW users. The following documents contain 

information that you might find helpful as you use the Touch Panel 

Module:

• LabVIEW Help—Refer to the LabVIEW Help, available by selecting 

Help»Search the LabVIEW Help in LabVIEW, for information 

about LabVIEW programming concepts, step-by-step instructions for 

using LabVIEW, and reference information about LabVIEW VIs, 

functions, palettes, menus, and tools. Refer to the Touch Panel 

Module book on the Contents tab of the LabVIEW Help for 

information specific to the Touch Panel Module and Touch Panel 

applications. LabVIEW Help uses (TPC) in the index to indicate 

Touch Panel-specific topics.

• Touch Panel Module Readme—Refer to the Touch Panel Module 

Readme file, available by selecting Start»All Programs»

National Instruments»LabVIEW 8.2»Readme and opening 

readme_TPC.html, for known issues with version 8.2.

• LabVIEW PDFs—In addition to this document, the Getting Started 

with LabVIEW manual, LabVIEW Quick Reference Card, LabVIEW 

Fundamentals manual, LabVIEW Release Notes, and LabVIEW 

Upgrade Notes are available as PDFs by selecting Start»

All Programs»National Instruments»LabVIEW 8.2»

LabVIEW Manuals.

Note You must have Adobe Reader with Search and Accessibility 5.0.5 or later installed 

to view the PDFs. You must have Adobe Reader with Search and Accessibility 6.x or later 

installed to search PDF versions of these manuals. Refer to the Adobe Systems 

Incorporated Web site at www.adobe.com to download Adobe Reader. Refer to the 

National Instruments Product Manuals Library at ni.com/manuals for updated 

documentation resources.

• Documentation for the Touch Panel target you use.
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Where to Go for Support

The National Instruments Web site is your complete resource for technical 

support. At ni.com/support you have access to everything from 

troubleshooting and application development self-help resources to email 

and phone assistance from NI Application Engineers.

National Instruments corporate headquarters is located at 

11500 North Mopac Expressway, Austin, Texas, 78759-3504. 

National Instruments also has offices located around the world to help 

address your support needs. For telephone support in the United States, 

create your service request at ni.com/support and follow the calling 

instructions or dial 512 795 8248. For telephone support outside the United 

States, contact your local branch office: 

Australia 1800 300 800, Austria 43 0 662 45 79 90 0, 

Belgium 32 0 2 757 00 20, Brazil 55 11 3262 3599, 

Canada 800 433 3488, China 86 21 6555 7838, 

Czech Republic 420 224 235 774, Denmark 45 45 76 26 00, 

Finland 385 0 9 725 725 11, France 33 0 1 48 14 24 24, 

Germany 49 0 89 741 31 30, India 91 80 41190000, 

Israel 972 0 3 6393737, Italy 39 02 413091, Japan 81 3 5472 2970, 

Korea 82 02 3451 3400, Lebanon 961 0 1 33 28 28, 

Malaysia 1800 887710, Mexico 01 800 010 0793, 

Netherlands 31 0 348 433 466, New Zealand 0800 553 322, 

Norway 47 0 66 90 76 60, Poland 48 22 3390150, 

Portugal 351 210 311 210, Russia 7 095 783 68 51, 

Singapore 1800 226 5886, Slovenia 386 3 425 4200, 

South Africa 27 0 11 805 8197, Spain 34 91 640 0085, 

Sweden 46 0 8 587 895 00, Switzerland 41 56 200 51 51, 

Taiwan 886 02 2377 2222, Thailand 662 278 6777, 

United Kingdom 44 0 1635 523545
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