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Getting Started with the LabVIEW ™ Touch Panel
Module

The LabVIEW Touch Panel Module extends the LabVIEW graphical development environment to
Touch Panel devices so you can create human-machine interface (HMI) applications for Touch Panel
devices running Windows CE or Windows Embedded Standard. You can create custom touch panel
displays to communicate with National Instruments embedded real-time platforms, such as Compact
FieldPoint, CompactRIO, and Compact Vision System.

This manual contains installation instructions for additional tools you might need to use with the Touch
Panel Module and a tutorial that shows you how to create a LabVIEW project and build, run, deploy,
and debug a Touch Panel application. Refer to the LabVIEW Touch Panel Module Readme, available
by opening readme TouchPanel.html on the installation media, for system requirements and
instructions about installing the Touch Panel Module.
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Supported Touch Panel Targets

The Touch Panel Module supports the following targets:

Target Processor Use

NI TPC-2006 ARM Use with NI TPC-2006 hardware
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Target Processor Use
NI TPC-2012 x86 Use with NI TPC-2012 hardware
NI TPC-2106/NI TPC-2106T ARM Use with NI TPC-2106 hardware or
NI TPC-2106T hardware
NI TPC-2512 x86 Use with NI TPC-2512 hardware
NI TPC-2515 x86 Use with NI TPC-2515 hardware
NI TPC-2215 x86 Use with NI TPC-2215 hardware
NI TPC-2212 x86 Use with NI TPC-2212 hardware
NI TPC-2206 x86 Use with NI TPC-2206 hardware
Touch Panel Windows CE 4.2 ARM or x86 Use with third-party touch panel
Device computers running Windows CE 4.2
Touch Panel Windows CE 5.0 ARM or x86 Use with third-party touch panel
Device computers running Windows CE 5.0
Windows Embedded Standard x86 Use with third-party touch panel
Device computers running Windows
Embedded Standard

5
5

Note If you use the x86 Touch Panel Windows CE 4.2 Device Touch Panel target, you must
manually download and install the eMbedded Visual Tools and Pocket PC 2003 SDK. Refer
to the KnowledgeBase for information about how to download and install these tools.

Note If you use the Windows Embedded Standard Device Touch Panel target, the device
must include an .msi engine in order to install the LabVIEW Run-Time Engine. The LabVIEW
Run-Time Engine is required to run Touch Panel applications. You also must install the NI
TPC Service on the device to deploy, run, and debug Touch Panel applications. Install the NI
TPC Service on the target from the NI TP Service\NITPCService.msi, which is located
in the same directory as the LabVIEW installer setup. exe file.

Installing Additional Tools

After installing the Touch Panel Module, you might need to install additional tools on the target depending
on the functionality you need.

NI-DAQmx Base

You can download the latest version of NI-DAQmx Base for use with Touch Panel devices from the
National Instruments Web site. After you complete the NI-DAQmx Base installation, you must copy

the driver files to the device.

Complete the following steps to install NI-DAQmx Base on the Touch Panel device.

1. Select StartyPrograms»National Instruments»NI-DAQmx Base» Utilities.

2. Launch the Driver Installation utility that corresponds to the Touch Panel device.

3. Check the device screen to see if any additional steps are requested, such as replacing an older

driver.

Getting Started with the LabVIEW Touch Panel
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Refer to the NI-DAQmx Base Readme and the NI-DAQmx Base 3.x Getting Started Guide for more
information about NI-DAQmx Base.

NI TPC Service Support

The NI TPC Service is an Ethernet-based service that you can use to deploy, run, and debug Touch Panel
applications. Use the NI TPC Service instead of ActiveSync if you are using Ethernet and need to deploy
a Touch Panel application to multiple Touch Panel targets. If you are using third-party devices or your
NI Touch Panel device does not have the NI TPC Service installed, you must install the NI TPC Service
on the device before you can use the NI TPC Service. Most NI Touch Panel devices include the NI TPC
Service by default.

Windows CE Targets

Complete the following steps to install support for the NI TPC Service on a Touch Panel target.

1. Depending on which type of target you are using, use FTP or an external storage device to copy
NITPCService.CAB from the labview\PDA\Utilities\NITPCService\ARM directory or
labview\PDA\Utilities\NITPCService\x86 directory to any location on the Touch Panel
device.

2. Runthe .caB file on the Touch Panel device to install the NI TPC Service.

3. For NI TPC devices, use the default installation location. Tap the <Enter> key to accept the default
installation location. For third-party devices, install the service in a non-volatile directory on the
device.

Third-Party Windows Embedded Standard Targets

You must install the LabVIEW Run-Time Engine on the Touch Panel target before you can install the
NI TPC Service. An installer for the LabVIEW Run-Time Engine is located on the LabVIEW DVD or
CD. Refer to the National Instruments Web site to download the latest version and other versions of the
LabVIEW Run-Time Engine.

After you install the LabVIEW Run-Time Engine on the Touch Panel target, install the NI TPC Service
fromNI TP Service\NITPCService.msi,whichislocated in the same directory as the setup.exe
you used to install the Touch Panel Module.

Shared Variable Support (Windows CE)

If you are using third-party devices or your NI Touch Panel device does not have shared variable support,
you must install the latest version of shared variable support on the device before you can use front panel
data binding and Shared Variable nodes in Touch Panel applications.

@ Note Most NI Touch Panel devices include the latest version of shared variable support, so
you do not need to complete the following steps. If you have an NI TPC-2006 device and you
downloaded the improved display driver from the National Instruments KnowledgeBase at
ni.com, you also do not need to complete the following steps.

@ Note Shared variables are not supported on Windows CE 4.x x86 Touch Panel targets.
Shared variables are supported on Windows CE 5.0 and later x86 targets.

Using ActiveSync/FTP

Complete the following steps to install or uninstall support for shared variables on a Touch Panel target
using ActiveSync/FTP.
1. Connect the device to the host computer using ActiveSync/FTP.

© National Instruments Corporation 3 Getting Started with the LabVIEW Touch Panel
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2. Navigate to and run labview\PDA\Utilities\Variables\ARM\Setup.exe Or
labview\PDA\Utilities\Variables\x86\Setup.exe, depending on which type of target
you are using.

3. For NI TPC devices, use the default installation location. For third-party devices, install the service
in a non-volatile directory on the device.

Using the NI TPC Service
Complete the following steps to install or uninstall support for shared variables on a Touch Panel target
using the NI TPC Service.

1. In LabVIEW, right-click the Touch Panel target in the Project Explorer window and select
Install»Support for Shared Variables (ARM) from the shortcut menu.

2. For NI TPC devices, use the default installation location. For third-party devices, install the service
in a non-volatile directory on the device.

PNG Image Support (Windows CE)

If you are using third-party devices or your NI Touch Panel device does not support PNG images, you
must install support for PNG images on the device if the VI contains PNG images in the user interface.

@ Note Most NI Touch Panel devices include support for PNG images, so you do not need to
complete the following steps. If you have an NI TPC-2006 device and you downloaded the
improved display driver from the National Instruments KnowledgeBase at ni . com, you also
do not need to complete the following steps.

Using ActiveSync/FTP

Complete the following steps to install or uninstall support for PNG images on a Touch Panel device

using ActiveSync/FTP.

1. Connect the device to the host computer using ActiveSync/FTP.

2. Navigate to and run labview\PDA\Utilities\LVPNG\ARM\Setup.exe Or
labview\PDA\Utilities\LVPNG\x86\Setup.exe,depending on which type of target you are
using.

3. For NI TPC devices, use the default installation location. For third-party devices, install the service
in a non-volatile directory on the device.

@ Tip  You also can right-click the target in the Project Explorer window in LabVIEW and
= select Install»Support for PNG Images (ARM) from the shortcut menu.

Using the NI TPC Service

Complete the following steps to install or uninstall support for PNG images on a Touch Panel target

using the NI TPC Service.

1. In LabVIEW, right-click the Touch Panel target in the Project Explorer window and select
Install»Support for PNG Images (ARM) from the shortcut menu.

2. For NITPC devices, use the default installation location. For third-party devices, install the service
in a non-volatile directory on the device.

NI-VISA Support (Windows CE)

You must install NI-VISA on the target to use VISA in Touch Panel applications. If you did not install
NI-VISA when you installed the Touch Panel Module, select Start»All Programs»National

Getting Started with the LabVIEW Touch Panel 4 ni.com
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Instruments» VISA and select Windows CE for ARM Driver Installation or Windows CE for x86
Driver Installation, depending on which type of target you are using.

Tip You also can right-click the target in the Project Explorer window in LabVIEW and
= select Install»Support for NI-VISA (ARM) from the shortcut menu.

x86 Target Support for Third Parties (Windows CE)

The Touch Panel Module installs support for ARM Touch Panel targets and Windows CE 5.0 x86 Touch
Panel targets. If you need support for x86 Touch Panel targets running Windows CE 4.2, install the
following Microsoft eMbedded Visual Tools:

. Microsoft eMbedded Visual C++ 4.0
. Microsoft eMbedded Visual C++ SP 4 or later
. SDK for Windows Mobile 2003-based Pocket PCs

Refer to the National Instruments KnowledgeBase at ni . com/info and enter the Info Code tpcevc
for the most recent information about downloading and installing the Microsoft eMbedded Visual Tools.

Windows CE Tutorial

Use this tutorial to learn how to configure a Touch Panel Windows CE device to use the NI TPC Service;
how to use the Touch Panel Project Wizard to create a project; and how to build, deploy, run, and debug
a Touch Panel application.

The VI in this tutorial simulates setting a temperature, displaying the current temperature in a graph and
on a thermometer, and indicating if the temperature is not in range.

Configuring the Windows CE Device to Use the NI TPC Service

@ Note If you want to use ActiveSync instead of the NI TPC Service, you must use a USB or
serial connection to connect the Touch Panel device to the host computer. If you use a serial
cable, connection time is longer.

Complete the following steps to configure the Touch Panel device to use the NI TPC Service.

1. Ensure the host and target are on the same subnet.

2. Enable FTP on the Touch Panel device. Refer to the National Instruments Web site at ni . com/info
and enter the Info Code ex6pwqg for the most recent information about configuring NI TPC devices
to use FTP. For third-party devices, refer to your device documentation.

3. Install the NI TPC Service on the Touch Panel target. Refer to the NI TPC Service Support section
for more information about installing the NI TPC Service on Touch Panel targets.

4.  Use the NI TPC Service Manager to configure the service to run on the Touch Panel target.

a.  Select Start»All Programs»National Instruments»NI TPC Service»NI TPC Service
Manager to launch the NI TPC Service Manager. The manager checks the status of the NI
TPC Service and displays the status information.

b.  Tap the Start button to start the NI TPC Service if the NI TPC Service is not running.

Creating the LabVIEW Project

Use LabVIEW projects to group together LabVIEW files and non-LabVIEW files, create build
specifications for building a Touch Panel VI into an application, and deploy the application to the target.
You must use a project to build a Touch Panel VI into an application.

© National Instruments Corporation 5 Getting Started with the LabVIEW Touch Panel
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Using the Touch Panel Project Wizard, complete the following steps to create a LabVIEW project, add
the target, and add an existing VI to the project.
1. Launch LabVIEW. In the Getting Started window, select Touch Panel Project from the Targets
pull-down menu. Click the Go button to launch the Touch Panel Project Wizard.
2. Define the project information as shown in Figure 1.
a.  Select New Touch Panel project, import VI from the Project type pull-down menu to create
the LabVIEW project using an existing VI.

@ Tip The blank VI project type creates a project with a new Touch Panel template
=/ VI rather than importing an existing VI.

b.  Specify a project name and the location where you want to save the project and the VI in the
Project location text box. Save the project to a location other than the default location so you
do not overwrite the shipping example with your changes. The default project name is
Untitled project.lvproj. For this tutorial, name the project Touch Panel
Tutorial.lvproj in the Project location text box.

c.  Click the Browse button next to the VI path text box and navigate to
labview\examples\TouchPanel\tutorial\Touch Panel Tutorial.vi toselectthe
VI to import. Click the OK button to add the VI to the project you are creating.

{3 Create New Touch Panel Project @

Define project information

Project type
MNew Touch Panel project, import VI El

Select this option to create a Touch Panel project and impaort a
previously created VI,

Project location

C:'\Program Files (x86)\Mational Instruments\LabVIEW
2011\examples\TouchPanel\tutorial{Touch Panel
Tutorial. lvproj

VI path

C:'\Proagram Files (x8&)\Mational Instruments\LabVIEW
2011\examples\TouchPanel\tutorial{Touch Panel
Tutorial. vi

< Back Mext » Finish Cancel l [ Help

Figure 1. Defining the Project Information
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3. Click the Next button.

4.  Select the Touch Panel device you are using from the Device type pull-down menu, as shown in
Figure 2.

13 Create New Touch Panel Project @

select device type

Device type
Touch Panel Windows CE 4.2 Device El

= Back ” Mext = Finish Cancel H Help

Figure 2. Selecting the Target

5. Click the Next button.
6. Configure connection information for the device as shown in Figure 3.

a. Select NI TPC Service (TCP/IP) from the Connection pull-down menu if you configured
the device to use the NI TPC Service.

b. Enter the IP address for the device in the Touch Panel device IP address text box.

© National Instruments Corporation 7 Getting Started with the LabVIEW Touch Panel
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{3 Create New Touch Panel Project \EI

Configure device

Connection
NI TPC Service (TCP/IP) (=]

Touch Panel device IP address

000.0.0.0

You can change the Touch Panel device connection and IP
address at any time in the Target Properties dialog box.

Use the NI TPC Service Manager to find the [P address of the
device, Select Start=Programs=Mational Instruments=MNI TPC
Service=MI TPC Service Manager on the device to launch the NI
TPC Service Manager.

< Back “ Mext » Finish Cancel ” Help

Figure 3. Configuring the Device

7.  Click the Next button.

8.  Click the Finish button. Because the Create a build specification checkbox contains a checkmark,
as shown in Figure 4, the Touch Panel Build Specification Properties dialog box opens. Refer

to the Creating the Build Specification section for more information about creating a build
specification.
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13 Create New Touch Panel Project @

System preview

El-m Touch Panel Windows CE 4.2 Device
I!E» Touch Panel Tutorial. vi
-'o0' Dependendies
-, Build Spedifications

Create a build spedfication

Next » Finish || Cancel || Help

Figure 4. Previewing the Project

Creating the Build Specification

Build specifications contain the build settings and code generation options to use when you build a
Touch Panel VI into an application. You can create the build specification when you create a project or
wait until you are ready to build the application. You must create a build specification before you can
build a Touch Panel VI into an application.

You can have multiple build specifications for the same target. For example, you might want one build
specification that generates debugging information and another build specification that does not generate
this extra information.

@ Note This tutorial creates the build specification through the Touch Panel Project Wizard.
You also can create a build specification at any time by right-clicking Build Specifications
under the target in the Project Explorer window and selecting New»Touch Panel Application
(EXE) from the shortcut menu.

Complete the following steps to create a Touch Panel build specification.
1. Define the settings for the Touch Panel application, as shown in Figure 5.
a. Enter Touch Panel Tutorial in the Build specification name text box. This is the name
that appears under Build Specifications in the Project Explorer window.

© National Instruments Corporation 9 Getting Started with the LabVIEW Touch Panel
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b. (Optional) By default, the name of the application is the same as the top-level VL. If you do
not want to use the top-level VI name for the application name, remove the checkmark from
the Same as top-level VI checkbox and enter a name in the Target filename text box.

c. Browse to and select the destination directory for the application on the host computer, which
is where LabVIEW saves the . exe, in the Destination directory text box.

d.  Enter the destination directory for the application on the target in the Remote path for target
application text box.

{3 Touch Panel Tutorial Touch Panel Build Specification Properties 3

ioi S Application Information
IC30on ormanon

Device Information

Build specification name

Source Files

Source File Settings Touch Panel Tutorial
Machine Aliases

Generated Files Target filename

Touch Panel Tutorial exe Same as topevel VI

Destination directory

C:'Program Files (x86) \Mational Instruments\LabWIEW 2011\examplesiTouchPanel}
builds{Touch Panel Tutorial{Touch Panel Tutorial

Remote path for target application
My Documents

[ Generate serial only [] Expression folding
[] Enable debugging

Front panel scale factor

2
Screen depth
8 [+

[ 0K H Cancel H Help

Figure 5. Defining the Application Information

@ Note Although it is common to use the same name for the VI, application, and
build specification, you are not required to do so.

2. (Optional) Click the Help button to open the LabVIEW Help and read a description of each build
setting.

3. Select the Device Information category to view which target and processor this build specification
applies to.

4. Select the Source Files category to select the source files to include when you build the VI into an
application. When you use the Touch Panel Project Wizard to create a build specification, LabVIEW
automatically uses the VI you import as the top-level VI. When you create build specifications
outside of the wizard, you must manually select the top-level VI and click the blue arrow button

Getting Started with the LabVIEW Touch Panel 10 ni.com
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to move the VI to the Top-level VI text box, as shown in Figure 6. Touch Panel applications can
have only one top-level VL.

43 Touch Panel Tutorial Touch Panel Build Specification Properties 3
Category I Source Files
Application Information
Device Information ——
Source File Settings =) Touch Panel Windows CE 4.2 Device Top-evel VI —
Machine Aliases Eg | Eg Touch Panel Tutorial. vi |
Generated Files
Additional files (*.c, *.cpp, ®.lib, *.obj) -
4 2
Always induded (*.vi) -
< | 1] | ¥ Ll ¢
[ oK ] [ Cancel ] [ Help

Figure 6. Selecting the Source Files

@ Note The Source File Settings and Machine Aliases categories are not used in this
tutorial. You use the Source File Settings page to view and set VI-level code generation
options. You use the Machine Aliases page to overwrite the default IP address of a target
hosting shared variables so you can move the shared variables to a different host without
rebuilding the application. Refer to the Using Shared Variables (Touch Panel Module)
topic in the LabVIEW Help for more information about using shared variables.

5. Select the Generated Files category to view the filenames and paths to the files the Touch Panel
Module generates when you build the VI into an application.

6.  Click the OK button. The build specification you just created appears in the Project Explorer
window under the Touch Panel target, as shown in Figure 7.

© National Instruments Corporation 1 Getting Started with the LabVIEW Touch Panel
Module



i

i3 Project Explorer - Touch Panel Tutonal lvproj * EIIEI

Eile Edit View Project Operate Tools Window Help
EECIE IELY=A

Items | Files
- k.. Project: Touch Panel Tutorial.vproj

E} E M}rCnmputer

':q Dependencies

* Build Specifications

EI m Tl:uuch Panel Windows CE 4.2 Device
: 'sﬂ. Touch Panel Tutorial.vi

_':'qT' Dependencies

= +% Build Specifications

W Touch Panel Tuterial

Figure 7. Project Explorer Window

7. Select File»Save Project in the Project Explorer window to save the project. LabVIEW saves
any build specifications with the project.
8. Ifyou configured the Touch Panel device to use the NI TPC Service, ensure that the NI TPC Service
is running on the device.
a. Right-click the Touch Panel target in the Project Explorer window and select Properties
from the shortcut menu to display the Touch Panel Target Properties dialog box.
b.  On the General page, click the Test button to confirm that the NI TPC Service is running on
the target.

Building the VI into an Application and Deploying
After you develop the VI on the host computer, you build the VI into an executable application that you
can run on a target. Select one of the options in the Using the Shortcut Menu section or the Using the
Run Button section of this manual to build, deploy, and run the application.

Getting Started with the LabVIEW Touch Panel 12 ni.com
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Using the Shortcut Menu

Right-click the build specification in the Project Explorer window and select one of the following

options from the shortcut menu:

*  Deploy—Builds the VI into an application, if necessary, and deploys the application to the target.
This option does not run the application automatically.

*  Run—Builds the VI into an application, if necessary; deploys the application to the target; and
runs the application automatically.

*  Build—Builds the VI into an application. This option does not deploy or run the application
automatically.

@ Note An Application Builder Information dialog box may appear when you deploy, run,
build or debug the application. By default, the Application Builder configures new build

specifications to include compiler optimizations that optimize the run-time performance of
your build application. However, if the target for your build specification does not support
SSE2 instructions, you must remove the checkmark from the Enable SSE2 optimization
checkbox on the Advanced page of the Properties dialog box for the relevant build
specification. For more information about enabling and disabling SSE2 optimizations, refer
to the Verifying That Target Hardware Supports SSE2 Instructions topic in the LabVIEW
Help.

Using the Run Button

When you run a VI under the Touch Panel target in the Project Explorer window, the Run button

behaves differently from when you run a VI under My Computer in the Project Explorer window:

«  If you want to build, deploy, and run—Click the Run button in a VI to build the VI into an
application, deploy the application to the target, and run the application on the target.

+  Ifyou want to build without deploying or running—Press the <Ctrl> key while you click the
Run button in a VI to build the VI into an application without deploying or running the application.

@ Note LabVIEW prompts you to create a build specification if you do not have an existing
build specification for the VI. If you have multiple build specifications, LabVIEW prompts
you to select a build specification in the Select a Build Specification dialog box. Alternatively,
you can specify a default build specification by right-clicking a build specification in the
Project Explorer window and selecting Set as Default from the shortcut menu. LabVIEW
indicates the default build specification with a green square around the build specification
glyph in the Project Explorer window.

Closing the Application

Tap the Exit button in the application on the Touch Panel target to close the application.

Debugging the Application

You must create a build specification that enables debugging before you can debug a Touch Panel
application. Enabling debugging generates extra debugging information and can significantly increase
the size of the application.

When LabVIEW on the host computer connects to the Touch Panel target, the application runs on the
target. The front panel is fully functional on the target. However, the front panel controls have no effect
on the application, and the indicators in the VI on the host computer do not reflect the execution of the
application on the target.

© National Instruments Corporation 13 Getting Started with the LabVIEW Touch Panel
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The block diagram acts as a conduit between the application running on the target and the VI running
on the host computer, where you can probe signals, set breakpoints, and step through code as you do in
any other VI.

@ Tip  You can modify an existing build specification by double-clicking the build specification
€ in the Project Explorer window or right-clicking the build specification and selecting Properties
from the shortcut menu. This tutorial creates a second build specification for debugging.

Creating a Debugging Build Specification

Complete the following steps to create a debugging build specification.

1. Right-click Build Specifications under the Touch Panel target and select New»Touch Panel
Application (EXE) from the shortcut menu to open the Touch Panel Build Specification Properties
dialog box.

Enter (Debug) Touch Panel Tutorial inthe Build specification name text box.

3. Remove the checkmark from the Same as top-level VI checkbox so you can change the application
name.

Enter (Debug) Touch Panel Tutorial.exe inthe Target filename text box.

5. Place a checkmark in the Enable debugging checkbox to generate debugging information when
you build the VI into an application, as shown in Figure 8.

4 My Application Touch Panel Build Specification Properties E3
Categor Application Information
Application Information
Device Information Build Pt
Source Files ufld spedication name
Source File Settings (Debug) Touch Panel Tutorial
Machine Aliases
Generated Files Target flename
(Debug) Touch Panel Tutorial.exe [] same as topevel VI
Destination directory
C:'Program Files (x86) \Mational Instruments\LabWVIEW 2011\examplesiTouchPanell
builds\Touch Panel Tutorial\(Debug) Touch Panel Tutorial
Remote path for target application
My Documents
[ Generate serial only [] Empression folding
Enable debugging
Front panel scale factor
2
Screen depth
g [+
[ oK ] [ Cancel ] [ Help
Figure 8. Creating the Debugging Build Specification
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6. Select Source Files from the Category list and select Touch Panel Tutorial.vi in the Project Files
list. Click the blue right arrow button to move the VI from the Project Files list to the Top-level
VI text box.

7. Click the OK button. The build specification you just created appears in the Project Explorer
window, as shown in Figure 9.

o

i3 Project Explorer - Touch Panel Tutorial.hvproj * El@

Eile Edit View Project Operate Tools Window Help
Y= T dIELCYENSEY

Iterns | Files

= @;L Project: Touch Panel Tutorial.lvproj

=+ B My Computer

_'-!:T" Dependencies

: +% Build Specifications

= m Touch Panel Windows CE 4.2 Device
e [=] Touch Panel Tutorial.vi
_'5:,'_' Dependencies
= +% Build Specifications

. (©ebug) Touch anelTutoria

+m Touch Panel Tutarial

Figure 9. Two Build Specifications in the Project Explorer Window

Adding a Probe to the VI
Probes display information about the data that passes through a wire. As you interact with the application
on the target, you can see the data passing through the wire in the corresponding VI on the host computer.

Complete the following steps to add a probe to the Touch Panel Tutorial VI.
1. Select Window»Show Block Diagram in the VI to open the block diagram if it is not visible.

@ Tip Double-click the VI in the Project Explorer window to open the VI if the VI is not
= already open.
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2. Right-click the wire flowing from the Set Temperature control and select Probe from the shortcut
menu.

A floating Probe Watch Window appears when you create a probe. LabVIEW numbers the probes
automatically and displays the same number in a glyph on the wire you probe, as shown in Figure
10.

o

13 Probe Watch Window ===
@ Probe Display

Probe(s) Yalue Last Update
= Touch Panel Tutorial.vi B

| [1] Set Temperature | 45141E+0 | 4/11/2011 11:27:26 AM 45.1408

Current Temperature

FDEL

Set Temperature Current Temperature

[mein— 1} FOBL |

Temp Too High!

Temp Too Low!

Figure 10. Adding a Probe to the Block Diagram

Deploying and Debugging a Touch Panel Application

You must use the debugging build specification to deploy the application, which contains debugging
information, to the target before the probe in the VI on the host computer can update the values passing
through the wire.

Complete the following steps to deploy and debug the Touch Panel application.
1. Right-click the debugging build specification you want to build and deploy and select Debug from
the shortcut menu. Save any VIs if prompted.
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LabVIEW builds the VI into an application, deploys the application to the target, and runs the
application on the target.

Change the value of the Set Temperature knob in the application running on the target. The value
in the Probe Watch Window on the block diagram on the host computer updates as you change
the value of the knob in the application.

@ Note Any changes you make on the front panel of the VI on the host computer have

no effect on the application running on the target.

Tap the Exit button in the application on the target to stop the application and end the debugging
session.

Windows Embedded Standard Tutorial

Use this tutorial to learn how to configure a Touch Panel Windows Embedded Standard device to use
the NI TPC Service; how to use the Touch Panel Project Wizard to create a project; and how to build,
deploy, run, and debug a Touch Panel application.

The VI in this tutorial simulates setting a temperature, displaying the current temperature in a graph and
on a thermometer, and indicating if the temperature is not in range.

Creating the LabVIEW Project

Use LabVIEW projects to group together LabVIEW files and non-LabVIEW files, create build
specifications for building a Touch Panel VI into an application, and deploy the application to the target.
You must use a project to build a Touch Panel VI into an application.

Using the Touch Panel Project Wizard, complete the following steps to create a LabVIEW project, add
the target, and add an existing VI to the project.

1.

Launch LabVIEW. In the Getting Started window, select Touch Panel Project from the Targets

pull-down menu. Click the Go button to launch the Touch Panel Project Wizard.

Define the project information, as shown in Figure 11.

a.  Select New Touch Panel project, import VI from the Project type pull-down menu to create
the LabVIEW project using an existing VI.

@ Tip The blank VI project type creates a project with a new Touch Panel template
= VI rather than importing an existing VI.

b.  Specify a project name and the location where you want to save the project and the VI in the
Project location text box. Save the project to a location other than the default location so you
do not overwrite the shipping example with your changes. The default project name is
Untitled project.lvproj. For this tutorial, name the project Touch Panel
Tutorial.lvproj in the Project location text box.

c.  Click the Browse button next to the VI path text box and navigate to
labview\examples\TouchPanel\tutorial\Touch Panel Tutorial.vi toselectthe
VI to import. Click the OK button to add the VI to the project you are creating.
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{3 Create New Touch Panel Project

Define project information

Project type

MNew Touch Panel project, import VI El

Select this option to create a Touch Panel project and impart &
previously created VI,

Project location

C:'\Program Files (x86)\Mational Instruments\LabVIEW

2011\examples\TouchPanel\tutorial {Touch Panel
Tutorial. lvproj
VI path
C:\Program Files (x86)National Instruments\LabVIEW
2011\examples\TouchPanel\tutorial{Touch Panel
Tutorial. vi
< Back Mext » Finish Cancel l [ Help
Figure 11. Defining the Project Information
3. Click the Next button.
4.

Select NI TPC-2512 Device from the Device type pull-down menu, as shown in Figure 12
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13 Create New Touch Panel Project @

Select device type

Device type
MI TPC-2512 Device [+]

< Back ” Mext = Finish Cancel H Help

Figure 12. Selecting the Target

@ Note If you are using a third-party Windows Embedded Standard device, select
Windows Embedded Standard Device from the Device type pull-down menu instead.

5.  Click the Next button.

6. Configure connection information for the device. Enter the IP address for the device in the Touch
Panel device IP address text box, as shown in Figure 13.
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{3 Create New Touch Panel Project \EI

Configure device

annect

Touch Panel device IP address

000.0.0.0

You can change the Touch Panel device connection and IP
address at any time in the Target Properties dialog box.

< Back “ Mext » Finish Cancel ” Help

Figure 13. Configuring the Device

7.  Click the Next button.

8. The System preview page, shown in Figure 14, shows a preview of the project the wizard creates
when you click the Finish button. Notice the checkmark in the Create a build specification
checkbox. This checkmark indicates you want to create a build specification immediately after you
create the project. Refer to the Creating the Build Specification section for more information about
creating a build specification.
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13 Create New Touch Panel Project @

System preview

= NI TPC-2512 Device
I!E» Touch Panel Tutarial. vi
-'o0' Dependendies
-, Build Spedifications

Create a build spedfication

Next » Finish || Cancel || Help

Figure 14. Previewing the Project

9.  Click the Finish button.

Because the Create a build specification checkbox contains a checkmark as shown in Figure 14, the
Application Properties dialog box opens when you click the Finish button.

Creating the Build Specification

Build specifications contain the build settings and code generation options to use when you build a
Touch Panel VI into an application. You can create the build specification when you create a project or
wait until you are ready to build the application. You must create a build specification before you can
build a Touch Panel VI into an application.

You can have multiple build specifications for the same target. For example, you might want one build
specification that generates debugging information and another build specification that does not generate
this extra information.

@ Note This tutorial creates the build specification through the Touch Panel Project Wizard.
You also can create a build specification at any time by right-clicking Build Specifications
under the target in the Project Explorer window and selecting New»Touch Panel Application
(EXE) from the shortcut menu.
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Complete the following steps to create a Touch Panel build specification.
1. Define the settings for the Touch Panel application, as shown in Figure 15.
a.  Enter a name for the build specification in the Build specification name text box. This is the
name that appears under Build Specifications in the Project Explorer window.
b. Enter name for the application in the Target filename text box. For this tutorial, name the
application Touch Panel Tutorial.exe.

c. Browse to and select the destination directory for the Touch Panel application on the host
computer, which is where LabVIEW saves the . exe, in the Local destination directory text

box.

d.  Enter the destination directory for the Touch Panel application on the Touch Panel target in
the Target destination directory text box.

13 Touch Panel Tutorial Properties

Cateioﬁ

Source Files
Destinations

Source File Settings
Icon

Advanced

Additional Exclusions
Version Information
Windows Security
Shared Variable Deployment
Run-Time Languages
Pre/Post Build Actions
Preview

=
oo |

Build specification name
Touch Panel Tuterial

Target filename
Touch Panel Tutorial.exe

Lecal destination directory
Ch\Documents and Settings\user\builds\Touch Panel Tutorial

Target destination directory

chni

Build specification description

[ Buitd |[ ok |[ Cancel |[ Help

5

Figure 15. Defining the Application Information

Note Although it is common to use the same name for the Touch Panel VI,
application, and build specification, you are not required to do so.

2. (Optional) Click the Help button to open the LabVIEW Help and read a description of each build

setting.

3. Select the Source Files category to select the source files to include when you build the Touch
Panel VI into a Touch Panel application. When you use the Touch Panel Project Wizard to create
a build specification, LabVIEW automatically uses the VI you import as the startup VI. When you
create build specifications outside of the wizard, you must select the startup VI manually and click
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the blue arrow button to move the VI to the Startup VIs list box, as shown in Figure 16. You must
define at least one VI as the startup VI for the application.

43 Touch Panel Tutorial Properties @
Information
Project Files Startup VIs &
Destinations Bdﬁ -], Touch Panel Tutorial.vi
Source File Settings {:ﬂ»

Icon

Advanced

Additional Exclusions
Version Information
Windows Security =
Shared Variable Deployment
Run-Time Languages
Pre/Post Build Actions
Preview

Always Included -

[ Buid |[ ok |[ Cancel |[ Help

Figure 16. Selecting the Source Files

4. In this tutorial, you can use the default settings for the following categories:

*  Destinations—Specifies destination settings, adds destination directories for the application,
and indicates whether LabVIEW adds the files to a new project library.

*  Source File Settings—Specifies destinations and properties for individual files and folders
in the application.

»  Icon—Specifies the icon file to associate with the application.

*  Advanced—Configures advanced settings for the application.

*  Additional Exclusions—Configures settings to disconnect type definitions, removes unused
polymorphic VI instances, and removes unused members of project libraries to reduce the size
of the application.

*  Version Information—Specifies the version number and other application information.

*  Run-Time Languages—Sets the language preferences for the application.

5. Select the Preview category and click the Generate Preview button to view the filenames and
paths to the files the Touch Panel Module generates when you build the Touch Panel VI into a
Touch Panel application.

6. Click the OK button. The build specification you created appears in the Project Explorer window
under the Touch Panel target, as shown in Figure 17.
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Figure 17. Project Explorer Window

7. Select FilenSave Project in the Project Explorer window to save the project. LabVIEW saves
any build specifications with the project.
8. Ensure that the NI TPC Service is running on the device.
a. Right-click the Touch Panel target in the Project Explorer window and select Properties
from the shortcut menu to display the Touch Panel Target Properties dialog box.
b.  On the General page, click the Test button to confirm that the NI TPC Service is running on
the target.

Building the VI into an Application and Deploying
After you develop the VI on the host computer, you build the VI into an executable application that you
can run on a target. Select one of the options in the Using the Shortcut Menu section or the Using the
Run Button section of this manual to build, deploy, and run the application.
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Using the Shortcut Menu

Right-click the build specification in the Project Explorer window and select one of the following

options from the shortcut menu:

*  Deploy—Builds the VI into an application, if necessary, and deploys the application to the target.
This option does not run the application automatically.

*  Run—Builds the VI into an application, if necessary; deploys the application to the target; and
runs the application automatically.

*  Build—Builds the VI into an application. This option does not deploy or run the application
automatically.

@ Note An Application Builder Information dialog box may appear when you deploy, run,
build or debug the application. By default, the Application Builder configures new build

specifications to include compiler optimizations that optimize the run-time performance of
your build application. However, if the target for your build specification does not support
SSE2 instructions, you must remove the checkmark from the Enable SSE2 optimization
checkbox on the Advanced page of the Properties dialog box for the relevant build
specification. For more information about enabling and disabling SSE2 optimizations, refer
to the Verifying That Target Hardware Supports SSE2 Instructions topic in the LabVIEW
Help.

Using the Run Button

When you run a VI under the Touch Panel target in the Project Explorer window, the Run button

behaves differently from when you run a VI under My Computer in the Project Explorer window:

«  If you want to build, deploy, and run—Click the Run button in a VI to build the VI into an
application, deploy the application to the target, and run the application on the target.

+  Ifyou want to build without deploying or running—Press the <Ctrl> key while you click the
Run button in a VI to build the VI into an application without deploying or running the application.

@ Note LabVIEW prompts you to create a build specification if you do not have an existing
build specification for the VI. If you have multiple build specifications, LabVIEW prompts
you to select a build specification in the Select a Build Specification dialog box. Alternatively,
you can specify a default build specification by right-clicking a build specification in the
Project Explorer window and selecting Set as Default from the shortcut menu. LabVIEW
indicates the default build specification with a green square around the build specification
glyph in the Project Explorer window.

Debugging the Touch Panel Application

You must create a build specification that enables debugging before you can debug a Touch Panel
application.

When LabVIEW on the host computer connects to the Touch Panel target, the application runs on the
Touch Panel target. The front panel is fully functional on the Touch Panel target. The front panel controls
affect the Touch Panel application, and the indicators in the Touch Panel VI on the host computer reflect
the execution of the application on the Touch Panel target.

The block diagram acts as a conduit between the Touch Panel application running on the target and the
Touch Panel VI running on the host computer, where you can probe signals, set breakpoints, and step
through code as you do in any other VI.

Debugging Touch Panel applications for Windows Embedded Standard targets is similar to debugging
stand-alone applications that you create with the Application Builder. For more information about
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debugging stand-alone applications, refer to the Debugging Applications and Shared Libraries topic in
the LabVIEW Help.

@

=

Tip  You can modify an existing build specification by double-clicking the build specification
in the Project Explorer window or right-clicking the build specification and selecting Properties

from the shortcut menu. This tutorial creates a second build specification for debugging.

Creating a Debugging Build Specification
Complete the following steps to create a debugging build specification.

1. Right-click Build Specifications under the Touch Panel target and select New»Touch Panel
Application (EXE) from the shortcut menu to open the Application Properties dialog box.

Enter (Debug) Touch Panel Tutorial inthe Build specification name text box.

3.  Enter (Debug) Touch Panel Tutorial.exe inthe Target filename text box, as shown in

Figure 18.

ﬂ (Debug) Touch Panel Tutorial Properties

Cateioﬁ

Source Files
Destinations

Source File Settings
Icon

Advanced

Additional Exclusions
Version Information
Windows Security
Shared Variable Deployment
Run-Time Languages
Pre/Post Build Actions
Preview

=
=

Build specification name
(Debug) Touch Panel Tutorial

Target filename

(Debug) Touch Panel Tutorial.exe

Local destination directory
Ch\Documents and Settings\user\builds\Touch Panel Tutonal\(Debug) Touch Panel Tutorial

Target destination directory

chni

Build specification description

[ Bud |[ ok |[ Cancel |[ Help

Figure 18. Creating the Debugging Build Specification

4. Select Source Files from the Category list and select Touch Panel Tutorial.vi in the Project Files
list. Click the blue right arrow button to move the VI from the Project Files list to the Startup VIs

list box.

5. Select Advanced from the Category list.

6. Place a checkmark in the Enable debugging checkbox to generate debugging information when
you build the Touch Panel VI into an application.
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7. Click the OK button. The build specification you created appears in the Project Explorer window,
as shown in Figure 19.

o
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File Edit VYiew Project Operate Tools Window Help
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: +% Build Specifications
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Figure 19. Two Build Specifications in the Project Explorer Window

Adding a Probe to the Touch Panel VI

Probes display information about the data that passes through a wire. As you interact with the Touch
Panel application on the Touch Panel target, you can see the data passing through the wire in the Touch
Panel VI on the host computer.

Complete the following steps to add a probe to the Touch Panel Tutorial VI.
1. Select Window»Show Block Diagram in the VI to open the block diagram if it is not visible.

@ Tip Double-click the VI in the Project Explorer window to open the VI if the VI is not
= already open.

2. Right-click the wire flowing from the Set Temperature control and select Probe from the shortcut
menu.

A floating Probe Watch Window appears when you create a probe. LabVIEW numbers the probes
automatically and displays the same number in a glyph on the wire you probe, as shown in Figure
20.
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Figure 20. Adding a Probe to the Block Diagram

Deploying and Debugging a Touch Panel Application

You must use the debugging build specification to deploy the Touch Panel VI, which contains debugging
information, to the Touch Panel target before the probe in the Touch Panel VI on the host computer can
update the values passing through the wire.

Complete the following steps to deploy and debug the Touch Panel application.
1. Right-click the build specification for the VI you want to build and deploy and select Debug from
the shortcut menu. Save any Vs if prompted.

LabVIEW builds the VI into an application, deploys the application to the Touch Panel target, and
runs the application on the target.

2. Change the value of the Set Temperature knob in the Touch Panel application running on the
Touch Panel target. The value in the Probe Watch Window on the block diagram on the host
computer updates as you change the value of the knob in the Touch Panel application.

3. Tap the Exit button in the application on the Touch Panel target to stop the application and end the
debugging session.
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Related Documentation

LabVIEW includes documentation for new and experienced LabVIEW users. The following documents
contain information that you might find helpful as you use the Touch Panel Module:

5

LabVIEW Help—Refer to the LabVIEW Help, available by selecting HelppLabVIEW Help in
LabVIEW, for information about LabVIEW programming concepts, step-by-step instructions for
using LabVIEW, and reference information about LabVIEW VIs, functions, palettes, menus, and
tools. Refer to the Touch Panel Module book on the Contents tab of the LabVIEW Help for
information specific to the Touch Panel Module and Touch Panel applications. The LabVIEW Help
uses (TPC) in the index to indicate Touch Panel-specific topics.

LabVIEW Touch Panel Module Readme—Refer to the LabVIEW Touch Panel Module Readme,
available by selecting Start»All Programs»National Instruments»LabVIEW»Readme and
opening readme_TouchPanel.html, for last-minute information and known issues.

Touch Panel Module Examples—Use the Touch Panel Module examples to learn how to use certain
VIs and functions as well as a starting point for developing your own Touch Panel VIs and
applications. You can modify an example to fit an application, or you can copy and paste from one
or more examples into a VI that you create. Browse or search the example VIs with the NI Example
Finder by selecting Help»Find Examples.

NI-DAQmx Base 3.x Getting Started Guide

NI-DAQmx Base Readme

Documentation for your device.

LabVIEW PDFs—In addition to this document, the Getting Started with LabVIEW manual, LabVIEW
Quick Reference Card, LabVIEW Release Notes, and LabVIEW Upgrade Notes are available as
PDFs by selecting Start» All Programs»National Instruments» LabVIEW»LabVIEW Manuals.

Note You must have Adobe Reader installed to view the PDFs. Refer to the Adobe Systems
Incorporated Web site at www . adobe . com to download Adobe Reader. Refer to the National
Instruments Product Manuals Library at ni . com/manuals for updated documentation
resources.

© National Instruments Corporation 29 Getting Started with the LabVIEW Touch Panel

Module


http://www.ni.com/manuals
http://www.adobe.com/

LabVIEW, National Instruments, NI, ni.com, the National Instruments corporate logo, and the Eagle logo are
trademarks of National Instruments Corporation. Refer to the Trademark Information section at ni . com/trademarks
for other National Instruments trademarks. Other product and company names mentioned herein are trademarks
or trade names of their respective companies. For patents covering National Instruments products/technology,
refer to the appropriate location: Help»Patents in your software, the patents.txt file on your media, or the
National Instruments Patent Notice at ni.com/patents. Refer to the Export Compliance Information at
ni.com/legal/export-compliance for the National Instruments global trade compliance policy and how to
obtain relevant HTS codes, ECCNs, and other import/export data.

371940F-01
©2006-2011 National Instruments Corporation. All rights reserved.

Jun11



	Getting Started with the LabVIEW™ Touch Panel Module
	Contents
	Supported Touch Panel Targets
	Installing Additional Tools
	NI-DAQmx Base
	NI TPC Service Support
	Shared Variable Support (Windows CE)
	PNG Image Support (Windows CE)
	NI-VISA Support (Windows CE)
	x86 Target Support for Third Parties (Windows CE)

	Windows CE Tutorial
	Configuring the Windows CE Device to Use the NI TPC Service
	Creating the LabVIEW Project
	Creating the Build Specification
	Building the VI into an Application and Deploying
	Using the Shortcut Menu
	Using the Run Button

	Closing the Application
	Debugging the Application
	Creating a Debugging Build Specification
	Adding a Probe to the VI
	Deploying and Debugging a Touch Panel Application


	Windows Embedded Standard Tutorial
	Creating the LabVIEW Project
	Creating the Build Specification
	Building the VI into an Application and Deploying
	Using the Shortcut Menu
	Using the Run Button

	Debugging the Touch Panel Application
	Creating a Debugging Build Specification
	Adding a Probe to the Touch Panel VI
	Deploying and Debugging a Touch Panel Application


	Related Documentation


